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Foreword

You’re holding one of the most important InDesign books on the planet. That might sound audacious, but
your ability to set type well in InDesign is a critical part of whether your work will be successful. After all, if
you don’t understand the fundamentals of professional typography, and how to apply them using the tools in
InDesign, you’re doomed to creating “blah” design. And no one wants to make blah design.

The good news is that design — and especially the design of text, called typography — is something that
anyone can learn. It involves two steps: developing the feeling, and learning how to make type better. Having
“the eye” (the feeling for type) leads to misery if you don’t know how to handle the tools to change it. And
understanding the software is meaningless if you don’t know what you’re looking for.

Fortunately, I’m pleased to say that this book can help you do both. I’ve known Nigel French for over a
decade, and I can tell you that he is one of the top typography trainers in the world, specifically because he
understands — and can communicate — the “feeling” and the “how-to.”

In this new edition of Nigel’s book, he delves even deeper and stretches even further into making type
beautiful, for both print and interactive design. You’ll enjoy reading it and learning from it.

Adobe InDesign is the industry’s best tool for setting type in short and long documents. The more you know
about InDesign, the more fun it is to use it, especially when you have a good teacher like Nigel.

— David Blatner
     co-host, InDesignSecrets.com
     founder, InDesign Magazine and
          the InDesign Conference
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Introduction

Today we are all typographers. Everyone knows what a font is, and most people have an opinion about the
fonts they like and those they don’t. Typography is no longer an arcane trade plied by curmudgeonly men with
inky fingers, but rather a life skill. We make typographic decisions every day: the material we choose to read in
print and onscreen, the fonts we select for our correspondence, and the advertising we respond to, consciously
or subconsciously. The fonts themselves are readily available — from long-established foundries with
extensive catalogs and from boutique font houses with niche offerings, from subscription services like Typekit,
and the countless number freely available from Google Fonts and many other online sources.

This democratization of typography is empowering; anyone can participate. But to participate well it helps to
know a thing or two; with power comes responsibility. If you’re using InDesign, then you have at your
disposal the state-of-the-art software for creating typographic layouts of any length and complexity. It’s worth
bearing in mind that the concepts behind InDesign didn’t just arrive simultaneously with the program’s
launch in 1999. InDesign is part of a continuum of technological advances going back to the 15th century
with the invention of the printing press. The terminology and typographic conventions upon which InDesign
is built have evolved over generations. The typefaces on our font menus — even the funky postmodern ones
— are descendants of the letter shapes chiseled into the Trajan Column in Rome nearly 2000 years ago.

Designing with type is a subjective discipline, so it’s useful for you to know where I’m coming from and why
I’m advancing the opinions I am. I’d say that my type preferences are more “old school” than experimental, my
style more conventional than boundary pushing. I admire graphic designers who break the rules of type and
do it well; I groan when I see graphic designers breaking the rules and doing it badly. Unfortunately, too many
graphic designers who break the rules fall into the latter camp.

Computers let us get away with stuff. It’s all too easy for a half-hearted effort to look — at first glance —
polished. But on closer inspection, we see that it lacks sensitivity to the type. There’s scant attention to detail
and little-or-no appreciation of the cues and messages that the type is sending.

With every passing month, it seems that more and more people are using more type and using it more
creatively. But simultaneously, “type crime” are on the rise, and it feels like some of the foundations of
typography are being sidelined, lost, or forgotten. The most frequent complaint of design instructors is that
students lack sophistication in their use of type. Their layouts routinely feature flashy graphic explorations in
Photoshop and Illustrator, but the typography is too often given short shrift, thrown on the page as an
afterthought.

It’s an oft-repeated adage that good typography is “invisible,” meaning that, rather than drawing attention to
itself, typography should serve the words it represents. This perhaps makes typography sound like a thankless
task. Where’s the fame? The glory? There are few celebrity typographers, and those few walk the streets in
relative anonymity. Nonetheless, typography is a noble cause. If typefaces are the bricks and mortar of
communication, then we, the typographers, are the architects. A simple and understated building may pass
unnoticed by many, but everyone notices an ugly one. Likewise with typography: Good designs serve their
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purpose and may not elicit comment, but we can all spot bad typography, even though we may not be able to

say precisely why it’s bad. InDesign Type exists to demonstrate the rules and conventions of professional
typography, specifically as they relate to InDesign, so that we can avoid ugly and thoughtless type — which, I
believe, is a major step in the direction of creating beautiful type.

Who Should Read This Book?
This book is about working efficiently in InDesign — getting familiar with its conventions and nomenclature,
knowing its keyboard shortcuts (the important ones anyway), and taking advantage of its powerful global
formatting and automation features. But it’s not just a book about working with InDesign; it’s also a book
about typographic best practices. Although they continue to evolve, these practices were around long before
InDesign — and will be around long after InDesign is forgotten and we’re all using the new thing, whatever
the new thing may be.

InDesign Type is not a beginner’s guide to InDesign. Maybe you’ve been using InDesign since version 1.0 or
maybe you’re a novice user, but I’m assuming that you know your way around the basics of the program. Some
of the information is elementary and will be old news to seasoned users, but there’s also a deep exploration of
InDesign’s type-related features, a wealth of tips, tricks, and workarounds, and some good old-fashioned
hacks.

This book deals with English-language typography — not because it’s the most important, but because it’s
what I know. It’s primarily concerned with the typographic conventions of magazine and book publishing,
whether those books and magazines are intended to be read in print or onscreen. The techniques in this book
will help you create layouts to a professional standard by following certain typographic “rules.” To this end,
my approach is utilitarian rather than experimental. These rules are not intended to limit creativity, but rather
are intended as a starting point. Learn the rules. Then, if you choose, break them — but break them
consciously, knowing why you do so. Whatever you do, don’t ignore them.

Regarding some technical issues, I should mention that although this edition of InDesign Type was written
specifically for Adobe InDesign CC, most of the techniques in the book are applicable to earlier versions of
InDesign. Where there is a keyboard shortcut for a command, I indicate the Mac shortcut first, followed by
the Windows shortcut in parentheses. For example: Cmd+Option+W (Ctrl+Alt+W). My screenshots show a
light gray interface (Preferences > Interface) because screenshots in the light gray reproduce better in print
than those in the default, medium dark gray.

I hope you find InDesign Type a useful addition to your design bookshelf. I hope that, in some small way, by
reading this book you’ll be able to work faster and more decisively in InDesign and — most importantly —
that your InDesign documents will look better because your type looks better.

If you enjoy the book, you might also be interested in viewing my “InDesign Typography part 1 and part 2”
courses on LinkedInLearning.com or Lynda.com, which are structured in much the same way as the book and
use many of the same examples.

Please email me with any comments, corrections, or suggestions.

— Nigel French
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     nigel@nigelfrench.com
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Chapter 1

About Type

When it comes to type, we are wide-eyed kids in a candy store. Our font menus are expansive and
seductive, spanning centuries of typeface history and reflecting the glorious typographic contributions
of different cultures, art movements, mass transit systems, and gifted (and often eccentric)
individuals. However, with so many typefaces just a click away, it’s easy to feel more overwhelmed
than empowered by such a treasure trove.

If you’re like me, you’ve probably frittered away the best part of a day experimenting with this or that
enticingly named font chosen almost randomly from a cast of thousands, only to find yourself
dissatisfied with the results but not really knowing why. I hope that this book will help keep such days
to a minimum.

Before we get to the practical details of choosing type and working with it in InDesign, we should get
acquainted with type terminology and conventions. To set good type in InDesign, we should remind ourselves
that InDesign is just a tool, and — brilliant tool though it is — unless we understand our raw material, all the
power of InDesign won’t amount to much. To use InDesign effectively we must understand how type works
— and to understand how type works, we need to look at its history, how it is measured, how it is classified,
and what messages our typeface choices carry. And of course, we must be comfortable with InDesign’s
interface and logic. Specifically, we need to know where to find the type-related tools and preferences, how to
navigate documents smoothly, and how to set up an efficient type-oriented workflow.

“Typography is a hidden tool of manipulation within society.”
— Neville Brody

Whoa there, Tiger! I know you’re excited about working with InDesign, but don’t skip this first chapter. I
promise there are some gems of information — even if you’re a seasoned InDesign user.
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“Typefaces are to the written word what different dialects are to different –languages.”
— Steven Heller

Type Choices
When we choose a typeface, we aim to enhance the meaning of the text. Of course, we also have to meet the
expectations and match the tastes of our clients. Experienced typographers might say that they never typeset
anything they haven’t first read, and in a perfect world, we’d all read and thoroughly digest the text we are
given to work with as raw material. Depending on the length of these documents and the timeframe of the
project, that may or may not be possible, but we should at least have a solid understanding of the intended
message.

“Typography is what language looks like.”
— Ellen Lupton

Typefaces can be loaded — intentionally or otherwise — with symbolism and meaning. In Gary Hustwit’s
fantastic documentary film Helvetica (2007), influential graphic designer Paula Scher speaks of her negative
connotations of the world’s most ubiquitous font, Helvetica, calling it the “font of corporate America.” She
goes on, tongue firmly in cheek, to describe Helvetica as the font of the Vietnam War and the two Gulf Wars.
Elsewhere in the movie, some of the leading lights of the type and design world extol the beauty and
timelessness of Helvetica. Typefaces divide opinion.
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“We read best what we read most.”
— Zuzana Licko

Taking Helvetica and its equally ubiquitous clone Arial as cases in point, one can argue that their use screams
“generic.” We see them as the “default” font, the choice that does not involve any conscious choice at all.
System typefaces — those that come packaged with your computer’s operating system — may be tarred with
the same brush. There is a certain snobbery here. This has nothing to do with the inherent qualities of these
typefaces and everything to do with how common they are. Typefaces like Times and the current InDesign
default, Minion Pro, are considered by some to be the choice of civilians and hobbyists. Because they are
everywhere, they become part of the furniture and we cease to really see them. The best and worst thing that
can happen to a typeface is to be promoted to the default font. Once it becomes ubiquitous it says less, not
more.

Jessica Hische, type designer and “crazy cat lady.”

Professional designers, the logic goes, have more discerning tastes. It’s good to be aware of such trends, but
don’t let them tie you in knots or you might find yourself in a time-wasting pursuit for “something that’s like
Helvetica but not Helvetica,” when Helvetica itself is the best choice for the job.

Of course, it’s not just Helvetica that comes with cultural baggage. To cite an extreme example, Fette Fraktur
might now connote Nazism, even though similar Blackletter or Fraktur typefaces were used peaceably for
hundreds of years before the Nazis adopted them. Other typefaces, once fashionable, may be trapped in a
historical period — great if you want to evoke that era, but a potential faux pas if you don’t. And type nerds
love to point out inappropriate typeface usage in movies — check out the goofs pages on imdb.com if you
don’t believe me. Then there are certain typefaces that have been co-opted by an overexposed advertising
campaign and can’t help but be associated with that product; others — like an overplayed song on the radio —
may change from flavor of the month to fingernails-on-a-chalkboard irritation.
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“There are now about as many different varieties of letters as there are different kinds of fools.”
— Eric Gill

Often people speak of “good fonts” and “bad fonts.” Comic Sans became Public Enemy Number One — the
typeface everyone loves to hate. Papyrus, ever since it was used on the film Avatar, has been similarly derided
and was recently the butt of a Saturday Night Live skit featuring Ryan Gosling. But why?

Aldus Manutius (1449–1515) printer and publishing, “inventor” of italics.

To type neophytes, most typefaces look the same. Scrolling down a long list of fonts, with only the word
“Sample” and the typeface name to distinguish one from another, it’s those highly flavored typefaces — like
Comic Sans — that stand out. They look more fun than all the stodgy fonts on the list, and hence they act,
according to type designer Mark Simonson, as “novice magnets.” And so they become overused,
inappropriately used, or both. They are put to tasks that make even their creators wince.

“Typography makes my words visible.”
— Erik Spiekermann

As typographers, we should think not in terms of good or bad, but in terms of appropriate and inappropriate.
Comic Sans was designed to be used in speech bubbles in MS Bob, an application for teaching people how to
use a computer. As such, it was a functional response to a design challenge. Its creator, Vincent Connare (who
also designed the highly respected screen typeface Trebuchet), could not in his wildest dreams have foreseen
the uses to which it would be put: sports team jerseys, all sorts of branding, and, yes, even gravestones (not
discounting the possibility that the online evidence may have been doctored). He has this to say of his
creation: “If you love it, you don’t know much about typography. And if you hate it, you don’t know much
about typography either and you should get another hobby.”
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Carole Twombly, type designer and creator (among others of Myriad, Adobe Caslon, and Trajan).

Type Anatomy and Classification
To talk about type, we need a common vocabulary. To name something is a big part of being able to
understand it. Knowing the names of the component parts of letters will help you understand how letterforms
are constructed as well give you a point of reference to evaluate and compare typefaces based upon the
qualities of these components.
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Typography is necessarily fussy and relies on small details. Let’s clarify some terms we’ll be using frequently. A
typeface is a complete alphabet, including letters, numerals, punctuation, and accents. A font is a specific size
and style of that typeface. For example, Adobe Garamond Pro is a typeface; Adobe Garamond Pro Bold is a
font. These terms are frequently used interchangeably, but typographers love to split hairs, and I guess I’m no
exception.

THE PARTS OF THE LETTERFORM

Stem: The main part of the letterform that is straight

Descender: The portion of the lowercase characters g, j, p, q, and y that projects below the baseline

Stress: The orientation of the letterform’s curved strokes, from thin to thick

Counter: The interior “negative” space of the letter. A, a, B, b, D, d, e, g, O, o, P, p, Q, q, and R all have closed counters.

Bowl: The rounded part of the letterform

Ascender: The part of the lowercase characters b, d, f, h, k, l, and t that extends above the x-height

Cap Height: The height of the uppercase letters

Median: The imaginary line defining the x-height

Baseline: The implied line upon which the characters sit

X-Height: The height of the main body of the lowercase characters. The letter x is chosen because the letter’s strokes end at — rather than
overshoot — this line of measurement.

The broadest distinction we can make between typefaces is the distinction between serif and sans serif. Most
typefaces fall into one or the other broad category.

18



“Type is a beautiful group of letters, not a group of beautiful letters.”
— Matthew Carter

Serifs are the small “ticks” at the end of the letter strokes. Sans serif typefaces do not have these ticks, sans
meaning “without” in French. While most typefaces are one or the other, there is a wealth of diversity within
this broad categorization. Not all serifs are the same, and not all sans serifs are the same. Serifs may be
bracketed (curved), hairline, or slab. Sans serif typefaces may be Grotesque (simple and neutral with only a
slight variation in the thickness of the strokes), Humanist (their letterforms influenced by calligraphy), or
Geometric (the Os and other rounded letterforms are derived from circles).

“Don’t mistake legibility for communication.”
— David Carson

Once we’re familiar with this basic difference, we’ll want to drill down deeper in classifying our type. There is
no single recognized standard for classifying typefaces; rather, there are several over–lapping standards. For
our purposes, I’m going to use a simplified version of Adobe’s type classification, showing examples of each
category.

Venetian Oldstyle
Venetian Oldstyle typefaces are named after the letterforms used by the scholars and scribes of northern Italy
in the 14th and 15th centuries. Distinguishing features:

Sloping cross stroke on the lowercase e

Stress that approximates that of a broad-nibbed pen held at an angle to the page

Little contrast between thick and thin strokes

Examples: Adobe Jenson, Berkeley Oldstyle, Arno
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Garalde Oldstyle
Garalde typefaces represent the late Renaissance evolution from the earlier Venetian style and include some of
the most enduring typefaces in use today. Distinguishing features:

Horizontal cross stroke on the lowercase e

A slightly greater contrast between thick and thin strokes than Venetian types

Stress that is inclined to the left

Bracketed serifs

Examples: Adobe Garamond, Bembo, Minion Pro

Script
Script typefaces mimic handwriting by joining letters with con- necting strokes. They are useful for
flamboyant headlines, logos, or elegant branding, but like a sticky confection are best when consumed
sparingly. Scripts require extra attention to kerning — that is, the adjustment of space between the letters —
but we’ll be coming to that later. Script faces should never be set in all caps — after all, one doesn’t write
cursive script in capitals. The challenge of working with script typefaces is that their “personal” nature is
antithetical to their digital manufacture. In handwriting, no two “a”s would be exactly alike, but in a typeface,
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they are. Today there are an increasing number of script typefaces with contextual alternates that go some way
to addressing this problem.

Examples: Bickham Script Pro, Champion Script Pro, Voltage

Transitional
A move away from letter shapes based on handwriting, transitional types were the first typefaces to be drawn
as shapes in their own right. They represent a transition between Garalde and Didone (Modern) typefaces and
contain aspects of both. Distinguishing features:

A vertical, or near vertical, stress

Pronounced contrast between hairlines and main strokes

Serifs are thin, flat, and bracketed

Examples: Baskerville, Perpetua, Stone Serif

Didone (Modern)
Named after Firmin Didot (1764–1836) and Giambattista Bodoni (1740–1813), Didone typefaces were a
response to improvements in late 18th-century paper production, composition, printing, and binding, which
made it possible to use typefaces with strong vertical emphasis and fine hairlines. Distinguishing features:

Strong contrast between thick and thin strokes
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Vertical stress

Mechanical appearance — constructed rather than drawn

Hairline serifs

Examples: Bodoni, Didot, Fenice

Slab Serif
Until the late 18th century, type was used primarily for books. With the Industrial Revolution came the
increased use of posters, billboards, and other forms of advertising, and the need for bolder, more in-your-face
typefaces that stood out from the competition. Slab serif typefaces were originally called “Egyptians,”
reflecting the public’s enthusiasm for the archeological discoveries of the time. Distinguishing features:

Heavy, squared-off serifs

Relatively consistent stroke weight

Sturdy

Examples: Clarendon, Memphis, Chaparral Pro

Sans Serif
The first sans serif typeface was issued in 1816 by William Caslon IV (great, great grandson of William

Caslon).1 However, it wasn’t until the end of the 19th century that sans serifs were widely adopted.

1. A digital interpretation is available as Caslons Egyptian from Font Bureau: https://fontbureau.typenetwork.com.
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This category can be subdivided into Grotesques (Helvetica, for example), which have strokes of near-uniform
thickness and are noted for their neutral appearance; Geometric (Futura), where the letterforms are geometric
or near-geometric and the strokes are of uniform thickness; and Humanist (Gill Sans), where the letterforms
are based on Roman proportions and have strokes of varying thickness.

Examples: Futura, Helvetica, Gill Sans

Decorative & Display
This is a catchall category for those typefaces whose primary pur–pose is to grab the reader’s attention. They
are most effective when used in large sizes for headlines, titles, and signage. Because they are so expressive and
tend to evoke a particular fashion or moment in time, they can have a short shelf life.

Examples: Arnold Böcklin, Rosewood, Industria

Blackletter
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These types are called Blackletter because they look dark on the page. They are also sometimes referred to as
Old English or Gothic (not to be confused with Gothic sans serif); in Germany they are referred to as
Fraktur. They may suggest a traditional newspaper masthead and the authority (or stuffiness) that entails.
However, Fette Fraktur, a typeface designed in the mid-19th century, was unfortunate enough to be adopted
by the Nazis in preference to the “non-Germanic” sans serif faces favored by the Bauhaus and other radical art
movements of the time. In an interesting twist, the Third Reich discontinued the use of Blackletter typefaces
in 1941, after allegations of Jewish contributions to the development of these faces, but it’s still hard to see
these letterforms without their negative baggage.

Examples: Fette Fraktur, Goudy Text, Lucida Blackletter

Monospaced
Monospaced fonts were designed for the technical limitations of typewriters. Because typewriters needed to
move the same distance forward with each character typed, each character needed to take up the same amount
of space on the line.

Typically used to differentiate a line of computer code in an instructional manual, or for optical character
recognition, they are also popular for evoking an “undesigned” look. Of course, we see through such artifice,
but it doesn’t matter. Even though we know the anti-design look has been carefully crafted by the designer
(probably too young to have ever used a typewriter), we’re happy to imagine that a beaten up typewriter was
the only tool they had. On a subconscious level we buy the message: this is the raw stuff. It’s about the
content: these are the facts, take them or leave them.

Examples: Courier, OCR A, Anonymous
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Ornaments
Ornament typefaces contain decorative elements that can be used to embellish documents. Some OpenType
fonts include ornaments as part of their extended character set.

Examples: Minion Pro Ornaments, Adobe Caslon Ornaments, Adobe Wood Type Ornaments

Symbol, Dingbat, or Pi
There exists a parallel universe of typefaces that aren’t letters at all, but pictograms. These picture fonts can be
playful as well as practical, with such useful devices as bullets, social media icons, check boxes and check
marks, stars, and navigational arrows. As well as extending the range of your typical character set, they are
used for musical notation, map making, mathematics, crosswords, and puzzle publishing. David Carson,
enfant terrible of grunge typography in the 1990s, famously set an article for Raygun magazine — an interview
with Bryan Ferry — in Zapf Dingbats. “It’s not worth reading — why not do it in Zapf Dingbats?”

Examples: Zapf Dingbats, Carta, Font Awesome

Typeface Characteristics
The class that a typeface belongs to usually hints at its best usage, but that isn’t always the case. In
publications, design typefaces serve one of two roles: as text types for continuous reading or as display types to
entice the reader into the piece. Text typefaces are easy to read in long blocks of copy and don’t call attention to
themselves. Conversely, display typefaces are intended to stand out. While it’s possible to use some text faces in
a display role, it rarely works the other way around. For this reason, we want to make sure we’re using the
right — or appropriate — typeface for the job in hand.
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To the untrained eye one sans serif might look much like another, but when you look closely, there are distinct differences. Here are
comparisons of sans serif typefaces that are commonly confused. While some letters look similar, there will always be those distinctive
forms that are the key to identification.

Take a selection of fonts, set them in the same point size, and you’ll find that some look bigger than others.
This is in part a legacy of the days of metal type, when point size referred to the size of the metal block on
which the type was cast. Some typefaces occupied more space within their blocks than others. Today, point
size refers not to the size of a metal block, but to the size of its digital equivalent: the bounding box that
surrounds each letter. We measure the space in which the type lives, not the letter itself; some fonts occupy
relatively more of that space than others. For this reason, let your eye guide you, not the point size.

TIP: Here’s an obvious point, but one worth making: It’s hard to evaluate the size (and other
aspects) of your type exclusively onscreen. Unless you’re creating type that’s intended for screen
reading only, print your test pages rather than relying on what you see on your monitor.

Another reason why some types look bigger is the x-height, or the relative size of the lowercase characters. A
large x-height generally makes a typeface more visible at any given size. Display faces with large x-heights
tend to communicate with clarity and emphasis. Text typefaces with large x-heights are typically regarded as
easier to read.

But it’s not as simple as bigger being better. Typefaces with very high x-heights have proportionally smaller
ascenders and descenders; if they are too small readability will suffer.

TYPE SIZES
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The same passage of text at the same point size and leading, showing how some fonts look bigger than
others.

Adobe Jenson Pro Regular 9/11

I was at first touched by the expressions of his misery; yet, when I called to mind what Frankenstein had
said of his powers of eloquence and persuasion, and when I again cast my eyes on the lifeless form of my
friend, indignation was rekindled within me. “Wretch!” I said. “It is well that you come here to whine
over the desolation that you have made. You

Meta Serif Pro Book 9/11

I was at first touched by the expressions of his misery; yet, when I called to mind what Frankenstein had
said of his powers of eloquence and persuasion, and when I again cast my eyes on the lifeless form of my
friend, indignation was rekindled within me. “Wretch!” I said. “It is well that you come here to whine
over the

Other characteristics to consider are the weight of the type, ranging from very light to extremely heavy, and
the letter proportions, ranging from compressed to extended. Note that although these are commonly used
terms, there is no universally agreed upon standard for denoting the weight or proportion.

A SAMPLE TYPE BLOCK

In traditional typesetting, the size of the type (point size) refers to the vertical height of the block itself, not the letterform on the
block. Nowadays, the same holds true for digital fonts, where point size refers to the invisible bounding box surrounding each
letter.

What’s in a Name?
Many typeface names are in the public domain, and many of the typefaces we work with are revivals or
interpretations of the original classics. Anyone with font editing software can create a typeface and call it
“Garamond” — just because something is called Garamond doesn’t mean it’s going to look the same as
somebody else’s Garamond. Sometimes interpretations of a typeface can be dramatically different from each
other, in much the same way as interpretations of the same song may be more notable for how unlike they are
rather than how similar. For this reason, when discussing your designs with co-workers and clients, be specific
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about which Garamond (or other typeface) you’re using and what vendor supplied it.

An InDesign Type Map: Where to Find the Type Stuff
Everything in InDesign relates to type in one way or another; here I want to point out the most frequently
used type-related menu and panel options. I’ll also discuss InDesign preferences that control how type is
viewed and how it behaves. As with any of the big-hitter design applications, there’s usually more than one
way to do something. Sometimes, it’s merely a matter of preference. Other times, new features have been
added that improve on old features — and so that veteran users aren’t alienated, the old menu options remain.
We all work differently, and InDesign encourages customization.

There are several preferences relating to type; for now, I want to point out where they are and suggest a couple
of changes to the factory default settings. I’ll deal with specific preferences in the relevant chapters.

With many InDesign preferences, when you make a change, you affect only the document you are working
on. If you want to change the preferences for every document you create thereafter, make sure you have no
InDesign document open so that your changes become application preferences. The following preferences
only become application-wide when you change them with no document open: Type, Advanced Type,
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Composition, Units & Increments, Grids, Guides & Pasteboard, Dictionary, Appearance of Black, and File
Handling.

Picas, Points, and Pixels in a Nutshell

6 picas = 1 inch or 25.4 millimeters

12 points = 1 pica

72 points = 1 inch

1 pica and 6 points = 1p6. Alternatively, this could be expressed as 0p18 or 18 pt.

6 points = 0p6, p6, or 6 pt

1 pixel = 1 pica

If you’re serious about type (and because you’re reading this I expect you are), I suggest you get used to
working in points (or picas, of which points are a subdivision). Points are a typographic unit of measurement
that originated in the early 18th century. They’re arcane and nondecimal, but there are compelling reasons to
use them. Since type is rarely expressed in anything but points, it’s helpful to have distances that relate to type
— such as leading (space between the lines), indents, paragraph spacing, and gutter (inter-column) spacing —
also expressed in points. In the U.S., margin sizes and column widths are typically expressed in picas; in
Europe, they are more commonly expressed in millimeters.

Typography also has relative units, two common examples being the em space (the size of your type — if you’re
working with 10-point type, then an em space is 10 points) and the en space (half the size of the em space).
The em measurement is also commonly used online, and although InDesign stops short of being a full-blown
web design tool, it is increasingly common to repurpose InDesign content for the web. With the development
of Cascading Style Sheets (CSS), the W3C (World Wide Web Consortium) best practices call for webpages
to be based on scalable designs using relative em units, rather than a fixed unit like pixels.

TIP: You’re free to move between different measurement systems as often as you like. Throughout
the course of any project, I typically find myself switching between points, picas, inches, and
millimeters. Regardless of your chosen measurement system, you can express values in any of
InDesign’s supported measurement systems so long as you are explicit. For example, if you are using
points but want a frame that is 50 millimeters square, select the frame and type 50 mm in the Height
and Width fields of the Control panel.

Another relative unit is the 1/1000 em, which is used for kerning and tracking. To understand kerning and
tracking units, it helps to know that each character of a typeface is designed within an em square that is
typically 1000 units. The character occupies a certain set width of that em square according to its shape; for
example, an m will necessarily be wider than an i. The widest character in the typeface will be the em dash,
which occupies nearly the full 1000 units. Kerning and tracking involve the adjustment of these relative
amounts of space, either to create the “illusion” of perfect spacing or, in the case of tracking, to give the type a
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denser or airier feel.

The Tools Panel
InDesign’s two most frequently used tools are the Selection tool and the Type tool. The Selection tool is used
for (among other things) moving, resizing, and threading text frames. The Type tool is used for formatting
and editing the text inside those frames.

Here’s how to toggle between tools:

With the Selection tool, double-click a text frame and your cursor changes to the Type tool.

With the Type tool, hold down Cmd (Ctrl) to switch to the Selection tool. With the Cmd (Ctrl) key
held down, you can drag the frame to move it or adjust any of its handles to resize it. When you release
the key, you return to the Type tool.

You can easily change the measurement system on the fly by right-clicking where the rulers intersect. Alternatively, you can cycle
through the supported measurement systems with the keyboard shortcut Cmd+Shift+Option+U (Ctrl+Shift+Alt+U).

It’s also worth memorizing the single-key shortcuts to access these tools: T for Type and Esc for the Selection
tool (V also works when you don’t have your cursor in a text frame).
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The letters in brackets indicate the shortcut for that tool. Note the Selection tool has two shortcuts, depending on the context. Esc only
switches you to the Selection tool when you have a cursor in a text frame. Click and hold on those tools with a black triangle in their right
corners to access the additional tools shown right.

The Control Panel
The Control panel is a chameleon, changing its appearance according to what is selected. When you’re using
the Type tool, the Control panel has two views: Character Formatting Controls and Paragraph Formatting
Controls. If your monitor is big enough, a digested list of Paragraph formats is displayed to the right of the
Character formats in Character Formats view; this view is reversed in Paragraph Formats view. You can
toggle between Character Formats view and Paragraph Formats view by pressing Cmd+Option+7
(Ctrl+Alt+7).
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 The Control panel in Character formatting mode (top) and Paragraph formatting mode. Further options can be found on the
Control panel menu shown above.

A number of useful options are tucked away on the Control panel menu, on the upper right of your monitor.
Note that you can customize the Control panel. If you don’t see the options you expect — particularly if
you’re using a shared computer — check the current options by clicking the gear icon above the menu.
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View the Page
There are several ways to view and navigate your InDesign documents; some are better than others. Although
you have myriad options, you can do most everything you need with just three shortcuts.

Zoom In: Cmd+spacebar (Ctrl+spacebar)+drag. If you value your eyesight, get in close when editing
text. There’s no point squinting at a page you can barely read. You could choose the Zoom tool from the
Tools panel, but save yourself the trouble. Instead, access the Zoom tool by holding down
Cmd+spacebar (Ctrl+spacebar). Now, rather than clicking to increase your view percentage, drag a
marquee around the portion of the layout you want to enlarge. The defined portion then fills your
window. To zoom out incrementally, hold Cmd+Option+spacebar (Ctrl+Alt+spacebar) and click.

TIP: When moving with the Hand tool, type onscreen might be “greeked” — that is, displayed
as gray bars. This is controlled in Preferences > Interface > Options > Hand Tool.

Pan: Option+spacebar (Alt+spacebar). To pan around at an enlarged view, press Option+spacebar
(Alt+spacebar) and drag with the Hand tool to move your page or spread within the document window.
In any tool other than the Type tool, pressing just the spacebar switches the current tool to the Hand
tool. However, if you’re using the Type tool, pressing the spacebar gets you a whole mess of spaces. This
may sound obvious, but you’d be surprised how easy it is to make this mistake, especially when working
quickly. So it’s best to standardize on Option+spacebar (Alt+spacebar), which works in all situations.
You can also use the Hand tool at reduced view sizes to move vertically through pages. Don’t bother
with the scroll bars; it’s hard to estimate their sensitivity, and you’ll waste time getting to exactly where
you want to be. Note that if you have a scrollable mouse, you can also use this for the same purpose.
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Ruler Units: Points and picas are a typographic standard. Wouldn’t you rather 12 points (or 1 pica) than 4.233 millimeters?

Keyboard Increments: These determine the increment when sizing type or adjusting leading with keyboard shortcuts.
Cmd+Shift+> (Ctrl+Shift+>) to increase, Cmd+Shift+< (Ctrl+Shift+<) to decrease. Option+Down Arrow (Alt+Down Arrow) to
increase leading, Option+Up Arrow (Alt+Up Arrow) to reduce leading. A smaller increment gives you more control. To size in
bigger increments, add the Option (Alt) key to the keyboard shortcut to increase that increment fivefold.

Baseline Shift: The keyboard shortcut to adjust the baseline shift is Shift+Option+Up or Down Arrow (Shift+Alt+Up or Down
Arrow).

Kerning/Tracking: This value determines the increment used when custom tracking or kerning is applied through keyboard
shortcuts: Option+Left Arrow (Alt+Left Arrow) to reduce the space or Option+ Right Arrow (Alt+Right Arrow) to increase the
space. For fine (read better) control, change this to the lowest increment possible, 1/1000 em. If you require bigger increments, add
in the Cmd (Ctrl) key to increase that increment fivefold.

Zoom Out: Cmd+Option+0 (Ctrl+Alt+0). Use this key combination to fit your page (or spread) in the
window. Having zoomed in and made your changes at a comfortable view size, zoom out again to get an
overall perspective on your layout.

An alternative to this triumvirate of view shortcuts is Power Zoom: At any view size, press Option+spacebar
(Alt+spacebar) to access the Hand tool, then click and pause for a second. A red magnification rectangle
appears that you can drag to view a different part of your page or spread. To change the size of the zoom
rectangle, continue to hold down Option+spacebar (Alt+spacebar) while you press the Up Arrow or Down
Arrow to increase or decrease its size; the smaller the rectangle, the bigger the magnification, and vice versa.

When editing type, Cmd+2 (Ctrl+2) and Cmd+4 (Ctrl+4) are useful shortcuts for zooming in to 200 percent

34



and 400 percent, respectively. Both zoom in to your insertion point in the text.

If you forget all of these you can always use the old standbys: Cmd++ (Ctrl++) to zoom in or Cmd+– (Ctrl+–)
to zoom out. If you have an active cursor in a text frame, you are zoomed to the center of the cursor. Without
an active cursor in a text frame you are zoomed to the center of the page.

View Modes
InDesign offers five view modes. The two principal view modes are Normal and Preview. Normal displays any
non-printing visual aids — guides, special characters, text threads — that you have turned on. Preview is just
that: a preview of how the page(s) will look when printed. It hides anything that is non-printing, as well as the
pasteboard surrounding your page or spread. The easiest way to toggle between the two is by pressing the W
key. But don’t do this when you have your Type tool inserted in a text frame, because then you will insert a w.
It’s an obvious point, but a mistake we all make from time to time. If you have the Type tool selected, first
press Escape to switch to the Selection tool, and then press W. If you’re more comfortable doing it the long
way, you can access the view modes at the bottom of the Tools panel. The Bleed and Slug view modes are
variants of Preview that include your bleed guide and slug area, respectively. Presentation mode is useful if you
want to make presentations using InDesign — but you’d be better off with Keynote or PowerPoint.

TIP: If the images on the page look pixelated, it’s probably because you’re using Typical Display
mode, InDesign’s low-resolution, quick screen-redraw option. Choose View > Display Performance
and switch to High Quality to render the images on screen at full resolution. If you have a fast
computer, set High Quality as the default view by choosing Preferences > Display Performance.
Note that Display Performance has no bearing on how your documents print.

Although it may be tempting to hide the visual clutter and work in Preview mode, I suggest doing your work
in Normal mode — all those guides and special characters are there to help you. Learn to love them; switch to
Preview just to evaluate your layout.
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Move Between Pages
For documents consisting of only a few pages or spreads, you can navigate from one page to the next with the
Hand tool. For longer documents, use the Pages panel, the Pages pop-up menu at the bottom left of your
document window, or the options in the Layout menu.

TIP: Press the Tab key to hide and show all your panels. Press Shift+Tab to hide or show all panels
except the Tools panel and Control panel.

When using the Pages panel to navigate a facing-pages document, it’s usually preferable to double-click the
page numbers, to include both pages of the spread in the window, rather than double-clicking the page icon,
which fits that specific page in the window.

Move Between Documents
With multiple documents open, you can simply click the relevant document tab to make it the active
document, or use the shortcut Cmd+~(tilde) / Ctrl+Tab to cycle through open documents.
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 My preferred workspace, a modified version of the predefined Typography workspace.

Optionally, you can create a keyboard shortcut to quickly load your workspace. Because you can’t overwrite the default
shortcut set, click New Set. For Product Area, choose Window Menu. You’ll get a long list of all the commands on the
Window menu — scroll down to Workspace: Load 1st User Workspace. Click into the New Shortcut field, and press the
keys for your new keyboard shortcut. I use Ctrl+F12 — Ctrl being the fourth, seldom used, modifier on the Mac. (Leave
the Context list set to Default so that the shortcut functions in all situations.) Click Assign to create the new shortcut.

Arrange Documents
If you need to compare documents or move content back and forth between documents, it can be useful to see
them side by side. The Arrange Documents drop-down allows you to split your screen in numerous
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configurations. When you’re done, to consolidate all to tabbed documents, choose the first item on the list.
You can also choose New Window to open another window, allowing you to see the same content at different
view percentages. Those of you with dual 27-inch monitors might occasionally find this useful. For the rest of
us, it fits in the good-to-know-but-can’t-say-I’ll-often-use-it category of features.

Create a Typography Workspace
InDesign panels are so numerous you would swear they breed like rabbits when your back is turned. Some of
these panels you’ll seldom or never use, no matter how illustrious your InDesign career. Thankfully, you have
full control of your workspace. You can save — and recall at any time — the visibility, positions, and
groupings of your panels. The names of workspaces appear in the Workspace picker on the application bar or
in the Workspace submenu of the Window menu.

To share a workspace with colleagues on your team …

Mac:

In the Finder, choose Go > Go to Folder. In the text field, enter ~/Library/Preferences/Adobe
InDesign, then click OK. This opens the preference folder for InDesign

Navigate to Version X.0/en_us/Workspaces2, and you’ll find your workspace files. Copy and place the
workspace files in the same location on the new Mac.

2. Note that en_us is the language. Your folder name might be different according to the regional version you have installed.

Windows:

Windows XP: C:Documents and Settings:[User Name]:Application Data:Adobe:InDesign:Version
[#]:en_US

Windows 10/Windows Vista: C:Users[User Name]:AppData: Roaming:Adobe:InDesign:Version
[#]:en_US:Workspaces

Windows 7: C:Users:[User Name]:AppData:Roaming:Adobe: InDesign:Version [#]:en_US

Note that this applies to other presets as well, not just workspaces. Whenever InDesign is updated
(frequently with Creative Cloud), it’s a good idea to save the desired preset folders from the old
version so that you can move those presets to the new version.
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The whimsical Periodic Table of Typefaces by Camdon Wilde features 100 of the most popular, influential, and notorious
typefaces. The table groups the typefaces into families and classes of: sans-serif, serif, script, blackletter, glyphic, display,
grotesque, realist, didones, garalde, geometric, humanist, slab-serif, and mixed. The poster is available at www.squidspot.com.

To create a custom workspace, first arrange your panels the way you want them. Create groupings that make
sense to you, close those panels you think you’ll seldom or never use (if you need them later, you can find
them under the Window menu), and then dock, or float, those you want, where you want them. From the
Workspace picker, choose New Workspace and give your workspace a name.

InDesign comes with a selection of predefined workspaces. The Typography workspace is a good starting
point. To this I like to add the following: Object Styles, Info, Links, Scripts, and Align. I close the Paragraph
and Character panels because their offerings are also available on the Control panel.

Having saved a workspace, you can load it at any time by choosing it from the Workspace picker (located next
to the search field, upper right). If you have made changes to the workspace and want to revert it to its
previously saved state, choose Reset. If you’d like those changes to overwrite the workspace, choose New
Workspace and type the same name (you’ll be asked to confirm that you want to overwrite the existing
workspace).

▄

Now that you have an overview of the history of typography, are familiar with typographic conventions and
terminology, and are comfortable with the InDesign interface, let’s start working with type.
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SAN SERRIFFE

On April 1, 1977 British newspaper the Guardian published a seven-page “special report” about San Serriffe, a small republic
located in the Indian Ocean.

Such an elaborate hoax was possible at the time because few people outside the printing industry knew the names of any
typefaces.
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Chapter 2

Type on the Page

Typography begins with a single character, and putting type on your page is about as fundamental as
InDesign skills get. There are several approaches to getting type on the page. You’ll use all of them at
one time or another. Let’s begin with the most elemental.

Text Frames
In InDesign, text frames hold your type. To be a stickler for the nomenclature, we’re talking text frames, not
text boxes. Each independent section of text is referred to as a story. A story can contain a single character in a
single text frame, hundreds of pages of “threaded” text frames, or anything between. An InDesign document
typically contains multiple stories, as would a newspaper or magazine. At the end of each story, if the hidden
characters are shown, you’ll see a hash mark or pound sign, known as the end-of-story marker.

TIP: The Smart Cursor displays the width and height of the frame as you drag it out. Alternatively, you
can specify the size of your frame, once drawn, using the Width and Height fields on the Control panel.

You can create a text frame in any of the following ways:

Draw one using a Frame tool or Shape tool. Select the Type tool and click within the object to activate
it as a text frame.

Create one by dragging on the page or pasteboard with the Type tool to define the width and height of
the frame. When you release, a flashing type cursor appears in the top left of the frame and you’re ready
to start typing.

Choose File > Place or press Cmd+D (Ctrl+D) to import a text document. You’ll see a loaded text
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cursor. Click on the page to flow the text and create a text frame that is the width of the column.
Alternatively, drag to define the size of the text frame. This also works when dragging a text document
from Adobe Bridge, a Creative Cloud library, or the desktop.

Paste previously copied text without a text frame selected. This creates a new text frame in the center of
the page.

Unless you’ve edited the [Basic Paragraph] style, the default font will be Minion Pro Regular 12 point. Since
you’ll be applying formats to the type, it doesn’t really matter how it starts out. But if you want to change the
default font, here’s how: First, if you want the change to become an application preference, close all
documents; with a document open, the preference will apply only to that document. Next, open the Paragraph
Styles panel, right-click [Basic Paragraph], and choose Edit. From the list of options on the left, choose Basic
Character Formats and change the font, point size, and so on. While you’re in Paragraph Style Options you
can also change other attributes, like the alignment, indents, or hyphenation. Realistically, though, text never
ends up formatted with [Basic Paragraph]. It’s just the point from which you start your text formatting.

CHANGE THE DEFAULT FONT

Right-click [Basic Paragraph] to edit its definition.

Fit Text Frames
Frames frequently need readjusting so that they’re big enough, and no bigger than necessary, to accommodate
the text. With a text frame selected, use the keyboard shortcut Cmd+Option+C (Ctrl+Alt+C), or choose
Object > Fitting > Fit Frame to Content. You can also double-click the bottom corner handle of the text
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frame with the Selection tool. If you want to fit the frame horizontally only, double-click either the left or
right center handle with the Selection tool; to fit the frame vertically, double-click the top or bottom center
handle.

Text Flow
Although it’s possible to author your text in InDesign, most of the time the writing is done in a dedicated
word processing application like Microsoft Word or Google Docs, or possibly in InDesign’s editorial cousin,
Adobe InCopy. When documents need to go back and forth in a review cycle, it’s arguably easier to use Word
for its editorial features, such as Comments and Track Changes. (Even though InDesign has a Track Changes
feature, Word has more robust editorial features and, more importantly, is used by more editors, most of
whom have never used InDesign or InCopy.)

It’s our job as designers to import the prepared text into an InDesign document, where — juxtaposed with
imagery and flowed from column to column and from page to page — we make it look beautiful.

To import — or “place” — a text file, choose File > Place or press Cmd+D (Ctrl+D), navigate to the file, and
then click Open. Your loaded type cursor displays the first few words of the file in a thumbnail. You can click
the loaded cursor inside a frame or create a frame by clicking a blank area of your page. The point where you
click becomes the top of the frame; the frame’s width is determined by your column and margin settings. To
align the top of the text frame with the top margin (or ruler guide), hover over the guide until the arrow in the
loaded cursor icon changes from black to white, indicating that the frame will “snap” to that guide.

Each text frame contains an In port and an Out port, which are used to make connections to other text
frames. An empty In port indicates the beginning or end of a story; an empty Out port means the end of a
story. An arrow in either indicates that the frame is threaded to another frame. A red plus sign (+) in an Out
port indicates that there’s overset text — more than will fit in the current text frame(s). To flow the overset
text, select the frame with the Selection tool, click the red plus to reload your cursor, move to where you want
to continue the text, and click or drag to define an area.
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PLACE TEXT

Use the Place menu (Cmd+D / Ctrl+D) to import prepared text into InDesign.

To move a text frame, select it with the Selection tool and drag from within the frame. To resize a text frame,
select it with the Selection tool and pull from one of its handles.

To edit text within a frame, use the Type tool. If you’re using the Selection tool, double-click in the text frame
to switch to the Type tool. You can toggle between the Type tool and the Selection tool by holding down
Cmd (Ctrl).

Primary Text Frames
It’s impossible to talk about primary text frames without bringing up master pages, which we’ve yet to get to
— see Chapter 17, “Page Geometry, Grids, and White Space.” Suffice it to say that master pages function as
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template pages or “page styles” for your document, and when you create a new document, you are in fact
setting the size, margins, and columns of your initial master page.

Using a primary text frame ensures that text automatically flows from one page to another. The size of the
primary text frame is determined by your margins and column settings. On your document pages, you can
type or place your text. When you fill the page, another is automatically created.

Here are some things worth noting about primary text frames:

If you choose Web or Mobile as your Intent, Primary Text Frame is selected by default.

You don’t need to override primary text frames the way you would a “normal” text frame that is drawn
on a master page.

There can be only one primary text flow in a document. But a primary text frame can contain multiple
stories on different pages.

Primary text frames can’t hold text on the master page itself.
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Primary text frames are denoted on the master page by the arrow icon in the top left of the frame. Click
this icon to convert a frame to a primary text frame, and vice versa. If converting to a primary text frame,
be sure to thread frames on facing pages.

If a primary text frame is moved or resized on a document page, the master page can be reapplied
without duplicating text frames.

Primary text frames can be used in conjunction with Smart Text Reflow to add (and optionally delete)
pages as needed.

Primary text frames let you apply different master pages to the same content and have the text flow in
different configurations.

If you apply a master page with a primary text frame to a document page with a primary text frame, the text
on that page is reflowed according to the size and position of the primary text frame on the master. This is the
chief advantage of using primary text frames. This is not what happens with normal text frames, where the
grid changes but not the content (unless you turn on a feature called Layout Adjustment, but that’s another
matter).

What to Watch for When Flowing Text

Replace Selected Item option in the Place dialog box: If this is selected and you have a frame selected
with the Selection tool, the text file you choose will replace the current contents of that frame. If you
are using the Type tool and your cursor is already in the frame, the new content is added from that
point in the story. These are both useful techniques, but if the results aren’t what you expect, press
Cmd+Z (Ctrl+Z) to restore the selected text frame to its original state. This will also return you to a
loaded type cursor.

Canceling a loaded text cursor: If you decide you are not ready to flow the text, press Esc to “unload”
the cursor, or switch to a different tool.

To create primary text frames in a document already in progress, go to your master pages and draw your frame
(or frames, if you’re working with a facing pages document — one for the left page and one for the right). To
convert the frame to a primary text frame, click the icon in its upper-left corner. Returning to your document
pages, you can insert or place text into the primary text frame and, assuming Smart Text Reflow is turned on,
the text flows from one page to the next.

While you can have multiple frames threaded together for a more complex layout, primary text frames are
most suited to documents with a simple text flow — for example, a story or article continuing from one page
to the next.

Other Text Flow Methods
There are five other text flow methods in InDesign:
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Manual Text Flow adds text one text frame at a time. The text flow stops at the bottom of the frame or at the
last of a series of linked frames. You’ll need to reload the type cursor to continue the text flow. Manual text
flow is most appropriate for short bodies of text.

Semi-Autoflow (Option/Alt) works like Manual Text Flow, except that the cursor is automatically reloaded
at the end of each frame, so you don’t have to click the red plus. You then continue the text flow by clicking to
create a new text frame or clicking an empty frame to add it to the text thread. If you drag, you can range your
text across multiple columns. Semi-Autoflow is useful when working with magazine or newspaper articles.
Both Manual and Semi-Autoflow can be combined with clicking and dragging to determine the exact size of
the text frame.

Autoflow (Shift) flows all the text, adding pages and frames as necessary. Because it creates single-column text
frames as opposed to (potentially) multi-column text frames, its usefulness has largely been superseded by the
primary text frame. Autoflow functions well when working with single-column documents containing one
main story — like a novel, a short story, or a journal article — but doesn’t do anything that a primary text
frame can’t.

What to Watch for with Text Frames and Master Pages

Using Enable Layout Adjustment to change from a single column to multiple columns creates a text
flow of threaded text frames. This can cause overlapping text frames.

Solution: Change the number of columns in the primary text frame before using Enable Layout
Adjustment.

Creating a document with Mobile Intent causes the Pages panel to display pages by Alternate
Layouts, even if there are none.

Solution: From the Pages panel menu, choose View Pages > Horizontally.
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Switching from facing pages to single pages in Document Setup still leaves you with a left- and right-
hand master page.

Solution: Select the master page, and from the Pages panel menu choose Master Options to change
the number of pages to 1.

Fixed-Page Autoflow (Shift+Option or Shift+Alt) flows as much text as will fit without adding pages —
useful if your document has a fixed number of pages.

Smart Text Reflow automatically adds or deletes pages as the amount of your text grows or shrinks. To use
Smart Text Reflow, choose Preferences > Type and deselect the Limit to Primary Text Frames option to
make it applicable to all text frames. New pages will be added to the document based on the master page
applied to the current last page of your document. Select the Delete Empty Pages check box, and any pages
that no longer have any content will disappear. Note that Smart Text Reflow works only when you have at
least two threaded text frames over at least two pages.

Drag and Drop Text Files
Rather than placing text files one by one, you can place multiple text files in one step. This can be done with
either the File > Place command or by dragging and dropping into InDesign from the macOS Finder or
Windows Explorer. Depending on the size of your monitor (this approach works best when you have a lot of
screen real estate), this may be a faster, more fluid way of working.

For multiple files, hold the Shift key to make a continuous selection or the Cmd/Ctrl key to make a
noncontinuous selection of the files. When you drag from the thumbnail of any one of the selected files into
your InDesign document, a loaded text cursor (or picture cursor, if you’re dragging pictures) displays in
parentheses the number of files that are queued. To cycle through queued files on your cursor, press the
Left/Right or Up/Down arrows.

Placing multiple files in one move can transform a document from foundation to near-complete dwelling in
just a few clicks —
provided that is, that you are working from thumbnail sketches and have pre-established empty, but threaded,
text frames.

Text Threads
Continuing the text flow from one frame to another is called threading. Here are some typical threading
techniques:

NOTE: To be consistent with InDesign nomenclature, I’m avoiding the term “linking text frames.”
QuarkXPress, InDesign’s competitor, uses the term “linking” to describe this process of flowing text
from one frame (or box) to another, and quite a few InDesign users who were formerly Quark users
still use this term. But in InDesign, the term “linking” refers to something else entirely: the
relationship of graphics placed in InDesign to their original files on your hard drive or file server.
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Create a thread. Select a frame containing overset text with the Selection tool, then reload your type cursor by
clicking its In port or Out port. It’s more likely you’d click the Out port, since you usually want to continue
from where the text stopped. Move to the next column or page and click, drag, or click inside an empty frame
to continue the text flow.

Show Text Threads. For an overview of how text flows from one text frame to another, choose Show Text
Threads from the View > Extras menu. Arrows indicate the flow of the text for your selected story. Text
threads are not always obvious, especially in a newspaper or magazine layout, where stories may jump from
one page to a noncontinuous page.

If you’re working with anchored objects, text threads also show where your anchored objects are positioned in
the text.

Delete a frame from a text thread. Select the frame with the Selection tool, then press Delete. Don’t worry
about losing the text; you are deleting the container, not the content — the text moves to the next frame in
the thread. If this is the last frame in the text thread, the text becomes overset.

Break a thread. Double-click the In port of the frame you wish to remove from the thread. The frame
remains, but the text is removed from it — though not deleted from the document.

Thread frames that are not part of the same story. If a story occupies multiple frames, it’s usually preferable to
keep those frames threaded, rather than chop up the text into independent text frames. Threaded frames can
be selected, spell-checked, and viewed in the Story Editor as one story. You can also, if necessary, export the
story as one file to be repurposed, perhaps for the web, rather than having to piece it back together from
separate frames. When working with EPUBs, it’s essential to keep your text as a continuous flow.
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So there may be times when you want to reassemble parts of a story that have become unthreaded, or perhaps
join stories together. To do this, click the Out port on the last frame of the first story, then click inside the
frame of the second story. This may require some adjustment, because the text from what was the second
story moves into the available space in the previous text frame. Also, before you do this, check that the last
line in each text frame is followed by a paragraph mark; otherwise, the last paragraph of the one text frame
will become joined to the first paragraph of the next.

The Preflight panel indicating overset text, with a hyperlink to the page in the document where the problem occurs

TIP: To see the bounding boxes for your text frames — even if they have nothing in them — make
sure View > Extras > Show Frame Edges is selected, or press Cmd+Ctrl+H (Ctrl+H). Working with
frame edges visible makes it easier to avoid untidy, overlapping frames, which may later cause
confusion.

Thread empty text frames. Sometimes it’s useful to draw text frames and thread them before the text content
is ready, essentially creating a “wire frame” of the document. To create a series of linked empty text frames,
draw your frames with the Rectangle Frame tool, and then click the first frame with the Type tool to
designate it as a text frame. Click the text frame’s Out port to “load” the text cursor (even though there is no
actual text), and then click inside the next frame to thread it to the first frame. Repeat as necessary, threading
frame 2 to 3, frame 3 to 4, and so on. Holding down Option (Alt) as you do so “reloads” the type cursor,
allowing you to continue threading without reselecting each new frame. To mock up your layout, you can fill
the text frames with placeholder text.
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Live Preflight

This useful panel indicates potential errors in your document, including overset text. Choose Window
> Output > Preflight to open the Preflight panel, and then click the disclosure triangle to the left of
the listed error for more information. Click the hyperlinked number to jump to where the problem
occurs in the document. Note that working with Live Preflight on may exact a toll on your
computer’s performance. Sometimes, while the document is in its early stages, you can turn this
feature off, turning it back on as the document nears completion to flag potential problems. You can
also access Preflight Options from the panel menu to limit the scope of preflight checks to exclude
certain types of layers, objects on the pasteboard, and objects set to be nonprinting.

You can also create multiple threaded text frames on the fly with the Type tool, using InDesign’s Gridify
feature. As you drag out a text frame, press the Right Arrow key to create additional columns, or the Left
Arrow key to remove columns. When you release the mouse, the multiple columns are threaded.

Split a threaded story into separate text frames. You can “unthread” a story with the SplitStory script. Select
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the frames of the story you wish to unthread, and choose Windows > Utilities > Scripts to access the Scripts
panel. Expand the Application folder, then the Samples folder, then the JavaScript folder. Double-click the
SplitStory.jsx script to convert your story to a series of unconnected text frames.

Remove a frame from the text thread. BreakFrame is the close cousin of the SplitStory script. Rather than
break a threaded story into unconnected text frames, it removes the selected frame from the text thread,
leaving the remainder of the frames still threaded.

Reflow the story. If you’ve created a series of threaded text frames and it just isn’t working, you can start over
with this technique. With the Selection tool, click the In port of the first frame in the story to load the
content onto your cursor. Now toggle to your Selection tool by holding Cmd/Ctrl, and click the first of the
text frames you want to remove. Next, add the Shift key and click the other frames in the story (or simply drag
over them to select them). Once they’re selected, press Delete to remove the frames. Release the Cmd/Ctrl
and Shift keys and you’re back to a loaded text cursor, with which you can now drag to draw a new text frame.

Span and Split Columns
When working with a multicolumn text frame it’s easy to have a headline span, or straddle, two or more
columns. With your cursor in a paragraph, choose Span Columns from the Control panel menu or the
Paragraph panel menu, or use the widget on the Control panel (though this does not include the option to
add space after the span). Note that Span Columns is intended to be used for headings at the top of a frame.
If you apply Span Columns elsewhere within a text flow, you’ll get unpredictable results.

After they came up with spanning columns, the clever Adobe engineers realized they could also do the
opposite: splitting columns. If you want to break two or more paragraphs into subcolumns, you can split them,
which is useful for lists in a wide text column.

The instructions to span and split columns can both be incorporated into a paragraph-style definition; see
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Chapter 15, “Styles.”

While Span Columns automates the straddling of a headline across multiple columns, there is a scenario in
which manually threading a headline is preferable. This is when you have columns of different widths, with
one of those columns used as a white space or caption column.

To manually thread a headline, follow these steps:

1. Pull down a guide from the Horizontal Ruler to where the first paragraph following the headline will
begin.

2. Drag the top of each text frame to this guide.

3. Click the In port at the top left of the first text frame to load your text cursor.

4. Drag to create a text frame that spans the width of the columns and is at the estimated height of the
headline.

The headline of the story (or as much of it as will fit) will flow into this text frame. If needed, adjust the
height of this frame afterwards.

Multiple-Column or Individual Text Frames?

Let’s say you want a three-column layout. You can achieve this with either:

A single text frame divided into three columns

Three threaded text frames of one column each

Your choice affects how you edit your layout.

A single frame divided into three columns lets you control the tops and bottoms of the three columns
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at once. If you have a heading that you want to straddle multiple columns, you can use the Span
Columns feature. Note that Span Columns works only in multi-column text frames.

On the other hand, with three individual columns, you can control the columns independently. This
is useful if you want columns of different depths or if you want the spacing between the columns to
vary, perhaps to have a narrow or “floating” column for captions. Each text column is actually two
column widths wide, with the captions column being a single column. The threading of the text
frames allows the position of the floating column to vary.

Text Flow in Reflowable EPUBs
If you’re preparing an ebook and your document is made up of multiple stories, you’ll need to rethink your
document strategy. Reflowable (as distinct from fixed-layout) ebooks are different from print books, and if
you’re new to EPUBs (the ebook format that InDesign exports to), you may find yourself questioning many of
the concepts you thought integral to a book. For starters, there’s no such thing as a fixed page — only a text
flow. Because screen sizes differ and because readers can change the size of the type, you, the designer, cannot
predict on what page the content will end up. All you know is that Chapter 1 comes before Chapter 2, which
comes before Chapter 3, and so on. For this reason, it’s important that you minimize the number of stories.
Essentially, what you’re after is for most, if not all, text to be in a single story and for graphics to be inline —
that is, inserted into the text flow. The Articles panel does allow you to have multiple stories and to specify
their running order, but you’re still better off, when possible, keeping everything as a continuous thread.

While it is possible to “crack the code” to create multi-column EPUBs, you cannot create them directly from
InDesign, so you may also need to rethink your content so that it works as a single column.
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Placeholder Text
Using placeholder, or dummy, text when mocking up a layout is a time-honored tradition. Traditionally,
designers have used a piece of Latin text called lorem ipsum. This text is based on Cicero’s The Extremes of
Good and Evil, written in 45 BC, but its word and sentence lengths have been tweaked to approximate those
of an “average” article. Dummy text is used so that clients, when approving design concepts, don’t get hung up
on the meaning of the text content but rather concentrate on the overall visual impression. Ironically, using
lorem ipsum sometimes requires designers to explain to their clients why the text is written in Latin.

InDesign has its own random text generator, which creates placeholder text similar to, but different from,
lorem ipsum. To use placeholder text, insert your Type tool into a text frame and then select Type > Fill with
Placeholder Text. The frame (or threaded frames) is filled with dummy text. If you make your font smaller
and need more placeholder text, you can choose Fill with Placeholder Text again to fill the frame.
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To add placeholder text in different alphabets (Cyrillic, Greek, Hebrew, Arabic, and so on), hold Cmd/Ctrl
when choosing Fill with Placeholder Text.

Thumbnails
Before you start laying out your pages in InDesign, make thumbnail sketches on paper. No matter how quick
you are with keyboard shortcuts, you’re faster (and more free to explore) with pencil and paper. Thumbnails
help eliminate those daft ideas that we all have — and often need to work through before we can get to the
good ones. Based upon your sketches you can construct a wireframe of text and picture frames, threading the
text frames together and possibly filling them with placeholder text until the real copy is available. To help
organize your content, put the text frames and picture frames on separate layers (see Chapter 17, “Page
Geometry, Grids, and White Space”). My house rule is for the text layer to be color-coded light blue and the
pictures layer to be red. That way I can tell at a glance which are my text frames and which are my picture
frames.
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Paste Text
Another method for getting text into an InDesign document is to copy and paste it from another application.
The regular Paste shortcut Cmd+V (Ctrl+V) brings in the text; whether the formatting comes with it depends
on how you have your Clipboard Handling Preferences set up. The default is Text Only, which will make the
text take on the formatting of the surrounding text where you paste. Alternatively, you can change the
preference setting to All Information to include the styles and formatting of the incoming text. To override
this preference on a case-by-case basis choose Edit > Paste Without Formatting or press Cmd+Shift+V
(Ctrl+Shift+V). The pasted text is added seamlessly at the location of your text cursor.

Although copying and pasting — with or without formatting —
usually works fine, it sometimes causes strange things to happen to special characters. It’s preferable to place
text rather than use copy and paste. Pasting is most useful if you’re copying small chunks from a larger whole,
possibly from the body of an email message or a PDF document.
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 As a possible starting point for your sketches, print out blank thumbnails of your pages with your layout grid shown. In the
Print dialog box General settings, select the Print Blank Pages and Print Visible Guides and Baseline Grids check boxes. In
Setup, choose Thumbnails and a suitable arrangement: 2×2, 3×3, 4×4, and so on. (In the PDF Export dialog box, choose a PDF
preset that is not based on the PDF/X standard and select the Visible Guides and Grids check box.)

Place Microsoft Word Text
The preferred method of getting your text into InDesign is to use the Place command. When placing a
Microsoft Word or Rich Text Format (RTF) file, you can control how the text is imported. Choose File >
Place (Cmd+D/Ctrl+D). A dialog box appears asking for file location. At the bottom of this window are
several check boxes. Select the file to import, select Show Import Options, and click Open, and you are taken
to the Microsoft Word Import Options dialog box. Here, you can choose whether or not to import Word-
created footnotes, endnotes, table of contents text, and index text.

TIP: As an alternative to selecting Show Import Options in the Place dialog box, hold the Shift key
when you need to see the import options. This works for pictures as well as text. In reality, you need
to see the import options less than 50 percent of the time, and this approach means your import
options don’t get stuck in the “on” position, showing you more information than you need and
slowing you down.

Choose Preserve Styles and Formatting from Text and Tables to import styles from the Word document.
Depending on how those Word styles were set up and implemented, this could be a blessing or a curse. In the
best-case scenario, the names of the Word styles are identical to the InDesign style names and the InDesign
styles take precedence. Your text formatting is done, and you get to go home early. For information on how to
map specific Word paragraph and character styles to their chosen equivalents in InDesign, see Chapter 15.

Auto-Size Text Frames
When you add to a frame, increase the size of the type, or sometimes just change the font, the text becomes
overset. You then have to readjust the size of the frame or thread the frame to a new column, a new page, or a
different part of the page. In short, it can be a pain. To get around the problem, it’s useful in certain
circumstances to create auto-size text frames. As the text size or length changes, auto-size frames grow or

58



shrink accordingly.

Rectangles and Rectangle Frames: What’s the Difference?

There are two tools that do essentially the same thing: the Rectangle tool (and its associated tools
Ellipse and Polygon) and the Rectangle Frame tool (along with the Ellipse Frame and the Polygon
Frame). What’s the difference? Well, not much.

Shapes drawn with the Frame tools appear with an “X” inside them. They are always created with no
stroke and no fill, and their content is set to Graphic in the Object menu. The Rectangle, Ellipse, and
Polygon (the Shape tools), however, have no “X” and are intended as graphic elements in their own
right. They take on the formatting of the object style you have set as the default (it’s the one
highlighted in the Object Styles panel when nothing is selected). There’s nothing stopping you from
putting text or a graphic inside a shape: Click in the frame with the Type tool, and the object
becomes a text frame. Likewise, there’s nothing compelling you to put content into frames.

Some designers use only the Rectangle tool because it arguably makes for a cleaner workspace. I
prefer to use the Rectangle Frame tool for any content; that way, when I’m wireframing a layout, it’s
clear where the content will go.

Because some people prefer their text frames to be text frames and their graphic frames to be graphic
frames, there’s a Type preference that prevents graphic frames from being converted to text frames
with the Type tool. Personally, I like being able to convert graphic frames to text frames, so I leave
this option turned off.

Another way to change graphic frames to text frames, or vice versa, is to choose Object > Content. If
you’re a neat freak, you can convert empty text frames to “unassigned” frames, thereby removing the
end-of-story markers in those frames and reducing visual clutter.

If you need to change the shape of any object — for example, from a rectangle to an ellipse or vice
versa — choose Object > Convert Shape.

Choose Object > Text Frame Options (Cmd+B/Ctrl+B), then click the Auto-Size tab. Here, you can choose
whether the frame width and/or height is adjusted and how the text frame is anchored —
that is, which edge doesn’t move. Keep in mind that Auto-Size works for unthreaded frames only — stories
that start and end within the same frame — or for the last frame in a thread.

Here are some possible uses for auto-size frames:

Pull-quotes that are positioned within columns of text — anchor the center and expand the frame on all
four sides.

Sidebars that are positioned alongside the main story — anchor the top and expand the frame from the
bottom.
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Captions that are aligned side by side with the bottom edge of a picture — anchor the bottom and
expand the frame from the top.

TIP: To insert a Word or other text file into an existing text flow, insert your cursor in
the story where you want the additional text to go. Choose File > Place, or press
Cmd+D/Ctrl+D. In the Place dialog box, make sure that Replace Selected Item is
turned on. Then select the file with the new content and click Open to place the text
at the point of your cursor.

Picture credits — anchor the left and expand from the right side.

Title treatments that are non-threaded, where you want to experiment with the size and style of the type
without having to readjust the size of its frame — anchor the top left and expand from the bottom and
the right.

You can choose a minimum height to ensure that the frame never gets smaller than that specified height.
Choose a minimum width if you need your frames to be a specific column width. To automate the use of
auto-sizing, you can incorporate your Auto-Size setting into an object style.

Dude, Where’s My Text?

There are many possible causes for overset set. Here are the most likely culprits:

Keep Options. The frame contains text formatted with a Keep Option like start On Next Odd Page.

Text Wrap. If a text wrap object touches the text frame, the text may become overset. Keep in mind
that the text wrap object may be hidden or on a hidden layer.

No Break. When No Break formatting is applied to a range of characters, either manually or with a
GREP style, text becomes overset if the frame isn’t wide enough to fit the range of text.

Align to Grid. When text is aligned to a baseline grid, the text may become overset if the grid
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increment is more than the leading value of the text.

Text Frame Options. Custom baseline grid, insets, or a large minimum value for the First Baseline
Offset can all cause overset text.

No hyphenation. If hyphenation is turned off and any word is wider than the text frame, the text
becomes overset. This is a common problem with long URLs.

No Language. Text with No Language specified can’t be hyphenated, because InDesign doesn’t
know which dictionary to use. If any word with No Language is wider than the frame, the text
becomes overset.

Indents. Text with large right and/or left indents can become overset in narrow frames.

Tables. When a table has more text than can fit in a cell, overset text is the result.

Inline graphics. If inline objects are taller than the text frame in which they are anchored, you get
overset text beginning at the line containing the object.

As a side note, not only does Auto-Size adjust the size of the frame when the size of your text changes, it also
adjusts the fill that is applied to that text. Ninety-nine percent of the time, you might say, “So what?” But for
display text to which a gradient is applied, this means, conveniently, that the gradient itself adjusts according
to the width of the text.

The Story Editor
InDesign offers another way of viewing your text content. In the Story Editor, text is displayed in one
continuous column, all in the same font and all at the same size. To view text in the Story Editor, select a text
frame with your Type tool or Selection tool and choose Edit > Edit in Story Editor, or press Cmd+Y
(Ctrl+Y).

The chief reason for using the Story Editor is that editing text, especially long passages of text, is quicker
without the visual distractions of graphics, column breaks, and formatting. You don’t have to worry about
zooming in and out or navigating from column to column or from page to page. It’s pure content. Any
changes made in the Story Editor are automatically reflected in the layout and vice versa. You can also use the
Story Editor to quickly apply paragraph and character styles.

If you don’t see the left column with the style names, as shown in the figure on the next page, choose View >
Story Editor > Show Style Name Column. The Depth Ruler (View > Story Editor > Show Depth Ruler)
displays the length of the story in column inches (or whatever measurement system you’re using inside the
Style Name Column). When you’re ready to return to Layout view, press Cmd+Y (Ctrl+Y) or click the Close
button in the Story window.
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The appearance of text in the Story Editor is for your eyes only and has no bearing on the appearance of text
on your document pages. You can make the text as big and as retro-looking as you want, so long as it’s
comfortable for you to read. To change the appearance of text in the Story Editor, choose Preferences > Story
Editor Display.

Alternatives to Word

Although Word remains the most commonly used application to prepare text for InDesign, it’s not
the only show in town. Other, more streamlined, workflows exist. If you’re a Creative Cloud
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subscriber, you have access to InDesign’s editorial cousin, InCopy. This useful but underappreciated
app allows editors to “check out” stories from an InDesign layout and work on them while the
designer simultaneously works on the layout. When the edits are made, the story is checked back in,
and it updates in place. InCopy can also be used to create text from scratch. For more on InCopy,
take a look at InCopysecrets.com.

A similar round-trip workflow is possible using Google Docs and DocsFlow, a plug-in from Em
Software. After you place a Google Doc it’s shown in the Links panel. If the file is edited, the Links
panel displays a “modified” icon — double-click the icon and the file updates in InDesign. DocsFlow
allows editing in InDesign and Google Docs and will merge the edits from both. For more on
DocsFlow, visit emsoftware.com.

A less obvious reason for using the Story Editor is that it is a useful tool for troubleshooting text composition
problems, like mysterious line breaks or spacing gaps. Editing in the Story Editor is like getting under the
hood to view the engine. You can see and more easily access things here that are hidden or hard to see in
Layout view. Among the many things you see in the Story Editor are markers for anchored objects, text
variables, hyperlinks, nonprinting Notes, cross references, index markers, and XML tags. You can also edit
overset text, including overset text in table cells. The Overset Text Indicator “redlines” the overset text,
making it easier to write to fit the available space.

Text Cleanup
Having placed a text file, the first thing to do — even before you start formatting the text — is clean it up.
Designers commonly work with text files that have been created by someone else. In a perfect world, these
files would be as lean as a cheetah and as minimalist as a piece of Bauhaus furniture. This is rarely, if ever, the
case. People clutter up their text files with all kinds of junk, often in the misguided notion that they’re helping
you out. Extra paragraph returns, multiple tabs, and multiple spaces (in some cases used to align type) should
all be removed. See Chapter 8, “Small (but Important) Details,” for why not to use more than a single space.
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Of course, communication with your client can go a long way: Tell them what you want and you might even
get it. But even with crystal-clear communication and the best of intentions, you’re still going to need to clean
up your text files — even if it was you that created them in the first place. Thankfully, it’s fast and easy to whip
your stories into shape.
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Before you do anything, make sure you’re in Normal view and that you have hidden characters shown (Type >
Show Hidden Characters). That way you can see more clearly the problems that need resolving.

The predefined GREP queries in the Find/Change dialog box let you remove multiple spaces, multiple
returns, and any trailing white space (spaces before the paragraph mark that can cause formatting problems).
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The fastest way to clean up text is to use the FindChangeByList script that comes with InDesign. Choose
Window > Utilities > Scripts to open the Scripts panel. Next, in the panel, expand the Application folder,
then the Samples folder, then the JavaScript folder. Scroll down to FindChangeByList and double-click its
name. In the blink of an eye, the script performs a sequence of Find/Change routines on your selection, your
story, or your document. If you want to see exactly what it’s doing — and customize how it performs — open
the FindChangeSupport folder beneath the script on the Scripts panel, right-click the FindChangeList.txt
file, and choose Show in Finder/Show in Explorer. You can open the text file in a text editor and edit its list
of Find/Change routines. The easiest way to do this is to copy and paste an existing routine and then adjust
the Find and Change criteria as necessary.

Even if you’re not feeling intrepid enough to customize this script, just using it off the shelf to banish
egregious spacing will save precious time. A word of caution that applies to using any script: If you try using
Undo after running a script you’ll find yourself needing to press Cmd+Z (Ctrl+Z) numerous times to restore
things to the way they were. This is because a script is a sequence of steps, and Undo reverses only a single
step in that sequence at a time. To play it safe, save your work before you run a script. That way, you can then
use Revert to get your document to the previously saved version if you don’t like the results.

▄
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Now, with type on the page, in the next chapter we’ll look at crafting type using InDesign’s extensive
character formatting options.
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Chapter 3

Type Choices

This chapter looks at how and why to choose type and InDesign’s basic character formatting options.
Selecting a typeface and its treatment for a particular task is simple. Deceptively so. Your choice of
typeface, its style and point size, and any casing options all contribute to — or detract from — the
readability of your text. They should be conscious, informed choices. Discussing these options, we’ll
follow the order determined by the InDesign interface, an order that both reflects the logic of
predigital typesetting and sets the agenda for how we work today. But we’ll also look beyond the
buttons and menus to discuss the historical precedents and time-honored conventions that are
attached to such options.

Text Selection Methods
Before we can format type, we must first select it. Here’s a list of shortcuts for selecting text and moving
within stories:

Select one word: Double-click word

Formatting Affects Text

As well as selecting a range of text, you can also select text on a frame-by-frame basis. This is
useful if you want to apply the same formatting to all the text in a frame or multiple frames.
With a text frame selected, choose the Formatting Affects Text icon on the Swatches panel or
the bottom of the Tools panel. You can also press J to toggle back and forth between this and
the default option, Formatting Affects Container. This approach lets you evaluate changes
without the visual distraction of the text selection color. Note that you will need to apply the
formatting through the Character panel, because the Control panel does not show text
formatting options when a frame is selected with the Selection tool.

Select one line: Triple-click line (depending on Text preferences setting)

Select to beginning of paragraph: Cmd+Shift+Up Arrow (Ctrl+Shift+Up Arrow)

Select to end of paragraph: Cmd+Shift+Down Arrow (Ctrl+Shift+Down Arrow)
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Delete one word to left of cursor: Cmd+Delete (Ctrl+Backspace)

Delete one word to right of cursor: Cmd+Fn+Delete (Ctrl+Delete)

Move to start or end of story: Cmd+Fn+Left Arrow or Right Arrow (Ctrl+Home or End)

Select from the point of the cursor to the start or end of story: Cmd+Shift+Home or End
(Ctrl+Shift+Home or End)

Move to beginning of line: Fn+Left Arrow (Ctrl+Up Arrow)

Move to end of line: Fn+Right Arrow (Ctrl+Down Arrow)

Move one word to the right: Cmd+Right Arrow (Ctrl+Right Arrow)

Move one word to the left: Cmd+Left Arrow (Ctrl+Left Arrow)

Move to beginning of next paragraph: Cmd+Down Arrow (Ctrl+Down Arrow)

Move to beginning of previous paragraph: Cmd+Up Arrow (Ctrl+Up Arrow)

Unfortunately, there’s no way of selecting text one sentence at a time.

Basic Character Formats
This section looks at the basic character-level options of the Control panel.

NOTE: These options are found both on the character formats of the Control panel and in the
Character panel. It’s a matter of preference which you choose to use. I prefer the Control panel, and
the figures in this chapter reflect that choice.

Font
To change the font of a selected range of text, use the Font field on the Control panel. To jump to the Font
field when character formats are active, press Cmd+6 (Ctrl+6), or just click in the Font field. From there,
either click the x to clear the search field or select the existing font name and type over it the first few letters of
the font you’re after. You can also click the magnifying glass icon in the Font field to set the search preference
to either Search Entire Font Name or Search First Word Only. This changes the results you get when you
start typing a font name

To move through the fonts on your menu, applying them to your selected text, press the Up or Down arrow.

You can change the size of the font previews (or turn them off completely) in Type preferences. The preview
is nothing more than the word “Sample” rendered in the particular font. It’s not especially useful. Type
preferences is also where you can choose the number of recent fonts to display and whether to sort them
alphabetically. Recently used fonts are displayed at the top of your Font menu — a list that stays active, even
after you quit the program.
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The font menus of designers can be long and a time-suck to use, so it’s useful that InDesign provides a
number of time-saving filters. As well as the ability to filter the font list by style — Serif, Sans Serif, Script,
etc. — you can also filter by Typekit fonts, by “favorites” that you have starred, and by similarity to your
currently selected font.

Font Management

You can never be too rich or too thin or have too many fonts. To use that font collection effectively,
however, you’re going to need some organization. So as your font collection grows, you may want to
invest in a font management utility. On the Mac, Font Book, which comes with macOS, lets you
test, preview, and organize your fonts. You can create customized collections, as well as organize —
and activate — your fonts by style, project, or client.

If you need more control, Suitcase Fusion, from Extensis (extenisis.com), automatically activates your
fonts in Creative Cloud apps, provides tools to fix common font problems, and offers integration with
font services like Typekit and Google Fonts. FontAgent Pro, from Insider Software
(insidersoftware.com), and FontExplorer X, from Monotype (fontexplorerx.com), offer a similar
range of features at the same price, which at the time of this writing is around $100.

The Font menu is organized by language. After the fonts with western character sets, you will see a list of
Japanese fonts, traditional Chinese fonts, simplified Chinese fonts, and Korean fonts. Following these are
Arabic fonts and Hebrew fonts.

The following icons are used to indicate different kinds of fonts:

 OpenType

 Typekit (these too are OpenType but are “synced” and the actual font files stored in a hidden folder on
your computer)

 TrueType

 Type 1
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Sometimes fonts, usually free fonts of dubious provenance, are prone to errors. This is not to besmirch free
fonts — there are many good ones out there — but rather a commonsense reminder that you get what you pay
for. If you plan on using a free font in your layout, make sure to road-test it before the project deadline.

OpenType is the font file format preferred by most graphics professionals. A single compact file contains both
the printer outlines and the bitmap screen information. The printer outlines in an OpenType font can be in
either PostScript format or TrueType format. Those with PostScript outlines have the .OTF extension, while
those with TrueType outlines have the .TTF extension. OpenType fonts are cross-platform compatible, and
offer the potential of up to 65,000 glyphs in one font. In reality, many have the same 228 glyphs you’d find in
a Type 1 PostScript font. OpenType fonts may have either Std or Pro appended to their name. Std means the
font contains the standard range of Latin characters. Pro means that the font contains additional characters
for working with other languages, as well as such typographic niceties as real small caps, extra ligatures, and
different –numbering styles.

Handling Missing Fonts
Sometimes when you open an InDesign document, especially a document created by someone else, you see an
alert that fonts are missing. If the document contains unsynced Typekit fonts, the Find Font dialog appears,
giving you option to sync those fonts. Assuming you have an internet connection, have a Creative Cloud
subscription, and have not reached the maximum number of fonts you can sync from Typekit, after a short
pause the fonts will be synced.

NOTE: The pink highlighting can be turned off in your preferences. Choose Preferences >
Composition > Highlight Substituted Fonts.

Missing fonts are indicated in your layout with pink highlighting; they are listed on your font menu in square
brackets. Ideally, you can install the correct fonts. If this isn’t practical, you can choose Type > Find Font to
replace the missing fonts with fonts you have installed.

Select Redefine Style When Changing All to ensure that paragraph and character styles will be redefined to
use the new font — assuming, that is, that styles have been used. If you don’t use this option, you’ll end up
changing the font on your pages, but it will linger inside the style definition and likely pop up when you least
expect it.

TIP: Find Font is not limited to replacing missing fonts. It’s also the quickest way to change one
font to another throughout your document — just make sure to have Redefine Style selected when
you do so.

To avoid missing fonts when you pass your job on to someone else — or just move it from one machine to
another — make sure the project is packaged. Choose File > Package, click the Package button, and then
select the Copy Fonts check box (as well as the Copy Linked Graphics box) to have InDesign collect the fonts
in a folder inside the project folder. Note that Typekit fonts can’t be packaged, however. If you’re passing on
the document to colleagues, they too must have a Creative Cloud subscription so that the fonts can be synced.
Chinese, Japanese, and Korean fonts (CJK) can’t be packaged either.
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Font Styles

Having a choice of different type styles — like bold or italic, for instance — within the same typeface
family lets you indicate hierarchy and emphasis, while at the same time maintaining stylistic
continuity. InDesign won’t allow you to apply “faux” bold or italic font styles; there’s no B or I button
to make the text heavier or slanted. Both styles can be faked in other ways, but you have to be
desperate to want to do so. Instead, choose the italic or bold weights of that typeface from the Font
Style menu. You can also use the shortcuts Cmd+Shift+I (Ctrl+ Shift+I) or Cmd+Shift+B
(Ctrl+Shift+B) — if a font doesn’t have a bold or italic version, the text doesn’t change.

Normal/Regular/Roman
Numerous terms are used to describe the styles within a typeface. Type that doesn’t slant is referred to as
roman. This “normal” style is usually called regular, but in certain typefaces may be called book or medium. The
terms italic and oblique both refer to slanted type, the latter employed in some sans serif typefaces. Terms like
light, semibold, bold, or black refer to the font weight and are self-explanatory; other, lesser-used terms to
describe font weight are heavy and extra bold. The terms condensed and extended refer to character width.

The most important type choice you’ll make is your body text, which will be in the “normal” style. Body text
makes up most of any document, so the look of the body text is of paramount importance. Here are some
things to consider:

Your body type should be trustworthy and unobtrusive. These are qualities best served by typefaces with
conventional letterforms. Novelty slows comprehension; letters with excessive ornamentation or quirky
design elements force the reader to process what they are looking at first — “Wow, look at that cute g”
— before taking in the message.
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Body text should be easily readable at small sizes. Typically this means choosing a typeface with a tall x-
height. A tall x-height makes it easier to distinguish between similar lowercase letters, like “a,” “c,” and
“e.”

Although it’s not a cast-iron rule, serif fonts are more common for body text in print. Pick up any book,
newspaper, or magazine and there’s a more than 50 percent chance it has a serif font for the body text.
In screen publications, body text can be sans serif or serif. Sans serifs were once preferred for screen type
because they look crisper on low-resolution displays. Screens have come a long way in recent years,
however, and today serif fonts look equally good.

Identifying Type

See a typeface that you like but don’t know its name? There are several online services that help
you play font detective.
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Visual Search from Typekit uses Adobe Sensei’s machine-learning technology to identify a font
and suggest similar typefaces on Typekit. You upload a photo of lettering or type, and Visual
Search will return a list of similar typefaces on Typekit.

WhatTheFont (from MyFonts.com) and the Font Matcherator (from Fontspring.com) work
in a similar way.

Identifont (www.identifont.com) takes a different approach, drilling down to the font’s identity
by asking a series of questions, such as: Does the font have serifs? What style is the uppercase Q
tail?

Research the attributes and connotations of prospective typefaces. Does the family have italic and bold
variations, and are there enough weights and styles for the job in hand? Is the typeface designed for print
or screen? Is its history congruent with the subject matter of the text? If you’re in doubt, a quick browser
search will give you some background information about the typeface.

As well as identifying the physical characteristics of the typeface, consider too any baggage that comes
with it. Default choices like Times or, sadly these days, Minion can connote laziness. Which is not to
say that you can’t create great-looking designs with these fonts, but rather that you’re starting on the
back foot and you’ll have to work harder to make them look like conscious and informed choices.

Variable Fonts

This exciting new font format allows you to customize styles within a typeface design —
effectively giving you a whole font super family in a single file. You can change weight, width,
and slant, as well as optically size. For veterans who remember multiple master fonts, it’s like
that, only better. At the time of this writing there’s no support for variable fonts in InDesign or
Typekit, but that’s bound to change, as they are now available in Adobe Photoshop and
Illustrator. You can view a demo video here: https://youtu.be/bD6BSjl-xfw.

Italics
Italic type styles — so named because they evolved in Italy — are designed to complement their roman
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siblings. Most fonts come with a matching italic. The company that developed InDesign’s predecessor,
PageMaker, took the name Aldus after Aldus Manutius (c. 1449–1515), a Venetian printer who was the first
to use italic type in the early 16th century.

Italics are separate fonts in their own right, not just slanted versions of the roman. When they were first used,
they were considered distinct from the roman forms. Over time, printers began pairing italics with romans of
the same weight and x-height, but italics retain their identity through narrower proportions and unique
letterforms.

Italics have the following uses:

Emphasis.

Foreign language words or phrases, except those words that are in such common usage as to not require
distinction; for example, cliché, elite, genre. Such conventions shift over time, so check the dictionary
for clarification.

The titles of films, books, magazines, or works of art.

In written dialogue to indicate that the conversation is thought, rather than said, by the character.

Avoid setting long passages in italics. The calligraphic flow of italics makes the type look hurried; or perhaps
the characters, being more decorative, attract too much attention. If they’re overused, the uniqueness of italics
is lost.
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When working with serif typefaces, consider increasing the size of the italics by about half a point (for ease
and consistency this should be incorporated into a character style — see Chapter 15). This is an optical issue
— with the roman and italic at the same size, the italics often look smaller — though of course this depends
on the typeface.

If you’re using a typeface without an italic and you really need an italic version for emphasis, but you’re
wedded to that particular typeface, you can, in a pinch, fake italics by using the slant option to give the type an
angle of 12 degrees. Don’t say I didn’t warn you — fake italics look cheesy.

It’s common for sans serif families to have an oblique, rather than italic, style. Oblique types are slanted
versions of the roman characters rather than separately drawn letter forms. If you’re working with such a
typeface family, consider using bold rather than italic to give emphasis, as obliques lack the grace and
calligraphic quality of true italics.

When using italics (or any other method) for emphasis, any punctuation that follows should be in the same
style.

Bold
Bold weights are typically applied to headings and subheads to establish hierarchy. It’s also common in
newspapers and magazines to distinguish supporting text like sidebars, captions, and pull quotes by using a
bold or semibold weight.

In larger typeface families, there may be relative weights of boldface, with names like semibold, black, extra
bold, and super. Given the option of several weights within the same family, it’s preferable to differentiate by
two weights to achieve the desired contrast. For example, pair regular with bold, or light with semibold; a
regular paired with a semibold will look too similar and will not provide sufficient contrast.

The use of bold as opposed to italics for emphasis is a style issue. If you opt for bold, use it sparingly. Because
bold type is more commanding than italics, too much bold on a page can be distracting and even disruptive to
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the reading process. If everything is emphasized, then nothing is emphasized. Bold text can break up the
continuity of the type and set an overly didactic tone. The eye will jump to the text called out in bold rather
than discover the emphasis as part of the reading, as with italics, which blend in better with the roman type.

EMPHASIS

There are NUMEROUS ways to give emphasis. Making words bold or italic
are the most common, but using color or a  highlight  can also be effective.
Whichever method you choose, you need only one way to signify
difference. For example, it is redundant to use bold and italic or bold and a
color.

From a historical perspective, the use of boldface may undermine the authenticity of a page, because prior to
the 19th century there was no such thing as bold roman type, printers relying instead on small caps or italics
for emphasis. As Robert Bringhurst puts it in his landmark book The Elements of Typographic Style,
inappropriate use of boldface can “create unintentional anachronisms, something like adding a steam engine
or fax machine to the stage set for King Lear.”

Font Size
As well as sizing type with the Control panel, you can use keyboard shortcuts: Cmd+Shift+> (Ctrl+Shift+>)
increases the size by the increment specified in the Units and Increments preferences for Size/Leading.
Cmd+Shift+< (Ctrl+Shift+<) reduces point size by the same increment. Add Option (Alt) to this key
combination, and you can increase or decrease your point size by five times the specified increment. Pressing
Cmd+> (Ctrl+>) scales the frame and the type at the same time. The type is scaled relative to the text frame,
rather than by the increment specified in the Units & Increments preferences.
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If you’re working with a short piece of type that’s not part of a threaded story, it’s often easier to scale the type
and the frame together. To do this, drag out a text frame with your Type tool, then type your text. If your
frame is bigger than necessary to accommodate the text, click the Fit Frame to Content icon on the Control
panel, press Cmd+Option+C (Ctrl+Option+C), or double-click the lower-right handle of the text frame to fit
to the text. To scale the type by eye while maintaining its proportions, hold Cmd+Shift (Ctrl+Shift) as you
drag from one corner of the frame. You can also use the Scale tool or the Free Transform tool to size the
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frame and its contents.

Common Text Sizes in Print
Body text or body copy is the type (typically in sizes between 8 and 12 points) that makes up the majority of a
book or article and carries the bulk of the message. Typefaces designed for such a purpose — referred to as
text typefaces — need to have letterforms that are effortlessly recognizable and so tend to have open counters,
large x-heights, rhythmic and repetitive shapes, and a medium weight.

Font Size in Parentheses

By default, if you scale a frame, the text inside is also scaled. If you double the size of a text frame, the
text size also doubles, so 20-point text increases to 40 points, for example.

There’s an ill-advised preference that changes this behavior. If you choose Adjust Scaling Percentage,
the Font Size field displays both the original and the scaled size of the text, such as “20 pt (40).”

The purpose of this option is so users can monitor scale changes to frames — potentially useful if you
have to revert a frame and its text to its original size. In practice, however, it just confuses people.

If you inherit a document with font sizes in parentheses, reset this preference to Apply to Content.
To see the “real” sizes of your type, select the frames, then choose Redefine Scaling as 100% from the
Control panel menu. Choosing this option doesn’t change the appearance of the scaled frame.
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When choosing the size of your body text, you can probably go smaller than you think. Text that is too large
looks amateurish and clunky. While 12-point type is InDesign’s default type size — and looks about right on
screen — it will probably look too big in print. Start out with 10 point, then increase or decrease the size as
necessary according to the characteristics of the font and the needs of your audience.

Display type is the big type (typically 18 points and above) whose primary purpose is to be seen; it’s the bait
that lures the reader. Display type is designed to grab attention and relies on a unique, sometimes showy form
to announce and amplify the message of the text. Text type can function as display type by making it bigger,
but it seldom works the other way around. It’s also worth mentioning that while size usually indicates the
type’s intent, this is not always the case. For example, an understated headline can sometimes attract attention
by being unexpected.

Subheads allow a story to be broken down into bite-size chunks that are more visually enticing than a mass of
undifferentiated paragraphs. They provide visual relief and interest, as well as acting as signposts throughout a
book or article. Subheads may be the same size as the body text but be distinguished by a different font or
weight, or they may be a point or two bigger.

Captions help interpret an image or figure and are usually set a point or two smaller than the body text. In our
busy world, it’s the captions that the tentative reader reads before engaging fully with the body copy or moving
on.

Casing
Whereas capital letters evolved from the Romans, it wasn’t until the end of the 8th century that anything like
lowercase letters were used. Credit for their invention goes to Alcuin of York (c. 735–804), Charlemagne’s
leading adviser on ecclesiastical and educational affairs, who oversaw the standardization of ecclesiastical texts.
With the invention of the printing press in Europe around 1450 (though it existed earlier in both China and
Korea), the terms uppercase and lowercase were adopted from the wooden type cases used to hold the movable
type. The top case was for the majuscules, the bottom case for the minuscules. Today, most fonts come with
both uppercase and lowercase letters, but some are unicase, or unicameral. Trajan, by Carol Twombly (1959–),
for example, comes only in uppercase, while Bayer Universal, by Herbert Bayer (1900–1985), comes only in
lowercase — in fact, Bayer, a leading figure in the Bauhaus, advanced the idea of doing away with uppercase
letters altogether.
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All Caps
Continuous text set in unicase can be challenging to read. Text in all caps, for example, is less readable than
text in upper- and lowercase because the word shapes all look alike and are differentiated only by their length.
We recognize words as shapes — it’s the descenders and ascenders of lowercase text that allow us to instantly
identify letters. Also, text in all caps tends to look disproportionately large when set among upper- and
lowercase text; hence the need for small caps. Just as shouting doesn’t make your message any clearer, setting
text in all caps doesn’t make your message any more compelling. At the other extreme, continuous text set all
in lowercase makes it harder for the reader to distinguish one sentence from another and is really only
appropriate if you are k.d. lang, bell hooks, or e. e. cummings.

Nonetheless, all caps can be effective in headlines and subheads. Because there are no descenders, be sure to
tighten the leading (line spacing). With a serif font in all caps, you may want to loosen the letterspacing for a
sophisticated and understated look; for an all-caps sans serif font at display sizes, consider tightening the
letterspacing for a denser, more solid look.

If the text has been typed in lowercase or sentence case, you can easily convert it to all caps by using the
shortcut Cmd+Shift+K (Ctrl+Shift+K). InDesign doesn’t replace the characters themselves but changes how
they appear and print. As far as the spell checker or Find/Change are concerned, the text remains as it was.
Alternatively, you can choose Type > Change Case, which does change the text. Unfortunately, the Change
Case options are very easily tripped up. For example, Title Case capitalizes the first character of each word in
the selection, even prepositions and articles. Converting text that has been typed in all caps to sentence casing
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is even more hit-and-miss: InDesign interprets any period, question mark, or exclamation point as the end of
a sentence. This causes unexpected case changes when these characters are used in other ways, as in
abbreviations, file names, or URLs.

“To remain nameless and without specific appreciation, yet to have been of service to a valuable work and to
the small number of visually sensitive readers — this, as a rule, is the only compensation for the long, and
indeed never-ending, indenture of the typographer.”

— Jan Tschichold (1902–1974), from The Form of the Book

House styles vary when it comes to the casing of chapter headings, headlines, and subheads. Up style, in which
every major word is capitalized, is the most common approach. With down style, only the initial cap and
proper nouns are capitalized. Down style has the obvious editorial appeal that no one has to agonize over
whether a word is a “major” word and thus needs to be capitalized. Another advantage is that since more
words appear in lowercase, there are more familiar word shapes. (This book uses up style heads due to
Peachpit’s style guide.) A third approach, commonly used for product names, is camelcase, in which compound
words or phrases are written without spaces and the first letter of each compound is capped; for example,
PlayStation, PageMaker, and of course … InDesign.

If I may gripe for a moment, I don’t know why in 2018 we can’t include title casing as part of a paragraph
style or character style. If memory serves, Ventura Publisher (may it rest in peace) had this option circa 1988.
Take this a step further and you could exclude articles and prepositions for down-style casing. This would
make the styling of headlines and subheads faster and more consistent. Of course, it wouldn’t be foolproof,
but it would cut down on the drudgework. As an InDesign user, you make feature requests at the InDesign
UserVoice page: https://indesign.uservoice.com.

Small Caps
Small caps are only as tall as the x-height and so do not, like regular caps, overwhelm the upper- and
lowercase type they appear alongside. Small caps are mainly associated with serif typefaces and are nearly
always roman. Small caps have the following uses:

Acronyms, initialisms, and historical designations such as BC and AD — preferably without periods,
though house styles differ

To transition from a drop cap to the regular body text
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For abbreviations like AM and PM — with no letter spaces or periods, though it’s more contemporary to
use lowercase: 3pm, 7pm, and so on

The names of speakers in plays

If you’re using a font that lacks real small cap characters, your small caps will be regular caps scaled to the
percentage specified in the Advanced Type preferences. Because the weight of their strokes is reduced along
with their height, these software-generated or “fake” small caps appear too light when set alongside other text
at the same size. My advice is to avoid them. There are other ways to give emphasis.

Real small caps, on the other hand, are distinct characters that have been designed with their weights the same
as the full-size text.

Small caps imply that the first character of the word is going to be a regular cap and therefore bigger than the
rest. This needn’t be so. Choose OpenType All Small Caps to have all characters the same size — at the
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height of the x-height.

Glyph Positioning

With display type in all caps, the positioning of hyphens, dashes, and parentheses may require
adjustment. Hyphens are centered on the x-height, which is appropriate for lowercase letters but too
low for capitals. Hyphens, dashes, and parentheses may need to be adjusted with baseline shift.

Among the many benefits of OpenType fonts — and InDesign’s support for them — is that this
glyph positioning happens automatically. Some OpenType fonts adjust the position (or even
shape/size) of some glyphs in all-caps situations. If you format an OpenType font as all caps, the
surrounding hyphens, dashes, parentheses, braces, and brackets all shift vertically. Note, however, that
this happens only when you choose All Caps character formats, not when you key in text with Caps
Lock on.

Superscript (Superior) and Subscript (Inferior)
Superscript is typically used for ordinals in numbers or for footnotes. Subscript is used for scientific notation.
In Advanced Type preferences, you can change the size of superscripts and subscripts — expressed as a
percentage of the full-size capitals — as well as their position relative to the baseline. My preferred settings are
60% for the size of both. The superscript position I leave unchanged, but I change the subscript position to
20%.
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As with fake small caps, the problem is that you’re reducing not just the vertical scale but also the horizontal
scale. The result is that the characters look too light and too narrow when set alongside full-size characters.

With OpenType faces, rather than use the Superscript and Subscript buttons on the Control panel, choose
Superscript/Superior or Subscript/Inferior from the OpenType flyout menu. In most cases, ordinals and
superscript/superior are the same thing. These are distinct glyphs with a stroke weight the same as that of the
upper- and lowercase text. Superior figures are used for footnotes and formulas. They are the same as
numerators used in diagonal fractions, but with a higher baseline. Inferior figures sit below the baseline and
are used in chemical formulas. They are the same as denominators used in diagonal fractions but with a lower
baseline.

Underline
In days of yore, when records came on vinyl and people typed on machines called typewriters, underlining was
de rigueur for adding emphasis — but that was only because typewriters couldn’t do it any other way.
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Underlining, as every type primer will tell you, should never be used for emphasis. The underline is too heavy,
collides with the descenders, and insists on applying itself to the spaces in the selection. On this last point, if
you want the underlines to break at spaces in the text, you can use Find/Change to find a space in the
selection with Underline turned on, then replace it with a space with Underline turned off. But unless your
design unequivocally calls for this treatment, you’re better off choosing another way to give emphasis.

With the web, underlining got a new lease on life when it was adopted as the conventional way to indicate
hyperlinks. If you’re using underlining for this purpose, be sure to change the weight, the offset, and possibly
the color of the line in Underline Options. They will still look ugly, but less so.

Underlines work best when they don’t look like underlines. By adjusting the weight, offset, and color of the
underline, it’s possible to apply “highlighting” as a character style. (See Chapter 15, “Styles,” for more on
creating character styles.) Select the Overprint Fill check box if you’re applying highlighting to any color of
text other than black, to avoid the need for trapping in professional print projects.

Climate change is caused by factors such as biotic processes, variations in
solar radiation received by Earth, plate tectonics, and volcanic eruptions.
Certain human activities have been identified as primary causes of ongoing
climate change, often referred to as global warming.
UNDERLINING APPLIED AS A CHARACTER STYLE TO
INDICATE HYPERLINKS

Strikethrough
Strikethrough is used to indicate which text will be deleted as a document moves through revision cycles. If
you tweak the Strikethrough Options, the strikethrough could potentially be used as a second underline.
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Baseline Shift
Baseline shift — Option+Shift+Up Arrow or Down Arrow (Alt+Shift+Up Arrow or Down Arrow) — is used
to vertically shift the selected characters relative to the baseline of the type. It should not be used to adjust
spacing between paragraphs, which should be controlled by Space Before and Space After.

Baseline shift can be used for the following:
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Adjusting the position of bullets, ornaments, inline graphics, and such symbols as @, $, ®, ©, ™

Adjusting the position of a decorative drop cap

Manual fractions (although it’s preferable to use a fraction script or, better still, an OpenType Pro font
with real fractions)

Monetary amounts where the size of the currency symbol is reduced

Mathematical or chemical formulas

Adjusting the position of parentheses, braces, and brackets — all of which center on the lowercase x-
height, relative to the type they enclose. When used with all caps, they should center on the cap height.
(OpenType fonts make using baseline shift unnecessary because of their ability to glyph shift — that is,
adjust the position of certain characters, like opening and closing parentheses, according to whether they
are preceded or followed by an upper- or lowercase character; see “Glyph Positioning.”)

Creating type that looks like the thing it is describing

Adjusting the baseline of a type on a path, particularly around a circle

Condensed and Extended Type
The Character Formatting view of the Control panel has controls for changing the horizontal and vertical
scale of your type. Most of the time these controls are best avoided. Choose real condensed or real expanded
typefaces rather than try to fake them by adjusting the horizontal or vertical scale. Faking a condensed
typeface (squeezing the horizontal scale) or an expanded typeface (stretching the horizontal scale) makes the
character shapes look puny and the overall effect amateurish.
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Condensed type is useful when you have a lot of text to fit into a finite space; extended type can fill a defined
space with a relatively small amount of text.
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Condensed faces can make for more impactful headlines. Because the characters occupy less horizontal space
than a regular typeface, you can increase the type size and occupy more vertical space.

Condensed faces are also useful for tabular material where the space inside each cell is cramped.

Extended faces may be used for display type, and are more likely to be sans serif — like Helvetica Neue
Expanded or Univers Extended.

Horizontal or vertical scale controls are sometimes useful when using picture fonts, like Zapf Dingbats or
Wingdings, so that you can turn circular bullets into ovals, turn squares into rectangles, or create taller
triangles or longer arrows.

Typekit
Typekit is Adobe’s font subscription service that offers a curated selection of high-quality fonts from reputable
foundries. To add Typekit fonts via Typekit.com, select Add Fonts from Typekit from the Font menu or
Type menu. The browser interface helps you make informed type choices. You can specify the class of
typeface you’re looking for as well as its properties and drill down to a short list of candidates. Once synced,
the fonts show up on your font menu.

NOTE: If you’re working with equations and there are just a few, you can use a typeface like
Mathematical Pi in conjunction with baseline shift and tabs. If the document contains many equations,
consider a third-party plug-in like MathTools, available from https://movemen.com. The
InDesignSecrets website has a discussion of different approaches to formatting equations:
http://indesignsecrets.com/typesetting-math-in-indesign.php.

Not all Typekit fonts are syncable. Some are web fonts and some require purchase, but a good (and growing)
selection of fonts is available as part of your Creative Cloud subscription.
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A Typekit font looks and behaves like any other and can be printed as well as embedded in a PDF or fixed-
layout EPUB. The one limitation is that they cannot be included as part of a package. The font files
themselves are renamed and hidden from the user. This means that if you’re using Typekit fonts in an
InDesign document that you share with a colleague, they too will need a Creative Cloud subscription to sync
the fonts on their machine. But then again, they’d need that subscription just to open your files with the
current version of InDesign, so this isn’t as much of an obstacle as it might seem. Another issue that gives
some users pause is that of archiving. Because you can’t package Typekit fonts, you can’t store your own
complete archive of a project, which means you can’t let your Creative Cloud subscription lapse if you want to
work with documents that use Typekit fonts in the future.

Legibility and Readability
The related concepts of legibility and readability determine the effectiveness of your typography. Legibility
refers to how easily we can recognize a typeface. Specifically, how easy it is to discern the letters and
distinguish them from each other — as in an eye exam. Legibility is the responsibility of the typeface designer.
The typeface designer crafts the shapes, details, and negative space of the letterforms, which in turn determine
how these letters combine to make words and sentences.
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Readability refers to the ease with which we comprehend text by recognizing words and phrases as shapes. It is
the product of how the type is set and is the responsibility of the typographer. It is the typographer who,
guided by typographic rules, chooses the type, its size, leading, color, column width, and so on, to create
readable type. This means putting the reader first and leaving your ego behind — or at least confining it to a
first draft. The design of your body copy, it is said, should be “invisible.” If no one notices your type, you’re
doing a good job.
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Typekit filters allow you to search for fonts by class, recommendations, properties, and language support (not shown). In this
example, I am searching for a slab serif suitable for body text with a medium weight, standard width, high x-height, and medium
contrast.

This might make the designer sound undervalued, but while readers may not notice good typography, they will
certainly notice bad.

This view of designer as self-effacing craftsperson in service of the message is not universally held. Part of the
appeal of grunge typography, so popular in the early 1990s, was that it celebrated rather than dampened the
designer’s subjectivity. The results were, by conventional standards, often unreadable, relying instead on the
visual impact of the type to convey the meaning of the text.

Personally, I believe “the rules” of readability are a good starting point. Once learned, they can be upheld or
disregarded as you see fit. But as the saying goes: Learn the rules first before you start breaking them. If you
feel like making your type “invisible” is taking things too far, then aim for your type to not call too much
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attention to itself.

Not all typefaces are — or should be — created for readability. Many decorative faces aim to create a mood or
make a design statement. Some are deliberately challenging in terms of their readability and are arguably
more, not less, legible for that. They exist to grab attention rather than to be read continuously. It’s interesting
that type can be legible without necessarily being easily readable.

“A few hundred years of type and typography have established rules that only a fool would ignore.”

—Eric Spiekermann

However, the opposite is not true: Type cannot be readable without first being legible. Sure, you can improve
the readability of a hard-to-read typeface, but if it’s illegible, it’s always going to be hard to read.

In most cases, communication comes before style. Readability is our goal, so start with a legible typeface. But
there are some twists. For example, not all type is intended to be readable. A cynic might cite legal small print
or terms and conditions text as examples of typography where readability is deliberately compromised. There
have also been studies that prove that using ugly fonts in an educational environment can improve cognition
— presumably because they are more memorable. I think this is fascinating, but there’s enough ugliness in the

world without us adding more.1

1. www.wired.com/2011/01/the-benefit-of-ugly-fonts

READABILITY

The 15th-century (Jenson) versus the twenty-first (Open Sans). Is one more readable than the other?

One morning, when Gregor Samsa woke from troubled dreams, he found himself transformed in his bed
into a horrible vermin. He lay on his armour-like back, and if he lifted his head a little he could see his
brown belly, slightly domed and divided by arches into stiff sections. The bedding was hardly able to
cover it and seemed ready to slide off any moment. His many legs, pitifully thin compared with the size of
the rest of him, waved about helplessly as he looked.

Adobe Jenson Pro

One morning, when Gregor Samsa woke from troubled dreams, he found himself transformed in his bed
into a horrible vermin. He lay on his armour-like back, and if he lifted his head a little he could see his
brown belly, slightly domed and divided by arches into stiff sections. The bedding was hardly able to
cover it and seemed ready to slide off any moment. His many legs, pitifully thin compared with the size of
the rest of him, waved about helplessly as he looked.

Open Sans Regular

“[…] 90% of graphic designers do not know the basics of setting good text …. I am not sure why […] maybe
because colleges are frightened that students will get bored, maybe because everybody wants to be a pop-star
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designer they don’t think these things are important — well they are. A plea to young designers — learn the
basics, then your work will have the underlying authority to be subversive.”

— Jonathan Barnbrook (www.typographer.org/archive/mag-interview-barnbrook.html)

Serif vs. Sans Serif
The conventional wisdom is that in print, serif typefaces are more readable for body text than are sans serif
faces. If we buy into this assumption, what’s the reasoning? Perhaps it’s because the serifs function as rails,
guiding your eye along the line. Perhaps we perceive serif typefaces as more “human” because the transitions
of their strokes resemble calligraphy. Perhaps sans serif typefaces are less readable because the letters are
inherently more like each other, it being hard to distinguish between an uppercase I and a lowercase l, for
example.

Or perhaps the explanation is self-fulfilling. We read serif type more easily because we’re more used to reading
serif type. We could get used to anything; it just so happens that we’ve been reading serif type for centuries
and the habit is second nature.

Sans serif typefaces are the new kids on the block, relatively speaking. They weren’t invented until the early
19th century and weren’t in common usage until much later. They were invented for advertising and are, in
general, more forceful and in-your-face than serif typefaces. We’re accustomed to seeing them used as display
type, where readability is a lesser concern, because headlines and subheads are set in short bursts rather than
long passages. In fact, because their letter shapes are simpler, sans serifs may be more legible than their serifs.
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In practice, readability is more nuanced than choosing one class of typeface over another. It depends on how
the variables of type composition are handled.

In the right hands, there’s no reason why a sans serif can’t be every bit as readable as a serif typeface. In fact,
we’re accustomed to reading sans serif typefaces at small sizes, too: for captions, in classified ads, in phone
books, in timetables, on business cards, and as body text. In fact, it’s often the simplicity of a sans serif that
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makes it suitable for small text.

To put it another way, it’s less about whether the typeface has serifs or not, and more about what you do with
that typeface.

Other Readability Factors
Your choice of font is just one of several factors that work in sync to create readable type. Other factors
include but, as they say in legalese, are not limited to:

Leading (see Chapter 5).

Column measure (the relationship of type size and column width). There’s no “right” size of column
measure, as it will depend upon the nature of the text and the type of publication you’re working for, but
as a rough guide, aim for 45 to 65 characters (including the spaces) per line.

Alignment (see Chapter 8).

Margins (see Chapter 17).

Printing conditions: If the piece will be printed, what kind of paper stock will be used?

Reading conditions: This is an enormous variable over which you, the designer, have no control. You
can’t know whether your audience will be reading by candlelight, while standing on a busy commuter
train, or while soaking in the bath. Depending on the type of document you’re creating, however, you
can make an educated guess. For example, if you’re designing a bus timetable, you’ll want to forgo the
challenging grunge typography in favor of a straightforward approach.

97



NOTE: If you’re typesetting for a dyslexic audience, consider the Open Dyslexic typeface. Its
unique letter shapes are designed to help prevent confusion through flipping and swapping. You
can download it for free: opendyslexic.org.

Color and contrast: For type to be readable you need contrast between the color of the type and the
color of the background. Avoid placing type on a busy pattern, and if you opt for placing type on top of
a photograph, be aware that doing so compromises readability. What you gain in return may be worth
it, but always opt for a “quiet” part of the image.

Finally, to close this chapter, some sobering (and inspiring) words from influential graphic designer David
Carson: “Don’t mistake legibility for communication.” Following the rules of readability and legibility will
ensure against typographic failure, but it is not a guarantee of typographic success. Just because a piece of type
is legible and readable, it doesn’t always follow that people will want to read it.
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Chapter 4

Screen Typography

More unites screen typography and print typography than separates it, but type rendered in pixels is
different from type printed on paper. Reading on a screen is a different experience from reading a
physical book, magazine, or newspaper. Even though today’s modern screens offer extremely high
resolutions, equaling the crispness of type in print, there are still special considerations for preparing
type that will be read onscreen.

Throughout history, typography has both adapted to and been affected by new technologies. For example, in
the 18th century, the high contrast of John Baskerville’s transitional typeface wouldn’t have been possible
without his innovations in printing, paper, and ink.

Sabon, a typeface designed by Jan Tschichold in the 1960s, was created to look the same whether set on a
Monotype or a Linotype machine.

With desktop publishing, which started in the mid 1980s, we began to see typefaces, like Lucida and Officina,
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designed specifically for laser printing.

The first typefaces designed for the screen were Verdana and Georgia, designed by Matthew Carter in 1994.
Without the need to save paper on a physical page, Carter designed the letters wider than most body typefaces
for print and provided generous spacing between them. This made them more readable, especially on the
relatively low-resolution screens of the time. The frustrating thing for designers was having to restrict their
font choices to the limited number of “web-safe” fonts available on all computers. Today, web fonts make it
possible to embed or download remote fonts, so designers can use fonts that are not installed on the reader’s
computer. In response, many typefaces have been designed specifically for screens and made available by such
services as Google Fonts, Typekit, and Font Squirrel.

Types of Digital Publishing
InDesign supports several types of digital publishing: reflowable EPUBs, fixed-layout EPUBs, Publish
Online, interactive PDFs, and apps created for AEM (Adobe Experience Manager) Mobile. Each has its pros
and cons.

NOTE: Amazon’s Kindle has its own propriety formats, Mobi and KF8. You can use Kindle Plugin
for Adobe InDesign to convert InDesign docu–ments to these formats. Download it at
https://www.amazon.com/gp/feature.html?ie=UTF8%E2%80%8B&docId=1000234621.

Reflowable EPUBs are best suited to a continuous, linear text flow, like a novel, or to any prose with a single
text stream. The reader can exercise some control over the size and style of the type, and EPUBs can be sold
through many online retailers. The paradox of reflowable EPUBs is that the thing that makes them most
readable — the reader’s ability to change the size of type — is the same thing that so challenges the designer’s
efforts to heighten readability.

Fixed-layout EPUBs (FXL) are more appropriate for books in which the relationship of the text and image is
essential, such as children’s books or graphic novels. A fixed-layout EPUB offers a “near pixel-perfect” (some
OpenType features are not fully supported) rendition of your page, using HTML. The text is live and
searchable, but readers can’t change the font. Because each page is static, FXLs offer a degree of page design
not possible in a reflowable EPUB. At present, FXLs can’t be sold through as many outlets as reflowable
EPUBs.

InDesign and HTML

With the ability to embed fonts in HTML documents it’s possible to create great-looking type on the
web. But the focus of this chapter is on type for ebooks rather than for web pages. Although the
aesthetic considerations of ebook and web typography are the same, there are specific technical
considerations relating to web typography that are beyond the scope of this book. If you’re interested
in exporting InDesign pages to HTML5 output, check out in5, an app from Ajar Productions that
allows you to export virtually any InDesign layout as an HTML file, along with supporting CSS,
JavaScript, and image files.
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If you’re interested in learning more about using InDesign as a web prototyping tool, Michael
Murphy has a great course on Lynda.com/LinkedInLearning, “InDesign for Web Design”:
https://www.lynda.com/InDesign-tutorials/InDesign-Web-Design/105366-2.html.

Publish Online documents are similar to FXLs but offer a 100 percent faithful digital version of your InDesign
document that works on any device, and in any modern browser, without special software or the need to
install a plug-in. A Publish Online document can include all of InDesign’s interactive elements — hyperlinks,
buttons, audio and video files, multi-state objects, and even InDesign animations.

Your document is published to a unique URL, which can be shared via social media or email, and you can also
embed a Publish Online document in your website.

The limitations are that despite a document being almost impossible to discover due its unique URL, there’s
no way to prevent people from viewing the document if they have the URL. You can’t password-protect
Publish Online documents, and the documents can live on Adobe servers only. This may be a deal-breaker if
you have confidential information that needs to stay behind a firewall. Publish Online is geared toward the
individual Creative Cloud subscriber, so companies can’t upload documents to a company account. Neither
can you monetize Publish Online documents. Publish Online documents are not responsive — that is, they do
not reformat based on screen size — which may make them hard to read on a smartphone.

Interactive PDFs were poised to revolutionize online reading a few years ago, but they’ve been stalled in their
development. They remain the best choice for onscreen presentations and are still the easiest format to
distribute, but PDFs are not easy to monetize, and support for their interactive features is limited and
inconsistent on mobile devices.

From 2011 to 2016 Adobe Digital Publishing Suite (DPS) was a way for designers to produce digital,
interactive magazines using InDesign. The magazines were intended for viewing on a tablet and could be
designed and viewed in horizontal or portrait orientation — or both. Using plug-ins within InDesign,
designers could create typographically sophisticated and graphically rich “folios” either as stand-alone apps or
as periodicals.

However, when it became clear that people weren’t consuming digital magazines on tablets to the extent that
had been predicted, Adobe killed off DPS and replaced it with AEM (Adobe Experience Manager) Mobile,
an enterprise-level solution costing tens of thousands of dollars a year.

Obviously AEM was never intended for individuals and small studios, but regardless it seems its development
is stalled. For this reason, PDFs, FXLs, or Publish Online documents have become the choice of small
publishers needing more design control over their digital publications.

Choosing Type for Screens
Because of the commonalities between screen and print typography, the factors contributing to readability
discussed in Chapter 3 (and throughout this book) apply to type onscreen as well. If your project is both
screen- and print-based, consider a typeface family that works both in print and onscreen to help provide a
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consistent experience for your readers. Here are some factors that are specific to choosing type that will be
read onscreen:

Weight: A medium weight works best onscreen. Although lighter-weight typefaces may work when printed on
good-quality paper, they do not fare well as pixels.

Stroke modulation: Typefaces with an even stroke modulation are preferable because there is less risk that they
will be rendered inaccurately onscreen. Didone typefaces such as Bodoni, on the other hand, suffer in pixels
because of the strong contrast between the thin and thick parts of the stroke. At small sizes, the thin parts of
the stroke may disappear.

Serif versus sans serif: It’s often said that serif fonts are more readable than sans serif fonts. Despite many
readability studies, however, this has never been conclusively proved.

On the other hand, with low-resolution screens a sans serif type will suffer less — mainly because there’s less
to be distorted. In the past, this has led to the advice that sans serifs are better for screen type. In recent years,
increased screen resolution and the proliferation of Retina displays mean that serif faces can be rendered
equally well.

More important to readability than the serif versus sans serif issue is the interplay of such variables as line
length, line height, and typeface style and size. If you take care of everything else, either a serif or a sans serif
font will work.

That said, serifs are more commonly used for body text. This may be a self-fulfilling argument, but it’s worth
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noting that the iBooks app has six built-in serif fonts, compared to just two sans serifs, while the Kindle has
five serifs to three sans serifs.

If you opt for a serif font, choose one designed specifically for screen use, as it will have heavier, more
exaggerated serifs to compensate for the fact that fine serifs can erode at small sizes and low resolutions.

Script typefaces: A cautionary word about using script typefaces in EPUBs. Script typefaces often rely on the
application of manual kerning to ensure that certain letter combinations connect in the manner of
handwriting. Some script typefaces also use OpenType contextual alternates in certain letter combinations.
Support for both is inconsistent across e-readers, and you may find your refinements lost in the exported
EPUB.

Enlarged apertures: Choose a typeface with open letterforms, reducing the likelihood of the counters closing in
on themselves at small sizes.

X-height: In all typography, readability is enhanced by a high x-height, but this is especially true of type
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onscreen. Type with a high x-height appears larger at the same pixel size compared to type with smaller x-
heights. Most of the information that we read is in the lowercase letters, and because type with a high x-
height has relatively short ascenders and descenders, the most important parts of the letters occupy as much of
the body size as possible.

Letterspacing: Because pixels tend to mush the edges of letters, type for screen use typically benefits from being
slightly more spaced than its print equivalent.

For reflowable EPUBs this is a function of type choice rather than of tinkering with the spacing in InDesign.
When you export to EPUB, only the font metrics that are part of the typeface affect the letter spacing.
Optical kerning, manual kerning, and tracking are ignored, as are any adjustments you may have made to the
letter spacing values in the Justification options. If you absolutely must keep a certain font and formatting,
there is the radical solution of rasterizing the type. To do this, put the type in its own frame. Copy the text,
and choose Object Export Options. Paste the text in the alt text field, and in the EPUB and HTML field
choose Rasterize Container. The downside is that it won’t thereafter be editable as text.

For this reason, choose a typeface with good built-in letterspacing. If you need to adjust the letterspacing, you
can crack open the exported EPUB with a utility such as ePub Unzip and edit the CSS file, adding the
letterspacing attribute. Spacing values are expressed in ems — that is, they are relative to the size of the type.
For more information see https://www.mobileread.com/forums/showthread.php?t=55681.

Kerning and tracking are different propositions in FXLs. The choice of automatic kerning is honored, as are
tracking adjustments, and letterspacing adjustments made through the Justification options. Manual kerning,
on the other hand, is ignored.
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Other design attributes: Because of the lower resolution of a digital display compared to a printed surface, some
design attributes are not suited to the screen. For example, closely fit features (such as the counters of “e” or
“a”) can visually fill in. Also, onscreen, slight angles to stems may appear jagged rather than graceful.

Font Embedding
In a reflowable EPUB, for your reader to see the fonts you intend, you have to embed them. This seems like
something you’d obviously want to do, but there are some downsides to embedding fonts.

Type 1 fonts don’t work. Those old Postscript fonts that you may still have on your computer will need
to be replaced by OpenType versions if you want them to work in an EPUB.

Figuring out the licensing of the fonts can be daunting and, potentially, expensive.

At present, e-reader support for embedded fonts is inconsistent.

Another argument for not embedding fonts is that the fonts on the device have been optimized for that
device. Why overwrite them with fonts of your own?

But don’t let these arguments put you off embedding your fonts, because:

It’s easy to avoid Type 1 fonts. Just stick to OpenType and TrueType. If you’re a Creative Cloud
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subscriber, you can sync OpenType fonts through Typekit and use them in both print and digital
publications, with no extra licensing fees.

There are plenty of fonts with an open license. Services such as Google Fonts and Font Squirrel offer
hundreds of fonts that are free for commercial use. All Typekit fonts and Adobe fonts are licensed for
use in EPUBs.

In the future, we’ll have more control over our EPUB typography, and someday, probably very soon,
we’ll look back on these times of font embedding problems as the dark ages. Things are only going to
get better. Embedding your fonts now helps raise the bar of typographic standards, sending a message to
device makers that good typography and creative control are important.
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For FXLs, absolute positioning of the elements on the page requires that fonts be embedded. As with
reflowable EPUBs, they must be OpenType or TrueType.

Preparing Type for Screens
Here are some special considerations for setting type for screen. When working with PDFs, FXLs, and
Publish Online documents, you’re mainly concerned with the larger viewing distance, the properties of
(mostly) horizontal and backlit screens, and how these differ from physical pages. With reflowable EPUBs,
there are more variables and more technical limitations, and consequently a greater need to simplify.

Sizing Screen Type
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The size of body type should be significantly larger onscreen than in print. Historically, this was in large part
due to the lower resolutions of screens versus paper. Modern displays have significantly, if not entirely,
reduced this differential, but it’s still the case that we view a computer monitor from a greater distance than
we do a book or magazine, and the farther away your text, the bigger it needs to be. Reading distance on a
desktop or laptop computer doesn’t vary much, but with a handheld device it can vary significantly. You might
use your tablet on a desk, on your knee, on the sofa, or in front of your face on a crowded train. This means a
variety of reading distances, some of them greater than the reading distance for a newspaper or magazine. In
order to make the type readable in all instances, the farthest reading distance should define the type size and,
in particular, the body text size.

In a reflowable EPUB, type size can be adjusted by the reader. The iBooks app, for instance, offers a 12-step
range of size adjustment. Keep in mind that the font size at which an EPUB opens reflects the size at which it
was last set.
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When you export your InDesign document to EPUB, 12 points is translated to 1 em in the CSS. When
iBooks looks at the CSS, however, it translates 1 em to 16 pixels, which is regarded as a comfortable viewing
size onscreen. For this reason, many people producing EPUBs will leave their base font size in InDesign at 12
points. However, having 16 points as your middle range makes the smallest view size not small enough and
the largest view size too big. For that reason, consider setting your body text at .8 em — or 9.6 points.
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Other readers display 1 em at different sizes. For example, in Adobe Digital Editions, 1 em is larger, making
the type size issue a moving target — but ultimately the type size is the reader’s choice.

In FXLs, the type is not responsive. For comfortable reading, aim for a body size of from 14 to 16 points.

Scaling Type
Just as with print, size shifts onscreen should be clear — to establish hierarchy. With a reflowable EPUB, it is
the ratio of the sizes that is most important. Here are three possible approaches:

The traditional type scale

The proportions of the golden ratio: 1:1.6, which is very similar to the type scale

Size type according to a Fibonacci sequence, where the size of the next number is the sum of the two
preceding numbers

Each could serve as a starting point in determining the scale relationship between different levels of hierarchy.
In practice, large type becomes problematic in a reflowable document, resulting in unsightly line breaks when
the type is scaled up.
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Because of the difference between the smallest and largest view sizes, it’s best to work within a limited range
of type sizes so that the type remains readable at all sizes. For this reason, don’t rely exclusively on size to
convey hierarchy, but combine it with other attributes such as color, font style, and paragraph spacing.

Leading
In a reflowable EPUB, leading values are converted to ems in the exported CSS relative to the type size. For
example, a type size of 12 pt and a leading of 18 pt would result in a line height of 1.5 em.

Because leading is treated as a relative rather than absolute value, it makes sense to use Auto Leading. You can
increase the relative size of Auto Leading in the Justification options. A value of 140% results in a line height
of 1.4, which is a comfortable line height for body text.

In an FXL, because the designer can control the column width, leading should be approached in the same way
as for a print project, with longer lines requiring proportionally more leading, and narrower columns requiring
less.

For a more thorough discussion of leading, see Chapter 5.
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Color and Contrast
For a reflowable EPUB, the color of the background is determined by the reader. But you can set the color of
the type. Color doesn’t cost more, but that doesn’t mean you should overuse it. Color is best used sparingly —
for accent. If you find the contrast of backlit screens a bit too bright, for a comfortable reading experience
choose a gray text, such as RGB 51, 51, 51, or Hex #333333. Of course, when using color, define it as RGB
rather than CMYK ink.

To check the contrast of your color and background, you can use the Colour Contrast Analyser. EPUB 3
accessibility guidelines recommend a contrast ratio of 7:1 between text and background. For more information
see https://developer.paciellogroup.com/resources/contrastanalyser.

Page and Margin Sizes
For reflowable EPUBs, the size of the InDesign document is almost irrelevant. It’s not about layout, but
rather about the flow.

Web and Mobile Intent

Reflecting its print heritage, InDesign’s default intent, which you specify in the New Document
dialog box, is Print. Choosing either Web or Mobile changes the following:

The page sizes are either common screen sizes (Web) or common device resolutions (Mobile).

113

https://developer.paciellogroup.com/resources/contrastanalyser


Primary Text Frame is selected for Mobile, but not for Web.

The Facing Pages option is deselected.

The colors in the Swatches panel are RGB rather than CMYK.

The Transparency blend space is Document RGB.

The unit of measurement changes to pixels. However, the type size and leading remain in points, as
do the strokes on frames. One point equals one pixel, and you can, if you wish, specify your type in
pixels (px) and it will automatically convert to points (pt).

If repurposing a print document, you can leave the document size as is. If you’re creating an EPUB from
scratch, on the other hand, you can set up your InDesign document to give a rough approximation of how
things will look onscreen:

Choose a document size that is the physical size of an iPad screen: 148 × 197mm (5.8 × 7.8 inches).

Select Primary Text Frame to make it easier to establish a continuous text flow.

Leave the number of columns at 1. If you want a multi-–column layout you need an FXL or a Publish
Online document. Reflowable EPUBs are normally viewed in portrait orientation. Although tablets
provide a two-–column view in landscape orientation, this is not the same as InDesign spreads.

Set the margins at 20 mm (0.78 inch) — the size of the margins in the iBooks app. Most e-readers have
margins around the content — and changing the Page Margin options in the CSS export options
doesn’t change these. Unlike print books, where the inside margins and outsides margins may be set
differently, EPUB margins are uniform.

Turn on Smart Text Reflow (Preferences > Type) to adjust the number of pages in order to
accommodate the length of your text.

Note that master pages are irrelevant and any items on master pages are ignored when exporting to
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reflowable EPUB.

If you’re creating FXLs, they will most likely be viewed on an iPad. The iPad screen is 2048 × 1536 (or
1024 × 768 pixels for older models), an aspect ratio of 4:3. This can be in either vertical or horizontal
orientation.

You’ll want the margins to be uniform — at whatever size you want. There are no built-in margins, and
artwork can go to the edge of the screen.

The Importance of Styles
Reflowable EPUBs require that you use styles consistently — to build a navigable table of contents, to control
how pages and sections break, and to avoid local overrides being exported as CSS classes, which will bloat the
size of your output and make the CSS harder to edit. Chapter 15 goes into styles in depth. In the meantime,
here are some tips for working with styles in an EPUB:

Create a paragraph style for the body text, select all the text, and then apply your style to all the text.
You can restyle the heads and subheads afterwards.

Establish parent–child relationships with your styles using the Based On option. That way, if you need
to experiment with a different look, editing the parent style will affect all styles based on it.

Avoid local formatting. Instead, create character styles to give emphasis — be it bold, italic, color, or
whatever.

Character styles should inherit most of their formats from the paragraph to which they are applied.
Leave most of the attributes blank when you create the style.

TIP: Make a preflight profile that flags overrides in your document.

When you place text from Word, it may contain local overrides. If this local formatting is required,
convert it to a character style using Find/Change.

Use InDesign’s Export Tagging feature to map InDesign styles to HTML and CSS tags. This ensures
that the EPUB conforms to web standards and that your heads and subheads end up as true hierarchical
HTML tags: h1, h2, h3, and so on. You can do this on a style-by-style basis, but it’s quicker to address
all styles in one go with Edit All Export Tags. Provide every style with a tagging rule for EPUB and
HTML — use h1 to h6 for headings.
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Don’t use spaces or odd characters in file names or style names. Stick to letters, numbers, and
underscores. If you are repurposing a print document and need to rename the styles, you can use the
Rename Styles script by Peter Kahrel, located at www.kahrel.plus.com/indesign/rename_styles.html.

Use the Table of Contents feature to create your navigable table of contents. If you don’t want the table
of contents as part of the text flow, place it on the document’s pasteboard.

Threading Text
Because reflowable EPUBs are essentially a scroll of text, keep your content in a single-threaded story.

To keep your images with their associated body text, anchor them within the text frame. Create an empty
paragraph with Auto Leading and base a paragraph style upon this. Images that are not anchored will appear
at the end of the EPUB. For images that have captions, group the image with their captions and anchor the
grouped objects. (See Chapter 15 for more details.)

TIP: The free MergeTextFrames script from Ajar Productions can be used to rethread frames of a
story that’s been cut into independent text frames. You can find it at
https://ajarproductions.com/blog/2017/07/17/merge-textframes-for-indesign-updated-with-
highly-requested-features.

It may not be possible to have everything in a single threaded story, in which case you can use the Articles
panel to determine the order of different sections within the book.

Alignment
For reflowable EPUBs, using left alignment rather than justified avoids the problem of gappy text. At large
view sizes, the text may have a very uneven rag, but this is the lesser of the evils. Unfortunately, InDesign’s
hyphenation features won’t help you. There’s no control over how hyphenation happens in an EPUB —
beyond turning it on or off — so turning hyphenation off is the best option.

Optical Margin Alignment and hanging punctuation are ignored in a reflowable EPUB, but they are honored
in an FXL.

Indents and Paragraph Spacing
In print, first-line indents are favored over paragraph spacing for continuous prose because they’re more
economical in terms of space. Over the course of a 60,000-word novel, using first-line indents rather than
having space between paragraphs saves a lot of paper.

Because EPUBs can be as long as we want, should we continue to use first-line indents when, arguably,
paragraph spacing more clearly delineates the paragraphs? Ultimately, it’s down to personal preference, but to
my eye, text that is spaced rather than indented at the beginning of every paragraph doesn’t have the same
cohesion.

116

http://www.kahrel.plus.com/indesign/rename_styles.html
https://ajarproductions.com/blog/2017/07/17/merge-textframes-for-indesign-updated-with-highly-requested-features


I prefer indents, though for a different type of book — something that is instructional rather than literature —
spacing will work better. Whatever method you choose, use either one or the other — definitely not both
together.

In InDesign, you specify first-line indents and paragraph spacing in pixels — an absolute amount. To make
these values relative to the type size, you’ll need to edit the CSS and express the properties in ems.

For first-line indents, edit the text-indent property. Slightly larger indents than in print are preferable —
equivalent to the line height.

If you opt to delineate your paragraphs with spacing, use space before or space after in your paragraph styles.
Don’t add extra return characters. In print and FXL, even though it’s a bad idea, you can get away with this
— up to a point. Reflowable EPUBs are entirely unforgiving: white space in HTML is collapsed and multiple
paragraph returns are converted to one.

To express paragraph spacing in ems, edit the margin-top if you used space before, or the margin-bottom if
you used space after. For a thorough discussion of indents and paragraph spacing, see Chapter 9.

Controlling Breaks
To create page breaks in a reflowable EPUB, use Keep Options to start chapters on a new page. (See Chapter
10.) When you export to reflowable EPUB, you can choose to split the document based on a specified
paragraph style; if you want more than one paragraph style to contain a page break, choose Based on
Paragraph Style Export Tags. This will break the InDesign document into separate HTML files based on
their paragraph style.
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For longer projects with more graphics, you have the option of breaking your document into chapter-length
chunks and combining them as a book — but unless you’re dealing with a large, unwieldy document,
“booking” the project introduces an unnecessary level of complexity.

When it comes to line breaks, avoid forced line breaks. Although these might work visually in print, they will
wreak havoc in the EPUB, where the flow of the text will be determined by the reader’s font size. You can
select Remove Forced Line Breaks in Export Options, but it’s also a good idea to get into the habit of not
pressing Shift+Return (Shift+Enter).

To keep words together, use nonbreaking spaces. Neither the No Break attribute nor Balance Ragged Lines is
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honored in a reflowable EPUB.

Controlling Widows, Orphans, and Runts
You can, to a limited extent, control widows and orphans by specifying in Keep Options that you want at least
two lines at the start and end of every paragraph.

Hyphenation in EPUBs

The best way to handle hyphenation in a reflowable EPUB is to turn it off in InDesign. This is done
in Paragraph Style Options (see Chapter 10).

Resist any temptation to force a hyphen break with a hard hyphen, as this becomes a permanent
feature in the word even when it’s not needed.

Hyphenation presents a different sort of problem in FXL EPUBs. Here, you have access to the full
range of hyphenation options, so hyphenation becomes a viable choice — especially when working
with justified text. However, hyphenated words are exported with a hard hyphen character. This will
look OK, but it means the text will no longer be searchable as a whole word. That’s less likely to be a
problem if you choose not to hyphenate capitalized words.

You can’t control runts — as you would in print — by using a GREP style to apply a No Break character style
to a specified number of characters at the end of a paragraph. But you can run a GREP Find/Change to
replace the space between the last two words of each body text paragraph with a nonbreaking space. This is
honored in iBooks, but not in all e-readers.

The Keep With Next {number} lines option doesn’t work to keep a subhead with the text that follows. If your
document has a lot of subheads, consider using run-in heads created with a nested style. This will prevent the
subhead and the text that follows from being separated.

Typographic Details
A number of typographic compromises and adjustments have to be made when you’re working with
reflowable EPUBs. Some are simply the consequence of working in a different medium, but most stem from
the fact that although OpenType fonts are supported, most OpenType extended typographic features are not
(see Chapter 8). Here are the things to look out for:

Small caps: On some reading devices, type in small caps converts back to lowercase. To avoid this, actually type
the text as ALL CAPS and apply a character style to reduce the caps by a chosen percentage — say, 70%. The
EPUB will generate a span with the font-variant:small-caps property. However, these are the same
as synthetic small caps and look obviously fake. Support for real OpenType small caps is inconsistent. If you
have the option, use a separate complementary small cap font, much like the Expert Sets that were popular in
the ‘90s. Relatively few fonts have a companion small cap font, but one that does is Alegreya.
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Drop caps are a time-honored device for signaling the starting point of a chapter or section. They also provide
graphic interest in a sea of text. But they are handled inconsistently across e-readers.

Another problem is that drop caps are usually combined with small caps, with the first few words after the
drop cap set in small caps to create a visual transition from big to small. As mentioned, small caps don’t fare
well in an EPUB.

Personally, I think the best solution is to avoid drop caps in EPUBs. A drop cap is, after all, just one solution
to a section opening. No one’s going miss a drop cap if it’s not there, just so long as there is a clear visual cue
— like no first-line indent and a space above — that the reader should start there. This is an EPUB. It’s not a
medieval manuscript. We don’t need to shoehorn a graphic solution born out of a particular problem into
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another, entirely different situation in which it has no historical relevance.

Oldstyle numerals: Some OpenType fonts give us the option of using oldstyle numerals as an alternative to the
default lining numerals. However, these revert to the default numbering style in the EPUB. If oldstyle
numerals are important to you, choose a typeface that has them as the default numbering style.

Fractions: OpenType fractions are not supported in either reflowable EPUBS or FXL. Your best option is to
choose a fraction glyph — which you can access through InDesign’s Glyphs panel. The range of these will
vary from typeface to typeface. If your document calls for many fractions, the number of available fraction
glyphs will be a factor in your choice of typeface.

In an FXL, a fraction glyph is still your best choice, but you can also generate a synthetic fraction either
manually or using the popular Proper Fraction script (see Chapter 8). If there is no fraction glyph available
and you’re using OpenType fractions, you can convert the fraction to outlines (Type > Create Outlines or
Cmd+Shift+O/Ctrl+Shift+O) before exporting the document.

White space characters: Extras spaces and tabs are ignored in a reflowable EPUB. InDesign’s white space
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characters (see Chapter 8) are not ignored, but neither are they honored for their specific widths — instead,
they are converted to regular spaces.

For those rare times when you need multiple spaces, you can use multiple nonbreaking spaces, which are not
collapsed in the resulting EPUB.

TIP: Turn on hidden characters. Keep this on to show you where you might have empty paragraphs,
double spaces, space at the end of a paragraph/heading, tabs, and soft breaks.

Leader dots (for example, in a table of contents) are ignored in an FXL if the space they fill is created with a
right-indent tab. If you use a right tab (as opposed to a right-indent tab), then the leader dots show up.

Paragraph rules above and below are ignored when exported to a reflowable EPUB. You can edit the CSS to
add the rules by adding border properties to the paragraph.

Paragraph rules do show up as expected in an FXL.

Bullets and numbering: When you export bulleted and numbered lists to an EPUB, there is the choice of
mapping them to a list (unordered list for bullets and ordered lists for numbers) or converting them to text.

Mapping to an unordered list loses the character style applied to the bullet. You don’t need to convert bullets
or numbers to text in InDesign; rather, let the EPUB export options handle this.

▄

Reading on a screen is different from reading type on a printed page, but not so different. It’s just a matter of
melding the traditional, commonsense rules of good typography with an understanding of the specific
qualities of pixels and screens versus those of print and paper. For those screen documents that are pixel-
perfect (or near pixel-perfect) renditions of your InDesign document (FXLs, PDFs, and Publish Online
documents), it’s mainly about your choice of font and making sure the body type is at a comfortable reading
size for your audience. For reflowable EPUBs it’s more a matter of humbling yourself before the limitations of
current technologies, whilst embracing the immense gains in convenience.
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Chapter 5

Leading

Leading (pronounced “ledding”) is the space between lines of type. The term comes from the days of
hot-metal typesetting, when thin strips of lead, known as reglets, were inserted by hand between the
lines of type to add vertical space. Lines of type without these strips of lead were — and still are —
referred to as “set solid.” Leading plays a big part in the readability of text. Body text is usually made
more readable by a positive amount of leading (a value greater than the point size of the type).
Headlines and display type, however, may benefit from negative leading. When it comes to screen
type, leading is usually referred to as line height.

Leading Size
When it comes to leading, there’s no “one size fits all.” Tight leading increases the density of the type. Done
well, it gives your type authority, commanding the reader’s serious attention. But if you go too tight, your type
looks claustrophobic, and the descenders of one line collide with the ascenders of the next. Loose leading, on
the other hand, can create a more laidback or luxurious look. But if it’s too loose, the lines of type look like
individual strips rather than cohesive paragraphs and the result looks sloppy and is less readable. This is
especially true if there is spacing between the paragraphs and the leading is similar to, or even greater than,
that space.

Leads displayed at a printing museum

Leading is measured in points from one baseline to the next. The leading value includes the point size of the
typeface and the actual space between the lines. Thus, 10-point type with 12 points of leading really means
two points of space between each line. This is written 10/12, and spoken “10 on 12.” Other common type size
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and leading combinations for print body text are 9/11, 11/13, and 12/15.

Bad leading makes your text harder to read because the eye has trouble locating the next line of type.
Choosing an appropriate amount of leading depends on several variables:

The nature of the text. While text intended for continuous reading benefits from some breathing space,
a short burst of advertising copy or a title might be more effective if the lines are tightly leaded. Leading
has more effect on document length than does point size, so if text needs to fit in a fixed number of
pages, adjust the leading first.

Type size. Bigger type sizes require proportionally less leading. With display sizes, the same relative
amount of space between the lines appears larger, so much so that it’s common to use negative leading
for display type. On the other hand, smaller type sizes require proportionally more leading, to offset the
reduced readability of small settings.

The width of the column. Increase leading as you increase column width, or measure. Increasing the
leading anywhere from 0.5 point to 2 points improves readability by keeping the lines distinct and
preventing the eye from dropping off to the line below or doubling back to reread the same line.
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The width of the column gutters. Leading, like all type attributes, needs to work in harmony with
everything else on the page. The width of the column gutters should be the same as the leading value or
a multiple thereof. If the gutters are too small, there will be a tendency to read across the columns; too
large and the separate columns will look unconnected.

TIP: A convenient rule of thumb for determining leading is to take the width of a column in
picas and divide it by the size of the type, then round the result to the nearest half point. For
example, 10-point type on a 24-pica measure yields a leading value of 2.4. This is rounded up
to 2.5 and expressed as 12.5 (the lead added to the point size).

The size of the word spaces. A general rule is that your leading should be wider than your word spaces
to ensure that the eye moves along the line rather than down the lines. Justified type in narrow columns,
such as in newspapers, may result in word spaces larger than the leading. This causes the eye to jump to
the next line rather than to the next word. In such situations, extra leading ensures that the space
between the lines is at least as wide as the space between the words. Better still, don’t set justified type in
narrow columns.

The color of the background. We’re used to reading black type on white paper, so when we use the
opposite, we’re guaranteed to get attention. However, reversed type tends to “sparkle,” making it harder
to read. A slight increase in leading can compensate.
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A leading gauge lets you measure the leading value on a printed piece.

The characteristics of the typeface. Typefaces with larger x-heights are perceived as bigger than other
typefaces at equivalent sizes. The lowercase letters are large relative to the size of the overall character
and thus require more leading. Typefaces with lower x-heights are space saving. Their ascenders and
descenders are bigger relative to the lowercase letters, so they give the impression of more white space
between lines of type.

Didone (also called Modern) typefaces that have a strong vertical stress, like Bodoni, guide the eye down
the page rather than across the line. Adding more leading with these typefaces keeps the eye tracking
horizontally rather than vertically.

Leading or Line Height?

Leading is a printing term; web designers use the term line height. If you’re using InDesign to
create documents for screen — screen PDFs, Publish Online documents, and fixed layout
EPUBs — you can continue to call it leading. So long as you have control over type size and
column width, the principles are the same. Although without the constraints of working with a
fixed number of pages, you can err on the side of being more generous. However, when creating
reflowable EPUBs, where type size and column width are variable, leading — referred to as line
height — should be increased. Accessibility guidelines recommend as much as 150 percent of
the type size, but one size does not fit all, and line height needs to be considered alongside
factors like the x-height and characteristics of your typeface, as well as the needs and
expectations of your audience.

Display typefaces with low x-heights suggest tighter leading, but tighter leading might cause the
ascenders and descenders to collide. Much depends on the characters themselves. If you’re working on
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display type, rewording — if you have editorial license — might make all the difference. Let common
sense prevail, and be open to the possibility that colliding ascenders and descenders might even look
good in certain situations.

Typefaces with small x-heights appear to have more horizontal space between lines and thus require less
leading.

Bold and Semibold typefaces benefit from extra leading to prevent the type color — the density of the
letterforms as a block — from appearing too heavy.

Type in all caps requires less leading because the absence of descenders makes the lines appear farther
apart.
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Avoid Auto Leading (Most of the Time)
Auto Leading is a relatively new concept, emerging with desktop publishing in the mid-’80s and the need for
programs to apply some default leading value. InDesign’s Auto Leading value is by default 120 percent of the
type size, although you can change this in Justification options, found in the menus of the Paragraph panel
and Control panel. You can spot the use of Auto Leading on the Control panel or Character panel because
the value is in parentheses.

Leading Shortcuts
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To tighten the leading of a selected range of text: Option+Up Arrow (Alt+Up Arrow)

To loosen the leading: Option+Down Arrow (Alt+Down Arrow)

The increment is determined in the Size/Leading field in the Units & Increments preferences. To
increase or decrease the leading value by five times this increment, press Cmd+Option+Up Arrow
(Ctrl+Alt+Up Arrow) or Cmd+Option+Down Arrow (Ctrl+Alt+Down Arrow).

Although Auto Leading just about works for body text, it usually looks awful applied to display type, causing
the lines to appear too far apart. Auto Leading is one of those default, works-OK-most-of-the-time-if-all-
you’re-doing-is-designing-a-newsletter-for-the-local-scout-troop features. It’s not a tool of the professional
designer.

The best thing you can say about Auto Leading is that it’s convenient. You can change your text size as often
as you like and your type will always be readable. As your font size increases or decreases, so does your leading.

This may sound like a good idea, but Auto Leading is actually proportional to the biggest piece of type in the
paragraph. This means that if you have just one character larger than the rest of the paragraph, your leading
value on that line will be 120 percent of that character. Here’s a common scenario: You select the type by
dragging and unknowingly exclude the hidden paragraph mark at the end of the paragraph. You reduce the
size of the type, but not the size of the paragraph mark. This results in the last line of the paragraph having
more leading than the rest of the paragraph.

You can fix this problem by removing overrides from the paragraph’s formatting: With your cursor in the
paragraph, click the Clear Overrides button  on the Control panel (with the Paragraph Formatting
controls showing) or the Paragraph Styles panel.

But as everyone’s grandmother used to say, an ounce of prevention is worth a pound of cure. To avoid
problems with Auto Leading, use paragraph styles, rather than manually selecting the text, to apply text
formats. Paragraph styles are applied to the entire paragraph, including end-of-paragraph symbols, regardless
of what’s selected.

129



If you prefer to manually format an entire paragraph — and that’s fine while you’re in the exploratory stages
— don’t drag over the text, but instead select paragraphs with four clicks. This ensures that the paragraph
mark is part of the selection and so takes on the same formats.

Another preventative measure is to work with hidden characters shown (Type > Show Hidden Characters, or
Cmd+Option+I/Ctrl+Alt+I). That way, you can see exactly what is — and what isn’t — selected.

Best of all, avoid Auto Leading altogether. Its name sounds like it should make things easier, but in reality,
it’ll come back to bite you. If you’re using 10-point type, Auto Leading is 12 points, a nice easy number to
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work with. However, if you’re working with 11-point type, then your leading value is 13.2, which is difficult
to calculate in multiples if you intend to work with a grid — see Chapter 17, “Page Geometry, Grids, and
White Space.” In a nutshell, Auto Leading is OK when you’re experimenting with type at different sizes, but
once you’ve decided on your font, Auto Leading doesn’t give you the control you need and you should switch
to a fixed leading value. If you see parentheses around the leading value, change it to an absolute number so
that you’re in control.

Auto Leading and Inline Graphics
Auto Leading does have a legitimate use: when you’re using inline objects. These are frames (usually, but not
exclusively, picture frames) that are dragged or pasted into a blank paragraph in the text and thereafter move
with the text flow. If the text makes specific reference to figures above or below, those figures can be inline
graphics, so the relationship between text and graphic is never disrupted by edits to the text. Inline graphics
are a hybrid of text and graphics: You control their vertical spacing with leading. Auto Leading ensures there’s
always enough space for the graphic on the line, because the leading value increases or decreases according to
the height of the frame containing the graphic. When working with inline graphics, make a paragraph style
with a leading value of Auto (you may wish to adjust the percentage of the Auto Leading) and apply this to
the blank-line paragraphs into which the graphics are dragged or pasted.
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Auto Leading in EPUBs
In a reflowable EPUB, the line spacing is referred to as line height rather than leading, but if you’re creating
EPUBs in InDesign it is the leading value that determines the line height. The W3C accessibility guidelines
recommend a line height of 1.5 ems. Although this is a good starting point, it’s not a figure that should be
adhered to slavishly. While it’s broadly true that line height onscreen should be more than its equivalent in
print (in part because line lengths onscreen tend to be longer), all the factors discussed above are as applicable
to screen typography as they are to print typography.
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In a reflowable EPUB, leading values in points are converted to ems in the exported CSS. Ems are relative to
the type size.

Because type size in EPUBs is user determined, Auto Leading is preferable to fixed leading to ensure that the
line height is always bigger than the type size. The relative size of Auto Leading can be adjusted in the
Justification options in the paragraph style options. A value of 140% results in a line height of 1.4 em. In a
fixed-layout EPUB, because the designer controls the point size and column width, leading should be handled
in the same way as in print documents.

The “Apply Leading to Entire Paragraphs” Preference
Whether you’re working with Auto Leading or absolute leading, the height of a line is determined by the
largest piece of type on that line. This can cause inconsistent leading if you mistakenly have one character
bigger than the rest. You can change this behavior in your Type preferences by selecting Apply Leading to
Entire Paragraphs. This means only one leading value can be applied to any given paragraph. Note that
changing to this setting does not affect the leading in existing text.
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If you can’t remember the last time you needed to change the leading of a single line of a paragraph, then you
can turn on this “safety” feature. But if, like me, you feel it takes away user discretion, then leave it off. Most
of the time we want only one leading value per paragraph, but there are occasions — particularly when
working with display type — when we need to control leading line by line. In such situations, we want leading
values to give the optical effect of consistency — something not possible with this preference turned on.

Keep It Consistent, Except …
Leading, like much in typography, is about rhythm, and as with a piece of music, you want your rhythm to be
steady and unfaltering. The best way to achieve this is to set the leading values within paragraph styles. Should
you need to change the leading values, you can edit the style definition rather than work on the text locally.

Baseline Options

Leading also shows up as an option in the mysterious and often overlooked First Baseline Options,
which are a part of the Text Frame Options (Cmd+B [Ctrl+B]). Choose this option and input the
leading value to start the first line of text at that distance from the top of the frame inset. For more on
Baseline Options, see Chapter 6.

Skip by Leading

There’s an overlooked preference that determines how leading is affected by a text wrap. Choose
Preferences > Composition and select Skip by Leading to make text below a wrap object move to the
next available leading increment (this is the default). The purpose of this is to achieve cross-alignment
of your baselines. This sounds like a good idea, but Skip by Leading works only with the Jump Object
style of text wrap. Also, if the wrap object is at the top of the column, the preference is ignored.

Although it won’t do any harm to have Skip by Leading turned on, it has little benefit. You’re better
off using a baseline grid to achieve the same effect. Nevertheless, it’s good to be aware of this
preference because it explains why there is sometimes extra space below a text wrap object.
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When it comes to fixing widows and orphans, don’t mess with the leading. You have other tricks up your
sleeve — rewriting, tracking, adjusting word and letter spacing, discretionary hyphens, forced line breaks — to
fix such problems. Tempting though it may be to tighten the leading a little here and there, your document
will suffer if you do. Keep your body text leading consistent; otherwise, the rhythm of your type will wander
like the beat of a distracted drummer.
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Also, don’t be tempted to go for the quick ‘n’ dirty solution of using vertical alignment, which increases the
leading in a short column to make it bottom out (that is, end on the same baseline as other columns). While
columns of uniform depth are preferable in continuous prose, InDesign can achieve this with the Balance
Columns feature, which adjusts the height of all columns rather than just extend the shortest one.

There may be times when you need to relax consistency in favor of optical leading and tweak the leading of
individual lines to make the leading appear more consistent. Such a situation may arise in display type if one
line lacks descenders.

When Leading Gets Ignored
There are two scenarios when your leading value is overruled:

Baseline grid. If your text is aligned to a baseline grid, the grid increment takes precedence over your leading
value. For example, if you have a 12-point baseline grid and you increase the leading of text aligned to that
grid to 13 points, the leading rounds up to the next grid increment of 24 points. See Chapter 17 for more
details.

Vertical justification. The General tab of the Text Frame Options dialog (Cmd/Ctrl+B) contains the Align
pop-up menu, which you can use to force your text to vertically align within its text frame. Choose Align >
Justify, and the leading value becomes irrelevant. The text fills the vertical space of the frame, regardless of
how much space it has to add between the lines to do so — almost always a bad idea. To use vertical
justification without overriding your leading values (a slightly better option), increase the Paragraph Spacing
Limit so that InDesign can add space between the paragraphs instead of between the lines of text. See
Chapter 6, “Alignment.”
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▄

Leading is one of the most important factors contributing to the readability of text. It ain’t rocket science, but
there are a number of variables to consider. While there’s no single “right” leading value, there are plenty of
inappropriate amounts. To sum it up: Avoid Auto Leading (except for inline graphics and EPUBs), think
about the purpose — as well as the characteristics — of the type you’re working with, and exercise a strong
degree of common sense. And always trust your eyes.
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Chapter 6

Alignment

Usually when we speak of the alignment of type, we’re referring to the horizontal position of text on
the page. Each of the alignment options — left, center, right, and justified — creates its own vibe, has
its own strengths, and asks to be treated in particular ways. In this chapter, we’ll look at when and how
to use each method of alignment, as well as how to avoid the common shortcomings associated with
each. We’ll also take a look at how to vertically align type within a frame.

Horizontal Alignment
First, let’s define our terms. What InDesign refers to as Left alignment is commonly referred to as ragged right
or flush left. What InDesign refers to as Left Justify is commonly referred to simply as justified. Justified means
that all lines of the paragraph are the same length, except the last line. InDesign also offers two other flavors
of justified type, which have limited utility: Center Justify and Full Justify. The difference between them is the
way the last line of the paragraph is handled.

In broad terms, ragged can refer to left-, center-, or right-aligned type, the paragraphs of which have lines of
differing lengths. If you’re working in print with facing-pages documents, there are two more alignment types:
“Align towards spine” aligns text on a left-hand page so that it is right aligned (with the smooth edge toward
the spine). If the same text moves to a right-hand page, it becomes left aligned. “Align away from spine” does
the opposite: Text on a left-hand page is left aligned, while text on a right-hand page is right aligned.

Because the character count of every line varies, an important distinction between ragged types and justified
type is what happens to the extra space on the line. With ragged alignments, the word spacing is consistent.
Every word space is the same width as every other word space in the paragraph. The extra spacing is allotted
to the right edge of the column (left alignment), allotted to the left edge (right alignment), or divided equally
between the left and right edges (center alignment). With justified alignment, the size of the word space varies
to allow the lines to be the same length. We strive to minimize the amount of this variation in order to
maintain the illusion that all word spaces are the same.

COMPARING LEFT WITH JUSTIFIED ALIGNMENT

The earliest credible evidence of coffee-drinking or knowledge of the coffee tree appears in the middle of
the 15th century in the accounts of Ahmed al-Ghaffar in Yemen. It was here in Arabia that coffee seeds
were first roasted and brewed, in a similar way to how it is now prepared. Coffee was used by Sufi circles
to stay awake for their religious rituals. Accounts differ on the origin of coffee (seeds) prior to its
appearance in Yemen. One account credits Muhammad ben Said for bringing the beverage to Aden from
the African coast. Other early accounts say Ali ben Omar of the Shadhili Sufi order was the first to
introduce coffee to Arabia. According to al Shardi, Ali ben Omar may have
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Left

The earliest credible evidence of coffee-drinking or knowledge of the coffee tree appears in the middle of
the 15th century in the accounts of Ahmed al-Ghaffar in Yemen. It was here in Arabia that coffee seeds
were first roasted and brewed, in a similar way to how it is now prepared. Coffee was used by Sufi circles
to stay awake for their religious rituals. Accounts differ on the origin of coffee (seeds) prior to its
appearance in Yemen. One account credits Muhammad ben Said for bringing the beverage to Aden from
the African coast. Other early accounts say Ali ben Omar of the Shadhili Sufi order was the first to
introduce coffee to Arabia. According to al Shardi, Ali ben Omar may have encountered coffee during his
stay with the Adal

Justified

When it comes to text alignment for continuous reading, we’re essentially concerned with the pros and cons of
using left-aligned versus justified type. There’s no right or wrong here, and it largely comes down to a matter
of personal preference. Whichever alignment you choose, however, there are certain steps and precautions to
take to get the best results.

Alignment Shortcuts

Left: Cmd+Shift+L (Ctrl+Shift+L)

Center: Cmd+Shift+C (Ctrl+Shift+C)

Right: Cmd+Shift+R (Ctrl+Shift+R)

Left Justified: Cmd+Shift+J (Ctrl+Shift+J)

Justify All Lines: Cmd+Shift+F (Ctrl+Shift+F)

Align Left
With left-aligned type, each line starts at the same place. The word spaces are consistent, giving the text block
an even type color, or density. The line lengths vary, adding shape and interest — as well as white space — to
what would otherwise be a rectangular block. The asymmetry of left-aligned text can appear informal because
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it resembles the uneven line lengths of handwriting.

When working with left alignment, pay attention to the shape of the rag — the uneven side. InDesign won’t
always break lines the way you would like, so you’ll need to spot and correct poor rags using the techniques
outlined in Chapter 10, as well as by editing the copy, if appropriate. The rag shape is influenced by the
column measure (the relationship of point size to column width), the nature of the text (whether it contains
predominantly long or short words), and whether, and how, you’re using hyphenation. Ideally, the rag should
modulate subtly, without sudden “holes” or awkward shapes. The line lengths should be clearly irregular (the
paragraphs shouldn’t look like carelessly set justified type), but not so irregular that they create distracting
shapes, or “rivers,” that slow reading.

To aid readability, the second line should be longer than the first. Once we’ve started reading a paragraph,
having a first line that overhangs the paragraph gives unnecessary pause. Similarly, the penultimate line of the
paragraph should be longer than the last line. Addressing this second point, InDesign’s Paragraph Composer
ensures that this almost always happens, but problems can occur in paragraphs set in narrow columns where
the last word is a particularly long one.

Asymmetric Typography

In typography, asymmetry is associated with a particular design philosophy, the New Typography,
first developed in Germany in the late 1920s and early 1930s and championed by Jan Tschichold and
the Bauhaus. This functional approach underscored the Modernist aesthetic that dominated graphic
design until the 1990s (and has recently come back into vogue). In his book The New Typography,
Tschichold argued that the “old typography” practice of aligning type on a central axis was inflexible,
inorganic, and ill suited to the requirements of modern typography. He felt the modern age
demanded the “greatest economy of expression.” In practical terms, along with a rejection of
symmetry, this meant using sans serif type, predominantly in lowercase, and rejecting any unnecessary
ornamentation.

After the Second World War, Tschichold lived in England, where he worked for Penguin Books and
embraced the classical design principles of symmetry, balance, and order that he had earlier criticized.
The message? Perhaps it’s this: There is no right or wrong alignment, only the alignment that best
serves the needs of the text.

One way to prevent a bad rag is to reword the text. If this isn’t an option, you can shape the text manually
with forced line breaks, judicious application of the No Break attribute, or discretionary hyphens. A further
option is to apply a small amount of tracking to make the paragraph rag differently.

There’s also the Balance Ragged Lines option, which attempts to give you lines of roughly equal length. But
this feature is not intended for use in body text, and if applied here, it will create more problems than it solves,
making it difficult to manually control the line breaks.

Balance Ragged Lines is useful for heads and subheads and reduces the amount of manual intervention
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necessary, but you’ll still need to check the type for meaning. Balance Ragged Lines won’t always break the
line where you would choose to break it. It’s the designer’s responsibility to make sure that line breaks
accentuate, rather than detract from, the meaning of the text. (For more on Balanced Ragged Lines, see
Chapter 10.)

Justified with Last Line Aligned Left
On every line, there is leftover space. With justified type, that extra space is necessarily elastic — distributed
between the word spaces and (potentially) between the letter spaces to make the lines the same length.

Justified type is symmetrical; the smooth edge on the right side of the columns creates a sense of balance. The
uniformity of the right-hand margin also gives a more formal look to your page. Justified type is more
economical than ragged type because it allows more words on the page. The difference may be insignificant in
a short document, but in a magazine or book it can mean a difference of several pages.

Problems arise with justified type when it is set in columns that are too narrow. Nothing screams “Amateur
Typography” like having spaces between the words big enough to drive a truck through. These gaps are
unsightly and disrupt the rhythm of your type. Great-looking justified type happens through a combination of
an appropriate column width, good Hyphenation and Justification settings, and a willingness to manually fix
any problems that crop up despite your attention to these factors.

TIP: With your cursor in a story, you can use the Info panel to see a word or character count — for a
line, a paragraph, or the story. This useful and underused little panel also tells you by how much your
text is running over, if you have overset text. Overset text is preceded by a + symbol. The limitation
of the Info panel is that it gives you a count for only a single story, rather than all the stories in your
document.

There are different rules of thumb when it comes to what constitutes an appropriate column width: Some
experts say between 12 and 15 words per line, but this may be unrealistic in a magazine or newspaper. If you
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have 9 to 12 words per line, good justification is still possible, and if you’re willing to allow more hyphenation,
you can achieve good justification with fewer words still. Of course, counting the number of words is only a
rough guide because the length of those words will vary according to the language and the nature of the text
— a scientific text will have much longer words than a children’s book, for example. For this reason, a more
useful measure is the number of characters per line. One standard is a minimum of two alphabets, or 52
characters per line (you can count them with the Info panel). Personally, I prefer a range of 45 to 70
characters. If you have certain paragraphs that are indented or passages that wrap around a graphic, keep in
mind that these should also fall within the target range.

Even if your body text is justified, other elements of your text should be ragged. For example, headlines and
subheads, bylines, captions, pull quotes, footnotes, bibliographies, and indexes should never be justified.

How InDesign Composes Type
InDesign’s justification settings define the permissible variation in the size of the word spaces, the spaces
between the characters, and the horizontal scaling of the characters, known as glyph scaling. If these ranges
are too tight your type will look pinched; too loose and your text blocks will be blotchy — full of gaping word
spaces or too much space between the letters. Tight lines look darker, loose lines lighter. Neither is pretty, and
both are difficult to read. Ideally, your text should have a middle gray value that doesn’t call attention to itself.

Justification settings are best applied as part of a paragraph style but can also be applied locally by choosing
Justification from the Control panel menu or pressing Cmd+Option+Shift+J (Ctrl+Alt+Shift+J). The
Justification dialog is relevant to all types of alignment, but with left, center, and right alignment only the
desired settings are considered.

If justification can’t be achieved by adjusting word spacing alone, then InDesign adjusts the letter spacing
according to the Minimum, Desired, and Maximum settings that you choose in the Justification dialog. After
that, it moves on to the Glyph Scaling settings.
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The more words there are on the line, the more word spaces there are to adjust and the less noticeable those
adjustments will be. You get more words by making either your type smaller or your column wider. It’s a
balancing act: Make your column too wide relative to the type size and you’ll be swapping one problem for
another.

Word spacing, not surprisingly, refers to the space between words — the width of space you get when you
press the spacebar. The size of a word space at 100 percent is roughly equivalent in width to the lowercase i of
the font you’re using.

A starting point for good word spacing is 100 percent, which is the width of the spaceband specified by the
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font designer. However, you may want to reduce this to 90 percent or even less when working with any of the
following:

Condensed type

Typefaces in light weights

Typefaces that are tightly fit (if you have tight letter spacing, you’ll want your word spacing to be
correspondingly tight)

Display type

TIP: With both word spacing and letter spacing, you need to find a balance between being strict and
being reasonable. There’s no point in specifying restrictive settings if your column measure makes it
impossible for InDesign to honor these settings.

Letter spacing is the distance between letters and includes any kerning or tracking values that may be applied
to the type. Because there are more letter spaces than word spaces on every line, changing the letter spacing by
a barely perceptible amount — plus or minus 2 percent — can dramatically improve the evenness of justified
type.

Glyph scaling is the process of adjusting the width of characters in order to achieve even justification. A little
glyph scaling goes a long way. Glyph scaling might sound like the kind of crime that the Design Police will
bust you for in a heartbeat. In reality, though, moderate amounts of glyph scaling — combined with your
other justification settings — can improve type color significantly.

Moderation is the key: Keep your Glyph Scaling settings to 98%, 100%, and 102% for Minimum, Desired,
and Maximum, respectively. No one will ever know that you varied the horizontal scale of your type. They
will, however, appreciate the splendidly even word spacing. It would be useful to be able to select the
characters to see exactly how much horizontal scaling is applied, but the Horizontal and Vertical Scale fields
remain at 0%.

Pushing your Glyph Scaling setting to its maximum values — admittedly, not what it was intended for — can
yield interesting results when combined with Justify All Lines alignment.

The Adobe Paragraph Composer is a mainly behind-the-scenes feature that influences how the lines of
paragraphs break. When the Composer setting in the Justification dialog is set to Adobe Paragraph Composer
(the default choice), InDesign analyzes the word spaces across a whole paragraph, considers the possible line
breaks, and optimizes earlier lines in the paragraph to prevent bad breaks later on. This means that when you
edit text composed with the Paragraph Composer, the type before as well as after the cursor may move.

Which Paragraph Composer?

The Adobe Paragraph Composer and Adobe Single-line Composer are suitable for Western
European languages, Central European languages (like Polish and Czech), and languages like Greek
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and Russian, which are set in Cyrillic characters.

For Indic and Southeast Asian script languages, and for Middle Eastern languages such as Arabic or
Hebrew, use the Adobe World-Ready Composer or Adobe World-Ready Single-line Composer.

For Japanese and Chinese use the Japanese Composer, which is introduced to the document by
pasting a paragraph that has the Japanese Composer applied to it using the Japanese version of
InDesign. Korean, however, is best set with the Adobe Paragraph Composer.

The result is fewer hyphens and better spacing. Looking at the whole paragraph means there are more places
where space can be discretely added or subtracted. The Paragraph Composer works for both ragged and
justified type, but it’s with the latter that you really see its benefits.

The Adobe Single-line Composer is an alternative to the Paragraph Composer, and its benefits are less
striking when working with ragged text. Some people find it disconcerting that line endings may change at
more than one place in the paragraph. For example, this might be an issue if, in a previous draft, your client
had signed off on specific line breaks. To maintain the line breaks as they are from one iteration of the
document to the next, consider switching the Composer setting to Adobe Single-line Composer. Be aware,
however, that because the text is composed line by line with the Single-line Composer, InDesign has fewer
options for controlling the breaks. You will gain more manual control over the text, but you will probably have
more line endings that need fixing.

Single Word Justification controls what happens to a word in a paragraph of justified text (Justify All Lines)
that’s so long that it’s the only word on a line. Hopefully, if you’ve followed the advice on using an appropriate
column measure, it will never come to this, but if you’re working with German train-car constructions of
words, or particularly long web addresses, it may be an issue. Nothing is going to look good, but the default
option of Full Justify will look the least bad.
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H&J Violations is a useful Composition preference that allows you to identify problems so that you can fix
them (or make an informed choice to live with them). As fabulous as the Adobe Paragraph Composer is,
don’t expect miracles. Good type color doesn’t just happen, and you’ll still have to fix some composition
problems manually. With this preference turned on, you’ll see yellow highlighting applied on a line-by-line
basis wherever InDesign can’t honor your justification settings.

Even with the most considered column widths, the most carefully weighted justification options, and the most
judicious use of InDesign’s Composition preferences, spacing problems still occur from time to time. So don’t
fire the proofreader.
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Centering Type
Center alignment assigns extra space on the line equally to the left and right of the type, giving equal weight
to both ends of the line. It is widely used in magazine design for headings and in book design for title pages. It
is also associated with birth announcements, wedding invitations, and … gravestones. Centering works best
with single lines or short paragraphs; centering long paragraphs means every line has a different starting point,
making the text less readable.
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When done right, centering can be formal and classical, and give an interesting shape to your text block; when
chosen as a fallback option, it makes layouts appear stodgy or generic. Beginning designers often gravitate
toward center alignment because they’re more comfortable with its solidity — each line supported on either
side by white space. But this equal white space on both sides of the line can make the text feel static, as if it
were being held in a vise-like grip.

Combining centered headings with other types of alignment has drawbacks. The different alignments
diminish the visual connection between heading and text, and the even white space on both sides of the
heading creates a symmetry that’s at odds with the ragged text that follows. Also, centered headings over left-
aligned text will not be optically centered if the first line of body text spans less than the full column measure.
Worse still would be to center an italic headline over roman type, because the slant of the italic would make
the headline appear off-center.

There’s no reason why centered type can’t look good, but it requires more than just clicking a button. Be
prepared to adjust the line endings to enhance the meaning of the text as well as to give the paragraph an
interesting shape (think chandelier). It should be obvious to the reader that the type is centered and not just
badly justified.
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Right-Aligned Type
Right-aligned, or flush-right, type is less common and is thus distinctive. It can be effective for short bursts of
text like captions, pull quotes, or sometimes headlines. When used in a print spread, it tends to work better on
left-hand pages, where the text is “facing in” toward the spine, rather than the right-hand pages, where the
text faces the outside margin and looks like it’s trying to escape from the page.

If right-aligned text is overused, it can be off-putting to the reader because the eye ends up focusing on the
end rather than the beginning of the line. Also, the ragged edge makes it harder to find the start of the line.
Applied thoughtfully, however, right alignment can be dynamic and a welcome change of pace.

Right-aligned text draws attention to itself. If you’re going to use it, capitalize on this and emphasize, rather
than play down, the unevenness of the rag. Alignment should never be ambiguous. If necessary, use forced line
breaks (Shift+Return) to make some lines shorter so that there’s a distinct rag on your left edge. Be sure to
turn off hyphenation in right-aligned type: You don’t want the smoothness of the flush right edge disturbed
by hyphenation stubble.

When positioning a block of informational text on a flyer or poster or even a business card, there’s a tendency
to right align it in the lower-right corner. This creates an uncomfortable “photo corner” effect and tends to
trap the flow of white space, making the composition feel confined. It’s good to remember that you can
position a text block on the right side of your page but still have it be left aligned, with a clearly defined
starting point for each line to aid readability. Make sure the left side of the text block aligns with some other
element in the composition to help unify the different parts of the layout.

As well as the usual justification choices, there are also lesser-used options that may be appropriate in specific
situations.
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Align Towards and Away from Spine
The Align Towards Spine and Align Away from Spine options are useful in print design if you’re working
with a facing-pages spread. They ensure that the alignment of your type mirrors itself when moved from a
left-hand to a right-hand page or vice versa. For example, if you want picture captions that are right aligned
on the left-hand pages and left aligned on the right-hand pages, choose Align Towards Spine. If you want
page numbers that are aligned to the outside margins of facing pages, choose Align Away from Spine. Using
these align methods eliminates the need to have distinct paragraph styles for left pages and right pages.

Side Heads
Combining a right-aligned caption or side head with a left-aligned column can be a visually effective use of
white space. This involves creating a separate text frame for the right-aligned text and positioning it to the left
of the main text frame. To maintain the visual relationship between the two types of text, it’s necessary to
anchor the caption text frame to a specific point in the text. Here’s how:

1. Anchor the caption frame. Drag the frame from the blue rectangle at top right to the beginning of the
paragraph where you want to anchor the caption.
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2. With the caption frame selected, right-click or choose Object > Anchored Object > Options.
Alternatively, Option-click (Alt-click) the Anchored Object Control Widget. Make the Reference
Point the upper-right corner. For X Relative To, choose Text Frame, and set X Offset to the space you
want between the caption frame and the main text frame. For Y Relative To, choose Line (Cap
Height), and set Y Offset to 0. Optionally, select Prevent Manual Positioning to prevent the
relationship of the caption frame and main text frame from being disturbed. Select Relative to Spine if
you want the side heads to mirror each other across a facing-pages spread.

There is currently no elegant automated solution to creating side heads, but InDesign scripting expert Peter
Kahrel has written an excellent script, available for a voluntary donation, that can convert a selected range of
text into a side head (www.kahrel.plus.com).

“Movie credits” alignment, where the two parts of the line are aligned toward a central axis, can be achieved
with a Center Tab or by converting the text to a table with the right-aligned text in the left column and the
left-aligned text in the right column. See Chapter 11, “Tables.”
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Optical Alignment and Hanging Punctuation
When it comes to typography, little things can make a big difference. One of the simplest enhancements you
can make to your type is to use Optical Margin Alignment.

Have you ever noticed how punctuation at the margin of a text frame makes the left or right sides of a column
appear misaligned? When a line begins with punctuation, such as an opening quotation mark, or ends with a
comma, period, or hyphen, you have a visual hole.

With InDesign’s Story panel, you can easily ensure that your punctuation (especially your hyphens) and the
edges of your letters hang outside the text frame so that the column edge remains flush. This makes Optical
Margin Alignment especially beneficial when working with justified text, but even with left-aligned text the
first character of the line will “hang” outside the text frame.

The Story panel is perhaps the easiest panel in InDesign to use. You select the story you want to align, either
with the Selection tool or the Type tool, choose Story from the Type menu, click the check box, and you’re
done. The only user-defined option is the font size, which determines the amount of overhang. Start out with
this at the size of your type, then adjust as necessary according to what looks good.

You won’t find Optical Margin Alignment in your Paragraph Style options, so if you want to apply it globally
(and consistently), you’ll need to incorporate it into an object style definition, which you can then apply to
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your text frames. (See Chapter 15, “Styles.”)

Certain types of paragraphs don’t benefit from Optical Margin Alignment, notably bullet or number lists. For
such paragraphs, the left edge should remain flush. To make sure this happens, choose the Ignore Optical
Margin Alignment option in the Indents and Spacing section of your Paragraph Style options.

Closely related to Optical Margin Alignment, hanging punctuation is used to maintain the clean left edge of
the text. It’s useful for pull quotes and callouts that begin with a quote mark. Because the opening quote mark
creates an optical hole on the left edge of the text, it’s preferable to hang the punctuation using the Indent to
Here character: Cmd+\ (Ctrl+\). This invisible character indents all subsequent lines in the paragraph to the
insertion point.

Aligning Elements Relative to Each Other
Page layouts are modular, and all their elements should fit comfortably with neighboring elements — even if
this isn’t visually obvious to the viewer. Everything on your page should be aligned relative to something else.
Frames should be sized perfectly to their content and their edges snapped to the guides with the precision of a
docking space station. This is best achieved by using grids, discussed in Chapter 17, but at the very least make
sure you draw out guides to align elements to, rather than just eyeball their position. Pay particular attention
to small and often fussy frames like photo captions, picture credits, and labels. Make sure that the text itself,
not the text frame, is aligned relative to an accompanying picture. As your visual reference, use the x-height of
the text or, more commonly, the cap height of the text. Most importantly, be consistent.

Mission control for aligning elements relative to other elements, or to the page, is the Align panel. This has
all the expected options of aligning or distributing left edges, right edges, or centers, but it also has, if you
choose Show Options, some lesser-known options for distributing spacing. This is a particularly useful way of
maintaining consistent spacing between elements — for example, the distance separating a series of items in a
diagram.

Vertical Alignment
As well as the horizontal alignment of text, InDesign also has options for its vertical alignment. These choices
are found in the Text Frame Options dialog (Object > Text Frame Options or Cmd+B/Ctrl+B). The default
is for type to begin at the top of the frame, which is appropriate in most instances. There are times, however,
when Center or Bottom alignment of type within a frame is necessary.
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Top Alignment
The First Baseline Offset determines the start position of the type in the text frame. Rarely is there reason to
change from the default of Ascent, especially because using a baseline grid overrides these options, effectively
giving the same result as choosing the Leading option.

It’s important to note that there will be a small amount of space between the top of the text frame and the top
of the first line of type. This means that aligning the top of a text column to the top of a picture requires
special attention. The solution is to draw a guide to the cap height (or x-height if you prefer) of the text and
align the picture tops to that, rather than to the top of the frame (see Chapter 17, “Page Geometry, Grids,
and White Space”).

Center Alignment
When centering vertically, the text may not appear to be optically centered, especially if there are few or no
descenders. The solution is to change the First Baseline Offset of the text frame to Cap Height.

Alternatively, you can shift the vertical position of the text using baseline shift, Option+Shift+Up/Down
Arrow (Alt+Shift+Up/Down Arrow).

Aligning Type in a Circle
When you create text inside a circle, it may be easier to work with the text frame and the circle shape as
separate elements. Here’s how:

1. Size the text to your liking.

2. Select the text frame and choose Fit Frame To Content, Cmd+Alt+C (Ctrl+Alt+C), to have the frame
fit snugly around the type.
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3. Select both the text frame and the circle, and align the two frames horizontally and vertically using the
Align panel. If necessary, adjust for optical alignment.

4. Group the two items together by pressing Cmd+G (Ctrl+G).

Bottom Alignment
Bottom alignment is useful for caption frames that you want aligned to the bottom edge of the picture. Using
bottom alignment ensures that the baseline of the caption is aligned with the bottom of the picture in the
adjacent column.

Justified Vertical Alignment
Justified vertical alignment is used to force text to fill a vertical space or, with multiple columns, to make the
text “bottom out” by adding extra space between the paragraphs and potentially to the leading of the shorter
column.
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Vertical justification can be convenient when working with single column text frames that you need to end at
a specific point.

However, you should be wary about using vertical justification in multiple-column frames. Yes, it makes your
columns “bottom out,” or end on the same baseline, but it does so at a price. That extra spacing has to go
somewhere.

If you leave the Paragraph Spacing Limit at 0, vertical justification “feathers” the leading, knocking your type
off the baseline grid, if you’re using one (only the first and last lines in each frame will be aligned to the grid),
so that the type no longer aligns across columns.

If the column has multiple paragraphs, increase the Paragraph Spacing Limit to a large value — larger than
you would ever actually need — so that all the extra spacing is added between paragraphs and the leading is
unaffected. If the last column contains only a single paragraph, this approach won’t work. This will yield a
better result — and the more paragraphs there are in the column, the better because there will be more places
to discretely tuck the extra space — but it will still throw off the cross-alignment of your baselines.

What InDesign’s vertical justification lacks is the ability to let you specify where the spacing is added — for
example, only to space before a paragraph rather before and after, in what subdivisions of your baseline grid,
and with what maximum threshold.

Ultimately, it comes down to personal taste, but for my money there are less intrusive alternatives to vertical
justification: If the layout contains images or other graphic elements like pull quotes, add extra spacing around
these elements, or opt to balance your columns — especially if the last column is several lines short. And then
— and this isn’t meant to sound flippant — there is the easiest solution of all, which is to live with unbalanced
columns. What’s so bad about a bit of asymmetry anyway?

156



If you really need that last baseline to find the bottom of the text frame, try adjusting the space manually:
Divide the amount of space you need to fill (the number of lines × the leading) by how many subheads there
are in the column, and distribute the space evenly between these paragraphs. This manual approach allows you
to assign the extra spacing before the paragraph, rather than before and after, which is what you’ll get with the
automated approach.

Vertical Type
InDesign’s vertical alignment refers to the vertical positioning of a block of horizontal type. If you want type
that reads from top to bottom, rather than left to right, you’ll need the Type on a Path tool combined with the
Stair Step effect applied to a perfectly vertical line. To space out the letters, use tracking. For best results, use
all caps and consider a monospaced typeface where all the letters are of equal width. You’ll have more options
for vertical type in Adobe Illustrator or even Adobe Photoshop, both of which have dedicated vertical type
tools.
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Alignment plays an important part in establishing the character of our type, the impression it gives, and how
easily it can be read. Each alignment option has its pros and cons and particular challenges. User intervention
and discretion are required to make the type look its best. Working in conjunction with alignment to give the
type shape and form are paragraph spacing and paragraph indents, which are the subjects of the next chapter.
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Chapter 7

Letterspacing, Tracking, and Kerning

More than just letters, typography is also the space between those letters. Each letterform and each
word inhabit a background of negative space that gives form to the type. This space helps establish the
rhythm of the text. Tight- or loose-fit type may be in or out of fashion, just as jeans may be skintight
one season and flared the next. But whatever the trend, for the type to be readable, the rhythm should
be steady, the spacing consistent.

InDesign offers three distinct but related approaches to adjusting the space between words and letters. Going
from global to local, let’s start by defining our terms:

Letterspacing is the overall adjustment of space between letters and between words.

Tracking is the adjustment of the space between the letters and words across a range of text.

Kerning is the adjustment of space between letter pairs, to compensate for uneven spacing.

Letterspacing vs. Tracking
In InDesign, letterspacing adjustments are made using the Word Spacing and Letter Spacing options in the
Justification dialog box. Letterspacing and tracking can achieve the same results, but there’s an important
distinction: letterspacing is macro; tracking is local. Neither letterspacing nor tracking takes into account the
shapes of the letterforms themselves. To adjust ill-fitting letter combinations, you need to fine-tune with
manual kerning.

“You can put as much nationality in the spacing of a typeface as in the typeface itself.”

— Danny van den Dungen of graphic design studio Experimental Jetset (Quoted in Helvetica, Dir.
Gary Hustwit, 2007)

Letterspacing can be used to adjust the overall tightness or looseness of certain classes of paragraph as part of a
paragraph style definition. This approach is preferable when you can predict the need for adjusting the spaces
between characters, as in tightening headlines or loosening captions. I’ll refer to Word Spacing and Letter
Spacing options collectively as letterspacing throughout this chapter.

While it’s possible to use tracking to achieve the same visual tightness or looseness of your type, I prefer to
achieve this with letterspacing and limit the use of tracking to fixing composition problems (see the section
“Runts, Widows, and Orphans” later in this chapter) and to making adjustments to specific types of text
through the use of a character style.

Exactly what constitutes good letterspacing is neither fixed nor universally agreed upon. To the extent that
“rules” exist, we can say this: The letters should be far enough apart to be distinct, but not so far they separate
into individual signs. The space between the words should be equivalent to the width of the letter “i.” The
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leading should be greater than the space between the words. But these rules of thumb don’t necessarily apply
to display type, where the text is shorter, the type larger, and gaining attention — rather than readability — is
the most important thing.

With loose letterspacing, we see more of the background. If we see too much, the background gobbles up the
type: Letters lose their association with each other, and words lose their shape. Italic or script types with
letterforms designed to connect with their neighbors should never be loosely tracked. Spacing your letters
loosely might not seem like a big deal to the layperson, but typographers get quite upset about such practices.
The American typographer Frederic Goudy (1865–1947) famously said, “Men who would letterspace
lowercase would steal sheep.” (Reputedly, that’s the sanitized version of the quote.)

With tightly spaced type, we see less background; the words can look dense, possibly more impactful. But if
there’s not enough background, the letters run into each other. Here there’s the risk of an undifferentiated
mass of type or creating unintentional meanings. We’ve all seen those funny examples that do the rounds on
social media, where carelessly spaced letter pairs create a whole new level of unintended meaning.

When applying tighter letterspacing, pay careful attention to what happens to pairs like rn; letterspaced too
tight, these might look like an “m”; ri might look like an “n,” and cl like a “d.” If you often find yourself
reducing letterspacing in order to shoehorn your type into a tight space, consider using a condensed typeface
that was designed with the efficient use of space in mind.
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That said, these admonitions are not absolutes. Sometimes loose letterspacing is necessary. Don’t take
anything as gospel. Print your page and evaluate for yourself, getting a second opinion if necessary.

Loose letterspacing might be useful in these situations:

When setting wide columns.

In serif headlines or brand names set in all caps, extra letterspacing can yield a more elegant look.

When reversing type out of a solid background, a small amount of extra letterspacing improves
readability. This is because the negative (color) space makes the white characters seem closer together.

When using small type, as in captions or photo credits, loose letterspacing makes the individual
letterforms more identifiable.

When the type is going to be viewed from far away (on a sign, for instance). Look at the spacing of type
on a highway sign and you’ll see that it is quite loose.
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Tight letterspacing becomes a factor as type size increases. This is because as type size grows, the negative
space around the letters appears to grow faster. The larger the type, the more loose its spacing looks. The
solution is to tighten the letterspacing — how much depends on the point size, the typeface itself, and the
effect you’re after.

Tight letterspacing might be useful in the following situations:

When setting narrow columns or a short column measure.

In sans serif headlines, tight letterspacing can help the characters hold together better to form more
easily recognized word shapes and create increased density and impact.

When using condensed typefaces, their vertical nature calls for a reduction in the spaces between letters.
Too much “air” and the words lose their dynamism.

Kerning and Tracking Shortcuts

The shortcuts for kerning and tracking are the same: with your cursor between a letter pair, you are
kerning; with a range of text selected, you are tracking.
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Tighten kerning/tracking: Option+Left Arrow (Alt+Left Arrow)

Loosen kerning/tracking: Option+Right Arrow (Alt+Right Arrow)

Tighten kerning/tracking by five times specified increment: Cmd+Option+Left Arrow/Right Arrow
(Ctrl+Alt+Left Arrow/Right Arrow)

Loosen kerning/tracking by five times specified increment: Cmd+Option+Right Arrow
(Ctrl+Alt+Right Arrow)

Decrease word spacing: Cmd+Option+Delete (Ctrl+Alt+Backspace)

Increase word spacing: Cmd+Option+\ (Ctrl+Alt+\)

Clear all manual kerning and reset tracking to 0: Cmd+Option+Q (Ctrl+Alt+Ctrl+Q). On a Mac,
this conflicts with the macOS shortcut for Quit and Keep Windows. To get around this you can add
your own keyboard shortcut to this command.

Adjust letterspacing (open Justification dialog box): Cmd+Option+Shift+J (Ctrl+Alt+Shift+J)

Tracking vs. Kerning
A surefire way to raise the hackles of a typographer is to use the terms tracking and kerning interchangeably.
While closely related, they are distinct. Here’s the difference: With a range of characters selected, you are
tracking; with the cursor inserted between a pair of characters, you are kerning. Both share the same keyboard
short–cut (Option/Alt+Left Arrow for tighter, or Option/Alt+Right Arrow for looser). Tracking works in
combination with your other type settings; if your Justification and Hyphenation settings are set appropriately,
for example, there will be less need for manual intervention in the form of tracking to fix composition
problems.

Runts, Widows, and Orphans
Given the drama of their names, the actual definitions of these terms may be a little disappointing. Precise
definitions vary, depending on your source, but I define them as follows.

A runt (a termed coined by InDesign guru David Blatner) is the last line of a paragraph that ends with a short
word or, worse, a single syllable of a hyphenated word (preventable with appropriate Hyphenation settings). A
single word on the last line may not be a problem if it’s a long word. Ideally, the last line of a paragraph
should be about one fifth of the column measure. At minimum, it should be wider than the first line indent.
Addressing runts first will minimize the number of widows and orphans you have to deal with.

A widow is the last line of a paragraph, stranded at the top of a column or page. Widows should always be
avoided.

An orphan is the first line of a paragraph that occurs at the bottom of a column or page. Orphans are not
desirable.

The order in which you address these problems is important. Fix the runts first, and you’ll have fewer widows
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and orphans to worry about.

The easiest way to address runt lines is to use a GREP style. A GREP style is a way to search for consistent
patterns in text formatted with a particular paragraph style and apply a character style to the result. Styles are
the subject of Chapter 15, so we’re jumping ahead here, but the approach is this: Create a paragraph style that
determines the appearance of your body text. Next, make a character style that has a single attribute — No
Break — and call it “No Break.” Now edit the paragraph style and from the list of attributes on the left choose
GREP Style. Click New GREP Style, and from the Apply Style drop-down choose No Break. Next — and
this is the important bit — in the To Text field type the following:

.{8}\r
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This simple GREP instruction finds the runts in your body text (you shouldn’t apply it to heads or subheads),
ensuring that the last line of a paragraph is at least eight characters in length. Here’s what it says:

.{8} [Find a string of 8 characters] \r [at the end of a paragraph]

If you feel that eight characters is still too short, especially because it includes punctuation, you may want to
up this to nine or ten, depending on your line length.

To cover all bases, add a second GREP style: .{8}\z. This will address paragraphs that occur at the end of a
story. And be sure to remove any spaces before the paragraph mark. This is easily done with a predefined
GREP query: Choose Edit > Find/Change, and from the Query drop-down select Remove Trailing
Whitespace.

Once the runts have been addressed, you can move on to fixing the widows and orphans. To gain a single line
in a paragraph, rather than work on individual lines, select the problem paragraph, or one that precedes it, and
tighten the tracking using the keyboard shortcut (Option+Left Arrow or Alt+Left Arrow). The aim is to pull
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back a line by (imperceptibly) tightening the letterspacing across the range of words. This is a compromise
and contradicts the golden rule of consistency. So it’s important that the reader not notice.

TIP: Other uses of tracking: Apply positive tracking, preferably as part of a character style, to
acronyms (for example, NATO, AIDS, ASBO) or initialisms (FBI, USA, HTML), to help
distinguish the individual characters.

Choose your battles wisely — certain paragraphs may be resistant to tracking. Forcing them too much will
result in a cure worse than the original problem. Different publications have different standards of what’s
acceptable; I suggest applying no more than -10/1000 em.

Fixing widows and orphans should be one of the last stages in your workflow. There’s no point in addressing
these problems when the layout or the text itself isn’t yet finalized. Here are some other things to consider
when tracking to fix widows and orphans:

Start at the beginning of your text flow and work methodically to the end. Don’t flip back and forth
from one page to the next or you’ll find yourself fixing one problem only to create another.

Try tightening up a paragraph that precedes the widowed or orphaned paragraph (rather than the
problem paragraph itself), in the hope that this will fix problems later in the text flow. Look for
paragraphs that already have relatively short last lines.

Use the Custom Tracking/Kerning preference to highlight in green any ranges of text that have been
custom-tracked, and in orange where any custom kerning has been added. There are actually two tints
of green: lighter green to indicate where the custom tracking has been applied as part of a paragraph or
character style and darker green to indicate where custom tracking has been applied locally. To turn on
this option, choose Preferences > Composition and select Custom Tracking/Kerning. This is
particularly helpful if you have inherited a document and want to make sure the text hasn’t been
overzealously tracked. It’s also useful if the text is edited or reflowed so that the tracking you formerly
applied is no longer necessary. This preference is the reason you don’t want to apply tracking as part of a
paragraph style definition: If it’s been applied everywhere, you can’t distinguish the exceptions. This
highlighting is most useful as you near completion of your document. Turning it on at the beginning of
your design process is more likely to cause annoyance than provide useful feedback.
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Rivers
When you adjust tracking, stay alert to the “color” or density of the whole paragraph, not just the line, and
watch out for rivers, another composition problem that can spoil your type. A river is a line or crack of
whitespace that runs vertically through your paragraph, caused by a random and unfortunate pattern of word
spaces on successive lines. Rivers are most common in narrow columns of justified text, but can also occur
when letters are spaced too tightly. If you’re using an appropriate column measure and appropriate
Hyphenation and Justification settings, rivers are unlikely to occur. Sometimes, however, you’re unlucky, and
applying tracking with a light touch may solve the problem.

Tracking and the Paragraph Composer

The lines of paragraphs composed with the Adobe Paragraph Composer (the default composition
method) don’t always break as expected when tracked. This is because the lines are recomposed on a
paragraph basis rather than line by line; every change you make to a paragraph causes InDesign to
reconsider the line breaks of the whole paragraph, not just the line you are working on. While this
can be frustrating for editors and proofreaders, using the Adobe Paragraph Composer rather than the
Single-line Composer will result in a more even type color or density. See Chapter 6, “Alignment.”

The best way to spot a river is to print a proof and turn your page upside down — or just choose View >
Rotate Spread — so that the negative space between the letters is abstracted. Any scars on the page will be
more noticeable.

Adjusting Letterspacing
As an alternative to fixing widows, orphans, and runts with tracking, you can adjust the Letter Spacing setting
in the Justification dialog box to achieve similar results. To do this, insert your cursor into the problem
paragraph, press Cmd+Opt+Shift+J (Ctrl+Alt+Shift+J), then reduce both the minimum and desired
letterspacing values. The key difference between this and tracking the paragraph is that (assuming you have
the Adobe Paragraph Composer chosen) the spacing will not be exactly the same between each character or
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word, but rather will be optimized according to the available space and potential line and hyphenation breaks

within the paragraph.

A potential downside is that paragraphs adjusted in this way cannot be easily identified by a color highlight
using the Composition preference, the way tracked text can.

Other Ways to Fix Widows, Orphans, and Rivers

TIP: Flipping through your pages in the Fit in Window view with the type greeked can help you
quickly identify widows, orphans, runts, and rivers.

If the paragraph is impervious to the charms of tracking or letterspacing and the widows, orphans, or runts
persist, don’t force it. You also have these options available to you:

Revise the copy. This may not be an option, depending on the kind of document you’re working with, but if
you have license to rewrite, then go for it — often a subtle rewording will do the trick.

Adjust the word spacing. You can tighten or expand the word spacing across a range of characters without
affecting the character spacing. Cmd+Option+Delete (Ctrl+Alt+Delete) tightens the word spaces.
Cmd+Option+Shift+\ (Ctrl+ Alt+Shift+\) increases the word spaces.

Use Keep Options. Keep Options is the umbrella term for different methods of controlling how paragraphs
break — or don’t break. The various options are Keep With Previous, Keep With Next, Keep Lines Together,
and Start Paragraph, which can force a page, frame, or column break. If you don’t need your columns to
“bottom out” (that is, share the same last baseline), you can control how your paragraphs break by using Keep
Options to specify that a number of lines at the end of the paragraph be kept together. Beware: Overzealous
use of Keep Options can cause your text to behave oddly, with paragraphs jumping from frame to frame as if
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they have a life of their own. That said, Keep With Next is useful for preventing headings and subheadings

from being divorced from the text that follows them. See Chapter 10, “Breaking (and Not Breaking) Words,
Lines, Paragraphs, and Pages.”

Kerning
Kerning operates at the micro level of spacing adjustment. Its purpose is corrective: to compensate for the
appearance of unequal spacing between certain pairs of letters, especially when one or both of those letters is
angled or curved. For a better reading experience, it’s necessary to use kerning to even out inconsistent spacing
in your type. This usually involves reducing the space between the characters, although it might on occasion
mean an increase in space. Inconsistently spaced type can spoil a page. While most readers won’t be able to
pinpoint poor kerning as the culprit, they will know intuitively that something is wrong.

Custom Tracking and Kerning and Style Overrides

When you apply tracking to a paragraph to fix widows or orphans, you are creating a style override. In
Chapter 15, “Styles,” I stress the importance of consistency and not overriding your style definitions.
So how come the contradiction?

As I mentioned, tracking to fix composition problems should be one of the last finessing steps you
take before publication. At such a point you are making exceptions, nipping and tucking — albeit
with a light touch. The resulting style overrides are a necessary compromise to achieve beautifully set
type.

That said, if you are a styles purist and can’t sleep knowing that your paragraph style names have a +
next to them, you can apply your tracking as a character style. Make 10 character styles that each have
a single attribute — between –1 and –10 units of tracking. Optionally, you can assign a keyboard
shortcut to these styles, making them as quick to apply as the Option+Left Arrow (Alt+Left Arrow)
shortcut, and to keep things neat and tidy, put them in a style group. Apply these character styles as
needed to the selected text of a paragraph, starting with the smallest increment, and if that doesn’t
work, progress to the next.

If that seems like a lot of setup work, do it once, then make these character styles available in all
documents. Chapter 15 explains how to create a default set of styles and load styles from one
document to another.

On a related note, if you are working with a Preflight profile that flags style overrides, you can choose
to exclude tracking and kerning overrides.
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Certain letter combinations are known to be troublesome; hopefully, the font’s kerning metrics address the
problem, but this won’t always be the case, nor will you always agree with the prescribed metrics values. At the
micro level, manual kerning can be 1/1000 employed to adjust the spacing of particular letter pairs.
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Automatic Kerning
If adjusting the space between every pair of letters seems like an obsessive and ridiculously time-consuming
endeavor, take heart: Rarely is it necessary to apply manual kerning to type below 14 points in size. The
majority of our kerning needs are addressed by InDesign’s automatic kerning methods. There are two such
methods, both of which are adequate for small type: metrics (the default) and optical. Regardless of the
method you use, you can always add manual kerning as needed.

TIP: The default kerning and tracking increment in Preferences > Units & Increments is 20⁄1000 of
an em, which is too coarse. Do yourself a favor, and change this increment to 1⁄1000 of an em, with
no InDesign document open so that it becomes an application preference and will apply to all new
documents you create henceforth.

To see how much automatic kerning is applied to any given letter pair, insert your type cursor between the
characters; the Kerning field in the Control panel and the Character panel displays the amount in parentheses.
Typefaces are designed in a 1000-unit em square; InDesign kerns (and tracks) in these increments of
thousandths of an em. Because these are relative units, a kerning and tracking adjustment made at one point
size will scale along with the type and have proportionally the same effect at any other point size.

Metrics vs. Optical Kerning
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Metrics kerning uses the metrics values that are built into most fonts. These values are instructions to adjust
the spacing between particular letter combinations. They reflect the type designer’s judgment about how the
type should be spaced and make an important contribution to the quality of a typeface. Font creation software
can automate the creation of kerning pairs, but many type designers prefer to create them manually — at least
for those letter combinations that are known to be troublesome.

Optical kerning is a mathematical solution that ignores the metrics values within a font and instead adjusts
the space between letters according to their character shapes. Because it’s a mathematical solution, it’s more
consistent and there are more kerning pairs. Optical kerning works on all possible kerning pairs, whereas
metrics kerning works only on those kerning pairs the type designer deemed important. Does this make
optical kerning better? Ultimately it depends on the quality of the metrics you are comparing it against.
Kerning metrics are the subjective judgment of the type designer, and as any type designer will tell you, a good
typeface is one that looks good to the eye; it’s more an art than an exact science. Basically, the best kerning
method will vary from typeface to typeface. If you use metrics, you are trusting the type designer; if you use
optical, you are overruling the type designer. Try both to see which you prefer, but here are some rules of
thumb.

NOTE: Kerning and tracking are cumulative; they don’t cancel each other out. You can use tracking
to adjust the overall look of your type, then use kerning to adjust particular letter combinations.

Choose metrics kerning if:

You’re using a professional typeface. The type designer sweated long and hard to determine the kerning
metrics.

You’re using a script typeface. Typefaces where the letters that need to connect fare badly with optical
kerning and will not join in the way they are intended.
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You’re using a monospaced font. Kerning metrics for a monospaced font will all be zero. Because a
kerned monospaced font is an oxymoron, there are no metrics values in monospaced fonts. If you choose
optical kerning you are essentially making the monospaced font, proportionally spaced. This might be
useful if you like all aspects of the font except its monospaced-ness, but not a good idea if you chose the
font for that very quality. Likewise with tabular lining numerals, which presumably you’ve chosen so
that they line up in a table. Make the kerning optical, and they won’t line up any more.

Choose optical kerning if:

You like your display type a little tighter. Optical kerning, because it is mathematical and works on all
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letter pairs, is usually tighter spaced.

Your font includes few or no built-in kerning pairs. Decorative and novelty fonts may have a limited
number of kerning pairs, for instance. To find out how many kerning pairs a font has, change the
kerning to metrics and then move your cursor through the text and watch the kerning numbers. If the
value changes frequently between letter pairs, there are a lot of kerning pairs. If the number rarely — or
never — changes, there are few or no kerning pairs.

You’re combining typefaces in the same word (admittedly rare). There are no kerning metrics for letter
pairs of different fonts. If you use one letter from one face and another letter from another typeface,
there will be no kerning metrics for the new coupling, and you’ll need to use optical kerning to adjust
the spacing.

Manual Kerning
Manual kerning is not usually necessary for type at text sizes, but it plays an important role with display type.
Because spacing anomalies become more apparent as type size increases, the bigger the type, the more need
there is to kern to achieve visually consistent spacing between the characters. Manual kerning is part of the
fine-tuning of your document and shouldn’t be undertaken until the type style, size, and letterspacing are
nailed down. When it comes time to kern, be careful — you don’t want to end up “keming” instead of
kerning.
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Possible candidates for manual kerning include:

Headlines and display type.

Drop caps where the large opening letter collides with the word that follows or where the space between
the drop cap and the text looks awkward.

Words that combine fonts (especially roman-italic combinations).

Script typefaces. If the kerning metrics are good, most letter pairs will connect, but if you’re using a less
common letter pair, you may need to manually kern to ensure that the connecting strokes touch the
letters that follow them.

Tabular lining numerals.

Approaches to Kerning Display Type
It takes time to develop an eye for kerning. Until you feel confident, be cautious and make only modest
adjustments. Manual kerning needs to be approached carefully and thoughtfully or it becomes a giant (some
say obsessive) time sink. Before you start adjusting the kerning on display type, make sure you have the
letterspacing the way you want it. Any fine tweaks to kerning pairs may be redundant should you later make a
blanket change to the letterspacing.
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The shorter the headline, the more crucial the kerning — with fewer words any inconsistencies will be more
obvious.

Manual kerning is not static. It affects not just the letter pair you’re working on but all the letters that follow
it. The letters to the right of the kerned pair move left if the kerning is made tighter, or to the right if the
kerning is made looser.

Fix the worst problem first, then let this kerning pair determine the spacing for the rest of the characters. The
spacing of the line can only be as tight as this kerning pair will allow.

If there are multiple instances of a letter pair in the text you’re kerning, make sure you apply the same
treatment to each.

Turn your page upside — choose View > Rotate Spread > 180°. This makes the words abstract: You see the
letterforms and the space between them without reading the words. You can also try squinting to abstract the
words.

Don’t overdo it. Along with the ease of kerning comes a tendency to want to fix things that aren’t broken.
Most letter shapes fit well with nearly all their possible neighbors.
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When making kerning adjustments, zoom in to a large enough view size to evaluate your results — and then
zoom out again to 100 percent view to make sure your changes look appropriate. If it’s a print project, always
evaluate the results on paper and not just on the screen.

▄

Like much in life, good typography is as much about what to leave out as what to include. That special
ingredient of space between the letters and the words plays a key role in the way we respond to a message.
Often “invisible,” good letterspacing, or tracking, is a key component of readability, whereas its close cousin,
kerning, is used on display type to make the letters appear evenly spaced or to create expressive headline
treatments.
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Chapter 8

Small (but Important) Details

Typography is all about the details, and good typographers tend to be mildly obsessive by
temperament. But this sweating the small stuff is more than just nitpicking; it’s about clear
communication. And to communicate clearly we need to care about small details like quote marks and
apostrophes, the difference between an en dash and an em dash, and when it might be preferable to
use oldstyle rather than lining numerals.

Special Characters
Communication is ever evolving, and we communicate differently today from how we did just a few decades
ago. But even allowing for changing fashions, needs, and meanings in language, grammar, and typography, it’s
our job to guard against common mistakes and the dumbing down that they represent. This duty starts with
using the appropriate characters to convey the intended message.

Typographer’s Quotes
No self-respecting typographer would be caught dead using straight quotation marks, or inch marks, instead
of paired typographer’s (“curly”) quotes. By default, this preference is on — and should stay that way.
Including typographer’s quotes is also an option in the Word Import options when you place text with the
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Show Import Options check box selected. In American English, double quotation marks are used to set off a
quote and single quotation marks are used for quotes within a quote. In British English, it’s the other way
around. In addition, American English requires commas and periods to go inside the quotation marks even if
the punctuation is not part of the quoted sentence. Colons and semicolons, however, go outside the quotation
marks. In British English, all punctuation goes outside the quotation marks, which perhaps makes more sense,
but looks ugly.

Dictionary preferences allow you to choose the appearance of your single and double quotes for specific
languages.

‹ O › French single quotes

« O » French double quotes (guillemets)

«O» Non-French guillemets without space

‚O’ German single quotes

„O“ German double quotes
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Quote Marks Shortcuts

“ Double Opening: Option+[ (Alt+0147)

” Double Closing: Shift+Option+[ (Alt+0148)

‘ Single opening: Option+] (Alt+0145)

’ Single closing / apostrophe: Shift+Option+] (Alt+0146)

« Opening double guillemet: Option+\ (Alt+0171)

» Closing double guillemet: Option+Shift+\ (Alt+0187)

‹ Single opening guillemet: Shift+Option+3 (Alt+0139)

› Single closing guillemet: Shift+Option+4 (Alt+0155)

„ German double opening: Shift+Option+W (Alt+0132)

“ German double closing: Shift+Option+[ (Alt+0148)

‚ German single opening: Shift+Option+0 (Alt+0130)

’ German Single closing: Shift+Option+] (Alt+0146)

If you need to convey feet or inch measurements, it’s possible, although not recommended, to toggle to
straight quotes by pressing Cmd+Option+Shift+’ (Ctrl+Alt+Shift+’). A better option is to avoid straight
(dumb) quotes altogether and use the single prime (feet, minutes) and double prime (inches, seconds) glyphs.
Not all fonts will have these; you can use InDesign’s Glyph panel to search for them by Unicode number:
2032 and 2033, respectively. If you’re using a font that does not include prime marks, they are available in the
Symbol font, or at least the Adobe version of the Symbol font. If you don’t have the Symbol font, as a last
resort you can italicize straight quotes.
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To automate the italicizing of straight quotes, you can create a GREP style. This involves the use of character
styles and paragraph styles, which are covered in Chapter 15. Rather than repeat myself, here I’ll just give the
bare bones on the GREP expression:

~'|~"

The tildes (~) before the straight single quote and straight double quote clarify that you want only these
characters (and not real quotes) affected. The vertical bar (|) functions as “or.” The GREP style will find
either dumb single or dumb double quotes and apply the italic character style to the result.

Apostrophes
An apostrophe is the same glyph as a single closing quote. What you need to watch out for is when InDesign
second-guesses you and thinks you want a single opening quote rather than an apostrophe. This is every
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editor’s pet peeve and is most likely to occur at the start of phrases where an apostrophe is used in place of

missing letters, or in dates where the apostrophe is used in place of missing numerals. To make sure you get
an apostrophe rather than a single opening quote, type Shift+Option+] (Shift+Alt+]). Easy enough, right?
And yet you see this problem repeated frequently. The third Friday in August is International Apostrophe
Day, when funny examples of misused apostrophes light up social media feeds. Make sure your work isn’t
among them.

Punctuation
In running text, The Chicago Manual of Style recommends that punctuation be set in the style of the word that
immediately precedes it. Parentheses or brackets, however, should be set in the same style as the rest of the
sentence.

Aesthetically, punctuation and hyphens look better when they “hang” outside the column measure —
something easily achieved using optical margin alignment. In English, there are no spaces before punctuation.

Punctuation in display type can look disproportionately large, so be prepared to reduce the size of your
commas, periods, colons, and quote marks to compensate, or to occasionally even replace them with
punctuation from another typeface.
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Dashes
There are three lengths of dash — five if you include the minus sign and the figure dash — and all serve
different functions.

The hyphen is the shortest dash, typically one-third the length of an em dash. Hyphens are used to break
single words into syllables when hyphenation is turned on (soft hyphens), to join ordinarily separate words
into compound words, or to link the words of a phrase that is used as an adjective. A hyphen doesn’t need
spaces on either side, except for suspended hyphens, which require a space after the hyphen. Suspended
hyphens are used when hyphenated adjectives refer to a common basic element and this common element is
shown only with the last term — such as upper- and lowercase, two- and four-wheel drive, pre- and post-war,
and so on.
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The figure dash (Unicode 2012) is the same width as a monospaced, i.e. non-proportional, digit and is used
for alignment purposes and in between digits of a telephone number. For fonts that don’t include a figure
dash, use an en dash, which is typically the same width.

The minus sign (Unicode 2212) is used to represent the notion of negative as well as the operation of
subtraction.

The en dash (Option+- or Alt+-) is used to indicate duration or a range of values. If you would say “to” when
reading the sentence aloud, then use an en dash. The en dash is also used instead of a hyphen in compound
attributives in which one or both elements is itself a compound. An example of the role of the en dash in such
instances was illustrated by Strunk and White in The Elements of Style with the following example: When
Chattanooga News and Chattanooga Free Press merged, the joint company was inaptly named “Chattanooga
News-Free Press” (using a hyphen), which could be interpreted as meaning that their newspapers were news-
free. There is no space around the en dash.
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The em dash (Shift+Option+- or Shift+Alt+-) is used to separate a parenthetical break in the sentence.

Em dashes should not touch the characters that precede or follow them. It’s preferable to put a thin space
(Cmd+Shift+Option+M or Ctrl+Shift+Alt+M) around em dashes to ensure they remain separate. A regular
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word space is too wide and in justified type will grow and shrink to achieve justification. A thin space is one-
eighth the width of an em space, is nonbreaking (and so prevents the dash from being separated from the
words next to it), and will not change size in justified text.

Some people find the em dash too wide and choose instead to use an en dash as a phrase marker, or to use an
em dash at 75–80 percent horizontal scale. If you opt for the latter, you can set up a GREP style (see Chapter
15) to automate the process.

In bibliographies, when listing more than one work by the same author, use three consecutive em dashes to
create a continuous rule. Track the space between the dashes to make sure they connect.

On a typewriter, an em dash was conveyed with double hyphens. Because some people resist unlearning this
habit, you’re likely to encounter this and all manner of other approximations of an em dash, which you’ll need
to fix. See the “Text Cleanup” section in Chapter 2, “Type on the Page,” for more about this.

Ellipses
An ellipsis indicates an omission or rhetorical pause. When the omitted words are within a sentence, use a
three-dot ellipsis preceded and followed by a space. And the important thing here is that it’s three dots —
don’t get carried away with the finger held down on the keyboard. Style manuals vary, but typically when the
omission occurs at the end of a sentence, add a period at the end of the sentence after the ellipsis.

A three-dot ellipsis is included in most standard font sets (Option+; /Alt+0133). If you find the dots of the
ellipsis character too tightly spaced, you can create your own ellipsis with dots separated by thin spaces. Use
Find/Change to automatically replace any other ellipsis forms with your custom ellipsis, or set up a GREP
style to automate their conversion within the text.

End Marks
An end mark is a common device in magazines, newsletters, and journals to signify the end of a major article,
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especially if the article spans several pages. The end mark can be a character taken from a picture font, such as
the venerable Zapf Dingbats, or an inline graphic, such as the logotype of the publication. If you want to go
down this latter route, take a look at Indyfont, a script from Theunis de Jong — aka “Jongware” — that allows
you to convert your logo into editable type: www.indiscripts.com.

End marks should be scaled so that they are no bigger than the cap height of the text; depending on the mark
you’re using you may want to size them to the x-height. They can be separated from the text with an en space
(Cmd/Ctrl+Shift+N) or set flush right with the margin (Shift+Tab). To ensure consistency, create an End
Mark character style. End marks can also be incorporated into a nested style — see the “Nested Styles” section
in Chapter 15, “Styles.”

Multiplication and Minus Sign
The multiplication, or dimension, sign is its own character, more symmetrical than a lowercase x. The minus
sign is slightly wider than a hyphen and may be slightly wider or narrower than the en dash, depending on the
typeface. The multiplication sign is critically important in math equations with variables, e.g., 3x × y, and for
accessibility, where using a lowercase x ruins the meaning of the equation. To access these and other math
symbols, filter your view in the Glyphs panel to show math symbols.
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Choose a Style Guide

All publishers have their own style manual, which specifies the use of punctuation, spaces, and other
points. Many publishers take as their starting point The Chicago Manual of Style. You can buy the style
guides of large publishers like the New York Times, the Guardian (UK), and the Associated Press.
Regardless of which style manual you follow, most importantly be consistent.

Symbols
Frequently used special characters can be accessed by choosing Type > Insert Special Character > Symbols; all
others can be accessed from the Glyphs panel. As with punctuation, as your text gets bigger, the symbols
should become proportionately smaller.

A Copyright symbol precedes either author or year and is always followed by a space. The Registered symbol
and Trademark symbol are not preceded by a space.

The @ symbol (or at sign) in certain typefaces looks too big alongside lowercase text and may require
adjustment, especially on business cards.

When using the degree symbol, there should be no space between it and the C or F that follows. Some
typefaces have separate glyphs for degree Celsius and degree Fahrenheit.

The appearance of these symbols, and others, such as the number symbol (aka the pound symbol or hash tag),
can vary greatly from one typeface to another. Be prepared to adjust their size, weight, position, and spacing

— or to use a symbol from a different typeface altogether — according to the needs of the project.1 As your
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text gets larger, the symbols should become proportionately smaller.

1. For a fascinating history of the hash tag, aka octothorpe, listen to the “99 Percent Invisible” podcast:
https://99percentinvisible.org/episode/octothorpe.

White Space Characters
There are 12 other spacing characters in addition to the word space, and they can be accessed by choosing
Type > Insert White Space, or by selecting Insert White Space from the Type tool context menu (Ctrl-click
or right-click). All the white space characters are nonbreaking.

Em Space
An em space (Cmd+Shift+M/Ctrl+Shift+M) is a relative unit, equal in width to the size of your type. In 12-
point type, an em space is 12 points wide; in 72-point type, it is 72 points.

En Space
An en space (Cmd+Shift+N/Ctrl+Shift+N) is half the width of an em space.

Flush Space
A flush space is used to flush out a series of items across a column without increasing the word spacing within
those items. Flush spaces work only with Justify All Lines alignment.

Hair Space
A hair space is 1/24 the width of an em space. It can be used as an alternative to a thin space.

Nonbreaking Space
The same width as a word space, a nonbreaking space (Cmd+ Option+X/Ctrl+Alt+X) prevents two (or more)
words, like a name, from being broken across a line. If you encounter a hyphenated name, like Gil Scott-
Heron, you can use a nonbreaking hyphen (Insert Special Character>Hyphens>Nonbreaking Hyphen) to
prevent the hyphenated name from breaking across a line.
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The Nonbreaking Space (Fixed Width) option is used in justified type to prevent the space from varying with
the other spaces on the line in order to achieve justification. Instead of using a nonbreaking space, however,
you can apply No Break to a selected range of text. See Chapter 10, “Breaking (and Not Breaking) Words,
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Lines, Paragraphs, and Pages.”

Thin Space
A thin space (Cmd+Option+Shift+M/Ctrl+Alt+Shift+M) is one- eighth the width of an em space. This
makes it a good choice on either side of an em dash or to separate the three dots used in place of an ellipsis.

Figure Space
A figure space is the same width as a figure in the typeface, if the typeface you’re using is designed with
tabular lining or tabular oldstyle figures, where each figure occupies the same set width. Figure spaces can be
used to help align numbers in tables.

Punctuation Space

TIP: To make word space characters visible in GREP expressions, use \x{0020}, which is the
Unicode notation for the space character. Or use the code \s, which stands for any white space
(including paragraph breaks and tabs).

A punctuation space is the same width as an exclamation mark, period, or colon in the typeface.

No Double Spaces, (Pretty) Please
This may be old news to most, but it’s surprising how many people didn’t get the memo: no multiple spaces.
Ever. Not after a period and especially not to align text. If you ever feel yourself tempted to press that spacebar
more than once, you’re on the wrong track. Proportionally spaced fonts require only a single space between
sentences — any more breaks up the consistency of your word spacing and looks ugly and amateurish.
Consistency is king, and that begins with even word spaces.

The convention of double spacing after a period is a holdover from the days of the typewriter, when fonts
were monospaced — that is, all characters had the same width regardless of the shape of the letter, so that an i
occupied the same width as a w. The characters were so wide and so open that a single space wasn’t enough
between sentences.

These days, our typefaces — unless you’re using a monospaced typeface — are proportionally spaced, which
means that each character has a unique width corresponding to its character shape. The word spaces in
proportionally spaced typefaces are designed to separate sentences perfectly. Putting two spaces after every
period undermines the goal of even type color and looks unprofessional.
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These days you’re more likely to see a typewriter displayed as a piece of retro art than as a working typesetting
tool, but the double-–spacing habit persists. You may inherit a document with extra spaces, or errant spaces
may have crept into your document; either way, choose Edit > Find/Change, and then from the Query drop-
down menu, choose Multiple Space to Single Space. This will zap any extra spaces in the blink of an eye.

Of course, whenever there’s a “rule,” someone’s going to want to break it, and no orthodoxy should go
unchallenged. For a provocative alternative opinion, see “You Can Have My Double Space When You Pry it
From My Cold, Dead Hands,” by Tom Lee, reproduced in the Atlantic: “[…] nor should we assume that just
because typographers believe earnestly in the single space that their belief is held entirely in good faith.
They’re drunk on the awesome power of their proportional fonts, and sure of the cosmic import of the
minuscule kerning decisions that it is their lonely duty to make.” You’ll notice that the article is reproduced on

the website with a single space after each period.2

2. www.theatlantic.com/entertainment/archive/2011/01/you-can-have-my-double-space-when-you-pry-it-from-my-cold-dead-hands/69592/

The Glyphs Panel
“Give me 26 soldiers of lead and I will conquer the world.” It’s an oft-repeated quote about the power of the
printed word. Some attribute it to Benjamin Franklin; others to Karl Marx. Regardless of who said it, it
makes a good point. To update it would diminish its power: “Give me (up to) 65,536 Unicode glyphs …”
doesn’t have the same gravitas. But today that’s how many potential “digital soldiers” we have under our
command.

OpenType fonts, which we’ve been using since the turn of the century, are based on Unicode and offer a
character set of up to 65,000. In reality, no font comes close to having this many characters, but OpenType
Pro fonts have expanded character sets that include a full range of Latin characters, accented characters to
support central and Eastern European languages such as Turkish and Polish, and Cyrillic and Greek
characters. In addition to making multilingual typography easier, OpenType Pro fonts also offer all kinds of
typographic delicacies — such as extra ligatures, real small caps, real fractions, and oldstyle numerals.

196

http://www.theatlantic.com/entertainment/archive/2011/01/you-can-have-my-double-space-when-you-pry-it-from-my-cold-dead-hands/69592/


With such power at our fingertips the challenge is how to harness it.

Providing access to the full range of glyphs is the Glyphs panel, which also exists in a slightly dumbed-down
form in Illustrator and Photoshop. It’s easy to use: Find the glyph you’re after, make sure your Type tool is
inserted in a text frame, and then double-click the glyph to insert it into the text. But invaluable though it is,
your strongest impression of the Glyphs panel may be that there must, in the twenty-first century, be a more-
automated, less error-prone way than visually sifting through rows and rows of glyphs to find the proverbial
needle in a haystack.

There isn’t.

But there are things you can do to make it easier, like viewing a subset of the font (such as math symbols,
ornaments, or currency symbols) or changing the view size of the glyphs. If you know what the glyph is called,
you can search for it by name in the Search field. Or, if you know it, you can search by Unicode number or
Character or Glyph ID.

One of the biggest timesavers is making a glyph set. That way, you’ll have those glyphs you use often close to
hand, rather than having to hunt for them repeatedly.
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Creating a Glyph Set
If you find yourself repeatedly using the same glyphs, making a glyph set saves you the trouble of looking for
them each time you need them. To create a glyph set, do the following:

1. Choose Type > Glyphs.

2. From the Glyphs panel menu, choose New Glyph Set, name your glyph set, choose the method you
want to use to order your glyphs (insert at front, append at end, or Unicode order), and click OK.

3. Click the glyph you want to add to your glyph set. Right-click, and choose Add to Glyph Set from the
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context menu that appears.

4. To view your glyph set, choose it from the panel menu or Show menu (you may need to scroll upward
to see your glyph set in the Show menu choices).

TIP: The aptly named FontAwesome is an incredibly useful icon font set, especially if you
need social media icons. You can download it here: fontawesome.io. Using the
FontAwesome Cheatsheet (fontawesome.io/cheatsheet), you can copy and paste the required
glyphs into InDesign.

You can edit a glyph set by choosing Edit Glyph Set from the Glyphs panel menu. As appropriate, deselect
Remember Font with Glyph when you want only the glyph itself and not the specific font. If a typeface
doesn’t have that particular glyph, the glyph will revert to its original typeface.

Emoji and Symbols Viewer
A limitation of the Glyphs panel is that although it enables you to access all the available glyphs in a given
typeface, it doesn’t help find a font that contains a specific glyph you’re looking for. For example, prime marks
and the minus sign are available in only some fonts.

If you use a Mac, you can use the Emoji and Symbols Viewer (BabelMap is a free Windows equivalent) to do
this.

Go to System Preferences, and choose Keyboard. Click the Keyboard tab, and select Show Keyboard &
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Character Viewers in Menu Bar. This adds the Input menu to the menu bar in the Mac Finder next to the
date and time. Select Show Emoji & Symbols to open the utility.

Select a glyph category in the left column to see the glyphs it contains. When you click one of these glyphs in
the middle area, its name appears at the upper right above a list of the way that glyph is displayed in your
currently installed fonts. Click one to see its name and a larger display in the upper right.

TIP: Both macOS and Windows support keyboard layouts for multiple languages. Make sure you’re
using the appropriate one so that you have ready access to the characters you need.

Double-click the glyph to insert it into your InDesign document at the point of your cursor. You can also add
it to your favorites.

You can customize the categories that appear in the Character Viewer. Click the Action menu (gear icon) in
the upper left, and select Customize List.

Substituted Glyphs & Missing Glyphs
A Composition preference lets you see at a glance where substituted glyphs, such as for discretionary ligatures,
swash characters, and fractions, are used in the text. Choose Preferences > Composition, and select
Substituted Glyphs. In Normal view, the substitutions are highlighted in yellow. This may be useful if you’re
revisiting an old project or inheriting a document from someone else, but with so much other highlighting
going on, I prefer to have this deselected.

Missing Glyph Protection in the Advanced Type Preferences offers two options for avoiding missing glyphs.
Protect While Typing substitutes Minion Pro for the missing glyph; Protect When Applying Fonts notifies
you with a warning message, and it then retains the current font for what would be the missing glyph and
changes the rest of the selection to your chosen font. This preference has no effect when pasting text or
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placing text from other applications. Alternatively, if you want to change to an available glyph, use
Find/Change to find any glyph from any font and replace it with any other glyph from any other font. Select
the glyph you want to change, right-click, and choose Load Selected Glyph in Find from the context menu.

Characters and Glyphs: What’s the Difference?

Ever wondered about the difference between a character and a glyph? Every character in a typeface is
represented by a glyph assigned to a Unicode number. While most characters are represented by a
single glyph, certain characters may be represented by more than one — a default form and alternate
form(s). This means that the same Unicode number may have a number of variations, with each
variation assigned its own Glyph ID (GID) value. A triangle in the lower-right corner of the
character square in the Glyphs panel indicates the presence of alternate glyphs — click and hold to
see the other glyphs assigned to that Unicode number. To find the specific GID number for the
glyph, hover your cursor over the glyph to view the tool tip.

OpenType Features
You can access InDesign’s OpenType features through the Type Contextual Controls, from the OpenType
menu on the Control panel, or through the OpenType features dialog that is part of a paragraph or character
style definition. Note that the list of features on the OpenType menu is really a list of potential features. There
is no OpenType typeface that includes them all, and indeed some are mutually exclusive. If an option is
surrounded by square brackets, it is unavailable for that particular typeface.

Ligatures, Diphthongs, and the Dotless i
Ligatures are two or more intersecting characters fused into a single character. If fact, everyone’s favorite glyph
— the ampersand — started out as a ligature, combining E and t, forming the Latin word et, meaning “and.”

Type Contextual Controls

When you turn on Type Contextual Controls (Preferences > Advanced Type), a blue adornment
appears below selected text and a pop-up row of characters allows you to choose from available
OpenType alternates or fractions. This relatively new feature is an alternative to using the Glyphs
panel to access alternates and makes the existence of OpenType features more obvious.

They are used to avoid collisions, most commonly between the finial of the lowercase f and the dot of the i or
between the finial of the f and the ascender of the l. Beyond the obvious letter combinations of fi and fl, as
English continues to create and absorb words, new ligature combinations are necessary. Words like fjord, hors
d’oeuvre, and offjár place demands on a typeface that its original designer could not have foreseen. If you’re
doing multilingual publishing, the range of available ligatures might be a factor in your choice of typeface.
InDesign is smart enough to substitute individual glyphs for the ligature when the letterspacing is increased
and Check Spelling is smart enough to recognize them and not flag words that contain them as misspelled.
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Ligatures are a response to a design problem and as such may not be necessary with sans serif typefaces, where
there’s no danger of a character collision. First try setting the type without ligatures. If the characters collide,
then turn on ligatures. If they don’t, well — if it ain’t broke, don’t fix it, especially because using ligatures may
make these letter combinations appear more tightly set than the rest of your type. Ligatures can be turned on
from the Control panel menu or, when applied as part of a paragraph style, in the Basic Character Formats.
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OpenType fonts may contain discretionary ligatures, such as , , and . In certain decorative typefaces
they may allow for unique letter combinations that give a hand-lettered look.

Diphthongs are ligatures that visually represent the pronunciation of a combined vowel. The most common
examples are æ or Æ and œ or Œ, such as in Cæsar, encyclopædia, mediæval, and œuvre. Their usage is
considered archaic in modern English, especially American English. Both discretionary ligatures and
diphthongs can be applied on a case-by-case basis through the Glyphs panel. Choose Discretionary Ligatures
from the Show menu to isolate the available options.

Because ligatures can look odd in display type, you may be better off kerning to avoid character collisions, or
replacing the i with a dotless i (Unicode 0131). On the Mac, the dotless i can be typed by pressing
Shift+Option+B; on macOS or Windows, to locate the dotless i in the Glyphs panel, type 0131 in the Search
field. For an example of the dotless i used in practice, visit the AIGA’s 100 Years of Design website:
celebratedesign.org.

Ornaments
Sometimes referred to as fleurons, typographic ornaments were historically used to expand the typesetter’s
palette. While some typefaces, like Chaparral Pro, contain playful ornaments, ornaments typically create a
historic feel — useful in a book cover, title page, or chapter opener, or in repetition to create a typographic
wallpaper suitable for endpapers. Ornaments can also useful as bullets or end marks. Some ornaments were
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designed to be used in multiples to make decorative frames — these days it’s a lot easier to achieve the same

result using a custom brush in Adobe Illustrator.

FF Chartwell and Infographics Fonts

Chartwell3 is a font that makes clever use of discretionary ligatures to let you create pie charts and bar
graphs, as well as rings, roses, radars, bubbles, scatters, and floating line charts — all in InDesign.
Type the percentages in the Story Editor; in Layout view, with Discretionary Ligatures turned on,
the result is converted to a pie chart (or a bar chart, area chart, or rose chart, depending on which font
of the Chartwell family you’re using).

3. www.fontshop.com/families/ff-chartwell/buy

To make the pie chart into a ring chart (above) follow the numbers by a letter. The size of the interior
space is determined by which letter you use. Lowercase a makes the smallest hole, uppercase Z, the
biggest. The data remains as editable text, allowing for painless updates via InDesign’s Story Editor.

The full Chartwell package costs over $100, so if you’re lacking a project that will pay for it, you can

try the free Amazing Infographic4 to get a flavor of the concept.

4. www.dafont.com/amazing-infographic.font

For example, the following Amazing Infographic syntax yields the results below: @b@b5050%
@p@p6565%. Ligatures must be turned on, and metrics kerning used.

There is also AtF Spark,5 which lets you create sparklines — those in-line charts popular in the
financial pages of newspapers. If you need fully customizable clock icons, for just a few bucks there’s

Clocko6 — just type in the time, like 11:55, and then set the font to Clocko. The following syntax
yields the result below: x9:12 x21:12. The letter preceding the numbers determines the style of
clockface. For a 24-hour clock, turn off ligatures.
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5. www.github.com/aftertheflood/spark

6. www.myfonts.com/fonts/upir-typo/clocko

Some typefaces may contain decorative catchwords, like “the,” “and,” “of,” and so on, that are available as a
single glyph. Catchwords are also available as whole fonts — for example, HWT Catchwords, available on
Typekit.

Swash Characters
Some italic styles of OpenType fonts have swashes; you can check by opening the Glyphs panel and looking
for Swash in the Show menu. Where available, these are accessible through the Type Contextual Controls,
the OpenType menu, or the Access All Alternates subset on the Glyphs panel. Typically, swashes are used at
the beginning of words or sentences. Some fonts also have lowercase swash characters called finials or terminal
characters, intended for use at the end of a word or line. Used sparingly (and never in all caps) swashes can
add a flourish to headlines, titles, logos, drop caps and initial letters, chapter headings, invitations, and — if
you’re a pirate — your treasure map.
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Figures
OpenType Pro fonts offer two styles of figures: lining, so called because they line up with the cap-height and
the baseline, and oldstyle, which are as tall as the x-height of the type, with figures 3, 4, 5, 7, and 9 having
descenders, and 6 and 8 having ascenders. Both of these styles are available as proportionally spaced or tabular
(monospaced) versions.

Lining figures are appropriate for working with text in all caps; oldstyle figures combine better with body text.
Selecting the right typeface for a project is about the numbers as well as the letters. If there are numerals in
the text, like address information, or quantities and measurements in marketing collateral, you’ll need
proportionally spaced figures. If you’re working on a financial report or with columns of statistics, you’ll need
tabular figures.

Another consideration, if your text contains a lot of code, is the similarity of the Os and the 0s. Choose
Slashed Zero from the OpenType menu to put a diagonal slash through the zeros to clear up any confusion.
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Fractions
PostScript and TrueType fonts have the following fractions in their character set: ¼, ½, and ¾. Certain
OpenType Pro typefaces may also contain ⅛, ⅓, ⅔, ⅛, ⅜, ⅝, and ⅞. More importantly, OpenType typefaces
allow you to make custom fractions. Highlight the numbers you want to convert to fractions and choose
Fractions from the OpenType menu on the Control panel. Unfortunately, leaving this feature on will
“fractionize” all numerals in your text, so it’s necessary to apply it on an as-needed basis. If you’re working
with a lot of fractions and that sounds too labor-intensive, you can incorporate this GREP style into your
paragraph style.

\d+/\d+

This will match one or more digits followed by a slash, followed by another sequence of one or more digits.

The Fractions character style has one attribute only: Fractions selected in the OpenType Features dialog.

If you’re not using an OpenType Pro font, you can still make your own fractions. Convert the numerator to
superscript, the denominator to subscript, and replace the slash or virgule with a fraction bar or solidus
(Option/Alt+Shift+1). For best results, in Advanced Type preferences set the Super/Subscript size to 60%, the
Superscript position to 33%, and the Subscript position to 0. To automate this, you can download Dan
Rodney’s Proper Fraction script from danrodney.com. No matter how you get your fraction, if it follows a
whole number, no space is necessary before the fraction, though I prefer to add a hair space.

Stacked fractions are favored by some for setting math and other measurements. These are not available in
most fonts, nor do they work with InDesign’s OpenType fractions. You could create them yourself in
InDesign — make the numerator superscript, the bar an en dash, and the denominator subscript, and then
kern the hell out of the letter pairs until the bar and denominator are stacked beneath the numerator. But the
result isn’t great and life is too short.

Here are some workarounds for getting stacked fractions.

Download the font Nutso (stacked fractions are sometimes referred to as nut fractions) from Tiro Typeworks.
This nifty font allows you to use InDesign’s OpenType fractions feature to create arbitrary fractions:
github.com/TiroTypeworks.
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If all you need are the basic fractions, here’s a list of Google Fonts that have basic fractions (½, ¼, and ¾) as
stacked fractions.

Coda — by Vernon Adams

Telex — by Huerta Tipografica

Arbutus Slab — by Karolina Lach

Unica One — by Eduardo Tunni

Cherry Swash — by Nataliya Kasatkina

Economica — by Vicente Lamonaca

Special Elite — by Astigmatic

Undeveloped Potential?

If you’re frustrated with the fussiness and obscurity of some of InDesign’s OpenType features, then
you’re not alone. In June 2015, an open letter to Adobe signed by more than 3500 designers (I was
one of them) asked Adobe for a better user interface for type:

The introduction of OpenType fonts in 2000 offered designers a rich and sophisticated typographic repertoire.
The number of fonts that support these typographic features has grown exponentially over the years. And yet
we — the designers, producers, and users of digital type — have observed with growing despair how software
applications offering typesetting capabilities have failed to provide an adequate typographic interface.

As a founding partner of the OpenType specification and a leading developer of applications for design
professionals, Adobe can be expected to lead in foregrounding the potential of the technology. However, the
font menus in Adobe software are severely lacking, giving users incomplete and/or needlessly convoluted access
to typographic features. Therefore, we urge Adobe to improve the OpenType user experience. This will unlock
tremendous existing value for users who are mostly unaware of the amazing possibilities current OpenType
fonts provide.

Some minor improvements have happened since that time, but while InDesign offers by far the best

OpenType support of any software, there is still room for improvement.7 You can add your two cents
about this or any other InDesign feature through the User Voice program:
https://indesign.uservoice.com.
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7. https://ilovetypography.com/2014/10/22/better-ui-for-better-typography-adobe-petition

You can create stacked fractions in Microsoft Word’s equation editor, then copy and paste these into
InDesign. They are pasted as an inline or anchored graphic, which you can scale according to your needs.

Contextual Alternates
Some OpenType faces, usually scripts, have alternate characters that let you personalize your type. Some
contextual alternates are designed to connect better in certain letter combinations; others exist just to expand
your palette. Sometimes there may be several alternates to choose from, and applying them randomly,
especially with handwriting or calligraphic typefaces, creates an organic look. You can choose the alternates on
a case-by-case basis using the Type Contextual Controls or by choosing Alternates for Selection from the
Show menu in the Glyphs panel. Alternatively, choose Contextual Alternates from the OpenType menu, and
as you type, the glyph to the left of your cursor may change according to the glyph that follows it — if there’s
an alternate for that particular letter combination.
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Titling Alternates
Some OpenType fonts have special “titling” characters intended for type at sizes of 72 point and above. The
letters of titling alternates are nuanced. The thin parts of the strokes are relatively thinner, the serifs are more
refined, and the letters are more condensed, giving them a more elegant look.

Stylistic Sets
Not to be confused with a 1970s Philadelphia soul group, stylistic sets tap into OpenType’s potential to
provide whole sets of alternates that allow you to vary the character of the typeface. Rather than using the
Glyphs panel or Type Contextual Controls to substitute every b and g, for example, with your preferred
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alternates, you can choose a stylistic set that uses those alternates as its default form for the b and g characters.
To find out what’s in a given stylistic set, you can use the Glyphs panel and filter your view using the Show
menu. InDesign allows more than one stylistic set to be applied on the same text to create unique
combinations. Like all OpenType features, stylistic sets can be incorporated into a paragraph or character style
definition. This once obscure and misunderstood feature has been made slightly less obscure. There are more
fonts that have stylistic sets, but relatively few of them have descriptive names for those sets to indicate how
they might be used. Some fonts come with accompanying documentation in the form of PDFs or webpages
that offer more information about their stylistic sets.

▄

As you’ve seen, there are many details to consider. While there’s usually more than one way to get them right,
there’s always a multitude of ways to get them wrong, so keep that fine-toothed comb handy. Each of these
details is an opportunity to demonstrate craft in our work.
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Chapter 9

Paragraph Indents and Spacing

Typography, like all communications media, relies on established conventions that are understood,
often unconsciously, by its audience. One such convention is the chunking of our text into separate
paragraphs, each of which represents a unit of thought. Although there are several ways to indicate a
new paragraph, two methods are most prevalent: indenting the first line and adding spacing between
paragraphs. In this chapter, I’m primarily concerned with the hows and whys of these two time-
honored conventions, but I also look at the use of other types of indents for differentiating specific
types of paragraphs.

First-Line Indents
The humble first-line indent plays a crucial role in the readability of documents, alerting the reader that one
paragraph has ended and a new one is about to begin. First-line indents also provide a visual pause and
necessary white space to what might otherwise look like a forbidding block of type.

How Big Should They Be?
There is no hard-and-fast rule regarding the size of first-line indents, but 1 em (or a bit bigger if the typeface
has a large x-height) is a good starting point. If you’re using 10-point type, for example, a 10-point first-line
indent is suitable; anything less and the indent may be missed.

“Typesetting without indentation makes it difficult for the reader to comprehend what has been printed.
And that is its most important disadvantage. While blunt beginnings seem to create a uniform and
consistent impression when compared to normal typesetting, this impression is paid for with a serious loss
of comprehension.”

— Jan Tschichold, The Form of the Book: Essays on the Morality of Good Design

Alternatively, you can use your leading increment: If your text is 10/12, then a 12-point first-line indent is
suitable. Some people prefer a slightly larger indent, especially when working with wide columns. Just make
sure your first-line indent is smaller than the shortest last line of your paragraphs, to avoid creating ugly areas
of trapped space between paragraphs.

Contradicting the advice above, you can use bigger indents to good effect. An extreme indent can be as wide
as mid-column and be applied to one or more lines. This technique provides an unmissable paragraph signal
and produces an interesting text shape, which can add graphic interest.
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How (and How Not) to Add First-Line Indents
First-line indents can be applied through the Control panel or the Paragraph panel, or (preferably) can be
incorporated into a paragraph style definition. Never create your first-line indents with tabs or, worse, by
pressing the spacebar multiple times.
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While first-line indents are generally well suited to reading matter, be it newspaper articles or literature,
block-style paragraphs with paragraph spacing may be more appropriate for reference material, instructional
manuals, or text intended to be read onscreen. To some degree, it’s a matter of preference, but here are some
things to consider:

Don’t use first-line indents and paragraph spacing to differentiate body text. It’s an either/or
proposition.

Don’t use first-line indents on centered or right-aligned type.

Don’t indent the first paragraph of an article. This is unnecessary because the indent serves to separate a
paragraph from the one that precedes it.

If a paragraph follows a heading or subhead, the first-line indent is unnecessary.

Dropping the first-line indent and adding a line of spacing before a paragraph is a simple way to
indicate a separation without implying a hierarchical difference between two paragraphs. For more
emphasis, a graphic element between continuous paragraphs can serve as an elegant separator.

First-line indents are more economical than paragraph spacing in terms of space usage.

Using first-line indents rather than paragraph spacing results in a more even type color because you
don’t have horizontal stripes of white space between paragraphs.

It’s easier to align type to a baseline grid when using first-line indents rather than paragraph spacing.
Adding a whole line space is too much between paragraphs. If you add less than a whole line of
paragraph space, however, the baselines of your type will not align across columns.

When you have wide text columns, you can make a statement with a wide indent.

Alternatives to the First-Line Indent
In some newspapers, where space is tight, paragraphs are set flush left. This is problematic if the last lines of
the paragraphs run the full column measure, making it difficult for the reader to discern one paragraph from
the next.

An alternative to using first-line indents is to run the paragraphs together and use a decorative mark between
them. This maintains the flush look of the text without compromising its meaning. In medieval manuscripts,
a pilcrow was used to differentiate paragraphs; in certain contexts, this can still be an effective solution.

ANOTHER WAY TO DIFFERENTIATE PARAGRAPHS

“Brave and generous friend, will you let me ask you one last question? I am very ignorant, and it troubles
me — just a little.” ¶ “Tell me what it is.” ¶ “I have a cousin, an only relative and an orphan, like myself,
whom I love very dearly. She is five years younger than I, and she lives in a farmer’s house in the south
country. Poverty parted us, and she knows nothing of my fate — for I cannot write — and if I could, how
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should I tell her! It is better as it is.” ¶ “Yes, yes: better as it is.” ¶ “What I have been thinking as we came
along, and what I am still thinking now, as I look into your kind strong face which gives me so much
support, is this: — If the Republic really does good to the poor, and they come to be less hungry, and in
all ways to suffer less, she may live a long time: she may even live to be old.” ¶ “What then, my gentle
sister?”

As an alternative to either the first-line indent or paragraph spacing, a
pilcrow (¶) — Option/Alt+7 — is used to differentiate the paragraphs.

Hanging Indents
There are two types of hanging indents: left-hanging (also known as outdents) and right-hanging (or last-line
indents). Left-hanging indents are used in dictionaries, bibliographies, and sometimes on résumés or CVs.
They look sharp and give prominence to the item or entry on the left side of the text frame. Right-hanging
indents are used in price lists, on restaurant menus, or in a table of contents with long, multiline entries. The
purpose of right-hanging indents is to create vertical white space around the prices or numbers so that they are
more easily read.

Left-Hanging Indents
With left-hanging indents, all the lines of the paragraph are indented except for the first line, which sticks out
beyond the left margin edge. Hanging indents can be distinct — the bigger the outdent, the more dramatic
the effect. They are achieved by first applying a left indent to the text, then applying a first-line indent with a
negative value, typically the same amount as you entered for the left indent. For example, if you specify a left
indent of 12 points, your first-line left indent will be −12 points.

Right-Hanging Indents
Right-hanging, or last-line, indents extend the last line of a paragraph beyond the edge of the text to
accentuate its content. They are achieved by applying a right indent to the text, then applying a negative last-
line indent. Typically, the last-line indent is the same amount as entered for the right indent. For example, if
you specify a right indent of 12 points, your last-line right indent will be −12 points.

Left and Right Indents
Certain types of paragraphs benefit from indentation on both edges. Indenting an entire block of text on the
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left, the right, or both is appropriate in the following situations:

To indicate a quoted passage of text or extract. Make the type 1 point smaller than the body text,
indented both left and right, and add an even amount of paragraph space — usually a half-line space —
before and after the passage. As with first-line indents, the left and right indents should be large enough
to be noticed, but not so large that the line length is too short. There’s no need for quotation marks at
the start and end of the indented passage.

In tables of contents or technical documents, the indentation signifies a lower level of the hierarchy.

When working with verse, center the longest line in the verse, then insert your cursor at the beginning
of this line and note the Horizontal Cursor Position on the Control panel. Next, select all the lines,
make them left aligned, and add a left indent that is the value of the Horizontal Cursor Position.

Text Insets
Text insets are margins, or padding, within your text frame. Choose Object > Text Frame Options or press
Cmd+B (Ctrl+B) — or just Option/Alt+double-click the text frame with the Selection tool. Inset spacing and
paragraph indents are cumulative; for example, add a 1-pica left inset to a frame containing text with a 1-pica
left indent and your text is indented by 2 picas. In terms of indenting your text left and right, it’s an either/or
proposition. In general, it’s easier to apply indents through the left/right indent values and leave the inset
spacing at zero. However, using an inset is more convenient if your text is clearly “boxed” — for example,
informational text in a colored or tinted rectangle. A shortcoming of text insets is that as soon as you make
your frame anything other than a simple rectangle, you have just a single inset value, losing the ability to set
the indent of all four sides independently.

Space Before and Space After
Time for another sweeping pronouncement: Never under any circumstances have more than one consecutive
paragraph mark in your document. To put it another way, never create line spaces by pressing Return (Enter).
There are no exceptions — at least none I can think of. If text that you place in InDesign has extra returns
(very likely), then zap ‘em with Find/Change: Cmd+F (Ctrl+F). An easy way to do this is to choose the
predefined Multiple Return to Single Return GREP query in the Find/Change window.
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Now you might be thinking, what’s the big deal? Why not type a harmless extra return or two between
paragraphs? And it’s true: The sun will still rise if you insist on maintaining this bad habit. But there are good
reasons to avoid extra returns:

Using returns for paragraph spacing is another example of “typewriter” thinking. It allows no flexibility
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in the size of the space between paragraphs. Every time you create a new paragraph by pressing Return,
the blank paragraph has the same formats (including the leading) as the paragraph before it.

If your text flows to multiple columns or pages, a return at the top of the column or page creates
unwanted vertical space.

If you’re creating EPUBs and you use blank returns to create space between paragraphs, the EPUB
export ignores them.

If you use Keep Options to keep a heading with the paragraph that follows, these will not work, because
the heading will stay with the next blank paragraph instead of the actual text.

Instead of pressing Return twice or — heaven forbid — more than twice, use Space Before or Space After
from the Control panel or, preferably, in the Paragraph Style Options. While occasionally it’s necessary to use
both Space Before and Space After, usually you only need one or the other. If you do use both, keep in mind
that InDesign adds the values of Space Before and Space After together rather than applying the larger of the
two.
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Most of the time, I use Space Before because that’s what I’ve always used. Pick one and stick with it. As well
as giving you complete flexibility in the size of the space between paragraphs, paragraph spacing is polite
enough to disappear when not needed (such as at the top or bottom of a column or page).

For those occasions when you need space before a paragraph at the top of a frame, you can use the First
Baseline offset. Choose Object > Text Frame Options, click Baseline Options, then choose Fixed from the
drop-down menu and enter the height of the space you want above the text in the Min: field.

In a book scenario, if you need space before a chapter-opening paragraph to provide a visual pause between
chapters, a useful trick is to use an invisible paragraph rule (see page 164). This is more flexible than the First
Baseline offset solution because it can be incorporated into a paragraph style and will move with the text flow.
Set the Paragraph Rule to On, and the color of the rule to None. Next, increase the offset of the rule to
introduce the required amount of space between the text and the top of the frame. So long as Keep in Frame
is selected, the invisible rule remains fixed at the top of the frame and the text moves down to the required

219



position on the page.

This approach has the added benefit that you don’t need to make a separate master page for the chapter
openers, which, if the text reflows, can end up being applied to the wrong page. For a similar technique that
allows you to start a lead paragraph in the same position regardless of the number of lines in the chapter title
that precedes it, see Chapter 15.

Proximity
Information that belongs together should have a visual connection. Make sure any paragraph spacing
accentuates rather than detracts from the connection between related pieces of text. Organizing your material
into clusters of information — subheads and body text, for example — establishes the rhythm of your type.
Readers will interpret the space between such clusters as a pause, the next cluster as being a new idea.

To reinforce this relationship, subheads should be closer to the text that follows them than to the text that
precedes them. This may seem obvious, but it’s a rule that’s frequently broken.
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To ensure that this connection isn’t broken — by a column or page break, for example — set your Keep
Options for your subheads to Keep With Next 2 Lines.

▄

Indents and spacing provide essential spatial cues. The white space that they create enhances the message of
the text and serves as visual pause for the reader, making our documents more digestible and more
approachable. The majority of the time it’s best to follow time-honored conventions in their usage, but it’s
also possible to sometimes break the rules.
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Chapter 10

Breaking (and Not Breaking) Words, Lines, Paragraphs,
and Pages

An important aspect of typography is controlling how words, lines, and paragraphs break — or are
kept together — to enhance the meaning of the text and to facilitate easier reading. At the micro level,
hyphenation determines how words are allowed to break — or are prevented from breaking — across
a line. In addition, certain combinations of words, most commonly proper nouns, can be prevented
from breaking over a line with the No Break attribute. On a macro level, Keep Options serve a variety
of related purposes. They can be used to prevent paragraphs from breaking over a column or page, to
keep heads and subheads with the lines that follow them, and to make sure that certain classes of
paragraph always start in a new column or on a new page.

Hyphenation
There’s a lot of prejudice against hyphens. Some designers regard them as ugly and to be shunned, as if
broken words, like broken cookies, were somehow inferior. Hyphenation happens and you need to control it.
That doesn’t necessarily mean turning it off, although for some categories of text that’s preferable. For body
text, good hyphenation settings, in tandem with Justification settings and Optical Margin Alignment, are key
to achieving even type color. Hyphenation should be avoided in centered or right-aligned type, but in left-
aligned or justified type, when used appropriately, hyphenation is a compromise that is sometimes necessary
for good typography. By allowing words at the ends of lines to be broken, hyphenation minimizes the amount
of leftover space on a line. As long as the breaks make sense, and are infrequent, hyphenation is preferable to
the bad word spacing that might otherwise occur in justified type or the uneven rags that might otherwise
occur in left-aligned type. We’re used to reading hyphenated text. We do it without thinking, rarely if ever
pausing to consider the hyphen’s service to the cause of readability.

Good hyphenation can be labor-intensive. Appropriate hyphenation settings address most issues, but
InDesign can’t read your mind. There will be times when you need to intervene to make sure words break the
way you want. The manual adjustment of hyphens should be included in the fine-tuning of your publication;
text invariably gets edited throughout the production cycle, causing line endings to change, so there’s no point
investing time in the hyphenation until you know exactly what you’re working with. Try to get the client to
sign off on the text content before you start manually tweaking. And — an obvious point — start at the
beginning of the story and work forward.

Language Dictionaries
Hyphenation rules vary from one style manual to another and from one language to another. The dictionary
that is applied to your type determines how that type is hyphenated and spell-checked. If you’re working on a
multilingual document, make sure you apply the correct language dictionary to the appropriate passages of
text. Even if you have only an excerpt — a single paragraph in a second language, for example — choose the

222



appropriate language dictionary for that content so that the text is hyphenated and spell-checked in the right

language.

Obviously, we’d expect the Latvian dictionary to break words differently than the English:USA dictionary;
less expected, though, is that the English:UK dictionary hyphenates some words differently than the
English:USA dictionary. The UK dictionary breaks words by etymology, while the USA dictionary breaks
them according to pronunciation. So make sure you have the appropriate language dictionary selected. This
applies not just on a paragraph level, but also on a character level, when quoting phrases or passages in a
different language. For example, if your English text contains a passage of French, make sure the French
dictionary is applied to that passage so that the words hyphenate correctly and so that they are not flagged by
the English spell checker. If you have multiple such passages, it’s worth making a character style for this
purpose.

TIP: If you want a specific instance of a word or phrase to never hyphenate — and to be ignored by
the Spell Checker — select the word(s) and choose [No Language] in the Language drop-down
menu in the Control panel or Character panel. If you plan on doing this more than once, make a No
Language character style. This can be useful for long web addresses, where a hyphen might be
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ambiguous.

To see how a word might hyphenate differently depending on the language dictionary applied, select the
word, then choose Edit > Spelling > User Dictionary. Click Hyphenate to see the hyphenation points. Now
choose a different language from the Language drop-down menu, and click Hyphenate again to see how the
hyphenation points may differ.

Hyphenation Options
I love InDesign, so my next statement may sound harsh. But really, there’s no other way to say it: InDesign’s
default hyphenation settings suck. They will result in two-character stubs before and after hyphens, create
ladders running down the right edge of the frame from consecutive hyphens, and allow words to be broken at
the end of a paragraph and across a column. The good news is that these setting are easy to change, and
taking charge of these options will have a profound impact on the appearance of your type. Combined with
Justification settings and Optical Margin Alignment, appropriate Hyphenation settings are essential
components of professional typesetting. The Hyphenation dialog is accessible via the Control panel menu, the
Paragraph panel, or, most usefully, as part of Paragraph Style Options.

Varieties of Hyphens

Typically 1⁄3 of an em, the hyphen in most fonts is nasty, brutish, and short, and it could easily be
swapped with the hyphen from another font without anyone noticing. Certain fonts, however, have
very distinctive — and beautiful — hyphens. To quote Robert Bringhurst, “In the republic of
typography, the lowliest, most incidental mark is also a citizen” [Elements of Typographic Style, p. 77].

Words with at Least refers to the minimum number of characters necessary for a word to be a candidate for
hyphenation. I prefer to set this at 7, which results in fewer hyphens. Even though I’m an advocate of the
hyphen, I like them best in small numbers. Words of five characters don’t look good hyphenated. Having only
two characters before the hyphen break is disruptive and potentially confusing. Hyphenating words of six
characters is best avoided because words don’t divide comfortably into two three-character fragments.

After First and Before Last: These confusingly named options refer, respectively, to the size of the word
fragment (in characters) that is left behind and the size of the word fragment that is carried down to the next
line. When hyphenating words with a minimum of seven characters, leave at least three characters behind and
take at least four forward. Like all rules of thumb, this has its exceptions. For example, when the first two
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letters are a prefix, it may be best to break the word at the prefix. Words like “realign” or “reappear” would
look confusing if they were broken after “rea.”

A firm but flexible approach is best when it comes to hyphenation settings. Two-letter fragments after the
hyphen are always best avoided, but in rare cases even these may be the lesser of two evils. Ultimately, it comes
down to two things: how it looks, and whether it makes sense.

TIP: If you’re creating an accessible PDF, avoid hyphenation altogether because it interferes with
Acrobat’s ability to read the text aloud.

Hyphen Limit determines the maximum number of hyphens that can appear on consecutive lines. Consecutive
hyphens create a ladder effect on your column edge, so you’d never want more than two. Somewhat
confusingly, a hyphen limit of 0 actually allows an unlimited number of hyphens. Set this option to 1 to
prevent consecutive hyphens.

Here are some options for minimizing the number of hyphens:

Rewrite, if you have the authority and it’s appropriate.

Find a better break a few lines above and insert a discretionary hyphen — press Cmd+Shift+–
(Ctrl+Shift+–).

Tighten the letterspacing with tracking.

Take the tightest hyphenated line and set the last word to No Break. This will turn the word over to the
next line.

Hyphenation Zone: Despite the alluring name, this is just an invisible boundary on the right side of the frame.
The value you choose is the maximum amount of white space you want InDesign to allow before it begins to
apply hyphenation. A larger hyphenation zone allows more words to be carried down to the next line, thus
resulting in fewer hyphens and a harder rag. A smaller hyphenation zone results in more hyphenated words
and a softer rag. However, the Hyphenation Zone setting applies only to ragged text composed with the
Adobe Single-line Composer.

The Hyphenation slider: There’s always a trade-off between good spacing and hyphenation, especially when
working with justified text. Nothing demonstrates this more clearly than the Hyphenation slider. Better
spacing or fewer hyphens: pick one, or leave the slider in the middle for a happy medium.

Hyphenate Capitalized Words: Generally, you want to avoid breaking capitalized words, but if your text
contains a lot of them, selecting this option yields better word spacing. If you opt to break capitalized words,
avoid breaking someone’s name the first time it appears — after that, do whatever looks best in terms of type
color. A name that is familiar to the English-speaking reader more easily lends itself to being broken than one
that is not.
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Hyphenate Last Word: Deselect this option to prevent last words of paragraphs being hyphenated. However, if
the last word in a paragraph is very long, then consider breaking it. If you turn this off in your paragraph style
and need to make an exception, inserting a discretionary hyphen won’t work. You will first need to manually
override the style definition. With the paragraph selected, go to the Hyphenation dialog and select Hyphenate
Last Word.

Hyphenate Across Column: Deselect this option to prevent the last word of a column or page from being
hyphenated. Hyphenating across facing pages, while best avoided, isn’t as bad hyphenating across a page turn,
from a right page to a left page.

Discretionary Hyphens and Nonbreaking Hyphens
Discretionary hyphens are entered at the insertion point by pressing Cmd+Shift+Hyphen (Ctrl+Shift+Hyphen).
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They allow a word to hyphenate at that point. They’re intended for when a word at the end of a line is not in
your hyphenation dictionary, or when you want to break a word somewhere other than where the language
dictionary recommends. Discretionary hyphens are just that — discreet. If the text is edited so that the word
no longer needs hyphenating, the discretionary hyphen becomes invisible and lies dormant until needed.

The problem with discretionary hyphens is that unless you’re entering them one or two characters on either
side of what InDesign considers an acceptable break, they are ignored. This is because the discretionary
hyphen is being overruled by the Paragraph Composer and/or your Hyphenation settings — the “discretion”
is InDesign’s, not yours. A better option is to relax the Hyphenation settings for the paragraph in question.
For example, reduce the Words with at Least setting or increase the number of consecutive hyphens, or allow
capitalized words to hyphenate. Do this with H&J Violations (see page 173) turned on and with the Preview
box selected in the Hyphenation Settings dialog so you can evaluate how the changes are affecting the text.
This will either more readily allow discretionary hyphens or cause the paragraph to recompose in a way that
makes the hyphen unnecessary. When you do this, make sure that what you gain in improved spacing is worth
what you lose by having more word breaks.

A discretionary hyphen, inserted in front of the word, prevents a word from hyphenating. But if you’re using a
discretionary hyphen to prevent a URL from breaking and you intend to export the result as an interactive
PDF, there’s a problem. The discretionary hyphen prevents Acrobat’s Auto-Create web links feature from
recognizing the text as a URL. For this reason, use a No Break style (see below) instead.

Nonbreaking hyphens prevent a line from breaking at the hyphen but allow it to be broken elsewhere. They are
used to prevent compound words from breaking at the hyphen, as well as in phone numbers and web
addresses.
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Hyphenation and User Dictionaries
When a word isn’t found in your language dictionary, you can add it. Right-click the word and choose
Spelling > User Dictionary. Optionally, to specify the word’s hyphenation, click Hyphenate to view suggested
hyphenation points. You can add your own hyphenation points by inserting tildes, ranking them as you go:
One tilde indicates the best break, two tildes the second best, and so on. To prevent the word from ever being
hyphenated, insert a tilde before the first character. Click Add to add the word (and its hyphenation) to your
user dictionary. To change the hyphenation points for a word already in the dictionary, right-click the word
and choose Spelling > User Dictionary > Hyphenate. Insert the hyphenation points where you want them,
then click Add.
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Because hyphenation exceptions can be stored in your document and your user dictionary, make sure
Compose Using (Dictionary preferences) is set to User Dictionary and Document to compose text using both
possible sets of exceptions.

Sharing or Merging User Dictionaries
In addition to adding words and hyphenation exceptions to your user dictionary, you can create a custom
dictionary that can be shared with others in your workgroup. This ensures that the same spelling and
hyphenation rules are applied to a document regardless of who’s working on it.

1. In Dictionary Preferences, click New User Dictionary. Give your new dictionary a name, and save it on
your file server where others can access it. The file will have a .udc extension. Click OK to exit
Preferences.

2. To quickly add words to the custom dictionary, create a plain text file that is a list of words you wish to
add. You can separate the words with spaces, tabs, or paragraph returns. Note that you can’t add
phrases, because each word in a phrase is treated as a separate entry.

3. Select Edit > Spelling > User Dictionary. Choose your custom dictionary from the Target menu, then
click Import to load the text file. If the words are capitalized, select the Case Sensitive checkbox before
you import the words. Thereafter, words can be added on a case-by-case basis.
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4. Each member of your workgroup can load the custom dictionary by choosing Preferences > Dictionary,
clicking the plus symbol to add a dictionary, and navigating to the server to select the custom
dictionary file.

From now on, words will be spell-checked and hyphenated using both the default dictionary and the custom
dictionary. However, although multiple people can use the same custom dictionary, only one person can add
or edit words. To everyone else, that dictionary will be locked. For this reason, you’ll need to assign one
person responsibility for the custom dictionary.

NOTE: Many dictionaries ship with InDesign, of which Hunspell is the default dictionary. You can
also download additional spelling and hyphenation dictionaries from the OpenOffice website
(extensions.openoffice.org).

As an alternative to sharing a user dictionary, you can merge it into the InDesign document. To do this, in
Dictionary Preferences select Merge User Dictionary into Document. When another user (who doesn’t have
access to your custom dictionary) opens the document, they’ll see your custom words in their Edit > Spelling >
Dictionary dialog (with the name of the document selected as the Target dictionary). The custom words
appear only within your document, not in any other documents on their system or in any documents that they
create.
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Merging the user dictionary into the document means one less thing to worry about. The downside is that the
user dictionary is not available across multiple documents.

H&J Violations
Using appropriate Hyphenation and Justification settings increases the likelihood of achieving good-looking
type, but it’s not a guarantee. InDesign can’t do the impossible, and when you’re working with justified type,
there will be places in your text where it can’t honor the settings you’ve chosen. Choose Preferences >
Composition and select H&J Violations to highlight in three shades of yellow any lines that violate your H&J
specs. The darker the yellow, the worse the problem. As with the Custom Tracking/Kerning Composition
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preference, this is distracting while you’re designing pages, but very useful when fine-tuning a layout.

Break Characters
Among our responsibilities, as designers with type, is to ensure that the lines break in a way that facilitates,
rather than obstructs, the meaning of the text — and in a way that looks good. Line breaks should not be
arbitrary, especially in headlines and subheads. Read the text and, where necessary, break the lines where you
would logically pause when reading it aloud.

The forced line break (Shift+Return/Shift+Enter) carries the text to the right of the cursor down to the next
line without starting a new paragraph. This avoids taking on any unwanted indent and spacing attributes of
the paragraph that it came from. The forced line break is also used for contouring paragraphs of ragged text
and for breaking lines for sense, especially in display text.

The problem with a forced line break is that if your text reflows, you could be left with awkward breaks in the
middle or even at the beginning of a line.

Cue the discretionary line break, which will disappear when the word is not at the end of the line. This sounds
like the answer to the problem of lines breaking inappropriately. However, when you insert a discretionary
line break, the line doesn’t actually break until you add to the text that precedes it or increase the type size. So
if you’re adjusting the rag of text that’s already written, this feature isn’t much help.

Nevertheless, discretionary line breaks have their uses. I like to put thin spaces around my em dashes. White
space characters and em and en dashes are nonbreaking. And most of the time, that’s a good thing, but
occasionally it causes H&J violations. In a long document, turn on the H&J Violations option to highlight
where the word spacing or letter spacing is less than optimal. If the cause of the problem is an em dash at the
end of the line, insert a discretionary line break after the dash to allow the word that follows to move down to
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the next line. Should the text reflow so that the break is no longer needed, it goes away.

The other breaks are self-explanatory and are inserted at the position of your cursor, introducing an invisible
character into the text. These invisible characters can be seen when you have hidden characters shown or
viewed in the Story Editor. When you insert one of these characters, text is forced to the next column in the
current frame, to the next threaded frame, to the next page, or to the next odd or even page.

Hyphenation Dos and Don’ts

Do: Make sure you’re using the right language dictionary. Hyphenation (and spelling) rules are based
on the language dictionary applied to the text. You can choose the dictionary from the Language
menu on the Control panel or, better yet, apply the language as part of a paragraph style definition.

Do: Hang your hyphens. To use Optical Margin Alignment to hang the hyphens in the right margin,
choose Type > Story and select the Optical Margin Alignment option. (See Chapter 6, “Alignment,”
for details.)

Do: Consult a dictionary for hyphenation breaks. When inserting discre–tionary hyphens, divide the
word after a vowel to turn over the consonant to the next line. In present participles, turn over -ing, as
in walk-ing, driv-ing, design-ing. When two consonants come together, put the hyphen between
them. Try to divide the word so that the first part of the division suggests what is following: conserva-
tion, not con-servation; re-appear, not reap-pear; cam-ellia, not camel-lia.

Don’t: Use stupid hyphenation. Avoid breaks like crap-ulous or the-rapist.

Don’t: Hyphenate headings, subheadings, or right-aligned or center-aligned text. Deselect
Hyphenate in the relevant paragraph styles. Hyphenated headlines are the typographic equivalent of
walking around all day with a Post-it note on your back saying “Loser.”

Don’t: Hyphenate short passages. If your text is a single frame of a few lines, forgo hyphenation.
There are not enough words for the hyphens to blend in.

Don’t: Hyphenate a word at the end of a paragraph. Remove the Hyphenate Last Word option in the
Hyphenation dialog to prevent this.

Don’t: Hyphenate across a column. A single word at the bottom of a column or page should not
break. If you are desperate, hyphenating across facing pages — from a verso to a recto — is preferable
to hyphenating across a page turn, from a recto to a verso.

Don’t: Double-hyphenate. This can happen in long compound words with hard hyphens occurring
near the end of the line. Apply No Break to prevent the word from breaking.

Don’t: Use more than two consecutive hyphens. Set Hyphen Limit to 1 to completely avoid ladders.
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Where you can predict the break — for example, if all chapter heads should start on a new right-hand page —
it is preferable to use Keep Options to incorporate this attribute into the paragraph style definition.

No Break

TIP: Because No Break is tucked away under the Control panel menu, save yourself time by creating
a character style that has this single attribute. Assign a keyboard shortcut to the character style so
that you can apply it quickly.

To prevent a word or a phrase from breaking, select it and choose No Break from the Control panel menu.
Whereas a nonbreaking space will permit hyphenation, using No Break guarantees that the selected word(s)
will always remain intact.

In addition to proper nouns and product names, No Break can also be used for the following:

To prevent single-letter words such as “I” and “a” from occurring at the end of a line. Finishing a line on
a short word leaves a dangling thought and interrupts the reader’s comprehension.

To prevent short words like “An,” “The,” and so on from occurring at the end of a line when they are
part of a title, such as The Bell Jar.

To keep together numerical expressions like “May 31” or “8 inches,” or phrases like “Chapter 9.”
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To prevent two or more consecutive lines from starting with the same word.

TIP: There is no Composition preference to show at a glance where No Break has been applied. It
would be useful to have a check box like those for Custom Kerning/Tracking and H&J Violations,
to highlight all the No Breaks in a document. Until that feature arrives, if you’ve applied No Break
as a character style, you can temporarily redefine the style to include an underline. That way, you can
easily spot all instances of No Break.

Some designers prefer to use a nonbreaking space (Type > Insert White Space, or
Cmd+Option+X/Cmd+Alt+X), which inserts a nonprinting character into the text, making it easier to spot
when editing text at a later date. For me, No Break has the edge over nonbreaking spaces and discretionary
hyphens because it can be incorporated into a character style and, by extension, can be applied automatically as
a GREP style to proper nouns, product names, text strings, and so on, that you never want broken across a
line.

Here’s how:

1. Make a No Break character style: From the Character Styles panel menu choose New Character Style,
name it “No Break,” and in Basic Character Formats select No Break.

2. Define the GREP style for the paragraph style where you want No Break applied. Right-click the style
name in the Paragraph Styles panel and choose Edit. From the list on the left, choose GREP Style.

3. Click the New GREP Style button. From the Apply Style drop-down menu, select the No Break
character style and click to the right of the To Text field, then type the name or text string you want to
prevent from breaking across a line. To apply No Break to multiple text strings, separate each one with
a vertical pipe ( | ).

Don’t be overzealous with your application of No Break. Apply it too much and you’ll create more problems
than you solve. With fewer places to break the line, you might end up with an outbreak of bad word spacing
or overset text.
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Balance Ragged Lines
This easy-to-apply feature is a checkbox in the Indents and Spacing dialog of Paragraph Style Options, and,
for applying locally, it can be found on the Control panel menu. It will attempt to give you lines of equal
length; more than 50 percent of the time it does a good job; for the rest, you’ll need to manually break the
lines for sense. Balance Ragged Lines works only on text that has the Paragraph Composer applied.

What’s not obvious is that Balance Ragged Lines, by default, favors a V shape for the text, with a longer first
line and a shorter second line. There’s a free script by InDesign guru Keith Gilbert that you can use to favor a
shorter first line and a longer second line, or to try to make all lines the same length. You can download the
script from www.gilbertconsulting.com/resources-scripts.html.
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Keep Options
As well as keeping related paragraphs together in a way that makes sense, Keep Options also control how a
paragraph flows between text frames. When incorporated into paragraph style definitions they can make light
work of long, complex documents, preventing widows and orphans and ensuring that headlines and the text
that follows them are inseparable. On the other hand, they can also be confusing if you are working with a
document you didn’t create and don’t know why your text seemingly has a will of its own, jumping from one
frame to the next. So you need to know how to control Keep Options, or they might end up controlling you.

Keep with Previous attaches the first line of the selected paragraph with the last line of the previous paragraph.
Applying Keep with Previous to body text will carry a head at the bottom of a column or page over to the next
column or page so that it stays with the body text.

Keep with Next can also be used to ensure that heads and subheads aren’t separated from the body text that
follows them. You can specify how many lines of the following paragraph must be kept with the head or
subhead.

With Keep Lines Together, you can make sure all the lines of a paragraph move together or that a specified
number of lines move together at the beginning of the paragraph, the end of the paragraph, or both. This
prevents widows and orphans, as discussed in Chapter 6. Inevitably this results in columns of varying depths,
so it’s not a viable solution if you’re working with multiple columns that should extend to the bottom margin.

The Start Paragraph options ensure that certain top-level paragraphs always begin on a new page or in a new
column or frame. These are especially useful for chapter or section heads.

Obviously, your paragraphs must break somewhere. Asking the impossible by setting too many Keep Options
results in keep violations or — more likely — in overset text. Like H&J violations and custom
tracking/kerning, keep violations can be seen by turning on the Composition preference (Preferences >
Composition). The highlight color is bright yellow, but it’s rare to see it because InDesign will more likely
honor your settings, no matter how unreasonable, and overset your text frames.

▄

Determining when and how your text breaks and when and how it should be kept together is about making
aesthetic decisions informed by common sense and pragmatism. As always, use a light touch, be consistent,
and automate where possible, but don’t rely on InDesign (or any software) to always get it right. The buck
stops with you, so be prepared to intervene manually where necessary.
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Chapter 11

Tables

Tables are everywhere: train and bus schedules, product comparisons, stock charts, sports league
tables, and TV and radio listings, to name but a few. Unlike narrative text, tables need to be read in
two directions simultaneously, so it’s important to keep the design simple. Even though it’s a table, it
still needs to be read. Too frequently we see tables that are a cage of borders, rows, and columns; they
look like data prisons. Clients sometimes treat tables the way we might treat a junk room — cram as
much stuff in there as possible, then force the door shut.

Table Aesthetics
Most important when working with tables is a commonsense, no-nonsense approach.

Choose an Appropriate Font
Table text is typically one or two points smaller than body text. Condensed faces may be preferable because
they are more economical with space. Sans serif faces with high x-heights and open counters (Helvetica,
Univers, Myriad) are, because of their relative simplicity, more readable at small sizes than are serif faces.
Make sure your typeface has tabular lining numerals (that is, numerals without ascenders and descenders)
rather than proportional old–style numerals. If it’s an OpenType font with a choice of numeral style, select
Lining Numerals as the figure style. Unlike in body text, in tables you want the figures to have the same set
width so that they line up with each other.

Keep It Simple
Borders, column and row strokes, and tinted cells are useful for establishing hierarchy in a table but are most
effective when used sparingly. Too many rules and tinted blocks and you’ll overemphasize the cellular
structure of the table, causing your data to look trapped. Rather than a full border around the table, consider
using only top and bottom rules to create a more “open” table. Begin your table without rules, tints, or
borders, and then introduce them only as necessary and only if you can articulate why they are necessary.

TIP: Drag and Drop Text Editing (Preferences > Type) is useful most of the time, but especially so
when working with tables. With this option enabled in layout view, you can more easily move your
text content from one cell to the next. Hold Option/Alt if you want to duplicate, rather than move,
the text.
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Be Flexible When It Comes to Alignment
Centering column heads over numbers is preferable if the number of numerals in each column varies. With
the same, or close to the same, number of numerals in each column, left alignment is preferable. Be prepared
to adjust for optical alignment where necessary. Justified alignment and first-line indents have no place in
tables; the table cells are too narrow.

Vertical alignment can be important for column heads. Where these run to more than one line, bottom
alignment is cleaner and makes it easier for the eye to scan along the row.
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When you’re working with currency columns, the currency symbol should be positioned according to the
widest numerical entry in the column.

Be Concise
If table cell entries run to multiple paragraphs, consider editing the text; if this isn’t an option, break the
paragraphs into separate cells.

Give Clear Visual Cues
To make things more interesting, you can stagger the height of the headers to match the text.

For tables that run across several pages, repeat the header row on each page. With your cursor in the first row
of the table, choose Table > Convert Rows > To Header. A footer row is necessary only at the end of the
complete table.

Emphasize the Reading Direction
Any shaded cells should accentuate the reading direction. For example, in a train timetable, the reading
direction is from top to bottom. We want to see what time the train starts and where, and what time and
where it terminates. Whereas in a football league table, because you first read from left to right to scan the
team’s statistics, the cell shading should be horizontal.

Differentiate
The more sections of data your table shows, the more you have to make things easy to find and distinguish.
Reverse type clearly indicates the table headings, and generous cell padding throughout makes the small text
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easy to read.

Creating a Table
Tables are contained in text frames. If you insert a table into an existing story, it moves with the text flow,
behaving like an inline object. To select the line that hosts the table, “sneak up” on it: insert your cursor in the
paragraph immediately before or after the table and press the Down Arrow or Up Arrow. You’ll see a large
blinking cursor to the side of the table. You can now adjust its horizontal alignment within the frame using
the text alignment options, add indents, or add spacing before or after the table. If you have multiple tables,
you can create a paragraph style to apply these formats consistently.

Tables are selected and edited with the Type tool. Table text is not threaded from one cell to the next, so edits
made in one cell don’t affect the text in any other cell. As you add text, the cell grows in height but not in
width. Formatting table text is the same as formatting any other text.

When you select a table, the Control panel offers table-specific options like merging and unmerging cells, row
height, and column width. These options are also available on the Table panel.

When it comes to formatting tables — and especially when working with table and cell styles (see Chapter 15)
— it’s important to know the difference between table-level formatting and cell-level formatting. Table-level
formatting includes borders, spacing before and after the table, alternating fill patterns, and row and column
strokes that are applied to the whole table. Cell-level formatting includes the positioning of the text within
the table cells, and row strokes and column strokes that are applied to individual table cells.

There are three approaches to creating a table: from scratch, converting existing text to a table, and importing
a table from Microsoft Word or Microsoft Excel.

From Scratch
Often, you’ll need to create a table from scratch. To create a table that is part of the text flow:

1. Insert the Type tool into the story and press Return to create a blank line to accommodate the table.

2. Choose Table > Insert Table.

3. Specify the numbers of rows and columns.
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4. Click OK.

Optional: If the table will span more than one column or frame, specify the number of (repeating)
header or footer rows. If you create a table without a header or footer, you can convert the first row to a
header, or the last to a footer, by choosing Table > Convert Rows. If you have a table style prepared,
you can apply it here.

If you want a table that stands on its own and isn’t part of an existing text thread, omit the first step.
Having specified the number of rows and columns, either click to have the table fill the width of a
column, or drag to determine the size of the table. In either case, the containing text frame will be the
same size as the table.

TIP: If you’re using tables to create a calendar, the Calendar Wizard script will save you a lot of
time, and possibly your sanity too: calendarwizard.sourceforge.net. Every aspect of the generated
tables is styled with paragraph, character, table, and cell styles, which makes the appearance of the
table very easy to edit.

Converting Text to a Table
If you plan to convert text to a table, it pays to set up the text with tabs separating the columns and with
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paragraph returns separating the rows. Select your text and choose Table > Convert Text to Table. It may not

look pretty at first, but by adjusting the column widths, merging cells where necessary, and applying
appropriate paragraph styles to the text, you’ll be well on your way. You can also make this conversion in
reverse by inserting your Type tool in a table and choosing Table > Convert Table to Text.

Importing a Table
There’s no point in reinventing the wheel. If you have a table already prepared — as an Excel spreadsheet or
Word table — you can place it in InDesign. Choose File > Place (Cmd+D/Ctrl+D) and select Show Import
Options, or hold the Shift key when you click Open. You can remove the styles and formatting from text and
tables, converting the tables to either unformatted tables or unformatted tabbed text, but it’s usually preferable
to evaluate the table with the original formatting and make an informed decision about which formatting to
remove and which, if any, to retain.

NOTE: If your type cursor isn’t in a frame when you place a table, the table will be independent of
the text flow. To insert the table into the text flow, cut it, select the Type tool, click inside the story,
and paste.

Table Shortcuts

Move from cell to cell: With your cursor in a cell, press Tab to move to the next cell or Shift+Tab to
move to the previous cell.

Resize rows and columns: Drag an interior row or column boundary.

Resize rows proportionally: Shift-drag from the bottom of table.

Resize columns proportionally: Shift-drag from the right table edge.

Resize the height and width of all table cells proportionally: Shift-drag the lower-right corner of the
table.

Resize rows or columns without changing the table height and width: Shift-drag an interior row or
column boundary.

Enlarge the table while inserting rows or columns: Option/Alt-drag the right edge, bottom edge, or
lower-right corner of the table outward.

Shrink the table while deleting rows or columns: Option/Alt-drag the right edge, bottom edge, or
lower-right corner of the table inward.

Insert a row: Cmd+9 (Ctrl+9).

Delete a row: Cmd+Delete (Ctrl+Backspace).

Insert a new row at the end of a table: Press Tab when the text cursor is at the end of the last row of
the table.

Insert a column: Cmd+Option+9 (Ctrl+Alt+9).
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Delete a column: Shift+Delete (Shift+Backspace).

Select a single cell: Esc.

Select a row: Cmd+3 (Ctrl+3). Click the table border to the left of a row.

Select a column: Cmd+Option+3 (Ctrl+Alt+3). Click the table border above a column.

Select a table: Cmd+Option+A (Ctrl+Alt+A). Click the table border at the top left of the table.

Use tab characters within a table cell: Option+Tab (Alt+Tab).

To remove the formatting from an already-imported table:

1. Select the table by inserting the type cursor in any of the table cells, and choose all cells by pressing
Cmd+Option+A (Ctrl+Alt+A).

2. Go to the Paragraph Styles panel and click the Clear Overrides button at the bottom of the panel to
remove any local character and paragraph formatting.

3. Go to the Cell Styles panel (Window > Styles > Cell Styles) and do the same. This will zap any cell
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formatting (row or column stroke weight, cell colors) so that you can proceed with an unformatted

table.

When placing an Excel file, you have a number of options. If there are multiple worksheets in the document,
you can choose which one you want. You can also restrict the cell range. In terms of formatting, you can
choose:

Formatted Table to include any formats applied in Excel
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Unformatted Table to import the table data with all the formatting stripped out

Unformatted Tabbed Text to use a tab-delimited file rather than a table

Formatted Only Once to bring in Excel formatting (but note that if the formatting is changed in Excel,
it won’t be updated in the InDesign file)

No disrespect to Excel users intended, but neither they nor their application of choice are known for their
typographic sensitivity, so if there’s one option you’re more likely to use than any other, it’s Unformatted
Table.

Cutting and Pasting Data
Rather than link to spreadsheet files, you can copy and paste data from Excel to InDesign as the spreadsheet
updates. With this approach, you don’t need to update the whole table, just those cells that have changed.
When updating a table in this way, consider the following:

Make sure you’re copying from and pasting to equivalent rows and columns.

When pasting the new data, select the entire cell by pressing the Escape key rather than inserting your
type cursor into the cell. It’s sufficient to select the first cell in the range.

Choose Edit > Paste Without Formatting (Cmd+Shift+V/Ctrl+Shift+V), rather than Paste, to retain
the formatting already applied to your InDesign table. This approach also works if you’re copying and
pasting data from one InDesign table to another.

Table Selection Methods
Selecting a whole table allows you to change the formatting of all its cells. To do so, move your cursor to the
upper-left corner of the table — it becomes a southeast-pointing arrow — and click. Alternatively, with your
type cursor inside the table, choose Table > Select > Table (Cmd+Option+A/Ctrl+Alt+A).
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To select a column, move the cursor to the top edge of the table and click to select the column.
Alternatively, press Cmd+Option+3 (Ctrl+Alt+3).

To select a row, move your cursor to the left edge of the table and click to select the row. Alternatively,
press Cmd+3 (Ctrl+3). You can also click inside a table and choose Table > Select > Column or Row.

To specifically select header, body, or footer rows, click inside the table and choose Table > Select >
Header Rows, Body Rows, or Footer Rows.

To select a cell, insert your cursor into the cell and press Esc or Cmd+/ (Ctrl+/). Alternatively, choose
Table > Select > Cell. To select multiple cells, drag from one cell to the others. All cell selections are
contiguous; that is, you cannot select one cell in the top left and another in the bottom right
simultaneously.

To select the text within a cell, use the normal text selection methods.

To move from one cell to the next, press the Tab key, or press Shift+Tab to move backward.

You can insert a tab stop into a cell by pressing Option+Tab (Alt+Tab) or choosing Type > Insert Special
Character > Other > Tab. But you might not need to, because InDesign tables honor tab stops, even
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without tab characters in the table cells. For example, select a column (or row) in a table, then open the
Tabs panel (Command+Shift+T/Ctrl+Shift+T). Choose the Decimal Align tab stop, and click the panel’s
ruler — the decimal points in the column will now align.

Linking to Spreadsheet Files

When you place a graphic in InDesign, a link is created to the original file. You manage links
through the Links panel, either initiating a roundtrip edit of the graphic in its native application
(Photoshop, Illustrator, and so on) or updating the link if the original file has been edited. This is not
the default behavior with text and spreadsheet files; once you place them in InDesign, they become
independent of the original file. That is, unless you select Create Links When Placing Text and
Spreadsheet Files, found in File Handling preferences.

Linking to a spreadsheet means that every time the original Excel spreadsheet is changed, the table
updates in InDesign. This may sound good, but it’s a dangerous strategy for two reasons.

First, when you update the Excel file, you lose any local formatting applied to the table in InDesign.
If you rigorously use table and cell styles (see Chapter 15), then the formatting is retained.

The second reason is not so easy to get around: Create Links causes text files to be linked from that
point forth. Placed text files will be updated if you, or anyone else, edit the original Word documents,
and you’ll lose the formatting applied in InDesign. It’s possible to turn this preference off and on as
needed, but you’re bound to forget at some point.

Working with Rows and Columns
This section looks at the numerous ways of formatting the rows and columns of a table.

Adding Borders, Strokes, and Fills to a Table
When you insert a table, unless you specify otherwise, it will be based on the [Basic Table] style, which has a
1-point black border and 1-point row and column strokes. In other words, it looks like a data prison. If you
plan on creating multiple tables, it’s worth creating your own table styles, but for a single table it’s usually
easier to start with a basic table and then change it.

Here’s how: select the table by clicking in its upper-left corner. Note the proxy preview to the right of Strokes
in the Control panel. Selected lines appear in blue, unselected lines in gray. Click the intersection of the inside
strokes to turn the inside strokes on or off. Click any corner point to turn the two adjoining strokes on or off.
Double-click any outside stroke to turn off or on all outside strokes. Triple-click anywhere in the proxy
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preview to turn all strokes on or off.

There are three places where you can change the properties of individual rows or columns: on the Control
panel, on the Stroke panel using the proxy preview, or through Table > Table Options or Cell Options.

Row shading should enhance readability by reinforcing the primary reading direction, either down the column
or across the row. Depending on the nature of the data, you may want to use the Alternating Patterns option.
You can apply fills or strokes to every other row, every second row, or every third row, or you can, using the
First and Next menus, come up with a custom row pattern. The same is true with columns.

Moving, Inserting, and Deleting Rows and Columns
Firstly, before you start working with your table, make sure you’re in Normal view mode and that frame edges
are visible (select View > Extras) so you can see the individual table cells. Depending on the complexity of
your layout grid, it may be preferable to hide your guides (Cmd+; / Ctrl+;).

The easiest way to move rows and columns is with drag and drop. Select a row or column with the Type tool,
then position your cursor over the selection until the drag-and-drop cursor appears. Move the selection to
another location in the table, as indicated by a dark blue line. Holding Option/Alt while you do this will
duplicate the rows or columns.

NOTE: You can also insert columns and rows using keyboard shortcuts. To insert a row, press
Cmd+9 (Ctrl+9); to insert a column, press Cmd+Opt+9 (Ctrl+Alt+9).

There are several ways to insert rows or columns into a table. My preference is to use the context menu. With
your cursor inserted in the relevant cell, right-click and choose Insert > Row or Insert > Column. You can
choose how many and whether they are inserted above or below — or in the case of columns, to the left or
right — of your current cell.

Pressing Tab when your cursor is in the last cell of the table creates a new row.

You can add rows and columns by holding down Option (Alt) as you drag a row or column border. This
technique can also be used to delete rows and columns: hold down Option (Alt) and drag up from the bottom
edge of the table to delete rows, or from the left edge of the table to delete columns.

To delete all or specific parts of your table, choose Table > Delete > Row, Column, or Table. Alternatively,
use the context menu and choose Delete > Row or Delete > Column, or use the keyboard shortcut
Cmd+Backspace (Ctrl+Backspace) to delete a row or selected rows, and Shift+Backspace to delete a column
or selected columns.

Pressing Delete or Backspace when you have cell content selected deletes the table content, not the cells
themselves.

Resizing Rows and Columns

NOTE: InDesign doesn’t show rows that fall outside the text frame (although it does show columns
that do), so you may need to adjust the frame after you’ve resized the table to ensure that the whole
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table is visible.

InDesign makes it easy to resize the rows and columns of your table:

To resize individual rows and columns, drag the row or column border to change the row height or
column width.

To keep the table’s existing size, hold Shift while you drag a row or column border. This method affects
only two rows (or two columns) at once; as one field grows larger, the other gets smaller.

To resize rows proportionally, hold Shift and drag the bottom edge of the table; to resize columns
proportionally, hold Shift and drag the right edge.

To resize the whole table proportionally, hold Shift while dragging its bottom right edge. Note,
however, that this doesn’t work if the table spans more than one frame.

For rows/columns of a uniform height/width, select the entire table and choose Table > Distribute
Rows Evenly or Distribute Columns Evenly.

Specifying Row Height
The default height of a row is determined by the leading of the text. Row heights can also be an absolute
value. The At Least option specifies a minimum row height that grows as you add text or increase the size of
the text. “Exactly” sets the row height to a fixed value even if the row is empty. If your content exceeds this
height, a red dot in the lower-right corner indicates that the cell is overset.

Breaking Tables Across Frames
If the table is taller than the frame in which it resides, you can thread the frame with another to continue the
table, in the same way you would thread any text frame.
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The Keep Options (Cell Options > Rows and Columns) determine where a row will start. The default is
Anywhere (that is, after the previous row), but if you have a table with subheading rows you want kept with
the rows that follow them, this can be changed to In Next Text Column, In Next Frame, On Next Page, On
Next Odd Page, or On Next Even Page. You can also request that a selected range of rows be kept together in
the same frame by selecting Keep with Next Row.

Choose Table Options > Headers and Footers to set the number of header and footer rows and how these
rows repeat — every column, every page, or every frame. This adds new header and footer rows; if you’d rather
convert an existing row that’s at the top or bottom of your table, with your cursor in that row, choose Table >
Convert Rows > To Header or To Footer.

Working with Table Cells
Cells are the building blocks of a table, and each cell in your table has the same properties as an individual text
frame.

In Cell Options, you set the Cell Inset Spacing and the Vertical Alignment. On a cell-by-cell basis, you can
also change Row Strokes, Column Strokes, First Baseline Options, and Diagonal Lines. Table text can be
formatted the same way as text in any frame, and paragraph and character styles are equally beneficial (see
Chapter 15). The only paragraph format that does work inside a table is paragraph space before/after. The
one restriction on table formatting is that text can be rotated only in increments of 90°, 180°, or 270°. (If you
need the text rotated at other angles, format the text in its own frame, then cut and paste the text frame into a
cell as an inline frame.)
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Merging and Splitting Cells
You can click the icons on the Control panel to merge (  ) and unmerge (  ) cells, or choose these options
from the Table menu. From the Table menu, you can also split cells horizontally or vertically. You can also
right-click and choose Merge or Split from the context menu.

Graphics in Table Cells
Graphic cells can be created in one of two ways. First, you can place a graphic directly in a cell. Just choose the
Place command and place the image — no need to select the Type tool first. You can also create a graphic cell
by selecting a cell and choosing Table > Convert Cell to Graphic Cell. A graphics frame is created in the cell.

This is useful for creating specification sheets or product comparison tables, or just for jazzing up what might
otherwise be a boring chunk of data.

If the graphic is bigger than the cell, choose Table > Cell Options > Text, select the Clip Contents to Cell
check box, and set Cell Insets to 0. The graphic will fill the cell vertically but not horizontally; you will need to
adjust the column width accordingly. To crop, triple-click with the Selection tool and drag the image within
its frame.

Because of the disparity between cell size and picture size, it may sometimes be easier to start with an
independent graphic. Rather than place the graphic directly into the table cell, first position it over the table
cell. Size the graphic relative to the dimensions of the table cell, and then drag from the blue rectangle at the
top right of the picture frame to the target cell to anchor the graphic inside the table.

Other Table Considerations
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Here are some miscellaneous other factors to consider when working with tables.

Tables and Text Wrap
It’s possible to create text wraps in tables, but before you do so, ask yourself if it’s really going to make the
table better. It’s also possible to make bacon-flavored ice cream, but that doesn’t make it a good idea.

To combine text and picture in the same table cell, the picture has to be an anchored object. Because anchored
objects have a longstanding limitation of not being able to wrap the first line of text around the object, it’s
preferable to create the text wrap outside the table, group it, and then paste it into a table cell with insets set to
0. Here’s how:

1. Set the insets of the cell that will hold the text wrap group to 0.

2. Size the text and image relative to the table.

3. Apply the text wrap.

4. Group the text frame and picture frame.

5. Cut or copy the grouped object into the recipient table cell.
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Rounded-Corner Tables
Here’s how to make a table with rounded corners:

1. Create your table without a table border.

2. Cut the table (Cmd+X/Ctrl+X).

3. Create a rounded-corner rectangle (Object > Corner Options), insert the type cursor into this, and
choose Paste Into (Cmd+Option+V/Ctrl+Alt+V). The table becomes an inline object and can be
repositioned using the Selection tool.

Joining and Splitting Tables

TIP: Peter Kahrel’s Merge Tables script merges all tables in a selection as long as they have the same
number of columns. You can find the script at www.kahrel.plus.com/indesign/table_merge.html.

Although there’s no command for joining tables, you can do this manually. First, make sure the table you’re
copying to has enough empty rows and columns to accommodate the data. Then copy or cut the contents to
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be carried over. Select the first empty row in the destination table and paste the contents. Be sure to select the
row(s) and not the single cell, as this would cause the new content to be placed as an inline graphic.

To split a table, select the rows you want to split off and cut them to the Clipboard (Cmd+X/Ctrl+X). Insert
the type cursor where you want the new table to be, and paste (Cmd+V/Ctrl+V).

Tables and the Story Editor
Use the Story Editor to view overset table text. Right-click the overset marker at the frame edge and choose
Edit in Story Editor to see the contents of the table. Click the triangle to the left of the Table icon to show or
hide the contents of the table. Right-click the table icon to choose whether to arrange the table data by rows
or columns. The Story Editor is also useful for selecting copy before or after a table, particularly if you want
two tables in a row with no paragraph return between them.

Unexpected Uses for Tables
Although it’s possible to use tables to design most anything, why would you? Unless you have a hankering for
designing like it’s 1999 and approaching every page as if it’s an HTML table, “going tabular” ultimately
doesn’t achieve anything you couldn’t have achieved with conventional methods. It can also frustrate
colleagues who may have to edit your files. Now that InDesign has real paragraph shading and paragraph
borders, the need for table-based workarounds is reduced. That said, there are some occasions when a deftly
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disguised table might be a good solution. See the examples on the next two pages.

FINDING TABLES

If you ever inherit an InDesign document and need to find out quickly where tables are used, you can
use Find/Change to search for the Unicode character 0016. While there isn’t a built-in way to search
for tables within a document, because tables are inline graphics within a parent “character” of Unicode
0016, they can be found by entering <0016> in the Find What field and clicking the Find Next
button.

▄

Tables, like referees and copyeditors, do their job best when they are clear, definitive, and unobtrusive. Keep
them clean, and keep them simple. If you find yourself working with a lot of tables, then to keep them
consistent and to speed up your workflow, you’ll want to master table styles and cell styles, which are discussed
in Chapter 15.
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Chapter 12

Bullet and Number Lists

Maybe it’s a sign of our shortening attention spans, but these days we seem to want more of our
information in quickly digestible points. And then there’s our need to quantify; people love lists. The
top ten this, the 100 greatest that, 12-step programs, 50 ways to leave your lover, and so on. The
popularity of the form has given rise to a new term: the “listicle.” Although the mechanics of creating
bullets and number lists are simple enough, both types of list raise certain design issues, and both are
prone to quirky problems.

Working with Lists
Before we dig deeper, here are the basics. Bullet and number lists are formatted with automated hanging
indents, with either a bullet character or the number as the first (hanging) character(s).

To apply either a bulleted or numbered list to selected text, Option-click (Alt-click) either the Bullets or the
Numbering icon on the Paragraph Formats level of the Control panel, and then choose the list type, the bullet
or numbering style, and the alignment. As always, select Preview to see how any changes affect your selection.
Conveniently, you can select a character style to be applied to the bullet or number; if you don’t have one
already made, choose New Character Style and make one on the fly. Once you’re satisfied with how things
look, click OK, and then capture the formatting as a paragraph style by choosing New Paragraph Style from
the Paragraph Styles panel menu.
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Bullet Lists
Here are some things to consider when making bulleted lists.

You can use the Add button in the Bullets and Numbering dialog to choose a bullet character from a different
font. This is useful if you’re after a dingbat or icon that’s unavailable in your text font. Sometimes, though, the
bullet may not vertically align with the rest of the text. The solution? Apply a character style to the bullet
character and adjust the baseline shift and possibly the font size for that character style. If your house style is
that items begin with a cap, align the bullets vertically between the cap height and the baseline. If the items
begin with lowercase characters, align the bullets to the x-height.

Typically, bullets use hanging indents, so you need to make the first-line indent the same as the left indent
but negative. For example, if the left indent is 12 pt, use a first-line indent of −12 pt. When you input a
negative first-line indent, the Tab field becomes blank, and the tab is automatically set at the left indent value.
An em space is usually sufficient when working with hanging indents, but you’ll need more if working with a
numbered list that includes two- and three-digit numbers.

Using an Icon as Bullet

To use an icon as a bullet, consider using an icon font such as FontAwesome or creating a custom
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icon with the Indyfont script (discussed in Chapter 8). You can also create your own icon set using

Fontastic (fontastic.me), which allows you to assemble your own icon font from the more than 9000
icons available on their site.

If you prefer your bullets flush rather than hanging, you’ll probably want less space after the bullet. You can
replace the tab character (^t) in the Text After field with a space or an en space from the drop-down menu to
the right.

Keep punctuation to a minimum while adhering to the house style. Unless the bullet point is a full sentence,
don’t end it with a period.

Add space before the first and after the last item in the list. Once you’ve made a bullet paragraph style, make
two variants based on it: bullet_first, incorporating space before; and bullet_last, incorporating space after.

For longer lists, consider using the Split Columns command to divide the list into two subcolumns. This
makes it easier to control the spacing before and after a list because it can be included in the Split Columns
instruction.

Spacing Before and After a List

To add extra space before and after a list — but not between the list items — you can use Span
Columns. This saves you having to create separate styles for the first and last bullet items. In your list
paragraph style, go to Span Columns and choose Paragraph Layout: Span Columns, choose Span:
All, and then add the desired space before and after.

The main symptoms of stroke can be remembered with the word FAST:

Face-Arms-Speech-Time.

Face - the face may have dropped on one side, the person may not be able to smile or their
mouth or eye may have dropped

Arms - the person with suspected stroke may not be able to lift one or both arms and keep them
there because of arm weakness or numbness
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Speech - their speech may be slurred or garbled, or the person may not be able to talk at all
despite appearing to be awake

Time - it is time to dial 999 immediately if you see any of these signs or symptoms

If you suspect that you or someone else is having a stroke, phone 999 immediately and ask for an
ambulance.

Presumably, you want your bullet and number styles to be stylistically related, so base your number list style on
your bullet style or vice versa; that way, if you need to change the paragraph style spec, you’ll need to make
only one change.

Indenting the text after the bullet means you lose the strong flush-left alignment of your text. For this reason,
many people prefer outdenting the bullet to strengthen the left axis of the text. This requires indenting the
body text by the same amount that you indent the bullet.

Because they tend to be short and pithy by nature, bullet lists don’t do well with justified alignment. Because
the lines are inevitably short, justified columns would mean big word spaces. For this reason, even if your body
text is justified, your list paragraphs should be ragged.

BULLET LIST ALIGNMENT

Ucipiet aut harchilit ipsae es
soluptio am nis enist facea
nist, venet.

facero beatem hillorem
eicieniet nem re
velicilibus expero
exceste natur

ullaccusam consequunt
mintium at ene pliqui
qui dit

ut aperum sit facea

The bullet character is
followed by a tab and hangs
flush left.

Ucipiet aut harchilit ipsae es soluptio
am nis enist facea nist, venet.

▄ facero beatem hillorem eicieniet
nem re velicilibus expero exceste natur

▄ ullaccusam consequunt mintium at
ene pliqui qui dit

▄ ut aperum sit facea

The bullet character is followed by a
space and the lines of the paragraph
align beneath the bullet.

Ucipiet aut harchilit ipsae es
soluptio am nis enist facea
nist, venet.

facero beatem hillorem
eicieniet nem re velicilibus
expero exceste natur

ullaccusam consequunt
mintium at ene pliqui qui dit

ut aperum sit facea

The text before and after the list is
indented to maintain the flush-left
alignment of the text.

Be vigilant about uneven rags. It’s tempting to select Balance Ragged Lines in the Indents and Spacing
section of the Paragraph Styles Options, but this will create as many problems as it solves. It’s up to you to fix
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the rag manually by applying No Break to phrases you want kept together or by using forced line breaks.

Because bullet lists are more likely to be used in instructional-type texts, where “bottoming out” columns may
not be necessary, con–sider using Keep Options to keep the lines of a paragraph together. That way, you avoid
orphaned lines at page or column top.

Bullet lists don’t play nicely with Optical Margin Alignment. If you’re using Optical Margin Alignment on
your story (a very good idea), you should choose Ignore Optical Margin Alignment in your Paragraph Style
Options to make exceptions of your bullet and number lists.

Sorting a List
To sort a list alphanumerically, you can use the SortParagraphs script that is installed as one of InDesign’s
sample scripts. From the Window menu, choose Utilities > Scripts, then navigate to the JavaScript folder
inside the Samples folder. Select the paragraphs you want to sort, and double-click the script. The script is
basic — there’s no option to ignore prepositions, for example, but if all you need is to alphabetize a list, it’s a
time saver.

Numbered Lists
All the considerations for working with bullet, or unordered, lists also apply to numbered lists, but there are a
few extra points to consider.

Converting Manual Numbers to Auto Numbers
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When creating a number list, you don’t need to type the numbers; they’re added for you. But there
will be times when a client supplies you with a text file that contains manually typed numbers. You’ll
want to remove these and apply the auto numbers so that you have more control over the paragraphs
from that point forward. You can use a GREP Find/Change to handle this efficiently.

Find What: ^\d+\. ?(.)

Change to: $1 (and apply the number list paragraph style)

Or, to find and change manually type bullets, followed by a tab …

Find What: ~8\t

Change to: $1 (and apply the bullet list paragraph style)

Applying auto numbering is self-explanatory: instead of bullets, choose numbers and the style of numbering,
the character style you want applied to the number, and the alignment, and you’re done. If you want the
numbering to begin at a number other than 1, change the Mode to Start At, and plug in the number you
want.

As useful as “live” numbers are, a couple of aspects of working with numbered lists can cause frustration.

Numbering Across Frames
You can number lists across unthreaded frames and even across documents. This is easy when you know
where to look, but list styles are somewhat buried and a little obscure.

List styles are a peculiar variant in the pantheon of InDesign styles and have only two check boxes. The
[Default] list style doesn’t allow numbering across unthreaded frames, so you need to create a new list style for
those paragraph styles you want sequentially numbered. In the Bullets and Numbering dialog, choose New
List from the List drop-down menu, name the style, and select Continue Numbers Across Stories and, if your
documents are collected into a book, Continue Numbers from Previous Document in Book.
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Creating a Multi-level List
These days I prefer to use InDesign rather than Word for word processing, but there’s one area where Word
still has the edge, and that’s when it comes to creating multi-level outlines. InDesign doesn’t give you the
convenience of easily collapsing and expanding different levels of an outline (though you can fake it with
Conditional Text), but it does allow you to make robust multi-level outlines with numbered lists.

To make this happen, you need to specify the Level Number, insert a Number Placeholder to indicate the
previous level, and select Restart Numbers at This Level.
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Restarting Numbers
There will be times when you want a list to restart its numbering after a head. For this, you need two
paragraph styles: one for the list and one for the head. It is the head style that will reset the counter for each
new list. Set its Mode to Start at 1.

The head should be set to Level 1 and the list to Level 2. The trick is that the head, while technically a
numbered paragraph, does not display its number. Both paragraphs need to share the same list style. Set the
list style to Continue From Previous and to Restart Numbers at This Level After: Any Previous Level.

Aligning Numbers
If your lists contain single- and double-digit figures, you may have experienced problems trying to right-align
the numbers with each other. To do this, in the Bullets and Numbering dialog, change the Alignment to
Right, then increase the left indent and/or decrease the first-line indent to move the text far enough to the
left, making space for the numbers. This can be tricky. Here’s a way to get the right combination of left indent
and first-line indent: using the Frame tool (with the stroke set to None), draw a frame to the width of the
two-digit numbers, note its width, and then delete it. Next, subtract the width of the frame from your left
indent value, making it a negative number. You now have your first-line indent amount.
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An alternative is to use a two-digit numbering style (assuming your number list doesn’t go beyond 99). This
may be the tail wagging the dog, but your numbers will always align.

If you want your numbers in circles, you can accomplish this using a paragraph rules trick. The rule above
should be set to a dotted line, and its color, weight, and offset adjusted so that it covers the number. Then,
you’ll need a rule below that is the same color as the background of your page. The trick is to make the left
indent of the rule below big enough to reveal the first dot of the dotted rule and obscure the rest. This
technique might serve for a one-off, but if you find yourself doing this regularly, you’ll save your sanity by
investing in a font that contains numbers in circles. One such font is Bullet Numbers by Wiescher Design,
available on fonts.com.

Combining lists with text wraps is bit like combining beer with wine — not a good idea, but sometimes we do
it anyway. If you position a list next to an object with a curved text wrap, the indents explode. To prevent this
from happening, use an en space or em space, rather than a tab, after the bullet or number.

Exporting Bulleted and Numbered Lists
InDesign converts bullet and number list paragraph styles to unordered and ordered lists, respectively, when
exporting to EPUB. If exporting an InDesign story to an RTF file, you’ll need to convert the automatic
numbers (or bullets) to text in order to preserve them in the converted document. From the Paragraph Styles
panel menu, choose Convert [Style Name] Bullets and Numbering to Text. (You can also apply this to a
selected range of text from the Type menu.) You will now be able to select the numbers or bullets as text. The
numbers will no longer be “live,” but they will survive intact when you export the story.

Tabs
TIP: When working in a table, pressing Tab moves the cursor to the next cell. To actually insert a
tab in a cell, press Option+Tab (Alt+Tab) or choose Type > Insert Special Character > Other > Tab.

Tabs are used for positioning text at specified positions on a line. Automatically incorporated into bullet or
number lists, tabs can also be added manually to create reply forms, to align numbers on a decimal point, or to
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separate columns of information into a table-like layout.

Tabs are made up of tab characters, tab stops, and tab leaders. Before we go any further, let’s define our terms:

Tab characters are inserted into your text when you press the Tab key. They move text to a specific position
— or tab stop — on the line. If you work with hidden characters shown (a good idea), you can see your tab
characters.
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Tab stops have a position (relative to the left edge of the frame), an alignment (which determines the behavior
of the text that follows), and, potentially, a leader. There are four types of tab stop: Left, Right, Centered, and
Decimal. The first three are self-explanatory and align the text relative to the tab position. Decimal tab stops
align the text on a decimal point or any character you specify in the Align On field. They’re useful when
working with currency or price lists.

Tab leaders are repeating characters that span the distance between the tab character and the text that follows.

Setting Tabs

TIP: When setting tabs as part of a paragraph style, it’s preferable to set the tab stops locally (using
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the Tab Ruler from the Type menu) rather than in the Paragraph Style Options. The Tab Ruler is

interactive, whereas the Tabs option in paragraph styles is static. Once you have the tabs how you
want them, either create a new style or right-click the style name to redefine an existing style.

Here’s how to set tabs:

1. Insert your type cursor before the text you want to shunt to a new position, and press the Tab key.

2. Choose Type > Tabs, or press Cmd+Shift+T (Ctrl+Shift+ T). With your type cursor in the frame, click
the magnet symbol at the lower right of the Tab Ruler to snap the Tab Ruler above the text frame.

3. On the Tab Ruler, choose the type of tab you want and click the ruler to set its location.

4. Optionally, capture these settings as a paragraph style by choosing New Paragraph Style from the
Paragraph Styles panel menu.

Using Tab Leaders
Tab leaders are used on menus, price lists, and tables of contents. Their purpose is to guide the eye from one
piece of text to the next. There are other solutions, arguably preferable, but so long as the distance between
the text and the number isn’t too wide, leaders can be effective.

For leaders with more space, add a space after the period in the Leader Character field. In a table of contents
with more than one level, make sure the leader characters are all the same size. Inconsistent spacing can occur
when the leader inherits its formatting from the last character before the tab. The best way to ensure
consistency is to apply a character style to the leader characters. Creating a character style for your tab leaders
also makes it easy to reduce the size of the leaders by one point, which improves their appearance in the text.
If you’re adding dot leaders to a generated table of contents, the Table of Contents dialog allows you to apply
separate character styles to both leader characters and page numbers. You can also incorporate spacing before
and after the leaders in the form of a thin space or en space.

Leader characters don’t necessarily need to be dots. Using the underscore as the leader character is an old-
school method of creating a simple line that’s useful in reply forms.
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Instead of leader characters, apply an underline to the tab character, preferably as a character style. This will
give you more control over the weight and offset of the line. You can go one better and apply this as a nested
style — see Chapter 15.

If you want to forgo the tabs altogether, you can apply a dotted underline to a flush space and set the
alignment of the paragraph to justify all lines to extend the leader to the right edge of the frame.

Tabs Dos and Don’ts

For best results with tabs, follow these guidelines:

Do: Use tabs, not spaces, to position text at a specific position on a line.

Do: Use left-aligned text with tabs. Anything else will give you unpredictable results.

Do: Align the Tabs panel with the top of your frame. This should happen automatically but,
depending on your view size, sometimes doesn’t. If necessary, click the magnet to snap the panel to
the frame.

Don’t: Use multiple consecutive tab characters. Just as with spaces and paragraph marks, one is
enough. Typing multiple tabs on your line will cause your words to start jumping around erratically.
Instead, press the Tab key and then set a tab stop to determine where you want the text to jump to. If
you receive a text file with multiple tabs, first clean it up using Find/Change to search for multiple
tabs and replace them with a single tab.

Don’t: Use tabs to set complex tabular information. There was a time, long ago before InDesign was
born, when page layout programs didn’t have dedicated table editors. Tabs were the only way to
format tabular information. Things have moved on. You can still create “tables” using tabs, and
visually the result may be the same as using a real table. But problems arise when you edit “tables”
created in this way; sometimes you need only look at a tab-created table for it to fall apart. Tables —
real tables — as well as being easier to use are far more robust when it comes to editing.

Don’t: Use tabs to indent the first line of a paragraph. That’s what the first-line indent feature is for.

Don’t: Force lines to break by entering tabs at the end of a line. These will come back to bite you
later when the text reflows.

Don’t: Use tabs in EPUBs. Tabs don’t export to EPUBs, so if an EPUB is your intent, use tables
instead for tabular data.
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Hanging Indents
Left-hanging indents can be created on the Control panel (see Chapter 6), in the Bullets and Numbering
dialog, or by using the Tab Ruler. If using the latter, drag the left indent markers to the desired location on
the ruler; this automatically sets a tab stop at the marker’s position. Now drag the top portion of the indent
marker back to the margin. You can’t make right-hanging, or last-line, indents with the Tab Ruler.

Repeating Tabs
You can set a repeating tab based on the distance between the tab and the left indent (or the tab and the
previous tab stop) by choosing Repeat Tab in the Tabs panel menu. To change the spacing, select the tab,
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move it left or right and/or change to a different type of tab, and then choose Repeat Tab again.

Right-Indent Tab
A right-aligned tab (Shift-Tab) aligns all subsequent text to the right edge of the text frame. This is preferable
to a right tab because the text after a right-indent tab always aligns with the right edge, even if the width of
the frame changes.

You can also use a right-indent tab with a tab leader in, for example, a table of contents: set a tab stop
anywhere in the paragraph, and apply a leader character to it. Place your cursor at the end of the paragraph
and press Shift-Tab, and the leader character will appear. The code for a right-indent tab is ^y.

▄

Bulleted lists and numbered lists can be fussy, and tabs can be frustrating and seem a little archaic. But it’s
worth getting to grips with both, because they are an inevitable part of typesetting more complex documents
— and because trying to cut corners will only end up making things worse. Now that our list and tabs are in
order, let’s move on to something more decorative: drop and initial caps.
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Chapter 13

Drop Caps

The use of decorative first letters as a design element has evolved from a long tradition of illustrated
first letters stretching back to before the invention of the printing press. Before printing, books were
dictated to scribes, and each book was regarded as a unique treasure. The scribes incorporated
individual flourishes to distinguish their work from others. It was with the decorative first letter that a
scribe could really cut loose and show his stuff. Each major section usually began with an illuminated
letter made with metallic, mineral, or vegetable pigments that were bound by glue or gum to the paper
or parchment.

The purpose of the initial letter, or versal, was to call attention to the beginning of the book. By the 14th
century, versals had evolved from enlarged heavy letters into elaborate illustrated works of art, most often used
to decorate or “illuminate” religious texts. An illuminated versal might flow down the whole side of a page, or
extend up and around the top of the page. Sometimes a versal included illustrations and took over the entire
page. In 1455, when Gutenberg printed his 42-line Bible — the first book to be printed in the western world
with movable type — he acknowledged the importance of this tradition by leaving space in the printed text for
a scribe to add a decorative first letter.

As printing evolved, so did the forms of initial caps used by designers. Current variations include hung caps,
several forms of dropped caps, and raised, or stick-up, caps. InDesign uses the term drop cap for all initial cap
styling.

Creating a Simple Drop Cap
Contemporary magazine and book publishing continues this centuries-old tradition by optionally beginning
chapters and articles with large initial letters. The treatment can be incorporated into a paragraph style or
applied locally through the Control panel.

To create a drop cap, insert your type cursor into the paragraph and type the number of lines for the drop cap
in the Control panel, then specify the number of drop cap characters you want — usually one, but this isn’t
always the case.
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If you plan on applying the same formatting to more than one paragraph in your document, it saves time (and
ensures consistency) to incorporate the drop cap attributes into a paragraph style definition.

To create a new style with the drop cap attributes, choose New Paragraph Style from the Paragraph Styles
panel. To edit an existing style, Ctrl/right-click the style and choose Edit.

Name the new style; “first par” and “body first” are common naming conventions. If you have a “body” style,
base your “body first” style on this. Choose “body” from the Based On drop-down menu.

Choose Drop Caps and Nested Styles from the list in the left column. Specify the number of lines to sink the
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first character and the number of characters that you want to include.

You can use the Character Style drop-down menu to apply an existing character style to the drop cap, or you
can choose New Character Style to make and apply a character style.

Drop Cap Aesthetics
There are no hard-and-fast rules concerning how big a drop cap should be, but common sense should prevail.
Bigger isn’t always better. The purpose of the drop cap is to signal to the reader where to begin. To do so, the
drop cap doesn’t need to scream at the reader and shouldn’t overwhelm any headline that precedes it on the
same page. The drop cap comes below the headline in terms of page hierarchy; usually, though not always, it
will be smaller than the headline. Also, there’s no need to repeat the letter that you use as the drop cap at the
beginning of the text.

TIP: The Daily Drop Cap (www.dailydropcap.com) is an online project from Jessica Hische that
showcases her beautiful initial cap illustrations created between 2009 and 2011. It’s an inspiration
for what’s possible when creating decorative drop caps.

Stylistically, the drop cap gives the designer a chance to echo the typeface choice for the headings in the article
and presents another opportunity to add visual interest by applying to it the signature color of the piece. If the
drop cap character looks overwhelming because of its size, consider running it in a reduced tint of this color,
or perhaps apply the color to the letter’s stroke rather than its fill.

In addition to the initial drop cap for the first paragraph of a chapter or article, it’s common to use smaller
drop caps as section markers (create a style based on the parent drop cap style). This is visually effective to
break up the monotony of columns of type and may be necessary if the text doesn’t have illustrations,
subheads, or other graphic elements.

However, if you sprinkle drop caps too liberally throughout a document, they start to become repetitive and
annoying. As a general rule, don’t use more than two drop caps per page. Paragraphs that get the drop-cap
treatment shouldn’t be close to each other on a page, and preferably the drop caps should be different letters.

Some letters are better suited to drop caps than others. Letters that are square or reach out toward the first
letter of the text appear more comfortable; for example, C, E, F, H, K, M, and N.

Drop caps often look optically misaligned because the left sidebearing (the space incorporated into the letter’s
design) causes the letter to appear slightly indented. This can be addressed by selecting Align Left Edge in the
Drop Caps and Nested Styles dialog and by turning on Optical Margin Alignment on the Story panel.

Decorative drop caps or letters with descenders, like J and Q, may collide with the second line of the text. To
prevent this, select the Scale for Descenders check box in Drop Caps and Nested Styles.
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Kerning Drop Caps
A common problem with automatically generated drop caps is that the big first character often collides with
the text that follows. You may need to kern to avoid such problems — or you may need to kern just because
you want more or less space between the drop cap and the text. Note that when you kern between the drop
cap and the first character of the text, kerning is applied to all the lines adjacent to the drop cap.

If you place a non-joiner (a character with no width) between the drop cap and the second letter, you can then
kern the space between that non-joiner and the following letter, bringing just the first line in. To enter the
non-joiner, choose Type > Insert Special Character > Other > Non-joiner.
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With a decorative letter, selecting Align Left may not be sufficient to optically align the drop cap. You may
also need to kern the drop cap to the left margin. To do this you’ll first have to add a space before the drop
cap. Note that adding a space will mean you have to drop two characters instead of one. Now insert your
cursor between the space and the drop cap and kern — Option+Left Arrow (Alt+Left Arrow) — until the
character is optically aligned with the left margin edge. Use a thin space — Cmd+Shift+Option+M
(Ctrl+Shift+Alt+M) — instead of a regular space, and you won’t have to kern as much.

Creating a Picture Drop Cap
Converting a drop cap to outlines — by choosing Type > Create Outlines or pressing Cmd+Shift+O
(Ctrl+Shift+O) — allows you to place an image into the letter shape. It’s a compelling idea, but unless the
drop cap is very large and in an extra-bold typeface, there’s unlikely to be enough space within the letter shape
for the image to be readable. There’s also the danger of visually disassociating the drop cap so that the reader
scans the first line without the first letter.

Creating a Contoured Drop Cap
Putting your drop cap character in its own text frame allows you to contour the text to the shape of the drop
cap. Once you’ve put the initial letter in its own frame, apply a text wrap to that frame, then use the Direct
Selection tool to sculpt the text wrap outline to the letter shape. Make sure the space around the drop cap is
optically the same on the right side and below the drop cap. You can anchor the drop cap to the text flow by
dragging the blue square at the top of the text frame to the end of the paragraph that precedes the drop cap.

281



To take this further, with a letter that leans away from the text, you might prefer to bring the first line back
against the drop cap:

1. In the main text frame, make sure the paragraph does not have any drop cap style applied, and then
add a space in front of the first character.

2. Kern back over this space to bring the first line closer to the drop cap.

3. Optionally, insert an Indent to Here character on the first line to determine the indent of the
subsequent lines in the paragraph.

Adding Small Caps
It’s common to set the words following the drop cap in small caps. This creates a transition or visual bridge
from the large decorative character into the upper- and lowercase text so that the drop cap doesn’t look like an
isolated graphic. Just how many characters are put into small caps is a matter for discretion — it may be the
first word, the first phrase, a specified number of words, or the first line. Whatever you choose, be consistent
throughout the publication.
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It’s possible to use a nested style to specify character-level formatting for one or more ranges of text in a
paragraph. This is useful for opening paragraphs that include drop caps. If the drop cap character is a different
color or typeface (or both) than the rest of the paragraph, you can nest a character style with these formats in
the paragraph style. You can also nest a character style to apply small caps to the text after the drop cap. Once
it’s set up, you can apply all the formatting with a single click.

1. Create a small caps character style. If you’re using an OpenType font, choose OpenType All Small
Caps from the Case drop-down menu to keep the case of your small cap range consistent without
having to rekey any initial caps as lowercase letters.

2. To “nest” the small caps character style in the paragraph style, Ctrl-click or right-click the paragraph
style in the Paragraph Styles panel and choose Edit to open the Paragraph Style Options panel, and
then choose Drop Caps and Nested Styles from the left-hand column.
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3. Click New Nested Style and specify the number of words to apply the nested style to. If you haven’t
already styled the type, you can create a new character style by clicking [None] in the window and
selecting New Character Style from the drop-down menu.

To automate the application of small caps to the entire line, create a new line style.

Drop Caps in Reflowable EPUBs
Drop caps are preserved in an exported EPUB. Any nested character styles that are part of your drop cap
paragraph style are exported as separate CSS classes. However, the problem is that drop caps are handled
inconsistently across ereaders.

As mentioned, drop caps are usually combined with small caps to create a visual transition from big to small.
But small caps do not fare well in an EPUB. If you find that small caps are showing up as upper- and
lowercase text in the exported EPUB, a fail-safe way to create small caps is to type them as ALL CAPS and
apply a character style that reduces their size — by say, 70% — to simulate small caps. This isn’t elegant, but if
you really need small caps, it will work. Of course, the issue is that the small caps are simulated. Even if your
InDesign document uses real small caps, these end up as synthetic small caps in the exported EPUB.
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Difficult Drop Caps
Drop caps are just one way of kicking off a paragraph; they’re not always the most appropriate solution. If you
have the occasional opening paragraph that needs customizing, no big deal, just so long as it’s an exception. If
you find yourself fussing over every chapter or article opening, then use another type of opening device or
simply remove the first-line indent and add a paragraph space before the section or chapter opening text.

Before you decide on a particular opening device, familiarize yourself with the material. Here are some
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instances when drop and initial caps don’t work well:

When the first character of the paragraph is a number.

When an opening paragraph begins with a quotation mark. You will need to drop both the opening
quotation mark and the initial cap. The opening quote mark will probably look disproportionately large.
You’ll want to reduce its size, adjust its vertical position by applying a baseline shift, and kern the space
between it and the drop cap that follows it. Exact amounts will vary according to the characteristic of
the font. You’ll also want to hang the opening quote mark in the left margin.

When opening paragraphs can’t accommodate the drop cap’s depth. Trying to sink a drop cap three
lines into a one-line paragraph creates visual confusion, although InDesign does an excellent job of
coping by allowing the next paragraph to come up. However, if you find you’re repeatedly using a three-
line drop cap on paragraphs that are only one or two lines deep, consider using a raised cap instead.

When your articles or chapters begin with poetry, song lyrics, or other quoted material. To apply the
drop cap here would add an extra (and unnecessary) level of decoration, possibly confusing the reader.

▄

In the rule-bound field of typography, drop caps are an area where anything goes. So long as they are an
appropriate fit for the material, drop caps are a great way to add visual interest to your text.
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Chapter 14

Combine Typefaces

Choosing a typeface is one thing, but once you’ve made your choice, how can you ensure it plays nicely
with others? In this chapter, we’ll look at tried-and-tested formulas for combining typefaces. This is a
perennial topic for designers and one that anyone concerned with typog–raphy will revisit numerous
times throughout their career. Good font combining relies on typographic principles. These
principles are not scientific, rigid, or fail-safe; all of them can be broken, but all should be understood.

Things to Avoid
A good principle to live by, whether you’re new to typography or a seasoned pro, is to keep it simple. Or to
put it another way: don’t use too many fonts. Just as mixing too many colors on your palette will likely result
in mud, mixing too many fonts on a page will probably result in a confused message.

But the old adage “never use more than three typefaces on a page” is not an unassailable truth; rather, it’s a
modernist principle and one that is best applied in editorial design. Although it may be true that most great
pop songs use only three chords, some use more and some use fewer. So it goes with type. Look at 19th-
century posters and you’ll see that the Victorians used a lot more than three typefaces, sometimes throwing
the whole type case at a job. Today, this style is often regarded as charming and is widely emulated.

Vive la Différence
Combining typefaces that are too similar may look like a mistake — like you had been experimenting with
different fonts and had forgotten to clean up after yourself. For example, combining two “neutral” sans serifs
like Helvetica and Univers creates discord; readers will sense something awry even if they can’t name what it
is. Combining two slab serifs like Clarendon and Rockwell — both of which are control freaks and want to
run the show — will create unnecessary tension. Just like in a comedy duo, there needs to be a straight man. If
you have a typeface with a strong, extrovert personality, try combining it with something neutral, reserved,
and trustworthy.
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It’s a Family Affair
Keep in mind that combining typefaces is optional, not obligatory, and to take the safe approach further, for
an (almost) guaranteed harmonious look, you can stick with a single typeface family. A typeface always goes
with itself. Just be sure to choose a typeface family that comes in a variety of weights, styles, and widths.
These days, extended typeface families are the norm, allowing you to easily differentiate one level of hierarchy
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from the next, while at the same time being assured that, as with the Everly Brothers, the shared DNA of the
family members means they can sing in perfect harmony.

When choosing a typeface family — as well as the range of weights, styles, and width — consider the size of
the available character set. Does it have distinct small caps? Are there different numeral styles? Extra ligatures?
Foreign accents? Pro fonts offer these and other glyphs within a single font.
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Keep in mind that much differentiation is possible, even without varying the font or its weight and size. You
can use casing, color, indents, letter spacing, paragraph spacing, and paragraph rules to denote difference. It is
an informative exercise to work within the limitation of a single font. When you’ve exhausted the possibilities,
one by one introduce other members of the family — the different weights and/or styles — and different
sizes.

It’s puritanical to say that differentiation should be an either/or proposition (either bolder or bigger but not
both), and adhering to these rules doesn’t reflect the reality of contemporary book and magazine publishing.
But working within such constraints makes you think about the changes you’re making and compels you to
justify them.

Go for Contrast
For editorial design, typeface combinations based on contrast are better equipped to clearly establish
hierarchy. Using contrasting typefaces makes it clear which paragraphs are your head and subheads and which
are body copy. It’s also clear that you want to draw your reader’s attention first to the heads.

Keeping Current

Just like clothes, food, and music, typefaces go in and out of style, and you owe it to yourself and your
clients to stay current. Stay abreast of new typeface offerings and trends by following popular
foundries on social media or signing up for their e-newsletters:
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MyFonts (myfonts.com)

Monotype (fonts.com)

Type Network (typenetwork.com)

Fontshop (fontshop.com)

House Industries (houseind.com)

P22 (p22.com)

T:D:F (thedesignersfoundry.com)
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Combining different fonts is not the only way to create contrast. Using the classic formula of mixing a serif
and sans serif — the former usually for the body text; the latter usually for the heads, subheads, and
supporting material — is another effective way of bringing contrast to your design. Using different weights,
sizes, and styles will vary the type color or density of your text, visually chunking it into distinct blocks. Of
course, other factors are also involved: leading, inter-paragraph spacing, and letter spacing also play their part.
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Try squinting at your text. If it blurs into a similar density, like when the sea and the horizon blend seamlessly

on an overcast day, then you need to adjust one or more of these properties.

And when making such adjustments (technical term: tweaking), you’ll find it easier if you’ve assigned distinct
roles to each font and created your paragraph styles in InDesign in a logical way. If you take advantage of
InDesign’s “based on” feature, then experimenting with different type combinations and different character
and paragraph formats is a fun, rather than onerous, task. A typical magazine spread might require two
distinct threads of styles, one based on the body style and the other based on the head style. With some
planning you can create a style sheet with two parent styles and as many offspring as necessary to fill the
different roles. Setting up your styles this way makes experimentation easy, because all it takes is a couple of
modifications to the parent styles for all the offspring to change, and — presto! — you have a whole new look.
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From the Same Stable
When combining typefaces, a little insider knowledge can go a long way. Your choices can be underpinned by
the logic of combining typefaces from the same designer. Don’t know who designed the typeface? It’s amazing
what you can find out on Wikipedia and Fonts in Use (fontsinuse.com). Some typefaces — like Museo and
Museo Sans, Stone Serif and Stone Sans, Source Serif and Source Sans — have been designed specifically for
combining with each other. Others that were not designed specifically as complements but were crafted by the
same hand will likely share a similar aesthetic. A couple of commonly used combinations that fall into this
category are Perpetua and Gill Sans (Eric Gill) and Palatino and Optima (Hermann Zapf).

Historical Accuracy
Another approach, appropriate for one-of-a-kind jobs, is to choose a typeface that’s historically appropriate
for the subject matter. Perhaps even more important here is to avoid a typeface that’s historically inappropriate
— for example, one designed after the period in which the material is set. There are type geeks hiding in the
bushes waiting to pounce on you for using a 1970s typeface in a biography of a writer best known for her
works of the 1950s. Don’t become their easy prey.
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And to strike a cautionary note, avoid the trap of the obvious. Trajan has been overused on movie posters,
Lithos should not be your go-to font for a book on Greece, Comic Sans is not the best choice for a children’s
book, and don’t use Futura just because your topic deals with “the future.”

Combining Characteristics
As well as the factors already mentioned, we need to consider the characteristics of the typefaces, in particular
their strokes, x-heights, and cap heights. Let’s look first at stroke. Bodoni and Futura might seem like unlikely
bedfellows — designed 130 years apart, one a modern typeface with extreme contrast between the thin and
thick parts of its stroke, and the other a geometric, almost monoweight, sans serif. What they have in
common, though, is a verticality of stroke, making them a good match.

If you intend to mix typefaces in the same paragraph, either because you’re using a different typeface for
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emphasis or because using a run-in head, you’ll want them to have the same x-height. If the x-heights differ

markedly, this will be jarring to your reader as their eyes run into the bumps of higher x-heights. If you’re
using a character style or nested style to call out the run-in heads, all you need do is slightly reduce the size of
the font with the larger x-height to bring it into line with the body text.

If you’re creating some sort of wordplay by mixing typefaces in the same word, you’ll need to adjust sizes to
match the cap heights and switch to optical kerning, because there won’t be any kerning metrics for combined
letter pairs.

▄

What these guiding principles for mixing typefaces don’t take into account is the wild card of all good design:
intuition. Just as an experienced chef can combine the most unlikely ingredients to great effect, so can an
experienced typographer toss together type combinations that defy logic.

Also, don’t forget the context. For editorial design, following these guidelines will likely yield a better result,
but for more subjective work, there are no restraints. So long as your document has some sort of typographic
rhythm, the sky’s the limit. In short, these principles make a good starting point: adhere to them when they
facilitate your creativity; overrule them when they get in your way. But don’t ignore them.
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Chapter 15

Styles

Styles have been around since the dawn of desktop publishing, continually evolving in their ease of use
and range of capabilities. A bedrock feature of any page layout program, styles enable better design
and a more efficient workflow. No matter how good your conceptual grasp of typography, it won’t
amount to much unless you apply type formatting consistently and efficiently using styles.

Defining Our Terms
Paragraph and character styles are collections of attributes that can be applied to text with a single click or
keystroke. Paragraph styles can incorporate both character and paragraph formats — font, font size,
alignment, paragraph spacing, color, you name it. Character styles can incorporate character formats only. As
the name suggests, paragraph styles are applied to whole paragraphs; character styles are applied to a selected
range of text within a paragraph.

Object styles are applied to frames — text frames or picture frames — and include such attributes as fill color,
stroke color and weight, text frame options, picture fitting options, and many more.

Table and cell styles are applied to tables. Table styles cover the attributes of the overall table, such as whether
it has a border or uses row or column strokes. Cell styles refer to the attributes of the individual cells — like
text insets — that make up a table.

Things get more complicated when you nest character styles within paragraph styles, which in turn can be
incorporated into object styles. Add into the mix GREP styles (which automatically apply character styles to
predefined ranges of text within paragraph styles) and sequential styles (which let you apply styles to a cascade
of paragraphs), and the possibilities are mind-boggling.

Collectively, I will refer to the paragraph, character, and object styles in a document as a style sheet.

Why Use Styles?
The difference between using styles and not using styles is the difference between you controlling InDesign
and InDesign controlling you. Here are some reasons to use styles:

Styles ensure consistency in formatting throughout a document, allowing readers to find with ease the
section or subsection they wish to read.

Styles enable you to easily change the formatting of your entire document, no matter how large or
complex, by changing your style definitions.

Styles save you hours and hours of drudgery.

Despite these irrefutable facts, many designers either underutilize styles or avoid them altogether. I’m
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frequently amazed by the number of designers — many of whom should know better — who don’t use styles
or who use them in a half-assed way. What’s up with you people? Do you like the grind of repetitive work?
Are you masochists?

I’ve had designers tell me “I don’t like to use styles because I like to experiment with different designs” or “I
don’t want my pages to all look the same.” These are exactly the reasons you should use styles. Far from stifling
creativity, styles enhance it by making experimentation quick and easy. And just because your style names may
be the same or similar from one document to the next doesn’t mean the style definitions can’t be completely
different.

Creating Paragraph Styles
Time spent creating style sheets is an investment that will repay you many times over throughout the lifespan
of a publication. You can set up your styles at the beginning of the design process or add and edit your styles
as your document evolves. If you’re like me, a style sheet is never finished but is always being refined and
improved.

[Basic Paragraph]
By default, the [Basic Paragraph] style is applied to text you type. You can’t rename or delete this style, but
you can edit it: Ctrl-click (right-click) the style name and choose Edit to bring up the Paragraph Style
Options, where you can change its properties. Alternatively, you can designate a different style to be the
default: simply choose that style when you have no text or text frame selected. The best advice I can give about
[Basic Paragraph] is to ignore it. This is because if you’re copying and pasting text between documents that
have different definitions of [Basic Paragraph] you can get some nasty surprises.

Another special class of style is [No Paragraph Style]. Sometimes for the sake of expediency you will format
text locally and want this text to remain independent of any changes to its style definition. To do so, choose
Break Link to Style from the Paragraph Styles panel menu. Thereafter, (No Styles) appears at the top of the
Paragraph Styles panel when the text is selected.

Creating the Style “Blind”
Using the Paragraph Style Options dialog, you can create as many styles as you need without having a single
character on your page. With experience, you can visualize what a style will look like without needing to see it
realized on your page, which makes setting up a style sheet much faster.

Basing Styles on a Parent Style

In this example head 3 is based on head2, head2 on head1. This means you can edit the parent style
and cause all the styles based upon it to change.
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Basing styles on other styles is a beautiful thing when you’re fully aware of what you’re doing; when
used unintentionally, the Based On feature might leave you scratching your head about why your
styles seemingly have a mind of their own. If you don’t want your new style based on anything,
choose [No Paragraph Style] from the Based On pop-up menu.

Basing Styles on Other Styles
Hierarchy is a big concept in typography. Hierarchy gives a document structure and aids effective
communication by clearly signaling to the reader what is most important. The Based On option helps
establish hierarchy in your styles. Typically, though not exclusively, hierarchy is established through size. Take
a simple example: your headings and subheadings will probably use the same font — Head1 will be bigger
than Head2, which in turn will be bigger than Head3.

By basing one style on another, you create more than just a visual link between the styles; when you edit the
base, or “parent,” style, the attributes that it shares with its “offspring” styles also change. This lets you effect
changes across a range of styles with a single edit to the parent style. For example, if you want to switch the
font of your heads from Helvetica to Univers, change Head1 (the parent style) and all the styles that are based
on it will change too (except for attributes like the font size, which are unique to the individual styles).
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To create related styles and establish hierarchy using the Based On option:

1. Adjust the Character and Paragraph settings on the Control panel to format the paragraph the way you
want it to look.

2. With your cursor in the newly styled paragraph, open the Paragraph Styles panel and choose New
Paragraph Style from the menu. The Style Settings window will reflect your choices. (If you don’t want
the local formatting, click the Reset to Base button.)

3. Name the style and (optionally) specify a shortcut keystroke. If you want to add additional formatting,
click the attributes list on the left and specify the options you want to add to your style. To apply your
new style to the text you are basing the style on, select Apply Style to Selection. With Preview selected,
you can see your formatting changes added to the selected paragraph.

4. Click OK.

Applying Styles
When you select text, the style applied to that text is highlighted in the Paragraph Styles panel, the Character
Styles panel, or both. If you select a range of text covering multiple styles, no style is highlighted — (Mixed)
appears at the top of the panel.

To apply a paragraph style, place your type cursor anywhere inside the paragraph — there’s no need to select
the whole paragraph — and then click the style name in the Paragraph Styles panel. To apply a paragraph
style to more than one contiguous paragraph, drag your cursor through those paragraphs. Again, you don’t
need to select the whole paragraph; you just need to make contact with at least one character of each
paragraph.

Applying a paragraph style doesn’t remove any existing character formatting when a character style has been
applied to any text in that paragraph — unless you clear any overrides (see the “Clearing Overrides” section).
When you apply a style, if the text has additional formatting that’s not part of the style definition, a plus sign
(+) appears next to the style name in the Paragraph Styles panel.

Assign a keyboard shortcut to your styles and you’ll be able to apply them even faster. Shortcuts must be a
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combination of Shift, Option/Alt, and Cmd/Ctrl and a keypad number. Letters and non-keypad numbers will
not work, nor will function keys, so if you’re working on a laptop, the key combinations are unwieldy.

For text-heavy documents, it may be quicker to apply styles in the Story Editor (with or without shortcuts)
simply because you can scroll through long passages of text faster than in Layout view.

Quick Apply
When you have many styles, you often need to scroll through long lists and manage multiple panels to get to
the one you’re after. To speed things up, use Quick Apply to find a style by typing the first few characters of
its name. Here’s how:

1. Select the text or frame to which you want to apply the style, and press Cmd+Return (Ctrl+Enter) to
bring up the Quick Apply list.

2. Start typing the name of the style. InDesign takes you to the closest match.

3. Use the Up Arrow and Down Arrow keys on the keyboard to move through the list.

4. Press Return/Enter to apply the style.
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Quick Apply remembers the style you just used and returns to its name in the list of styles when you return to
the Quick Apply panel.

Clearing Overrides
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When you add formatting to text that already has a paragraph or character style applied, you override the style
definition. To put it another way: you’ve defined a paragraph style, applied it to a piece of text, and then
contradicted your style definition by adding additional formatting. You can identify text with overrides by the
plus sign (+) next to the style name. You can also choose Toggle Style Override Highlighter from the
Paragraph Styles panel menu to highlight, in cyan, where overrides have been applied. Hover the cursor over
the style name in the Paragraph Styles panel and a tool tip pops up with details of the local formatting.

Styling Paragraph Pairs

When styles need to be applied in a predictable way, the “Fix paragraph style pairs” script from
Thomas Silkjaer can save a lot of time. For example, if a subhead style is always followed by a body no
indent style, run the script to speed up your paragraph styling. You can find the script at
https://indesignsecrets.com/find-change-the-next-paragraph-style-with-a-script.php.

Maybe this local formatting is what you want; maybe it’s not. Maybe you’ve inherited the document from
someone else — someone who hasn’t used styles as effectively as you would like — and you want to clear the
overrides.

There are several ways to approach this:

To clear local formatting but retain any character styles applied to the paragraph, Option/Alt-click the
style name in the Paragraph Styles panel. Alternatively, click the Clear Overrides button in the Control
panel.

To remove only the local character formatting (retaining any local paragraph formatting), Cmd/Ctrl-
click the Overrides button (the Paragraph icon) at the bottom of the Paragraph Styles panel.

To remove only the local paragraph formatting (retaining the character formatting), Cmd+Shift-click
(Ctrl+Shift-click) the Clear Overrides button.

To clear all local formatting and character styles, Option+Shift-click (Alt+Shift-click) the style name in
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the Paragraph Styles panel.

To clear overrides while using Quick Apply, press Cmd+Return (Ctrl+Enter) and then press
Option/Alt as you click the style name.

Editing and Adapting Styles
The beauty of styles is that you can change their definitions at any time. Changing a style definition means
that all text formatted with that style changes. This has been a staple feature of page layout programs since the
Stone Age.

Styles allow unprecedented flexibility in experimenting with the appearance of your document. A few simple
clicks and you can totally transform the appearance of your pages. It’s a beautiful thing.

The safest way to edit a style is to Ctrl-click (right-click) the style name in the appropriate Styles panel and
choose Edit from the menu. This is preferable to double-clicking the style, which also works but risks
inadvertently applying the style.

Once you’re in the Styles Options dialog box, make as many or as few changes as you want, click OK, and
Bob’s your uncle.

Redefining Styles
InDesign is flexible about how you manage your styles. As an alternative to editing styles, you can redefine
them. If you apply local overrides to a paragraph and then decide that’s actually how you want the style to
look, you can incorporate those overrides into the style definition. When your cursor is in text with local
overrides, open Paragraph Styles, Ctrl-click (right-click) the style name, and choose Redefine Style from the
menu. The same approach works for redefining character styles. If you’d prefer, use these shortcuts: to
redefine a paragraph style, press Cmd+Option+ Shift+R (Ctrl+Alt+Shift+R); to redefine a character style,
press Cmd+Option+Shift+C (Ctrl+Alt+Shift+C).

Loading Styles from Another Document
Every publication, be it the National Enquirer or the New York Times, whether it be destined for print or
screen, follows a similar structure: heads of different levels of hierarchy, subheads, captions, callouts or pull
quotes, and several closely related variants of body text. When you set up styles, it’s important to establish the
relationship between them — that is, which styles are based on (and thus inherit their properties from) other
styles. Once the relationships have been established, changes to a “parent” style will affect all other styles based
on it. With such a style sheet, you can effect a dramatic transformation in the appearance of the document
with just a few moves.

You can reuse and repurpose styles from one document in any other document. The same is also true of
master pages and color swatches. Choose Load Paragraph Styles (or Load All Text Styles if you also want
character styles), navigate to the document containing the styles you wish to import, and then click Open.
You can import all styles or specific styles and determine how to deal with any style-name conflicts: if the style
name is the same in both documents, you can use the incoming style definition or rename the incoming style,
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which will have “copy” appended to its style name. (You can later rename it if you wish.)

Loading Styles from a CC Library
Every time you create a style, you can select the Add to CC Library check box in the bottom left of the
Paragraph Style Options. Frankly, this is annoying when you forget that you have the box selected and feels
like Adobe pushing their new(ish) CC Library feature down your throat. More useful, however, is the ability
to add a group of selected styles to your current CC Library by clicking the cloud icon at the bottom left of
the Paragraph Styles panel (the same option exists for other styles). To add these styles to another document,
select them in the CC Library panel, Ctrl-click (right-click), and choose Add to Paragraph Styles.

Organizing Styles
A well-organized style sheet is a boon to productivity. Here are some tips and personal preferences.

NOTE: Be precise when naming your styles, or you may end up with two versions of a style and no
idea which is the real one. Style names are case-sensitive; for example, Body Text and body text are
two distinct styles.

Naming: Keep in mind that you might revisit a document months or even years from now, so you’ll want a
style-naming strategy that’s transparent. Alternatively, you may need to hand over your document to someone
else to finish. So that you don’t have to waste time explaining why you named your styles after your favorite
Radiohead songs, keep them logical and follow established conventions: body, head, subhead, caption, and so
on. Rather than have the style names describe their formats — for example, “Helvetica 18 pt Bold” — it is
preferable to have them describe their function: say, “Head2.” That way, you won’t have to rename the styles
when you want to change from Helvetica.

The Problem with Style Groups

With style groups being so useful, what’s not to like? In reality, and depending on your workflow,
style groups can create as many problems as they solve. Firstly, if you have same-named styles in
different style groups, it can be confusing which subhead or body copy you’re applying. But the bigger
problem comes if export your InDesign story as an RTF (Rich Text Format) file for editing in Word.
Upon export, InDesign changes the style names by appending the style group name — with the
consequence that if you then reimport the updated RTF file, the styles are not automatically
remapped back to their original InDesign styles. If this describes your workflow, I’d recommend
avoiding style groups altogether or switching to an InCopy workflow, where the full style names are
preserved.

Sorting: When you choose Sort by Name from the Paragraph Styles, Character Styles, or Object Styles panel
menus, InDesign lists your styles in alphanumeric order. For this reason, you might consider putting a two-
digit identifier — such as 01_head for a first-level head — in front of your most commonly used styles to force
them to the top of the panel. Unfortunately, this option is not “sticky.” New styles won’t be sorted
alphanumerically, so you may find yourself having to periodically revisit this option.
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Style Groups: These folders on the Styles panels allow you to group related styles together. This visually
reinforces the relationship between those styles but also allows you to more easily manage long lists of styles by
hiding and disclosing the contents of the style groups as necessary. To create a style group, click the Style
Group icon at the bottom of the style panel, name the group, and then drag the styles into the folder.
Alternatively, Shift-click to select the styles you want to group together (Cmd-click/Ctrl-click to make a
noncontiguous selection), then choose New Group from Styles from the panel menu to move your selection to
a new folder.

As well as their housekeeping role, style groups also help avoid style conflicts when copying text from one
document to another. When you copy text from one document to another, the style definitions in the
destination document take precedence. For example, if you copy text in the “body” style to another document
where there’s already a “body” style with a different definition, you’re in for a nasty shock.

To prevent this, in the source document, move the styles into a style group. Do this not just for the paragraph
styles but also for the character, object, table, and cell styles. For example, the figures for this book were
prepared in a separate document using many paragraph styles, some of which conflicted with the style names
in the main chapter documents. To avoid conflicts, the styles in the figures document were moved into a style
group named Figures. This had the added benefit of keeping these styles separate from the styles used for the
running text.

The Mother of All Styles: The Book Feature

InDesign’s Book feature lets you apply one set of styles to a group of documents. Choose File > New
> Book to open the Book panel. Add documents to the book by clicking the Add button or by
dragging files (or even folders of files) into the panel. Use the Up Arrow and Down Arrow keys to
change the order of the documents. Once the book is set up, you can synchronize the styles and color
swatches in your “booked” documents all at once or one at a time. The Book feature also provides a
fast way to add the styles from one document to a group of others.
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Specify a style source, or “master” document, by clicking in the leftmost column of the Book panel,
and then synchronize the documents in the book. Styles and swatches are copied from the style source
to all the documents in the book, replacing any that have identical names.

You can synchronize the book while its documents are closed. InDesign opens the closed documents,
makes any changes, and then saves and closes the documents. Documents that are open when you
synchronize are changed but not saved. To synchronize selected documents, Cmd-click (Ctrl-click)
the document icons (or Shift-click for a contiguous selection). If no documents are selected, the
whole book will be synchronized. Synchronizing documents adds styles and changes the definition of
styles with the same names as those in the style source; it does not remove styles from book
documents.

Whether or not you choose to use the Book feature depends upon the kind of documents you are
creating, whether you’re working solo or as part of a team, and your personal preference. If you’re the
only designer working on the project, unless the InDesign document is hundreds of pages in length
and contains many graphics I would keep it as one document. If you’re working as part of a team, the
benefit of the Book feature is that you can split the project into bite-sized chunks, and different
people can work on the different parts simultaneously.

Small Panel Rows: This option is accessed through the flyout menu and is useful if you have many styles (and
very good eyesight) and want to see more of them on the Styles panel without scrolling.

Select All Unused: Throughout the lifecycle of a project you may end up with several unwanted styles.
Leaving these around is apt to create confusion — either for you or for anyone else working on the document.
You can delete them on a case-by-case basis, but it’s quicker to choose Select All Unused from the menu in
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any of the Styles panels and then click the Delete icon at the bottom of the panel.

In web design, CSS (Cascading Style Sheets) is based on the model originally developed for desktop
publishing applications. If you’re coming to InDesign from a web design background, a key difference you’ll
find between InDesign styles and CSS is that InDesign doesn’t allow multiple paragraph styles to be applied
to a single paragraph. To achieve the same result, you can apply a character style in addition to the paragraph
style. Attributes specified in the character style overwrite those attributes in the paragraph style. As in CSS,
any item can be overwritten manually. For example, you can apply a paragraph style with a font size of 10
points but manually change this size at any time.

Character Styles
Character styles are for applying formats to specific ranges of text within paragraphs. Rather than apply a
character style to an entire paragraph (that’s what paragraph styles are for), apply it to selected words, phrases,
or titles. Character styles are for the exceptions to the formatting — for example, italics for emphasis. They
work best when they are simple. With character styles, it’s most often the font style (italic, bold, and so on)
that varies; it’s usually not necessary or desirable to specify the font, leading, size, and other formats, because
these attributes are inherited from the paragraph style. Not specifying a font for the character style means that
the same character style can be applied within multiple paragraph styles. It will change the selected range of
text relative to the paragraph style formats.

A Typical Style Sheet

Print and web designers often refer to lists of styles as a style sheet. What follows is a basic style sheet
that would be appropriate for a magazine, newsletter, or newspaper.
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Head1: Heads are typically in a heavier weight. Depending on the typeface, they may be negatively
tracked and tightly leaded, contributing to a dark type color. The purpose of the headline is to make
the reader want more. Typically, headlines do this by posing a question or telling part — the best part
— of the story.

Head2: A secondary-level head or subhead will often be in the same typeface as Head1 and be based
on that style with a reduction in size to indicate a lower level of hierarchy. Space is added before (and
possibly after) to separate the head from the surrounding text. This format helps the reader navigate
the body text and breaks the text block up into chunks to provide visual relief.

Head3: A third level of heading could be a run-in head, one in which the heading is part of the same
paragraph as the body text that follows. The run-in head would be called out as a character style,
which could be nested in the paragraph style definition.

Body: As the most widely used style in a document, this is the one to create first. You can use it to
quickly format a document by applying it to all the text in a story, then go back and apply the other
styles as appropriate. If you’re working in print, the Body style will likely (though not necessarily) be a
serif face in regular or book weight at a size of 8 to 11 points, with first-line indents to indicate the
beginning of a new paragraph. If you’re designing for screen, the Body style might be a sans serif of
anything between 14 and 20 points.

Body No Indent: This is based on Body, with first-line indent set to 0. It is used following a head,
when an indent is unnecessary to differentiate the text from the preceding paragraph.

Body First: This is a version of Body No Indent, adding a drop cap or initial cap treatment to
emphasize the start of stories or major sections within a story.

Body Numbered List: An ordered list based on Body. To make the list distinct, consider two
variants: a start list and an end list style with space before and space after, respectively.

Body Bulleted List: As above, but an unordered list.

Byline: The author’s credit is typically based on Body and may be differentiated by a bold weight and
by paragraph spacing above, below, or both.

Caption: Captions are typically set smaller than the body text and possibly in the same typeface
family as the head styles. With so many competing demands on people’s time, captions may be the
text that people read first. A caption should provide enough information for the browsing reader to
decide whether to dive into the main article. More than just stating the obvious, a caption should
clearly establish the relationship between the image and the text.

Intro: To create an entry point for the reader, magazine designers often set an article’s opening
paragraph (or its first lines) in larger type, possibly in bold type, possibly in a contrasting font. An
intro paragraph may be set over a wider measure than the body text, and may incorporate the byline.

Picture Credit: The picture credit can be as small as 5 or 6 points, and it’s often rotated 90 degrees to
sit in the gutter or at the bottom of a page outside the body text. Wherever you choose to put it, the
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picture credit should be aligned relative to something else. Sans serif type is often preferred for
credits, to aid legibility at smaller sizes.

Pull Quote: A pull quote is an excerpt “pulled” from the text, with the intention of adding visual
interest to a layout, especially when there are few photographs or illustrations to work with. A pull
quote is display text and as such should contrast with the body text. It should occur on or before the
page where the excerpted text appears and be positioned to catch the eye of potential readers who are
skimming pages. Edit long sentences into tight, provocative pull-quote versions. Combine pull quotes
with rules, reverse them out of a solid background, set them in a contrasting color, or add decorative
quotations marks.

Sidebar: A sidebar is a smaller article that, as the name suggests, typically runs by the side of the main
article, though it can mean any supplementary article. It is graphically separate from the main text but
contextually linked to it. Begin by basing Sidebar on the Body style and adjust the look, perhaps by
using a contrasting typeface, to set it apart.

Sidebar Head: This refers to the heading of a sidebar article, often based on Head1.

A common usage of character styles is to give emphasis. Here’s how to create an italic character style:

1. Open the Character Styles panel and select New Character Style from the menu.

2. Name the new style and click Basic Character Formats to open the Character Style Options dialog
box.

3. Type Italic for Font Style, but leave the other attribute fields blank.

NOTE: Unfortunately, not everyone received the memo about not applying character styles to
whole paragraphs. If you haven’t already, at some point you’ll inherit an InDesign document in
which the user has mistakenly used character styles instead of paragraph styles. When this time
comes, roll up your sleeves and use Find/Change to search for specific character formats and convert
them to paragraph styles. Once you’ve done that, you can remove the overrides from the paragraph
styles and delete the character styles. Here’s a link to a useful article by Anne-Marie Concepcion on
InDesignSecrets.com that addresses the issue: indesignsecrets.com/convert-character-styled-text-
to-paragraph-styled-text.php.

When you apply this character style to text within a paragraph styled in Garamond 10 pt, it becomes
Garamond Italic 10 pt; apply it to another paragraph style that is Caslon 11 pt, and it will be Caslon Italic 11
pt. If, however, you want your emphasis to always be Centaur Italic 10 pt, then make sure you include all
these attributes in the Character Style Options. Unlike paragraph styles, character styles replace local
formatting. Because you can’t apply two character styles to the same text, as soon as you apply a new character
style, the old one is removed.

There is sometimes a flaw in this otherwise logical method, and that is when using a typeface that deviates
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from standard naming conventions. For example, if you create an italic character style, as outlined above, and
apply it to body text in Tisa Pro, you will end up with the pink highlight that indicates a missing font. This is
because the italic style in Tisa Pro is called “Regular Italic” rather than Italic. In such a case, you would need
to specify the font style of the character style explicitly as Regular Italic. Hopefully one day, InDesign will
offer fallback choices when the font style you’re requesting is not found.

Creating Default Styles
Because you tend to use the same styles for most projects, it saves time to create a set of default styles that are
available in every new InDesign document. As well as the above list of paragraph styles, my default set also
includes character styles for bold and italic, as well as styles that take advantage of OpenType features like
superior and inferior, small caps, and fractions. I’ll also include a “No break” character style that can be applied
to a phrase or product name that I don’t want separated by a line break.

To use these styles as your default styles, create them with no InDesign document open. Any preferences you
set — as well as any styles you make (or load) — when there is no active document will become the defaults
for every document you create thereafter. With a set of default styles, you’re ready to hit the ground running
every time you start a project. Just because the names are the same doesn’t mean the styles have to look the
same. How they look is entirely up to you. What’s important is the hierarchy of the styles.

Strange Style Behavior

There’s a problem that arises occasionally when working with styles. If you apply a paragraph style
only to find that the text remains unchanged, it could be that you have mistakenly made one of your
character styles the default character style. Deselect your text. If a character style is already selected in
the Character Styles panel, that’s the source of your problem. To fix the specific instance of the
problem, with the text selected, choose None at the top of the Character Styles panel. To be sure it
doesn’t happen again, deselect everything and choose None a second time to make it the default.

Alternatively, create a CC Library to hold the styles. In the document containing the styles, select the styles
on the Paragraph Styles panel and click the cloud icon at bottom left to add them to your current library. To
add these styles to another document, Control/right-click their selected thumbnails in the CC Libraries panel
and choose Add to Paragraph Styles Panel.

Importing Styles from a Microsoft Word Document
When you place a Word or RTF document in InDesign, the Word styles are added to your Paragraph Styles
panel — and distinguished with a disk icon. This is nothing to worry about. As soon you make a change to
the style definition, the icon disappears. If a Word style has the same name as the InDesign style, InDesign’s
style takes precedence and the style is considered a “native style” from the outset.

You can choose to preserve or remove the styles and formatting in a Word or RTF document by selecting
Show Import Options in the Place dialog box. The most appropriate choice depends on the quality of the
formatting in the Word document. If the Word operator has done a good job, there’s no reason to duplicate
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their efforts. On the other hand, if there’s so much dodgy formatting that it’s causing you to have murderous
thoughts, opt to remove everything and start with a blank slate. A less drastic approach would be to remove
styles and formatting but preserve local overrides — that way, you can convert these to character styles.

Create a Style Template for Word

To speed up formatting, create a template for colleagues who are using Word to prepare text content.
Here’s how:

1. In InDesign, format a sample story. Placeholder text is good enough — just be sure to use an
example of all the paragraph and character styles you want to include in the template.

2. Export the story as a Rich Text Format (RTF) document.

3. Open the RTF file in Word, where you’ll notice that the Styles and Formatting panel contains
all your styles.

4. Delete the text so that you have a blank document.

5. In Word, save the file as a template (.dotx).

Send this file to your editors or writers with the instruction that they begin each new document by
opening the template. Word will automatically create a new, standard .doc/.docx document based on
the template rather than saving over the template itself.

As a best-case scenario, select Customize Style Import in Microsoft Word Import Options and choose Style
Mapping to map incoming Word styles to styles in the InDesign document. If the Word styling has been
implemented logically and consistently, it’s merely a question of going through the list of styles and deciding
what gets mapped to what. When you click OK to place the document, it immediately takes on the
appropriate formatting and you get to leave work early. Even better, if the names of the Word styles are
identical to the InDesign styles, then the InDesign styles take precedence and you don’t need to worry about
mapping styles.

Preserving Character Styling in an Imported Microsoft Word Document
Microsoft Word documents commonly contain much egregious formatting that you’ll want to zap
immediately before you start designing your layout. The problem is, along with all the rubbish, there may be
some useful information — typically text with emphasis — that you want to preserve. So before you apply
styles and clear overrides, you may need to convert local formatting to character styles.

TIP: Power Styles, part of the Blatner Tools suite, is a plug-in from DTP Tools (dtptools.com) that
helps you manage documents designed without a consistent use of styles. You can create styles with a
generic name based on the document’s local formatting. This makes identifying the document’s
structure easier. All you have to do is consolidate and rename the styles to fit your naming
convention.
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For example, let’s say you need to preserve the italicizing in an imported document:

1. Go to Find/Change and enter Italic in the Find Format field.

2. In the Change Format field, click the magnifying glass to the right and select your italic-only character
style (if you don’t have one, open the Character Style pop-up menu to create a new one).

3. Click Change All.

Now all the italic text is isolated as a character style. You can press Cmd+A (Ctrl+A) and Ctrl-click (right-
click) to select the Clear All Overrides option. This wipes out the unnecessary formatting but keeps the italics,
which are now in a character style and immune to Clear Overrides. What’s more, you can now control the
appearance of your emphasis text — say, for example, you wanted to use boldface instead of italic — by
editing its character style definition. It’s the difference between making one change and having to make many.

Using the Eyedropper to Apply Styles
The Eyedropper lets you sample the character and paragraph styles from one piece of text and apply them
elsewhere. Choose the Eyedropper tool and click the paragraph containing the style you want to sample. With
the Eyedropper now “loaded,” click the paragraph you want to format. If you’re using the Eyedropper to apply
character styles, drag to select a range of text. The Eyedropper remains “loaded” so you can apply the style
multiple times.

You can set the Eyedropper behavior by double-clicking the tool and specifying which settings to include. If
you’re concentrating on text formatting, turn off all options apart from Character Settings and Paragraph
Settings.
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Object Styles
Object styles take the concept of paragraph and character styles and apply it to frames as well as to lines and
pen paths. Object styles can incorporate such attributes as fill color, stroke weight, stroke color, the number of
columns in the frame, drop shadow, and the size and position of a frame. You can also specify the Frame
Fitting Options, which make object styles massively time saving when incorporating images into your layout.

Formatting Callout Boxes
You can specify, as part of an object style, a paragraph style to be applied to the text content, allowing you to
apply frame and text attributes with a single click. This makes object styles useful for formatting single-
paragraph stories, like captions or photo credits.

Linking to Text Files

InDesign has a preference that allows you to link to a placed text file, so if the original text file is
modified, the changes will update in place. Choose Preferences > File Handling > Create Links
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When Placing Text and Spreadsheet Files. As mentioned in Chapter 11, while this may sound like a
good idea, it is rarely practical, because each time you update the link, you’ll lose all of the edits
applied in InDesign.

But building on this idea, the Wordsflow plug-in from EmSoftware allows you to “roundtrip” your
content between Word and InDesign. WordsFlow lets you place linked Word (or RTF or Excel)
documents into InDesign; authors and editors can continue to work on the original files, and you can
merge their changes into the InDesign layout so that your work in InDesign is not undone each time
the link is updated. A companion plug-in, DocsFlow, offers the same functionality when working
with Google Docs.

You can find out more at emsoftware.com/products/wordsflow.

Taking automation to the next level, if you include the Apply Next Style option, the application of an object
style can trigger a style sequence. This can be useful in a number of instances.

For example, let’s say you’re designing a journal where all the articles follow the same format: head, strapline,
byline, body first, body. Start by setting up the Next Style specifications for each of these paragraph styles:

1. Open the Object Styles panel and choose New Object Style from the menu.

2. Name the new style and click Paragraph Styles in the Basic Attributes list of the Object Styles panel.

3. Choose the head style from the menu and select the Apply Next Style option.

Now when you apply this object style to a frame, you format multiple paragraphs with a single click.

Using Object Styles with Anchored Objects
If you’ve ever positioned a graphic, a caption, or a pull quote next to its associated story only to have to
reposition it when the story is edited, you’ll appreciate anchored objects and inline graphics.

Inline graphics are a subset of anchored graphics and have been around for years. If you want a graphic
inserted into the text flow, cut it to the Clipboard, insert your cursor into the frame where you want the
graphic to go (usually on a separate line), then paste it. Alternatively, hold Shift and drag from the blue square
in the top corner to where you want the graphic positioned. Thereafter the graphic moves with the text,
remaining relative to its position in the text flow. This has always been a necessary approach when it’s
important that the graphic keep pace with the text flow. For example, if the text says, “see image below,” you’d
better be certain that the image stays below and doesn’t get left behind when the text is edited. Because
ebooks require that your text and graphics be in a continuous flow, anchored objects are essential when
preparing documents for EPUB export.

Custom anchored objects take this approach a step further by allowing you to position a graphic relative to a
portion of text, as well as potentially outside the text frame.

In facing-pages documents you can also position anchored objects relative to the spine so that they are outside
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the text frame they are anchored to — in the left margin for left pages, the right margin for right pages.

Working with Captions

InDesign allows you to generate live or static captions derived from an image’s metadata (as specified
in Object > Captions > Caption Setup). You can also choose which paragraph style gets applied to the
caption. Unfortunately, you cannot specify an object style to be applied to the caption text frame. Live
captions will update if the image metadata is changed; static captions, once generated, are not affected
by any change to the metadata.

The captions feature is one of several examples of InDesign features that when first introduced looked
promising and had you eagerly anticipating the next iteration. Unfortunately, we’re still waiting and
nothing has changed. Captions can be a time-saving feature if you’re working with many images that
need captioning, but it leaves you expecting more options in terms of positioning and also wishing
that live captions allowed line breaks, which is currently not the case.

Note that if you try to position a caption next to an image, you may find that the caption becomes
overset. This could be due to a text wrap being applied to the image. To fix this, select the text frame,
choose Object > Text Frame Options (Cmd+B/Ctrl+B), and select the Ignore Text Wrap check box.

An anchored object can be a text frame, a picture frame, or any combination of grouped objects.

To convert a frame into an anchored object, position it where you want it to go, then drag the blue square in
the top corner of the frame into the text to anchor it relative to that position. So that you can more easily
manage your anchored graphics thereafter, drag the cursor to the start or end of a paragraph. You can also cut
the object, insert your cursor into the main story, and paste the frame as an inline graphic.

Using either approach, if you need to adjust the object’s placement, Ctrl-click (right-click) the object and
choose Object > Anchored Object > Options. Alternatively, Option-click (Alt-click) the anchor widget (blue
square) in the top corner of the frame.

Positioning an anchored object exactly where you want it can be a bit fussy, which is why, when you get it
right, you’ll want to capture the settings as an object style. Select the object, open the Object Styles panel, and
choose New Object Style from the panel menu. Name the style and save it. Thereafter, you can apply the
object style to other frames you want to anchor. The frames won’t snap into place immediately — but as soon
as you drag them or cut and paste them into the text frame, they will be positioned correctly relative to the
text frame.

Just as with paragraph and character styles, you can base one object style on another, creating a parent–child
relationship so that when you change the base, or parent, style, the shared attributes of the child style also
change.

Each document begins its life with the [Basic Text Frame] and [Basic Graphics Frame] object styles. By
default, these styles are applied to any text or graphics frames you create. You can edit these basic styles, but
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you can’t delete them. To change the default text or graphics frame, choose the style from the Default Text
Frame Style or Default Graphics Frame Style flyouts on the Object Styles menu, or just click the desired style
with nothing selected in the layout.

Just as with text styles, you can import object styles from another document. From the Object Styles panel
menu choose Load Object styles, navigate to the document containing the styles you want to import, and click
Open.

Pertinent to EPUBs, you can map object styles to specific tags and classes in your CSS, the same way you can
with paragraph styles and character styles. Ctrl-click (right-click) the object style and choose Edit from the
context menu. At the bottom of the list of Basic Attributes are the Export Tagging options, where you choose
what tag and what class the object style maps to.

Table and Cell Styles
Table and cell styles continue the automated, do-it-once-reuse-it-again-and-again approach. While a boon to
any sort of table-heavy document, they are not a total solution. Table styles include such attributes as table
borders and row and column strokes that are applied to the whole table. Cell styles include formatting such as
cell insets, paragraph styles, and strokes and fills applied to specific cells.

Table and cell styles have their limitations, and you might want to calibrate your expectations accordingly.
Neither allows you to set the column width, the row height, or the relative width of the columns. Table styles
don’t know what cells you want to merge (how could they?), nor do they specify which rows should be
converted to header rows or footer rows. Therefore, once a table style is applied, you’ll still need to adjust
column widths, merge appropriate cells, and convert, if required, your first and last rows to headers and
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footers, respectively. That said, you might be tempted to avoid them. And this is possible if you have only the

occasional table to format, but if your documents contain lots of tables, you’ll be tearing your hair out without
table and cell styles.

A table style is built like a Russian nesting doll. Inside a table style you can include cell styles, and inside cell
styles you can include paragraph styles. For example, when you create a table style, you specify which cell
styles are applied to which parts of the table: header and footer rows, left and right columns, and body rows. If
you don’t specify the cell style for a particular element, InDesign assigns the default Same as Body Rows style.

Cell styles don’t necessarily include all the formatting attributes of a selected cell. When you create a cell style,
you can determine which attributes are included. That way, applying the cell style changes the desired
attributes only, such as the fill color, and ignores all other cell attributes.

As with other styles in InDesign, you can load table styles and cell styles from other documents, either taking
all table and cell styles or cherry-picking just those that are relevant.

If you plan to convert tables to EPUB, make sure you’re using table styles and cell styles rather than local
formatting, both to retain as much of the formatting as possible and to make editing of the CSS easier
thereafter.

If your table is complex, consider simplifying — or linearizing — the table. This means breaking it down into
bite-sized chunks that are more EPUB-friendly. If this isn’t possible, consider converting the table to a
graphic using Object Export Options. Choose Keep the Size Relative to Page Width so that the table will fit
regardless of the size of screen.

Features Related to Styles
Beyond the top-level items, there are a number of features that work in conjunction with — and extend the
capabilities of — styles. Once your basic styles are set up, these additional options can really turbo-charge and
personalize your use of styles.

Nested Styles
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Nested styles allow you to embed a character style — or multiple character styles — in a paragraph style
definition. These, in turn, can be incorporated into object styles. Potentially you can apply multiple formats
with a single click or keyboard shortcut, eliminating hours of repetitive drudgery and freeing you up to be
more creative.

TIP: When you create nested styles, you may not be the only person who uses them. To avoid other
members of your team being confused by nested styles, adopt a naming convention that is
transparent. For example, append “_ns” to the style names.

Maybe you’ve seen nested styles demonstrated by an InDesign pro — one click and the document’s formatted,
the laundry folded, and everyone goes to the beach. In real life, it doesn’t work like that. Although it’s possible
to construct amazingly powerful nested styles, what you’re not seeing is that it probably took longer to create
the nested style than it would have to format the document “normally.”

Complicated nested styles are fun party tricks but can confuse people and go awry in the hands of anyone but
their Dr. Fran–ken–stein. Keep it simple — especially if you’re working as part of a team. When you create
styles, you may not be the only person using them. Or you may find yourself returning to documents that you
created weeks, months, or even years before.

The best nested styles are those that are easy to set up and that you use frequently. Look at just about any
newsstand magazine and you’ll find a host of examples of simple nested styles in action: styles that took just
seconds to create and over the course of a publication’s lifetime save hours of tedium (and ensure consistency).
To create a nested style, first create the character styles you will add to a paragraph style definition, and then
follow these steps:

1. Ctrl-click (right-click) the paragraph style you want to edit.

2. Select Drop Caps and Nested Styles from the list on the left side of the Paragraph Style Options
dialog.

3. Click New Nested Style and choose from your list of available character styles. (If these aren’t already
set up, you can choose New Character Style to create them here.)

4. Character styles applied as part of a nested style remain “on” for a specified number of words,
characters, or sentences, or until a “delimiter” is entered in the last field in the row. As well as choosing
from the drop-down list, you can also type a specific character, such as a colon (:), in this field.
Without a delimiter, the character style never gets turned off and will affect the whole paragraph.

TIP: Use a custom keyboard shortcut to insert the End Nested Style Here character. Create your
own custom keyboard shortcut to quickly place this character in your text. I use
Ctrl+Cmd+Option+X (on a Mac).

TIP: It’s possible to accommodate just about any kind of variation by entering multiple characters in
the delimiter field of a nested style. If you enter all the possible characters that could end a sentence
— .?! — InDesign uses the first one it encounters to turn off the nested style.
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Choosing Through includes the character that ends the nested style, while choosing Up To formats only
those characters that precede the designated character.

If you have more than one nested style, you can use the Up button or Down button to determine the order in
which the formatting is applied. The formatting of the second style begins after the formatting of the first.

Here are some examples of nested styles that offer a high return on the investment it takes to set them up.

Chapter or Section Openings. For chapter openings with a drop cap, it’s common to style the drop cap
in a contrasting font, perhaps also in a different color, and to transition to the upper- and lowercase of
the body text with a specified number of words in small caps. Fiddly stuff to be sure — but it’s all
possible with a single click once you’ve set up a nested style. Note that if you want to apply small caps to
a whole line rather than to a specified number of words, you can use a nested line style. See Chapter 13,
“Drop Caps.”

Run-in Heads. Run-in heads are usually third-level subheads that have the heading on the same line as
the body text that follows, thus making them space efficient. The heading is distinguished from the
body text with a contrasting font. The key with run-in heads — as for all nested styles — is an
identifiably consistent element. For example, this could be a colon or an en space that separates the
subhead from the body text.

Contents Pages. Contents pages often use a page number as a run-in head. Additional run-in elements
can include identifying tags like “Cover Story” or “Feature Article,” which can be added as GREP styles
— see below.

Repeating Styles. To repeat a sequence of nested styles — effectively creating a loop of styles — choose
[Repeat] from the Nested Style drop-down menu and specify the number of styles to repeat. This can
be used to give alternating contrast to a list of names in a single paragraph.

TIP: The Treasures of GREP Facebook group is the place for helpful advice and useful tips on using
GREP. If you have a Lynda.com/LinkedIn Learning subscription, I also recommend Michael
Murphy’s “InDesign CS4: Learning GREP.”

GREP Styles
A GREP style applies a character style to consistent patterns within the text, regardless of where they occur in
the paragraph. To create a GREP style, specify a GREP expression that matches the text you’re looking for
— and choose a character style to apply to that text. An obvious application of GREP styles is for a product
name or publication name that you want formatted with specific character styling — bold, italic, a certain
color, whatever. Any time you type that combination of characters, it automatically takes on the desired
appearance. To apply a GREP style to multiple text patterns, separate each with a vertical pipe ( | ). For
example, to apply a character style to the words “red” and “blue,” type red|blue in the To Text field.

Nested Styles at the End of a Paragraph
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A nested style typically starts at the beginning of a paragraph and continues until stopped by a
delimiter. Using the None character style, it’s possible to position a nested style at the end of a
paragraph.

Such a nested style can be used for the last paragraphs of articles that conclude with an end ornament
or dingbat. To do this, apply None to the beginning of the paragraph. This means that the normal
formatting for the paragraph is used until the delimiter — in this case, a right-indent tab — is
encountered. A character style is applied to the text that follows the right-indent tab. This particular
nested style can be incorporated into the Body style, where it will lie dormant until invoked by the
right-indent tab. Because a right-indent tab does not appear in the drop-down list of delimiters,
you’ll need to type in its metacharacter: ^y.

At the end of the story, press Shift+Tab to insert the right-indent tab, then type the end character
(for example, n is a solid square bullet in Wingdings or Zapf Dingbats). This will be automatically
formatted by the character style.
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Sequential Styles
Because it’s common for one particular style to always follow another style, you can use Next Style to define a
sequence of styles that can be applied with one click. In documents where the text styling follows a consistent
pattern — a large proportion of documents — this can save hours of donkey work as well as ensure
consistency. A simple example of a style sequence might be a subhead style that is always followed by a Body
No Indent style. For more of a wow factor, sequential styles can be applied to listings text — like a directory
listing — to make fast work of what might otherwise be an arduous task.

322



Five Useful GREP Styles

Beyond the obvious, but very useful, application of GREP styles to apply specific formatting to a text
string, GREP styles can be used to maintain stylistic consistency in small details and to preempt
spacing problems. Here are some of my favorites.

To fix runts (short last lines). I mentioned this in Chapter 6, but it’s so useful it’s worth repeating
here:

To avoid single words — such as I and A, and salutations like Mr., Mrs., or Dr. — from occurring at
the end of a line:

To fix a specific kerning pair. If you find that there are certain kerning pairs that need attention, you
can create a GREP style to adjust the tracking for those pairs. For example, in Gill Sans, to my eye
there should be more space to the left of a capital A and less space on either side of the number 1. (If
you find yourself doing this to a significant number of letter pairs, you might question whether you
made a good font choice.)

To change the width of an em dash. In some fonts, the em dash is just too wide. Make a character
style with a 75% (or whatever) horizontal scale. Then apply it to the em dash character.

To make OpenType fractions. Make a fractions character style (select Fractions in the OpenType
Features of the Character Style Options). Apply this character style to the GREP expression \d+/\d+
(one or more digits, followed by a slash, followed by one or more digits).
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Imagine, for example, an event listing where the date style is followed by the title style, which in turn is
followed by the description style. Define date’s Next Style as title, and define title’s Next Style as description.
Select the full sequence of text. In the Paragraph Styles panel, Ctrl-click (right-click) date (the first style in the
sequence), and then choose Apply “Style Name” then Next Style from the pop-up menu to style three
paragraphs in one. Note that you have to choose at least two paragraphs to bring up the Apply “Style Name”
then Next Style option. If the text sequence repeats, you can define the next style for description (the last style
in the sequence) as date (that is, the first style in the sequence). This will make a repeating loop of styles.

Using this approach, you can theoretically format pages of text with a single click. I say “theoretically” because
for this looping approach to work, your text has to adhere rigidly to the style sequence — one paragraph out
of place, or one piece of information that runs to more than a single paragraph, and the whole thing comes
tumbling down like a house of cards. If there are some blocks of information that run to multiple paragraphs,
you can replace the paragraph marks with line breaks (Shift+Return) so that the lines break visually but are
technically part of the same paragraph. However, if you have to spend a lot of time massaging your text in this
way before applying your spiffy automation techniques, you might question how automated those techniques
really are.

Next Style also has another function, and that’s to determine the style you get when you press Return (Enter)
for a new line. This is useful if you’re writing your text in InDesign, but otherwise underwhelming. When
typing, Next Style has no effect on text that is already on the page.
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Rules, Borders, and Shading
There was a time, not so long ago, when to apply a color highlight to a line or word, the only options available
were paragraph rules and getting creative with the underline options. If you wanted shading behind a whole
paragraph, you were in the land of workaround, which is often a precarious place to be. Thankfully, recent
versions of InDesign have added paragraph shading and paragraph borders as bona fide features. But before
we get to those, let’s look at some old-school techniques for working with paragraph rules, which still have
their place.

If you’ve ever drawn a rule above a line of text only to have the text reflow and leave the rule in the dust, you’ll
find paragraph rules (Cmd+Option+J/Ctrl+Alt+J) useful. The simple premise of a paragraph rule, be it above
or below your text, is that it moves with the text. The rule(s) can be incorporated into a paragraph style. It is
associated with the text, faithfully following it wherever it goes.

Paragraph rules are useful for differentiating blocks of information. As well as changing the weight, style, and
color of the rule, you can also set its width: to either the width of the column or the width of the line of type
itself. These two options can be customized with the addition to the rule of a left indent, a right indent, or
both.

Creating Reverse-Out Heads
You can use paragraph rules to make type reverse out of a solid bar. This takes a few moments to set up, but
once you’ve done so, you can create a paragraph style based on the text.

Whether it’s a rule above or a rule below, the rule starts on the baseline of the type. Specifically, the bottom of
a rule above and the top of a rule below align on the baseline. For a rule above, a positive offset moves the rule
up; for a rule below, a positive offset moves it down. But don’t worry about trying to memorize that: just make
sure Preview is selected, put your cursor in the Offset field, and press the Up Arrow or Down Arrow key to
dial in the amount of offset you want. Specify a color for the rule other than (Text Color). For best results, set
the weight of the rule to the size of your type, or possibly a point or two less, depending on how tightly you
want the rule fitted around the text. I prefer to use all caps so that the spacing above and below the type is
optically even. I also favor a bold or semibold sans serif font because fine serifs don’t fare well reversing out of
a solid color at small type sizes.

Here are some pointers for working with paragraph rules:

Paragraph rules are not an either/or proposition; you can have both a rule above and a rule below
attached to a paragraph.

The Keep in Frame option causes the type to move down rather than stick up above the top of the
frame. This is useful when using a reverse out head at the top of an info box.

While paragraph rules are great for single-line paragraphs, they don’t work for multi-line paragraphs.
That’s where paragraph borders and paragraph shading come in.

Paragraph Borders
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Paragraph borders enable you to create a border around one or more paragraphs, which will move with the
text and grow and shrink as necessary as the text is edited. You can customize the corners and offset the
borders. You can even make the borders behave as intercolumn rules. Hold Option/Alt as you click the
Border icon on the Control panel (Paragraph Formatting Controls) to open the Paragraph Borders and
Shading dialog.

Things get messy when the paragraph splits across multiple columns. Selecting Display Border if Paragraph
Splits Across Frames/Columns will give you two intact borders, but that’s a dubious improvement.

To apply a border around multiple paragraphs, select the Merge Consecutive Borders and Shading with same
Settings checkbox at the bottom of the Borders dialog box.
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Paragraph Shading
The Paragraph Shading feature lets you create a shade (or color) behind a paragraph. The shade resizes and
moves along with the text. Hold Option/Alt as you click the Shading icon on the Control panel (Paragraph
Formatting Controls) to open the Paragraph Borders and Shading dialog.

Footnotes and Endnotes
Although footnotes and endnotes are not specifically related to styles, you’d find it difficult to use these long-
document features effectively without styles. Choose Type > Document Footnote Options or Type >
Document Endnote Options to determine what character style is automatically applied to a footnote or
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endnote reference and what paragraph style is applied to the footnote or endnote itself.

Creating a Table of Contents
If you’ve used paragraph styles in your document, you can create a dynamic table of contents — that is, one in
which the entries and page numbers are auto-generated and which will (with prompting) update as your
pagination changes. InDesign finds and gathers any content formatted with the paragraph styles you opt to
include in your table of contents (TOC) wherever they are used in the document and applies your specified
styles to the collected content.

Here’s how to create a TOC:

1. Make sure you have a place for the TOC. If necessary, create a new page.

2. Choose Layout > Table of Contents. Click More Options if necessary to see the full dialog box.

3. Give your TOC a title (“Contents” by default) and choose the paragraph style that is applied to this
title. I prefer to use TOC Title, an auto-generated style that, first time around, requires redefining
according to your needs.

4. Choose which styles in your document (listed on the right) become styles in your TOC. Depending on
the document’s complexity, its TOC may have one level or multiple levels, but if you find yourself with
more than three, you might question why.

5. Choose the paragraph style you want applied to your TOC entries. For the first level, I choose TOC
Body Text. This is another auto-generated style: it won’t look right initially, but it’s a simple matter to
redefine it.
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6. Next, in the Style section, choose how to format the TOC. You can have the page number before or,
more typically, after the entry. You can even choose not to have a page number — potentially useful in
an EPUB. You choose what character you want between the entry and the page number — for
example, an en space, a tab, a right-indent tab — and which character style, if any, to apply to this
space and to the page number itself. Leave PDF Bookmarks selected to create a dynamic TOC: if you
export your document to an interactive PDF, the TOC entries become PDF bookmarks that viewers
can click to access those pages. Even if you don’t plan on making an interactive document, there’s no
harm in having this selected.

NOTE: A document can contain multiple TOC styles. This allows you to experiment with
alternative TOCs as well as generate additional TOCs — perhaps for a list of figures or
illustrations.

7. Before leaving the dialog, click Save Style to capture your settings as a TOC style. Although this final
step isn’t required for a print TOC, if you’re planning on exporting to EPUB it’s essential.

8. When you click OK, you get a text cursor loaded with your TOC story. You can place this on the
page, or portion of the page, that you set aside in step 1.

Note that the updating of the TOC isn’t automatic. If anything about your pagination changes, choose
Layout > Update Table of Contents. The good news is that this happens in a flash and you won’t need to
repeat all these steps. However, be aware that you will lose any manual formatting changes or edits you apply
to the TOC text.

Styles and EPUB Export
If you’re creating EPUBs, there are some additional considerations when working with styles.

EPUBs and TOCs
When exporting to EPUB (both fixed-layout and reflowable), your TOC style is used to generate a table of
contents that readers can access through the ereader software (sometimes called a navigational TOC) — even
though you may not have a TOC placed anywhere in the document. To use a TOC style to generate a
navigational table of contents in an EPUB, choose File > Export or press Cmd+E (Ctrl+E) and select EPUB
as the format. In the General options, choose TOC Style from the Navigation drop-down, then choose your
saved TOC style from the drop-down to its right.
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Splitting Documents
The exporting tagging options that are part of paragraph style options allow you to split a reflowable EPUB
into distinct chap–ters using specified paragraph styles as break points. These chapters become independent
XHTML files in the resulting EPUB. To split a reflowable EPUB based upon your export tagging settings,
choose File > Export or press Cmd+E (Ctrl+E) and select EPUB as the format. Choose Based on Paragraph
Style Exporting Tagging from the Split Document drop-down menu in the General options.

Export Tagging
A second purpose of export tagging is to map your InDesign styles to XHTML code. These can be standard
tags (h1, h2, p, and so on), or custom tags that exist in a predefined CSS. You can also add a CSS class —
which is used for slight variations in styling and is broadly equivalent to an InDesign character style. If you
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don’t enter a class name, InDesign automatically generates one based on the style name. The process for
mapping styles to PDF tags is the same, except that PDF tags are uppercase.

Rather than set up export tagging on a style-by-style basis, choose Edit All Export Tags from the Paragraph
Styles panel menu and bulk-map your InDesign styles to appropriate EPUB and HTML tags, as well as the
corresponding PDF tags. You can also choose what paragraphs should split the EPUB here.

The most efficient workflow for creating EPUBs — and one that requires an understanding of XHTML and
CSS — involves mapping your InDesign styles to a predefined CSS file.

When you export to EPUB, InDesign typically creates a lot of redundant markup. Each InDesign style
becomes a CSS class, and every possible property of the InDesign style is included in that CSS class. A class
in web design is like a character style. Adding a class to all your paragraphs is equivalent to applying a
paragraph style and then applying a character style with the same settings for font, font size, color, and so on,
on top of that paragraph style. It will work, but it’s unnecessary and unwieldy.

If you have a predefined CSS file, you can map your InDesign styles to the styles in that file. In Export
Tagging, you can type the name of your defined tag in the Tag field. If you’ve defined a class for this style, you
can enter that too. Add your external style sheet in the Advanced EPUB export options. In the resulting
XHTML, the paragraphs will take on the attributes defined in the external CSS file, and the exported EPUB
will be devoid of any extraneous markup.

Setting up the external style sheet in the first place is an investment of time, but one that will quickly repay
your efforts. With this approach, the same style sheet can control the appearance of multiple EPUBs, and the
HTML code within each file is leaner and far less confusing.

▄

Even if they appear intimidating at first, persevere with styles. They’re the kind of thing that computers excel
at: keeping track of multiple formatting options, where they are applied, and when they are updated. With all
the time you save by using styles, you can add a level of nuance and artistry — the kind of thing that humans
do best.
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Chapter 16

Type and Image

Type doesn’t live in a vacuum. In InDesign, we need to combine text with images in our layouts. This
chapter looks at some common ways to marry words and pictures, beginning with text wraps and
going on to explore simple text effects that blur the distinction between type and image such that the
text itself becomes the image.

Text Wraps
Text wraps offer a design opportunity to add visual interest to a page. With text wraps, a boring picture can
become an intriguing shape, or a boxy layout can be made to feel more organic. Like most tricks, text wraps
should be used sparingly and with care. Done well, a text wrap improves both text and image; done poorly, it
makes your layout look gimmicky and amateurish. Once you start looking out for bad text wraps, you realize
they’re everywhere. What often gets overlooked is that placing a graphic inside a column (or columns) of type
means narrowing that column, with all the potential problems that entails.

Applying Text Wraps
For a good text wrap all you need is common sense — and a little tweaking. Here are a few simple
precautions.

Avoid text wraps in a single column where the text wraps around all four corners (or the entire shape) of
the bounding box or graphic. Just because InDesign will let you do it doesn’t make it a good idea. Such
text wraps disrupt the horizontal flow of the text, and readers may be confused about whether to jump
the graphic or continue reading down the column.

TIP: When adding a text wrap to a picture, be sure to add it to the picture frame (selected with
the Selection tool) and not to the picture itself (selected by clicking the Content Grabber or
with the Direct Selection tool). If you do the latter, the text will wrap according to the picture’s
full dimensions rather than its cropped dimensions. In addition, the scaling applied to the
image is also applied to the text wrap. For example, if the picture is scaled 50% and the text
wrap offset value is 10 points, it will effectively be reduced to 5 points on the page.

Text wraps work better with justified type — that is, when wrapping the right edge of the text around
the object. Because left-aligned type has an uneven or ragged edge, it doesn’t emphasize the shape of the
graphic the way justified type does. Of course, working with justified type, you’ll need to make sure the
columns are wide enough.

Related to the point above, text wraps work better when on the right, rather than the left, side of the
text. In left-to-right reading text, the reader’s eye returns to the left edge of the text column after
scanning each line. If the reader has to search for that location, it decreases the readability of the text.
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It’s essential to visually balance the space around the graphic. This is about more than just selecting
equal values for all the text offsets. The vertical space around the wrapped object depends on where it
sits relative to the baselines of the type around it. It’s common to have a smaller offset below the object,
because the wrap below is measured to the ascenders and not to the x-height of the type.

Check the lines affected by the wrap. Composition problems can often be fixed by minor adjustments to
the position or scale of the text wrap object. Or you can customize the shape of the text wrap offset with
the Direct Selection tool and the Pen tools. As a last resort, use tracking, hyphenation, or (if
appropriate) rewriting to cause the lines to break differently. If none of these options work, don’t use a
text wrap in this instance.

Evaluate text wraps by eye rather than relying on the numbers in the Text Wrap panel. For example, a
text wrap around a curved shape may appear to have a bigger offset at the top and bottom of the shape
than at its center, even though the wrap offset is set to a uniform distance from the graphic.

If you have more than one text wrap in your document, keep the offset amount consistent.

Don’t attempt the impossible. If the shape of your graphic is too irregular, the result will be too many
different line lengths, too much hyphenation, and great gaping holes in the text. If you’re working with
multiple columns, consider placing the image on the edge of one of those columns rather than between
columns.

Wrapping Type Around Irregularly Shaped Graphics
Creating layouts that look “boxy” is something of an occupational hazard in InDesign. When all your content
lives in a box, the danger is that the boxes themselves are too prominent. An effective way to prevent this is to
wrap text around object shapes. This requires basic image editing skills to prepare the images in Photoshop.
To isolate images from their backgrounds, you can either create a layer mask and save the file as a PSD or
create a pen path and save the file as a JPEG (a PSD or TIFF will also work, but a JPEG yields a smaller file
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size). Once your image has been prepared, place it in your InDesign document. From Contour Options,

choose Alpha Channel or Photoshop Path. You can adjust the Top Offset field (you’ll have only the one) to
determine how close the text comes to the edge of the image.

Don’t have Photoshop? You may be able to create a clipping path for the graphic within InDesign. This
works best if the image has a flat background and strong contrast along the subject edge; it’s unlikely to work
if your subject is indistinct from the background or the background itself is busy. With the picture frame
selected, choose Object > Clipping Path > Options (Cmd+Shift+Option+K/Ctrl+Alt+Shift+K), from the
Type menu choose Detect Edges, and make sure Preview is turned on. If necessary, move the Threshold and
Tolerance sliders to control how the clipping path recognizes the image edge. Once you have a decent result,
click OK to return to the layout. To position the image behind the text, choose Object > Arrange > Send To
Back (Cmd+Shift+[/Ctrl+Shift+[).

TIP: If you have a text-wrap object on a master page that you don’t want to affect items on
document pages, select the object and choose Apply to Master Page Only from the Text Wrap panel
menu.
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To use the clipping path as a text wrap shape, select the object and choose Wrap Around Object Shape from
the Text Wrap panel. Add an appropriate amount of offset (take your body text leading value as a starting
point), and depending on the object shape, choose an appropriate Wrap To option. The Contour Options
should change to Same as Clipping; if they don’t, choose this from the drop-down menu.
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TIP: Often the most effective way to adjust a text wrap is to give the text wrap object a small nudge
up or down, left or right. If you reduce the cursor key increment (Preferences > Units &
Increments), you’ll have more flexibility when doing this.

Using the Direct Selection tool and the Pen tool, you can finesse the shape of the text wrap offset. Select the
image with the Direct Selection tool to show the text wrap offset (this will be in the layer color). Now drag
any of the anchor points to adjust its shape. To add or delete anchor points, switch to the Pen tool. Click the
path wherever there is no anchor point to add one, or click an existing anchor point to delete it. You can also
use the Convert Direct Point tool to convert smooth points to corner points and vice versa.

As well as finessing the text wrap offset, you can also adjust the shape of the clipping path itself, using the
same techniques.

A clipping path can be converted to a frame (Object > Clipping Path > Convert Clipping Path to Frame),
which can then be filled with any text or picture content, or filled with a solid color and moved to a separate
layer as a way of identifying a spot varnish for the object.

Rather than rely on Detect Edges (which works only when the edges of an image are clearly detectable), you
can use the Pen tool to draw a vector shape around the image. Apply the text wrap to this shape rather than to
the image, making sure that the shape has no fill and no stroke. Group it with the image (Cmd+G/Ctrl+G) so
that the two elements can be moved or transformed as one. Alternatively, once you’ve drawn your custom
vector shape, select the image with the Content Grabber and cut it from its original (rectangular) frame, then
select the custom shape and choose Paste Into (Cmd+Option+V/Ctrl+Alt+V).

Wrap Options
By default, the wrap options are set to both the right and left sides. It’s often more visually effective and less
prone to spacing problems to wrap the text around one or the other. The Largest Area option compares the
right and left sides of the object and wraps the text around the largest.

TIP: If you’ve adjusted your text wrap and you don’t like the result, you can start again by choosing
Wrap Around Bounding Box, then choosing Wrap Around Object Shape once more.
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Text Wrap Preferences
The following composition preferences (choose Preferences > Composition) determine how a text wrap
behaves. In all cases, they are document-wide preferences.

Justify Text Next to an Object justifies text next to text wraps in a single column. This preference will
not justify ragged type when the wrap object straddles more than one column. This preference is of little
practical value because wrapping text around all sides of an object in a single column is just a bad idea.

Wrap Nudger Script

A little nudge can make a big difference when it comes to text wraps. A useful free script from
Dave Saunders saves you having to edit the text wrap offset with the Pen tools, letting you
nudge the text wrap offset in any direction. You can download the script from the InDesign
Secrets website: https://indesignsecrets.com/tip-of-the-week-taking-control-text-wrap.php.

Skip By Leading: When working with multiple columns of text, if a text wrap affects some but not all of
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those columns, this preference ensures that the text below the text wrap is knocked down to the next
available leading increment, making sure that your baselines align across columns. Rather than turning
this preference on, you’re better off using a baseline grid to get the same effect (see Chapter 17, “Page
Geometry, Grids, and White Space”).

Text Wrap Only Affects Text Beneath makes InDesign behave like QuarkXPress, where text wraps —
or runarounds, as they are called in QuarkXPress — affect only the text beneath them in the stacking
order. Documents that have been converted from Quark using Markzware’s Q2ID will have this
preference turned on. For all other documents, leave this preference off. Putting pictures above text in
the stacking order can result in printing problems when transparent objects overlap type. Text that
wraps around a drop shadow or any other transparency effect can end up being rasterized if that text is
below the image in the stacking order. Solution: make sure that text is on a layer above the pictures,
especially those that are transparent. If you want a text frame to be unaffected by a text wrap, choose
Object > Text Frame Options, and select Ignore Text Wrap (see the section “Ignoring a Text Wrap”).
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Another option relating to text wraps is Suppress Text Wrap When Layer Is Hidden, found in Layer
Options. When you hide a layer containing a text-wrap object, the text on other layers continues to wrap
around the object. This is so your text won’t recompose if you turn off the layer. You can also use it to create
interesting text-wrap shapes without seeing the text-wrap object. Turning on this option causes the text to
reflow when the layer containing the wrapping object is hidden. This may be useful if you wish to print a
version of the document without the images.

Inverted Text Wraps
To make the text wrap within the graphic shape, rather than around it, select the Invert option on the Text
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Wrap panel. This works best with simple shapes and when the type is a solid block — without paragraph
breaks and indents — tightly leaded and justified so that it better defines the object shape. Although this is
interesting, it’s easier to just put the text inside a frame. For example, if you want text to flow inside a shape,
even if that shape is part of an image, you’re better off adding a clipping mask to the image, converting the
clipping mask to a frame, and then inserting text into that frame.

Ignoring a Text Wrap
There are certain elements that you don’t want affected by a text wrap. A common scenario is a caption
directly below a photo around which the body text wraps. Unless the caption ignores the text wrap, it may not
be possible to position it close enough to the picture. The same applies whenever you have text overlapping a
wrap object. In such cases, the text gets pushed out of the frame by the text wrap, even though the text may be
above the image in the stacking order.

The solution is to select Ignore Text Wrap (in Text Frame Options) (Cmd+B/Ctrl+B). You can also make an
object style that incorporates the Ignore Text Wrap attribute and applies the caption’s paragraph style to the
content of the frame.

Text Wraps in Anchored Objects
Anchored objects are useful for creating side-by-side paragraphs or when you need a caption or pull quote to
move with the text flow. While it’s possible to add a text wrap to an anchored object, unfortunately the first
line of a paragraph will not wrap around the anchored object.

The workaround is to anchor the object in the previous paragraph. To finesse the position of the anchored
object, Option/Alt-click the anchored object widget (blue square) to call up the Anchored Object Options.
You can do this numerically, with x and y coordinates relative to the anchor marker, column edge, text frame,
page margin, or page edge, as appropriate. Alternatively, deselect the Prevent Manual Positioning check box
and click OK. Now move the anchored frame to exactly where you want it. Once you’ve nailed the position of
the anchored object, save the selected frame as an object style so that you can apply its formats with a single
click thereafter. Another consideration of anchored text wraps — perhaps a limitation, perhaps a good thing
— is that only the story in which the object is anchored is affected by the text wrap.

Creating Flexible Layouts with Text Wraps
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For magazine layouts, where text and graphic frames may overlap, text wraps allow easy experimentation with
different layout options. Combined with a baseline grid, layers, Auto-Size frames, and the Gap tool, text
wraps are integral to a modular layout.

To use this approach, make sure your text frames extend from the top margin to the bottom margin. The text
will fill the available type area: no picture and you get a whole column of text; place a picture and text
obligingly moves out of its way. That way, you end up resizing one element — the picture frame — rather
than two. With Snap to Guides turned on and the baseline grid visible, picture frames snap to the next grid
increment, and with a baseline grid, the text moves to the next available grid increment. Put your text and
picture frames on separate layers so that you can lock or hide those layers as necessary.

Simple Type Effects
This section is a catchall for those type treatments that come under the heading of type effects.
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In terms of typographic effects, InDesign is perhaps the poor cousin of Photoshop and Illustrator. But there
are many simple and effective type treatments that can be achieved (almost) exclusively with InDesign, and
given the scope of this book (and the number of pages I have to work with), I’m limiting myself to these.

Working with Outlines
Converting text to outlines and filling the resulting frame with a picture is an effect that is easy to execute but
doesn’t always yield a pleasing look. If you’re like me, you’ve tried it many times but not always with great
results. Here are some tips for a better batting average.

Letter shapes that are bold and simple tend to work best. For that reason, I’ll typically start out with a heavy
sans serif set in all caps so that my text “windows” are as big as possible. In addition, it helps to make the type
as dense as possible, so tighten the tracking and, if you’re working with multiple lines, reduce the leading.

Make sure your type is the way you want it before you convert to outlines (Type > Create Outlines, or press
Cmd+Shift+O/Ctrl+Shift+O) because once you do so, there’s no going back. You might consider putting a
copy of the type on the pasteboard as insurance before converting to outlines. If your type runs to more than
one line, each line will be converted to its own group. Before you can place the picture in the letter shapes,
there are a couple of extra steps. First, ungroup the letters (Object > Ungroup or press Cmd+Shift+G/
Ctrl+Shift+G). Then, so that all the letters are considered a single frame and the picture fills all the letters and
not just one of them, convert them to a compound path (Object > Paths > Make Compound Path, or press
Cmd+8/Ctrl+8).

The effectiveness of this technique depends on the picture you’re using. Much of the picture will be hidden, so
it’s important that the reader already have an idea of what it is. For that reason, choose something very simple
or clearly recognizable so that the reader can “fill in the blanks.” If necessary, hover your cursor over the center
of the image and click the Contact Grabber to adjust the position of the image within the frame.
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You don’t need to stop at putting a picture inside text outlines. You can also place text inside text. It helps to
have words with the same or a similar number of letters, possibly synonyms or antonyms, and to use the
technique to emphasize or comment on the relationship between them.

Also consider using text as shading to define the outline of a simple graphic shape. In this example, multiple
overlapping and rotated text frames are used to create texture within the bug vector shape. Start by
overlapping the text, then group the frames together. Now cut the group and paste into the vector shape of
the cockroach. Obviously, the text is unreadable, but using the words of the book to define its graphic image
gives the text another role.

Type on a Path Options
Putting type around a circle never goes out of style. Here’s how to put text at the top and bottom of circle or
ellipse and have both pieces of text the right way up.

1. Draw a circle with the Ellipse tool and make sure it has no fill and no stroke.

2. With the Type on a Path tool (Shift+T), click an insertion point on the bottom handle of the circle
(the 6 o’clock position).

3. Choose center alignment, and start typing. Somewhat counterintuitively, your text appears at the top
of the circle.

4. To have text at the bottom and top of the circle, you need two circles. Copy the first circle and paste it
in place.
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5. With the Selection tool, drag the text from the vertical tick that indicates its alignment (it should be in
the center of the text) around and inside the circle. If you’ve never done this before, it will almost
certainly go haywire. Undo, and try again with a steady hand. Once you get the hang of it, it’s easy
enough, but it takes getting used to. If you’re having trouble getting the text inside the circle, double-
click the Type on a Path tool or choose Type > Type on a Path and select Flip.

To adjust the vertical position of the text on the bottom of the circle, in Type on a Path Options choose
Align: Center. To fine-tune its position relative to the path, select the text and use baseline shift
(Shift+Option+Up Arrow/Shift+Alt+Up Arrow). Putting text around two circles like this is tricky, so consider
using the Layers panel to lock one part of the composition while you work on the other.

For a variation of the type-around-a-circle theme, try the overlooked Effect drop-down in Type on a Path
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Options. In addition to the default (Rainbow) option, there are also options called Skew, 3-D Ribbon, Stair
Step, and Gravity. These are the type effects that time forgot — and unfortunately, InDesign lacks the
Warping tools available in Illustrator and Photoshop — but they still have their uses. I’ve yet to find a role for
3-D Ribbon, but Skew can be useful for maintaining the uprights on type around a curve, Stair Step can be
used for vertical type, and Gravity can be used to create a cast shadow. Here’s how:

1. Draw a frame wide enough for your text.

2. Using the Type on a Path tool, drag from the top-left corner to the top right.

3. Type your text — all caps, sans serif works best — and center-align it.

4. Select the frame, choose one of the top reference points, and Option/Alt-click the Flip Vertical button
in the Control panel to duplicate the frame and flip it.

5. With the new frame selected, choose Type > Type on a Path > Options and choose the Gravity effect.
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6. To adjust the length of the shadow, select the shadow text and change the Vertical Scale value in the
Control panel.

7. Fade the shadow with a Directional Feather. Apply it to the top of the frame, and select First Edge
Only from the Shape menu.

Using the Pathfinder Options
The Pathfinder panel lets you combine shapes in creative ways. For example, a simple application of the
Pathfinder Add function can be used to create a custom ligature or type mark. Like many of these techniques,
it works best with a typeface that has a large surface area. In the example shown, I used Futura Bold and
custom-kerned two straight-sided letters so that their vertical stems touch or slightly overlap. Next, I

347



converted the text frame to outlines and used Pathfinder to add the shapes together. Once they’re fused, it’s
possible to add a stroke color to the resulting shape.

The second Pathfinder function, Subtract, deletes a shape from the shape(s) beneath. In the example shown, I
used it to create a custom “shattered” frame. To try this yourself, draw two jagged pen paths over a rectangular
frame, select the pen paths and the frame, and choose Subtract from the Pathfinder panel. Then, copy your
text frame and choose Edit > Paste Into or press Cmd+Option+V (Ctrl+Alt+V) so that the shattered frame
masks the text.

With the Pathfinder Intersect option, you can create an interlocking effect that reinforces the connection
between the words. Here’s how:

1. Once you have arranged your text, convert it to outlines. If you have multiple lines, select them
(without the overlapping ampersand) and ungroup them (Cmd+Shift+G/Ctrl+Shift+G), and then
convert them to a compound path (Cmd+8/Ctrl+8).

2. Applying Intersect will remove everything but the intersecting areas, so before you apply it, copy your
selection to the Clipboard.

3. Choose Pathfinder > Intersect. Temporarily, apply an obvious color to the resulting shapes.

4. Choose Edit > Paste in Place or press Cmd+Option+Shift+V (Ctrl+Alt+Shift+V) to restore the
original shapes.
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5. Send these behind the intersected shapes by choosing Object > Arrange > Send Backward or pressing
Cmd+[ (Ctrl+[).

6. Select the intersecting shapes, and choose Object > Paths > Release Compound Path.

7. Using the Direct Selection tool, you will now be able to select and color the different intersecting
segments to give the illusion of the letterforms interlocking.

Working with Gradients
To apply a gradient to text in InDesign it isn’t necessary to convert the text to outlines, so the text remains
fully editable. Before you apply the gradient, tear off the Gradient panel so it’s open alongside the Swatches
panel.

In the example shown, I have sampled the colors of the gradient from the image itself. Using the Eyedropper
tool, click the image, and then click the New Swatch button at the bottom of the Swatches panel.

To apply the gradient to all the text in the frame, select the frame and then click the Formatting Affects Text
button ( J ), either at the bottom of the Tools panel or at the top of the Swatches panel. By applying formats
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this way, you won’t have the visual distraction of the selection color, and you can better evaluate the result.

Start by applying the standard black-and-white gradient to the selection. To change the colors, click a color
stop at the bottom of the gradient bar and then Option/Alt-click the color you want in the Swatches panel.
To add more colors to the gradient, click the bottom of the gradient bar. To remove colors, drag them off the
gradient bar.

To determine how one color transitions to another, drag the diamond sliders on the top of the gradient bar.
Their position indicates the point at which there is 50% of each color.

When you first apply a gradient, it runs horizontally across the text. Select the Gradient tool (G) in the Tools
panel and drag across your selection in the direction you want the gradient to go. If you drag beyond the
bounds of the selection, the gradient continues outside the letter shapes — you see just the portion that is
revealed by the letter shapes.
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Once you’ve made a gradient you like, drag its swatch to the Swatches panel. Reapply the gradient to the text.
This won’t affect anything visually, but doing so allows you to edit the gradient through the Swatches panel
(double-click the gradient swatch) and have it update wherever it’s applied in the document.

Transparency
A little transparency can go a long way, and sometimes all you need is a few overlapping shapes.

Putting text over an image is a compelling idea, but you need to make sure you don’t end up with the worst of
both worlds: unreadable text and an unreadable image. Here’s a simple technique that works in some
situations: to improve the readability of the text, make its frame white, and reduce the opacity of the fill. Note
that you can affect the transparency of the fill, the stroke, and the text independently. In this case you want to
keep the text at 100% and adjust only the fill transparency.

As a note of caution, if your work is destined for print, don’t get too carried away with transparency effects, as
they have a tendency to get muddied by the printing process. For a more accurate onscreen preview of how
transparency will print, make sure the transparency blending space of the document is CMYK (Edit >
Transparency Blend Space) and that you have Overprint Preview and Proof Colors (both under the View
menu) turned on.

▄

These type and image treatments are, as I’m sure you’re aware, just the tip of the proverbial iceberg. I
encourage you to explore what’s possible in InDesign and to try to use the tools in ways that they weren’t
necessarily intended to be used. As you do, don’t limit yourself to working exclusively in InDesign. Bringing
Illustrator and Photoshop to the party will really enhance your range of options.
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Chapter 17

Page Geometry, Grids, and White Space

Crucial to any page design are its dimensions and its framework. The page size and orienta–tion, the
width of the margins that define and frame the type area, and the number and width of the columns
that control the flow of the text are integral design elements that profoundly influence how a reader
reacts to the page, be it printed or onscreen. Superimposed on these dimensions is the grid, a series of
guides intersecting at regular intervals. The grid is an invaluable tool for organizing text and
suggesting (rather than dictating) how text and pictorial elements should be arranged on the page.

Setting Up the Document
When setting up a new document, here are some questions to ask:

What type of document is it? Is it a novel or continuous prose with a single text flow, a magazine or
newsletter with multiple stories, a brochure with several folds, a single-sided poster or flyer?

If it will be viewed onscreen, is it an interactive PDF to be projected as a presentation, an ebook to be
viewed on a Kindle or iPad, or a digital magazine to be viewed on a tablet?

Is there a fixed page count, or will the number of pages be determined by the length of the text?

How will the piece be printed? Is it possible to have bleeds — elements that print to the edge of the
page?

How many different types of text are there? Are there sidebars, captions, pull quotes, footnotes, or
endnotes? How many levels of hierarchy?

If there are images, are they predominantly vertical, horizontal, or square in orientation? Are they
photographs, illustrations, maps, icons, or all of the above? Do they need to be integrated into the flow
of the text?

Choosing a Page Size
Often, we don’t have the option of choosing a page size — and when we do, convenience and economy are
two major factors. Standard page sizes have practical benefits beyond being readily available: brochures need
to fit into standard envelopes, magazines and newspapers into display racks, and business cards into wallets.
But the world is full of documents in standard sizes: US letter, A4, tabloid, and so on. Use them, but choose
them because they offer the best solution for your design. Don’t settle for them because they’re the defaults.

Different Page Sizes

InDesign allows the use of different page sizes within the same document. This is useful if you want
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to keep the parts of a project together (for example, a business card, a letterhead, and an envelope can

each be different pages in the same document) or if you want to create the front and back cover of a
publication as a single page. To change the size of a page or range of pages, select the page(s) in the
Pages panel and choose Edit Page Size at the bottom of the panel. Alternatively, choose the Page
tool, click the page, and change its dimensions on the Control panel.

If you plan on using a custom page size, be sure to get a cost estimate from your commercial printer before
you commit to designing your publication at that size. It’s good to be different, but being different might
come with a hefty price tag. Sometimes, though, a custom size will warrant the extra cost. The dimensions of
your project will look unique rather than expected, organic rather than off-the-shelf.
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For as long as humans have been making printed materials they’ve been searching for the perfect page aspect
ratio — the relationship of width to height.

TIP: InDesign’s smaller screen sizes (640 by 480, 800 by 600, and 1024 by 768) are all 4:3 aspect
ratio; 1280 by 800 is a golden ratio.

Here are some common approaches.

The golden section/golden ratio: 1:1.618. This formula is based on the proportions found in the human body
and in nature. It was used for medieval manuscripts as well as in the creation of great works of art and
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architecture like the Mona Lisa and the Parthenon.

TIP: A handy workflow feature is the ability to save the settings you input in the New Document
dialog box as a preset. Once you’ve keyed in the values you want, click the Save Document Preset
button. Thereafter you can choose the preset name from the Saved Document Presets tab of the
New Document dialog box.

The silver ratio: 1:1.4142. ISO paper sizes — A4, A3, and so on — are based on this aspect ratio of 1 to the
square root of 2. It’s a clever and economical system because it allows you to fold one standard size into
another without needing to trim the paper to make smaller sizes. You can make brochures by using paper of
the next size up. For example, fold an A3 page in two and you have two A4 pages, fold an A4 in two and you
have two A5 pages, and so on. The standard US letter size (8.5 by 11 inches) is similar in aspect ratio to an
A4 page (8.3 by 11.7 inches) but slightly wider and not quite as tall.

Classical proportions: 2:3. Jan Tschichold (1902–1974) identified this aspect ratio based upon his studies of
medieval manuscripts.

Photographic aspect ratio: 1:1.5. This yields sizes such as 4 by 6 inches, 6 by 9 inches, and 8 by 12 inches.

Business card aspect ratio: 2:3.5. This is the ratio of most business cards. Its size, and multiples of it, feels
familiar.
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EPUBs and Page Size
If you’re creating a reflowable EPUB, page size is practically irrelevant. Rather than laying out an ebook,
you’re arranging its flow. You specify the order of the content and how that content is divided into sections,
but the size of the “page” itself is determined by the reader’s device. The point of a reflowable ebook is that its
content adapts to different screen sizes and resolutions.

Changing Page Size

While it’s possible to change the page size of a document in progress (File > Document Setup or
Cmd+Option+P/Ctrl+Alt+P), there’s nothing like getting it right from the outset. How successfully
you can transition from one page size to another will depend on how similar the aspect ratios of the
new and original page sizes are. To put it another way: Don’t expect miracles.
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Page Orientation
A quick glance at your bookshelf confirms that the majority of books — as well as magazines, newspapers, and
brochures — are tall (portrait) in orientation. Of course, there are exceptions: CD covers are square, and
books that showcase landscape-orientation photos or images may work better in wide format. But for the
most part, printed material is tall, and those publications that aren’t sit uneasily alongside this overwhelming
majority.

Know Your Intent
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One of the first choices you make when starting a new document is its intent: whether the document
is intended for print, for web (interactive PDFs, Publish Online documents, or website mockups), or
for mobile (tablet publishing or EPUBs).

In the default New Document dialog, Print, Web, and Mobile intents are presented as tabs at the top
of the dialog. In the legacy dialog, they are offered as a drop-down menu. The Web and Mobile
intent settings are the same except for their default screen size and use of a primary text frame (for
Mobile it’s on by default; for Web it’s not). Both use landscape orientation, turn off facing pages, and
set the units to pixels. The bleed is irrelevant and so is set to zero.

Inside the document you’ll notice that the default colors on the Swatches panel are RGB rather than
CMYK and that the Transparency Blend Space is Document RGB. While the unit of measurement
is pixels, type size and leading remain in points, as does stroke weight. This doesn’t matter, because
one point equals one pixel, unless you’ve changed the Point/Pica Size preference from its default of
PostScript (72 pts/inch).

If your document is in progress and you want to switch to the Web or Digital Publishing intent,
choose File > Document Setup. One small caveat is that if you originally began with a facing-pages
document, you will still have left- and right-hand master pages, even though switching intents turns
off facing pages. To fix this, select the master pages on the Pages panel, choose Master Options for
“A-Master” from the Pages panel menu, and change the number of pages to 1.

Pages designed for the screen, however, work better in landscape format for the simple reason that our
monitors are horizontal.

Master Pages
Think of master pages as template pages for your document pages — or as “page styles.” All documents start
out with one master page, which will be called A-Master. Any items on a document’s master page(s) show up
on all of the pages that are based on that master page. Changing the properties of the master page(s) changes
the properties for all document pages to which that master page is applied, whereas changing the margins and
columns of a specific page or range of pages affects only that page or range. Thereafter, the margins, the
columns, or both are independent of the master page. When changing the margins or columns of a master
page, pay attention to whether Enable Layout Adjustment is selected. Select Enable Layout Adjustment
before you change margins or columns if you want the frames of the document pages to also change.

On the Pages panel, a letter on the page icon indicates what master page it is based on. For facing-pages
documents it is in the outside corner; for non-facing pages it is top center. There’s no limit to the number of
master pages you can have, and you can even have master pages of different sizes and orientations, but if
you’ve planned your document carefully, even complex documents need only a few. For example, rather than
have a 2-column, 3-column, and 4-column master page, you could have one 12-column master page that
subdivides to 2, 3, or 4 columns.

To apply a master page to a document page, drag the master page icon onto the document page. Alternatively,
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select a range of document pages, Ctrl-click (right-click), and choose Apply Master Pages To when the

context menu appears.

Note that master page items are locked on document pages and appear with dotted borders instead of solid
frames. To modify a master page element on a document page, hold Cmd+Shift (Ctrl+Shift) and click the
object to unlock it. To unlock all master page elements, choose Override All Master Pages Items from the
Pages panel menu. Attributes that are locally modified are independent of the master pages; attributes that are
not locally modified remain under master page control. If you just want to remove a page number from a title
page, it’s easiest to apply the [None] master page. The margins and columns of [None] are set when you
create the document. It starts out the same as the A-Master, but thereafter is not controlled by it.

Here are some further considerations for working with master pages.

The initial properties of the A-Master page are determined by the New Document dialog.

When working with a facing-pages spread, double-click “A-Master” to select both pages of the spread.

Auto numbers display on the master pages as their page prefix. For example, when you insert an auto
page number (Type > Insert Special Character > Markers > Auto Page Number) on master page A, it
will appear as an A. On the document pages it will appear as the actual page number.

Put master items on their own layer. This makes it easier to control the stacking order of elements.

Creating a master page based on another sets up a parent–child relationship. Changes made to the
parent master page will affect its offspring.

TIP: If you want to add guides around the type area of the page, on the master page choose
Layout > Create Guides. Set the number of rows and columns to 1 and fit the guides to the
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margins.

For long documents, consider color-coding your master pages. You’ll be able to tell from a glance at
your Pages panel which master is applied.

Rather than create a master page with a bigger top margin for chapter opening pages, use an invisible
paragraph rule to add space above your chapter-opening paragraph style.

Navigate to master pages by using the keyboard shortcut Cmd/Ctrl+J followed by the page prefix: A, B,
C, and so on.

Master pages can be synced across a range of documents using InDesign’s Book feature. Choose
Synchronize Options from the Book panel menu and then select the Master Pages check box.

Folios
Page numbers and publication information are referred to as folios. The page number may be accompanied by
such information as the name of the magazine and month of publication, or the chapter title. Folios are placed
outside the type area, at either the top or the bottom of the page, but must relate to it. They usually work best
in the outside margin, where they can be easily seen by the reader, although centered folios are common in
book design and are a legitimate choice. Folios in the inner margin, however, make it hard to flip through the
book to find a specific page. Their type size will often be the same as the body text.

The left and right pages of a spread typically mirror each other so that the page number is the outermost
element. Choose Align Away from Spine — preferably applied as a paragraph style. (For layouts where
the folio will occasionally overlap an image, make a reverse variant of this style.)
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Running Heads
The content of running heads (headers) varies between publishing houses, but it’s common to put the author’s
name at the top of the left-hand (verso) pages and the title of the book or chapter on the right-hand (recto)
pages. This may be useful for short-story collections or anthologies, which have multiple authors, but is
unnecessary in a work by a single author. After all, how many times do you need to be reminded of the
author’s name or the name of the book you’re reading?

In a work using running heads at the top of the page, it’s common to position the folio at the bottom of the
page on chapter heading pages where a running head at page top would interfere with the type treatment of
the chapter heading. In such instances, it’s worth making a separate master page for the chapter opening
pages.

For books divided into chapters or sections, the running head may contain the name of the chapter or section
number. You can use a text variable on the master page(s) to add a placeholder for changing the text of the
running heads. It’s easy to add a text variable to a master page:

1. Choose Type > Text Variables > Define to set up the conditions of the text variable. Select Running
Header as the type of variable, and click Edit to define its options.

2. Choose the appropriate predefined paragraph style to apply to the text for the header. Click OK.

3. Click Insert to insert the text variable into the text frame.
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4. While you’re on the master page, the variable will read <Running Header>. If necessary, duplicate the
text frame to the facing master page. Now, on the document pages the text variable will reflect the
chapter or section head of the first (or last) match of the paragraph style specified in step 2.

TIP: In a perfect world, our clients would mark up their proofs electronically with Adobe Acrobat
or, better still, use an InCopy workflow. Until that day, make a line scale on your master page to
indicate line numbers for clients who like to give you corrections over the phone. Put the line scale
on its own layer. That way, your client can refer to corrections by page and line number, which
makes for quicker document editing. When the layout is finished, either delete the layer containing
the line scale or make that layer nonprinting. To do that, double-click the layer name in the Layers
panel to bring up the layer properties. Deselect the Print Layer option.

A problem with text variables is that they are treated as a single character. This means that you cannot vary
the text formatting within a variable, to, say, italicize part of it. Furthermore, a line will not break inside a text
variable instance — a problem if your chapter names are long. A possible solution (beyond shortening your
chapter titles) is to create a character style and apply it to the first few words of each chapter, then use a
character style running header to extract this information as the running head.

Page numbers and running heads are irrelevant when exporting to EPUB and will be ignored, along with all
master page elements, when you export the document.

Section Markers
If you’re working with long documents that are divided into parts, section markers (Type > Insert Special
Character > Markers > Section Marker) can help simplify the project by cutting down on the number of
master pages or the number of documents needed. Section markers can be used to mark the transitions
between departments in a magazine or parts of a book. Each section can have its own numbering scheme —
1, 2, 3, 4 or i, ii, iii, iv or A, B, C, and so on. Section markers can be formatted just as you would format any
piece of text.

On the master page a section marker appears as the word “Section.” To “activate” the section marker on a
document page, select the page on which you want the section to begin in the Pages panel and choose
Numbering & Section Options from the Pages panel menu. Type the section name into the Section Marker
field and click OK. This section marker will now appear on all pages based on the master page until another
section is defined.

In addition, there are also the Next Page Number/Previous Page Number markers, which are useful in
magazines or newspapers when a story jumps from one page to a non-contiguous page. They are typically
preceded with “Continued on … ” and “Continued from … ” It’s time-saving to create Library items for both.
The text frame containing Next Page Number or Previous Page Number markers must touch or overlap the
frame containing the text flow in order for the page numbers to be “live.”

Layers
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If you’re familiar with layers in either Adobe Photoshop or Adobe Illustrator, then InDesign’s layers
will look familiar. Layers determine the stacking order of objects on your page. Each individual layer
also has a stacking order that you can control using the Object > Arrange menu. Layers represent a
higher level of hierarchy. For instance, if you have a document where the Text layer is on top of the
Pictures layer, an object at the front of the Pictures layer is still beneath an object that is at the back of
the Text layer.

Layers allow you to view and edit specific kinds of content in your document without affecting other
kinds of content. For example, you can hide the Pictures layer when concentrating on the text and
vice versa. Clicking the small square to the right of the layer name selects all the content on that layer.

Layers can be twirled open to show their contents by clicking the arrows to the left of the layer
names. This makes it easy to see and change the stacking order of elements (by dragging the items up
or down in the list) as well as to select specific items by clicking the selection square to its right.

Layers help avoid printing problems that can arise when you use transparency in your layout. In
InDesign, transparency means a drop shadow, feathering, a Photoshop image with an alpha channel,
or any object with a blend mode other than Normal or an opacity of less than 100 percent. When a
document is printed, any text in proximity to a transparent element — for example, a text wrap
around a layered Photoshop image — is in danger of being rasterized, and possibly ending up looking
rather furry as a result.

To prevent this, move all text objects (except those that use transparency effects) to the top layer of
your document.

Determining Margins
Margins are often given insufficient consideration. It’s easy to fall back on even margins of half an inch, but in
doing so you miss an opportunity to establish the margins as an integral design element of your document.
Look at any page and you’ll notice that margins are the first space you see — they are vital in determining the
reader’s initial impression of the page. Margins serve several functions:

Margins separate the content from the edge of the page, framing and defining the type area of the page.
If you’ve ever done any picture mounting you’ll appreciate how much a good mount can increase a
picture’s impact.

Obviously, but quite profoundly, margins are where you hold the book or page — they are a place for
readers to put their thumbs, hopefully without obscuring the content on the page.

Historically, margins have been used as a space to write notes (wide outside margins are still referred to
as scholars’ margins), and in certain types of publications they continue to serve this function.

Margins are also a place to put the page numbers and publication information, in either the top or
bottom margins of the page, outside the type area.
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While margins define the type area, they are not absolute. Certain text elements, like drop caps, pull quotes,
and captions, may hang outside the type area and into the margins — as will punctuation if you are using
Optical Margin Alignment. Pictures frequently break out of the type area, disrupting the rectilinear nature of
the page and — potentially — making for a more dynamic layout.

Relative Size of Margins
Although single-sided documents like posters, flyers, or business cards often use even margins, making all the
margins the same for facing-pages documents can look static. When two pages are adjacent — such as in a
magazine or book — they share an inside margin broken only by the spine. This double margin means the
spread will be perceived as a single image with a middle margin.

NOTE: When setting the inside margin, bear in mind that the binding will change the reader’s
perception of the amount of space at the inside of the page. If the inside margin is too small, text will
be “lost” in the shadow between the pages.

Book margins typically progress from smallest to largest in the following order: inside, top, outside, bottom.
There are no cast-iron rules, but a popular ratio for determining margins is 1:1.5:2:2.25. This produces
margins that are generous yet look familiar to a 21st-century eye.

The inside margin should be the smallest dimension because it faces another inside margin. However,
this measure should be at least 10 mm on each page to avoid losing information in the spine. Ask your
print service provider to get the definitive inside margin advice for a specific project.

Next comes the top margin (head). This should be about 1.25 to 1.5 times the size of the inside margin.

The outside margin (foredge) should be big enough so that the type doesn’t look confined and to allow
space for the reader to handle the document. It should be approximately 1.75 to 2 times the size of the
inside margin.
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The bottom margin (foot) should be the biggest — about 2 to 2.5 times the size of the inside margin —
so as to avoid the type area looking bottom-heavy and to allow room for the folios. The amount allowed
for the top and bottom margins can be switched if the folios will be placed above, rather than below, the
type area.

Facing-Pages Documents
In a facing-pages document, the left and right pages mirror each other and the margins are expressed as inside
and outside, rather than left and right.

TIP: The first page of a two-page document is a right-hand page (or recto), meaning that the first
two pages will not appear as a spread. To have them do so, make the Start Page number an even
number. If you forgot to do this in the New Document dialog box, select the first page and from the
Pages panel menu choose Numbering and Section Options. Choose Start Page Numbering At, and
type an even number.

When you make a facing-pages document, you create two master pages with inside and outside margins that
mirror each other. If you want to create an asymmetrical facing-pages layout, start with a facing-pages
document, Ctrl-click (right-click) the spread representing the A-Master, choose Master Page Options, and
change the number of pages to 1. A single-page A-Master will replace the spread.

Setting Up Columns
The type area can be subdivided into columns. In setting up your columns, be sure that the text frames that
will contain your body text are wide enough, either as a single column or in multiples, for the text to be
readable. The relationship between type size and text frame width is the column measure. As mentioned in
Chapter 6, aim for 45 to 70 characters (including the spaces) per line. That’s a big range, so there’s plenty of
scope. Another commonly used standard is to use two alphabets, or 52 characters.

TIP: If you want columns of unequal widths, unlock the column guides (View > Grids and Guides >
Lock Column Guides) and drag the column guides. You may find it helpful to use the Rectangle
Frame tool as a “measuring stick” by drawing in place the outline of the columns and then
positioning the column guides according to these frames. When you’re happy with the result, delete
the frames and relock the column guides.

If the measure is too wide and you have too many characters on your line, “doubling” can occur — the eye
returns to the left column edge only to read the same line again. If you’re obligated to work with such a
measure, you can improve its readability by increasing the leading of your type. If your measure is too narrow
— especially if you’re working with justified type — getting evenly spaced type will be next to impossible.

Take a look at your daily newspaper and you’ll find justified columns with less than 50 characters. You’ll
probably also find — without looking too hard — that these columns are riddled with huge word spaces. This
is poor justification as a consequence of the narrow column measure. We’ve gotten used to bad typography in
newspapers — which, in their defense, are produced under tight deadline pressure — and read them easily
despite their typography, not because of it. Historically, newspapers used smaller type than they do today. But
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while the type has gotten bigger, the columns haven’t grown proportionally, hence the justification problems.
That said, there are notable exceptions — the Guardian (UK) has significantly raised the bar for newspaper
typography in the last few decades.

Create Margins from a Text Frame

Snap Margins to Text Frame is a simple InDesign script that lets you determine your margins based
on the size of your type area, rather than the other way around.

Draw a text frame. If you’re working with a facing-pages document, draw the frame on the first page
or on any right-hand page. With the frame selected, run the script to modify margins of all pages in
the document, including the master pages, so that they’re flush with the selected text frame.

You can download the script here: www.id-extras.com/snap-margins-to-text-frame.

Column width is more of an issue with justified type than with ragged type. If you’re working with a narrow
measure, do yourself a favor and use Left rather than Left Justified alignment.

Determining Gutter Width
In multicolumn documents, the separate columns of type should appear as parts of a unified whole. If the
space between the columns (the gutter) is too wide, those columns will look like they bear no relation to each
other. If the gutter is too narrow, though, the reader’s eye may mistakenly cross over from one column to the
next.

Gutter widths should relate to the body text leading value. To achieve uniform spacing, set your gutters to the
same value as, or to a multiple of (1.5 or 2, for example), the leading of the text. The wider the column, the
bigger the gutter.

Changing the Number of Columns
To change the number of columns, the size of the margins, or both for your page(s) or your whole document,
choose Layout > Margins and Columns.

When changing the number of columns, here are some things to consider:

To change the number of columns for all the pages based on a specific master page, you should edit the
master page itself (see “Master Pages,” earlier in this chapter).

To adjust the text and picture frames (and not just the column guides) on your document pages, select
Enable Layout Adjustment. Make sure you do this before you change any of the margin values. You can
set how Layout Adjustment behaves in the Layout Adjustment dialog box, also under the Layout menu.

To change the columns for the left- and right-hand pages of a spread, select both page icons in the
Pages panel; otherwise, you’ll be changing just one or the other.

You can change the margins and columns for a range of pages by selecting those pages in your Pages

369

http://www.id-extras.com/snap-margins-to-text-frame


panel.

“The reduction of the number of visual elements used and their incorporation in a grid system creates a
sense of compact planning, intelligibility, and clarity, and suggests orderliness in design. This orderliness
lends added credibility to the information and induces confidence.”

— Grid Systems in Graphic Design, by Josef Müller-Brockmann.

Creating Columns of Fixed Width
Turning on Fixed Column Width means that when you resize the frame it snaps to your specified width for
columns and gutters. If you know how wide you want your columns to be, select a text frame and choose
Object > Text Frame Options (Cmd+B/Ctrl+B) and specify a fixed column width. You can use the total
width of the text frame to determine the size of your type area and, by extension, the size of your left and right
page margins. For example, let’s say you’re working with a letter-size page. If you choose two columns with a
width of 20 picas and a 1-pica gutter, the total width of the text frame will be 41 picas. From here, you can
subtract the width of the text frame (41 picas) from the page width (51 picas) and allot the remaining 10 picas
to the left and right margins symmetrically or asymmetrically. This approach makes the margin width
subservient to an appropriate column width, rather than the other way around.

Creating Flexible-Width Columns
To specify a flexible number of columns in a text frame, change the Columns option to Flexible Width and
then input your column width. Thereafter, if you resize the text frame, InDesign adds (or removes) columns
as necessary. The maximum width field ensures that the column width will never be too large.

Working with Grids
Behind every well-designed page is a grid of some sort. Grids help you quickly and consistently arrange text
and graphics in your layout. Even though a grid will be invisible to the average reader, it helps them make
sense of the different elements of a document. The enhanced readability and increased structure that come
from using a grid give your documents credibility.

For you, the designer, the grid takes the guesswork out of where to place elements on the page. This means
increased design confidence as well as a more efficient workflow. A grid is a modular organizer, and working
with a grid you have the freedom to scale, run text across multiple columns, and move the elements around
and have them relate to each other — unified by the proportions of the grid. Everything on your page will be
where it is for a reason.

Grids impose order and constraint, so they take some getting used to. But once you’re comfortable with them,
grids enhance, rather than inhibit, creativity. Rather than the uncertainty that comes with a blank page, a grid
suggests layout permutations, encourages experimentation, and makes it more likely that the elements of your
page are in their right place, consistently spaced, and with everything relating, in some way, to something else.

A grid can be simple or complex, but even a one-column grid has to be carefully considered, because it
determines the type area of the page as well as the position of the folios. Newspapers and magazines with
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multiple columns and a mixture of type sizes — as well as photographs and illustrations — require grids that

are more complex and allow for variation. Such grids use a flexible number of columns and divide the page
horizontally as well as vertically. In addition, they use a baseline grid to keep the baselines of the type cross-
aligned over columns and equally spaced from other elements.

To fully embrace the grid, the size and position of all elements on your page will be derived from the grid
increment. Most obviously this will be the leading value of your body text, but for increased flexibility (and
also increased complexity) you can subdivide this number to arrive at the base unit. For example, if your body
text leading is 12, you can work with a base unit of 6 or even 3. Leading, margins, gutters, spacing between
paragraphs, and spacing between objects will be sized as multiples of this base number, with the objective of
creating a layout that is balanced and rhythmic.

Elements of the Grid
Let’s start by identifying the different types of grids:

A layout grid is a matrix of grid fields that divide the page vertically (columns) and horizontally (rows).
These grid fields, or cells, are separated by gutters.

A baseline grid is an incremented ruling of guides, superimposed onto the layout grid.

A document grid divides the page (and pasteboard) into “graph paper,” with grid lines at specified
increments and a chosen number of subdivisions. To align the grid to a specific part of your page, drag
from the intersection of the rulers to change the zero point. Document grids are especially useful when
aligning elements in diagrams.

TIP: Make the document grid invisible on the pasteboard. If you find it visually distracting to see
the document grid on the pasteboard, you can make sure it appears only on the page by making the
grid color the same as the color of the pasteboard. Note that this will work only if you have the
subdivisions set to 1. Choose Custom as the color. Switch to RGB slider and use the Eyedropper to
sample the pasteboard color.

Grid Terminology

Type area: The area of the page where type appears. The layout grid, made up of fields and gutters, is
contained within the type area.

Grid fields: The individual cells of the grid. The more grid fields (within reason), the more flexible
the grid.

Gutters: The horizontal and vertical spaces separating the grid fields. Their width and height are
usually the same as the baseline grid increment.

Active corner: The upper-left corner of each grid field, especially when using left-aligned text with a
flush left edge and a ragged right edge. It’s not necessary for text or images to fill the grid field, but
the content should be aligned to the top left of the active corner to preserve the integrity of the grid.
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One exception to this is when the text functions as a caption above a picture in the grid field below.
In such cases, the text can be aligned to the bottom of the text frame.

Setting Up a Layout Grid
Layout grids and baseline grids work in tandem. Before you set up the baseline grid, you create the layout
grid. At its most basic, this means choosing the page size, margin values, number of columns, and the gutter
width when you start a new document. If you’re changing these values for a document in progress or creating
a new master page, use Margins and Columns under the Layout menu.

To create an “organic” grid, drag out guides from the horizontal and vertical rulers. A horizontal guide can be
used as a “hang line” to position elements a consistent distance from page top. When a certain kind of
information, be it body copy, headline, or imagery, is always located in the same place on the page, the reader
knows where to look and what to expect. Draw these guides on the master page(s) and they’ll be visible on all
document pages. Hold down Cmd (Ctrl) to make a horizontal guide traverse both pages of a facing-pages
spread.
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To position guides precisely, select them and type the coordinates in the Control panel. For vertical guides,
specify an x-coordinate; for horizontal guides, specify a y-coordinate. Guides can be shown or hidden
(Cmd+;/Ctrl+;) as well as locked (Cmd+Option+;/Ctrl+Option+;). To delete all the guides on the page or
spread, Ctrl-click (right-click) in the ruler and choose Delete All Guides on Spread.

Use Create Guides (under the Layout menu) to create custom grids of rows, columns, or both. Turn on
Preview and experiment with different configurations. The guides can be positioned relative to the page or to
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the margins. If you already have a mess of guides on the page, select Remove Existing Ruler Guides to begin

with a blank slate.

Create Guides allows you to divide the page horizontally as well as vertically. If you’re using a complex grid,
consider superimposing an extra level of columns. For example, if you have a 12-column grid, you can
subdivide this into 3- and 4-column configurations. To avoid visual clutter, put these guides on their own
layers, which you can show, hide, or lock as needed.

TIP: You can also access Grid preferences by Option/Alt-clicking either of the Grid icons on the
Control panel or the Paragraph panel.

TIP: Set your vertical ruler to a custom increment. Open the Preferences dialog box and select Units
& Increments in the list on the left. Choose Custom from the pop-up menu next to Vertical, and
enter the grid increment as the amount. This makes the ticks on your ruler correspond to the lines of
your grid.

Setting Up a Baseline Grid
Before we sign off on the layout grid, we also need to set up the baseline grid because one informs the other.
Firstly, choose View > Grids & Guides > Show Baseline Grid, then go to Preferences > Grids to determine
the look, starting position, and increment of the grid. These are the options:

Color: I prefer light gray because it’s not too distracting.

Start and Relative To: These determine from where the grid starts counting off and whether that number is
relative to the top margin or the top of the page. I prefer to start at 0, relative to the top margin. This shows
the baseline grid only within the type area, rather than across the whole page.

Increment Every: This value, always in points, should correspond to your body text leading. The grid
increment sets the tempo of your document — controlling not just your leading but also suggesting the
spacing between elements and the sizing of images, which can be scaled and cropped to the closest grid
increment. Making the grid work involves some rudimentary math, so it helps to use a round number. Avoid
using auto leading, which may give you fractional leading values. For example, if the body text is 11, the auto
leading will be 13.2 — not a number you want to be juggling with.

View Threshold: This determines the view size at which the baseline grid becomes visible when shown. If
working on a laptop, make this number less than the default 75%. Or if you’re somewhat grid-phobic, you can
set the percentage higher, to something like 125%, so that you see the baseline grid only when you’re zoomed
in.

NOTE: Custom ruler guides are always in front of margin guides, column guides, and the baseline
grid — even if you deselect Grids in Back.

Grids in Back: I prefer to see my grid in front of page objects, so I do not select this.
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Now that the baseline grid is set up, you can revisit the layout grid. Things look tidier if the height of the type
area is divisible by the leading increment. This yields an exact number of lines and ensures that the last
baseline sits snugly on the bottom margin. It also makes it easier when aligning images to the bottom margin.

Take the following steps:

1. Go to the master pages. The type area will likely end with a partial grid increment. Zoom in to the
bottom of the page, and with the Rectangle Frame tool draw a rectangle to measure the height of this
partial increment.

2. Note the rectangle’s height (shown on the Control panel), or highlight the value and copy it to the
Clipboard.

3. Go to Layout > Margins and Columns. Insert your cursor after the value of the bottom margin, type +,
and then enter (or paste) the value of the partial increment to increase the size of the bottom margin by
this amount. Alternatively, you can enter this partial increment into the Start field in the Baseline Grid
preferences.

Dividing the Page into Rows
If you want square grid fields, choose a number of rows and columns that corresponds to the aspect ratio of
your page. For example, if you’re working with a tall US letter-size page (8.5 × 11 inches or an aspect ratio of
approximately 1:1.3), divide the page into a grid of 13 rows and 10 columns for grid fields; for an A4 page
(1:1.4), use 14 rows and 10 columns. The resulting grid fields will be square — or almost. They’re slightly out
because the aspect ratios are rounded off.
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If you want each row to have an exact number of lines and the row guides to sync with the baseline grid, begin
by making the row gutters the same value as the baseline grid increment. Then, for six rows, subtract five
gutter widths from the total height of the type area; for eight rows, subtract seven gutters, and so forth. The
number you’re left with needs to be divisible by your grid increment. If it’s not, you’ll need to either increase
or decrease the top and bottom margins accordingly.

For example, a type area of 53 lines divides into six rows: 53 − 5 = 48; 48 ÷ 6 = 8 lines per row. A type area of
55 lines divides into seven rows: 55 − 6 = 49; 49 ÷ 7 = 7 lines per row; or into eight rows: 55 − 7 = 48; 48 ÷ 8 =
6 lines per row.

Aligning to the Grid
Once the baseline grid is set up, align text to it by choosing All Lines in the Align to Grid choices found in
Paragraph Style Options/Indents and Spacing or by clicking the Align to Grid icon on the Control panel.

Aligning to the grid means the next grid increment, causing leading values to be rounded up, never down. For
example, if a paragraph with a leading value of 13 points is aligned to a 12-point grid, its leading becomes 24
points. When you align text to a grid, the grid increment always takes precedence over the leading.

(Not) Locking to the Grid

There will often be certain types of paragraphs that, while numerically on the grid, are not “officially”
aligned to it. Some designers like to take this a step further and not lock any text to the grid. Instead,
they prefer persuasion. And as long as the total amount of spacing in a paragraph (leading+space
before+space after) is a multiple of the grid, then locking to the grid is arguably unnecessary. If you’re
using this approach, you’ll also want to set the first baseline offset of your text frames to Leading and
specify the minimum amount as your grid increment.

The more different types and sizes of paragraphs your document contains, the more challenging it will be to
keep the text aligned to the grid. To allow more flexibility, consider subdividing the grid increment. For
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example, if your body text and grid increment are 12, halving the grid increment to 6 will allow the
introduction of paragraphs with a half-line space before or after. This means that your body text baselines in
adjacent columns will fall in and out of sync with each other with each occurrence of a paragraph with a half-
line space above.

Another approach (and one that can be combined with subdividing the grid increment) is to come off the grid
with certain elements, such as headings and subheads, so long as the next passage of body text finds the grid
again. To take specific paragraphs off the grid, make the total paragraph spacing (leading+space before+space
after) a multiple of the grid increment. For example, if the grid is 12 points and your subheads are 14/14, take
these paragraphs off the grid and assign 10 points of space (24−14) between the space before and after.

Aligning First Line Only
When working with captions and other supporting text that, because of size and leading values, cannot keep
to the grid, choose Only Align First Line to Grid. This ensures that the first lines of such paragraphs align
with the text in adjacent columns. Subsequent lines follow the specified leading increment.

Set the leading values of such sidebars or supporting text so that they resolve with the baseline grid on every
third or fourth line. For example, if the body text leading is 13.5 points and the sidebar leading is 9 points, the
baselines will resolve on every second/third line (13.5 × 2 = 27; 9 × 3 = 27).

Aligning Text and Images
When aligning text frames to the top of picture frames, the gap between the text cap height and the top of the
text frame results in optical misalignment. To fix this, draw a ruler guide from the horizontal ruler to the cap

378



height of the first line of type and align the top of the picture frame to this guide. If the layout requires cross-

alignment of multiple picture frames with the text cap height, then create a cap height grid by following these
steps:

1. Draw a ruler guide to the cap height of the first line of type.

2. Cut the guide to the Clipboard (Cmd/Ctrl+X), and go to the master pages.

3. Create a new layer for the cap height grid. Having the grid visible all the time will create visual clutter,
so you’ll want the option of seeing it only when necessary by turning on the layer visibility.

4. Paste in Place (Cmd+Option+V/Ctrl+Alt+V) the guide from the Clipboard.

5. With the guide selected, choose Edit > Step and Repeat (Cmd+Option+U/Ctrl+Alt+U).

6. Enter the number of lines in your type area (minus 1) for the Count, and the baseline grid increment
for the Vertical Offset.

7. Finally (and optionally), change the color of the guides. Select the guides on the layer by clicking the
square to the right of the layer name, then choose Layout > Ruler Guides.

Snap to Guides

When resizing and moving elements, frames will snap to the baseline grid, making it easier to
position and crop your images to a leading increment. If you’re using text wraps, set the text wrap
offset to your leading increment.

Make sure Snap to Guides is turned on (View > Grids and Guides > Snap to Guides, or press
Cmd+Shift+; /Ctrl+Shift+;) so that when you draw, move, or resize an object, its edges snap to the
nearest guide or baseline grid. Guides must be visible in order for objects to snap to them.

The Snap to Zone setting in Guides and Pasteboard Preferences determines the exact range within
which an object snaps to guides.

Text Frames with Different Grids
In addition to a document-wide baseline grid, you can also use a separate baseline grid for each frame. This
can be useful if you have sidebar material that flows in multiple columns and uses a different leading value
than the body text. Use a custom baseline grid when it’s more important that the supporting text align with
itself than that it be side by side with the main text. Theoretically, every text frame can have its own baseline
grid, but having too many different baseline grids in one document undermines the whole purpose of the grid:
a document architecture based on consistent modular units.
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A unique benefit of a custom baseline grid is that it remains in effect regardless of any rotation applied to the
frame. Rotate a frame containing text aligned to a document baseline grid and the leading goes haywire; apply
the same rotation to a frame with a custom baseline grid and the text stays on the grid. So if you want to
design on a diagonal grid, then a custom baseline grid is the way to go.

Grid Resources

A number of excellent resources are available if you want to explore grids further.

The website thegridsystem.org has grid templates and examples and links to all things relating to
grids.

Josef Müller-Brockmann’s Grid Systems in Graphic Design, although predigital, is a book every
designer should read.

Grid Calculator Pro is a clever plug-in that speeds up grid creation. Not only will it do the heavy
lifting when it comes to establishing grids of any complexity, its methodology will actually inform the
way you create and work with grids. You can download a trial version from
www.designersbookshop.com.

Layout Grid Calculator for InDesign is an easy-to-use online tool designed by Jean-Lou Désiré that
walks you through the necessary steps to create modular grid derived from your page size, font size
and leading. You can find it at www.layoutgridcalculator.com.

The Grid Toolkit
InDesign has a suite of tools that work together to help you set up and manage your grid.

Align To Grid: On a local level, you can click the icons on the Control panel; at the paragraph style level,

380

http://thegridsystem.org
http://www.designersbookshop.com
http://www.layoutgridcalculator.com


choose Align To from the Indents and Spacing options. For text with different leading increments, such as

captions or callouts — where aligning all lines to the baseline grid would prove too constraining — you can
opt to align the first line only. The first line of the paragraph will be on the grid; thereafter, the text is
controlled by its leading value.

Create Guides (Layout > Create Guides): This immensely useful feature allows you to make custom grids of
rows and columns, as an alternative to laboriously dragging out multiple ruler guides. Create Guides is a
guide-making machine — and because it’s instantaneous, you’re free to experiment with different
configurations.

Ruler Guides: Choose Layout > Ruler Guides to change the color of any selected guides. This is useful for
color-coding different parts of the grid. For example, with guides superimposed on a 12-column grid, you can
indicate three columns with one color and four columns with another.

The following options allow you to create a grid of objects:

Step and Repeat: Choose Step and Repeat (Cmd+Option+U/Ctrl+Alt+U) and select Create Grid to generate
a grid of objects from your selection, with each successive copy offset a specified distance from the preceding
one. Note that you need to factor in the size of the object when specifying the offsets. For example, if you
want to copy a 72-point square 12 points to the right, then make the horizontal offset 84 points.

Gridify: This feature allows you to expand a frame into a grid. While you’re drawing a frame, press the Up
Arrow and Down Arrow keys to add or remove rows and the Right Arrow and Left Arrow keys to add or
remove columns. This also works with a loaded Place cursor. The default gutter spacing between the rows and
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columns comes from the value you have set in the Margins and Columns dialog box. To adjust the gutter

spacing, hold down Cmd/Ctrl while tapping the arrow keys.

You can also duplicate objects into a grid. Hold down Option/Alt and begin dragging away from a selected
frame. Once you’re moving, press the Up Arrow key or Down Arrow key to change the number of rows of
objects and the Left Arrow key or Right Arrow key to change the number of columns of objects.

MakeGrid: Though to some extent superseded by Gridify, the MakeGrid script is still a quick and effective
way of dividing a frame into a specified number of row and column grid fields. Choose Window > Utilities >
Scripts to access the Scripts panel, and then drill down through the folders, from Application to Samples to
JavaScript. In the JavaScript folder you’ll see a list of scripts. With a frame selected, double-click
MakeGrid.jsx, then choose the number of rows and columns and the gutter space between them.

AddGuides: This script (found in the same location as the MakeGrid script) adds ruler guides to any selected
objects, which is useful if you’ve created a grid of objects that you’d like to convert to guides. Simply add the
guides, then delete the original objects.

Smart Guides: These make it easy to snap items to objects on your page. As you drag or create an object,
temporary green guides appear, indicating that the object is aligned with another page item. Magenta guides
appear when an object is aligned to an edge of the page or the center of the page. Smart Guides are on by
default (View > Grids and Guides > Smart Guides, or Cmd+U/Ctrl+U). Their preferences can be set in
Guides and Pasteboard preferences.

White Space
When you’re not fully confident in what you’re doing, there’s a tendency — one I’ve succumbed to many
times — to overcompensate with more stuff. This approach can have endearing results in a pub or restaurant
or other realms, but it rarely does any favors to a print or web design. So when challenged with a design
problem, instead of adding more content, try adding more white space — the stuff without content — to
bring the content you have into sharper focus.
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NOTE: White space doesn’t have to be white; it can be any color that represents the negative space
of a design — the areas that you don’t want the eye to focus on.

Using white space effectively comes with confidence and knowing how to employ it to your advantage. To
start with, that means dispelling the myth that because it’s empty, white space is unimportant. Not to be
confused with wasted space, white space is designed absence, not just space that’s left over when the text ran
out. It’s a conscious choice: even with all the design tricks you have up your sleeve, you’ve chosen the path of
restraint. Rather than the easy route of adding more content, you’ve chosen to use — or activate — the space
in the layout to help your viewers better understand and appreciate your design. This isn’t because you ran out
of stuff or didn’t have anything better to put there, but rather because presentation and context are important,
and by carefully considering the negative shapes, you’re making the positive shapes more interesting.

White space gives a layout form, holding it together with emphasis and structure, giving meaning to text and
image. Indeed, white space and content depend upon each other. A blank page isn’t white space until there’s
something on it. Place an element on the page and, because you’ve created a figure–ground relationship, the
space around it becomes white space. On the other hand, without white space, content is ambiguous — the
reader doesn’t know which elements in the design are the most important, nor how to navigate a layout.

At the micro level, white space is about readability. It’s the space around every letter and between every word
and the leading between every line of type. There’s also the text wrap offset, the column and row gutters, text
insets in shaded text frames, and cell insets in tables. Without these spatial elements, text would be unreadable
— letters would collide, words run into each other, and lines overlap. There are numerous ways to craft the
white space in small typographic details. For example, controlling the permissible variation of word spaces in
justified text, whether to use indents at the beginning of paragraphs (and their size), whether to put spaces or
thin spaces on either side of an em dash or between the points of an ellipsis, or how to chunk the different
parts of a phone number.
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At the macro level, white space helps establish a visual hierarchy, makes layouts more approachable, and aids
users in navigating content. It is the space between the major elements of a composition, like the margins, the
columns used for pictures and captions, and the space between paragraphs and graphic elements. As well as
framing the page, macro white space conveys hierarchy, provides resting points for the eye, and gives a respite
from wall-to-wall text. By signaling to the reader what’s most important, which elements belong together, and
which elements are separate, the macro space provides rhythm and pacing and allows the reader to rest while
navigating the design.

Our brains put emphasis and importance on design elements that are surrounded by white space. The negative
space gives visual clues about where to look and provides buffer room around an element so that the reader
can quickly process it.

The economics of print publishing often mean working with less white space than you want, and that makes
the limited white space that is there especially important. Just as cities need parks and public spaces,
newspapers and magazines need white space, and with a limited amount to work with, how you choose to
incorporate that white space within a layout can mean the difference between visual chaos and a pleasant
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reading experience.

Removing White Space and Maximizing White Space
As well as manipulating the white space, you can make a statement with its absence. Bleeding a picture off the
edge of the page or across a spread makes the image more dynamic; with a full-page bleed, without white
space to frame the image, the image gives the impression of being so big that it cannot be contained by the
page.

At the other extreme, because white space looks extravagant, you can use it to imply luxury and sophistication
— just like the open floor plan of a high-end store versus the crowded shelves and wall-to-wall merchandise
of a discount store. With a wealth of options at your disposal, it’s a statement that you choose not to print on
that part of the paper. It shows confidence in your message. You don’t need to overplay your hand or toot your
own horn — the content speaks for itself.

In a crowded visual arena, so the argument goes, the designs with white space are the ones that stand out. If
everyone is shouting, it’s the calm, assured voice that has credibility and that will hold a person’s attention.
But it’s also possible to have too much of a good thing. A connotation of luxury and extravagance is not
appropriate for every message. In the wrong context, ample white space could come off as snooty or elitist.
Too much paper without ink might be considered environmentally irresponsible, or the design may look
unfinished or boring or even be perceived as having nothing to say. Although the Beatles’ “White Album”
may be a classic of design minimalism, Spinal Tap’s Smell The Glove (essentially the same design in black) is a
parody of empty-headedness. Sometimes less isn’t more, it’s just less.

▄

To summarize, your choice of page size, if that’s within your remit, has a big impact on your design. The size
of your margins is an important design decision and should be considered carefully; don’t settle for the
defaults, or at least not without considering other options. Grids, while they may take some getting used to,
are nothing to be afraid of but will enhance your creativity and speed up your workflow. The modular nature
of grids makes it easier for you to incorporate the white space as an active element in your document. When
you have all the elements — pages, margins, grids, and white space — working together, your documents will
have grace and authority.
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Appendix

Type Checklist

Following the rules is not an assurance of good typography, but disregarding them is a cast-iron guarantee of
bad. No matter what your level of experience, it’s helpful to have a checklist to measure your work against.

Keep It Simple
Typeface Selection: Why did you choose the typeface(s) you did? What message does it send? The only
wrong answer is no answer. Your type should be a considered choice.

Sizes: Do you really need all those different sizes? And all those different weights? Can you do more with
less? Consider differentiating with spacing, indentation, or color rather than changing font size or style. If you
can’t articulate why you need a change in size or style, maybe you don’t.

Consider the Spacing
Hidden characters: Turn them on so you can more easily spot spacing problems.

Eliminate unnecessary spaces, especially double spaces after a period.

Remove unnecessary returns: Paragraph spacing should be achieved with Space Before or Space After.
Usually you need one or the other; occasionally it’s appropriate to use both.

Paragraph spacing: There are pros and cons to using spaces between paragraphs versus first-line indents, but
whichever way you choose to differentiate your paragraphs, it is an either/or proposition. Don’t use both.

Remove unnecessary tabs. Just as with spaces and returns, there’s never a reason for multiple tabs.

Know your space widths: Are you using em spaces, en spaces, and thin spaces where appropriate?

Kerning: Do those headlines need kerning? If so, make sure that kerning is even. Are you using the most
appropriate type of automatic kerning (Metrics or Optical) for the particular class of type?

Proximity: Does the spacing of elements reinforce the connections between them? Subheads should be closer
to the text that follows them than to the text that precedes them. The spacing of your paragraphs should
enhance, rather than confuse, the message of the text.

Rhythm: Do the spacing values work together? The leading, the gutter spacing, and the space around pictures
and graphic elements should all work together.

Sweat the Details
Know your quote marks from your inch marks. Working with Use–Typographer’s Quotes selected will
address most, but not all, quote mark issues. Be particularly careful with apostrophes. And remember that
sometimes you need inch and foot marks (primes).

Know your dashes: Make sure you’re using hyphens, en dashes, and em dashes correctly.

No faking it: Don’t change the horizontal or vertical scale of your type. Don’t put a stroke around type to
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make it bolder. Don’t slant your type. Instead, opt for real condensed or extended fonts, use a real bold
weight, and use real italics. If your text calls for the extended use of small caps, choose a typeface that has real
small caps whose strokes have the same weight as all the other glyphs in that font, rather than using fake,
computer-generated small caps.

All caps: Use all caps sparingly in body copy. Sometimes shouting your message is necessary; other times it
makes you look like an oaf having an uncontrolled Twitter outburst. Never use all caps for cursive or swash
characters.

OpenType: Become familiar with the enhanced typographic options that OpenType Pro fonts offer, and use
them where appropriate. Consider the figure style. Use real fractions; use discretionary ligatures and swash
characters where appropriate. The Glyphs panel is your key to unlocking the full potential of OpenType Pro
fonts.

Drop caps: Watch out for character collisions, and kern the space between the initial character and the text
where necessary. And don’t overuse them.

Bullets: Adjust the size, position, and spacing of bullets as necessary. The bullet character should emphasize
the point but not overwhelm the text that follows it.

Special characters: Adjust the vertical position and spacing of special characters like ®, ™, and © as well as
footnote characters as necessary.

Maximize Readability

Consistency: Rhythm and consistency are essential for readable text. Don’t fudge things with inconsistent
leading; don’t vary type sizes to make things fit or fill up space. Don’t squeeze type with too much tracking, or
fill up vertical space with vertical justification. People will notice.

Leading: Make sure your leading is consistent. Avoid auto leading most of the time, especially for headings.

Justified text: Your column measure should be wide enough to achieve even word spacing. It’s not enough to
simply choose the justified alignment option — you need to consider how your line length, justification
settings, hyphenation settings, and Optical Margin Alignment work together.

Left alignment: Pay attention to the evenness of the rag. Intervene with No Break, discretionary hyphens, and
forced line breaks as necessary. Consider the importance of hyphenation and your hyphenation settings to the
quality of your rag.

Center alignment: Center-aligned text can look classy or it can look boring and static. Make sure you’re using
it for the right reasons.

Right alignment: Use right alignment sparingly, and make sure your lines aren’t too long.

Text wraps: Pay particular attention to the word spacing of your text when you position a text wrap object
within a column of type.

Composition preferences: Use the H&J Violations composition preference to spot at a glance where your
spacing problems are.

Hyphenation: Proper hyphenation is about more than just selecting the check box. Adapt your hyphenation
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settings to the needs of the text. If you hyphenate your body copy, make sure you’re not also hyphenating
headings and subheads. Be sure you’re using the appropriate language dictionary. Check for bad hyphenation
breaks and avoid consecutive hyphens.

Tracking: Apply tracking sparingly to fix spacing problems. To achieve a tighter or looser letter fit, adjust
word and letter spacing instead. Use the Custom Tracking/Kerning composition preference option to spot at
a glance where the letter and character spacing has been adjusted — especially if you’re working on a
document you’ve inherited from a colleague.

Widows, orphans, and runts: Fix these when you can — just make sure that the fix doesn’t create a worse
problem. Don’t underestimate the usefulness of editing the copy in order to make it fit.

Contrast: Make sure there’s enough contrast between the color of your type and the color of the background.

Think Locally, Format Globally

Finally, make sure you’re using paragraph styles and, where appropriate, character styles and object styles. If
your document has multiple tables or if your tables require frequent updating, you should also be using table
and cell styles. Styles are the opposable thumb of document formatting. If you’re not using them, you’re
working too hard and your results will be clumsy. Without styles you’ll be creating documents that are difficult
and time consuming to edit as well as prone to formatting inconsistencies.

In all your work in InDesign, as well as any typesetting in related programs like Photoshop and Illustrator, try
to balance the big picture with the small, the overarching view with attention to the minutiae. It’s the
combination of the two that will distinguish your work as that of someone who understands and cares about
type.
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Index

Numbers
1/1000 em, 14

A
Active corner, 300

AddGuides script, 311

Adobe Experience Manager (AEM) Mobile, 67–68

Adobe Garamond typeface, 221

Adobe Jenson typeface, 6, 10, 61, 168, 223–224

After First and Before Last, hyphenation, 168

Align panel, 110

Align to Grid icon, 306–307, 309

Align Towards and Away From Spine, 106–107

Alignment

to baseline grid, 304

bullet lists, 197

drop caps and, 211

horizontal. See Horizontal alignment

of numbers in number list, 199–202

of only first line to grid, 307

overview of, 95

screen text and, 78

shortcuts, 97

table, 181

text to grid, 306–307

vertical, 94, 110–116

All caps

leading for, 86, 89

letterspacing display type in, 120

lining figures and, 150

never setting script typefaces in, 6

overview of, 53–55

Ampersands, 146

Anchored objects, 244–246, 272
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Apostrophes, 135

Arial typeface, 2–3, 10, 62

Arno Pro typeface family, 223

Aspect ratios, pages, 287–289

Asymmetric typography, 98

At sign (@), 139

Auto Leading

avoiding, 88–92

in EPUBs, 91

inline graphics and, 91

Auto numbers, 196, 202

Auto-size text frames, 36–39

Autoflow, text, 28

B
Background

leading based on color of, 86

readability and contrasting, 64, 75

Balanced columns, 93, 116

Balanced Ragged Lines, 98, 177

Barnbrook, Jonathan, 60

Baseline grid

align first line only, 307, 312

align text and images, 308, 312

align text to, 306–307

cap height grid, 308, 312

custom, 308–309, 312

determining for master pages, 294–296

divide page into rows, 305–306, 307

halving, 313

handling subheads on, 313

ignore leading value when text is aligned to, 93–94

positioning on layout grid, 303

setting up, 303–305

text frames with different grids, 308–309, 312

Baseline shift, 17, 57–58

Bayer Universal typeface, 53

Bibliographies, consecutive em dashes in, 137
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Blackletter (Old English, Fraktur or Gothic) typefaces, 8

Blackletter types, 3, 8, 21

Bodoni typeface, 68–69, 86, 89, 225–226

Body rows, tables, 186

Body text, 48–49, 52–53

Bold type, 50–51, 86

Book feature, styles, 237

Borders

paragraph, 255–257

table, 187, 194

Bottom vertical alignment, 111–113

Bounding boxes, 30

Brackets, setting, 136

Break characters, 173–178

Breaks, controlling in EPUBs, 79

Brody, Neville, 2

Bringhurst, Robert, 51, 168

Bullet lists

common use of bullet character, 139

creating, 196–198

exporting, 202

on screen, 82

sorting, 198–199

tabs, 202–206

Business card aspect ratio: 2:3.5, 288

C
Callout boxes, formatting, 244

Cap height grid, 308, 312

Capitalized words, hyphenating, 169

Captions

auto-size frames for, 37

letterspacing for small type, 120

text sizes for print, 52

working with, 245

Carson, David, 5, 9, 64

Carter, Matthew, 5, 66, 73

Casing
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text sizes for print, 52–53

typeface combination using, 223

Cast shadows, 276, 278–279

Catchwords, decorative, 149

CC Library

adding auto-size text frames to, 39

holding styles in, 241

loading styles from, 235–236

Cell styles, 228, 246–248

Cell Styles panel, 185

Cells, table

formatting, 183–184

graphics in, 190–191

inserting tabs in, 202

selection methods, 186

Center alignment, 97, 104

Center Justify, 96

Center vertical alignment, 110–112

Chapter headings

casing, 54–55

drop caps with nested styles in, 249–250

Character count, column width, 99–100

Character formats

all caps, 53–55

baseline shift, 57

bold weights, 50–51

common text sizes in print, 52–53

condensed and extended type, 58

font, 45–46

font size, 51

italics, 49–50

normal/regular/roman styles, 48–49

small caps, 53–55

strikethrough, 57

superscript and subscript, 55–56

underline, 56–57

Character styles

applying, 231–234
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applying tracking as, 127

bullet lists, 196

defined, 228

drop caps and, 208, 210, 215–216

editing and adapting, 234–238

end marks and, 138

footnotes and endnotes, 258

in nested styles, 248–250

number lists, 196

preserving in placed text, 242–243

tab leaders and, 204

understanding, 238–240

Characters. See also Special characters

glyphs vs., 144

tab, 203

tab leader, 204

white space, 139–141

Chartwell font, 148

Circles

aligning type in, 111, 113

text around, 274–279

Clarendon typeface, 221

Classical proportions aspect ratio: 2:3, 288

Cleanup, text, 40, 42

Clipping path, 266, 268, 270

Collisions, avoiding, 146

Color

coding master pages in long documents, 291

combining typefaces and, 224

drop caps and, 210–211

leading based on background, 86

white space and, 313

Color and contrast

Colour Contrast Analyser, 75

for readable type, 63–64

for screen type, 75

Columns

avoiding text wraps in single, 264, 267
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creating fixed-width, 298

creating flexible-width, 298

height adjustment for of all, 93

in tables, 183–184, 186–189

justified type and width of, 99–100

leading and width of, 84–85, 87

letterspacing for short/narrow, 121

letterspacing for wide, 120

master pages, changing, 290–291

master pages, setting up, 296–298

number of, 297–298, 301

page/margin sizes for screen, 76

vertical justification vs. balancing, 116

Combining typefaces

choosing from same designer, 225

choosing typeface family, 220–222

combining characteristics, 225–226

going for contrast, 222–225

historical appropriateness, 225

overview of, 219

vive la diffèrence, 220

what to avoid, 220

Comic Sans font, 3–4, 62, 225

Communication, legibility and, 64

Composition, troubleshooting in Story Editor, 40, 41

Composition Preferences

Custom Tracking/Kerning, 124–125

H&J Violations, 103, 173

text wrap preferences, 269–270

Compound paths, 272–275, 281

Condensed typefaces

in tables, 180

tight letterspacing of, 119, 121

working with, 58–59

Content Grabber, 264, 268

Contextual alternates, OpenType, 153

Contoured drop caps, 213–214

Contrast
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color and. See Color and contrast

typeface combinations based on, 221–225

Control panel, 16

Convert Text to Table, 184–185

Copyright symbol, 138–139

Create Guides, 303, 309–310

Create Links to spreadsheet files, 187

Curves, bullets around, 201

Custom baseline grid, 308–309, 312

Custom Tracking/Kerning (Composition Preferences), 124–125

Cut and paste

creating text frame via, 24

data from Excel, 185–186

drop caps into text frames, 209

positioning anchored objects, 245

text frame into cell as inline frame, 190

text into InDesign document, 35

D
The Daily Drop Cap, 210

Dashes, 136–137, 319

Dates, 137

Decimal alignment, in table cells, 191

Decorative catchwords, 149

Decorative drop caps

history of, 207–208

inspiration for, 210

kerning, 212–213

preventing collision with second line of text, 211–212

Decorative typefaces, 8

Default styles, creating, 240–241

Degree symbol, 139

Descenders, drop cap, 211

Desktop publishing, first typefaces, 66

Details, small and important

Glyphs panel, 142–145

OpenType. See OpenType

overview of, 133
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special characters, 134–139

white space characters, 139–141

Diagonal grid, designing on, 310

Diagonal lines, applying to table cells, 192

Didone (Modern) typefaces, 7, 86

Digital publishing, 66

Digital Publishing intent, 290

Digital Publishing Suite (DPS), 67–68

Dingbats, 9, 196

Dipthongs, 147–148

Direct Selection tool

adding text wrap to picture, 264

creating contoured drop caps, 213–214

customizing shape of text wrap offset, 265, 267–268

Discretionary hyphens, 170–171

Discretionary ligatures, 147–148

Display type

common text sizes for print, 52–53

extended faces, 58–59

glyph positioning for all caps, 55

intended to stand out, 10

kerning in, 128, 130–132

leading and, 86, 88–89

letterspacing for all caps, 120

ligatures and dotless i as, 147

overview of, 8

punctuation in, 136

Document grid, 300

Documents

applying master pages to, 290–291

defined, 24

knowing intent of new, 290

loading styles in, 235–236

master pages as templates for. See Master pages

modifying master pages, 291

moving between/arranging, 20

new, 286–290

page/margin sizes for screen, 76
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saving settings as presets, 288

use of white space in. See White space

working with grids. See Grids

working with layers, 294

Dotless i, 147–148

Double quotation marks, 134

Double spacing, never, 140–141

DPS (Digital Publishing Suite), 67–68

Drop caps

aesthetics of, 210–211

auto numbers using, 202

contoured, 213–214

examples, 209

fixing tricky, 217

kerning, 130–131, 212–213

line styles and, 214

in nested styles, 249–250

other uses for, 217

pictures and, 213

in reflowable EPUBs, 81, 216–217

simple, 208, 210

small, 214–216

tradition of, 207–208

when to avoid, 218

Dumb (straight) quotation marks, and italics, 135

Dummy (placeholder) text, 34–35

Dyslexic audience, typesetting for, 63

E
Editing styles, 234–238

Elements of Typographic Style (Bringhurst), 51

Ellipses, 137–138

Em space/dash

bullet lists around curves using, 201

changing width of, 252

defined, 13–14

typography for, 137

as white space character, 139
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Emoji and Symbols Viewer, Glyphs panel, 143–145

Emphasis

avoid underlines for, 56

with bold type, 51

character styles and, 240

with italics, 49–50

En space/dash

defined, 14

usage, 136–137

as white space character, 139

End marks, 138

Endnotes, paragraph/character styles for, 258

EPUBs

Auto Leading in, 91

exporting bulleted and numbered lists, 202

hyphenation in, 80

mapping object styles to, 246

page size and, 288

paragraph spacing and, 162

styles, and exporting, 260–262

styles in, 77

tables in, 248

types of digital publishing, 66–67

Excel, 185–187

Exporting

bulleted and numbered lists, 202

styles, and EPUB, 260–262

Extended type, 58–59

Eyedropper, applying styles with, 243

F
Facing-pages documents, master pages, 296

Feet, measurements, 135

Fibonacci sequence, 287

Figure space character, 140

Figures, OpenType, 150

Fills, table, 182, 187

Filters, font, 46, 60
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Find/Change dialog box, text cleanup, 42

Find Font dialog, 47

FindChangeByList script, 42

Finials, 149

First Baseline offset, 111–113, 161

First-line indents

aligning circled numbers in number list, 201

alternatives to, 158

creating bullet lists with, 196

paragraphs and, 156–157

for screen, 78–79

vs. paragraph spacing, 158

Fixed Column Width, 298

Fixed-layout EPUBs (FXLs)

choosing type for screen, 70

digital publishing with, 66–68

embedding fonts for, 72

hyphenation in, 80

leading for screen, 75

page and margin sizes for screen, 76

using fractions, 81

Fixed-Page Autoflow, text, 28

Fleurons. See Ornament typefaces

Flexible Column Width, 298

Flush left

bullet list alignment and, 197

first-line indent alternatives, 158

Left alignment, 96

Flush spaces, 139

Folios, master page, 292

Fontastic, 196

FontAwesome, 144

Fonts

for bullet characters, 196

changing default, 24

character format options. See Character formats

combining in same word, 130, 225

combining using same typeface family, 220–223
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handling missing, 47

management utility for, 46

for numbers in circles, 201

for screen, 68–73

size, 52–53

size/style of typeface and, 4

for table text, 180

three-dot ellipsis, 137–138

variable, 49

Footer rows, tables, 186

Footnotes

paragraph/character styles for, 258

superscript and, 55–56

Formatting. See also Character formats

callout boxes in Object Styles, 244

clearing overrides, 233–234

removing from already-imported table, 185

Nested styles, 228

styles and, 228

tables with Control panel, 182–183

using character styles for exceptions to, 238

Formulas, superscript typeface for, 56

Fractions

making OpenType, 252

overview of, 151–153

using fraction glyph for EPUBs, 81

nut or stacked fractions, 151–152

Proper Fraction script, 151

Frame tool, 24, 201

Frames

converting to anchored objects, 245–246

numbering across unthreaded, 198–199

using clipping paths as, 270

Type Tool Converts Frames to Text Frames (Type Preferences), 36

Full Justify alignment, 96, 103

Futura typeface, 4, 8, 10–11, 225, 278

FXLs. See Fixed-layout EPUBs (FXLs)
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G
Garalde Oldstyle typefaces, 6–7

Garamond typeface, 4, 6, 11, 72, 153, 221, 240

Geometric sans serif typefaces, 4–5, 8, 225–226

Georgia typeface, for screen, 62, 66, 73

Gill, Eric, 3, 223, 225

Gill Sans typeface, 4, 10, 223, 225, 252

Glyph Scaling, alignment, 101–102

Glyphs

characters vs., 144

choosing contextual alternates, 153

for discretionary ligatures/dipthongs, 148

for fractions in EPUBS or FXL, 81

glyph sets, 142, 144

handling missing, 145

positioning for all caps display, 55

using stylistic sets, 154

Glyphs panel, 142–145

Golden section/golden aspect ratio: 1:1.618, 288

Google Fonts, 152–153

Gotham typeface, 223

Gradients, applying text, 280–283

Graphic cells, converting table cells to, 190–191

Graphics

changing graphic frames to text frames, 36

text wraps and, 264, 266–268

Gravity effect, 268, 276

GREP Find/Change

changing open quotes to apostrophes, 136

converting manual numbers/bullets to auto, 203

creating nonbreaking space with, 80–81

replacing ellipsis with customized ellipse, 138

GREP styles

defined, 228

managing runt lines, 123

overview of, 250, 252

simulating primes, 135
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Grid Calculator Pro, 309

Grid field, 300

Gridify feature, 305, 311

Grids

baseline. See Baseline grid

document, 300

Grid toolkit, 309–311

layout, 300–303

overview of, 299

types of, 300

working with, 298

Grotesque sans serif typefaces, 4–5, 8, 10

Groups, style, 236–238

Guides

creating master page, 291

positioning on layout grid, 300

turning on Snap to Guides, 308

Guillemets, 135

Gutter width

fixed width columns, 298

leading and, 85, 87

in multicolumn documents, 297

Gutters, 300

H
H&J Violations, 103, 173

Hair space character, 139

Halving baseline grid, 306, 313

Hanging indents

bullet lists, 196

paragraphs, 158–159

tabs, 206

Hanging punctuation, 109

Headers

center alignment for, 104

with clear visual clues for tables, 182

running heads in master pages, 292

selecting table rows, 186
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Headlines

all caps text in, 53

casing chapter headings, 54–55

condensed type for, 58–59

manual kerning for, 130

manually threading, 32

Heads, creating reverse-out, 254–255

Heller, Steven, 2

Helvetica typeface, 2–3, 8, 10, 89, 180, 220–221

Hidden characters

Auto Leading issues, 90

in Story Editor, 41

text cleanup, 42

viewing, 82

Hierarchy

creating with based on styles, 230–231

of information, 163

white space creating visual, 314–315

Highlights, underlining applied as, 56–57

Hische, Jessica, 3

Historical accuracy, combining typefaces, 224–225

Horizontal alignment

Align Towards Spine/Align Away from Spine, 106–107

aligning elements relative to each other, 110

centering type, 104

how InDesign composes type, 100–103

left-aligned type, 97–100

optical alignment and hanging punctuation, 109

overview of, 96–97

right-aligned type, 105–106

side heads, 107–108

HTML, InDesign and, 67

Humanist sans serif typefaces, 4–5, 8, 73

Hyperlinks, underlining applied to, 56

Hyphen Limit, 168–169

Hyphenate Across Column, 170

Hyphenate Capitalized Words, 169

Hyphenate Last Word, 170
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Hyphenation

discretionary hyphens, 170–171

dos and dont’s, 174

in EPUBs, 80

H&J Violations, 173

in justified type with last line aligned left, 99

nonbreaking hyphens, 171

options, 167–170

qualities of good, 166

turning off for right-aligned text, 105

user dictionaries and, 171–173

varieties of hyphens, 168

Hyphenation slider, 169

Hyphenation zone, 169

I
Icons, 196

Images. See also Type and images

aligning to grid, 308, 312

simple type effects and, Type effects

text wraps around irregularly shaped, 266–268

Importing

object styles from another document, 246

prepared text into document, 24–25

styles from Microsoft Word documents, 241–243

tables, 184–185

Inch marks, 135, 319

Indentation

Balanced Ragged Lines using, 177

on screen, 78–79

typeface combinations using, 223

types of, 156–160

Indent to Here character, 109

InDesign overview

Control panel, 16

finding preferences, 12–13

introduction to, 2

names of typefaces, 11
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Tools panel, 14–15

type anatomy, 4–5

type characteristics, 10–11

type choices. See Type choices

type classification, 6–10

type measurement systems, 13–14

type sizes, 10

type weight, 11

viewing pages, 16–20

workspaces, 20–21

zooming in/out, 17–18

Industria typeface, 224

Info panel, 99

Infographics fonts, 148

Inline graphics, 91

Inserting

rows and columns into tables, 188

white space, 138, 175–176

Intent

choosing in new document, 290

specifying for Web or Mobile document, 75

Interactive PDFs, digital publishing with, 67–68

Interlocking type, 281

Inverted text wraps, 271

ISO paper sizes, 288

Italics

automating for straight quotes, 135

letterspacing for, 119

for OpenType swash characters, 149

overview of, 49–50

typeface combinations using, 223

J
Joining tables, 192

Justified alignment

defined, 96

InDesign settings, 100–103

with last line aligned left, 98–100, 103
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leading and, 85–87

left alignment vs., 96–97

other types of, 103

text elements that should never use, 100

using Optical Margin Alignment with, 109

Justified type, text wraps and, 264, 267

Justified vertical alignment, 111–115

Justify All Lines alignment, 102–103

K
Keep Options

Keep Lines Together, 126–127, 177–178, 189

Keep with Next, 164, 176–177

Keep with Previous, 177

Start Paragraph, 178

Kerning

automatic, 128

defined, 118

display type, 131–132

drop caps for listicles, 212–213

keyboard shortcuts, 17

manual, 130

metrics kerning vs. optical, 128–130

overview of, 127–128

particular letter combinations, 129

script typefaces and, 6

shortcuts, 120

style overrides, 127

vs. tracking. See Tracking vs. kerning

Kerning pairs, 129–130, 252

Keyboard increments, 17

L
Landscape orientation, pages, 290

Language dictionaries, hyphenation and, 166–167

Language, Font menu organized by, 46

Last-line indents (right-hanging indents), 158–159

Layers
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Suppress Text Wrap When Layer Is Hidden, 269, 270

working with, 294

Layout

aligning elements on page, 110

changing number of columns in, 297–298

type wraps creating flexible, 272

white space in, 313–315

Layout grid, 300–303

Layout Grid Calculator, 309

Layout view, Story Editor, 40–41

Leader dots, on screen, 82

Leading

Auto Leading, 88–92

keeping consistent, 92–94

as line height in screen type, 83

overview of, 83

for screen, 74–75

size, 84–87, 156

Left alignment, 96–100, 103–104, 109

Left-hanging indents (outdents), 158–159, 206

Left indents, 159–160, 201

Left Justify. See Justified alignment

Legibility and readability, 59–62

Letter Spacing, 118

Letterforms

legibility and, 60

type, 5

type for screen, 70

Letterspacing

defined, 118

fixing windows, orphans and rivers, 126

in justified type, 101

kerning and. See Kerning

tracking vs., 118–121

type for screen, 70

Licko, Zuzana, 2

Ligatures

customizing, 281
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in OpenType, 146–148

Lines

applying text wraps, 265, 267

line breaks, 79, 173–178

scale and master pages, 292–293

styles and drop caps, 214

Lining numbers, 150, 180

Linking

to spreadsheet files, 187

to text files, 244

List styles, numbering across frames, 198–199

Listicles, 202

Lists

bullet. See Bullet lists

number. See Number lists

sorting, 198–199

tabs, 202–206

working with, 196

Local overrides, clearing, 233

Loose letterspacing, 119–120

Lorem ipsum, 34

Lower case typeface, 53

Lupton, Ellen, 2

M
Mac, sharing workspace in, 20

MakeGrid script, 305, 311

Manual kerning, 130–132

Manual text flow, 28

Manutius, Aldus, 3

Margins

and aspect ratios, 289

changing master page, 290–291

creating from text frame, 297

relative size of, 295–296

size settings for screens, 76

Master pages

adding nonprinting line scale to, 292
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applying with primary text frames, 27

columns, 296–298

facing-pages documents, 296

folios, 292

guides, 291

margins, 294–296

overview of, 290–291

running heads, 292–293

section markers, 293–294

Measurement systems, type, 13–14

Merging/unmerging table cells, 190, 193

Metrics kerning, 129–131

Microsoft Word

alternatives to, 40

Import Options, 36–37

importing styles from, 241

preserving character styling i, 242–243

text flow in, 24

Minion Pro typeface, 3

Minus sign, typography, 136

Missing fonts, handling, 47

Mobile Intent, new document, 290

Modern (Didone) typefaces, 7, 86

Monocased typefaces, 53

Monospaced fonts

defined, 9

metrics kerning for, 129

Moving, rows and columns in tables, 188

Müller-Brockmann, Josef, 298, 309

Multilingual publishing, 147

Multiplication sign, typography, 138

N
Naming

styles, 235–236

typefaces, 11

Nested styles

defined, 228

411



drop caps in, 215–216, 249–250

end marks in, 138

examples, 251

overview of, 248–250

Next Style, sequential styles, 252–254

No Break

creating bullet lists, 198

managing runt lines, 123

nonbreaking spaces vs., 171

overview of, 175–176

Non-joiner, kerning drop caps, 212–213

Nonbreaking hyphens, 170–171

Nonbreaking space

No Break vs., 171, 176

overview of, 140

on screen, 79

Number lists

creating with manual numbers, 196

overview of, 198–202

using tabs, 202–206

Numbers

drop caps with auto, 202

in fractions, 151–153

lining vs. oldstyle figures, 150

on screen, 82

page, 292

Nutso font, stacked fractions, 152–153

O
Object Layer Options, 273, 277

Object styles, 228, 243–246

Oblique type, 50

Oldstyle numbers, 81, 150

Only Align First Line to Grid, 307

Open Dyslexic typeface, 63

OpenType

checklist, 319

contextual alternates and, 153
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features of, 142

figures, 150

fractions, 150–152

ligatures, dipthongs, and dotless i, 146–148

ornaments, 9, 148–149

overview of, 146

stylistic sets, 154

swash characters, 149

titling alternates, 153

Optical kerning, 128–131, 225–226

Optical Margin Alignment

bullet lists, 198

drop caps in, 211

overview of, 109

text elements when using, 294

Optima typeface, 225

Ordinals, superscript for, 55

Orientation, page, 290

Ornament typefaces, 9, 148–149

Orphans

controlling on screen, 80

defined, 122

fixing, 93, 123–127

Outlines

converting text to, 273–274

creating interlocking type, 281

Overrides

clearing, 233

converting to styles, 244

redefining styles, 234

Overset text, 38

P
Packages

avoiding missing fonts, 47

Typekit fonts not collected in, 59

Padding, within text frame, 160

Pages
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breaks on screen, 79

choosing size for, 286–289

designing orientation, 290

dividing into rows, 305–307

page breaks. See Break characters

setting up columns, 296–298

size settings for screen, 76

viewing, 16–20

Palatino typeface, 225

Panning, around large view, 17

Paragraph Composer, 100, 102, 126

Paragraph Formatting Controls, 16

Paragraph styles

applying, 231–234

Auto Leading issues, 88, 90

changing default font, 24

creating, 229–231

creating bullet and number lists, 196–197

creating table of contents, 258–260

defined, 228

editing and adapting, 234–238

and EPUB export, 260–262

exporting bullet and number lists, 202

footnotes and endnotes, 258

justification settings and, 100

letterspacing adjustments in, 118

mistakenly using character styles vs., 240

and nested styles, 248–250

restarting numbers for number list, 200

setting leading values, 92–93

setting tabs, 203

Space Before or Space After, 162

Paragraphs

aligning circled numbers in number list, 201

borders for, 255–257

breaking. See Break characters

drop caps for opening. See Drop caps

first-line indents, 156–158
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fixing drop caps with short opening, 217

hanging indents, 158–159

left and right indents, 159–160

rules for, 254–257

rules for screen text, 82

shading, 256, 258

spacing, 160–164

spacing on screen, 78–79

Parentheses, 136

Pathfinder options, 278–281

Pen tool, shaping text wrap offsets, 268

Perpetua typeface, 223

Photo credits, letterspacing for small type, 120

Photographic aspect ratio: 1:1.5, 288–289

Pi typefaces, 9

Picas, 13

Picture credits, using auto-size frames, 38–39

Picture drop caps, 213

Picture frames

aligning text frames to, 308, 312

text as, 275

Pilcrows, 158

Place command, 36

Placeholder (or dummy) text, 34–35

Point size, 10–11

Points

leading, 84

overview of, 13

Portrait orientation, pages, 290

Positioning

anchored objects, 245

caption next to image, 245

Power Styles, Blatner Tools suite, 242

Power Zoom, 18

Preferences

Font menu, 45–46

Grid, 303–304

for recommended units/increments, 16

415



Story Editor, 40–41

text wrap, 269–270

working with, 10–11

Presets, New Document, 288

Primary text frames, 26–28, 76

Prime marks, 135

Print Intent, new documents, 290

Print, white space and, 315

Proximity, 163–164

Publish Online documents, 66–68

Pull-quotes, auto-size frames for, 37, 39

Punctuation

bullet lists, 197

fixing tricky drop caps, 217–218

hanging, 109

Optical Margin Alignment for, 109

space character, 140

typography for, 136

Q
Question-and-answer, using drop caps, 217

Quick Apply

clearing overrides, 234

finding styles, 232

Quotations

hanging punctuation for, 109

indenting, 159–160

quote mark shortcuts, 135

Quote marks, 134–135

R
Ragged alignment

in bullet lists, 198

justified type vs., 98

leading applied as, 94

in left-aligned type, 97–98

overview of, 96

in right-aligned text, 105
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Ratio, determining margin, 295–296

Readability

all caps text and, 53

bold type and, 51

checklist for maximizing, 320–321

color and contrast for, 63

emphasizing in tables, 181–182, 187

italics and, 50

leading and. See Leading

and legibility, 59–62

other factors affecting, 62–63

rules of, 60–61

on screen vs. printed page, 82

serif vs. sans serif and, 61–62

sizing screen type for, 72, 74

of tables. See Tables

text wrap on left edge undermining, 264, 267

transparency effects and, 283–284

white space and. See White space

Rectangle tool, vs. Rectangle Frame tool, 36

Redefining styles, 234

Reflowable EPUBs

digital publishing with, 66

drop caps in, 216–217

hyphenation in, 80

page size and, 288

screen type for. See Screen typography

text flow in, 33–34

Registered symbol, 138–139

Regular style type, 48

Relative units, 13–14

Repeating formats, using nested styles, 250

Repeating tabs, 206

Return (Enter), creating line spaces and, 160–162

Reverse-out heads, 255

Reverse-out text, 87

Reverse type, 120

Rewriting copy to copyfit, 126
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Right alignment, 96, 105–106

Right-hanging indents (last-line indents), 158–159

Right indent tabs, 206

Right indents, 159–160

Rivers, fixing, 125–127

Road signage, letterspacing for, 120

Rockwell typeface, 221

Roman style type, 48

Rounded-corner tables, 191, 194

Rows

dividing pages into, 305–306

selecting table, 186

specifying height for, 189

specifying number of, 183–184

working with tables, 187–189

Ruler Guides, 303, 304, 310

Ruler units, viewing pages, 17

Rules

applied to paragraphs, 254–257

for typeface combinations, 223

Run-in heads, using nested styles, 250–251

Running heads (headers), master pages, 292–293

Runts

controlling on screen, 80

managing with GREP styles, 123, 252

overview of, 122

S
Sans serif typefaces

all caps text, 53

bold vs. oblique style, 50

choosing type for screen, 68–69

combining with serif, 224–225

examples of, 10

extended faces as, 58–59

letterspacing all caps display type, 120

letterspacing headlines using, 121

ligatures and, 147
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naming conventions for indicating weight, 11

overview of, 8

serif vs., 4–5, 61–62

for table text, 180

Scale for Descenders, 211–213

Scaling type, for screen, 74–75

Scientific notation, typeface for, 55

Screen typography

alignment, 78

choosing type, 68–73

color and contrast, 75

controlling breaks, 79

controlling widows, orphans, and runts, 80

indents and paragraph spacing, 78–79

leading, 74–75

overview of, 65–66

page and margin sizes, 76

preparing type for, 72

scaling type, 74

sizing type, 72, 74

styles, 77

threading text, 78

types of digital publishing, 66–68

typographic details, 80–82

Script typefaces

choosing type for screen, 69–70

defined, 6

letterspacing for, 119

manual kerning of, 130

metrics kerning and, 129–130

Scripts panel, text cleanup, 42

Search

fonts, 45

Typekit font filters, 60

Section markers

drop caps for, 211, 249–250

for master pages, 293–294

Selection methods
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table, 186–187

text, 44

Selection tool

keyboard shortcuts, 14–15

moving/resizing text frame, 26

Semi-Autoflow, text flow, 28

Semibold type, leading for, 86

Sequential styles, 252–254

Serif typeface

all caps text in, 53

choosing type for screen, 68–69

combining with sans serif, 224–225

increasing italics size in, 50

letterspacing all caps display type, 120

letterspacing headlines/brandnames, 120

setting body text in print, 48–49

slab serif, 7

vs. sans serif, 4–5, 61–62

Shading, paragraph, 256, 258

Shape, changing object, 36

Sharing workspaces, 20

Shift key, viewing import options, 36

Shortcuts

alignment, 97

assigning to styles, 231–232

font size, 51

kerning/tracking, 120

leading, 88

master pages, 291

quote mark, 135

symbols, 139

table, 184

text selection methods, 44

Tools panel, 14–15

tracking vs. kerning, 121

viewing pages, 16–20

Show Import Options, Place dialog box, 36, 184–185

Side heads, 107–108
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Sidebars, auto-size frames for, 39

Silver aspect ratio: 1:1.4142, 288

Single-Line Composer, Adobe, 100, 102

Single quotation marks, 134–136

Single word justification, 102–103

Size

of drop caps, 210–211

of first-line indents, 156

of leading, 84–87

of pages, 286–289

of pages and margins for screens, 76

point, 10

relative size of margins, 295–296

resizing rows and columns, 188–189

screen type, 72, 74–75

typeface combinations and text, 223, 224

Skewed text, 276, 279

Skip by Leading, 92

Slab serif (Egyptian) typefaces, 7

Small caps typeface

drop caps and, 214–217

fake and real in reflowable EPUBs, 80–81

uses for, 55

Small Panel Rows option, 238

Smart Guides, 311

Smart Text Reflow, 27–28, 76

Snap to Guides, 308

Sorting

lists, 198–199

styles, 236

Spacing

alignment and, 97

avoid double, 140–141

bullet lists, 197

checklist for type, 318–319

combining typefaces using different, 224

first-line indents vs. paragraph, 158

how InDesign composes type, 100–103
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kerning drop caps, 212–213

paragraph, 160–164

ragged alignments and, 96

repeating tabs, 206

typeface combinations using, 223

Span Columns, 31–32

Special characters

accessing, 138

apostrophes, 135

checklist for, 320

dashes, 136–137

ellipses, 137–138

end marks, 138

multiplication and minus signs, 138

overview of, 134

punctuation, 136

symbols, 138–139

typographer’s quotes, 134–135

Spiekermann, Erik, 3, 60

Split Columns, 31–32

Splitting table cells, 190–193

Stacked fractions, 152–153

Stair Step effect, vertical type, 113, 116, 276, 282

Start Paragraph options, Keep Options, 178

Step and Repeat, 305, 308, 310

Stick-up caps, 208–209

Story Editor, 192, 232

viewing story in, 41

Straight (dumb) quotation marks, and italics, 135

Strikethroughs, 57

Strokes, 68–69, 187

Style groups, 236–238

Style sheets, 239

Styles

applying, 231–234

applying with Eyedropper, 243

based on other styles, 230–231

cell, 246–248
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character. See Character styles

checklist for, 321

choosing style guide, 138

clearing overrides, 233–234

converting overrides to, 244

creating reverse-out heads, 254–255

creating table of contents, 258–260

custom kerning/tracking overrides using, 127

default, 240–241

editing and adapting, 234–238

and EPUB, 77

and EPUB exports, 260–262

finding using Quick Apply, 232

fixing paragraph style pairs, 233

footnotes and endnotes, 258

GREP. See GREP styles

for group of documents, 237

importing from Microsoft Word documents, 240–242

list, 196, 198–199

loading from another document, 235

loading from CC Library, 235

master pages as page. See Master pages

nested styles, 248–250

object styles, 243–246

organizing, 235–238

overview of, 227

paragraph. See Paragraph styles

paragraph borders, 255–257

paragraph shading, 258

reasons to use, 228–229

rules, borders, and shading, 254

sequential styles, 252–254

table, 180, 246–248

terminology for, 228

Stylistic sets, OpenType, 154

Subheads

all caps text in, 53

casing of chapter headings, 54–55
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common text sizes in print, 52

handling on baseline grid, 306–307, 313

paragraph spacing and proximity of, 164

Subscript (inferior) typeface, 55–56, 151

Substituted glyphs, handling, 145

Superscript (superior) typeface, 55–56, 151

Suspended hyphens, 136

Swash characters, OpenType, 149

Symbols

commonly used, 139

typefaces using, 9

typography for, 138–139

Syncing documents, 291

T
Tab leaders, 203–206

Tab Ruler, 203, 205–206

Tab stops, 203, 205

Table of contents (TOC)

creating, 258–260

exporting to EPUBs, 260–262

left/right paragraph indents in, 159

updating, 260

Tables

aesthetics of, 180–182

anatomy of, 180

cells, 190–191

creating, 182–186

enhancing readability in, 181–182, 187

finding, 192

formatting, 183–184

joining and splitting, 192

language dictionaries and, 166–167

overview of, 179

rounded-corner, 191

rows and columns, 187–189

selection methods, 186–187

shortcuts, 184
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Story Editor and, 192

styles, 228, 246–248

text wrap and, 193

unexpected uses for, 192–194

Tabs, 203–206

Tabular lining numerals, 130

Tschichold, Jan, 54, 66, 98, 156, 288

Terminal characters, 149

Text

adding variables to master pages, 292–293

aligning to baseline grid, 306–307

converting to outlines, 273–274

converting to table, 184–185

leading and, 84

linking to text files, 244

selecting within table cell, 186

Text flow

dragging and dropping text files into, 29

inserting text file into existing, 37

other methods of, 28

overview of, 25–26

in reflowable EPUBs, 33–34

threading text for, 29–33

using primary text frames for, 26–28

Text Frame Options, vertical alignment, 110–113

Text frames

aligning to top of picture frames, 308, 312

anatomy of, 25

auto-sizing, 36–39

breaking tables across, 189

changing graphic frames to, 36

creating, 24

creating contoured drop caps, 213–214

creating margins from, 297

with custom grids, 308–309, 312

defined, 24

fitting, 25

multiple-column or individual, 33
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scaling type size together with, 51

snapping to baseline grid, 308

tables contained in, 182

text flow using, 25–28

threading text between, 29–33

viewing bounding boxes for, 30

Text insets, 160–161

Text typefaces, 10

Text wraps

in anchored objects, 272

applying, 264–265

applying to master page only, 266

around irregularly shaped graphics, 266–268

combining lists with, 202

contoured drop caps with, 213–214

flexible layouts with, 272

ignoring, 271

inverted, 271

nudger script for, 269

overview of, 264

preferences, 269–270

Skip by Leading for Jump Object style of, 92

tables and, 191, 193

Text Wrap panel, 265

Texture, text as, 275

Thin space character, 140

Threading text, 29–33, 78

Three-dot ellipsis, 137

Tight letterspacing, 119–121, 129

Tildes (~), 135

Titling alternates, 153

TOC. See Table of contents (TOC)

Tools panel, 14–15

Top vertical alignment, 110–112

Tracking

1/1000 em measure used in, 14

adjusting overall look of type, 129

creating vertical type, 282
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defined, 118

fixing composition problems, 118

fixing windows, orphans and rivers, 123–126

and Paragraph Composer, 126

shortcuts, 17, 120

style overrides, 127

vs. letterspacing, 118–121

Tracking vs. kerning

defined, 121

fixing windows, orphans and rivers, 126–127

letterspacing, 126

overview of, 50

rivers, 125–126

runts, widows, and orphans, 122–125

shortcuts, 121

style overrides and custom, 127

Trademark symbol, 138–139

Transitional typefaces, 6

Transparency, 282–284, 294

Troubleshooting, text composition in Story Editor, 40

Twombly, Carol, 4

Type

anatomy of, 4–5

characteristics of, 10–11

checklist for, 318–321

classification of, 6–10

Control panel, 16

display, 10

em space, 13–14

en space, 14

identifying typeface, 48

letterform, 5

measurement systems, 13–14

naming conventions, 11

preferences, 12–13

size, 10, 120

weight, 11

Type and images

427



creating flexible layouts with text wraps, 272

ignoring text wraps, 271

inverted text wraps, 271

simple type effects. See Type effects

text wrap preferences, 269–270

text wraps, 264–265

working with, 263

wrapping type around irregularly shaped graphics, 266–268

Type area, 300, 307

Type choices

basic character formats. See Character formats

Formatting Affects Text, 44

introduction to, 2–4

legibility and readability, 59–64

organizing content, 34–35

overview of, 43

for screens, 68–73

Selection tool, 14

text selection methods, 44

Typekit fonts, 58–59

Type Contextual Controls, 146, 153

Type effects

gradients, 280–283

outlines, 273–274

Pathfinder, 278–280

transparency, 283–284

Type on a Path, 274–278

Type on a Path options

putting type around circles, 274–278

vertical type, 113, 116, 281

Type on page

auto-sizing text frames, 36–39

Microsoft Word text, 36–37, 40

pasting text, 35

placeholder text, 34

Story Editor, 38–41

text cleanup, 40–42

text flow, 25–29
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text flow in reflowable EPUBs, 33–34

text flow with text threads, 29–33

text frames, 24–25

thumbnails, 34–35

viewing content in Story Editor, 38–41

Type tool, 14–15

Typeface. See also Type

combining. See Combining typefaces

defined, 4

Typefitter plug-in, 124

Typekit fonts, 46, 58–60

Typographer’s quotes, 134–135

Typography workspace, 21

U
Underlines, 56–57

Unicase or unicameral typeface, 53

Units & Increments, viewing pages, 17

Univers typeface, 221

Unmerging table cells, 190, 193

Up style, 53

Update Table of Contents, 260

Upper case typeface, 53

User dictionaries, 171–173

V
van den Dungen, Danny, 118

Variable fonts, 49

Venetian Oldstyle typefaces, 6

Verdana typeface, 62, 66

Versal, defined, 208

Verse, indenting, 159

Vertical alignment, 110–116, 190

Vertical justification, 94, 111–115

Vertical pipe (|), 135, 252

Vertical type, 113, 116, 282

Viewing

pages, 16–20
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text in Story Editor, 38–41

W
Weights, typeface

bold, 50–51

combining typefaces using different, 224

overview of, 11

for screen, 68–69

White space

in centered type, 104

characters, 139–141

converted to regular characters on screen, 82

created by indents and spacing, 164

removing or maximizing, 315–316

in right-aligned type, 105

side heads and, 107–108

using effectively, 311, 313–315

Widows

controlling on screen, 80

fixing, 93, 123–127

overview of, 122

Word count, column width, 99

Word Import Options, 134

Word, mixing typefaces in same, 225–226

Word spacing

alignment and, 101

fixing windows, orphans and rivers, 126

in justified type, 98–99

leading and size of, 85–86

in left-aligned type, 97

letterspacing adjustments and, 118–121

ragged vs. justified alignments, 96–97

Words with at Least, hyphenation option, 168

Wordsflow plug-in, 244

Workspaces, 20–21

X
X-height
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choosing screen type, 70

combining typefaces using matched, 225–226

leading and, 86, 89

small caps only as tall as, 55

and type size, 10

Z
Zooming in/out, 17–18
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