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1Starting up

About Digital Classroom
Adobe® After Eff ects® CS6 lets you create artwork for a variety of uses. The animation and 
compositing tools of After Eff ects are second to none; allowing you to manipulate text, 
images, audio and video. After Eff ects provides you with the tools to express your creative 
ideas for video, fi lm and broadband production. After Eff ects CS6 is also tightly integrated 
with other Adobe products such as Photoshop®, Illustrator®, and Premiere Pro®.

Adobe After Eff ects CS6 Digital Classroom is like having your own personal instructor 
guiding you through each lesson while you work at your own speed. This book includes 
12 self-paced lessons that let you discover essential skills and explore the new features 
and capabilities of After Eff ects CS6 on either a Windows or Mac OS computer. Each 
lesson includes step-by-step instructions, lesson fi les, and video tutorials, all of which are 
available on the included DVD. This book has been developed by the same team of Adobe 
Certifi ed Experts and After Eff ects professionals who have created many offi  cial training 
titles for Adobe Systems.

Prerequisites
Before you start the lessons in Adobe After Eff ects CS6 Digital Classroom, you should have a 
working knowledge of your computer and its operating system. You should know how to 
use the directory system of your computer so that you can navigate through folders. You 
need to understand how to locate, save, and open fi les. You should also know how to use 
your mouse to access menus and commands.

Before starting the lessons fi les in Adobe After Eff ects CS6 Digital Classroom, make sure 
that you have installed Adobe After Eff ects CS6. The software is sold separately, and not 
included with this book. You may use the 30-day trial version of Adobe After Eff ects CS6 
available at the adobe.com website, subject to the terms of its license agreement.

System requirements
Before starting the lessons in Adobe After Eff ects CS6 Digital Classroom, make sure that your 
computer is equipped for running Adobe After Eff ects CS6, which you must purchase 
separately. The minimum system requirements for your computer to eff ectively use 
the software are listed below and you can fi nd the most current system requirements at 
www.adobe.com/products/aftereff ects/tech-specs.html.

Starting up
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Prerequisites

Adobe After Eff ects CS6 Digital Classroom2

Windows

• Intel® Core™ Duo or AMD Phenom® II processor; 64-bit support required

• Microsoft® Windows® 7 with Service Pack 1 (64 bit)

• 4GB of RAM (8GB recommended)

• 3GB of available hard-disk space; additional free space required during installation 
(cannot install on removable fl ash-based storage devices)

• Additional disk space for disk cache (10GB recommended)

• 1280×900 display with OpenGL 2.0–capable system

• DVD-ROM drive

• QuickTime 7.6.6 software required for QuickTime features

• Broadband Internet connection required for software activation and access to online services

Mac OS

• Multicore Intel processor with 64-bit support

• Mac OS X v10.6.8 or v10.7

• 4GB of RAM (8GB recommended)

• 4GB of available hard-disk space for installation; additional free space required during 
installation (cannot install on a volume that uses a case-sensitive fi le system or on 
removable fl ash-based storage devices)

• Additional disk space for disk cache (10GB recommended) 

• 1280×900 display with OpenGL 2.0–capable system

• DVD-ROM drive

• QuickTime 7.6.6 software required for QuickTime features

• Broadband Internet connection required for software activation and access to online services
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3Starting up

Fonts used in this book

Starting Adobe After Effects CS6
As with most software, Adobe After Eff ects CS6 is launched by locating the application 
in your Programs folder (Windows) or Applications folder (Mac OS). If necessary, follow 
these steps to start the Adobe After Eff ects CS6 application:

Windows
1 Choose Start > All Programs > Adobe After Eff ects CS6. If you have the Creative 

Suite installed, you may have to select Adobe After Eff ects from within the Creative 
Suite folder.

2 Close the Welcome and Tip of the Day Screen when it appears. You are now ready to 
use Adobe After Eff ects CS6.

Mac OS
1 Open the Applications folder, and then open the Adobe After Eff ects CS6 folder. 

2 Double-click on the Adobe After Eff ects CS6 application icon.

3 Close the Welcome and Tip of the Day Screen when it appears. You are now ready to 
use Adobe After Eff ects CS6.

Menus and commands are identifi ed throughout the book by using the greater-than symbol (>). 
For example, the command to save a project would be identifi ed as File > Save.

Fonts used in this book
Adobe After Eff ects CS6 Digital Classroom includes lessons that refer to fonts that were 
installed with your copy of Adobe After Eff ects CS6. If you did not install the fonts, 
or have removed them from your computer, you may substitute diff erent fonts for the 
exercises or re-install the software to access the fonts.

If you receive a Missing layer dependencies warning dialog when you open a fi le, it is usually 
due to not having a necessary font installed on your system. If this occurs, press OK and After 
Eff ects will substitute a default system font. You can then change the default font to one similar 
to the one used in the lesson.
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Resetting Adobe After Effects CS6 preferences
When you start Adobe After Eff ects, it remembers certain settings along with the 
confi guration of the workspace from the last time you used the application. It is important 
that you start each lesson using the default settings so that you do not see unexpected 
results when working with the lessons in this book. Use the following steps to reset your 
Adobe After Eff ects CS6 preferences. 

Steps to reset Adobe After Eff ects CS6 preferences

1 Quit After Eff ects.

2 Locate and rename the Adobe After Eff ects 11.0 MC Prefs fi le, as follows.

In Windows: Rename the Adobe After Eff ects 11.0 MC Prefs (for example to Adobe 
Eff ects 11.0 MC Prefs-old) in the Users/(user)/AppData/Roaming/Adobe/
After Eff ects/11.0

In Windows 7, it is necessary to set hidden fi les to display in the folder and search options 
dialog box in order to see the AppData folder.

In Mac OS: Rename the Adobe After Eff ects 11.0 MC Prefs fi le in the Users/(user)/
Library/Preferences/Adobe/After Eff ects/11.0 folder.

3 Start After Eff ects. It creates a new preferences fi le.

You can also reset preferences using a keyboard shortcut. When starting the application, press 
and hold Control+Alt+Shift (Windows) or Command+Shift+Option (Mac OS). When the 
dialog box appears asking if you are sure you want to delete the preferences fi le press OK. Note 
that you have a very short window for using this keyboard command, so do it immediately after 
starting the application.

Loading lesson files
The Adobe After Eff ects CS6 Digital Classroom DVD includes fi les that accompany the 
exercises for each of the lessons. You may copy the entire lessons folder from the supplied 
DVD to your hard-drive, or copy only the lesson folders for the individual lessons you 
wish to complete.

For each lesson in the book, the fi les are referenced by the fi le name of each fi le. The exact 
location of each fi le on your computer is not used, as you may have placed the fi les in a 
unique location on your hard drive. We suggest placing the lesson fi les in the Documents 
folder (Windows) or at the top level of your hard-drive (Mac OS).
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Loading lesson fi les

Copying the lesson files to your hard drive:
1 Insert the Adobe After Eff ects CS6 Digital Classroom DVD supplied with this book.

2 On your computer desktop, navigate to the DVD and locate the folder named aelessons.

3 You can install all the fi les, or just specifi c lesson fi les. Do one of the following:

Install all lesson fi les by dragging the aelessons folder to your hard drive.

Install only some of the fi les by creating a new folder on your hard drive named 
aelessons. Open the aelessons folder on the supplied DVD, select the lesson you wish to 
complete, and drag the folder(s) to the aelessons folder you created on your hard drive.

Unlocking Mac OS files

Mac users may need to unlock the files after they are copied from the accompanying disc. 
This applies only to Mac OS computers and is because the Mac OS may view files that are 
copied from a DVD or CD as being locked for writing.

If you are a Mac OS user, and have difficulty saving over the existing files in this book, you 
can use these instructions so that you can update the lesson files as you work on them and 
also add new files to the lessons folder 

Note that you only need to follow these instructions if you are unable to save over the 
existing lesson files, or if you are unable to save files into the lesson folder.

1 After copying the fi les to your computer, click once to select the aelessons folder, then 
choose File > Get Info from within the Finder (not After Eff ects). 

2 In the aelessons info window, click the triangle to the left of Sharing and Permissions to 
reveal the details of this section.

3 In the Sharing and Permissions section, click the Lock icon ( ), if necessary, in the 
lower-right corner so that you can make changes to the permissions.

4 Click to select a specifi c user or select everyone, then change the Privileges section to 
Read & Write.

5 Click the lock icon to prevent further changes, and then close the window.
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Working with the video tutorials
Your Adobe After Eff ects CS6 Digital Classroom DVD comes with video tutorials developed 
by the authors to help you understand the concepts explored in each lesson. Each tutorial 
is approximately fi ve minutes long and demonstrates and explains the concepts and features 
covered in the lesson.

The videos are designed to supplement your understanding of the material in the chapter. 
We have selected exercises and examples that we feel will be most useful to you. You may 
want to view the entire video for each lesson before you begin that lesson. Additionally, at 
certain points in a lesson, you will encounter the DVD icon. The icon, with appropriate 
lesson number, indicates that an overview of the exercise being described can be found in 
the accompanying video.

0
DVD video icon.

Setting up for viewing the video tutorials
The DVD included with this book includes video tutorials for each lesson. Although you 
can view the lessons on your computer directly from the DVD, we recommend copying 
the folder labeled videos from the Adobe After Eff ects CS6 Digital Classroom DVD to your 
hard drive.

Copying the video tutorials to your hard drive:

1 Insert the Adobe After Eff ects CS6 Digital Classroom DVD supplied with this book.

2 On your computer desktop, navigate to the DVD and locate the folder named videos.

3 Drag the videos folder to a location onto your hard drive.
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Viewing the video tutorials with the Adobe Flash Player
The videos on the Adobe After Eff ects CS6 Digital Classroom DVD are saved in the Flash 
projector format. A Flash projector fi le wraps the Digital Classroom video player and the 
Adobe Flash Player in an executable fi le (.exe for Windows or .app for Mac OS). Note that 
the extension (on both platforms) may not always be visible. Projector fi les allow the Flash 
content to be deployed on your system without the need for a browser or prior stand-alone 
player installation.

The accompanying video fi les on the DVD use the Adobe Flash Video format to make 
universal viewing possible for users on both Windows and Mac OS computers. 

Playing the video tutorials:

1 On your computer, navigate to the videos folder you copied to your hard drive from 
the DVD. Playing the videos directly from the DVD may result in poor quality 
playback. 

2 Open the videos folder and double-click the Flash fi le named PLAY_AECS6videos to 
view the video tutorials.

3 After the Flash player launches, press the Play button to view the videos. 

The Flash Player has a simple user interface that allows you to control the viewing 
experience, including stopping, pausing, playing, and restarting the video. You can 
also rewind or fast-forward, and adjust the playback volume.

A B D E FC

A. Go to beginning. B. Play/Pause. C. Fast-forward/rewind. D. Stop. E. Volume Off /On. F. Volume control.

Playback volume is also aff ected by the settings in your operating system. Be certain to adjust 
the sound volume for your computer, in addition to the sound controls in the Player window.
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Additional resources
The Digital Classroom series goes beyond the training books. You can continue your learning 
online, with training videos, at seminars and conferences, and in-person training events.

Training from the Authors
The authors are available for professional development training workshops for schools 
and companies. They also teach classes at American Graphics Institute including training 
classes and online workshops. Visit agitraining.com for more information about Digital 
Classroom author-led training classes or workshops.

Book series
Expand your knowledge of creative software applications with the Digital Classroom 
training series. Books are available for most creative software applications as well as web 
design and development tools and technologies. Learn more at DigitalClassroom.com.

Seminars and conferences
The authors of the Digital Classroom seminar series frequently conduct in-person 
seminars and speak at conferences, including the annual CRE8 Conference. Learn more at 
agitraining.com and CRE8summit.com.

Resources for educators
Visit digitalclassroombooks.com to request resources for educators, including instructors’ 
guides for incorporating Digital Classroom books into your curriculum.
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What you’ll learn in 
this lesson:
• What types of content you 

can create in After Eff ects

• The properties of the video 
fi les you will be creating 
and importing into After 
Eff ects

• About the various 
broadcast and broadband 
standards that you can 
create content for

Lesson 1

This lesson provides an overview of the various types of motion 
graphics and digital video projects you can create in After Eff ects. 
It’s fi lled with important information that you need to know to 
work eff ectively in this application. If you can’t wait to get started 
using the program, skip over this lesson for now and jump ahead to 
Lesson 2, “Understanding the After Eff ects Interface.” If you jump 
ahead, make sure you come back to review this lesson at a later time.

Starting up
This lesson includes useful background information. If you’d prefer to jump right into 
working with After Eff ects, you should move to the second lesson, which gets you hands-
on right away.

Understanding 
Motion Graphics
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See Lesson 1 in action!

Use the accompanying video to gain a better understanding of how to use some of the features 
shown in this lesson. The video tutorial for this lesson can be found on the included DVD.

Defining motion graphics
Adobe After Eff ects is an industry standard tool for creating motion graphics that are 
used for broadcast television, fi lm, and other motion graphics and video productions. 
After Eff ects is used to create content that appears in presentation graphics and on mobile 
devices. It is a tool for storytelling, creating visually appealing motion graphics that 
integrate into any medium to enhance a presentation, story, image, or mood. 

Television and video graphics
After Eff ects is an important tool for broadcast-design professionals. It is used to create 
original content for interstitial, lower thirds, bumpers, and show openings. Many video 
professionals consider it an essential tool in their daily work. In fact, you can see it at 
networks such as MTV, Spike, truTV, and the Food Network, where it’s used to produce 
stunning, high quality graphics and motion design packages quickly and aff ordably. 

Internet and mobile devices
The Internet and mobile devices are becoming a major entertainment medium. After 
Eff ects high-quality motion graphics are being widely used for online and mobile 
content. Video sharing sites, such as Vimeo.com and YouTube.com, provide content creators 
with access to a wide audience, which creates additional distribution opportunities for 
individuals and organizations alike.

Desktop distribution and presentation graphics
Digital displays such as high-defi nition televisions, monitors, and projectors have created 
new venues for displaying motion graphics. After Eff ects is used to add impact to otherwise 
static slides, charts, and graphs. With the proliferation and aff ordability of high-defi nition 
televisions and other digital displays, many public venues such as: malls, retail stores, 
schools, and even military bases are using motion graphics to both inform and entertain. 

Regardless of how you plan to use After Eff ects, you will fi nd it to be a powerful, well-
rounded tool that, with a little practice, can serve you well.

1
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Digital video basics

Digital video basics
If you want to, you can open After Eff ects and start creating graphics without any 
understanding of how video works. (If you really can’t wait to get started, jump ahead to 
Lesson 2, “Understanding the After Eff ects Interface.”) However, successfully producing 
graphics for video and other media requires that you understand a few technical 
requirements. If you don’t understand these, you’ll merely be pushing buttons and clicking 
checkboxes, so you should take a few minutes to at least get a foundation in digital video. 

When working in After Eff ects, you will want to consider the fi nal destination for 
your project. Will it be used on television, in video, on a mobile device? Knowing this 
information allows you to accurately create your After Eff ects content to match your 
intended destination. Projects for high-defi nition television diff er from those for a portable 
device with a small-screen. Each of these media has its own standards for items, such as 
frame rate, aspect ratio, and bit rate. Understanding these items saves you time and eff ort 
in the production process. 

Understanding video formats
Some video formats are common for professional video production, while others are 
suitable only for broadband or small-screen purposes. There are two main standards used 
for broadcast television, a handful of competing standards for desktop and web video, and 
a series of device-specifi c standards used in mobile handheld devices. Technical standards, 
such as the ones touched upon here, are very complex, and a full description of each one 
is beyond the scope of this book. In general, regardless of the platform for which you are 
creating video content, there are three main properties to keep in mind:

Dimensions: This property specifi es the pixel dimensions of a video fi le—the number 
of pixels horizontally and vertically that make up an image or video frame. This value 
is usually written as a pair of numbers separated by an x, where the fi rst number is the 
horizontal value and the second represents the vertical value, such as 720×480. The 
term Pixel is a combination of the words picture and element and is the smallest individual 
component in a digital image. Whether you are dealing with a still image or working 
with video frames makes no diff erence; everything displayed on-screen is made up of 
pixels. The dimensions of a video or still image fi le determine its aspect ratio; that is, 
the proportion of an image’s horizontal units to its vertical ones. Usually written in the 
following format: horizontal units:vertical units, the two most common aspect ratios seen 
in current video displays are 4:3 and 16:9.

Frame rate: This property specifi es the number of individual images that make up each 
second of video. Frame rate is measured as a value of fps, which is an acronym that stands 
for frames per second. 

Pixel aspect ratio: This property specifi es the shape of the pixels that make up an image. 
Pixels are the smallest part of a digital image, and diff erent display devices such as televisions 
and computer monitors have pixels with diff erent horizontal and vertical proportions. 
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When producing graphics for broadcast television, you have to conform to a specifi c set 
of formats and standards. For example, you need to know whether your graphics will be 
displayed on high-defi nition screens (1080i, 1080p, 720p), standard-defi nition screens, or 
mobile devices because this aff ects the size that you must create your graphics at. Similarly, 
you need to know whether you’re in a region that broadcasts using the ATSC (often still 
called NTSC) or PAL standards, as this aff ects both the size you can create your graphics 
at, and the frame rate and pixel aspect ratio you will need to use. If you are producing 
animation or video for the Web, you’ll need to know the format that the distributing site 
will be using: Flash, Silverlight, h.264, or other, since certain video eff ects don’t work well 
when exported to certain formats. 

ATSC

In the United States, the ATSC, or Advanced Television Systems Committee, has issued 
a set of standards for the transmission of digital television. These standards have replaced 
the older, analog NTSC (National Television Standards Committee) formats. The 
standards embraced by the ATSC include standard-defi nition and high-defi nition display 
resolutions, aspect ratios, and frame rates. All broadcast video and graphics must conform 
to one of the ATSC standards. Information on the various ATSC standards is available on 
their website at ATSC.org.

High-definition television

While high-defi nition (HD) television technology has existed for decades, it wasn’t until 
the beginning of the 21st century that it came to the attention of the average American 
television viewer. The term HD is used to describe video that has a higher resolution 
than traditional television systems, which are called SD, or standard defi nition. There 
are two main high-defi nition standards for broadcast television—720p and 1080i—while 
many televisions, gaming consoles (Playstation 3, Xbox 360, and more) and Blu-ray disc 
players can support a third, 1080p. The letters p and I refer to whether the format uses 
a progressive or an interlaced display method. Interlacing divides each frame of video 
into two separate fi elds. When combined, these two fi elds form a single video frame that 
shows a single image. Progressive display forgoes fi elds and has each individual frame as its 
own unique image. In general, progressive displays are clearer and better defi ned, while 
interlaced displays require less broadcast bandwidth to be transmitted to the viewer. Most 
modern video cameras allow the user to choose whether to record in a progressive or 
interlaced format.

720p: The 720p format has a resolution of 1280 pixels wide by 720 pixels high and 
supports a variety of frame rates, from the 24 fps used by fi lm, through the 30 fps that was 
part of the old NTSC standard, all the way up to 60 fps.

AECS6_06Pass.indb   12AECS6_06Pass.indb   12 5/18/12   1:05 PM5/18/12   1:05 PM



1

13Lesson 1, Understanding Motion Graphics 

Digital video basics

1080p and 1080i: The 1080 formats come in both progressive and interlaced versions 
and, like other modern digital standards; they support a variety of frame rates between 24 
fps and 30 fps. 

You will learn more about the diff erences between progressive display and interlacing later in 
this lesson.

Standard-definition television

Prior to the invention of high defi nition, there was only one standard in the United States, 
NTSC (National Television Systems Committee), which includes settings for both 4:3 
and 16:9 aspect ratios. While technically it has been replaced by the ATSC standards, the 
term NTSC is still used by most video cameras and editing and graphics applications when 
referring to standard-defi nition, broadcast-quality video.

NTSC and NTSC widescreen: Graphics applications designed to produce content for 
broadcast, such as Adobe After Eff ects, Adobe Photoshop, Adobe Illustrator, and more, 
include pre-built settings for creating video projects called presets that correspond with the 
most commonly used broadcast standards. The NTSC presets include settings for both a 
standard (4:3) and widescreen (16:9) aspect ratio. They use the same dimensions, 720 × 480, 
but diff erent pixel aspect ratios, and this is what accounts for the diff erence in shape. 
Devices that comply with the NTSC standard use a frame rate of 29.97 frames per second. 

PAL

PAL, or Phase Alternating Line, is the standard for broadcast television used throughout 
Europe and much of the rest of the world outside of North America. PAL diff ers from 
NTSC in several key ways, including dimensions and frame rate. It uses a frame rate of 25 
fps, which is closer to the 24 fps used in fi lm and, like NTSC, it has both a standard and 
widescreen setting.

PAL and PAL widescreen: In applications such as After Eff ects, the PAL presets 
include both a standard (4:3) and a widescreen (16:9) aspect ratio. Much like their NTSC 
equivalents, they use the same pixel dimensions, in this case, 720 × 576, but each have 
diff erent pixel aspect ratios.

Web and mobile device video: There is no single standard for video on the Web or 
on mobile devices, though there are only a handful of competing audio/video formats. 
QuickTime, Windows Media Video, Flash Video, Silverlight, and H.264 are the main 
video formats. The QuickTime format is controlled by Apple Inc., and for years was the de 
facto standard for web-delivered video. The freely available QuickTime Player is compatible 
with both Windows and Mac OS and is used to view QuickTime Movie (.MOV) and other 
video fi le formats. QuickTime format video is also supported on some mobile devices; most 
notably the Apple suite of phones, iPods and iPads. 
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Windows Media Video, often simply called WMV, is the Microsoft standard made by the 
creators of the Windows operating system. A variation of WMV is used for Silverlight 
video, which is widely used by many professional media organizations, including NBC 
Sports for their live Olympics coverage and Netfl ix for streaming videos. Windows 
Media is also a supported format on some multimedia players and mobile devices, such as 
Windows phones. 

Flash video is the native video format of the Adobe Flash platform, and as such, it is used 
for the distribution of much of the world’s online video content. While the Flash player 
is widely installed on the desktop computers of Internet users, it is not as common on 
mobile devices. In fact, Adobe discontinued development of its mobile Flash Player and 
is recommending the use of HTML5 technology for mobile devices. Even before this, 
some organizations, companies, and other online content creators had begun to move 
their rich-media content away from Flash and onto other platforms, such as HTML5. In 
recent years, the dominance of fl ash video has been challenged by the natively browser-
supported HTML5 video formats, h.264, and OGG Theora. H.264 is a standard for video 
compression derived from the MPEG-4 standard, created and patented by MPEG LA, 
while OGG Theora is its open source alternative. Mobile devices such as the Apple iPod, 
Sony PSP and Microsoft Zune, and some HTML5-compliant browsers support variations 
of H.264, along with many mobile phones and third-party video playback applications, 
such as QuickTime Player, Flash Player, and the VLC Media Player. 

Understanding frame rate and resolution
Video is essentially a series of individual still images that are displayed very quickly, one 
after the other. The frame rate of video is measured by the number of frames recorded or 
played back each second, and it is denoted as fps, an acronym that stands for frames per 
second. Diff erent video standards have diff erent frame rates, and many video standards 
support a variety of diff erent frame rates. As a comparison, American television is 
broadcast at 30 fps, PAL uses 25 fps, and fi lm uses a frame rate of 24 fps.

If you have a background in graphic design, you may be familiar with the term resolution, 
which refers to the pixel density or the number of pixels in a given space. As such, in 
North America, resolution is denoted in pixels per inch or ppi. For example, images 
created for printing in high-quality magazines are usually 300 ppi, while images created 
for use on a web site usually have a resolution of 72 ppi. When working with video, ppi is 
not used to address resolution. When discussing video, the term resolution is used to refer 
to the pixel dimensions of an image: the number of horizontal and vertical pixels that 
make up the actual image. When creating graphics for the Web, these pixel dimensions 
determine the relative size of content to the overall video frame size. 

If you need to create graphics in Photoshop, the default resolution for video graphics is 72 ppi. 
The same is true for web graphics. 
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Understanding transparency

In broadcast video applications, transparency is often referred to as alpha or opacity.

Graphics that are used in video are created using the RGB color mode. Each individual 
pixel is assigned a unique color value consisting of combinations of red, green, and blue. 
Each of these colors is saved to its own color channel. When colors are combined, the 
composite (a full color image) is created. In addition to the color channels of an image, 
some formats can also contain an additional channel that holds information about the areas 
of an image that are transparent. This channel is called the alpha channel. If you also work 
in Photoshop, you may already be familiar with alpha channels, although the meaning 
of an alpha channel in video is somewhat diff erent. In Photoshop, any saved selection is 
called an alpha channel, and you can have up to 99 alpha channels. In After Eff ects, as in 
other applications designed to work with video, the term alpha channel refers specifi cally 
to the transparency of a still image or video fi le. Alpha channels use the 256 shades of 
gray to represent transparency. When looking at an alpha channel in most applications, 
black pixels represent those that are fully transparent, white pixels are fully opaque, and 
gray pixels represent semi-transparent areas. Only some image and video formats support 
saving alpha channels along with the other image information. Commonly used fi le 
formats that can include alpha channels are: Tagged Image File Format (.tiff  ), TARGA 
(Truevision Advanced Raster Graphics Adapter, .tga), QuickTime (.mov), and Flash Video 
(.fl v and .f4v). Alpha channels are automatically created for the transparent areas of native 
Photoshop and Illustrator fi les when they are imported into After Eff ects.

You can create an alpha channel in Photoshop by creating a selection, saving it as an alpha 
channel in the Channels panel, and then saving the fi le in one of the image formats that support 
RGB and Alpha, such as PSD, TIFF, or PNG.

Congratulations, you have completed this lesson!

AECS6_06Pass.indb   15AECS6_06Pass.indb   15 5/18/12   1:05 PM5/18/12   1:05 PM



1 Review

Adobe After Eff ects CS6 Digital Classroom16

Self study
In this lesson, you learned about some of the technical details that aff ect decisions you make 
when creating your After Eff ects projects. As new video, image, and audio formats are 
developed and support for them is added to After Eff ects, you will also want to understand 
these emerging standards. Good sources to keep your knowledge levels up to date include 
the Adobe web site (adobe.com) and forums (adobe.com/support/forums). There are also a wide 
variety of print and online journals that serve all facets of the video and design market. 

Review
Questions
1 What are the names of the two diff erent standards that govern video for American 

broadcast television and European broadcast television?

2 What are the diff erent frame rates for American television, European television, and fi lm?

3 What are some of the areas where After Eff ects is used professionally?

Answers
1 ATSC (Advanced Television Systems Committee) is the name of the set of standards 

that govern American television and PAL (Phase Alternating Line) is the standard used 
in Europe.

2 American television uses a frame rate of 30 fps, European television uses a frame rate 
of 25 fps, and fi lm uses a frame rate of 24 fps.

3 Television production, fi lm, on-line video, mobile video, and presentation graphics 
are all areas where After Eff ects is used.
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What you’ll learn in 
this lesson:
• Working with the main 

panels that are integral to 
using After Eff ects

• Previewing footage fi les 
and composition layers

• Customizing and saving 
panel layouts called 
workspaces

Lesson 2

The After Eff ects interface can seem daunting to the beginning user. 
In this lesson, you will gain an understanding of the key elements of 
the interface and how to work with the various application panels.

Starting up
You will work with several fi les from the ae02lessons folder in this lesson. Make sure that 
you have loaded the aelessons folder onto your hard drive from the supplied DVD. See 
“Loading lesson fi les” in the Starting up section of this book.

See Lesson 2 in action!

Use the accompanying video to gain a better understanding of how to use some of the features 
shown in this lesson. The video tutorial for this lesson can be found on the included DVD.

2

Understanding the 
After Effects Interface
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Understanding and working with menus
After Eff ects has nine menus on Windows and 10 on Mac OS, located at the top of the 
application window that combine with various panels to form the interface of the program. 
Some of the menu names may be familiar to you from other applications, while others may be 
new and unfamiliar. You’ll start with the File menu to open an existing After Eff ects project.

Opening an existing After Effects project
Opening a project in After Eff ects is much like opening a fi le in any other software program. 
In this exercise, you will work with an existing After Eff ects project to help you understand 
the organization and structure of the interface, and you will soon create your own projects.

1 Choose File > Open Project. Navigate to the ae02lessons folder that you copied to 
your hard drive and open the fi le named lesson02_StartingProject.aep.

This project is composed of several diff erent compositions that you will use to explore 
diff erent aspects of the program interface.

When a project is opened, the application remembers the arrangement of the interface from the last time it was used and saved.

2 Choose File > Save As and, if necessary, navigate to the ae02lessons folder on your 
hard drive. Rename this fi le lesson02_StartingProject-working.aep and press Save.

Do not close this fi le; you will need it while working through the exercises in this lesson.
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After Effects menus

The Mac OS includes an Application-specific menu, for commands for hiding and quitting 
the Application. For Mac OS users, this is also used to access the After Effects Preferences 
dialog box. The remaining menus are consistent for Mac OS and Windows users:

File
As in most other applications, you use the File menu for accessing key features of the program 
that deal mostly with creating new files, opening existing files, and importing or exporting 
files. In addition to these common commands, you will also find features for browsing files 
in Bridge, creating incremental saves and collecting files for output.

Edit
As in other programs, use the Edit menu to Copy, Cut, Paste, Delete, and perform other 
editing tasks with the content of your compositions. When working in Windows, this is 
where you can find the Preferences dialog box.

Composition
The Composition menu holds most of the commands you need to create, edit, and 
manipulate compositions. Each composition has its own independent timeline and is the 
space where all animation occurs. From this menu, you can create new compositions, adjust 
or preview comp settings.

Layer
After Effects places each separate media element on its own track, which is called a layer. You 
use the Layer menu to create new layers and edit the properties of existing layers.

Effect
After Effects is basically a motion graphics and compositing program. You use the Effect 
menu to apply layer effects in the application. These effects can be anything from simple 
color corrections and drop shadows to more advanced operations, such as chroma keying, 
particle generation, or explosive simulations.

Animation
The Animation menu contains commands to accomplish both common animation tasks, such 
as adding property keyframes to create animation, and advanced tasks such as adding Easing 
to keyframes or Expressions to properties to automate animation tasks.

View
You use the View menu to control the Composition panel. From the View menu, you 
can zoom in and out, open new preview windows, and set the display properties for your 
composition.

Window
You use the Window menu to access the commands that control the After Effects interface. 
From this menu, you can choose your workspace and open or close the various panels found 
in the application interface. 

Help
The Help menu gives you access to the help functions of After Effects. In addition to the 
standard After Effects Help command, you can also access specific references for the keyboard 
shortcuts and animation presets, as well as have After Effects check for program updates.
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After Effects software versions

After Effects project files are not backwards-compatible, and files created in a newer version 
of the application cannot be opened using an older version of the software. When you open 
an older After Effects project file in a newer version, you receive a warning message and 
you have to use the Save As command to save the file in the newer format. Once a file is 
converted to the latest file format, you are not able to return to using an older version of the 
software for additional edits. For this reason, if several people are working on an After Effects 
project, they all need the same version of the software.

Understanding the After Effects panel system
By default, After Eff ects uses a docked, panel-based interface to organize the work area. 
The entire interface confi guration is called a workspace, and After Eff ects includes a 
variety of pre-built workspaces to accommodate diff erent working styles and tasks that you 
may need to accomplish. You can also set each panel to move or fl oat, independently.

The default After Eff ects workspace is named Standard.
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After Effects panels
The After Eff ects interface is divided into panels, where you will do most of your work. 
Some panels are for previewing footage or animation, and others set options for the tools, 
while others are for creating animation. All the panels in After Eff ects are accessible 
through the Window menu. To help you better understand the panels, we’ve divided them 
into two groups: Primary panels, which you will use more frequently, and Secondary 
panels, which you will use less often.

Primary panels

Composition

The Composition panel is one of the most important panels in After Eff ects. It is the 
preview window and the main animation space that you work in when building an After 
Eff ects project. You can build your animated projects in this panel, and it has features you 
can use to change how your composition previews. Perhaps you want to create, show, 
or hide guidelines. Or maybe you need to isolate the alpha channel of your composition 
so that you can see which areas are transparent and which are opaque. This can all 
be accomplished in the Composition panel. In this exercise, you will work with the 
Composition panel to change the preview resolution of the display and learn how to reveal 
a composition’s alpha channel.

E F G H I J K L M N O P Q R S T U V W

B C DA

A. Rulers Composition. B. Flowchart Selector. C. Selector. D. Composition. E. Always Preview Toggle. F. Magnifi cation. 
G. Guide & Grid Options. H. Toggle Mask & Shape Path Visibility. I. Current Time. J. Take Snapshot. K. Show Snapshot. 
L. Show Channel and Color Management Settings. M. Resolution. N. Region of Interest. O. Toggle Transparency Grid. P. 3D 
View Pop-up. Q. Select View Layout. R. Toggle Pixel Aspect Ratio Correction. S. Fast Previews. T. Timeline. U. Composition 
Flowchart. V. Reset Exposure. W. Adjust Exposure.
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1 With the lesson02_StartingProject-working still open, look in the Project panel and 
double-click on the composition named Viewing Comp Alpha to make it active. This 
makes the composition visible in the Composition panel and also reveals the comp 
timeline in the Timeline Panel.

Double-clicking on any composition in the Project panel makes that 
composition active in both the Composition and Timeline panels.

This composition includes a single layer named cityScene.psd. It was created from a 
Photoshop document that contains transparent areas. The color blue that you can see 
behind the buildings is the background color of the composition itself. It is visible 
only in the area where the Photoshop document is transparent. In video programs, 
transparency is often referred to as Alpha, or the Alpha Channel. You can change the 
display of the Composition panel to confi rm which areas are transparent.
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2 With the Viewing Comp Alpha composition active, click on the Show Channel and 
Color Management Settings button ( ) located at the bottom of the Composition 
panel. From the list that appears, choose Alpha.

All the RGB color information has been hidden because you are showing only the 
Alpha channel of the composition. This leaves only a black-and-white representation of 
the comp. When viewing alpha information, the black area represents fully transparent 
sections while the white areas are fully opaque and gray areas are semi-transparent. 

Viewing a composition’s alpha information like this is a good way of confi rming which parts of a layer are fully 
transparent and which are not.

3 Now that you have seen that the background of the image is fully transparent, return 
to the standard display by clicking on the Show Channel and Color Management 
Settings button and choosing RGB from the list.
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4 Click on the Resolution/Down Sample Factor Pop-up button at the bottom of the 
Composition panel and choose Quarter from the list that appears.

You can use this menu to vary the quality of the Composition panel’s preview. Note 
that this aff ects only the display of the composition, not the way it outputs when you 
render your projects. Down sampling can be necessary to create longer and faster 
previews when you are working with complex compositions that might otherwise 
take a long time to preview.

Notice that this preview appears much more pixelated, or blocky, than the original, 
which was displaying at full resolution. At the quarter resolution setting, the program 
only renders every fourth pixel, and then scales up the result to fi t in the Composition 
panel. This allows it to build the preview much faster and can be helpful for reviewing 
complex animations. This lowered resolution is for preview purposes only; it does not 
aff ect the fi nal output quality when you output your fi le.

At the Quarter setting, the original composition’s resolution is reduced by three quarters, but is still displayed at 
its original size, which results in the image degradation you see here.

5 Click the Resolution/Down Sample Factor Popup button at the bottom of the 
Composition panel and this time choose Half.

The image appears to be a higher quality than when it was generated at quarter 
resolution in the previous step. This is because it is now rendering every other pixel to 
build this preview, resulting in double the quality of the previous setting, which was 
previewing every fourth pixel.
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6 Click on the Resolution/Down Sample Factor Pop-up button one last time and 
choose Auto from the list that appears.

Notice that the menu now displays the setting of Full, but that it is surrounded by 
parentheses. The parentheses indicate that the display is currently using the Auto 
setting. The Auto setting adjusts the resolution of the Composition panel to render 
only the pixels necessary to preview the composition at the current zoom level.

The Auto setting gives the best image quality, and at the same time avoids rendering unnecessary 
pixels by actively adjusting the Composition panel’s preview based on the Zoom percentage 
you are currently using. For example, if you are viewing a comp at 25%, the Auto settings will 
set the Resolution/Down Sample factor to Quarter to preserve system resources and provide a 
faster preview.

7 Choose File > Save, or use the keyboard shortcut of either Ctrl+S (Windows) or 
Command+S (Mac OS) on the keyboard. Do not close this fi le, you will need it later 
in the lesson.

You should quickly look at two other panels before getting into another exercise in 
the lesson.

Effect Controls

The Eff ect Controls panel is not part of the default workspace, but 
is automatically revealed whenever you add an eff ect to a layer in 
your composition. It can also be opened from the Window menu.
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Use the Eff ect Controls panel to edit eff ects you have applied to layers in your 
Compositions. While this panel is not a part of the Standard workspace,  you can access 
it using the Window menu by choosing Window > Eff ect Controls. To access eff ects 
you have applied to a layer, you must fi rst select the layer by clicking it in either the 
Timeline or Composition panels, or by using a keyboard shortcut. The layer numbers in 
your active composition correspond to the digits on the number pad if you are using a 
full-size keyboard. If you do not have a layer selected, or if the selected layer doesn’t have 
any eff ects applied to it, this panel remains blank. While it is not a part of the Standard 
workspace, the panel will be added the fi rst time you apply an Eff ect to any layer. You 
will use the Eff ect Controls panel many times throughout this book, but especially in 
Lessons 5, 7, and 9.

Flowchart

The Flowchart panel is an organizational tool, a way of visualizing the content of your compositions as objects.

The Flowchart panel provides an organizational chart, or a graphical representation of 
the relationship between compositions and footage items in your After Eff ects project. 
The Flowchart panel is a passive tool that displays the relationship between elements in 
your project; you cannot use it to change those relationships. This panel can come in 
handy when working with very complex animations that may contain multiple nested 
compositions. To view the fl owchart for a Composition, you must fi rst select that 
composition in the Project panel or make it the active Comp in the Timeline, then chose 
Composition > Composition Flowchart. You will not use the full fl owchart panel in 
this book, but will instead work with a companion feature, the Mini-Flowchart view, in 
Lesson 7, “Working with Audio,” when you begin working with audio fi les.
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Footage

When working in After Eff ects, you will use the Footage panel to preview individual 
pieces of footage. Double-clicking on any piece of imported media in your Project panel 
causes it to preview in the Footage panel. You can also use the drop-down menu at the top 
of the panel to choose footage to preview.

In this exercise, you will open a footage panel in order to use it to preview an imported 
video fi le.

A B C D E F G H I J K L M N O P Q R

A. Time Ruler. B. Always Preview Toggle. C. Magnifi cation. D. Guide & Grid Options. E. Current Time. F. Take Snapshot. 
G. Show Snapshot. H. Show Channel and Color Management Settings. I. Region of Interest. J. Toggle Transparency Grid. 
K. Toggle Pixel Aspect Ratio Correction. L. Reset Exposure. M. Adjust Exposure. N. Set IN Point to Current Time. 
O. Set OUT Point to Current Time. P. Duration. Q. Ripple Insert Edit. R. Overlay Edit.
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1 With the lesson02_StartingProject-working project still open, locate the Forest.mov 
fi le in the Project panel. It is in the folder named sourceFiles.

2 Double-click the Forest.mov fi le in the Project panel. This opens the Footage panel 
allowing you to preview the video clip.

3 Press the spacebar on your keyboard to preview the animation in this video fi le. 

Once it has played through one time, you can press the spacebar again to stop the 
playback. Notice that the Footage panel has many of the same buttons and menus that 
are present in the Composition panel.

You can also click on the Time Ruler to stop the playback as well. Once stopped, you can move 
the Time Marker, the yellow wedge on the Time Ruler, backward and forward to preview the 
animation.

4 In the Project panel, double-click on the footage item named cityScene.psd to open it 
in the footage panel. 

An alternative method for viewing footage is to select the footage item from the pull down-menu 
at the top of the Footage panel.
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From the Magnifi cation ratio drop-down menu, choose Fit up to 100% to fi t the 
footage item in the panel. Note that you can always view a footage item or composition 
at a magnifi cation higher than 100%; however, when viewed at values much greater 
than actual size (100%), footage and comps tend to appear pixelated and degraded.

Fit up to 100% can be used with the Composition, Footage, and Layer panels to auto-adjust their magnifi cation setting.

5 Click the Show Channel and Color Management Settings button located at the 
bottom of the Composition panel. From the list that appears, choose Alpha. You can 
view the individual channels for footage items in the panel the same way you do when 
previewing compositions.

6 Return to the standard display by clicking the Show Channel and Color Management 
Settings button and choosing RGB from the list.

Click the Composition panel’s tab and choose the Transform Properties comp for 
the list that appears. Alternately, you can double-click on the Transform Properties 
composition in the Project panel. 

7 Choose File > Save, or press Ctrl+S (Windows) or Command+S (Mac OS) on the 
keyboard. Do not close this fi le, you will need it later in the lesson.
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Layer

Once added to a Composition in the Timeline panel, a footage item becomes a layer inside 
of that comp. In fact, any item that is added to a Composition becomes a new layer; this 
can include audio, video, text, solids, lights, cameras, and more. One of the aspects you 
will get used to when working in this application is that every item in the Timeline panel 
is its own independent layer. Double-clicking a footage layer in the Composition panel 
opens it in the Layer panel. A footage layer contains a fi le that has been imported into 
the Project panel, as opposed to an item that is created in After Eff ects, such as text or a 
composition. Some eff ects, such as paint, motion tracking, and stabilization, cannot be 
applied in the Composition window but must instead be applied in the Layer panel. Here, 
you will explore the Layer panel.

Next, you will learn how to jump back and forth between your composition and layer panels.

A B C D E F G H I J K L M N O P Q

X
W
V
U
T
S
R

 A. Time Ruler. B. Always Preview Toggle. C. Magnifi cation. D. Guide & Grid Options. E. Current Time. F. Take Snapshot. 
G. Show Snapshot. H. Show Channel and Color Management Settings. I. Region of Interest. J. Toggle Transparency Grid. 
K. Toggle Pixel Aspect Ratio Correction. L. Comp Button. M. Reset Exposure. N. Adjust Exposure. O. Duration. P. Eff ect/
Layer Controls Editing drop-down menu. Q. Show rendered result for current view. R. Set OUT Point to Current Time. S. Set 
IN Point to Current Time. T. Alpha Boundary/Overlay Opacity. U. Alpha Boundary/Overlay Color. V. Toggle Alpha Overlay. 
W. Toggle Alpha Boundary. X. Toggle Alpha.
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1 With the lesson02_StartingProject-working project still open, double-click the 
Viewing Comp Alpha composition in the Project panel. 

2 In the Timeline panel, double-click the cityScene.psd layer to reveal it in the Layer panel. 

Like the Footage panel, the Layer panel is not a part of the Standard workspace, but is 
added to the interface when you double-click on a footage layer. This panel can also 
be opened by choosing Window > Layer.

Notice that just like in the Footage panel, many of the buttons and menus here are 
similar to those of the Composition panel. From the Layer panel, you can preview the 
alpha or other color channels of a layer, or adjust a layer’s duration. 

Double-clicking a footage layer opens it in the Layer panel. However, when you double-click a 
text layer, it allows you to edit the text. When you double-click a composition layer, it reveals 
the composition’s timeline in the Timeline panel.

3 Click the Comp Button ( ) at the bottom of the Layer panel to return to the 
composition that is associated with this layer. This reveals the Composition panel by 
moving it in front of the Footage and Layer panels in the interface.

4 Choose File > Save or press Ctrl+S (Windows) or Command+S (Mac OS) on the 
keyboard to save the project. Do not close this fi le, you will need it later in the lesson.

Project

The Project panel contains references to all the footage fi les (video, audio, and images) that 
you have imported into your After Eff ects Project. It also contains all the Compositions 
that you have created in your current project. The media items are denoted as references 
because of the way the program treats imported fi les. When imported, your media fi les 
remain in their original location on your hard-drive; After Eff ects creates a link to them. 
If these fi les are modifi ed outside After Eff ects, the application generates a new preview 
and updates your project accordingly. This linking system is helpful because you can 
still manipulate imported objects in their original programs, such as editing an image in 
Photoshop. While very useful, linking fi les in this way can also cause problems: if you 
move, rename, or delete your original media fi les, After Eff ects will lose the link, and it 
will be unable to display the content. 
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When working with imported media fi les in After Eff ects, you should always remember 
where the fi les are located and what their names are, because your project fi les need to be 
able to locate the objects you import in order to display them.

FED G H

A B C

A. Thumbnail preview. B. Search text fi eld. C. Columns. D. Interpret Footage. E. Create a new folder. 
F. Create a new Composition. G. Color depth. H. Delete selected project items. 

1 With the lesson02_StartingProject-working project still open, choose Window > 
Workspace > Reset “Standard.”

Choose Yes in the confi rmation dialog box that appears, to confi rm that you want to 
reset the Standard workspace to its original confi guration.

2 Click on any part of the Project panel to select it and make it the active panel. You can 
tell that a panel is active when it has an orange outline around it. 

Press the tilde (~) key on your keyboard. The tilde key acts as a full screen toggle, 
enlarging the active panel to full screen size or returning it to normal size if it has 
already been enlarged.

3 Notice that once expanded to full-screen mode, the Project panel reveals several 
previously hidden columns. Currently, the items in the panel are listed in alphabetical 
order, but this can be adjusted so that they are listed in a hierarchy determined by any 
of the columns.
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Click on the title bar for the Type column and notice that the panel’s content reorders 
so that similar fi le types are placed near each other.

By default, the content of the Project panel is organized into an alphabetical list, but you can change this to suit your 
preferences.

4 Again press the tilde (~) key on your keyboard to return the Project panel to its 
normal size in the workspace.

Changing the display size of the panel doesn’t aff ect the project, so there is no need to 
save the fi le again, but keep the fi le open because you will need it again later in this 
lesson.

Render Queue

The Render Queue, not the File > Export command, is how you render out your project as a video fi le so you can view it or take it 
to another application.

Once you have completed your animation, you use the Render Queue panel to produce, 
or render, your project to deliver it for fi nal output. Whether you are producing content 
for broadcast or broadband distribution, the Render Queue is your tool for exporting. You 
can use this panel to add multiple compositions, set the render options and destinations for 
each, and then render the compositions sequentially. In this book, you will use the Render 
Queue in Lesson 12, “Outputting After Eff ects Projects.”
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Timeline

The Timeline panel is one of the main panels used for creating animations. Each 
composition has its own independent Timeline panel, where you can animate layer and 
eff ects properties, position layers in time, and change the layer blending modes. 

When working with two-dimensional layers, the stacking order of the layers controls 
which layers appear farthest back, or behind, the other layers. 

The Current Time Indicator, also called the playhead, is the red vertical line that runs 
perpendicular to the Time Ruler. It indicates the current frame that is being displayed, 
moving as the animation or composition is played. 

The default display of the Timeline panel is the layer bar mode. It displays the composition 
time as a Time Ruler across the top of the panel, while layer names and properties are 
displayed to the left. The layer bar mode can also be switched so that the panel displays 
the Graph Editor, an advanced tool for animation that allows for more precise control of 
animated properties. Here, you will work with the Timeline.

You will reveal a composition in the Timeline and Composition panels, and change the 
stacking order of its layers to change the entire appearance of the composition.

A B F G IC D E H J K L M N

OP Q R

A. Current Time. B. Search Field. C. Composition Mini Flowchart. D. Live Update. E. Enable Draft 3D. F. Hide “Shy” 
Layers. G. Enable Frame Blending. H. Enable Motion Blur. I. Brainstorm. J. Auto-keyframe. K. Graph Editor. L. Current Time 
Indicator (playhead). M. Work Area Bar. N. Add Composition Marker. O. Expand/Collapse Layer Switches Panes. P. Expand/
Collapse Transfer Controls Panes. Q. Expand/Collapse In/Out/Duration/Stretch Panes. R. Zoom In/Zoom Out Timeline.

1 With the lesson02_StartingProject project still open, double click the Working with 
the Timeline composition in the Project panel to make it active.

In the Timeline panel that is revealed, notice that this composition includes three 
diff erent layers.

The fi rst layer is named Star Outlines and has the same Composition icon ( ) that 
you see next to some of the items in the Project panel. This is a nested composition, 
or a comp that is placed inside of another comp. You will learn more about nested 
compositions as you progress further through this book. The second layer is named 
cityScene.psd and is composed of a single Photoshop document, while the third and 
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fi nal layer is named Double Single numbers.mov and contains a single imported video 
fi le.

The current layer stacking order makes it diffi  cult to see the city and background 
video fi les because the white lines on top are so overpowering. You can fi x this by 
adjusting the order.

2 Click and hold on the Star Outlines layer and drag-and-drop it below the Double 
Single number.mov layer.

Just like in graphics programs like Photoshop and Illustrator, layers can be dragged above or below each other in 
the display to change their stacking order.

Look in the Composition panel and notice that the cityScene.psd layer is now located 
above the white lines, leaving them visible only in the areas where the cityScene layer 
is transparent. 

As you can see, the stacking order of layers in the Timeline panel is directly related to 
the way they display in the Composition panel.

3 Choose File > Save or press Ctrl+S (Windows) or Command+S (Mac OS). 

4 Close the project by choosing File > Close Project. 

Understanding the workspace
The organization and positioning of all the panels on-screen is called the workspace. After 
Eff ects comes equipped with a series of preset workspaces that you can use. After Eff ects 
displays certain panels depending upon the workspace selected, and they are named based 
upon common tasks you might need to perform. Some of these default workspaces are: 
All Panels, Animation, Minimal, Motion Tracking, Paint, Standard, Text, and Undocked 
Panels. When you run After Eff ects for the fi rst time, the application displays the Standard 
workspace.

Viewing and hiding panels 
To modify your workspace, you can open, hide, move, resize, fl oat, or dock panels. This 
functionality makes the After Eff ects interface customizable to meet your preferences 
and working style. After deciding which panels you want to display, close any panels you 
will not need and open the ones you plan to use. Next, you will work with a variety of 
application panels to customize and then save your own custom workspace.
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You do not need to open a project to complete this section of the lesson.

1 Choose Window > Workspace > Animation to change the current workspace. The 
Animation workspace has several common tools that you can use when animating 
your work, and you can customize it to meet your needs.

2 If it is not already active, click the Info panel’s tab to activate it and bring it to the 
front of its panel group. Click the X at the top of the Info panel to hide it. This leaves 
the Audio panel active in this group. Click the X icon to also close the Audio panel.

3 Choose Window > Align to open the Align panel. It appears in the bottom-right 
corner of the interface, directly below the Eff ects & Presets panel. 

4 Click the X icon in the tab of the Eff ects & Presets panel to close it. This causes the 
Align panel to move. 

In the next section, you will reconfi gure the workspace so the Align panel is placed in 
a more convenient area of the workspace.

Docking and undocking panels
After Eff ects panels are docked to the sides of the application window and also to each 
other. This creates a very stable, interlocked interface that can scale to fi t a wide range of 
screen resolutions. Occasionally, you might fi nd that the default docked confi guration is 
not advantageous. In such cases, you can change the default by docking and undocking 
panels to suit your work habits. A situation in which you may need to undock a panel or 
multiple panels in the applications is when you are working with system confi gurations 
that make use of multiple computer monitors.

1 Click the tab at the top of the Align panel. Press and hold the Ctrl (Windows) or 
Command (Mac OS) key on your keyboard while dragging the Align panel to the 
center of the screen. This removes the panel from the docked interface, making it an 
undocked, or fl oating, panel. 

If you are using a multiple monitors, you will need to use the Undocked Panels workspace to 
freely position the panels across your screens. When working with a single display, undocked 
panels often create more problems than they solve by obscuring the rest of the interface and hiding 
important areas of your compositions from view.

2 Click the Align panel’s name tab and drag the panel toward the Smoother panel at the 
top-right corner of your interface. Because you are no longer holding down the Ctrl 
(Windows) or Command (Mac OS) key, you will notice that a gray and purple overlay 
now appears as you move the panel around the screen. This is called a drop zone, and 
it highlights areas where you can drag and drop your panel to dock it.
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Docking and undocking panels

3 Position the Align panel toward the top of the Smoother panel. The top section of the 
drop zone becomes highlighted. The highlight appears when your mouse is hovering 
right below the Smoother panel’s name tab. Release the mouse while this section 
is highlighted to position the panel between the Preview and Smoother panels as a 
separate, individual panel.

Dock the Align panel so that it rests above the Smoother panel.

Using drop zones

Drop zones are a unique feature of the After Effects panel interface. They make it easier to use 
the docked panels by providing you with visual cues as you drag panels to rearrange them. 

A

B

B

C A

As you drag a panel around the interface, a drop-zone overlay appears above the current 
panel group that your cursor is hovering over. Different sections of the drop zone become 
highlighted to show you what your new panel configuration will be. If either section on 
the sides (labeled “A” in the figure) illuminates, the panel that you are repositioning will 
be placed to the side of the currently highlighted panel, creating a new, independent panel 
group vertically. The same is true for the top and bottom of the drop zone (labeled “B” in the 
figure), except this creates a new panel group horizontally. The third possibility is to release 
your mouse while hovering over the center of the drop zone (labeled “C” in the figure); this 
groups the panel that you are moving with the existing panel group, creating a new tab.

AECS6_06Pass.indb   37AECS6_06Pass.indb   37 5/18/12   1:05 PM5/18/12   1:05 PM



2 Resizing panels

Adobe After Eff ects CS6 Digital Classroom38

Resizing panels
In addition to hiding, opening, docking, and undocking panels, the After Eff ects interface 
lets you easily resize docked panels so they take up more or less space on the display. 

1 Place the cursor on the dark-gray, vertical dividing line between the Composition and 
Project panels. The cursor changes to a double arrow ( ) when it is hovering over the 
dividing line.

A double-arrow resize cursor appears between the panels enabling you to resize them.

2 Click and drag the dividing line toward the Project panel to increase the size of the 
Composition panel.
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Saving a custom workspace

3 Position the cursor on the dark-gray, horizontal dividing line between the 
Composition and Timeline panels. Drag the dividing line down to shrink the 
Timeline panel and make the Composition panel larger. 

Resize the panels to make the Composition panel larger.

Saving a custom workspace
You can save modifi cations you make to a workspace and save them as a new, customized 
workspace. Custom workspaces allow you to show only the panels you require. Here you 
will save a custom workspace.

1 Choose Window > Workspace > New Workspace to open the New Workspace dialog 
box.

2 Name your workspace Animation-Modifi ed and click OK to save it.

3 Choose Window > Workspace. You now see the name Animation-Modifi ed among 
the list of available workspaces. Additionally, you should note that it currently has a 
check mark next to it indicating that it is, in fact, the currently active workspace.

4 Click in any section of the After Eff ects interface to close the Window menu without 
changing the workspace.
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Resetting the workspace
When you create a custom workspace, you are actually modifying the confi guration 
of the workspace you originally started with. For example, in the preceding lesson you 
started in the Animation workspace. After adding panels, removing panels, and saving the 
custom workspace, the initial workspace does not automatically reset back to its original 
appearance. However, you can quickly return to the original workspace and reset it to its 
default confi guration. 

1 Choose Window > Workspace > Animation to return to the Animation workspace. 
Notice that it still looks exactly like the Animation-Modifi ed workspace you created 
in the preceding part of the lesson.

2 Choose Window > Workspace > Reset ‘Animation’ to open the Reset dialog box.

3 Confi rm the workspace reset by clicking Yes; the Animation workspace resets to its 
original appearance.

You must always confi rm that you want to reset a workspace to its default appearance.

The reset command always resets the current workspace. For example, if you are currently in the 
Animation workspace, the command is called Reset “Animation.” If you are in the Standard 
workspace, the command will say Reset “Standard.”
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Setting After Eff ects Preferences

Setting After Effects Preferences
Preferences are used to control many aspects of the After Eff ects application, including 
the way the interface displays, the way it works with external fi les, and even your system’s 
memory (RAM) behind-the-scenes. The location of the Preferences dialog box is diff erent 
on the Mac OS and Windows operating systems. Depending on your OS, you will 
access the Preferences dialog by choosing After Eff ects > Preferences (Mac OS) or Edit > 
Preferences (Windows).

After Effects Preferences

The Preferences dialog box is divided into several categories. Understanding each section of 
this dialog will help you quickly modify the application to fit your specific needs.

General: Contains the commands that don’t easily fit into any other group. In this section, 
you can control undo states, whether to show tool tips, and whether to use the operating 
system shortcut keys.

Previews: Specifies the settings for all preview operations. In this section, you can set Audio 
Preview duration, Adaptive Resolution quality, and whether to use hardware acceleration to 
aid in previews.

Display: Mostly used to set options for how motion paths are displayed, but you can also 
specify whether to use Project panel thumbnails and Info panel rendering displays.

Import: Contains options for setting the default image duration of imported still images and 
embedded alpha channels, and how to handle drag-and-drop import.

Output: Specifies options for segmenting files on output and whether or not to use a default 
filename and folder.

Grids & Guides: Specifies the color and style of grid and guide lines, as well as the screen 
size the action and title-safe grids should encompass.

Labels: Sets the default color and name for labels used in the Project and Timeline panels.

Media & Disk Cache: Enables and sets the location of disk and media cache folders. The 
cache is a storage area for conformed media files and other temporary files that are needed to 
optimize the After Effects workf low.

Video Preview: Specifies the external FireWire device, such as a camera or deck, to output 
video to during preview operations. Professionals generally use an external monitor to check 
color, motion, and safe margins during graphics or video work. 

Appearance: Specifies the options for controlling the appearance of the interface and color 
highlighting of labels and masks.

Auto-Save: Allows After Effects to save a copy of your project file at set intervals. You can 
specify the interval for the Save command as well as the number of versions of your project 
file the application will create before it begins to overwrite them.

Memory and Multiprocessing: Sets a value for the amount of RAM to use for other 
applications. In general, the greater the amount of RAM that After Effects and the other 
applications of the Creative Suite can utilize, the better the applications perform.

Audio Hardware: When using a system with multiple audio input or output devices, you 
can specify which device is used by After Effects when playing back or capturing sounds.

Audio Output Mapping: Specifies how sound is played back or mapped to the system’s 
selected audio devices.
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Changing the default Undo levels
You can use the Undo command to take back, or undo, a mistake. In After Eff ects, you 
can step back through several errors one step at a time. By default, After Eff ects lets you 
undo the previous 32 steps you performed, but you can modify this limit using your 
preferences.

1 Choose Edit > Preferences > General (Windows) or After Eff ects > Preferences > 
General (Mac OS) to open the Preferences dialog box.

2 Change the Levels of Undo from the default 32 to 50.

Change the Levels of Undo in the Preferences dialog box.

The Levels of Undo that your computer can support are based on the amount of RAM available 
on your system. The greater the value that you set, the higher the RAM requirements. If you 
are working on a computer with a limited amount of RAM, you should keep this at the default 
setting, or possibly lower it.
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Enable Auto-Save
Unfortunately, computer programs can crash and you can lose your work. You should get 
in the habit of saving your projects frequently to avoid losing your work if your software 
crashes or power to your computer is interrupted. After Eff ects has an Auto-Save feature, 
which automatically saves a copy of your project fi le as you work. You can set how often 
the Auto-Save runs and how many copies of your fi le it saves.

1 If it is not already open, choose Edit > Preferences > General (Windows) or After 
Eff ects > Preferences > General (Mac OS) to open the Preferences dialog box.

2 Click the Auto-Save category on the left.

3 Click on the checkbox labeled Automatically Save Projects to enable the program to 
automatically create backups of your project fi le at its default settings.

4 Click OK to close the Preferences dialog box.

The default value for Auto-Save is every 20 minutes and a maximum of 5 project versions. You can 
adjust these amounts to fi t your personal needs. Because this feature is not saving over your original 
fi le, but instead making a copy, you can set the amount for Save Every to the minimum value you 
can tolerate. Keep in mind that when the Auto-Save function runs, it can disrupt your work.

Once you enable the Auto-Save function, After Eff ects will create a folder in the 
same directory as your project fi le named Adobe After Eff ects Auto-Save. The auto-
save process creates enumerated backup copies of you project fi le. So a project named 
Moving Logo.aep would be backed up as Moving Logo auto-save1.aep in this auto 
save folder. To access this backup folder in case of a crash or to return to a previous 
project state, choose File > Open in After Eff ect, navigate to the auto-save folder and 
open the desired project normally.
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Self study
Now that you have created a new workspace that emphasizes tools for animation, you can 
build one that focuses on the Timeline. Create an interface with only the Composition 
and Timeline panels and save it as a new custom workspace. Now that you are comfortable 
with opening and hiding panels, you can create new workspaces to accommodate your 
specifi c workfl ow.

Review
Questions
1 How do you reset the current workspace?

2 What is the advantage of saving a custom workspace?

3 How do you access the Preferences dialog box to make changes to the number of 
Undo levels in After Eff ects?

Answers
1 Choose Window > Workspace > Reset “Current Workspace Name.”

2 Custom workspaces allow you to show only the panels you require for the specifi c task 
you are currently working on in After Eff ects.

3 You can access the Preferences dialog box by choosing Edit > Preferences > General 
(Windows) or After Eff ects > Preferences > General (Mac OS).
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What you’ll learn in 
this lesson:
• Creating and Organizing 

Projects

• Importing Images and 
Video Files

• Previewing Files

• Locating Missing Assets

Lesson 3

To be a successful After Eff ects artist, you need to understand the 
diff erent types of media you will work with, and know how to 
keep them organized. You also need to know how to work with 
and manipulate a variety of media types. After Eff ect provides you 
with tools to import, organize, edit and preview almost any type of 
digital media.

Starting up
You will work with several fi les from the ae03lessons folder in this lesson. Make sure that 
you have loaded the aelessons folder onto your hard drive from the supplied DVD. See 
“Loading lesson fi les” in the Starting up section of this book.

See Lesson 3 in action!

Use the accompanying video to gain a better understanding of how to use some of the features 
shown in this lesson. The video tutorial for this lesson can be found on the included DVD.

3

Media Management—
Working with Images, 
Audio, and Video
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What is Media Management?
A very important aspect of the motion design process, one that is also often overlooked is 
the concept of Media Management. Simply put, Media Management is how you organize 
or manage the media that you are working with in a project. There are two equally 
important aspects of Media Management. The fi rst is how you manage the media that you 
are working with on your hard drive, and the second is how you organize the diff erent 
media references that you import into After Eff ects.

You will look at how and where you need to store your original media fi les fi rst. For 
the sake of portability, performance, and safety, it is usually best to store your media on 
an external hard drive. The two standard connection types for external hard drives are 
FireWire (400 and 800) and USB 2.0. Most video editors (especially those who work on 
the Mac OS) will probably recommend a FireWire drive due to its higher sustained bus 
speed, but because After Eff ects doesn’t reference media in the same way as video editing 
applications, either connection type should work for you. What is more important than the 
type of connection that your disk drive uses is that you always keep it organized. There has 
long been a truism in the design and animation industries that the most important things to 
remember about working with fi les are where they are and what they’re called. 

Projects, compositions, and layers: An overview
The project fi le is at the heart of all the work you do in Adobe After Eff ects. The project 
fi le contains links to all the media that you are using in your compositions as well as the 
compositions themselves. While a project can contain many diff erent media elements and 
compositions, only one project can be open at a time in After Eff ects. You can think of the 
project fi le as a container, a briefcase for carrying around the content of your animations. 
Project fi les in After Eff ects are kept very small because media are not embedded or added 
to the project fi le. Instead, the project fi le contains links or references to any piece of 
media (audio, video, or stills) that you import. This creates a situation where the project 
is dependent on the media fi les remaining unchanged and in the same relative location on 
your hard drive. So if you have a situation that requires you to move your projects from 
one computer to another, you must move not only the project fi le but also the original 
media that are stored on your hard drive. Not every element you will use is external, 
though; compositions, shapes, lights, cameras, and other content that you create in After 
Eff ects are stored as part of the project fi le.

Compositions, often called comps for short, are a unique feature of After Eff ects, though they 
are similar to sequences, which can be found in video editing and animation programs such as 
Adobe Premiere or Apple Final Cut Pro. They are one of the key program features that you 
will become used to working with as you begin to master After Eff ects. Each composition—
you can have multiple compositions in each project—represents an independent Timeline and 
can contain any combination of video, audio, still images, shape layers, and other elements. 
Compositions can even contain other compositions (this is called nesting compositions), and 
this feature is the key to creating more complex animations and composites. When creating 
compositions, you want to set their properties for the format that you plan to output to. 
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Creating a new project

If you have a video editing background, this is probably going to be completely contrary 
to what you have been taught, but it is actually the standard way of working in After 
Eff ects. So if you are creating graphics for standard-defi nition broadcast television, you 
will want to create your comps to the NTSC standard, and if you are creating graphics 
for display on a computer screen, you will want to build comps that match your expected 
screen resolution. 

If you have used other graphics applications such as Photoshop, Illustrator, or Flash, 
layers may be a familiar concept to you. If you are new to the concept of layers, then, 
like compositions, they are a feature of After Eff ects that you will become more familiar 
with as you work your way through the lessons in this book. You cannot edit media in a 
composition directly; instead, each piece of media that is placed into a composition exists 
on its own track, called a layer. Each layer has properties such as position, opacity, and 
duration that you can adjust individually or in tandem with other layers. In addition to 
a layer’s built-in editable properties, you have the ability to add a wide variety of eff ects 
from the Eff ect menu to any layer, and it is by manipulating the properties of layers and 
their eff ects that you can create your animations.

Creating a new project
Technically, every time you open After Eff ects, the program creates a new blank project for 
you. A project isn’t a very impressive thing on its own; it’s really just a container that stores 
the references to the media fi les you are working with, along with the compositions you 
create and any original content, such as cameras, lights, and shapes. A single project may 
contains links to dozens, perhaps hundreds of diff erent fi les that reside on your hard drive.

AE
project

PS AI PS Mov Avi JpgPS
Photoshop
document

Illustrator
document

Photoshop
document

Quicktime
Movie

Photoshop
document

Video for
Windows

JPEG Image
Sequence

Flowchart representation of a typical After Eff ects project.

A new, untitled project is automatically created whenever you start After Eff ects and when 
you close the active project. You will need to create a new project if you have closed the 
default one or if you want to completely start from scratch.
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Importing media files
One of the great strengths of After Eff ects is the wide variety of media that you are able to 
use with it. After Eff ects supports standard-format still images, audio, and video fi les. In 
this part of the lesson, you will create a new After Eff ects project and learn to import two 
very common media types: audio and video. In addition to common formats such as .tiff , 
.jpg, .aif, and .mp3, the program off ers enhanced support for certain native fi le formats 
such as Photoshop (.psd) and Illustrator (.ai).

1 Create a new, empty After Eff ects project by choosing File > New > New Project, 
and reset your workspace to the standard layout by choosing Window > Workspace > 
Standard, then choosing Window > Workspace > Reset “Standard.” Click Yes in the 
dialog box that prompts you to confi rm that you want to reset the workspace.

2 Choose File > Import > File to open the Import File dialog box.

There are many ways to open the Import File dialog box. You can use a keyboard shortcut, 
Ctrl+I (Windows) or Command+I (Mac OS); you can right-click in any empty area of the 
Project panel and select Import > File from the context menu that pops up; and you can double-
click any empty area of the Project panel to immediately open the dialog box.

3 In the Import dialog box, navigate to the ae03lessons folder that you copied from the 
DVD included with this book. In the ae03lessons folder, continue to navigate to the 
video folder and click on the Double Single numbers.mov fi le. You can either double-
click on the fi le or click the Open button to import it. Depending upon the speed of 
your computer, there may be a brief pause where a loading bar appears, and then the 
reference to the video fi le appears in the Project panel.

By default, After Eff ects uses the fi le names of your original footage items in the Project panel. 
You can change this by right-clicking the item and choosing Rename from the menu.
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Importing media fi les

4 The Project panel is one of many panels that must share space on the screen, so after 
the video fi le has been imported into your project, it may be very diffi  cult to see if the 
Project panel is small. To fi x this problem, After Eff ects off ers a toggle function that 
allows you to fi t any panel to the full size of the screen. Click on the Project panel to 
make it active. The panel displays an orange highlight around it when it is active. Press 
the tilde (~) key on your keyboard to enlarge the panel to full-screen size. 

Press the tilde (~) key to enlarge the currently active panel to full-screen. 
Press it again to return to the normal panel layout.

Press the tilde (~) key again when you want to return to the standard workspace.

5 Again choose File > Import > File. In the Import dialog box, navigate to the audio 
folder located inside the ae03lessons folder and double-click house beat.aif. 

6 Open the Import dialog box one last time, navigate to the images folder inside the 
ae03lessons folder, and click the fi le named distressedBG.tif. This time you will 
import more than one fi le, so press and hold the Ctrl (Windows) or Command 
(Mac OS) key on your keyboard and click the Mini Cooper at Night.jpg and 
Washington City Street.jpg fi les to select them as well, then click Open.

7 Choose File > Save As. Name your fi le Lesson3-Working.aep and save it in the 
ae03lessons folder on your hard drive.

Do not close this fi le; you will need it in the next part of the lesson.

The keyboard command for the Save As function is Ctrl+Shift+S (Windows) or 
Command+Shift+S (Mac OS).
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Organizing the Project panel 
You can’t keep your project panel at full-screen size all the time, or you would never be 
able to get any work done. And even with the Project panel at this size, it may still need a 
few modifi cations so you can work more effi  ciently. By default, the panel displays all your 
imported fi les in alphabetical order, but this often is not be the best approach to organizing 
your media. What you want to do is make it as easy as possible to fi nd the media you need 
exactly when you need to use it. To accomplish this, you will adjust the display of the 
Project panel.

Modifying the column displays
The Project panel is organized using columns. Each one holds important information 
that may be useful to you while working on your projects in After Eff ects. The fi les are 
organized alphabetically by name as indicated by the arrow at the top of the panel. You 
can click on any other column header to reorganize the content in the panel. You can also 
hide or change the size of each column at any time.

1 Because you don’t need the File Path column for this project, you will hide it in the 
column header display. With the Project panel highlighted, press the tilde (~) key on 
your keyboard to maximize the panel to full-screen size. Right-click the File Path 
column header, and from the menu that appears, choose Hide This.

You should now have the following columns visible: Name, Label, Type, Size, Media 
Duration, and Comment. The Label column isn’t identifi ed by name, but appears as a 
Tag icon ( ).

You can reveal a column in almost exactly the same way that you hide it, right-clicking on any 
label. You may have also noticed that there are other columns that you can add to the Project 
panel, such as Date, Frame Rate, Duration, and Tape Name. The Project panel can display much 
of the meta-data that can be saved with media fi les.

2 You will now resize a column. Place your cursor at the dividing line between the 
Name and Label columns. As mentioned previously, you will notice that the label 
column isn’t identifi ed by name but by a Tag icon. When you hover over this dividing 
line, the cursor changes: it becomes a double-headed horizontal cursor. Click and drag 
the dividing line to the right to increase the size of the Name column.
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Importing media fi les

3 Increase the width of the Type, Size, and Comment columns as well.

Do not close this fi le; you will need it in the next part of the lesson.

Increase the width of the columns.

Creating folders and subfolders
Just as in real life, folders are a helpful tool for organizing the content of your Project panel 
in After Eff ects. They provide an excellent tool for effi  ciently managing your media assets. 
Folders are very fl exible and can be created in the root of the Project panel or even nested 
inside other folders. 

1 Click the Create a new Folder button ( ) at the bottom of the Project panel to create a 
new untitled folder. 

Click the Create a new Folder button.

2 The folder name is highlighted, so rename it Video, then press Enter (Windows) or 
Return (Mac OS).

If you deselect the folder before naming it, you can always right-click on the highlighted folder and 
choose Rename from the context menu. Additionally, you an click on any item to highlight it and 
then press the Enter (Windows) or Return (MacOS) key on your keyboard, making the items 
name editable.
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3 Click the Double Single numbers.mov fi le and drag it onto the Video folder. When 
the folder becomes highlighted, release your mouse button to add the video fi le to 
it. The folder may expand automatically, but if it doesn’t, click the arrow that now 
appears to the left of the Video folder’s name to reveal the contents of this folder.

Click on the arrow to reveal the folder’s contents.

4 Deselect the Video folder by clicking any empty area of the Project panel, create two 
additional folders, and name them Audio and Images, respectively. Make sure that 
the Audio folder is deselected before creating the Images folder.

You should deselect each folder before creating the next one; otherwise, the new 
folder will be placed inside the highlighted one, thus creating a sub-folder. 

5 Select all three image fi les—Washington City Street.jpg, Mini Cooper at Night.jpg, 
and distressedBG.tif—by fi rst clicking on any one of them. Hold down the Ctrl 
(Windows) or Command (Mac OS) key on your keyboard and then click to add the 
other two fi les to your selection. 

6 Click and hold any one of your highlighted fi les and drag it to the Images folder to 
move all the selected image fi les simultaneously. If necessary, click the triangle to the 
left of the Images folder to display its contents.

Drag the house beat.aif fi le into the Audio folder, and if necessary, click the triangle to 
the right of the Audio folder to display its contents.
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7 Right-click (Windows) or Ctrl+click (Mac OS) on an empty area of the Project panel 
and choose New Folder from the context menu that appears. Rename this folder 
Background Images. When you are fi nished renaming it, the folder jumps toward 
the top of the panel, as it is still organized alphabetically by name.

8 Click on the Background Images folder and drag it into the Images folder. Then drag 
the distressedBG.tif fi le into this folder. If necessary, click the triangle to the left of the 
Background Images folder to display its contents. 

This folder nesting is a useful way of providing even better organization in the Project 
panel and is probably very similar to the kind of structure you use with folders on your 
own computer.

With the Project panel highlighted, press the tilde (~) key on your keyboard to 
minimize the panel and return to the Standard workspace layout.

Nesting fi les and folders keeps your Project panel organized.

9 Save your fi le by choosing File > Save.

Do not close this fi le; you will need it in the next part of the lesson.

The keyboard command for the Save function is Ctrl+S (Windows) or Command+S (Mac OS).
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Renaming files

Renaming fi les in After Eff ects is a little diff erent from other programs you may be used 
to working with. In most programs you can just click on a highlighted fi le to rename it. 
Trying this approach in After Eff ects doesn’t work. Here you will change the name of the 
Washington City Street.jpg fi le.

1 With the Project panel highlighted, click the tilde (~) key on your keyboard to 
maximize it to full screen size. Then click the fi le named Washington City Street.jpg 
to highlight it.

2 Press the Enter (Windows) or Return (Mac OS) key on your keyboard. The fi lename 
becomes editable.

3 Change the fi lename by placing your cursor at the end of the word Street and adding 
-daytime at the end so that it now reads as Washington City Street-daytime.jpg, then 
press Enter/Return to complete your text editing and commit the change.

Changing the name of a fi le in the Project panel does not aff ect the actual fi le on your computer. 
Like all video editing programs, After Eff ects has a non-destructive workfl ow. Nothing you do 
in After Eff ects changes the original fi les on your hard drive. The one exception to this is when 
you use Edit Original commands, which are designed to open the original source fi les that you 
imported in external editing applications such as Photoshop and Illustrator.

4 Press the tilde key on your keyboard to minimize the Project panel and return to the 
Standard workspace.

5 Save your fi le by choosing File > Save or by pressing Ctrl+S (Windows) or 
Command+S (Mac OS) on the keyboard.

Do not close this fi le; you will need it in the next part of the lesson.

Previewing footage
Media that has been imported into a project is often called footage. You can preview 
footage by using the Footage panel, which is one of the panels hidden by default. You can 
easily display the Footage panel by choosing Window > Footage: (none).

1 Display the Footage panel by choosing Window > Footage: (none). 

This will open an empty panel that is standing by to preview a piece of footage from 
the Project panel.

The Footage panel automatically opens when you double-click on any item in the Project panel. 
If you have previously used the Footage panel, the name of the last item you viewed is displayed 
next to the panel name in the Window menu.
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Previewing footage

Previewing stills and video
You preview still images and video fi les in almost exactly the same way. The only major 
diff erence between the two is that video footage has a time ruler so that you can adjust its 
duration.

1 In the Project panel, double-click on Double Single numbers.mov to load it into the 
Footage panel. The text on the tab of the Footage panel changes to “Footage: Double 
Single numbers.mov,” to indicate that you are previewing a specifi c footage item.

2 With the Footage panel highlighted, press the spacebar on your keyboard to begin the 
video preview.

3 Once you see the animation begin to play, you can press the spacebar again to stop the 
preview.

Press the spacebar to start and stop the animation.

If you click and drag the playhead along the time ruler, you move backward or forward through 
the video fi le. You can use this technique, called scrubbing the playhead, to navigate quickly to a 
specifi c time in the fi le. Remember that this is not a real-time preview; the speed at which you 
scrub the playhead controls the playback speed.

4 Double-click the Mini Cooper at Night.jpg fi le to see how easy it is to preview still 
images as well.

Do not close this fi le; you will need it in the next part of the lesson.

As is the case when working with the Project panel, you can always press the tilde (~) key while the 
Footage panel is highlighted in order to expand it to full screen mode, giving you a larger preview area.
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Previewing audio
Just like video and still image fi les, you can preview audio fi les using the Footage panel. 
While an audio fi le is loaded into the panel in the same way that any other fi le is (by 
double-clicking on it), pressing the spacebar does not cause the audio to play in the same 
way that video does. To preview audio fi les, you will use a RAM preview.

1 In the Project panel, double-click on house beat.aif to load it into the Footage panel. 
Unlike when you previewed the video and image fi les, the Footage panel appears as a 
blank, gray screen.

The name of the audio fi le displays in the Footage panel tab and you see a time ruler for the 
duration of the audio fi le. Since it is an audio fi le, there is no visual preview.

2 With the Footage panel still highlighted, locate the Preview panel on the right side of 
the workspace and click the RAM Preview button.

A RAM Preview will play audio 
that is in the footage panel or on 
the timeline.

You can also initiate a RAM Preview by choosing Composition>Preview>RAM Preview with 
the Footage panel highlighted. 

3 After a brief pause, the audio fi le begins to play. When you are happy with the 
preview, click anywhere in the interface to stop the playback.

4 In addition to creating a RAM preview of your composition you can also preview 
audio while scrubbing the playhead. 

If it is not already there, move the playhead to the beginning (0;00;00;00) of the 
composition. Hold down the Ctrl (Windows) or Command (Mac OS) key on your 
keyboard and click on the playhead and drag it back and forth across the timeline to 
scrub it. You will now hear audio previewing as the playhead moves.

5 Save your fi le by choosing File > Save or by pressing Ctrl+S (Windows) or 
Command+S (Mac OS) on the keyboard. 

Do not close this fi le; you will need it in the next part of the lesson.
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Previewing footage

Trimming a video clip
When video clips are being prepared for use in After Eff ects, the editor will often include a 
little extra padding at the beginning and end called handles. Another possible situation may 
occur when you have a long video clip and only want to use a small portion of it in your 
project. The process of shortening a video clip is called trimming, and you do it by adjusting 
the clip’s IN and OUT points. You should note that After Eff ects is not a video editing 
program, so the only editing feature available is the ability to trim clips. For more precise or 
complex editing jobs, you can use a dedicated application such as Adobe Premiere Pro.

1 In the Project panel, double-click on Double Single numbers.mov to load it into the 
Footage panel. The entire clip is one minute long, but you are going to trim it down 
so that only a 20-second portion in the middle is used.

2 With the playhead at the beginning of the clip, click the Current Time button ( ) 
at the bottom left of the Footage panel. The Go to Time dialog box appears. 

The Go to Time dialog box.
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3 Type the number 2000 into the time text fi eld and click in any empty area of the 
Go to Time dialog box. After Eff ects automatically converts the number to its time 
code equivalent, so 2000 becomes 20 seconds (0;00;20;00). Click OK to go to the 
20-second mark on the time ruler.

Understanding time code

Time code is used in video editing and motion graphics programs to keep track of your 
position along a Timeline, tape, or any time-based medium. It is easily identified as a series of 
four numbers separated by either colons or semicolons. As seen in the example below, starting 
on the left, the numbers represent Hours : Minutes : Seconds : Frames.

00;00;00;00{ {

{{ FramesMinutes

SecondsHours

A time code.

Counting hours, minutes, and seconds is done the same way you would with a standard 
clock, except that the counting starts at zero instead of one. The one variable with time 
code is the number of frames that make up a second, which is based on the frame rate of the 
media you are dealing with. Depending on the Composition settings, you could be using 
the American television standard of 30 FPS (frames per second), the European standard of 
25 FPS, or the film standard of 24 FPS. Time code is used to provide a discrete address to 
each frame of video.
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Previewing footage

4 Click the Set IN point to current time button ( ) at the bottom of the Footage panel. 
This moves the start of the clip to the current position of the playhead.

The Set IN Point button changes the beginning of the footage item to match the current position of the playhead.

5 Again, click the Current Time button and in the Go to Time dialog box, type 4000 and 
click OK to move the playhead to the 40-second (0;00;40;00) mark of the time ruler.
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6 Click the Set OUT point to current time button ( ) to move the Out Point of the 
video clip to the current position of the playhead and fi nish trimming this clip.

Click the Set OUT Point Current Time button.

7 Save your fi le by choosing File > Save or by pressing Ctrl+S (Windows) or 
Command+S (Mac OS) on the keyboard.

Do not close this fi le, you will need it in the next part of the lesson.

Importing multiple files
Using the Import File command allows you to select multiple fi les simultaneously, but 
only if they reside in the same folder. Using this command is a little troublesome if you 
need to import fi les that reside in diff erent folders on your hard drive. To address this 
problem, After Eff ects uses a command called Import Multiple Files. 

1 Choose File > Import > Multiple Files to open the Import Multiple Files dialog box.

You can also use the keyboard shortcut Command+Option+I (Mac OS) or Ctrl+Alt+I 
(Windows) or right-click in any empty area of the Project panel and choose Import > Import 
Multiple Files.
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Importing multiple fi les

2 Navigate to the images folder; press and hold down the Ctrl (Windows) or Command 
(Mac OS) key on your keyboard, and click on fountain.jpg and Washington 
Church.jpg to select them both. Click the Open button to import them. The fi les are 
imported and the Import Multiple Files dialog box opens again to allow you to select 
additional fi les.

3 Navigate to the audio folder and click on Subliminal.mp3 to highlight it. Click Open to 
import this fi le as well. Again, After Eff ects imports the fi le and the dialog box reopens.

4 Navigate to the video folder, hold down the Command (Mac OS) or Ctrl (Windows) 
key on your keyboard, and click on forest.mov and pingpongnode.mov to select them 
both. Click Open to import these fi les. Again, the dialog box opens.

5 Click Done to close the dialog box, as you no longer need it. The Project panel now 
shows that all the fi les that you imported have been added to your project.

New files

Whenever you import a fi le, it appears highlighted in the Project 
panel. When you import multiple fi les, they all appear highlighted.

6 With the Project panel highlighted, press the tilde key on your keyboard to maximize 
it to full-screen size.

7 Move the video fi les (forest.mov and pingpongnode.mov) into the Video folder. 
Move the audio fi le (Subliminal.mp3) into the Audio folder, and move the image fi les 
(fountain.jpg and Washington Church.jpg) into the Images folder.

Your Project panel should now match the fi gure below. 
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With the Project panel highlighted, press the tilde (~) key on your keyboard to 
minimize the panel and return to the Standard workspace layout.

Enlarge the Project panel, then organize your fi les for easier access.

8 Save your fi le by choosing File > Save or by pressing Ctrl+S (Windows) or 
Command+S (Mac OS) on the keyboard.

Do not close this fi le, you will need it in the next part of the lesson.

Importing Photoshop and Illustrator files
Adobe Photoshop and Illustrator are two industry-standard applications for creating pixel-
based and vector graphics, respectively. While you can export a wide variety of fi le formats 
from either of them for import into After Eff ects, it is best to import the native fi le formats 
that both applications produce. When importing native Photoshop (.psd) and Illustrator 
(.ai) fi les, you can take full advantage of the integration between the applications. You 
can import layered Photoshop and Illustrator fi les either as footage or as compositions. If 
you import a fi le as footage, After Eff ects automatically fl attens the layers; however, if you 
choose to import it as a composition, the fi le is converted into a new composition in After 
Eff ects and the application imports each layer as an individual footage item so that they can 
be animated separately. The process is virtually identical for both types of fi les.
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Importing Photoshop and Illustrator fi les

1 With the Project panel highlighted, press the tilde (~) key on your keyboard to 
maximize the panel to full screen mode.

Choose File > Import > File. Navigate to images > photoshop & illustrator, and select 
the fi le Archaic Wheels.ai. 

2 From the Import As drop-down menu, choose Composition – Retain Layer Sizes. 
Click the Open button to import the fi le.

From the Import As drop-down menu, choose Composition – Retain Layer Sizes.

When you import a Photoshop or Illustrator fi le as a composition, the Project panel has a new 
composition automatically added to it that is named for your fi le, and a new folder that holds the 
individual footage items that make up the new composition. 
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Composition versus Composition — Retain Layer Sizes

When you import native Photoshop and Illustrator files into After Effects, an often-
misunderstood setting is the Import As feature. The difference isn’t technically in how 
the file is imported, but actually has to do with how After Effects arranges the layers in 
the file when it converts the file into a composition.. Regardless of which one you choose 
(Composition or Composition – Retain Layer Sizes), you end up with a new composition and 
a folder that contains each individual layer from your file. The difference isn’t in how After 
Effects brings in your files; it is in how it sets up the anchor point for each imported layer. 

Composition.

When using the Composition setting, After Effects looks at the boundary of the layered 
file that is being imported and sets the anchor point for each layer to the center of the file, 
regardless of the content of each layer. When importing a Photoshop file, the center point 
is calculated based on the document size, while with an Illustrator file, the center point 
is set based on the contents of the file. This setting can be very helpful when you have a 
symmetrical composition and you want to transform every layer in relation to the image’s 
central axis. 

Composition – Retain Layer Styles.

When using the Composition – Retain Layer Sizes option, After Effects takes a different 
approach to assigning anchor points. With this setting, the anchor point of each layer is based 
only on the content of each layer. This setting is usually more beneficial when dealing with 
artwork that is asymmetrical or when you want to transform each layer separately on its own axis.

3 Click the Create a new Folder button ( ) at the bottom of the Project panel to create 
a new folder. Name the new folder Imported Comps, then press Enter (Windows) 
or Return (Mac OS) to exit the folders name fi eld. Drag the Archaic Wheels 
composition and Archaic Wheels Layers folder into it. If necessary, click the reveal 
training to the left of the folder name to reveal its contents.

4 Click the Imported Comps folder to highlight it. Choose File > Import > File, 
navigate to images > Photoshop & Illustrator, and select the fi le GrungyBG.psd. 
Choose Composition in the Import As drop-down menu. 

Click Open to go to the secondary PSD Import dialog box.
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Importing image sequences

5 In the dialog box, make sure that the radio button for Editable Layer Styles is enabled. 
Click OK to import the fi le. The new Composition and its Layers folder is imported 
right into the Imported Comps folder.

The Import options dialog box.

6 Save your fi le by choosing File > Save or by pressing Ctrl+S (Windows) or 
Command+S (Mac OS) on the keyboard.

With the Project panel highlighted, press the tilde (~) key on your keyboard to 
minimize the panel and return to the Standard workspace layout.

Do not close this fi le; you will need it in the next part of the lesson.

Importing image sequences
Image sequences can be produced from a wide range of programs and also from devices 
such as scanners and digital cameras. While there is some variation in the naming 
convention for the images in a sequence, they generally begin with a fi lename followed 
by a number and then the fi le extension—for example, image01.jpg. When you select an 
image in a sequence, you can have After Eff ects search the folder for other images with 
similar names and import them as if they were part of a video fi le.

1 With the Project panel highlighted, press the tilde (~) key on your keyboard to 
maximize the panel to full screen mode.

Click the Images folder to highlight it, and then click the Create New Folder button 
at the bottom of the Project panel. Name the new folder Image Sequences, then 
press Enter (Windows) or Return (Mac OS).

2 With the Image Sequences folder highlighted, choose File > Import > File or press 
Ctrl+I (Windows) or Command+I (Mac OS) to open the Import File dialog box.

3 Navigate to images > time lapse sequence and click on the fi rst fi le in the folder, 
highway_0001.jpg, to select it.
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4 Confi rm that the JPEG Sequence checkbox is enabled at the bottom of the dialog box 
and click the Open button.

Make sure JPEG sequence is enabled in the Import fi le dialog box.

5 The fi les are imported and placed in the Project panel as a single entry named 
highway_[0001-0068].jpg.

With the Project panel highlighted, press the tilde key on your keyboard to minimize 
the panel and return to the Standard workspace layout.

Double-click the image sequence to preview it in the Footage panel. 
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Importing image sequences

6 If necessary, click the Magnifi cation ratio pop-up menu at the bottom left of the panel 
and choose Fit up to 100% from the menu that appears. This resizes the preview to fi t 
inside the Footage panel up to a maximum magnifi cation of 100%.

When set to Fit up to 100%, the video preview will adjust whenever you resize the footage panel.

The Fit up to 100% option is also available when working in both the Composition and 
Layer panels.

7 Press the spacebar on your keyboard to preview the sequence. You can press the 
spacebar again at any time to stop the playback.

The preview created by pressing the spacebar is not a real-time preview—at least it isn’t the fi rst 
time it plays. A green bar appears at the top of the time ruler as you preview the fi le. This is an 
indication that the program is rendering the video fi le for playback. The second time you preview 
the footage, the rendering is complete and you experience the playback in real time.

8 Save your fi le by choosing File > Save or by pressing Ctrl+S (Windows) or 
Command+S (Mac OS) on the keyboard.

Do not close this fi le, you will need it in the next part of the lesson.
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Importing After Effects compositions
So far in this lesson, you have imported individual still images, video, audio, and even 
image sequences. In addition to all these fi le types, you can import entire projects into 
other After Eff ects projects. This option is necessary when you need to move or share 
compositions or footage between multiple projects. In many other applications, you 
would just use a copy-and-paste command, but since you cannot open multiple fi les 
simultaneously in After Eff ects, another solution is needed. This is why you have the 
ability to import entire After Eff ects projects into another.

1 With the Project panel highlighted, press the tilde (~) key on your keyboard to 
maximize the panel to full screen mode.

Highlight the Imported Comps folder in your Project panel and choose File > Import 
> File, or press Ctrl+I (Windows) or Command+I (Mac OS), to open the Import File 
dialog box. 

2 Navigate to the AE Comps folder and select Spectral Background.aep. The Import As 
menu automatically sets itself to Project. Click Open to import the fi le. 

The entire project, including all the links to its imported media, and everything else 
that was in the imported fi les’ Project panel, are now a part of your current project 
and are stored inside of a folder named for the project fi le. In this case, the imported 
project contains a single Composition, and it is called Spectral Background.
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Importing After Eff ects compositions

3 With the Project panel highlighted, press the tilde key on your keyboard to minimize 
the panel and return to the Standard workspace layout.

Click the reveal triangle to expand the Spectral Background.aep folder. Double-
click on the Spectral Background composition to preview it in the Composition and 
Timeline panels.

Preview the Spectral Background composition by 
double-clicking the fi le in the Project panel.
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4 Compositions must be rendered fi rst before you can view them in real time. Click the 
RAM Preview button in the Preview panel to the right. The preview begins building, 
which is indicated by the green bar at the top of the Timeline. Once After Eff ects has 
fi nished building the preview, it begins automatically from the beginning. Depending 
upon the speed of your computer, it may take a few minutes. Faster computers with 
more RAM will speed your work with After Eff ects.

The duration of the composition preview is based on the amount of RAM on your system, 
which is why it is called a RAM preview. If you don’t have enough RAM, you may not be able 
to preview the entire Timeline at once. If necessary, you can increase the duration of the RAM 
preview by reducing the resolution of the composition in the Resolution/Down Sample Factor 
drop-down menu at the bottom of the Composition panel.

5 Save your fi le by choosing File > Save or by pressing Ctrl+S (Windows) or 
Command+S (Mac OS) on the keyboard. Do not close this fi le, you will need it in the 
next part of the lesson.

Locating missing files
When you import a fi le, After Eff ects creates a link to the original media fi le on your hard 
drive. This link is what you see in the Project panel. These fi les are linked and not actually 
a part of the project itself. If anything happens to the original fi le, i.e., it is deleted, moved, 
or renamed, this will cause a problem. When you attempt to open a project, After Eff ects 
checks the media links to ensure that they are all still intact, and if it encounters a problem 
will display a warning dialog telling you how many fi les are currently missing.

The number of missing fi les will vary depending on the project you are attempting to open.

To fi x this problem you must relink the missing footage by replacing the original linked 
footage with itself. To fi nd your missing fi les:

1 Click OK to close the initial warning dialog.

2 Locate one of the missing footage items in the Project panel. They will be easy to 
identify by the Color Bar icon ( ) to the left of the footage name.

3 Right-click on any missing footage item and from the menu that appears, choose 
Replace Footage > File.

4 When the Replace Footage File dialog box appears, navigate to the folder that 
contains the missing fi le that corresponds to this footage item. The name of the fi le 
should be visible in the dialog box’s title bar. 
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Using the Interpret Footage dialog box

5 Highlight the missing fi le and click Open. After a brief pause while your computer 
analyzes the folder’s content and relinks the missing fi les it fi nds here, a confi rmation 
dialog will appear informing you that previously missing fi les have be found. 

The number of recovered fi les will vary depending on the number of 
missing items After Eff ects was able to locate.

Click OK to close this dialog box.

If all your fi les still have the same names and are in the same relative folder locations 
as when they were imported, this one replace operation should locate all your missing 
footage items. If not, you will have to repeat this process several times to locate all 
missing fi les. In general, it is far easier to locate your missing media fi les when they 
are simply moved and not renamed. If your footage items have been deleted, there is 
nothing After Eff ects can do to assist you. Your only course of action will be to recreate 
or restore the items from a backup copy of your hard-drive or media fi les.

Using the Interpret Footage dialog box
When you import a piece of footage, After Eff ects analyzes the fi le and uses a set of 
built-in rules to determine attributes such as pixel aspect ratio, alpha channel type, frame 
rate, and color profi le, and it uses this information to determine how the fi le should be 
displayed. It uses these built-in rules to make a best guess, which is often correct, and 
you can happily go about the rest of your work. However, when the program interprets 
this information incorrectly, issues can occur with the appearance of your footage. The 
Interpret Footage dialog box allows you to set these footage attributes manually. The 
settings you have access to in the dialog box vary depending on the type of fi le and the 
information it contains. For example, one setting for audio fi les is how many times they 
loop, which wouldn’t be an issue with still images. 

Looping an audio or video file
The house beat.aif fi le that you imported earlier in this lesson is only 30 seconds long, 
which is actually not uncommon for audio that is intended for use as a loop. By default, all 
imported audio and video fi les are set to loop only once, but you can change that in the 
Interpret Footage dialog box.

1 If necessary, click the reveal triangle located to the left of the Audio folder to reveal 
its contents, click the house beat.aif fi le, and look at the fi le properties displayed at the 
top of the Project panel. The duration of the fi le reads 0;00;30;00, indicating that it is 
30 seconds long.
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2 Right-click (Windows) or Ctrl+click (Mac OS) on the house beat.aif fi le, and from 
the context menu that appears, choose Interpret Footage > Main. This opens the 
Interpret Footage dialog box. 

The keyboard shortcut for the Interpret Footage dialog box is Command+Option+G (Mac OS) 
or Ctrl+Alt+G (Windows). Remember to highlight the fi le in the Project panel before using the 
keyboard command.

3 Locate the Loop property at the bottom of the dialog box. Type 2 as the new 
Loop property.

Set the Loop property to 2.

4 Click OK to close the Interpret Footage dialog box with your new settings. With the 
fi le still highlighted, look at the fi le properties at the top of the Project panel. The 
duration of the fi le now reads 0;01;00;00, double its former length.

5 Save your fi le by choosing File > Save or by pressing Ctrl+S (Windows) or 
Command+S (Mac OS) on the keyboard.

Do not close this fi le, you will need it in the next part of the lesson.

AECS6_06Pass.indb   72AECS6_06Pass.indb   72 5/18/12   1:05 PM5/18/12   1:05 PM



3

73Lesson 3, Media Management—Working with Images, Audio, and Video 

Using the Interpret Footage dialog box

Using Remember Interpretation
At some point, you will want to apply the exact same type of interpretation to multiple 
fi les. This is easily accomplished by using the Remember Interpretation and Apply 
Interpretation commands.

1 Right-click on the house beat.aif fi le in your Project panel. Choose Interpret Footage 
> Remember Interpretation from the context menu that appears. This command 
stores the footage interpretation settings of the current fi le in memory.

2 Right-click on the Subliminal.mp3 fi le and choose Interpret Footage > Apply 
Interpretation. This command applies the currently stored footage interpretation 
settings to a new footage item.

3 Save your fi le by choosing File > Save or by pressing Ctrl+S (Windows) or 
Command+S (Mac OS) on the keyboard.

Do not close this fi le, you will need it in the next part of the lesson.

Changing Alpha Channel type

If you use only Photoshop to create your images, then you will probably never have a 
problem with the way After Effects reads your alpha channels. However, if you use other 
programs or rely on stock or royalty-free artwork, then you may run into a problem where 
the programs pick the wrong alpha channel type. This incorrect interpretation usually results 
in black or white halos around the transparent edges of your imagery, but you can use the 
Interpret Footage dialog box to fix this problem. 

Because Photoshop was used exclusively to prepare the pixel-based artwork in the project files 
for this lesson, none of the imported images here require you to change the alpha channel 
type. However, the instructions below will help you if you ever run into this problem.

1 Right-click on the fi le for which you want to change the alpha channel type, and choose 
Interpret Footage > Main.

2 In the Interpret Footage dialog box, click the radio button next to the type you want 
After Eff ects to use. 

Note that when switching to the Premultiplied – Matted With Color option, the two 
most common colors to matte with are black and white. Click on the color swatch to the 
right and use the Color Picker that appears to select the matte color.
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Using the Collect Files command to consolidate files
Throughout this lesson, you have imported footage from diff erent locations. Because of 
the nature of the lesson and how fi les are organized on the DVD that comes with this 
book, all your media has come from the same root folder, but this isn’t always the case. 
Many times you may fi nd yourself importing from diff erent folders and even diff erent hard 
drives. You may also run into the problem of wanting to transfer an entire project and all 
the footage needed to recreate it to another designer or to back it up for archival purposes. 
This is a situation where you can use the Collect Files command.

1 Choose File > Collect Files to open the Collect Files dialog box.

The Collect Files dialog box.

2 Confi rm that the Collect Source Files menu at the top of the dialog box says All, and 
click the Collect button to open the Collect fi les into the folder dialog box that allows 
you to choose the location in which to save your collected project folder.

3 In the Collect fi les into folder dialog box, the default folder name should be 
Lesson3-Working folder. Choose your desktop as the destination and click Save. As 
the Collect Files operation runs, you see a status bar on-screen.

4 When the Collect Files operation completes, minimize or hide After Eff ects to view 
your desktop, and double-click the Lesson3-Working folder you saved there. Notice that 
the Collect Files operation created a copy of your After Eff ects project, a folder that stores 
copies of all the footage that was in the project, and a text fi le that stores information 
about the Collect operation, such as what footage and compositions were collected.

5 Double-click on the (Footage) folder and notice that the structure of your Project 
panel was used to set the order of fi les in this folder. If you double-click on the Images 
folder, you see that this organization carries through to the subfolders as well.

6 Close the folders and return to After Eff ects. Choose File > Save, then File > Close.

Congratulations! You have completed the lesson.
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Review

Self study
Create a new project and import a variety of diff erent footage types. Create folders to 
organize the footage to make it easier to locate and use.

Review
Questions
1 What is the advantage of the Import Multiple Files command over the Import File 

command?

2 What does the Remember Interpretation command do?

3 What are the two most common colors to matte an alpha channel with when using a 
premultiplied alpha channel?

Answers
1 The Import Multiple Files command reopens the Import dialog box after every 

import operation so that you can import from diff erent folders. 

2 When you highlight a piece of footage, the Remember Interpretation command is 
used to store the settings for the Interpret Footage dialog box so that you can apply 
these settings to another footage item using the Apply Interpretation command.

3 The two most common colors to use for matting a premultiplied alpha channel are 
black and white.
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What you’ll learn in 
this lesson:
• Taking a project from 

a blank screen to a 
completed animation

• Creating new 
Compositions and 
adjusting Comp settings

• Animating Layer transform 
properties

• Parenting layers to ease 
repetitive animation tasks

Lesson 4

Now that you understand the interface and how to organize your 
media, you will animate your fi rst compositions in After Eff ects.

Starting up
You will work with several fi les from the ae04lessons folder in this lesson. Make sure that 
you have loaded the aelessons folder onto your hard drive from the supplied DVD. See 
“Loading lesson fi les” in the Starting up section of this book.

See Lesson 4 in action!

Use the accompanying video to gain a better understanding of how to use some of the features 
shown in this lesson. The video tutorial for this lesson can be found on the included DVD.

4

Creating Animation 
in After Effects
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Setting up
As you work in After Eff ects, you will inevitably open and close many panels, depending 
on the type of work you are doing. However, when working through the projects in this 
book, it is important to have an interface that matches the lessons. To this end, you should 
always reset your workspace to the preset Standard confi guration.

1 In After Eff ects CS6, choose Window > Workspace > Standard to set your current 
workspace confi guration.

2 Choose Window > Workspace > Reset Standard to reset the standard workspace in 
case you have modifi ed it at some point. 

Understanding the animation workflow
When working in After Eff ects it is important to understand that this program is usually 
used to animate or composite assets that are created in other applications. It’s safe to say 
that most professional After Eff ects users are often expert users, of other graphic and design 
programs. They often make use of Adobe Photoshop, and sometimes Illustrator, along 
with a variety of packages that can create 3D graphics such as 3D Studio Max, Maya, or 
Cinema 4D to create the media they will work with in After Eff ects.

In order to speed the learning process, many of the lessons in this book have you start with 
a pre-built project. This lesson will be a little diff erent, in that it will take you through the 
entire workfl ow, from creating a composition, to importing a variety of media content, 
and fi nally through the animation and previewing process. In this lesson, you will work 
with a variety of media assets to produce a logo animation for a fi ctitious corporation 
named Dison Worldwide.

Creating and working with compositions
In Adobe After Eff ects, compositions are where you do all your animation and compositing 
work. Inside of a composition, each piece of media resides on its own layer. Think of 
each composition as an independent Timeline in your project. In addition to the assorted 
types of footage that you import into After Eff ects, compositions can also contain other 
compositions, allowing for both an organized design environment and very complex 
animation projects. Placing one composition inside of another is called nesting compositions, 
and you will learn more about it in this lesson. In this fi rst part of the lesson, you will create 
the initial composition to hold the animated Dison Logo that you will create.
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Creating and working with compositions

Creating a new composition
As mentioned previously, projects themselves really don’t have any editable properties; it is 
in the compositions that you set everything from frame rate to pixel dimensions to aspect 
ratio. Compositions can be imported from other After Eff ects projects, automatically 
created when you import a layered Photoshop or Illustrator fi le, or created from scratch as 
you will do here.

1 Choose Composition > New Composition from the menus at the top of the After 
Eff ects interface to open the Composition Settings dialog box. You can also use the 
keyboard shortcut, Ctrl+N (Windows) or Command+N (Mac OS).

2 In the dialog box, change the default composition name to Dison Intro. From the 
Preset drop-down menu, select NTSC DV. Choosing the preset automatically sets the 
width, height, pixel aspect ratio, and frame rate. 

The presets in After Eff ects will match most standard video projects. If you have a project 
with specifi cations that do not match an existing preset, you should choose the closest one 
and modify it.

3 Confi rm that the Resolution is set to Full and change the duration to 0;00;15;00 
(15 seconds).

4 Click on the background color swatch to open the Background Color dialog box. 
When it appears, notice that the Color Picker in the dialog box allows you to insert 
numerical values for color using HSB (Hue, Saturation, Brightness), RGB (Red, 
Green, Blue), and hexadecimal values. 
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5 Click on the R (Red) value and type in 141. Repeat this for both the G (Green) and B 
(Blue) values as well. This produces a light–gray background color.

Whenever the RGB values are the same, you produce a grayscale value from 
black (R:0, G:0, B:0) to white (R:255, G:255, B:255).

You can also pick colors visually by selecting the hue from the vertical color slider and then clicking 
in the large color fi eld to the left of the color formulas.

6 Click OK in the Background Color dialog box to return to the Composition Settings 
dialog box, and then click OK again in the dialog box to add the new comp to your 
project.

Do not close this project; you will continue to work with it in the next part of this lesson.
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Understanding composition settings
The Composition Settings dialog box allows you to set and edit the properties of your 
compositions. The dialog box opens automatically when you create a new composition 
and can be opened manually by selecting a comp and choosing Composition > 
Composition Settings or by pressing Ctrl+K (Windows) or Command+K (Mac OS). The 
dialog box is divided into two sections, for basic and advanced settings.

Basic settings

A

B

C

D

E

F

G

H

A. Preset. B. Width and Height. C. Pixel Aspect Ratio. D. Frame Rate. 
E. Resolution. F. Start Time Code. G. Duration. H. Background Color.

Preset: Video projects usually have to conform to an established standard such as NTSC or 
PAL. The presets menu contains a variety of prebuilt composition settings to match the most 
commonly used standards. Because most video projects will match one of the established 
video standards, the most effi  cient way to begin is to choose a preset from the drop-down 
menu and then modify any properties that do not fi t your specifi c project. To the right of the 
menu are two buttons: one to save custom presets and the other to delete them.

Width and Height: This setting specifi es the physical dimensions, in pixels, of your 
comp. This is comparable to document size in other applications.

Pixel Aspect Ratio: This setting specifi es the shape of the pixels in your comp. Diff erent 
video standards use diff erent pixel aspect ratios to display content. An incorrect pixel 
aspect ratio will cause your work to appear distorted. The preset that you pick usually 
assigns this property for you.
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Frame Rate: This setting specifi es the number of frames per second (fps) that make up 
your composition. 

Timebase: This setting specifi es whether the new Composition will use a drop-frame or 
non-drop-frame timebase.

Resolution: This setting specifi es the quality of the Composition panel’s display. Lower 
values require less RAM in order to preview.

Start Timecode: This setting specifi es the timecode value at the beginning, or origin, 
of the Timeline. The After Eff ects default is 00;00;00;00 but if exporting your animations 
to videotape for broadcast, most stations require that the timecode origin be set to 
01;00;00;00 (1 hour).

Duration: This setting specifi es the length of the composition Timeline.

Background Color: This setting specifi es the background color for the comp.

Advanced settings

A

B

C

D

E

A. Anchor. B. Rendering Plug-in. C. Preserve frame rate when nested or in Render Queue. 
D. Preserve resolution when nested. E. Motion Blur. 

Anchor: This setting is not editable when creating a new comp, only when editing the 
settings of an existing one. If you are enlarging or shrinking its physical dimensions, the 
anchor settings specify how the transformation proceeds by locking a specifi c area in place.

Rendering Plug-in: This setting specifi es the engine to use for rendering 3D layers. This 
setting allows you to choose between Classic 3D and Raytraced 3D. The new raytracing 
engine in After Eff ects CS6 allows you to create extruded text and shape layers, and 
provides for a higher quality appearance for 3D content.
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Preserve frame rate when nested or in Render Queue: This setting specifi es whether the 
comp’s frame rate is preserved or converted when you place it inside of another composition.

Preserve resolution when nested: This setting specifi es whether the comp’s resolution 
setting is preserved or converted when you place it inside of another composition.

Motion Blur: This setting specifi es the strength of the Motion Blur eff ect when it is 
enabled for layers. Using Motion Blur is covered in greater detail later in this lesson.

Importing compositions from Photoshop and Illustrator
If you are unfamiliar with them, Photoshop and Illustrator are two industry-leading 
applications for creating pixel-based and vector graphics, respectively. The fact that they 
are also Adobe applications allows them to have enhanced functionality when used as 
part of an After Eff ects workfl ow. When you import layered Photoshop and Illustrator 
fi les into a project, you have the ability to control whether they are either brought in as a 
fl attened fi le (similar to when you import a JPEG) or converted into new compositions, 
which would maintain the integrity of the layers and the structure of the native fi les. For 
additional information on the benefi ts of using Photoshop and Illustrator fi les, refer to 
Lesson 3, “Media Management—Images, Video, and Audio.”

1 Choose File > Import > Multiple Files. In the Import Multiple Files dialog box, 
navigate to the ae04lessons folder you copied to your hard drive earlier, and click on 
the fi le named globe.psd. 

2 From the Import As drop-down menu, select Composition - Retain Layer Sizes. Click 
the Open button to gain access to the import options for this Photoshop fi le.

3 In the Import Options dialog box, confi rm that the radio button for Editable Layer 
Styles is selected. Making layer styles editable helps After Eff ects match the appearance 
attributes of the Photoshop layers. 

In general, enabling Editable Layer Styles from Photoshop ensures 
that your content in After Eff ects matches the Photoshop original.

Click OK to import the footage and reopen the Import Multiple Files dialog box.
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4 In the Import Multiple Files dialog box, select the Archaic Wheels.ai fi le. From the 
Import As drop-down menu, select Composition. Click the Open button to import 
this fi le and reopen the Import Multiple Files dialog box. 

In this instance, the Composition option works well because this fi le contains a 
series of concentric circles that are all centered on the Illustrator fi le’s center point. 
The circles are also intended to be animated around a single central point at the 
composition’s center.

5 In the Import Multiple Files dialog box, select the dison logo.ai fi le. From the Import 
As drop-down menu, select Composition – Retain Layer Sizes and click the Open 
button to import this fi le and reopen the Import Multiple Files dialog box.

6 In the Import Multiple Files dialog box, double-click on the Paper background.tif fi le 
to import it. 

7 When the Import Multiple Files dialog box reopens, click the Done (Windows) or 
Cancel (Mac OS) button to close it. Your Project panel should now look like the 
fi gure below.

The advantage to using native Photoshop and Illustrator 
fi les is the ability to import compositions so that you can 
animate each layer.

8 Choose File > Save As. Navigate to the ae04lessons folder on your hard drive. In the 
Save As text fi eld, name the fi le Lesson4-working and click Save. 

Do not close this project; you will continue to work with it in the next part of this lesson.
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Working with layers 
If you are familiar with graphics programs such as Adobe Photoshop and Illustrator, then 
you may be familiar with the general concepts of using layers, though here they work a little 
diff erently. In After Eff ects, every piece of footage that you place in a composition resides on 
a separate and individual layer. These layers are visible in the Timeline panel and each layer 
contains its own properties that can be manipulated or animated independently of any others. 

Now that you have created your main composition and imported the media assets you 
will work with, it’s time to get a handle on working with the Layers panel. In this part of 
the lesson, you will add media to the timeline and work with the footage layers that are 
created to layout your composition.

1 If it is not already open, open your Lesson4-working.aep project that you saved at the 
beginning of this lesson. This project has the Photoshop and Illustrator compositions 
that were imported previously, along with the folders that were automatically created 
to organize each fi le’s individual layers. 

2 In the Project panel, double-click on the Dison Intro comp to preview it in the 
Composition panel and Timeline. This comp is now empty, but you are going to fi x 
this in a moment.
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It is important to note that when you double-click on a composition, it previews in the 
Composition panel and Timeline simultaneously. However, the ways that they preview 
are a little diff erent. There is only one Composition panel by default, so double-clicking 
on a comp makes it active in the window and hides whichever one may have been 
visible previously. However, the Timeline panel is tab-based ( just like your Internet 
browser), so you can see multiple comp tabs at the same time. As a result, double-
clicking on a comp in the Project panel just brings its tab forward and makes it active. 

Double-clicking on any composition immediately causes it to preview in the Composition panel and Timeline.

If you have multiple composition tabs on your Timeline, clicking on one makes it active in both 
the Timeline and Composition panels.
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3 In the Project panel, click on the Paper Background.tif footage to highlight it, and 
drag it to the Dison Intro comp Timeline.

As you drag it, the footage appears onscreen as a gray wireframe box.
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4 When the footage is over the comp’s Timeline, release your mouse button. The 
footage is added to the comp and becomes visible in the Composition panel.

The drag-and-drop method is one of the easiest ways to add footage to a composition.

5 Again, in the Project panel, click on the globe composition, then drag and drop it 
below the Paper Background.tif layer in the Dison Intro Timeline.

A composition can contain any type of footage: images, video, audio, and other comps.

Instead of dragging and dropping your footage into the Timeline, an alternative method is to drop 
it into the Composition panel. The diff erence between the two destinations is in how the layers 
are positioned. When targeting the Composition panel, the position of the layers is based on where 
you drag the footage; when placing footage directly into the Timeline, it is always centered on the 
composition. 

If you look at the Composition panel, you will notice that the globe comp is not visible. 
This is because the paper texture is in front of it. You will fi x this in the next exercise.

6 Save your fi le by choosing File > Save.

Do not close this project; you will continue to work with it in the next part of this lesson.
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Understanding the different types of layers

In After Effects, the footage you import is added to a layer when you place it into a 
composition, but what about other objects, such as lights, cameras, or other shapes? They are 
layers as well; in fact, in addition to the standard layers you will create from your imported 
content, such as video, images, and audio, there are other types of layers that can be created 
entirely within After Effects: 

Text layers can be animated using the standard layer transform properties (such as position 
or rotation). Additionally, text layers have unique properties (called text animators) which give 
you more control over the text. An example of when you would use text animators is if you 
wanted to rotate each character in a word. Text layers are used frequently to create credits, 
lower thirds, or kinetic typographic effects.

Solid layers, also called layer solids are single color layers that are created directly in After 
Effects.They are often used as color fields, rectangular shapes, or for effects which generated 
internally within After Effects, such as the lightning grid effect, or beam effect.

Light layers are used to illuminate 3D layers and cast shadows. As an aesthetic tool, lights are 
used to enhance the sense of depth and volume in a scene.

Camera layers are designed to simulate the performance and behavior of video cameras in 
real life, and can be panned, tilted, and moved to create a sense of movement through space.

Null Object layers are invisible layers (which are visible in the composition and timeline 
panels, but do not render) that have all the transform properties of other visible layers. They 
are useful as helper objects, they require you to parent the properties of one layer to another, 
and they are often used as controller objects for cameras and three dimensional layers.

Shape Layers are vector shape objects created with the shape tools (rectangle, ellipse, 
polygon, etc.) in After Effects. Similar to text and solid layers, they have both layer transform 
properties and custom shape properties that are native only to shape layers. 

Adjustment Layers are invisible layers that can be the target of effects, which are similar 
to adjustment layers in Photoshop. They are used when you want to apply a specific effect 
or series of effects to multiple layers simultaneously. Since any layers below the targeted 
adjustment layer will display as if the effect is applied to them, it avoids the trouble of having 
to apply the same effect multiple times. 
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Understanding the layer switches
If you have worked with design or graphics programs before using After Eff ects, then 
the idea of having switches to hide or lock a layer is not new to you. But in addition to 
these standard controls, the Layer area of the Timeline contains several other specialized 
switches used to enable or disable various layer features. In addition to being able to show, 
hide, and lock layers, you can solo, shy, or enable features such as motion blur or frame 
blending. If those terms are new to you, this section should help you understand them. 
Each layer switch corresponds with a label above it that details its name and usage.

A B C D E F G H I J K L M N O P

A. Video On/Off . B. Audio On/Off . C. Solo. D. Lock. E. Label. F. Number. G. Layer/Source Name. 
H. Shy. I. Collapse Transformations/Continuously Rasterize. J. Quality. K. Eff ects. L. Frame Blend. 
M. Motion Blur. N. Adjustment Layers. O. 3D Layer. P. Parenting.

Video On/Off  ( ): Click this switch to toggle the visibility of the video on a layer. This 
switch is only available when working with a layer containing video; otherwise, the space 
is blank. In After Eff ects, this setting applies to both still images and actual video. When 
a layer’s video track is disabled, it doesn’t preview in the Composition panel and is not 
included when you render the composition for fi nal output.

Audio On/Off  ( ): Click this switch to mute the audio of a layer. This switch is only 
available when working with a layer containing audio. In this case, the audio can either 
be on its own layer, as when you add an MP3, WAV, or AIFF fi le to a composition, or 
embedded in a video fi le. When you disable a layer’s audio track, it doesn’t preview in the 
Composition panel and is not included when you render the composition for fi nal output.

Solo ( ): This switch hides all layers that do not have the Solo switch enabled. Often you 
will want to preview only a single layer in a much larger composition. In situations like 
this, toggling the video and audio off  for many layers can be very time-consuming. This 
switch allows you to isolate only the layers that have Solo enabled. When a track is soloed, 
its audio and video don’t preview in the Composition panel and are not included when 
you render the composition for fi nal output. 

Lock ( ): This switch prevents any editing to a layer’s content. When enabled, the layer 
cannot be selected or transformed at all. Use this switch to prevent accidental changes to 
content that you want to isolate, but want to remain visible in the composition.
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Label ( ): This is a drop-down menu used to apply a color label to each layer. The color is 
used in two places: as the color of the border around highlighted content in the Timeline, 
and also as the layer’s highlight color in the Timeline. While you can modify the colors, 
they default to specifi c colors based on the type of footage on the layer. You can change 
this default in the Preferences dialog box by editing the contents of the Labels category.

Number (#): This is a numerical value assigned to show the stacking order of layers in a 
composition. The fi rst layer is on top of all other layers, followed by the layer numbered 2 
and then 3 and so on. If you are using a keyboard with a number pad, you can select layers 
by pressing their corresponding keys.

Layer/Source Name: This column can be toggled to display two diff erent values. The 
Source names option displays the names of the footage items from the Project panel, while 
choosing layer names displays the custom name (if any) that you have assigned to layers 
in the Timeline panel. New compositions default to the Source name display, in which 
they use the footage name from the Project panel. When edited, the column automatically 
switches to the Layer name mode, which allows you to mix custom names changed in the 
Timeline with Source names.

Shy ( ): The Shy switch is a tool for optimizing the display of the Composition panel. 
You can enable a layer’s Shy mode, then use the Hide Shy Layers composition switch at 
the top of the Timeline panel to hide all Shy layers in the comp. This can be a helpful 
alternative to maximizing the Timeline panel to full-screen mode, because it removes Shy 
layers from the layer display but not the Composition panel. Shy layers still preview in the 
Composition panel and are also included when rendered for fi nal output.

Collapse Transformations/Continuously Rasterize ( ): The function of this switch 
changes, depending on what the layer’s footage type is. When applied to a composition, it 
collapses transformations on that layer, eff ectively changing the order in which eff ects and 
transformations are rendered in the nested composition. Continuously Rasterize applies 
only to vector-based content imported from programs such as Adobe Illustrator. When 
enabled, the layer is continuously rasterized, which produces a better result in animating 
properties, such as scale, but it does so with an increased performance cost.

Quality ( ): The Quality setting of a layer specifi es how precisely it is rendered. This 
setting is applied to the appearance of the layer in previews, but is also applicable when 
rendered for fi nal output. When you switch the layer quality, you can choose Best, Draft, 
and Wireframe modes. The Best quality mode displays the render at its highest quality, 
but takes a longer time to render than Draft or Wireframe modes. The Draft mode is a 
lower-quality preview than Best, and is intended to show your layers, but some eff ects are 
not rendered or may be applied inaccurately. Wireframe quality displays only the outline 
of a layer, discarding its appearance and all eff ects. The ability to change quality is helpful 
because a lower-quality display previews and renders faster, and this feature can be very 
useful when syncing the position or timing of elements.
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Eff ects ( ): This switch is disabled unless an eff ect has been applied to a layer, when it 
is automatically enabled. You use this switch to disable eff ects on the layer, resulting in 
quicker previews.

Frame Blend ( ): This switch is usually enabled when using time-remapping eff ects to 
speed up or slow down video footage. These eff ects can lead to jerky motion, which frame 
blending is designed to compensate for by combining multiple frames together.

Motion Blur ( ): This switch enables motion blur in the layer, helping to create the 
impression of motion that viewers are familiar with from watching video and fi lm.

Adjustment Layers ( ): When enabled, this switch converts the layer into an adjustment 
layer. When using adjustment layers, the content of the layer is ignored and instead, eff ects 
applied to the targeted layer aff ect only the layers below it. 

3D Layer ( ): When enabled, this switch converts a two-dimensional layer into a three-
dimensional layer. 

Parenting: This column contains controls for setting the layer as a child, thus allowing 
the parent layer to control its position, rotation, scale, and anchor point.

Understanding layer stacking order
When a composition consists of multiple layers, the arrangement of those layers, called 
the stacking order, is very important. When a layer that is fully opaque is placed on top 
of other layers, the result is that only the top layer is visible. If, however, the top layer 
has transparent areas, you can see through those transparent areas to the layer or layers 
beneath. You can easily modify the arrangement of layers in the Timeline panel, as you 
will do now.

1 In the Dison Intro timeline, locate the Source Name column and place your cursor on 
the dividing line to the right of the column. 

The panes of the Timeline panel can be expanded or contracted depending on your needs.

2 When your cursor changes to a double arrow, click and drag the dividing line to the 
right to enlarge the Source Name column.

Any column in the Timeline panel can be contracted or expanded, though this is most often used 
on the name column to accommodate longer fi lenames.
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3 Click on the globe layer to highlight it, and drag it above the Paper Background.tif layer.

As you drag layers in the Timeline, a black line appears to show you a preview of the new stacking order.

4 You should now be able to see the globe composition as in the fi gure below. Save 
your fi le by choosing File > Save or by pressing Ctrl+S (Windows) or Command+S 
(Mac OS) on the keyboard.

Do not close this project; you will continue to work with it in the next part of this lesson.

The globe composition has transparent areas that reveal the background beneath.

Changing layer names
By default, the names displayed in the Timeline panel are taken directly from the name of 
the source footage as it appears in the Project panel. However, many people prefer to have 
layer names that describe their content, because this makes them easier to locate when 
quickly scanning through or searching a composition.

1 Click on the Paper Background.tif layer in your Timeline panel to highlight it.

2 With the layer highlighted, press the Enter (Windows) or Return (Mac OS) key on 
your keyboard. This makes the layer name editable.

You can also rename a layer by right-clicking the current layer name and choosing Rename from 
the context menu that appears.
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3 Change the layer name to background. Press the Enter/Return key again to exit this 
editing mode. 

There are a couple things that have changed in the Timeline panel. The coulmn name 
is no longer called Source Name but is now instead titled Layer Name. Additionally, 
the globe layer is now enclosed in brackets, indicating that it is still being referred to 
by the Source Name. 

4 Save your fi le by choosing File > Save or by pressing Ctrl+S (Windows) or 
Command+S (Mac OS) on the keyboard.

Do not close this project; you will continue to work with it in the next part of this lesson.

Understanding Layer Properties

Every visual layer has five built-in properties that can be animated: Position, Opacity, 
Rotation, Anchor Point, and Scale. Each of these properties can be animated either 
individually or in combination with other properties to create animations. 

Position: This property specifies the X, Y, and Z (when the layer’s 3D switch is enabled) 
coordinates of the layer. The units of measure used by the Position property are pixels, and 
are relative to the composition’s origin point (0.0, 0.0) located in the upper-left corner. It is 
important to note that this property is for the anchor point of a layer, not its actual content. 

Opacity: This property specifies the transparency of a layer as a value between 0 (zero) and 100 
percent, where 0 percent would be fully transparent, and 100 percent would be fully opaque.

Rotation: This property specifies the amount that a layer turns around its central axis. 
When dealing with a two-dimensional layer, all rotation is around the z-axis. Once the 3D 
layer switch is enabled, however, the Rotation property is split into three: X Rotation, Y 
Rotation, and Z Rotation. Whether for two dimensions or three, the Rotation property is 
displayed as a series of numbers, 0x + 0.0º, where the first value is the number or times of 
complete rotations to make, and the second number is the ending degree value. So a value of 
1x + 0.0º would mean to rotate one full time and stop at 0º, while a value of 2x + 45º would 
mean to make two full rotations, then stop at 45º.

Anchor Point: This is the reference or registration point of a layer. This is the point that all 
transformations (rotation, movement, scale, and so on) occur around, so it is sometimes called 
the transformation point. 

Scale: This property specifies the relative horizontal and vertical size of a layer as a value that 
defaults to 100 percent. Values above 100 percent make the layer larger, while values below 
100 percent make it smaller. 

Specialized layers, such as cameras and lights, have a slightly different set of properties. 
For example, they both lack an Anchor Point and instead have a property named Point of 
Interest, which defines the target onscreen area that the light or camera is pointing at.

Any layer property can be animated independently from all the others. Once animation is 
enabled, any change to that property, either by using the Transform tools in the Composition 
panel or by editing its values on the Timeline, produces a new keyframe at the playhead’s 
current position. If there is an existing keyframe at the playhead’s current position, then you 
will instead modify its value when you change the properties.
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Creating Kinestasis by animating the Anchor Point
Kinestasis is a very popular technique when working with still images. It is also sometimes 
called the Ken Burns eff ect or Pan and Zoom. Traditionally, before the advent of modern 
software, the eff ect was created by panning a video camera over a still image. In modern 
motion graphics, this eff ect is most often recreated in After Eff ects by animating a layer’s 
anchor point.

This is what all your preparation up to this point has been for. You will now animate the 
layers that you have added to your composition to create a kinestatic eff ect.

Properties such as Anchor Point, Position, and Scale have multiple values for each 
keyframe. These values are numerical and correspond to objects on your screen, which in 
turn can be animated. For example with Position, you will have an X value (horizontal) 
and a Y value (vertical). By setting two keyframes with diff erent values you can animate an 
object horizontally, vertically, or both. While a three-dimensional layer will have a third 
value for the Z-axis position.

1 If it is not already open, open the Lesson4-working.aep project that you saved at the 
beginning of this lesson. This project has the Photoshop and Illustrator compositions 
that were imported previously, along with the folders that were automatically created 
to organize each fi le’s individual layers. 

2 In the Project panel, double-click on the Dison Intro comp to preview it in the 
Composition panel and Timeline. In the previous exercises, two layers were added 
to the comp: globe and background. The layers must be modifi ed a little before you 
can apply the Kinestasis eff ect. Both layers are much larger than the actual comp and 
must be scaled down to be useful, and the globe layer must be moved into the proper 
position for the eff ect. 

3 In the Timeline panel, click on the globe layer to highlight it. Hold down the Shift 
key and click on the background layer to add it to your selection. 

4 Click on the reveal triangle to the left of the globe layer’s name to view the Transform 
properties for the layer. Because both layers were selected, two Transform properties 
are revealed.

The reveal triangles are used to display hidden layer properties.
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5 Click on the reveal triangle for the globe layer’s Transform properties to view the fi ve 
individual properties that are inherent to all visible layers. 

Many layer and eff ects properties are hidden inside of property groups like Transform,  
that you must reveal in order to access them.

6 Click on the Scale value to make it editable. Type 70 in the numerical text fi eld and 
press the Enter (Windows) or Return (Mac OS) key on your keyboard. Because 
multiple layers were selected when you did this, both layers scale down to 70 percent 
of their original size.

7 Press Ctrl+Shift+A (Windows) or Command+Shift+A (Mac OS) to deselect all layers. 
Then click on the globe layer to select it. 

8 For the globe layer, in the Position category, click on the value for X Position (the fi rst 
value listed for the Position property) and change it to 146. Then click on the value 
for Y Position (the second value listed for the Position property) and change it to 254. 
Press Enter or Return to commit these changes.

The position of the globe layer should line up with the right side of the composition.

Up to this point, you have been changing the layer properties globally. This changes 
them to the same value for the entire duration of the composition. Now you will 
animate the Anchor Point property to create movement. 
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9 If your cursor is not at the origin (0;00;00;00) of the Timeline, click on the Current 
Time fi eld on the top-left corner of the Timeline to highlight it, type in the number 0 
(zero), and press the Enter (Windows) or Return (Mac OS) key to move the playhead 
back to the beginning of the Timeline.

10 Click the Time-Vary Stopwatch ( ) to the left of the Anchor Point property to enable 
animation for this property. This creates a keyframe at the current position of the 
playhead. 

Keyframes are always created at the playhead’s current position.

Keyframes store property values. In order to create animation, you will create a 
second keyframe farther down the Timeline with diff erent values. The program will 
then animate the change for you.

11 Click on the Current Time fi eld to highlight it, type 1000 into the numerical text 
fi eld, and click on any empty area of the Timeline to move the playhead to 10 seconds. 

12 Click on the X value of the Anchor Point property and change it to 185. This creates 
a second anchor point and completes the pair needed to animate the property. Click 
Enter or Return to accept.

Two is the minimum number of keyframes required to create animation.

13 Click on the playhead and drag it to the beginning of the Timeline. Press the spacebar 
on your keyboard to preview the animation. The globe layer slides to the right, while 
the background layer is static.

14 Save your fi le by choosing File > Save or by pressing Ctrl+S (Windows) or 
Command+S (Mac OS) on the keyboard.

Do not close this project; you will continue to work with it in the next part of this lesson.
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Animating rotation
Animating rotation allows you to spin a layer around its central z-axis. You can use 
it to simulate a swinging pendulum, the hands of a clock, or a fl ipping coin. In this 
exercise, you will animate the layers in the Archaic Wheels composition to spin a series of 
decorative circles around a common center point.

In this exercise, you will work with one of the imported Illustrator compositions that were 
added to the project earlier in the lesson.

1 If it is not already open, open your Lesson4-working.aep project that you saved at the 
beginning of this lesson. This project has the Photoshop and Illustrator compositions 
that were imported previously, along with the folders that were automatically created 
to organize each fi le’s individual layers. 

2 In the Project panel, double-click on the Archaic Wheels comp to preview it in 
the Composition panel and Timeline. If necessary, change the magnifi cation of the 
Composition window so that you can see the comp area. In the fi gure below, it is set 
to Fit up to 100% percent, but the exact setting you need will depend on your monitor 
size and resolution.

Double-clicking on any composition immediately causes it to preview in the Composition and Timeline panels.

AECS6_06Pass.indb   98AECS6_06Pass.indb   98 5/18/12   1:06 PM5/18/12   1:06 PM



4

99Lesson 4, Creating Animation in After Eff ects 

Animating rotation

3 In the Timeline, click on the fi rst layer, ArchaicRing01, to highlight it. To reveal the 
Rotation property, press the R key on your keyboard.

There are keyboard shortcuts for revealing each layer property: P is for Position, A is for Anchor 
Point, R is for Rotation, T is for Opacity, and S is for Scale. A good mnemonic device for 
remembering them is the acronym PARTS. Using these keyboard commands will hide any other 
layer properties that are visible. To reveal multiple properties at once, hold down the Shift key 
while using the shortcut.

4 Make sure your playhead is at the beginning of the Timeline (0;00;00;00) and click the 
Time-Vary Stopwatch ( ) to the left of Rotation to enable animation for this property 
and create the fi rst keyframe.

5 Drag the playhead to the end of the Timeline (0;00;14;29). For this animation you will 
make the ring rotate fi ve times. Click the fi rst number in the rotation value, change it 
to 5, and press the Enter (Windows) or Return (Mac OS) key on your keyboard. The 
Rotation property value should now read 5x+0.0º. This causes the ring to rotate once 
every three seconds in order to complete the assigned fi ve rotations.

The fi rst fi eld in the rotation value is the number of times to make a complete rotation, and the second fi eld is the 
fi nishing angle.

A quick way to jump to the beginning or end of your Timeline is to use the Home and End keys 
found on your keyboard’s extended keypad. If using a laptop, you may need to access these keys 
by using the FN key, depending on your computer model.

6 Move the playhead back to the beginning of the Timeline and press the spacebar on 
the keyboard to preview the animation. The ring rotates clockwise fi ve times between 
the start of the time line and the end, or approximately one rotation every 3 seconds. 
Press the spacebar again to stop the rotation.
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7 In the Timeline, click on the second layer, ArchaicRing02, to highlight it and reveal 
the Rotation property by pressing the R key on your keyboard.

8 Again, make sure your playhead is at the origin of the Timeline and click the Time-
Vary Stopwatch ( ) to the left of Rotation to enable animation for this property and 
create a keyframe.

A keyframe is automatically created when the Time-Vary stop watch that enables animation for the 
property is turned on.

9 Again, drag the playhead to the end of the Timeline (0;00;14;29) then type -5 in the 
fi rst numerical text fi eld and press Enter (Windows) or Return (Mac OS) to create 
the new keyframe. This sets the number of rotations to fi ve, but given that a negative 
number is used, the layer rotates counter-clockwise.

Once animation has been enabled for a property, any change to the value of that property creates a 
keyframe at the playhead’s current position.

10 Save your fi le by choosing File > Save or by pressing Ctrl+S (Windows) or 
Command+S (Mac OS) on the keyboard.

Do not close this project; you will continue to work with it in the next part of this lesson.
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Using layer parenting to ease repetition
The wheel graphic used in this exercise actually consists of a series of concentric circles, 
each with its own design and each on its own layer. You have just animated the fi rst two 
layers moving in opposing directions, but what about the others? If you want to continue 
the pattern and have each circle rotating in the opposite direction as its predecessor, you 
could add keyframes to all them manually, but this would be a bit tedious. All these 
individual keyframes would also create a nightmare if you decided to change the timing of 
the animation later. A situation like this is where parenting becomes important.

Parenting is a tool for eliminating the repetition that is often inherent in complex 
animations. With it you can link layers together so that one layer will follow another. 
Child layers inherit Position, Rotation, Anchor Point, and Scale properties from their 
parent layer, but not Opacity. A real advantage of parenting is that while a layer follows the 
movement of its parent, this movement is relative, so each property can still have its own 
independent keyframes.

In this exercise, all the odd-numbered layers will be the children of layer 1, while all the 
even-numbered layers will be the children of layer 2.

1 In the Timeline, click on layer number 3, the one named Archaic Ring03, to 
highlight it. Hold down the Ctrl (Windows) or Command (Mac OS) key on your 
keyboard and click on layers 5, 7, and 9 to highlight them as well.

Hold down the Ctrl (Windows) or Command (Mac OS) key to highlight non-sequential layers.
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2 In the Parent column to the right of the Layer Switches pane, click the drop-down menu 
for layer 3 and choose 1.ArchaicRing01 as the parent for all the odd-numbered layers.

When multiple layers are highlighted, any change made to the properties of one of them is made to all of them.

3 Click on layer 4 to highlight it. Hold down the Ctrl (Windows) or Command (Mac OS) 
key on your keyboard and click on layers 6, 8, and 10 to highlight them as well. 

4 In the Parent pane, click the drop-down menu for layer 4 and choose 2.ArchicRing02 
as the parent for all the even-numbered layers.

Because parenting creates movement that is relative to the original layer’s movement, you can adjust each 
layer’s properties as needed.

5 Move the playhead to 0, then press the spacebar on your keyboard to preview the 
animation. Press the spacebar again to stop animation, then save your fi le by choosing 
File > Save.

Do not close this project; you will continue to work with it in the next part of this lesson.
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Animating position
Perhaps the most common type of layer animation is positional animation. When 
working with two-dimensional layers, you can animate both the X and Y position values 
independently of one another. Remember that when working in the Timeline, the X 
position (horizontal) value comes fi rst, followed by the Y position (vertical) value. In this 
section you will animate the Dison logo to make it begin off -screen and then fl y into view.

1 If it is not already open, open your Lesson4-working.aep project that you saved at the 
beginning of this lesson. This project has the Photoshop and Illustrator compositions 
that were imported previously, along with the folders that were automatically created 
to organize each fi le’s individual layers. 

2 In the Project panel, double-click on the dison logo comp to load it into the 
Composition and Timeline panels. The problem that you have here is that the comp’s 
background color is black and so is the logo, so you really can’t see much at the moment.

In After Eff ects, the traditional background color is black.

3 Choose Composition > Composition Settings to open the Composition Settings 
dialog box.

You can also use the keyboard shortcut Ctrl+K (Windows) or Command+K (Mac OS).
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4 In the dialog box, click on the Background color swatch to open the Background 
Color dialog box. Type 165 for the R (Red), G (Green), and B (Blue) color values. 
This sets the background color to a neutral gray. 

5 Click OK to close the Background Color dialog box and click OK again in the 
Composition Settings dialog box.

6 Notice that the comp is composed of three visible layers: globe, DISON, and 
worldwide. The fourth layer, dot on I, is not visible at the moment. For this 
animation, the two parts of the logo are going to fl y in from opposite sides of the 
screen. So the fi rst thing you will do is parent the globe layer to the DISON layer.

In the Timeline, click on the globe layer’s Parent drop-down menu and select 3. 
DISON as its parent layer. Repeat this action to parent the dot on I layer to the 3. 
DISON layer as well.

Even though the dot on I layer is currently hidden, it will be helpful to parent it to the DISON layer to preserve 
its relative position.

The layer named dot on I is invisible because when the Illustrator fi les were imported, that layer’s 
visibility had been turned off . When importing compositions from Photoshop and Illustrator, you 
have a situation where what you see is what you get. In general, the After Eff ects composition will 
preserve the appearance of layers from both applications.

7 Click on the layer named DISON to highlight it, and press the P key on your 
keyboard to reveal the Position property. 

8 Confi rm that your playhead is at the beginning of the Timeline, and click the Time-
Vary Stopwatch ( ) to the left of the Position property to enable animation of this 
property and create the fi rst keyframe. We will keep this keyframe as it is and return 
to edit its value in a later step.
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9 Move your playhead to the 3 second (0;00;03;00) mark on the Timeline.

Remember that you can move the playhead by either dragging it directly, or clicking on the 
Current Time fi eld in the upper-left corner of the Timeline panel, typing in 300, and pressing the 
Enter (Windows) or Return (Mac OS) key on your keyboard.

10 Click the Add or Remove Keyframe at Current Time button; it is a Diamond icon ( ) 
to the far left of the Position property. This creates another keyframe at the playhead’s 
current position on the Timeline. The new keyframe is created with the same values 
as the one before it. This acts as the keyframe for the fi nal position of the layer where 
it is on-screen.

The Add or Remove Keyframe at Current Time button is very helpful in a situation like this 
where you already have your artwork on-screen in what you intend to be its fi nal location. It is 
also a very good way to create static or placeholder keyframes when you simply want to continue 
to hold a property at a previous value.

Click on the arrow ( ) to the left of the Add or Remove Keyframe at Current Time 
button. This is the Go to Previous Keyframe button, and causes the playhead to jump 
to the previous keyframe of this property. 

Click the Go to Previous 
Keyframe button.
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11 Change the magnifi cation of the Composition window so that you can see the comp 
area and the background area outside of it. In the fi gure below, it is set to 25 percent, 
but the exact setting you need will depend on your monitor size and resolution. 

When animating objects that move on- and off -screen, it is necessary to 
zoom out to see the area around the comp border.

12 Back at the beginning of your Timeline, place your cursor over the DISON layer’s X 
position property. The cursor changes from the familiar black arrow to a Finger icon 
with two horizontal arrows. This icon indicates that you are hovering over a dynamic 
text slider. 

In one motion, click and drag to the left with your mouse while hovering over the X 
position fi eld. As you do so, the value changes and the layer slides to the left. Change 
the X position until it reads -725. This operation will stop once you reach the edge 
of your screen, so you may have to repeat it several times. If you have a hard time 
making the text slider stop at exactly -725, you can just click on the numerical fi eld 
and type the value.

The text sliders are very helpful because they can show you the changes you are making as real-time previews.
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13 If necessary, move the playhead back to the beginning (0;00;00;00) of the Timeline. 
Then click on the layer named worldwide, press the P key on your keyboard to reveal 
its Position property, and click on the Time-Vary Stopwatch ( ) to enable animation 
for this property and create the fi rst keyframe.

14 Press the K key on your keyboard. This causes the playhead to jump to the next visible 
keyframe. Click the Add or Remove Keyframe at Current Time button ( ) to insert a 
second keyframe. This will be the fi nal onscreen position of the worldwide layer.

You can jump between keyframes on the Timeline by pressing the J and K keys on the keyboard. 
J jumps to the previous keyframe while K jumps to the next keyframe. If there are no further 
keyframes, the shortcuts jump to the beginning or end of the Timeline. You can also navigate 
from keyframe to keyframe using the Go To Next and Go To Previous arrows to the side of the 
property name display as you did before, but they are limited to the specifi c property they are 
attached to.

15 Move the playhead back to the beginning of the Timeline and change the layer’s X 
position value to 2700. This pushes it to the right outside of the composition border.

The text layers begin off  screen, and fl y in to form the logo.

16 Preview the animation by pressing the spacebar on your keyboard. You now have 
an animation in which the words fl y in from opposite sides of the screen and come 
together to form the logo.

17 Save your fi le by choosing File > Save.

Do not close this project; you will continue to work with it in the next part of this lesson.
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Understanding motion paths
A motion path is the visual representation of the movement of a layer. Motion paths are 
shown when you animate special properties such as Anchor Point and Position. The 
motion path appears as a series of small dots along a line. Each dot represents the position 
of that layer at each frame of the animation. The property keyframes are represented 
by small squares along the motion path. Motion paths appear as straight lines but on 
closer examination, they can be seen to have control points that allow them to be bent 
and warped. In this exercise, you will warp the motion path of the DISON layer so that 
instead of moving in a straight line it appears to make a short hop to appear on-screen.

1 Move your cursor to the beginning of the Timeline and click on the DISON layer to 
highlight it. You should see the motion path in the Composition panel.

When a layer is highlighted, its motion path is visible. 
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2 Click on the small Square icon at the beginning of the motion path that represents the 
keyframe so it is highlighted. You may need to change your zoom magnifi cation to do 
this. This reveals its direction lines, which will allow you to edit the shape of the path. 
Motion paths can be warped only at keyframes by manipulating these lines.

Directional handles are only visible when the keyframes they correspond to are selected. 

In order to see directional handles, you can select the keyframe in either the Composition or 
Timeline panel; the results will be the same.

3 The small circle at the end of a direction line is the direction handle. Click and drag 
the direction handle up, which causes the motion path to curve upward. Move the 
direction handle until the path matches the fi gure below.

The height and curvature of the path are determined by the length and angle of the direction line.

The direction lines and handles can sometimes be a little hard to see and you may have to 
increase the magnifi cation of the Composition panel to make them visible.
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4 Move your playhead to the beginning of the Timeline and press the spacebar to 
preview your animation. The DISON layer now travels along an arcing path instead of 
a straight line.

5 Save your fi le by choosing File > Save.

Do not close this project; you will continue to work with it in the next part of this lesson.

Using layer motion blur
There is an optical trick that appears in video and photography in which objects in motion 
can be made to appear blurry. This eff ect, called motion blur, is something that people 
have become accustomed to over time. Computer graphics typically don’t include this 
motion blur eff ect automatically and as a result their movement can seem unnatural and 
unrealistic. Any layer can have its motion blur enabled to create more visually appealing 
animations. In this exercise, you will add motion blur to the animated logo to enhance the 
illusion of motion.

1 If it is not already open, open your Lesson4-working.aep project that you saved at the 
beginning of this lesson. Double-click on the dison logo composition in the Project 
panel to make it active in the Composition and Timeline panels.

2 Move your playhead to the 2 second mark (0;00;02;00) and adjust the magnifi cation of 
the Composition panel so that you are zoomed in enough to see the details of the logo. 
You will notice that the two parts of the logo appear perfectly clear and this seems a 
little unrealistic and static. Adding blur to them will improve the sense of movement. 

By default, computer animations don’t normally have motion blur, 
which can make the animations seem unrealistic.
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3 Click the Motion Blur layer switch ( ) for the DISON and worldwide layers. Notice 
that nothing happens; the layers are still not blurry. This is because the Motion Blur 
eff ects don’t automatically preview in the Composition panel, but you can change this.

In After Eff ects Motion Blur is enabled on a per layer basis.

4 Click the Motion Blur Comp button ( ) located at the top of the Timeline panel to 
enable motion blur for all layers that have their layer switches set at the top of the 
Timeline panel. The stock Motion Blur eff ect is very subtle and may hardly even 
appear noticeable at its current settings. In the next part of this lesson, you will adjust 
the motion blur eff ect to produce a stronger eff ect. 

Layer Motion Blur is not visible in the Composition panel until you enable the appropriate layer switch.

5 Save your fi le by choosing File > Save.

Do not close this project; you will continue to work with it in the next part of this lesson.
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Adjusting Motion Blur settings 
If you are lucky, just applying motion blur produces the eff ect you want, but if not, you 
can adjust the composition’s Motion Blur settings. Keep in mind that any change to these 
settings will aff ect all layers with the motion blur switch enabled. The two most important 
settings to control the eff ect are Shutter Angle and Shutter Phase. Increase the Shutter 
Angle to strengthen the eff ect; higher values equate to a stronger blur. When applying 
motion blur to a moving object, its position on-screen changes, and may appear off set from 
when the eff ect wasn’t applied. You can use the Shutter Phase eff ect to adjust this off set, 
which is helpful when precise position or timing is required.

1 With the dison logo comp active in the Composition and Timeline panels, move the 
playhead to the beginning of the Timeline and preview the animation. Notice that the 
moving layers do have a motion blur applied to them but it is a little weak. You will 
edit this eff ect now.

2 Choose Composition > Composition Settings to open the Composition Settings 
dialog box. You can also press Ctrl+K (Windows) or Command+K (Mac OS) on your 
keyboard to open the dialog box.

The Composition Settings dialog box allows you to make changes to the 
properties of the composition.

If the menu item is grayed out, it is probably because the comp is inactive; simply click anywhere 
in the Timeline or Composition panel to activate it and try again.

3 In the Composition Settings dialog box, click on the Advanced tab at the top.
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4 Click on the Shutter Angle value and change it to 720. Click OK to exit the dialog box. 

The Shutter Angle value controls the amount of blur for the Motion Blur eff ect.

5 Move the playhead to the beginning of the Timeline and preview your animation. 
The Motion Blur eff ect is much stronger that it was at the beginning of the exercise.

6 Save your fi le by choosing File > Save.

Do not close this project; you will continue to work with it in the next part of this lesson.

AECS6_06Pass.indb   113AECS6_06Pass.indb   113 5/18/12   1:06 PM5/18/12   1:06 PM



4 Using blending modes 

Adobe After Eff ects CS6 Digital Classroom114

Using blending modes 
For users of applications such as Adobe Photoshop and Illustrator, blending modes may be 
a very familiar topic. They allow you to control how the content of two or more layers 
mix or blend together. By default, layers interact in a very straightforward fashion: opaque 
areas of layers simply cover and hide anything below them. But you can change this to 
create more interesting compositions. In this exercise, you will add a new shape layer to 
the comp and use blending modes to make it tint the layers below it.

1 If it is not already open, open the Lesson4-working.aep project that you saved at the 
beginning of this lesson. In the Project panel, double-click on the Dison Intro comp 
to make it active in the Composition and Timeline panels. 

Double clicking on a composition in the Project panel opens it in the Composition and Timeline Panels.

2 Deselect all the layers in the Timeline by choosing Edit > Deselect All. 

You can also use a keyboard shortcut, Ctrl+Shift+A (Windows) or Command+Shift+A (Mac 
OS), to deselect all layers. The reason you have to deselect all your layers is that if you try to use 
any of the shape tools with a layer still highlighted, the tools do not create a shape layer; they 
instead create a mask on the active layer. You will learn all about masks in Lesson 5, “Working 
with Masks, Track Mattes, and Keys.”

3 From the Tools panel at the top of the After Eff ects interface, click on the Rectangle 
tool ( ) to select it as your active tool. This activates the Fill and Stroke options to the right.

Activating the shape tools automatically enables the properties for Fill and Stroke.
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4 Click on the word Fill in the Tool panel to open the Fill Options dialog box, and 
choose the second button to fi ll the new shape with a Solid Color. Confi rm that 
the drop-down menu is set to Normal, the Opacity is 100 percent, and the Preview 
checkbox is enabled, and click OK to close the dialog box. The Fill is the interior color 
of a vector shape and you can set it to a solid color, a linear or radial gradient, or none.

Shapes can be assigned fi ll and/or stroke 
colors before or after they are created.

5 Click on the color swatch to the side of the word Fill to open the Shape Fill Color 
dialog box. Choose a dark blue color as the Fill by setting the RGB values to 
R: 5, G: 16, B: 103. Click OK to close the dialog box.

Instead of typing in the color values you could choose the colors visually 
using the slider and color box on the left side of the dialog.

6 Click on the word Stroke in the Tool panel to open the Stroke Options dialog box, 
and choose the fi rst button ( ) to set the new shape’s Stroke to None. Confi rm that 
the Preview checkbox is enabled and click OK to close the dialog box.

The stroke is the outline of a vector shape, and by choosing None, you disable it so 
that this shape only has a Fill color.
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7 Double-click on the Rectangle tool in the Tools panel to create a rectangle that is the 
same size as the composition. Because the new layer is placed above the two previous 
layers, the entire Composition panel is fi lled with blue. 

Double-clicking on any shape tool will automatically create a shape that conforms to the size of the composition.

You can also create a new rectangle shape by clicking and dragging with your cursor in the 
Composition panel. This allows you to create a shape of any size.

8 Click on the new Shape layer to highlight it. Press the Enter (Windows) or Return 
(Mac OS) key on your keyboard to make the layer name editable and change it to 
Overlay. Press Enter/Return again.

9 Click on the Expand or Collapse Transfer Controls Pane button ( ) in the lower-left 
corner of the Timeline panel to reveal the (Blending) Mode controls, and change the 
Overlay layers mode from Normal to Soft Light. This gives the composition a soft 
purple tint.
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Applying layer styles

10 In the Timeline, drag the Overlay layer below the globe layer so that the color tinting 
only aff ects the Background layer.

Layers can be dragged up and down in the Timeline to change the stacking order at any time.

Once again, click the Expand or Collapse Transfer Controls Pane button ( ) in the 
lower-left corner of the Timeline panel to hide the (Blending) Mode controls.

11 Save your fi le by choosing File > Save.

Do not close this project; you will continue to work with it in the next part of this lesson.

Applying layer styles
Layer styles are sets of pre-built eff ects, such as drop shadow and outer glow, that map 
almost exactly to their Photoshop counterparts. They are intended to extend the usefulness 
of Photoshop imports and provide you with a set of easily editable eff ects. In this exercise, 
you will add a drop shadow layer style to the map graphic layer in the Dison Intro 
composition.

1 If it is not already active, double-click on the Dison Intro comp to make it active in 
the Composition and Timeline panels. 

2 Click on the globe layer to make it active and choose Layer > Layer Styles > Drop 
Shadow. A new property group named Layer Styles is added to the Timeline and a 
Drop Shadow is now visible in the Composition panel.
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3 Click on the reveal triangle for the Drop Shadow style and set the following options:

• Blend Mode: Multiply

• Color: Black (R: 0, G: 0, B: 0). You must click on the color swatch to see RGB 
values.

• Opacity: 50%

• Use Global Light: Off 

• Angle: 0 x + 116.0

• Distance: 11.0

• Spread: 0.0 %

• Size: 5.0

• Noise: 0.0%

• Layer Knocks Out Drop Shadow: On

Clicking on the reveal triangle for a layer style will show or hide all the style’s options. 

The best way to learn what the diff erent properties of the layer styles do is to 
experiment with them. If you are a Photoshop user, you will fi nd that they compare 
almost exactly to the layer styles in that program.

As you are setting the values for the drop shadow’s properties you will notice that they all have 
Time-Vary Stopwatches. Nearly every property in After Eff ects, whether it belongs to a layer style, 
transform property or eff ect, can be animated. In fact, the entire process of creating and animating 
properties with keyframes is the same, regardless of what you are animating.
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4 Click the reveal triangle to the left of the globe composition layer to hide the layer’s 
properties.

Save your fi le by choosing File > Save.

Do not close this project; you will continue to work with it in the next part of this lesson.

Understanding nested compositions and precomposing
Complex projects are rarely created as a single composition; instead, they are the result of 
multiple comps that are animated individually. This process of placing one comp inside of 
another is called nesting. Nesting allows you to create sequential or consecutive animations 
because each comp has its own independent Timeline. Precomposing is a technique that 
allows you to create a comp from layers already on your Timeline and replace those layers 
with the new comp. It can be a very helpful technique when you want to combine multiple 
layers into a new comp, so that you can apply eff ects or transformations to all of them 
simultaneously, or as a tool for keeping the Timeline panel orderly. 

Adding nested compositions
In this exercise, you will add the Archaic Wheels and dison logo comps that you animated 
at the beginning of the lesson to the Dison Intro composition. 

1 If it is not already open, open the Lesson4-working.aep project that you saved earlier 
in this lesson, and double-click on the Dison Intro comp to make it active in the 
Composition and Timeline panels. 

2 In the Project panel, click on the Archaic Wheels comp and drag it into the Timeline. 
Place it at the top of the layer stack so that it becomes the top-most layer.

When you drag footage into the Timeline, a black line appears to indicate where the new layer will be added.
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3 The new layer’s size and position need to be adjusted to better fi t this comp. With the 
Archaic Wheel Composition layer highlighted, press the P key on your keyboard to 
reveal the Position property. Next, hold down the Shift key and press the S key, to 
reveal the Scale property as well.

If you want to remove a visible property, you can hold down the Shift key and press the keyboard 
shortcut that corresponds to the property. 

4 The Chain Link icon to the right of the Scale values constrains the proportions, ensuring 
that if you change the horizontal scale, the vertical scale will change by a relative amount, 
maintaining the appearance of the layer. Make sure that the constrain proportions option 
is turned on by confi rming the Chain Link icon is visible and change either of the Scale 
values to 75 percent. While still large, this will make it a more manageable size. 

5 Click on the X position property and change it to 0 (zero). Change the Y position 
property to 480. This moves the layer’s center, which is where its Anchor Point is 
located, to the lower-left corner of the composition. 

With the Archaic Wheels layer highlighted, press Ctrl+~ (Windows and Mac OS) to 
hide all the layer’s visible properties.

You should now have a composition in which most of the nested Archaic Wheels 
comp is off -screen.

Nested comps are treated like single layers whenever you transform them.
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6 If it is not already open, click the Expand or Collapse Transfer Controls Pane 
button ( ) in the lower-left corner of the Timeline panel to reveal the Blending Mode 
menus. Choose Soft Light as the blending mode for the Archaic Wheels layer. This 
allows the colors from the lower two layers, globe and background, to mix with the 
colors of the wheel, producing a more subtle design.

Once again, click the Expand or Collapse Transfer Controls Pane button ( ) in the 
lower-left corner of the Timeline panel to hide the Blending Mode menus.

7 Drag the dison logo comp from the Projects panel and place it at the top of the layer 
stack in the Timeline. Then, with the dison logo layer highlighted, press the S key to 
reveal the Scale property. Next, hold down the Shift key and press the P key on your 
keyboard to reveal the Position property as well.

8 With the Constrain Proportions option enabled, change the dison logo’s Scale to 44, 
change the X position to 365, and the Y position to 240. Preview your animation by 
dragging the playhead back and forth along the Timeline, a process called scrubbing. 

Notice that the darkest parts of the logo are very diffi  cult to see; the globe above 
the letter I, for example, is completely lost. You will correct this in the next step by 
adding a stroke to it.

9 With the dison logo layer highlighted, choose Layer > Layer Styles > Stroke. This 
adds the default red, 3-pixel stroke to the entire layer.

10 Click the reveal triangle next to the Stroke layer style in the Timeline panel to reveal 
its properties. Click on the Color swatch to open the Color dialog box and set the 
RGB values to R: 255, G: 255, B: 255 to give you a white stroke. Click OK to close 
the Color dialog box.

11 Click on the size value and change it to 2. Leave all other values unchanged. 

The Stroke properties contain additional settings for opacity and position that were left unchanged in this exercise, 
though you may want to experiment with them.

12 Preview your animation by scrubbing the playhead. Notice that while the playhead is 
moving, the preview seems rough and blocky. Remember to pause at various points along 
the Timeline to allow the program to preview individual frames for you at high quality.
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If you prefer, you can press the spacebar to preview the animation, but you will have 
to wait for the green bar at the top of the Timeline before the application can build a 
real-time preview. This may take some time, depending on the power of the computer 
you are using.

The white stroke makes the logo much easier to view.

13 Save your fi le by choosing File > Save.

Do not close this project; you will continue to work with it in the next part of this lesson.

Pre-composing layers
The overlay and background layers are intended to be used together, so if one moves 
they should both move together. In a situation like this, combining them into a single 
composition is benefi cial. In this exercise, you will pre-compose the overlay and 
background layers into a new comp, to make them easier to work with as a set. 

1 Click on any area of the Timeline panel to make it active. You can tell the active panel 
by the orange border surrounding it. Over the last several exercises, you have revealed 
several layer properties, and because of this it may be a little hard to fi nd the lower 
layers in the Timeline without scrolling.

2 Choose Edit > Select All or use the keyboard shortcut Ctrl+A (Windows) or 
Command+A (Mac OS) to highlight all layers, and press Ctrl+ ~ (both Mac OS and 
Windows). This hides all the visible layer properties for the currently selected layers. 

You can also use the Ctrl+ ~ keyboard command if you want to reveal all the properties of a 
selected layer. If multiple layers are selected, all their properties will be revealed. 

3 Choose Edit > Deselect All or use the keyboard shortcut Ctrl+Shift+A (Windows) or 
Command+Shift+A (Mac OS) to deselect all the highlighted layers. 
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Then click on the layer named Overlay, press and hold the Shift key on your keyboard, 
and click on the background. If you have followed along with every step up to this 
point in the lesson, these should be the two bottom-most layers in the composition.

Holding down the Shift key while clicking on layers allows you to select a sequential range of 
layers while holding down the Control (Windows) or Command (Mac OS) allows you to select 
layers out of sequence. 

4 Choose Layer > Pre-compose or use the keyboard shortcut Ctrl+Shift+C (Windows) 
or Command+Shift+C (Mac OS) to open the Pre-compose dialog box. 

Only the highlighted layers are included in the pre-compose operation.

5 Name the new composition background comp. The only other available choice 
would be to open the new comp as a tab in the Timeline. This is helpful if you want 
to edit it right away but is not required here.

Pre-composing can be a very helpful tool for keeping the Timeline panel neat and organized.

In the dialog box, there are two options for how the Pre-compose operation treats 
animation on the selected layers. Because this comp is made from a group of layers, 
the only available choice is to keep each layer’s attributes intact and move them into 
the new comp. This is called creating an intermediate composition. 

Another alternative that you have when pre-composing individual layers is to leave all 
attributes in the comp. Eff ectively, this option would take the keyframes and eff ects 
on the layer and transfer them to the new comp. Click OK to close the dialog box and 
create the new comp.
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6 Save your fi le by choosing File > Save.

Do not close this project; you will continue to work with it in the next part of this lesson.

Creating a fade-in by animating Opacity and Scale
Up to this point, you have animated every built-in Transform property, except for 
Opacity and Scale. Opacity animations allow you to control the transparency of layers, 
while you can use Scale to manipulate the size of layers horizontally and vertically. In this 
exercise, you will animate the Archaic Wheel layer so that it fades-in and scales-down 
simultaneously to appear on-screen.

1 If it is not already open, open the Lesson4-working.aep project that you saved earlier 
in this lesson.

2 Highlight the Archaic Wheel layer in the Timeline panel and press Ctrl+ ~ on your 
keyboard to reveal all this layer’s Transform properties. 

Technically, the Ctrl+ ~ command actually reveals all the attributes of a layer, not just the 
Transform properties.

3 Move the playhead to the 2 second (0;00;02;00) mark on the Timeline and click the 
Stopwatch icons for the Opacity and Scale properties to enable animation of these 
attributes.

Because the layer is already at its fi nal position in the comp, the ending keyframes of the animation are created fi rst.

4 Move the playhead to the beginning (0;00;00;00) of the Timeline and change the 
layer’s Opacity value to 0 (zero) percent. Make sure that the icon for Constrain 
Proportions is enabled and change its scale to 760 percent.

5 Preview the animation to see the ring appear on-screen in time with the logo, 
creating a more synchronous and visually appealing animation. Depending upon the 
speed of your computer, this may take a moment to complete.

6 Save your fi le by choosing File > Save.

Congratulations! You have completed the lesson.
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Review

Self study
Use the elements provided in this lesson, or your own, to create an animation that uses 
nested compositions to create multiple levels of animation. 

Review
Questions
1 When creating new compositions, how do you determine the size and frame rate to 

create them at?

2 What are the fi ve transform properties that are inherent in all visual layers?

3 What is the point of using the Motion Blur eff ect and how do you apply it?

Answers
1 New comps should always be set to match your output media.

2 Position, Anchor Point, Rotation, Opacity, and Scale.

3 You use motion blur to give layers a stronger sense of movement, slightly blurring 
them to mimic the look of moving objects on fi lm. Each layer has to have its Motion 
Blur switch enabled, and the Composition Motion Blur switch must be enabled, to 
preview the eff ect.
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What you’ll learn in 
this lesson:
• Creating Vector-Based 

masks to hide or reveal 
areas of a layer

• Creating track mattes from 
layers based on their alpha 
or luma channels

• To import animated 
Photoshop fi les for use in 
After Eff ects

• To key out a green screen 
background to composite 
video footage

Lesson 5

Masks, track mattes, and keys off er three ways of creating transparency 
on a layer. You can use these tools together or separately for both motion 
graphics and compositing projects. In this lesson, you will work with a 
series of video fi les to both create stand-alone eff ects and prepare fi les 
for later compositing.

Starting up
You will work with several fi les from the ae05lessons folder in this lesson. Make sure that 
you have loaded the aelessons folder onto your hard drive from the supplied DVD. See 
“Loading lesson fi les” in the Starting up section of this book.

See Lesson 5 in action!

Use the accompanying video to gain a better understanding of how to use some of the features 
shown in this lesson. The video tutorial for this lesson can be found on the included DVD.

5

Working with Masks, 
Track Mattes, and Keys
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Setting up
As you work in After Eff ects, you will inevitably open and close many panels, depending 
on the type of project you are creating. However, when working through the projects in 
this book, it is important to have an interface that matches the lessons. To this end, you 
should always reset your workspace to the preset standard confi guration.

1 Choose Window > Workspace > Standard to set your current workspace 
confi guration.

2 Choose Window > Workspace > Reset “Standard” to reset the standard workspace in 
case you have modifi ed it at some point. 

Working with masks 
In After Eff ects, masks are vector-based paths used to hide or reveal parts of a layer. If 
you use applications such as Adobe Photoshop and Illustrator, you will fi nd masks in 
After Eff ects to be similar to clipping masks in those applications, with the exception that 
masks in After Eff ects can be added to video as well as still images. You can create masks 
from simple primitive objects such as rectangles and circles, import them from vector-
based drawing programs, such as Adobe Illustrator, or create them from scratch in After 
Eff ects using the pen and shape tools. As with other vector objects, masks are composed 
of a series of vertices connected by line segments. These vertices represent single points 
in space and are used to anchor each line segment so that you can create lines and shapes. 
You can animate these vertices to create masks that change their shape and size to match 
the content of your video. For example, you can animate the Mask Path frame by frame 
to create a mask that moves to follow the path of a cloud traveling across the sky or a car 
traveling along the road.
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Working with masks 

Like vector paths in other applications, masks in After Eff ects can have both corner and 
Bézier vertices. It is the vertices that determine the length and shape of the line segments 
between them. Corner points always create straight lines, while Bézier points are used to 
create curved line segments. The curvature of these Bézier curves is determined by the 
direction handles attached to each vertex, as shown in the illustration below.

AA

B

A B

C

A. Vertex. B. Line segment. C. Direction handle.

In After Eff ects, you can have multiple masks on a single layer. When this is the case, the 
order of masks in the Timeline panel, called the stacking order, and the properties of each 
individual mask will determine the cumulative eff ect of all the masks.

Design programs such as Photoshop and Illustrator use the term anchor point to refer to vertices. 
Even though the terminology is diff erent, they are the same object. 
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Understanding mask properties

You use masks to control the transparency of layers. The first mask you create affects the 
alpha channel of the layer, and any additional masks that you create interact with all masks 
above the first. All masks have four properties that you can modify and animate:

Mask Path: This property specifies the position of the points that make up the mask. This 
property is animated whether you want to move all the points of a mask or only some of 
them, to create the effect of a mask moving around a layer or changing shape.

Mask Feather: This property specifies the softness of the edge of a mask. As a result of 
feathering, a mask’s edge becomes more transparent, creating the effect of a layer with edges 
that fade into its background.

Mask Opacity: This property sets the amount of inf luence that a mask has over the visibility 
of the layer it is on. When you set this property at its default value of 100 percent, the layer 
the mask encloses will be at full opacity.

Mask Expansion: You can use this property to expand or contract the edges of a mask.

In addition to these properties, each mask also has a mode setting that controls how it 
interacts with the mask above it in the stacking order:

None: When you set the mode to None, the mask does not affect the alpha channel of the 
layer. This setting is helpful when you are using the mask as the target of an effect or as a 
motion path for text.

Add: The effect of the mask is added to the masks above it in the stacking order. The Add 
setting makes the content of a layer visible.

Subtract: The effect of the mask is subtracted from the masks above it, creating a hole. If it is 
the only mask on a layer, this setting hides anything inside the mask.

Intersect: The effect of this mask adds to the ones above it. In areas where the mask does not 
overlap with the masks above it, the result is complete opacity. However, when all masks on a 
layer are set to Intersect, only the areas formed by overlapping these masks are visible.

Lighten: The effect of this mask is added to the masks above it. When multiple masks 
intersect, the highest Mask Opacity value is used for all overlapping areas.

Darken: The effect of this mask is added to the masks above it. When multiple masks 
intersect, the lowest Mask Opacity value is used for all overlapping areas.

Difference: The effect of this mask adds to the ones above it. When using multiple masks 
on a layer, masks with this setting behave as if they are set to Add when not overlapping. 
When overlapping with another mask, this setting allows the mask to behave as if it is set to 
Subtract mode.

The cumulative effects of these modes vary, depending on the number of masks on a layer, 
their position in the mask stacking order, and the mode of each. The best way to get a feel for 
how different mask modes will interact is to experiment with them. 
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Working with masks 

Creating masks with the shape tools
You can use the shape tools in After Eff ects to create masks or shape layers. They create both 
simple shapes such as rectangles and circles, and more complex ones such as polygons and 
stars. Once created, these masks can be transformed, modifi ed, and animated. In this exercise 
you will create a new project, import a video fi le, and create a rectangular mask for it. 

1 If you have just opened After Eff ects, you can skip to step 2; otherwise, choose File > 
New > New Project. If you have another project open and haven’t saved it, you are 
prompted to do so now. 

2 In the new project, choose File > Import > File. In the Import dialog box, navigate to 
the ae05lessons folder and then to the video subfolder. 

Double-click on the Creating Shape Masks.mov fi le to import it. This footage is 
composed of a montage of video and still images of Washington, D.C.

3 In the Project panel, drag the Creating Shape Masks.mov footage item to the New 
Composition button ( ) at the bottom of the panel. This creates a new comp that 
matches the properties of the video fi le.

Dragging any piece of footage to the New Composition button creates 
a new comp that matches the dimensions and length of that footage.
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With the new Composition active in the Timeline panel, choose Composition > 
Composition Settings to open the Composition Settings dialog box. If the Comp’s 
start timecode does not say 0;00;00;00, change it now. When complete, click OK to 
close the dialog box.

You can also use a keyboard shortcut to open the Composition Settings dialog box. 
With the Comp active, press Ctrl+K (Windows) or Cmd+K (Mac OS). 

4 In the Timeline panel, click on the Creating Shape Masks.mov layer to highlight it, 
and press the Enter (Windows) or Return (Mac OS) key on the keyboard to make the 
name fi eld editable. Rename this layer video 1. 
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5 With the video 1 layer highlighted, click on the Rectangle tool ( ) to make it active, 
then click and drag in the Composition panel to create a mask on this layer. It doesn’t 
matter how large you make the mask; you will resize it in a later part of this lesson.

In order to create a mask, you must have a layer selected before using the shape tools.

As you are working in the Composition panel, a new mask is being created and added 
to the Timeline panel. You should now see Mask 1 below the layer name along with 
its mask path property. 

6 Choose File > Save As. Navigate to the ae05lessons folder on your hard drive. In the 
Save As fi eld, name the fi le Creating Shape Masks-working.aep and click Save. 
Do not close this fi le; you will need it in the next part of the lesson.
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Selecting and manipulating masks 
If you can always draw your masks perfectly the fi rst time, you must be one really lucky 
individual. It is more likely that once you have created a mask you will have to edit its size 
or position at least once. Editing a mask can seem a little confusing to the novice, but with 
a little practice you will master it. If you are used to other programs that work with vector 
graphics such as Adobe Illustrator and Photoshop, then you will be used to having two 
cursors, one to manipulate the entire path and the other to edit individual vertices. After 
Eff ects is a little diff erent in that both the mask’s position on-screen, and the position of each 
vertex, are adjusted using the Selection tool. In this exercise, you will use the proportional 
grid as a guide to refi ne the shape and size of the mask that you created previously.

1 With the Creating Shape Masks-working project open, choose Proportional Grid from 
the Grid and Guide Options drop-down menu at the bottom of the Composition panel. 

The proportional grid is very helpful in 
creating shapes that are a relative size 
to the composition.

2 Click on the video 1 layer in the Timeline panel to highlight it. This reveals the edge 
of Mask 1 along with its vertices.
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Selecting and manipulating masks 

3 If it is not already active, click the Selection Tool ( ), and then in the Composition 
panel, double-click on any one of the mask’s vertices. This causes a bounding box to 
appear around the mask. A bounding box defi nes the boundary area of a mask and is 
used to move, rotate, or scale it.

The bounding box is helpful for transforming the entire mask as a single object.

The control points located around the edge of the mask’s bounding box are used to 
scale it. However, if you position the Selection tool outside of this box, it becomes a 
curved cursor allowing you to rotate the mask. Clicking and dragging on a corner 
point scales the mask horizontally and vertically, while the points on the top, bottom, 
and sides constrain the scaling to that axis.
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4 Using the Selection tool, adjust the points of the bounding box to match the example 
below. The mask’s new shape and position make it the height of the fi rst two rows 
of the proportional grid, while its width should extend slightly outside the comp to 
each side. Once you have completely resized the mask, press the Enter (Windows) or 
Return (Mac OS) key on your keyboard to confi rm the changes and to remove the 
bounding box from around the mask. The animation that you will eventually create 
in this project will involve this mask moving up and down to reveal parts of the video 
layer. This is why its height needs to be more precise than its width.

Clicking and dragging on a corner point of a bounding box lets you scale it both horizontally and vertically simultaneously 
while the middle points constrain the scale to a specifi c direction.

5 With the video 1 layer still selected, click on the Rectangle tool ( ) to make it active. 
Click and drag with your cursor in the Composition panel to create a new mask on 
the left side of the panel that is the width of the fi rst two columns of the grid, and 
whose height extends slightly beyond the boundary of the comp. You can change the 
magnifi cation of the Comp panel to see the top and bottom edges of the video frame.

A single layer can have multiple masks applied to it, this can be used to create interesting visual 
eff ects as the diff erent masks interact with one another.
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Animating the position of masks

6 Save your fi le by choosing File > Save. Do not close this fi le; you will need it in the 
next part of the lesson.

In the next exercise, you will animate the position and shape of these masks to create 
an eff ect where the masks slowly reveal the entire image.

If you use Adobe Illustrator, then you will be happy to know that you can bring vector paths 
from Illustrator into After Eff ects using a simple copy-and-paste command. All you have to do is 
select your vector shape in Illustrator and use the Copy command (Edit > Copy) to store it in the 
computer’s clipboard. Then in After Eff ects, select the layer you want to apply the mask to and 
use the Paste command (Edit > Paste). Your path from Illustrator will be applied as a mask in 
After Eff ects.

Animating the position of masks
Of the four mask properties described previously, not a single one of them is named Mask 
Position. Because they are part of a layer, masks do not have the same type of Transform 
properties that layers do. Instead, the Mask Path property is used to animate all a mask’s 
transform properties: rotation, position, and scale. It does this by storing a keyframe for 
the position of each individual vertex along a mask’s path. So when vertices are moved 
either separately (such as when you change the shape of a path) or as a group (such as 
when you scale, rotate, or move it), the Mask Path property is the one that is aff ected. In 
this exercise, you will animate the position and shape of the two masks that you created 
previously to reveal the video.

1 With the Creating Shape Masks-working project open, highlight the video 1 layer and 
press the M key on the keyboard twice in rapid succession to reveal all the properties 
of Mask 1 and Mask 2.

Pressing the M key once reveals only the Mask Path property of the layer currently selected.

2 In the Timeline panel, click Mask 1 to highlight it, and then press the Enter 
(Windows) or Return (Mac OS) key on your keyboard to make the name fi eld 
editable. Rename it horizontal mask. Click on Mask 2 to highlight it and press 
Enter/Return again, and rename it vertical mask. Press the Enter (Windows) or 
Return (Mac OS) key on your keyboard again to confi rm this change.
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3 Move the playhead to the beginning of the Timeline and click the Time-Vary 
Stopwatch ( ) next to the Mask Path property of both masks to enable animation for 
this property and create the fi rst keyframes.

Even though it may seem counter intuitive, animating the Mask Path property will aff ect its position.

4 Move the playhead to the 1 second (0;00;01;00) mark on the Timeline. In the 
Timeline, click on the mask named horizontal mask; this highlights the mask in the 
Composition panel and selects all its keyframes. In the Composition panel, place your 
Selection tool ( ) on the lower-right vertex of the mask. 

In After Eff ects, the cursor changes to indicate a new function of the currently active tool.

The Selection tool becomes an arrowhead without a stem. This icon indicates that the tool will 
move the selected vertex.

Click on the vertex and drag the mask to the bottom of the composition. Stop when 
the mask occupies the lower two rows of the proportional grid. After you begin 
moving the mask, pressing and holding the Shift key on your keyboard while moving 
the mask will let you constrain the movement to a completely horizontal path.

When using the shift key to constrain the movement of objects in After Eff ects it is important to 
press and hold the shift key only after you have begun moving the object or objects.
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Animating the position of masks

When all the vertices in a mask are highlighted, the Selection tool will move the mask as a single object.

5 In the Timeline, click on the mask named vertical mask. Just as before, this highlights 
the mask in the Composition panel and selects all its keyframes.

In the Composition panel, place your Selection tool on the lower-right vertex of the mask. 

Click on the vertex and drag the mask to the right of the composition. Stop when the 
mask occupies the right two columns of the proportional grid.

It is important to make sure that all the vertices in a mask are highlighted when you try to move it in the 
Composition panel.
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6 Move the playhead to the 1 second 14 frame (0;00;01;14) mark on the Timeline and 
click on the Add/Remove Keyframe switch ( ) to the left of the Mask Path property 
for both masks. This creates a new keyframe that has the same value as the ones at 
1 second. They act as placeholders to keep the masks in their current position for 
15 frames.

The Add/Remove keyframe switch adds keyframes at the current position of the playhead.

7 Move the playhead to the 3 second (0;00;03;00) mark on the Timeline and move 
the masks as you did in steps 4 and 5, so that they match the fi gure below. Now 
they should be positioned so they occupy the two center rows and columns of the 
proportional grid, forming a cross.

The mask should now be positioned toward the middle of the composition.

8 Move the playhead to the 3 second 14 frame (0;00;03;14) mark on the Timeline and 
again click the Add/Remove Keyframe switch to the left of the Mask Path property 
for both masks to create another pair of placeholder keyframes.
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Animating the position of masks

9 Move the playhead to the 5 second (0;00;05;00) mark on the Timeline. 

Now that you have moved the masks to the middle of the composition, you will 
animate their paths to scale them up so that they reveal the entire video.

In the Timeline, click on the mask named horizontal mask to highlight it and show 
the mask’s vertices.

10 With the mask selected, double-click any of the mask’s vertices in the Composition 
panel to activate the mask’s bounding box. 

Place your Selection tool ( ) on the middle top control point of the bounding box, and 
click and drag upward until the mask has reached or slightly exceeded the composition 
border. 

Repeat this process with the lower-middle control point, this time dragging 
downward to reveal the entire video.

11 In the Timeline, click on the mask named vertical mask to highlight it and show the 
mask’s vertices. With this mask selected, double-click any one of its vertices in the 
Composition panel to activate the mask’s bounding box.

Place your Selection tool on the middle-right control point of the bounding box, then 
click and drag right until the mask has reached the composition border. 

Repeat this process with the middle-left control point, this time dragging left until 
the mask extends to the composition border on both sides.

Because the mode of both masks is set to Add, any area that either one overlaps is visible.

It is okay if the masks extend past the borders of the composition.
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12 Preview the Timeline to see your animation by pressing the spacebar, and then save 
your fi le by choosing File > Save or by pressing Ctrl + S (Windows) or Command+S 
(Mac OS) on the keyboard. Do not close this fi le; you will need it in the next part of 
the lesson.

Working with mask feathering
Masks are vector-based objects, and by default, they have hard edges. But this may not 
always match your desired goals in a project. One of the built-in properties that all masks 
possess is called Mask Feather. It allows you to soften the edges of a mask by making them 
blurry and less distinct. The result when masks are being used to reveal or hide an image 
is that the edges of the footage layer appear to fade into the Composition background. In 
addition to the standard Mask Feather property, After Eff ects allows you set per vertex 
feathering, thus allowing you to set a diff erent feathering amount for each individual 
vertex on the mask.

Setting the Mask Feather Property
The Mask Feather property allows you to set the horizontal and vertical feathering amount 
of masks.

1 With the Creating Shape Masks working project open, highlight the video 1 layer and 
press the M key on the keyboard twice in rapid succession to reveal all the properties 
of Mask 1 and Mask 2. If you still have the Mask properties reveal from earlier in this 
lesson, you can skip this step.

2 Move the playhead to the beginning (0;00;00;00) of the Timeline panel and disable the 
Constrain Proportions switch ( ) for the horizontal mask’s Mask Feather property. 

By default, the Mask Feather property’s Constrain Proportions switch is enabled, forcing the 
horizontal and vertical feathering amount value to remain proportional to one another. Since they 
each have a default value of 0.0, this switch will usually keep both values exactly the same. If 
you have the switch turned off  and then re-enable it, you can press and hold the Alt (Windows) 
or Option (Mac OS) key on your keyboard while doing so to make both values the same.

3 Click the second value and change it to 20. This sets the mask’s vertical feather 
property to 20 pixels.

4 Disable the Constrain Proportions option for the vertical mask’s Mask Feather 
property. Click the fi rst value for the mask feather and change it to 20. This sets the 
vertical mask’s horizontal feather to 20 pixels.
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5 Deselect everything by choosing Edit > Deselect All, and then turn off  the 
Proportional Grid using the Choose grid and guide options drop-down list.

6 Preview the Timeline to see your animation by pressing the spacebar on your 
keyboard. You can now see that the edge of both masks is softer and semi-transparent, 
making the video edges fade in with the Composition background.

7 Save your fi le by choosing File > Save or by pressing Ctrl+S (Windows) or 
Command+S (Mac OS) on the keyboard. You can now close the fi le.

Setting Per Vertex mask feathering
In After Eff ects, each individual vertex along a mask’s edge can have a diff erent feathering 
value set for it. Unlike using the Mask Feather property, which allows you to control any 
horizontal or vertical feathering to set the feathering for individual vertices, you use the 
Mask Feather tool. This tool is used to create feather points along the edge of a mask. You 
can remove these points to increase or decrease the amount of feathering along the mask 
edge between points. In this part of the lesson, you will use a variation of the fi le that you 
were previously working with. 

1 Choose File > Open Project and navigate to the ae05lessons folder. Locate the fi le 
named Setting Per Vertex Feather.aep and double-click it to open it. If you haven’t 
already saved your current project, you are prompted to do so now. Choose File > Save 
As. If necessary, navigate to the ae05lessons folder on your hard-drive. In the Save As 
fi eld, name the fi le Setting Per Vertex Feather-working.aep and click Save.

2 Click the single layer in the Timeline panel and press the M key on your keyboard 
once to reveal the two masks that this layer contains.

3 In the Tools panel at the top of the After Eff ects interface, click and hold the Pen tool 
to reveal the other tools that are grouped with it. Click the Mask Feather tool once it 
becomes revealed to activate it.

Click and hold any tool with an arrow in its lower corner to reveal the tools that are 
grouped with it.
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4 In the Timeline panel, click the horizontal mask to make it active, and using the Mask 
Feather tool, click the bottom center of the mask to create a new feather point.

The Mask Feather tool is used to add, delete, or move feather points.

5 Click at the bottom left and bottom right corners of the horizontal mask to add 
additional feather points at each. 

If you have only one feather point on a mask path, adjusting it changes the mask feathering along all edges equally.
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6 With the Mask Feather tool, click the center feather point and drag it downward, 
away from the mask. This creates an eff ect where the mask is feathered more along the 
bottom than at each corner.

The Mask Feather tool becomes an arrowhead when it is hovering above a feather point.

7 Deselect everything by choosing Edit > Deselect All, and then turn off  the 
Proportional Grid using the Choose grid and Guide options drop-down list. This will 
allow you to see the feathering of the mask more clearly.

You can animate Per vertex mask feathering using the Mask Shape property. 

8 Save your fi le by choosing File > Save or by pressing Ctrl+S (Windows) or 
Command+S (Mac OS) on the keyboard. You can now close the fi le.

Creating freeform masks
Geometric masks can be very useful design tools, especially when creating title sequences 
or other onscreen graphics. However, the weakness of only being able to create masks 
in uniform shapes becomes obvious the moment you need a mask to follow a specifi c 
contour. In situations like this, the Pen tool is one of the most powerful and helpful tools 
you have. Similar to the Pen tool in applications such as Photoshop and Illustrator, the Pen 
tool in After Eff ects creates vector paths that when closed, form masks that hide or reveal 
areas of a layer. The Pen tool creates vertices that can be either corner points to form 
straight lines or Bézier points to form curves. 
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In this exercise, you will create a path composed of both curves and straight lines that 
follows the contour of an object in a video source, and you will then animate the mask’s 
vertices as the object’s position on-screen changes.

Setting up the project
1 Choose File > New > New Project. If you haven’t already saved your current project, 

you are prompted to do so now. This creates a new Untitled project for you to work 
in. If you have just opened After Eff ects, you already have a new Untitled project open 
and can skip this step.

2 Once you have created the new project, choose File > Import > File. In the Import 
dialog box, navigate to the ae05lessons folder, and then to the video subfolder. 

Double-click on the Creating Freeform Masks.mov fi le to import it. This footage is 
composed of a montage of automobiles driving toward the camera.

3 In the Project panel, drag the Creating Freeform Masks.mov footage item to the New 
Composition button ( ) at the bottom of the panel. This creates a new comp that 
matches the properties of the video fi le.

4 Again choose File > Import > File and navigate to the images subfolder of the 
ae05lessons folder. Locate the fi le named Tony Black Presents.tif and double-click to 
import it.

In the Interpret Footage dialog box, choose Straight–Unmatted as the Alpha channel 
type and click OK.

Drag the fi le into the Creating Freeform Masks composition above the video layer.

Alpha channels allow layers to have transparent areas.
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5 Click on the fi rst layer, the one named Tony Black Presents.tif. Press the Enter 
(Windows) or Return (Mac OS) key on your keyboard and rename it to 3D logo.

Rename the Creating Freeform Masks.mov layer to car video. In the next steps, you 
will change the duration of the 3D logo layer so it only appears on-screen for a short 
time, rather than for the entire duration of the composition as it does now.

6 Move the playhead to the 5 second (0;00;05;00) mark on the Timeline and click on 
the 3D logo layer to highlight it. 

The beginning of a layer is called the In Point, while the end is called the Out Point. 
When added to the Timeline, image layers are assigned a duration that matches the 
length of the composition. You can trim them (that is, you can adjust their In and Out 
points) so that you can specify their duration. Place the Selection tool ( ) at the beginning 
of the layer duration bar. When a double-headed arrow appears, press and hold the Shift 
key on your keyboard and click and drag the layer’s In Point to the playhead.

If you prefer keyboard commands, then pressing Alt+[ (Windows) or Option+[ (Mac OS) 
trims the In Point of the layer to the playhead.

Holding down the Shift key makes the layer In Point snap to the playhead.
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7 With the 3D logo layer still highlighted, move the playhead to the 7 second 
(0;00;07;00) mark on the Timeline.

Place the Selection tool at the end of the layer duration bar. When a double-headed 
arrow appears, again press and hold the Shift key on your keyboard and click and drag 
the layer’s Out Point to the playhead.

If you prefer keyboard commands, pressing the Alt+] (Windows) key or Option+] (Mac OS) trims the Out Point of the layer 
to the playhead.

8 With the 3D text layer highlighted, press the I key on your keyboard to jump to the 
In Point of the layer. Choose File > Save As. Navigate to the ae05lessons folder on 
your hard drive. In the Save As fi eld, name the fi le Creating Freeform Masks-
working.aep and click Save.

In the next exercise, you will use the Pen tool ( ) to create a mask that conforms to 
the contour of the car.

Drawing the mask

For this exercise, you will create a mask that follows the right-side contour of the car and 
then extends outside the composition boundaries to enclose the content of the 3D logo 
layer. While you can use the shape tools to create masks in standard geometric shapes, you 
must use the Pen to create your own custom masks. The Pen tool creates vertices and the 
application creates line segments to connect each new vertex to the preceding one.

1 With the Creating Freeform Masks-working project open, choose Proportional Grid 
from the Grid and Guide Options drop-down menu at the bottom of the Composition 
panel.

2 Set the Magnifi cation ratio to 200% from the drop-down menu on the left side of the 
Composition panel. 

You may have to pan the Composition panel using the Hand tool ( ) so that you see 
the top of the proportional grid. Depending on your screen resolution, you may have 
to do this several times while creating the mask.

While hovering over the Composition panel, you can press and hold the spacebar on the 
keyboard to toggle the active tool to the Hand tool.
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3 Click on the 3D logo layer in the Timeline to highlight it, and choose the Pen tool in 
the Tools panel at the top of the After Eff ects interface to make it active.

Click with the Pen tool at the topmost point of the second vertical grid line from the 
left to create the fi rst vertex of your path.

Masks are always applied to the layer that you want them to aff ect.

4 Place the Pen tool where the grid line intersects the top of the car and click to create a 
second vertex.

Use the Pen tool to create vertices, the line segments are created between them automatically.
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5 Place the Pen tool at the top of the windshield just below the T in Tony. Click and drag 
with the mouse to create a curved line segment that matches the shape of the car’s roof.

To create curved line segments, you must always 
remember to click and drag with your mouse.

As long as you don’t release the mouse button, the program allows you to reposition the curve you 
are currently creating, but the moment you release the button, the line segment is created.

There are two problems that you must now address. The fi rst is that the default mask 
color is yellow, which is very hard to see against the video’s white sky background. 
The second problem is that the graphic that you want to mask is currently obstructing 
your view of the car’s contour.

6 Press the M key twice in rapid succession to reveal the mask’s properties in the Timeline. 

To the left of the mask name is a small yellow box that represents the mask’s color; 
click on this box to open the Mask Color dialog box.

The default color of the mask’s outline can be changed to make it easier to view. 

Change the color to R: 0, G: 78, B: 255 and click OK. This results in a light-blue 
mask color that is much easier to see.

Fixing the visibility issue is even easier; just click off  the Video switch for the 3D logo 
layer. A layer doesn’t have to be visible for you to create a mask on it.
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7 Returning to the Composition panel, if you were to try and create the next vertex, it 
wouldn’t fi t the curve of the windshield exactly. This is because of the position of the 
third vertex’s point’s directional handle, which must be adjusted so that it matches the 
beginning angle of the windshield’s arc.

Place the Pen tool on the downward-pointing directional handle, and then press and 
hold the Alt (Windows) or Option (Mac OS) key on your keyboard. When you do 
this, the pen changes to a karat symbol ( ). This is the Convert Vertex tool and you 
can use it to refi ne directional handles. Click and drag with the tool to move the 
handle so that it matches the images below. The length and angle of a directional 
handle control the height and angle of the curve it creates.

As you become more skilled with using the Pen tool, you will have to make 
fewer adjustments to your initial Mask Paths. 

The best color to use when creating a mask makes depends on several factors, including the colors 
used in the video footage, the color settings of your monitor and personal preference. You can 
change the mask color at any time until you fi nd a color that makes it easy for you to work with 
the mask. 
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8 Place the Pen tool at the top of the side mirror, then click and drag to form the curve 
of the windshield. 

When using the Pen tool clicking and dragging when you create a new vertex creates a bezier (smooth) line.

Adjust the directional handle as in the previous step by holding the Alt (Windows) or 
Option (Mac OS) key to activate the Convert Vertex tool and match the length and 
angle of the mirror’s curve.

Continue to create the vertices and adjust the direction handles until you reach the top 
of the bumper.

As you practice and use the pen tool more often you will be able to better estimate where to place your vertices.
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9 Now at the top of the bumper you want to create a straight line, but that smooth 
point will always try to create a curve, and so it has to go. Place the Pen tool over the 
direction handle and again press and hold the Alt (Windows) or Option (Mac OS) key 
on the keyboard to activate the Convert Vertex tool, then click and drag the direction 
handle into the vertex. This collapses it, creating a corner point and now allows you to 
create a straight line.

Bezier points have two directional handles while corner points tend to have only 
one or zero direction handles.

10 Click at the outside edge of the bumper, and then again outside of the composition 
border to the right. Create another vertex outside the top right of the composition as 
shown in the image below.

When creating masks it is often helpful to extend them just beyond the composition border as it is easier than 
trying to create a mask that conforms to the border edge.
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11 Place the Pen tool on top of the fi rst vertex that you created at the beginning of this 
exercise until it becomes a Pen Head icon ( ) with a circle next to it. This indicates 
that you will close the path and complete the mask.

When you are creating a mask with the pen tool the fi rst vertex on the mask is always distinguished by 
its double square highlight.

12 Click the 3D logo layer’s Video switch back on to see the eff ect of the mask. Any part 
of the layer that is outside of the Mask Path is hidden.

When you hover your cursor over the fi rst vertex on a mask the cursor will change to indicate that you can 
now close the path you are creating.

13 Save your fi le by choosing File > Save. Do not close this fi le; you will need it in the 
next part of the lesson.
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Animating the shape of masks
The Mask Path property stores the position of all the individual vertices in a mask. When 
the position of these vertices is changed over time, After Eff ects automatically interpolates 
the change to create a smooth blending of the diff erent Mask Paths. In this section, you 
will animate the vertices of the path that you previously created so that it will adjust as the 
car moves in the video.

1 With the Creating Freeform Masks-working project still open, set the Magnifi cation 
ratio of the Creating Freeform Masks composition to Fit Up To 100% in the drop-
down menu on the left side of the Composition panel.

2 In the Timeline, click on the 3D logo layer to highlight it; this also highlights all the 
vertices of the mask.

With the playhead at the In Point of the layer, activate the Time-Vary Stopwatch ( ) 
for the Mask Path property to enable animation and create the fi rst keyframe. When 
animating the Mask Path property, any change made to the position of the mask’s 
vertices creates a new keyframe.

3 Press the O key on the keyboard to jump to the Out Point of the layer. Now that the 
car is in a diff erent position, you must adjust the mask. Click on the layer name to 
deselect the mask. 

It is very important that you deselect the mask before attempting to move the vertices. When the 
mask is selected, the Selection tool moves all its points simultaneously, which isn’t what you want 
to do here.

Using the Selection tool, click on the vertex that used to be at the top of the car’s roof, 
and drag it up so that it matches the new position of the car.
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Repeat this with the rest of the vertices until they all match the fi gure below. For 
some of the vertices, moving them won’t be enough, and you will also have to adjust 
their direction handles to match the curvature of the car’s body.

Once you begin to animate the Mask’s path some of the vertices may seem unnecessary. What ever 
you do, do not delete any of them. Deleting a vertex will remove that same vertex across all your 
keyframes, changing the shape of the mask so that it may no longer match the contour of the car.

This adds a second keyframe to set the ending position of the mask.

4 Move the playhead to the 6 second (0;00;06;00) mark on the Timeline. This places it 
right in the middle of the two keyframes you just created.

Adjust the mask vertices to match the contour of the car, as shown below.

You now have a third Mask Path keyframe in between the fi rst two.
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5 Move the playhead to the 5 second 15 frame (0;00;05;15) mark on the Timeline. This 
places it right in the middle of the fi rst two keyframes. Again adjust the mask vertices 
to match the contour of the car.

6 Move the playhead to the 6 second 15 frame (0;00;06;15) mark on the Timeline. This 
places it in the middle of the last two keyframes. Adjust the vertices again so that they 
follow the shape of the car.

7 In the Timeline, change the Mask Feather property to 2.0. With the Constrain 
Proportions switch enabled, you only have to change one of the values.

8 Move the playhead to the 4 second (0;00;04;00) mark on the Timeline and preview 
the animation. The mask is now animated so that it hides the 3D logo as the car 
moves across the screen.

This example needed very few keyframes to work well; the more movement there is in the 
video, the more keyframes are usually required. This technique of adding keyframes in between 
keyframes is more effi  cient than adding a new keyframe to every frame sequentially.

9 Save your fi le by choosing File > Save or by pressing Ctrl+S (Windows) or 
Command+S (Mac OS) on the keyboard.

Understanding track mattes
Track mattes, also called traveling mattes, are a technique used to hide or reveal areas of 
a video layer. They are similar to masks in this way but very diff erent in how they create 
the eff ect. While masks use vector-based line shapes to isolate areas of a layer, track mattes 
can use either alpha or luminance. Alpha is the technical name for what most people call 
transparency, while luminance is a measure of brightness. 

A very common source for track mattes is a text layer. This technique, often called clipping 
masks in programs such as Photoshop and Illustrator, allows the text layer to mask out the 
layer below it so that you can see an image or video inside the text shapes. Because track 
mattes are layers, you can animate them by adding keyframes for the layers’ properties such 
as scale, position, and vertices, or by animating eff ects that change their appearance.

Creating track mattes 
You can create track mattes from the alpha or luminance channels of video or still-image 
layers. Layers with an alpha channel are usually the easiest to work with, though using 
luminance can be just as successful if you have a high-contrast image to use as your matte. 
There are two things to keep in mind when working with the track matte feature in After 
Eff ects: the fi rst is that the track matte must be the layer right above the one to be masked 
out and the second is that you can only have one track matte per masked layer. If you need 
to have multiple layers acting as a track matte, then you must fi rst combine those layers 
into a new composition.
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In this part of the lesson, you will use an animation that has been built in After Eff ects to 
construct a track matte eff ect to reveal a hidden video layer.

1 Choose File > Open Project and navigate to the ae05lessons folder. Locate the fi le 
named Creating a Track Matte.aep and double-click to open it. If you haven’t already 
saved your current project, you are prompted to do so now.

This project consists of a series of Compositions. The one named Washington DC 
Travelogue Opening is the main comp you will work with in this section of the 
project. If it is not already active, double-click this comp in the Project panel to 
reveal it. Then preview the comp by scrubbing the playhead; notice that it contains 
an animation where text is fl ying in from off -screen and then disappears by fl ying 
forward toward the viewer.

2 Choose File > Import > File and navigate to the video subfolder of the ae05lessons 
folder. Locate the fi le named Creating Track Mattes.mov and double-click to import it.

3 Drag the Creating Track Mattes video fi le from the Project panel to the Timeline. 
Place it below the [Comp-in 1 Minute] layer. This covers the layer with the 
Washington, D.C. title on it, but that will be automatically corrected once you turn 
the top layer into a track matte.

Track mattes must either be layers with very high contrast (usually black and white) or layers that have transparent areas.

4 Click the Expand or Collapse Transfer Controls Pane switch located at the bottom left 
of the Timeline to expand the pane and reveal the Track Matte option.

The diff erent panes in the timeline panel can be expanded or contracted at will.

5 For the video layer, choose Alpha Matte “[Comp-in 1 Minute]” from the TrkMat 
drop-down menu in the pane. The video layer is completely hidden. Preview the 
animation, and you can see that the video is now only visible when the content of the 
[Comp-in 1 Minute] layer is onscreen.

The video layer now uses the alpha channel of the layer above it to control what areas 
are visible. Wherever the layer is opaque, you can now see the video layer, so as the 
animation progresses you can see more and more of the video until it is fully revealed. 
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In the next step, you will clean up the timeline by changing the In Point of this video 
layer so it begins when the track matte layer does.

6 Click the fi rst layer (the one named [Comp-in 1 Minute]) to make it active, and then 
press the I key on your keyboard to move the playhead to the In Point of this layer.

7 Click the video layer (the one named [Creating Track Mattes.mov]) to make it active, 
and then press and hold the Shift key on your keyboard while dragging the In Point of 
this clip to the current position of the playhead.

8 Click the Expand or Collapse Transfer Controls Pane switch located at the bottom left 
of the Timeline to hide the pane.

9 Choose File > Save As. Navigate to the ae05lessons folder on your hard-drive. In the 
Save As fi eld, name the fi le Creating a Track Matte-complete.aep and click Save. 
You can now close this fi le.

Creating mattes from animated Photoshop files
While there are some people who only work in After Eff ects, the majority of users also 
work with other graphics programs such as Photoshop and Illustrator to create artwork 
either as stand-alone graphics to animate or to build support graphics such as masks and 
track mattes. Most people are familiar with Photoshop as an image editing and painting 
program, but what many do not realize is that Photoshop also has a Timeline very similar to 
After Eff ects. The Photoshop animation that is used in this section was created by animating 
a brush to fi ll the screen over time, until the entire screen is black. When this document is 
imported into After Eff ects, it will be treated as a video fi le. In this section, you will create a 
new project and use an animated Photoshop fi le to create a track matte for a video fi le.

1 Choose File > New > New Project. If you haven’t saved your current project, you are 
prompted to do so now.

2 In the new project, choose File > Import > Multiple Files and navigate to the video 
subfolder of the ae05lessons folder. Locate the fi le named Creating Track Mattes.mov 
and double-click to import it. When the Import dialog box opens, again navigate to 
the images subfolder of the ae05lessons folder and double-click on ani track matte.psd 
to import it as well. Importing a Photoshop fi le will open a secondary options dialog, 
in this Import options dialog box, choose Footage as the Import Kind and confi rm 
that the Merged Layers radio button is active.
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Click OK to import this fi le.

Photoshop fi les have extra options that can be set in a secondary 
dialog box when they are imported into After Eff ects.

When the Import dialog box appears again, click the Done (Windows) or Cancel 
(Mac OS) button to close it.

3 Click on the Creating Track Mattes.mov footage item in the project panel and drag 
it into the empty Timeline panel. This automatically creates a new composition with 
the same properties and name as the video fi le, and is the most effi  cient way to create a 
composition that matches the settings of a specifi c piece of footage.

Creating a composition in this manner set the background color to the color that was 
used the last time a comp was created. Choose Composition > Composition Settings 
and at the bottom of the dialog box click on the background color swatch and change 
it to black. Click OK to close the dialog box.
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4 Drag the ani track matte.psd footage item into the Timeline and place it above 
the video layer. You should now see a large, black ink spot on a white background 
covering the composition.

Track mattes must always be placed above the layer you want to apply them to.

5 Scrub the playhead to preview the Photoshop animation. The ink spot multiplies until 
it completely overtakes the white background. The high-contrast image will make a 
good luminosity-based track matte.

Expand the Transfer Controls pane by clicking the switch ( ) on the lower-left corner 
of the Timeline panel. 
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6 Choose Luma Inverted Matte “ani Track Matte.psd” from the video layer’s TrkMat 
drop-down menu. The video layer is now visible in the shape of the ink spot, and 
surrounding it you see the composition’s background color.

Track Mattes are often used to create custom transitions in video like the one you are 
creating in this exercise.

Animated Photoshop fi les can be a very good way of creating a custom transition and they are a lot of fun to make.

7 Choose File > Import > File and navigate to the video subfolder of the ae05lessons 
folder. Locate the fi le named Creating Shape Masks.mov and double-click to import it.

Drag the Creating Shape Masks.mov footage item from the Project panel to the 
Timeline and place it below the video layer so that it become the new lowest layer.

8 Click the Expand or Collapse Transfer Controls Pane ( ) switch located at the 
bottom left of the Timeline to hide the pane.

9 Preview the animation and then save the fi le by choosing File > Save As. Navigate 
to the ae05lessons folder on your hard drive. In the Save As fi eld, name the fi le 
Photoshop Track Mattes_fi nal.aep and click Save.
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Creating a chroma key
Masks and track mattes can be very good tools for isolating and revealing areas of a video 
image. However, when dealing with subjects that move a lot or where you need a great 
deal of detail, trying to use either technique would be extremely time-consuming. This 
is where chroma keying comes in. Chroma keying allows you to composite two images 
together by removing a specifi c color from one of them. Most often, chroma keying is 
used when you shoot video of your subject in front of a blue or green screen and then 
replace it with a diff erent background. This technique is often referred to as color keying, 
blue screening, or green screening and is often used on television in weather reporting and 
in fi lms that make extensive use of virtual backgrounds and set extensions. 

In this part of the lesson, you will create a new project, import the video you will use, and 
set up the Timeline.

1 Choose File > New > New Project. If you haven’t saved your current project, you are 
prompted to do so now. If you have just opened After Eff ects it will not prompt you to 
save the default project if you haven’t added anything to it.

2 Choose File > Import > File and navigate to the video subfolder of the ae05lessons 
folder. Locate the fi le named greenscreen footage.mov, then press and hold the Control 
key (Windows) or command key (Mac OS) on your keyboard, and click on Creating 
Track Mattes.mov to add it to your selection. Click the Open button to import both fi les.

Once the fi les have been imported you can preview them in the footage panel by 
double clicking on either footage item in the Project panel. You have worked with the 
Creating Track Mattes fi le earlier in this lesson, here it will be used as the background 
of the composition. The Greenscreen-BusinessMan video fi le is footage of an actor in 
a suit shot in front of a greenscreen.
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3 Choose Composition > New Composition to open the Composition Settings dialog box.

• Change the Composition Name to Secret Agent Man.

• Set the Preset drop-down menu to NTSC DV.

• Set the Resolution drop-down menu to Full.

• Set the Duration to 8 seconds (0;00;08;00) and the background color to black 
(R: 0, B: 0, G: 0).

The NTSC preset is used for creating footage that conforms to the standard defi nition 
broadcast standard used in the United States.

Click OK to close the Composition Settings dialog box and create the new comp.

4 Drag the Creating Track Mattes.mov footage item from the Project panel to the 
Timeline, and then add the greenscreen footage.mov item above it.
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5 The greenscreen footage was shot in a high defi nition widescreen format and then 
converted to the standard defi nition fi le you see here. Because of this there are black 
bars at the top and bottom of the video frame that place the actor’s body above the 
base of the composition frame.

If necessary, move the playhead to the beginning (0;00;00;00) of the Timeline and 
then click on the greenscreen footage.mov layer and press the P key on your keyboard 
to reveal its position property. Change the Y position to 300. This makes the new 
position value 360.0, 300.0. Move the actor to the base of the composition so that he 
won’t appear to be cut off  at the waist once the layer’s background is removed.

When combining video shot at diff erent aspect ratios of sizes it is 
often necessary to adjust positioning manually.

6 Choose File > Save As. Navigate to the ae05lessons folder on your hard drive. In the 
Save As fi eld, name the fi le Creating a Chroma Key-working.aep and click Save.

Creating a garbage matte
The fi rst step in the chroma keying process is to create a garbage matte to isolate the 
subject and the area immediately around it. A garbage matte is a quickly drawn mask; it 
doesn’t have to be that precise, just a rough shape that removes any extraneous areas of the 
video frame. When using a green screen, technically the only area that matters is the area 
around your subject, especially if it is moving. Often you will see parts of the set, such as 
a light stand or the frame holding the screen at the edges of the video frame; the garbage 
matte blocks all those elements out. 

An important point to remember about using a garbage matte is that it has to completely 
enclose the subject. If the subject is moving, the vertices of the mask may need to be 
animated as well. When used properly, garbage mattes also allow the keying eff ect to be 
focused on a smaller area, which allows it to be applied more quickly. This footage is an 
example of a situation where the greenscreen is only used behind the actor. If you look 
at the right and left sides of the video you can clearly see the black border and part of the 
frame that was used to hold up the screen for the video shoot. A garbage matte will be 
used to hide these areas, as well as the black letter boxing bars at the top and bottom.
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1 With the Creating a Chroma Key-working project still open, click on the green screen 
footage layer in the Timeline to highlight it.

Move the playhead to the 6 second and 24 frame (0;00;06;24) mark on the timeline. 
The actor moves a bit and this point on the timeline show the point at which he is 
furthest to the right of the screen. When you have greenscreen footage where your 
subjects are moving, it is important to make sure your garbage matte is large enough 
to accommodate it.

2 With the greenscreen footage layer still selected click on the Rectangle tool in the 
Tool panel to activate it. 

Click and drag with the Rectangle tool from the upper left of the green screen footage 
to the lower right to create a mask like the one seen in the fi gure below. You want 
to create the mask so that the fi gure ends up with only the green screen background 
around him. Make sure that the mask crops out the stand that was used to hold up the 
greenscreen, you should be able to see it on the far right and left of the video frame.

The mask doesn’t have to be exact, which is why it’s called a garbage matte.

When creating a garbage matte, you want to use enough vertices that you will be able to animate 
it if necessary to fi t the movements of your subject.

3 Preview the video fi le by dragging the playhead slowly back and forth. The subject 
moves a little left and right in this video, so make sure the mask doesn’t cut off  any 
part of him. The most likely areas to cause a problem are the top of his head, and his 
left and right arms.
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As you are doing this, you may notice that you have misjudged the space you will 
need around the fi gure; at this point you can adjust the vertices of the mask with the 
Selection tool, as you learned how to do earlier in this lesson.

In this lesson, you only have to create a garbage matte that is large enough to not cut out any of 
the fi gure’s action. To do this, you create a rather large mask, an alternative approach would be to 
create a smaller mask that matches the contours of the fi gure and then animate the position of the 
points on the path using the Mask Path property so that it adjusts to the actual movement of the 
fi gure and stays as tight as possible in all frames.

4 Save your fi le by choosing File > Save, you can also use a keyboard command, by 
pressing Ctrl+S (Windows) or Command+S (Mac OS) to save the fi le.

Creating a chroma key 
There are actually several diff erent chroma keying eff ects that you can use in After Eff ects. 
On this footage, you will apply a color range key that allows you to select multiple colors 
to remove instead of only one. This is very helpful in situations such as this, where the 
background screen may not be evenly lit, producing a range of green or blue tones. In this 
part of the lesson, you will add a Color Range key to remove the green screen background. 

1 With the Creating a Chroma Key-working project still open, click on the green screen 
footage layer in the Timeline to highlight it.

If necessary, move the playhead to the 6 second and 24 frame (0;00;06;24) mark on the 
Timeline.

2 With the green screen footage layer highlighted, choose Eff ect > Keying > Color 
Range. This opens the Eff ect Controls panel if it is not already open so that you can 
edit the properties of the eff ect you have just applied.

The default setting of the Color Range eff ect will sometimes be enough to remove parts of the footage.

A side eff ect of applying the key is that a part of the fi gure’s body will automatically be 
removed; you will correct this when you set the actual key color in the next step.
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3 The Color Range eff ect uses three eyedroppers: one to set the key color and the 
other two to add or remove colors from the color range to key out. Click on the 
top Eyedropper tool ( ) in the Eff ect Controls panel next to the black-and-white 
thumbnail of the layer, and then click on the green background near the man’s left 
shoulder; this begins keying out the background.

Use the three Eyedropper tools to set the color range to key out.

4 Click on the second eyedropper ( ), the one with the plus sign next to it, this 
eyedropper is used to add colors to the color range that the eff ect removes. With this 
eyedropper active, click on the area that is still green near the man’s head. Since the 
green screen consists of a wide range of colors, depending on which area of green you 
click on your results will vary.

Use the second eyedropper to add areas to the color range to key out.
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5 Again click on the eyedropper with the plus sign next to it and continue to use it to 
add green areas to the selection until there is only a slight green border surrounding 
the man.

Look at the Black and White thumbnail in the Eff ect Controls panel; it represents 
the alpha channel of the layer. The white area represents the opaque parts of the layer 
while the black areas represent the parts that are transparent. Your goal is to have the 
contour of the fi gure entirely white, while the rest of the layer is entirely black.

You have to click on the plus eyedropper tool every time you want to add a new color to the color 
range that you want to make transparent.

The Color Range eff ect tends to leave a fringe around your subjects, which you can remove by 
adding additional eff ects to the layer.

6 In the Eff ect Controls panel, change the Fuzziness to 30. Fuzziness is the tolerance of 
the eff ect; increasing the value for tolerance widens the range of colors being selected. 
In this case, it removes some of the green fringe around the fi gure. 

You often need to complement a chroma key with additional eff ects 
before it can be considered acceptable.
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If you increase the fuzziness too much, it begins to remove the fi gure as well; when 
using a chroma key, it is usually better to err on the side of caution, leaving a fringe 
around the subject and using other tools to remove it later. This is what you will do in 
the next part of this lesson.

7 Save your fi le by choosing File > Save or by pressing Ctrl+S (Windows) or 
Command+S (Mac OS) on the keyboard.

Refining the matte
After the chroma key is created, it is often necessary to refi ne the mask that it creates in 
order to remove additional background area. Instead of trying to overdo any one eff ect, it 
is usually best to combine diff erent eff ects until you have removed the color background. 
Now that you have used the Color Range Key eff ect to create a matte, you will enhance 
it with a Matte Choker eff ect and then the Spill Suppressor eff ect. When using the Matte 
Choker eff ect, there are three properties you must be aware of:

Geometric Softness: This property is used to specify the largest possible spread or choke 
for the eff ect.

Choke: This property sets the amount of the choke or spread. You use positive values to 
choke the matte, and negative values to spread it.

Gray Level Softness: This property specifi es how feathered (soft) the edges of the matte 
are. A setting of 100 percent produces the softest edge and can sometimes appear blurry.

Each property has both a primary (labeled with the number 1) and secondary (labeled with 
the number 2) eff ect. The reason for the repeat settings is so that the eff ect can be used to 
both spread and choke a matte simultaneously. In general, the secondary settings are used 
to inverse the eff ect of the primary ones.

1 With the Creating a Chroma Key-working project still open, click on the green screen 
footage layer in the Timeline to highlight it.

2 Choose Eff ect > Matte > Matte Choker to apply the Matte Choker eff ect to the footage. 

The Matte Choker is an eff ect that you use to both choke (tighten) and spread (loosen) 
a matte. You can use it to fi ll in transparent holes that can be created as a result of 
using a keying eff ect or to modify the edge of a keyed area while preserving its shape. 
The eff ect can perform both a choke and spread because it duplicates the eff ect using a 
primary and secondary set of properties. 
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The default settings of the eff ect will choke the matte and cut off  the outside edge of 
the fi gure, removing much of the green fringe.

The default settings of matte choker can be helpful but you will 
usually want to adjust them to fi t the specifi cs of your footage.

3 Move the playhead to the beginning (0;00;00;00) of the timeline and then press the 
spacebar to preview the animation; the edge of the matte looks a little rough and 
jagged. You can also still see areas of the greenscreen in the space between the fi gure’s 
arms and body. This is especially noticeable when his arms are moving. Move the 
playhead back to the 6 second and 24 frame (0;00;06;24) mark on the timeline. In the 
Eff ect Controls panel make the following adjustments to the properties of the Matte 
Choker eff ect.

• Change the value for Geometric Softness 1 to 3.0.

• Change the value for Choke 1 to 50.

• Change the value for Gray Level Softness 1 to 20%.

This softens the matte edge for this footage so that is no longer appear so jagged and 
trims away less of the fi gure himself.

Finding the right settings for chroma-keying eff ects usually requires a lot of trial and error.
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Keep in mind that the settings listed here are the result of trial and error. To achieve them, 
diff erent settings were tested and previewed to fi nd the ones that produced the best results. The 
settings that you use will vary, depending on the footage and your needs. Even in this exercise, 
depending on how tight you were able to make the initial color range key you may want to use 
diff erent values on the Matte Choker eff ect to achieve a better result on your own footage.

4 Move the playhead to the beginning (0;00;00;00) of the timeline and then press the 
spacebar to preview the animation. You can still see those small areas of the green screen 
in the space between the fi gure’s arms and body. To remove these you will go back to 
the Color Range eff ect and add these areas to the color range that is being keyed out.

Move the playhead to the 2 second and 15 frame (0;00;02;15) mark on the timeline. At 
this point you should be able to see semi-transparent area of the greenscreen between 
his arms. 

In the Eff ect Controls panel change the Fuzziness property to 40. This will refi ne the 
key and help remove additional green areas.

5 There is still a slight green fringe around the fi gure; you can remove this using an 
eff ect named Spill Suppressor.

With the green screen footage layer highlighted, choose Eff ect > Keying > Spill 
Suppressor to add the eff ect. The default setting suppresses blue and must be adjusted 
to work on the green fringe, but it’s very diffi  cult to select the green background with 
the Color Range eff ect enabled.
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6 In the Eff ect Controls panel, disable the Color Range eff ect by clicking the fx switch 
to the left of the eff ect name. 

With the eff ect now disabled, click on the eyedropper switch ( ) for the Color to Suppress 
property. With the eyedropper active, click on the green background to suppress it. 

The ability to toggle eff ects on and off  
can be very helpful for preview purposes.

Re-enable the Color Range eff ect by clicking the fx switch back on.

If you fi nd it diffi  cult to see the results of the Spill Suppressor eff ect, you can disable 
and re-enable it to see how it neutralizes the green tint both around the edge and 
inside the fi gure.

When you click on the green background with the Color Suppression selector, the background 
turns gray. This eff ect only appears this way because the Color Range Keying eff ect has been 
disabled. Once all the layer’s eff ects are active, again they are applied in the order they are listed 
in the Eff ect Controls panel. 

7 Save your fi le by choosing File > Save or by pressing Ctrl+S (Windows) or 
Command+S (Mac OS) on the keyboard.

Congratulations! You have fi nished this lesson.

AECS6_06Pass.indb   173AECS6_06Pass.indb   173 5/18/12   1:06 PM5/18/12   1:06 PM



5 Review

Adobe After Eff ects CS6 Digital Classroom174

Self study
Reopen the Creating Shape Mask-working project that you created earlier in this lesson 
and experiment with changing mask modes on both masks to see what types of eff ects you 
can create using the exact same animation. 

Review
Questions
1 What are the four properties of masks and what does each one do?

2 What are the two properties that a track matte can be based on in After Eff ects?

3 What is the reason for creating a garbage matte?

Answers
1 The Mask Path property specifi es the position of the points that make up the mask. 

This property is animated whether you want to move all the points of a mask or only 
some of them, to create the eff ect of a mask moving around a layer or changing shape.

The Mask Feather property specifi es the softness of the edge of a mask. As a result of 
feathering, a mask’s edge becomes more transparent, creating the eff ect of a layer with 
edges that fade into its background.

The Mask Opacity property sets the amount of infl uence that a mask has over the 
visibility of the layer that it is on. Set at its default value of 100 percent, the layer the 
mask encloses will be at full opacity.

The Mask Expansion property expands or contracts the edges of a mask.

2 Alpha and luminance. Alpha is the transparency information of a layer, while 
luminance is the brightness information of a layer. Track mattes can be created by 
applying either the straight alpha or luminance information or by inverting it.

3 A garbage matte is used to remove extraneous areas of the background that aren’t 
necessary for the chroma key eff ect.
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What you’ll learn in 
this lesson:
• Creating and Editing Text

• Creating and Saving Text 
Animators

• Applying and Modifying 
Text Animation Presets

• Creating and Animating text 
that follows a mask path

Lesson 6

Even in the days of fi lm and video, text remains a very powerful 
tool for communicating ideas. The animation features in After Eff ects 
make it an extremely powerful application for working with text. In 
this lesson, you will learn about the diff erent types of text and how 
to work with them.

Starting up
You will work with several fi les from the ae06lessons folder in this lesson. Make sure that 
you have loaded the aelessons folder onto your hard drive from the supplied DVD. See 
“Loading lesson fi les” on page 4.

See Lesson 6 in action!

Use the accompanying video to gain a better understanding of how to use some of the features 
shown in this lesson. The video tutorial for this lesson can be found on the included DVD.

6

Working with Text
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Setting up

As you work in After Eff ects, you will inevitably open and close many panels depending 
on the type of project you are creating. However, when working through the projects in 
this book, it is important to have an interface that matches the lessons. To this end, you 
should always reset your workspace to the preset Standard confi guration.

1 Choose Window > Workspace > Standard to set your current workspace 
confi guration.

2 Choose Window > Workspace > Reset “Standard” to reset the standard workspace in 
case you have modifi ed it at some point. 

Creating text
Creating and editing text in After Eff ects is very similar to creating text in design 
applications such as Adobe Photoshop or Illustrator. Once it has been created, the way 
you edit it is almost identical to how you would edit it in a word processing program. You 
can adjust most of the common text properties that you may be familiar with, such as font 
family and style, size, leading, tracking, and kerning. There are two kinds of text that you 
can create in After Eff ects: point text and paragraph text. In this exercise, you will create 
a new document and then add text to it. You will then be guided through how to format 
and animate that text. The text you will be working with in this lesson is from the poem 
“Jabberwocky” by Lewis Carroll.

Point Text: You create point text when you click with the Text tool and just start 
typing. This text lacks a frame, and a new line is only created when you press the Return 
(Mac OS) or Enter (Windows) key on your keyboard. Point text is good for stand-alone 
areas of text and off ers a very intuitive way of working. It also works well when you want 
to create a headline or other small area of text, but it lacks the ease of use of paragraph text 
for longer text blocks. 

Paragraph Text: This text behaves similarly to text in a word processing program. You 
create it by clicking and dragging with the Text tool to create a text frame of a set width 
and height. You can then type or paste text into this frame, and the text automatically 
wraps to form new lines as needed. When using Paragraph text, it is possible to place 
more text than the frame allows, causing the text to be hidden; this is called overset text. 
Paragraph text works when you have to fi t text into a specifi c area of your composition or 
when working with large amounts of text.

1 Choose File > New > New Project to create a new project. Once the new project has 
been created, choose Composition > New Composition and in the New Composition 
dialog box, change the default name to Jabberwocky.

Choose NTSC DV from the preset menu and set the duration to ten seconds 
(00;00;10;00). Set the background color to black (R:0, G:0, B:0) and leave all other 
fi elds at their defaults and click OK.
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2 From the Grid and Guide Options button at the bottom of the Composition panel, 
choose Title/Action Safe to display the Title-Safe and Action-Safe margins.

A B

A. Action-Safe margin. B. Title-Safe margin.

The Title-Safe and Action-Safe margins are used in video to compensate for the fact 
that most televisions do not display the full image area of a video frame. The Action-
Safe margin is the outer rectangle and represents approximately 90 percent of the 
available screen space, while the Title-Safe area represented by the inner rectangle 
is approximately 80 percent of the full frame size. If you want to be sure that your 
graphics, titles, and animations display on all television screens, you should keep them 
inside the Title-Safe boundary. These boundaries vary by television format and you 
should ignore them if creating graphics solely for display on computer monitors and 
projectors, as these devices display the entire video frame. 

3 Click on the Horizontal Type tool ( ) in the Tools panel to make it active. When 
you activate the Type tool for the fi rst time, the Character and Paragraph panels 
automatically open. 
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4 The Character and Paragraph panels retain the last settings that you used to create or 
edit text. These values remain even when you shut the application down. It is usually 
best to set the initial text properties before you create the text, and then adjust them 
to fi t each composition’s needs. In the Character panel, set the font family drop-down 
menu to Georgia and the font style to Regular, and then set the font size to 40. If 
necessary, set the Fill Color to white (R:0, G:0, B:0). In the Paragraph panel, make sure 
the alignment is set to left. All other values should match those in the image below.

You can set text properties before 
or after you create the text.

5 In the Composition panel, click and drag from the upper-left corner to the lower-right 
corner of the Title-Safe margin to create a text frame.

In After Eff ects, text-editing capabilities are virtually identical to other graphics programs such as 
Adobe Photoshop and Illustrator.
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When you release the mouse, the text cursor becomes active. Type the following text:

Beware the Jabberwock, my son!

The jaws that bite, the claws that catch!

Lewis Carroll (1832–1898)

When displayed in the text box, it looks a little diff erent than it does above. This is 
due to the way that paragraph text breaks to form new lines so that it doesn’t exceed 
the width of the text frame. You will adjust the text in the next exercise.

Please note that you should press Enter (Windows) or Return (Mac OS) at the ends of 
the fi rst and second lines of text, the way you see them above.

An advantage of paragraph text is that new lines are formed automatically, based on the width of the text frame and the 
amount of text.

6 Choose File > Save As. In the Save As dialog box, navigate to the ae06lessons folder, 
rename the fi le Jabberwocky.aep, and click the Save button.

Setting text properties globally
The text that you create in the Composition panel is called the source text, and it is placed 
on a layer in the Timeline. It has properties that you can adjust to create text that conforms 
to the needs of your project. You edit text properties using the Character or Paragraph 
panels. You can use the commands in the Character panel to control the appearance of 
individual characters of text (such as font family, size, and color), while you can use the 
Paragraph panel to change the formatting of each paragraph (such as margin alignment and 
the space between paragraphs). In this section, you will learn how to format the entire text 
area at once, and later you will format individual characters.
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Character and Paragraph panel options

Character panel options
Font family: More technically called a typeface, this is a collection of letters, numbers, and 
symbols that all share a same overall design; examples include Georgia, Times New Roman, 
and Arial.

Font style: A variant of a typeface that usually modifies one property such as character 
thickness or rotation as in the case of bold and italic styles.

Font size: Specifies the size of the text in pixels.

Leading: Sets the space between the different lines of text. The term is taken from the days of 
printing when type was set by hand and strips of lead were used to separate the lines of text.

Kerning: Sets the space between any specific pair of letters. When you place the text cursor 
between a pair of letters, you can specify a numerical value, but when you select multiple 
letters or the entire text field, the only choices are Metrics, Optical, and Zero. 

Tracking: Sets the letter spacing (the amount of space between groups of letters). 

Stroke width: Specifies the thickness of the outline around the text.

Vertical scale: Sets the amount of vertical scaling on text characters. This setting does not 
affect the font size.

Horizontal scale: Sets the amount of horizontal scaling on text characters. This setting does 
not affect the font size.

Baseline shift: The baseline is the invisible line that the bottom of each line of text sits on. 
This setting specifies an offset to move text either above or below the baseline.

Tsume: Reduces the space to the left and right of a selected character by a specified 
percentage. While this setting is intended for use with Asian font families, you can apply it to 
western typefaces as well.

Note that in addition to the text properties listed above, there are six switches located at the 
bottom for Faux bold, Faux italic, All caps, Small caps, Super script, and Sub script.

Paragraph Panel options
Paragraph alignment: Similar to a word processing program, this property sets the 
alignment of all lines in the paragraph.

Left margin: Sets the amount of space that the paragraph is indented from the left side of 
the text box.

Right margin: Sets the amount of space that the paragraph is indented from the right side of 
the text box.

Space before paragraph: Sets the distance between the paragraph this setting is applied to 
and the paragraph before it.

Space after paragraph: Sets the distance between the paragraph this setting is applied to 
and the paragraph that comes after it. 

First line indent: Sets the amount of indentation on only the first line of a paragraph. This 
is a similar effect to those seen in word processing programs when you place a tab at the 
beginning of a line.
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1 With the Jabberwocky.aep fi le still open, activate the Selection tool ( ) by clicking on 
it in the Tools panel. Then click once on the text box in the Composition panel to 
highlight it.

If the Character and Paragraph panels are not visible, you can reveal them by using the Window 
menu at the top of the application interface. Choose Window > Character or choose Window > 
Paragraph. Each panel also has a keyboard command to allow you to quickly toggle it open or closed. 
To reveal or hide the Character panel, press Ctrl+6 (Windows) or Command+6 (Mac OS), and to 
toggle the Paragraph panel, press Ctrl+7 (Windows) or Command+7 (Mac OS).

2 In the Character panel, adjust the font size, leading, and tracking properties as follows:

Font size: 30

Leading: 55

Tracking: 2

It is usually helpful to establish a general base 
setting that makes all your text visible.

These settings will provide a base to work from when you begin formatting the text 
to create a more visually appealing typographic design that makes all your text visible. 
These settings changed the formatting of all the text on this text layer because it had 
been highlighted with the Selection tool. Later in this lesson, you will modify the 
appearance of individual words and letters.

In this exercise, you are given the values that will work for this text, but when working on your 
own, you will have to decide what works best for you. Typing in values and then waiting to 
see the results is a slow and tedious process; it is usually better to use the text slider function 
of the cursor to try diff erent values. Simply hold your cursor over the value you want to adjust 
until it becomes a Hand icon ( ), and then click and drag left or right to adjust the value. Your 
Composition panel’s display adjusts in real time.

3 Choose File > Save to save your After Eff ects fi le with the new text settings. Do not 
close the fi le, as you will need it in the next exercise.
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Formatting individual characters
As you have seen, text can be edited globally, but to achieve more interesting type eff ects, 
you need to make changes to the individual characters in a text fi eld. When you select 
individual characters, you can edit them to create more visually appealing designs. When 
active inside a text frame, the cursor allows you to select any number of characters, words, 
or lines. Once selected, changes made in the Character and Paragraph panels aff ect only 
the highlighted text. This way of working with text is actually very similar to using a 
word processing program or editing the text when you send an e-mail, so most people fi nd 
it an easy adjustment to make. In this section, you will edit individual characters and an 
individual word in the text to create a more interesting composition.

1 With the Jabberwocky.aep fi le still open and the Selection tool active, double-click on 
the text layer’s name fi eld in the Timeline panel to select it. Two things happen: the 
Type tool ( ) activates and all the text on the layer becomes highlighted.

Double-clicking on a text layer is a very quick way of selecting the text on that layer.

2 Now that the text is selected and the Type tool is active, double-click on the word 
Jabberwock in the fi rst line to select it. In the Character panel, change the font size, 
tracking, and vertical scale properties as follows. To display these options, you may 
need to undock the panel by clicking and dragging it by its name to the center of the 
work area.
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Font size: 50

Tracking: -20

Vertical scale: 110%

Changes that you make to text are visible in real-time.

This changes the word so that it appears narrower and taller compared to the other 
letters, allowing it to tower over them the way the Jabberwocky towers over the boy 
in the poem.

Double-clicking on any word with the Type tool automatically selects that word.

3 Tracking aff ects the amount of space between all words and letters equally, and the result 
of making it a negative value is that the letters in the word Jabberwock are now closer 
together. However, some of the letters may become too close and overlap each other, as 
the r and w do now. To fi x this, you will change the kerning between this letter pair.

Kerning is the term used to refer to the space between any two letters. In this example, 
you will loosen the kerning between the r and the w to move them further apart.

With the Type tool still active, click on the space between the letters r and w in 
Jabberwock. Click on the Kerning value and type in 70. This moves the letters farther 
apart and prevents them from touching one another.

The kerning property only accepts numerical values when the text cursor is between 
a pair of letters. At any other time, it only accepts Metrics, Optical, and Zero as values.
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4 Click and drag the Type tool over the B in Beware to highlight it, and change its 
font size property to 80. As the letter becomes larger, it creates a strange appearance, 
because the rest of the words on the line don’t line up with it any longer. To fi x this, 
you will baseline shift the B so that its center lines up with the rest of the text.

The baseline is an imaginary line that all type sits on. This is why the bottoms of 
letters line up with one another. When you baseline shift text you can move it above 
or below this line.

In the Character panel, change the baseline shift value to -28. If the baseline shift 
option is not visible in the character panel, undock it by dragging the panel to the 
center of the work area. There now seems to be a little too much space between the 
letters B and e, and an adjustment to kerning will correct this. Click once in the space 
between these two letters and change the kerning value to -40.

The baseline shift property works best when only applied to a portion of the text on a line.

5 One more adjustment—this time to the word son!—and this line should be done. 
Click once to place the text cursor in front of the s in son!. Then press the Tab key on 
the keyboard twice to insert two tabs and move the text over so that it is no longer 
directly underneath the B. The word is still a little close to the B, so press the spacebar 
on your keyboard twice to shift it over a bit more.
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Change the kerning value to -80; this moves the word to the left and helps it line up 
better with the rest of the word Beware. Click three times on the word son to highlight 
the entire line, and change its leading value to 40.

You can only edit leading when you select an entire line of text or the entire text box.

The great thing about betting creative with typography is that you have a great deal of freedom 
and control over how the composition will turn out. Each typeface is a little diff erent in 
appearance, size, and formatting so my making subtle changes to individual characters of words 
you can produce widely varied results. When working on this exercise, you can achieve diff erent 
results by adding extra spaces or changing the size of the text.

6 Select the word jaws and change its font size to 70, and then adjust the value of 
baseline shift to -10. Select the word claws and sets its font size and baseline shift to the 
same values that you just used for jaws. The enlarged size places greater emphasis on 
these two words and gives them more impact in the composition.

After Eff ects makes it very easy to try out diff erent text formatting in your composition. 
You can easily adjust text properties to fi t your needs.
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7 Highlight the word bite and change its font size property to 50, and then do the same 
for the word catch. Then select the exclamation point at the end of the poem and 
change its font size to 150. 

Changes made to character size can cause text on diff erent lines to overlap when 
you have set a leading value.

8 Because of the size change in the last step, the text on the line above the exclamation 
point is now concealed. You can fi x this by making an adjustment to kerning. Click in 
the space just before the exclamation point and change the kerning value to 600. This 
reveals the text that was hidden underneath it.

If you experiment with tracking and kerning, you will fi nd that you can use them 
to create many interesting visual eff ects.
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9 Click four times in succession on the word jaws to select the entire second paragraph 
the word resides in, and change the value of the leading property to 60. This creates 
additional space between the lines and ensures that the enlarged words are not 
touching one another. 

Clicking four times on any word in a paragraph selects that entire paragraph.

When editing text, remember that changing one value such as font size may require that you change another 
value such as leading, tracking, or kerning to maintain the legibility of the text.

If you deviated from any of the steps listed above your text will look diff erent from the example 
here. This is perfectly alright and is one of the great things about being creative with type. You 
have the ability and freedom to create a typographical treatment that is completely unique from 
anything else you have seen before. 
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10 Click three times on the name Lewis in the last paragraph; this highlights the entire 
line of text. In the Character panel, change the font size property for all the text in 
this line to 20.

In the Paragraph panel, change this line’s alignment to Right align and change the 
value for Space Before Paragraph to 10.

Working with the Character and Paragraph panels is very similar to working with 
a word processing program and is one of the easiest features of After Eff ects to adjust to.

11 Deselect the currently highlighted text by clicking on any empty area of the Timeline 
panel, by choosing Edit > Deselect All or using the keyboard command Ctrl+Shift+A 
(windows) or Cmd+Shift+A (Mac OS).

12 Choose File > Save to save your After Eff ects fi le with the new text settings. Do not 
close the fi le, as you will need it in the next exercise.

Animating text properties
Text layers have two sets of properties that you can animate. The fi rst set of properties 
are the standard transform properties that belong to every layer—Anchor Point, Position, 
Rotation, Scale, and Opacity—while the second set of properties, often called text 
animators, are only applicable to text layers. There are 15 text animators: Anchor Point, 
Position, Scale, Skew, Rotation, Opacity, Fill Color, Stroke Color, Stroke Width, 
Tracking, Line Anchor, Line Spacing, Character Off set, Character Value, and Blur. 
Keyframes are often not added directly to the animators; instead, text selectors are used to 
control the range and eff ect of the animators. 

Text animator properties function much like other layer properties; the main diff erence 
is that for text animators, the properties only aff ect the text that lies between the range 
selectors. Any text outside of these selectors will have the appearance and properties that 
were in eff ect before the animator was applied. The pairing of animators and selectors is 
called an animator group, and these groups can contain multiple text animators and selectors.

In this part of the lesson, you will use animators on the text you created previously in 
this lesson to animate the text entering onto the screen. This eff ect is sometimes called an 
Animate In, or an Animated Intro.
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1 With the Jabberwocky.aep fi le still open, click on the text layer in the Timeline panel 
to select it. Then click on the reveal triangle to the left of the layer name to show the 
layer’s Text and Transform properties. This also reveals the Animate menu located in 
the layer switches/modes column for this layer. 

2 Click the triangle button to the right of the Animate label, and from the list that 
appears, choose Position to add a new animator group to this text layer.

Text Animators have greater functionality than simply animating a layer’s transform properties.

3 Notice that the Position property only has two values. To enable three-dimensional 
positional changes, you must enable per-character 3D for this text layer.

Again, click on the Animate menu, and this time choose Enable per-character 3D 
from the top of the list. The animator group’s Position property now has three values: 
the fi rst value represents the X position, the second value the Y position, and the third 
value the Z position.

4 Change the Z position value (the third Position value) to -800. This moves the text 
toward the viewer, making it appear larger and moving most of it off -screen.

When animating along the z-axis negative numbers are closer to the viewer.
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5 If you leave it like this, the text will be useless, so you must animate the range selector 
that is part of the animator group. You may ask yourself, “Why can’t I just animate 
the Position property?” Animating the Position property itself would not allow you 
to control each letter individually. Animating the Range Selector gives you pinpoint 
control of the eff ect of the property on each individual character, word, or line.

Click the reveal triangle to the left of Range Selector 1 to show the range selector’s 
properties. Notice that the Start property is set to 0 percent and the End property is set 
to 100 percent, meaning that the range selector encompasses all the text on the layer.

By default, the range selectors encompass the entire text layer. 

6 Move the playhead to the beginning of the Timeline (0;00;00;00) and click the 
 Time-Vary Stopwatch ( ) to the left of the Start property of Range Selector 1 to 
enable animation and create your fi rst keyframe.

7 Move the playhead to the 4 second (0;00;04;00) mark of the Timeline and change the 
value of the Start property to 100%. The eff ect of this change moves the start range 
selector to the end of the text layer, leaving all the text on the layer outside of the 
selectors and unaff ected by the animator.

8 Move the playhead to the beginning of the Timeline and preview the animation. 
While the text does indeed fl y in, some of the text that should be hidden instead 
remains visible at the beginning of the animation. You can easily adjust this by adding 
the Opacity property to the animator group.
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Click on the triangle button to the right of the Add menu and choose Property > 
Opacity from the list that appears.

Animator groups allow you to combine multiple properties and range selectors together.

9 Change the Opacity value to zero and preview the animation to see the eff ect. Not 
only does this remove the text that is in the way at the beginning, but it also adds 
another animated feature to the text.

10 One additional property might make this animation even more visually appealing. 
You can easily add the Scale property to the group using the Add menu.

Click on the Add menu and choose Property > Scale; then change any of the three 
scale values to 1000. Because they are all linked together, this causes all three scale 
values to change simultaneously. 

When multiple properties are added to an animator groups they are all controlled by the same range selector.

11 Preview your animation and then choose File > Save to save your After Eff ects fi le 
with the animation you have just created. Do not close the fi le, as you will need it in 
the next exercise.
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Understanding Text Animators: Text Properties

Text Animators are composed of Text properties and Range Selector properties, both of 
which have their own properties that you can animate. 

Text Properties

Anchor Point: Sets the anchor point for the characters; this is the point at which all 
transformations are centered.

Position: Specifies the X and Y position of the text in relation to the comp size. The Z 
position value is enabled only when you activate per-character 3D.

Scale: Specifies the horizontal (X) and vertical (Y) scale of the characters.

Skew: distorts the text by rotating individual characters. 

Rotation, X Rotation, Y Rotation, Z Rotation: Sets character rotation. This is not the 
rotation of the text frame; instead, each character on a text layer receives its own individual 
rotation. If you enable per-character 3D, you can set a separate rotation value for each axis. 

All Transform Properties: Used to add all transform properties to the animator group 
simultaneously. 

Line Anchor: Specifies the point of alignment for the tracking in a line of text. A value of 0 
percent is left alignment, 50 percent is center alignment, and 100 percent is right alignment.

Line Spacing: Sets the leading value (the space between lines).

Character Offset: Specifies the amount of offset of characters in your text layer. You can 
use this property to shift characters in a text layer to form random words.

Character Value: Replaces all the characters in a word by the selected value amount. You 
can use this property to shift characters in a text layer to form groups of the same letter.

Character Range: This property appears whenever you add the Character Offset or 
Character Value property to a layer. This specifies limits on the character changes made by 
the properties. 

Blur: Sets the amount of Gaussian blur to be added to the characters.
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Understanding Text Animators: Range Selector Properties

Text Animators are composed of Text properties and Range Selector properties, both of 
which have their own properties that you can animate. 

Range Selector Properties

Start and End: The beginning and end of the selection. The animator only affects text 
between the selectors.

Offset: The amount to offset from the current position of the Start and End points of the 
range selector.

Shape: Sets how characters are selected between the Start and End points of the range 
selector.

Mode: Creates a similar effect to how multiple masks combine when you apply a mask mode 
property. Sets how each selector combines with the text and with the selector above it.

Amount: Controls the strength of an animator’s effect, and sets how much the range of 
characters is affected by the animator’s properties. 

Units and Based On: The units of measure for Start, End, and Offset. You can base the 
selection of the range selector on the characters, characters excluding spaces, words, or lines. 

Smoothness: Sets the amount of time the animation takes to transition from one character 
to another; higher numbers produce softer transitions.

Ease High and Ease Low: Used to create a sense of acceleration or deceleration when 
animating with text animators. The values set the speed of change as selection values change 
from fully included (high) to fully excluded (low). 

Randomize Order: Randomizes the order in which the property is applied to the 
characters specified by the range selector. 

Random Seed: This option is only available when you enable Randomize Order. You use 
it to set the randomized order of a range selector when the Randomize Order option is set to 
On, and it is useful when combining multiple range selectors in one animator group.
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Saving an animator as a preset
Now that you have spent so much time creating a custom text animation, you don’t want 
it to go to waste. By creating a preset for this text animator, you will be able to reapply it 
to text in this and future projects. 

1 With the Jabberwocky.aep fi le still open, click on the text layer in the Timeline panel 
to select it. Then click on the reveal triangle to the left of the layer name to show the 
layer’s Text and Transform properties.

Click on the reveal triangle next to the Text property and click on Animator 1 to 
select it.

2 With Animator 1 selected, press the Enter (Windows) or Return (Mac OS) key on 
your keyboard to make the name editable. Change the animator’s name to Fade-Fly 
In. Press Enter/Return to complete editing the text.

3 With the Fade-Fly In animator selected, choose Animation > Save Animation Preset 
to open the Save Animation Preset as dialog box. Change the name of the preset to 
Fade-Fly In. By default, the preset is saved in the User Presets folder on your hard 
drive, but if you fi nd it more convenient, you can choose another location. Click the 
Save button to fi nish saving the fi le.

4 You can now access the preset through the Eff ects & Presets panel under Animation 
Presets > User Presets.

The Eff ects & Presets panel only shows 
Presets that have been saved in the 
User Presets folder or in the Presets folder 
inside the After Eff ects Application folder.

5 Choose File > Save to save your After Eff ects fi le with the animation you have just 
created. You may now close the fi le by choosing File > Close Project.
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Working with text animation presets
In order to speed animation and make it easier for new users to become accustomed to 
working with text animators, After Eff ects ships with a wide variety of prebuilt animations 
for text. You can fi nd these text animation presets in the Eff ects & Presets panel or browse 
for them in Adobe Bridge. Unlike other applications that use pre-rendered eff ects, every 
preset here is fully editable, created and animated using live eff ects. This allows you to 
apply as well as modify these eff ects to fi t the needs of your specifi c project. 

Browsing and applying text animation presets

Installed as part of the Creative Suite, Adobe Bridge is used as a fi le browser and metadata 
editor. Some users consider it the hub for the Creative Suite applications. While in After 
Eff ects, the use of Bridge may not be as integral as it is in other applications, such as Adobe 
Photoshop or Illustrator; one very important use is as a tool to preview and apply the 
application’s built-in animation presets. While the Eff ects & Presets panel is a simple text 
list of preset names, Bridge off ers full animated preview of all the built in presets as a well 
as a quick way to apply them to layers in After Eff ects.

In this exercise, you will work with a prebuilt After Eff ects project. The project contains 
four text layers describing the life of Albert Einstein. The text layers are arranged on the 
Timeline so that each text block is visible on stage for a total of only six seconds. You will 
add a preset animation to enhance the eff ect of this project. 

1 Choose File > Open Project. In the Open Project dialog box, navigate to the Lesson 6 
folder and double-click on Albert Einstein.aep to open it.

2 In the Timeline panel, position the playhead at the beginning (0;00;00;00) of the 
Timeline, and then highlight the layer numbered 1 (the layer is named in school, HE 
was considered a below average student...). 

The layer name may be truncated; you can reveal the entire layer name by lengthening the Layer 
name column using the dividers that separate each column’s name.
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3 In the Eff ects & Presets panel, choose Browse Presets from the panel menu ( ). This 
launches Bridge and automatically takes you to the Presets folder. 

When working with After Eff ects, Bridge is used to browse 
and preview presets and media fi les.

If Bridge is not already open, it may take a few moments to open the application. Don’t panic—
this is normal. If you are not familiar with Bridge, it is an application that can preview and 
browse fi les, as well as performing other tasks. In this exercise, you will use it to preview the 
preset text animators that are available to you in After Eff ects. If this is the fi rst time you have 
opened Bridge you will be prompted to choose whether or not you would like it to automatically 
start at logon and may also be prompted to approve the installation of one or more extensions that 
allow it to communicate with the other applications of the Creative Suite.

4 In Bridge, from the Presets folder, double-click on the Text folder, and then on the 
Animate In folder. 

In the Animate In folder, double-click on Random Word Shuffl  e In.ff x. A few things 
happen at once: fi rst, the Bridge interface disappears and is replaced by the After 
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Eff ects interface; second, the eff ect that you double-clicked on is automatically applied 
to layer 1, the layer you had previously selected. 

If you plan to use Bridge to apply eff ects you must have your target layer 
selected in After Eff ects before you go to Bridge.

5 You can tell that the eff ects were applied because the text is now partially off -screen. 
The eff ect is built for a standard-defi nition project and you must adjust the values of 
the position change to fi t the HD project you are working in now. You will adjust this 
setting in the next exercise. Make certain the layer is selected, otherwise the eff ect is 
not applied.

6 Choose File > Save As. In the Save As dialog box, navigate to the ae06lessons folder, 
rename the fi le Albert Einstein-working.aep, and click Save. Do not close this fi le, 
as you will use it in the next section.
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Modifying animation presets
What good would animation presets be if you couldn’t modify them to fi t the needs of 
your specifi c project? This is a major advantage that After Eff ects has over some other 
motion graphics programs. While in some programs, the coolest parts of their built-in 
preset eff ects are pre-rendered and not editable, every After Eff ects text animation preset is 
fully editable.

In this exercise, you will edit properties of the Random Word Shuffl  e In.ff x eff ect that you 
previously applied. 

1 With the Albert Einstein_working.aep fi le that you created in the previous exercise 
open, hold down Ctrl (Windows) or Command (Mac OS) and click on the reveal 
triangle for this layer to reveal all the layer’s properties at once. 

Locate Animator 1 underneath the Text property; it is composed of a range selector 
and a Position property.

You may have to scroll the Timeline panel vertically in order to see both the range selector and 
Position property. 

2 Change the X value of the Position property to 1900; this places the text completely 
off -screen. Underneath the Advanced properties of Range Selector 1, change the 
Based On property to lines. This changes the entire animation so that now, instead of 
having each word fl y in individually, the text now fl ies in line by line.

The Based On property of range selectors controls which parts of a text layer are actually being 
animated. The choices are Characters, Characters Excluding Spaces, Words, and Lines. A simple 
adjustment to this property can completely change the nature and appearance of a text animator.
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3 Move the playhead to the 2 second (0;00;02;00) mark of the Timeline. Click on the 
second keyframe of Range Selector 1’s Off set property to select it. 

Hold down the Shift key on your keyboard and drag the keyframe toward the 
playhead until it snaps into position at the 2 second mark.

When dragging keyframes or In and Out points the shift key lets them snap to the playhead.

4 Now that you have amended the timing of the preset, you can add to it to create a 
new animation where the text enters the screen, holds for two seconds, and then leaves 
the screen. 

Move the playhead to the 4 second (0;00;04;00) mark on the Timeline and click the 
Add or Remove Keyframe at Current Time button to the left of the Off set property 
to insert a keyframe at 4 seconds. When using this button, it always sets a keyframe at 
the property’s current value, so it is a great way to create a placeholder keyframe. 

When the Add or Remove Keyframe at Current Time button is gray, it means the playhead is 
not currently on a keyframe and it will add one to the property; when it is yellow, it means that 
it will remove the keyframe that is at the current time of the playhead.
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5 With the layer still selected, press the letter O key on the keyboard to move the 
playhead to the out point of the layer. This occurs at the 6-second (0;00;06;00) mark 
on the timeline. 

Click on the fi rst keyframe of the Off set property and choose Edit > Copy. This is 
very similar to the way you can copy text in a word processing program so that you 
can move it to another section of your document. Choose Edit > Paste to create a 
copy of the keyframe at the current position of the playhead. 

The keyboard command for moving the playhead to the in point of the current layer is I, and the 
command for moving to the out point of the layer is O.

6 The animation is not bad, but it might be more visually appealing if the text were 
to leave the screen in the opposite direction from which it appears. You can easily 
achieve this eff ect by creating keyframes for the animator’s Position property.

Move the playhead to the beginning (0;00;00;00) of the Timeline and click on the 
Time-Vary Stopwatch ( ) of the Position property of Animator 1 to create a keyframe. 

7 Move the playhead to the 2 second (0;00;02;00) mark on the Timeline and click the 
Add or Remove Keyframe at Current Time button ( ) to the left of the Position 
property to create a placeholder keyframe.

8 Move the playhead to the 4 second (0;00;04;00) mark of the Timeline and change the 
X value of the Position property to -1900. 

When working with the X position property, negative values move a layer to the left.

Preview the animation. The lines of text now enter the screen from the left and exit it 
to the right.

AECS6_06Pass.indb   200AECS6_06Pass.indb   200 5/18/12   1:06 PM5/18/12   1:06 PM



6

201Lesson 6, Working with Text

Working with text animation presets

9 With Animator 1 selected, press the Enter (Windows) or Return (Mac OS) key on 
your keyboard to make the name editable. Change the animator’s name to Enter Left-
Exit Right. Press Enter/Return to complete editing the text.

10 With the Enter Left-Exit Right animator selected, choose Animation > Save Animation 
Preset to open the Save Animation Preset As dialog box. Change the name of the preset 
to Enter Left-Exit Right to match the name that you assigned to the animator in the 
previous step. In this part of the lesson, you are not going to save the preset into the 
User Presets folder. Instead, you will save it in the Presets folder located in the After 
Eff ects application folder. If necessary, in the dialog box, navigate to the After Eff ects 
Text Presets folder. If you are using a Mac OS computer, the folder is located here: 
Applications > Adobe After Eff ects CS6 > Presets > Text, and Windows users can 
fi nd the folder here: Windows: Program Files > Adobe > Adobe After Eff ects CS6 > 
Support Files > Presets > Text

11 If it does not already exist, create a new folder inside the Presets folder and name it 
Favorites. Click on this new folder to select it and press the Save button. From this 
point forward you can access your custom preset through the Eff ect & Presets panel 
under Animation Presets > Text > Favorites.

In order to create a folder in the Program Files (Windows) or Applications (MacOS) folders you 
have to have appropriate permissions on your computer.

12 Choose File > Save to save your After Eff ects fi le with the animation you have just 
created. You may now close the fi le by choosing File > Close Project.

Finding additional presets

Animation Presets were previously called favorite effects; this is the reason the file extension 
for them is .ffx. In addition to the presets that are included with the application and the 
presets that you create, there are other places you can find presets to optimize your workf low.

To provide a single, unified location for sharing presets, plug-ins, and other content between 
users of the Creative Suite, Adobe created the Marketplace & Exchange site at www.adobe.com/
cfusion/exchange/. At Adobe Marketplace & Exchange, you can find a source for free animation 
and text animation presets for After Effects as well as free and for-pay plug-ins, project 
templates, and scripts. If you use other Adobe applications, you can find additional supporting 
content for them as well.
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Creating custom text animators
Once you are comfortable with applying presets from the library, you may want to venture 
out and create your own. The entire point of creating and saving a text animation preset is 
that it allows you to reuse animations and tweak them instead of creating everything from 
scratch. 

Creating a typewriter effect
A classic and often-used eff ect is the typewriter. In this eff ect, text appears on-screen one 
letter at a time, as if it is being typed in front of you. 

1 Choose File > Open Project. In the Open Project dialog box, navigate to the 
ae06lessons folder and double-click on Creating a Typewriter Eff ect.aep to open it.

2 Click on the text layer in the Timeline panel to select it. Then click on the reveal 
triangle to the left of the layer name to show the layer’s Text and Transform properties.

Then click the triangle button to the right of the Animate label and from the list that 
appears, choose Opacity to add a new animator group to the layer.

3 Set the Opacity property to 0%, and then click on the reveal triangle to the left of 
Range Selector 1 to view its properties.

4 Move the playhead to the beginning (0;00;00;00) of the Timeline and click on the 
Time-Vary Stopwatch ( ) of the range selector’s Start property to enable animation 
and create a keyframe for the property’s default value of 0 percent.

5 Move the playhead to the 5 second (0;00;05;00) mark on the Timeline and change the 
value of the Start property to 100%.

By default, the start property of a range selector is 0% and the end property is 100% so that the selector encloses all the text 
on the layer.

AECS6_06Pass.indb   202AECS6_06Pass.indb   202 5/18/12   1:06 PM5/18/12   1:06 PM



6

203Lesson 6, Working with Text

Creating custom text animators

RAM Preview the animation. You should notice that while the text does indeed 
appear letter by letter, the letters each seem to fade in as opposed to the harsh, invisible/
visible eff ect that would occur if they were actually being typed by a typewriter. 
Fortunately, this is easy to fi x by adjusting the range selector’s Advanced properties.

6 Click on the reveal triangle to the left of the Advanced property group for Range 
Selector 1. Change the Smoothness value to 0%. This eliminates the fading eff ect that 
you saw in the previous preview. Preview the animation.

7 With Animator 1 selected, press the Enter (Windows) or Return (Mac OS) key on 
your keyboard to make the name editable. Change the animator’s name to Typewriter. 
Press Enter/Return to complete editing the text.

8 With the Typewriter animator selected, choose Animation > Save Animation Preset 
to open the Save Animation Preset As dialog box. Change the name of the preset to 
Typewriter to match the name that you gave to the animator in the previous step. In 
the dialog box, navigate to the After Eff ects Text Presets folder. Locate the Favorites 
folder that you created earlier in this lesson. Double-click on this folder to select it and 
press the Save button.

9 Choose File > Save to save your After Eff ects fi le with the animation you have just 
created. You may now close the fi le by choosing File > Close Project.

Creating a blur-in effect
Animating the appearance of text on-screen can make otherwise dull presentation 
graphics more visually appealing and fun. A blur-in eff ect begins with text that is invisible 
and gradually reveals the text by animating an increase in its opacity and a decrease in 
blurriness. 

1 Choose File > Open Project. In the Open Project dialog box, navigate to the 
ae06lessons folder and double-click to open Creating a Blur in Eff ect.aep.

2 Click on the text layer in the Timeline panel to select it. Then click on the reveal 
triangle to the left of the layer name to show the layer’s Text and Transform 
properties.

Then click the triangle button to the right of the Animate label and from the list that 
appears, choose Blur to add a new animator group to the layer.
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3 Click on the Chain Link icon to disable the Blur property’s Constrain Proportions 
option and set the horizontal blur value (the fi rst number) to 100. Then click on the 
reveal triangle to the left of Range Selector 1 to view its properties.

The blur property is used to create per character blurs on text.

4 Move the playhead to the beginning (0;00;00;00) of the Timeline and click on the 
Time-Vary Stopwatch ( ) of the range selector’s Start property to enable animation 
and create a keyframe for the property’s default value of 0 percent.

5 Move the playhead to the 5 second (0;00;05;00) mark on the Timeline and change the 
value of the Start property to 100%.

6 Click on the reveal triangle to the left of the Advanced property group for Range Selector 
1. Change the Randomize Order value to On by clicking on the current value which 
is set to Off . This causes the range selector to un-blur the text seemingly at random and 
creates a more frenetic eff ect. Preview your animation to see what you have created.

7 With Animator 1 selected, press the Enter (Windows) or Return (Mac OS) key on 
your keyboard to make the name editable. Change the animator’s name to Blur In. 
Press Enter/Return to complete editing the text.

8 With the Blur In animator selected, choose Animation > Save Animation Preset to open 
the Save Animation Preset As dialog box. Change the name of the preset to Blur In. 

Just as you did in the previous part of the lesson, navigate to the After Eff ects Text 
Presets folder. In the dialog box, double-click on your Favorites folder to select it and 
press the Save button.

9 Choose File > Save to save your After Eff ects fi le with the animation you have just 
created. You may now close the fi le by choosing File > Close Project.
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Creating text on a path
Text can be combined with mask paths and animated to create text that follows a specifi c 
course. When combined with a mask path in this way, text can escape its normal box and 
instead be fi t to a wide variety of possible shapes. There are fi ve properties available once 
you have created text on a path:

Reverse Path: You use this property to reverse the direction of a path. This property is 
useful when a path is drawn in the wrong direction, causing text to appear backward.

Perpendicular To Path: You use this property to rotate each character so that it is 
perpendicular to the path instead of horizontal to it.

Force Alignment: You use this property to justify the text, forcing the fi rst character to 
be positioned at the beginning of the path, and the last character at the end of the path, 
and then evenly spacing the remainder of the text along the path.

First Margin: This property sets the position of the fi rst character relative to the start of 
the path. 

Last Margin: This property sets the position of the last character relative to the end of 
the path.

In this exercise, you will work with a prebuilt After Eff ects project. The project consists of 
two layers, and each is made up of point text. Each layer also has a mask path on it that was 
created with the Pen tool. 

1 Choose File > Open Project. In the Open Project dialog box, navigate to the 
ae06lessons folder and double-click to open Creating Text on a Path.aep.

2 In the Timeline panel, click on the fi rst layer, the one named LIFE is like a ROLLER 
COASTER, to select it. When you select a layer, any masks on that layer immediately 
become visible.

Click on the reveal triangle to the left of the layer name to show the layer’s Text and 
Transform properties, and then click on the reveal triangle to the left of Text to reveal 
the Path Options. Click on the reveal triangle to the left of Path Options to reveal the 
Path property. Text can be attached to any mask shape on the text layer. The paths you 
will use here were created by drawing Bézier curves with the Pen tool ( ).

The path options property group attaches a mask path on a text layer as a motion guide for the text.
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3 From the Path property’s drop-down menu, select the path named Guide Path 01. 
Once you have selected a path, the additional path properties appear.

4 Move the playhead to the beginning (0;00;00;00) of the Timeline and change the 
value of the First Margin property to -210. Then click on the property’s Time-Vary 
Stopwatch icon to create a keyframe and enable animation for this property. Once you 
type in the value, it automatically creates a new keyframe. 

Remember that when you are animating properties, new keyframes are always created at the 
current position of the playhead. When the Time-Vary Stopwatch is fi rst enabled, a keyframe is 
automatically created. Once animation has been enabled for a property any change in the value of 
that property; either by adjusting a numerical value in the Timeline or Eff ect Controls panel or 
by directly transforming the layer in the Composition panel creates a new keyframe.

5 Move the playhead to the 5 second (0;00;05;00) mark on the Timeline and change the 
First Margin’s property value to 470.

6 Click on the second layer, named Full of Downs and Ups, to select it and use the 
reveal triangles to view the Path property.

7 From the Path property’s drop-down menu, select the path named Guide Path 02. 
This time, there is a little problem: this path was drawn from right to left and as a 
result, the text is reversed. 

Enable the Reverse Path property by clicking on the current value, which is set to 
Off . This corrects the text, leaving it right side up. The starting and ending vertices of 
a path control where the text placed on it begins and ends. Properties such as Reverse 
Path allow you to override the default positioning of path text.

8 Again move the playhead to the beginning (0;00;00;00) of the Timeline and change 
the value of the First Margin property to 780. Then click on the property’s Time-
Vary Stopwatch icon to create a keyframe and enable animation. Once you type in the 
value, it automatically creates a new keyframe.

Move the playhead to the 5 second (0;00;05;00) mark on the Timeline and change the 
property’s value to 210. 

Preview your animation; each text layer moves along its path from off - to on-screen 
simultaneously.

10 Choose File > Save to save your After Eff ects fi le with the animation you have just 
created. You may now close the fi le by choosing File > Close Project.

Congratulations! You have completed the lesson.
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Review

Self study
Now that you have learned how to create and animate text in After Eff ects, you can create 
your own custom type treatment and animate it appearing on the screen. Remember that 
you should try to create a visually appealing design so that you can engage your audience 
in the animation.

Review
Questions
1 What are the two types of text you can create in After Eff ects and how are they each 

created?

2 What is the advantage of using Bridge to preview animation? 

3 What is the advantage of saving a custom text animator as a preset?

Answers
1 The two types of text that you can create in After Eff ects are Point and Paragraph 

text. Point text is created when you click with the Type tool and just start typing, 
while Paragraph text is created by clicking and dragging with the Type tool to create a 
text frame of a set width and height. 

2 Animation presets have video preview when viewed in Bridge as opposed to the 
simple text list that you see in the Eff ects & Presets panel.

3 By creating a preset for a text animator, you will be able to reapply it to text in any 
project that you create in After Eff ects.
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What you’ll learn in 
this lesson:
• Loop Audio Files

• Animate Audio Volume

• Use Timeline markers to set 
sync points

• Add eff ects to audio layers

Lesson 7

When working in After Eff ects, audio can be an often-overlooked 
but integral part of your compositions. You can use audio either as a 
support for animation or as a motivator for it. 

Starting up
You will work with several fi les from the ae07lessons folder in this lesson. Make sure that 
you have loaded the aelessons folder onto your hard drive from the supplied DVD. See 
“Loading lesson fi les” in the Starting up section of this book.

See Lesson 7 in action!

Use the accompanying video to gain a better understanding of how to use some of the features 
shown in this lesson. The video tutorial for this lesson can be found on the included DVD.

7

Working with Audio
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Setting up
As you work in After Eff ects, you will inevitably open and close many panels, depending 
on the type of project you are creating. However, when working through the projects in 
this book, it is important to have an interface that matches the lessons. To this end, you 
should always reset your workspace to the preset Standard confi guration.

1 Choose Window > Workspace > Standard to set your current workspace confi guration.

2 Choose Window > Workspace > Reset “Standard” to reset the standard workspace in 
case you have modifi ed it at some point. 

Audio in After Effects
There are many diff erent types of audio fi les that you will come into contact with. After 
Eff ects can import the following formats:

FILE FORMATS FILE TYPE EXTENSIONS

Adobe Sound Document ASND

Advanced Audio Coding AAC, M4A

Audio Interchange File Format AIF, AIFF

MPEG-1 Audio Layer 3 (MP3) MP3, MPEG, MPG, MPA, MPE

Windows Waveform WAV

Although there are several diff erent audio formats that you can import, most experienced 
users prefer to use one of the uncompressed formats that are intended for editing, such as 
WAV or AIFF. Uncompressed audio formats tend to preview better in After Eff ects. Also, 
because they are uncompressed, they usually produce a higher-quality sound when exported 
than fi les that have already been compressed and are again re-compressed when you output 
them. If you are using Adobe SoundBooth to create your audio fi les, the native multi-track 
document format ASND makes an excellent lossless format to use in After Eff ects. 

Unfortunately, many animators overlook the importance of audio when creating After 
Eff ects projects. In fact, except at the highest levels, the audio aspect of motion graphics 
design is something that many designers don’t think about until nearly the end of the 
project, at which point they often try to fi nd music to match the visuals they have already 
created. This often results in a project where the audio, whether it is music or a voice-over 
track, seems tacked on. A better method is to take a holistic approach to the process, where 
the visual and audio elements of your design are given equal weight. Sometimes you 
may want to create your audio to follow the visual animation, and other times create the 
motion graphics to refl ect the audio, such as when graphics are created to match music.
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Previewing audio

Unfortunately, with today’s short deadlines, a holistic design approach is not always practical 
or possible. Luckily, After Eff ects gives you several ways of working with audio in your 
project that will help you streamline the process of integrating it with your animations.

All the audio used in this lesson was recorded, edited, or created in Adobe SoundBooth. 
If you are not familiar with it, SoundBooth is a part of the Creative Suite and is basically a 
scaled-down version of Adobe Audition. It is intended to put a set of very powerful audio-
editing tools into the hands of users who are not audio professionals, and off ers an interface 
and workfl ow that is very friendly to video editors and designers.

Previewing audio
Very often when you want to preview your animation, you can simply press the spacebar, 
and this generates a preview from the current position of the playhead. However, audio 
does not preview on the Timeline when you press the spacebar to preview animation. To 
preview the audio portion of the Timeline, either as part of the overall animation or alone, 
you can do one of the following: 

PREVIEW TYPE FUNCTION HOW TO PERFORM

RAM Preview Uses your computer’s RAM to 
render and play back video and 
audio in the composition, footage, 
or layer panels in real time.

1  Choose Composition > Preview 
> RAM Preview.

2  Click the RAM Preview button on 
the Preview panel.

3  Press the zero key on the 
number pad.

Scrubbing through 
audio on the Timeline

Plays sound on the Timeline as 
you drag the playhead forward 
or backward. The speed of the 
playback is based on how fast you 
move the playhead.

1  Hold down the Ctrl (Windows) 
or Command (Mac OS) key while 
dragging the playhead on the 
Timeline.

Previewing audio only Renders and plays back only the 
audio portion of the Timeline.

1  Choose Composition > Preview 
> Audio Preview (Here Forward).

2  Choose Composition > Preview 
> Audio Preview (Work Area).

3  Press the period key on the 
number pad.
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Adding audio files to the Timeline
In After Eff ects, audio fi les are imported into the project and added to a composition just 
like any other footage item. However, the diff erences become apparent once you begin 
working with audio fi les on the Timeline. Because they are not visual, audio footage layers 
lack the transform properties that you have become used to working with, and instead 
have only a levels property that allows you to control the volume of the track. 

In this exercise, you will open an After Eff ects project with a prebuilt text animation and 
add a background audio track and sound eff ects to match the animation. 

1 Choose File > Open Project and in the Open dialog box, navigate to the ae07lessons 
folder. Locate the fi le named Working With Audio Files.aep and either double-click 
on it or click the Open button in the dialog box. 

This project consists of two compositions. The main composition is called From 
word to deed and contains a text layer containing a French proverb, “from word to 
deed is a great space,” and another composition named Background. The Background 
composition contains several layers that create the textured cloud eff ect you see.

When animating text on-screen, it is important to give the viewer time at the end of an animation to read the text.

2 In the Timeline panel, click the text layer to select it and press the letter U key on 
the keyboard. This keyboard command reveals only the layer properties that have 
animation enabled. 

The animation in this fi le is pretty simple; the text layer has an animated range 
selector with keyframes at 2, 4, 6, and 8 seconds. Scrub the playhead to see that 
the text blurs in vertically one line at a time. The two-second delay before the fi rst 
keyframe prevents the animation from starting right away, while the space at the end 
of the animation allows for the text to remain on-screen so the viewer has time to 
read the message after it appears. 
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3 You will start by creating a folder in the Project panel to keep it organized. These folders 
function similarly to the folders on your hard drive, and are an excellent organizational 
tool. Click on the Create new Folder icon at the bottom of the Project panel.

Project panel folders are an excellent method of organizing your footage items.

Name the new folder audio and press the Enter (Windows) or Return (Mac OS) key 
on your keyboard to fi nalize the name change. Because the default sorting method of 
the panel is alphabetical, the folder jumps to the top of the list.

If it is not already highlighted, click on the audio folder’s icon to highlight it and then 
choose File > Import > File. In the Import dialog box, navigate to the ae07lessons folder. 

The keyboard commands to open the Import dialog box are Ctrl+I (Windows) or Command+I 
(Mac OS).

Click on the fi le named Outer Space Zero.asnd, then press and hold the Ctrl 
(Windows) or Command (Mac OS) key on your keyboard, and also click on 
Loop-Metallic Clang.wav so both fi les are selected. 

Click the Open button to import both fi les. Because the audio folder was highlighted 
when you used the import command, the two audio fi les are placed directly into 
this folder. The fi rst audio fi le you selected, named Outer Space Zero, is a multi-
track Adobe Soundbooth document, while the second fi le you selected is a Windows 
Waveform. Soundbooth was an application created by Adobe Systems used to clean 
up audio fi les and to compose scores and create sound eff ects for video and animation 
projects. It was distributed as part of the Creative Suite until it was replaced by Adobe 
Audition with version 5.5.

Windows waveforms are generic audio fi les that can be created in a wide variety of 
applications.
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Soundbooth and Window waveforms fi les demonstrate the wide range of importable 
formats that After Eff ects supports.

The import command will place fi les into whatever folder is highlighted in the Project panel. If there are no folders or none of 
them are highlighted then the footage items are placed into the main Project panel.

4 Click on any empty area of the Project panel to deselect the two imported audio fi les. 
Click on the Outer Space Zero.ansd fi le, drag it into the Timeline, and place it below 
the background layer.

Whenever you import a fi le, it is automatically highlighted in the Project panel, and when 
multiple fi les are imported simultaneously, you must deselect them all before you can reselect the 
fi le or fi les you want to work with.

5 RAM Preview the composition by choosing Composition > Preview > RAM Preview. 
Depending on your system confi guration the preview may take a few moments, but 
once complete the Composition will playback in real-time.

A RAM Preview is necessary to view Timeline animations with audio because audio doesn’t 
preview when you use a standard Timeline preview by pressing the spacebar.

6 Choose File > Save As and in the dialog box that appears, navigate to the ae07lessons 
folder and change the name of the fi le to Working with Audio Files-working.aep. 

Click the Save button to close the dialog box. Don’t close the fi le, as you will need it 
in the next part of the lesson.

Viewing audio file metadata
What is metadata? Meta comes from a Greek word meaning above or beyond, so metadata 
is data that is above the data of an image. It is sometimes referred to as data about data, 
because it contains information about the actual fi le. When metadata is used with video, 
audio, and images, this data usually describes information such as the formatting, fi le 
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structure, creator, and keywords. Metadata has long been a part of the digital imaging 
fi elds, digital photo cameras, and software such as Adobe Photoshop add it to fi les to aid in 
identifi cation, indexing, and cataloging. However, the use of metadata is still fairly new to 
motion graphic design. As the video and fi lm industries shift from tape-based to tapeless 
recording formats, metadata is becoming more important for archiving, searching, and 
retrieving fi les. 

When working with the Adobe Creative Suite, you can add metadata to fi les, or edit it 
using Bridge or by using the Metadata panel in After Eff ects.

1 With the Working With Audio Files-working.aep fi le open, choose Window > 
Metadata to view the Metadata panel.

2 Click on the reveal triangle for Dublin Core in the Project section to see the editable 
fi elds. In the Description fi eld, type Text based animation with background 
audio and sound fx.

The word eff ects is often abbreviated as fx by visual eff ects and graphic artists, as it is here.

This data is added to the After Eff ects project fi le and viewable and searchable in 
metadata editors such as Bridge. 

Metadata is quickly becoming an integral part of video editing, visual eff ects, and motion 
graphics workfl ows.
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3 Hide the project’s metadata fi elds by clicking the triangle to the left of the words 
Dublin Core at the top of the panel. In the Project panel, click on the Loop-Metallic 
Clang.wav fi le to highlight it, and then click the reveal triangle next to Dublin Core 
in the Files section of the Metadata panel. This fi le is an edited version of one of the 
sound eff ects found on Adobe Resource Central named Module Production Title 
Imaging Electronic Whoosh Digital Beeps Screech.

4 In the Description fi eld, type 2 second looping digital sound eff ect. Just like the 
fi le’s metadata, when you exit the text fi eld, the data is automatically added to the fi le. 

Text in the Description fi eld is searchable in metadata viewers such as Adobe Bridge.

If you are not familiar with Resource Central, it is a feature built into some of the applications in 
the Creative Suite that allows you to access a central location to download sound eff ects, scores, 
Encore DVD templates, and other assets for use in video and motion graphics production. 

5 Close the Metadata panel, as you have fi nished working with it. There is no need to 
save the project because editing metadata does not directly aff ect it, but you will need 
it open to complete the next segment of the lesson.
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Looping audio files
Like a video fi le, audio has a set duration, plays once, and then stops. But you can change 
this by setting a loop value in the Interpret Footage dialog box. If the audio fi le has been 
created so that it seamlessly loops, this can be a great way to create a background musical 
track for animations. In this section, you will loop a background sound that corresponds 
with the blur in animation of the text of this project. The Loop-Metallic Clang.wav fi le 
was created in SoundBooth to match the timing of this project’s animation. However, 
there is a problem: the audio fi le is approximately two seconds in length, while the 
animation takes a full six seconds to complete and needs the sound eff ect to repeat three 
times in succession. Fortunately, with the Interpret Footage dialog box, you can easily 
rectify this situation by looping the fi le. 

1 With the Working with Audio Files-working.aep fi le open, click on the Loop-
Metallic Clang.wav fi le to highlight it. This also makes the Project panel active (notice 
the orange outline around it), press the tilde (~) key on your keyboard to maximize 
this panel and make it easier to see all the columns.

Notice that the duration is currently listed as 2 seconds and three frames (0:00:02:03).

The properties of a footage item are visible in the Project panel when you highlight it.

2 With the project panel still active press the tilde key again to return to the Standard 
workspace confi guration. Right-click (Windows) or Control+click (Mac OS) on the 
Loop-Metallic Clang.wav fi le in the audio folder in the Project panel. From the menu 
that appears, choose Interpret Footage > Main to open the Interpret Footage dialog box.

3 In the Other Options section of the dialog box, type 3 into the Loop fi eld.

Looping the fi le 3 times like this changes its duration to 6 seconds and 7 frames 
(0;00;06;07).
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Click the OK button to close the dialog box.

Both audio and video footage items can be set to loop a specifi ed number of times.

4 Drag the Loop-Metallic Clang.wav fi le into the Timeline and place it above the Outer 
Space Zero.asnd layer.

The stacking order of audio layers is irrelevant; because they are not visible, they can’t hide other 
layers and so all layers play at once.

5 Move the playhead to the fi rst animation keyframe at the 2 second mark (0;00;02;00) 
and click on the Loop-Metallic Clang.wav layer to highlight it.

Press the left bracket ( [ ) key on the keyboard to move the beginning of the layer to 
the current position of the playhead.

By pressing the left bracket key, you cause the In point of the layer you have selected to jump to 
the current position of the playhead. The right bracket key causes the Out point of the layer to 
jump to the playhead’s current position. Be aware that this does not change the duration of the 
layer; the entire layer slides over as a whole.
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Animating audio levels

6 RAM Preview the animation by choosing Composition > Preview > RAM Preview. 
Notice that the metallic clang corresponds with the middle of the blur-in eff ect of the 
text animation. 

7 Choose File > Save to save these changes to your After Eff ects project. Do not close 
the fi le, as you will need it again in the next part of the lesson.

Animating audio levels
While visual layers such as images, video, and text have several transform properties that 
you can animate, audio layers have only the Audio Levels property to work with. The 
simplest defi nition for this property is that audio levels control the volume of the audio 
layer, and you can add keyframes to produce an eff ect where the sound gently fades in or 
out, or perhaps starts or stops abruptly. 

In the previous section, the metallic sound eff ect was added to the Timeline. This creates 
a bit of a problem because when it plays during the animation, the background audio 
track’s volume makes it hard to distinguish the two sounds. A solution is to lower the 
volume of the track so that you can better hear the sound eff ects, but because you want 
the background audio louder before the animation starts and after it ends, the best solution 
is to animate the layer’s Audio Levels property to allow the music to fade out as the 
animation starts and fade in once it ends.

1 With the Working with Audio Files-working.aep fi le open, move the playhead to the 
beginning (0;00;00;00) of the Timeline panel.

2 Click the reveal triangle to the left of the Outer Space Zero.ansd layer to show the 
Audio property; then click the reveal triangle for this property to show the Audio 
Levels, and then fi nally reveal the Waveform as well.

Audio layers only have a single property that you can animate: Audio Levels.

The waveform of an audio layer isn’t editable; however, it is a good tool for fi guring out the 
relative volume of the audio fi le at specifi c points in time.

3 Move the playhead to the 1 second (0;00;01;00) mark on the Timeline; this is where 
you will place the fi rst keyframe. 

Click the Time-Vary Stopwatch for the Audio Levels property to create the fi rst 
keyframe with the default value of 0.00 dB.
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The units of measure for audio fi les are decibels (abbreviated dB). The value 0.00 dB does 
not mean that there is no sound; it is simply the baseline at which the sound value starts. 
Positive numbers (the maximum value is +12.00 dB) raise the volume, while negative 
numbers (the minimum value is -48.00 dB) decrease it. You can watch the waveform to 
see a visual representation of the eff ects that level changes make to the audio fi le.

4 Move the playhead to the 2 second (0;00;02;00) mark on the Timeline and change the 
Audio Levels value to -10.00 dB.

5 Move the playhead to the 8 second (0;00;08;00) mark on the Timeline and click on 
the Add or Remove Keyframe button to the left of the property name to create a new 
keyframe with the exact same value as the previous one.

This will hold the value of the property at -10.00 dB for the duration of the animation.

6 Move the playhead to the 9 second (0;00;09;00) mark of the Timeline and change the 
Audio Levels value back to 0.00 dB. 

The Timeline now has four keyframes, as shown in the following fi gure.

The fi rst two keyframes are used to fade the volume down, while the second two are used to fade it back up. Because the 
middle two keyframes have the exact same value, there can be no change in volume between them.

7 RAM Preview the animation to hear the fade-down and fade-up eff ects you just 
created. Choose File > Save to save these changes to your After Eff ects project. Do not 
close the fi le, as you will need it again in the next part of the lesson.

Working with audio effects 
You can apply eff ects to audio layers in the same way that you apply them to visual layers, 
and while your choice of eff ects is much more limited, they can still be useful for quick 
corrections or modifi cations. In this exercise, you will add an audio eff ect to the Loop-
Metallic Clang.wav layer to make the sound a bit more ethereal and otherworldly.

1 With the Working with Audio Files-working.aep fi le open, click on the Timeline panel to 
highlight it, and then choose Edit > Select All to highlight all the layers in the composition. 

The keyboard command for selecting all layers is Ctrl+A (Windows) or Cmd+A (Mac OS).
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With all the layers selected, press Ctrl+ ~ (Windows and Mac OS) on your keyboard 
to collapse the visible properties of all the highlighted layers. If any of your layers had 
hidden properties, the command actually expands these properties. If this occurs, 
press the keyboard command again; all the properties of the highlighted layers will be 
hidden. Hiding the layer properties makes it easier to navigate the Timeline, as you no 
longer have to scroll up and down.

If you are not familiar with the tilde (~) key, it is located above the Tab key on the left side of 
your keyboard. The keyboard command to select all unlocked and visible layers is Command+A 
(Mac OS) or Ctrl+A (Windows).

2 Choose Edit > Deselect All and then click on the Loop-Metallic Clang.wav layer to 
highlight it alone.

The keyboard command to deselect All is Ctrl+Shift+A (Windows) or Cmd+Shift+A 
(Mac OS).

3 Choose Eff ect > Audio > Modulator to apply the modulator eff ect to the audio layer. 
As a result of your applying the eff ect, the Eff ect Controls panel opens.

The Modulator eff ect causes sound to pulsate and tremble by manipulating the 
frequency and amplitude of the fi le. It has only four settings:

Modulation Type: This setting specifi es the type of waveform to use for the eff ects 
distortion. A sine wave produces smoother modulation, but using the triangular 
setting results in more abrupt or sharp changes.

Modulation Rate: This setting specifi es the rate at which the eff ect varies the audio 
fi le. This value is measured in hertz (Hz) and is equivalent to setting the strength of 
other eff ects.

Modulation Depth: This setting specifi es the amount by which the eff ect modulates 
or varies the frequency.

Amplitude Modulation: This setting specifi es the amount by which the eff ect 
modulates or varies the amplitude.

4 Move the playhead to the beginning (0;00;00;00) of the Timeline and press the period 
key on your computer’s numerical keypad. If you do not have a numerical keypad, you 
can use the menu command to preview only the audio portions of a composition by 
choosing Composition > Preview > Audio Preview (Here Forward). 

This causes After Eff ects to render and preview only the audio of the composition. 
This allows you to quickly assess how the Modulator is aff ecting the sound eff ect. 
Stop the playback by pressing the period key again, or by pressing the spacebar, or by 
clicking anywhere along the Timeline.
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5 In the Eff ect Controls panel, leave Modulation Type as Sine, and then make the 
following changes to the other properties of Modulator:

Modulation Rate: 30.00

Modulation Depth: 10.00%

Amplitude Modulation: 10.00%

RAM Preview the animation. The Modulator eff ect produces a sound that seems to 
tremble and sounds hollow.

6 To add a second audio eff ect, choose Eff ect > Audio > Backwards. The Backwards 
eff ect reverses the audio of a layer by playing it from the last frame to the fi rst instead 
of in the normal order. Aside from a switch that allows you to swap the left and right 
channels of a stereo fi le, this eff ect doesn’t off er any customization.

7 RAM Preview the composition to see how the audio and animation interact with one 
another. Choose File > Save to save these changes to your After Eff ects project. You 
may now close this project, as you’re done with it.

Using composition markers to set the beat
In animations that must be synced to audio, you can use composition markers to set 
or mark the beat. Like the markers found in video and audio editing programs such 
as Premiere Pro and Audition, you can add After Eff ects markers to any point on the 
Timeline or any individual layer. Each marker can have a duration assigned to it and 
be given a unique, descriptive set of comments that display in the Timeline panel. An 
additional feature of markers, which only applies when you are outputting the fi le to 
certain fi le types, is the ability to create chapter and web links or Flash cue points. 

In this section, you will add an audio fi le that contains a voice-over to a project that 
contains a prebuilt animation. You will then use the features for previewing audio that are 
built into After Eff ects to help add Timeline markers that you can use to synchronize the 
animation to the spoken word. 

1 Choose File > Open Project and navigate to the ae07lessons folder. Locate the 
Syncing Animation to Audio.aep fi le and double-click on it to open the project.

Scrub the playhead to quickly preview the animation. It consists of a series of 
animated typographic treatments of part of a poem by William Blake named “The 
Tiger,” originally published as “The Tyger” in 1794. The animation in this part of the 
lesson is only partially complete. We have purposely left it unfi nished to give you a fi le 
to practice with so you enhance your skills in After Eff ects.
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2 Choose File > Import > File, navigate to the ae07lessons folder, and double-click on 
the fi le named Tiger Tiger.wav to add it to the Project panel.

Drag the Tiger Tiger.wav fi le into the Timeline and place it above the layer named 
TIGER, so that it becomes the new fi rst layer.

While an audio fi le can be placed anywhere in the layer stacking order, in this lesson it is kept above the other layers 
so that it is easy to see without having to scroll vertically.

3 This section of the exercise is going to focus on the fi rst stanza and so it may be more 
convenient to hide the layers that you are not going to be working with. To free-up 
space in the Timeline panel, you will use the shy switch.

Click on the layer named what (layer number 12) to select it. Then hold down the Shift 
key and click on the bottom layer (layer number 21) to select every layer between them.

Place your cursor over any of the selected layers and right-click. Choose Switches > 
Shy to enable the shy switch for every highlighted layer.

In this step, an alternative to right-clicking in this step is to click on the Shy switch for any one of 
the selected layers to shy them all.

4 Click the Hide Shy Layers Compositions switch ( ) at the top of the Timeline panel to 
hide all layers that have the shy layer switch enabled.

Layers that have the Shy switch enabled still preview and render in the Composition panel.
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The Shy switch hides layers from the Timeline display, but these layers are still visible when you 
preview the animation in the Composition panel. This command is almost the exact opposite of 
the layer visibility switch, which hides a layer in the Composition panel but still displays it in the 
Timeline.

Shy switch enabled. Shy switch disabled.

5 Now that you have some free space in the Timeline panel, click on the reveal triangle 
of the audio layer so that you can view its properties. Continue to reveal layer 
properties until you can see the layer’s waveform.

Creating composition markers isn’t hard, but to create them while previewing the 
audio fi le is a little tricky and requires a bit of practice, good hearing, and a familiarity 
with the audio. It also requires that you use a keyboard command to create the 
markers. The spoken text is as follows:

Tyger! Tyger! burning bright

In the forests of the night,

What immortal hand or eye

Dare frame thy fearful symmetry?

When creating the markers, you are going to place them at the beginning of every word.

6 Choose Edit > Deselect All to make sure none of the layers are selected.

Start the audio playback by pressing the period key on your keyboard’s numerical 
keypad or by choosing Composition > Preview > Audio Preview (Work Area). As the 
audio plays back, press the asterisk key (*) on the number pad to set a Timeline marker 
at the beginning of every word. This technique takes some practice to get right, and 
rarely works perfectly the fi rst time through. If you make a mistake in where you 
place the markers, don’t worry, you can always adjust them later. You will do this later 
in this lesson to name and refi ne their position. 

While performing this technique, if you pause the audio playback and use the undo 
command; Command+Z (Mac OS) or Ctrl+Z (Windows), you will remove all the 
markers that have been added to the timeline.
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You should end up with 20 markers in all. If you have more than 20 markers, then 
you should preview the audio again, right-click on any extraneous markers, and 
choose Remove Marker from the menu that appears. When using this technique, 
some people tend to place markers at every syllable instead of every word. 

The position of the markers must usually be refi ned, but this technique is a good start.

The markers will not be exactly at the right point on the Timeline for a couple of 
reasons: fi rst, there is a delay in your reaction time to hearing the word and pressing 
the asterisk key, and second, there is also a short delay while After Eff ects processes the 
keyboard command and creates a marker. However, this technique usually produces 
better and quicker results than just trying to play through the Timeline. In the next 
section, you will use the layer’s waveform to help refi ne the position of each marker.

This technique may take a couple of tries to perfect. You can always remove the markers by right-
clicking on any marker along the time ruler at the top of the Timeline and choosing Delete All 
Markers from the menu that appears.

7 Choose File > Save As, and in the dialog box that appears, navigate to the ae07lessons 
folder and change the fi le name to Syncing Animation to Audio-working.aep. 

Click the Save button to close the dialog box. Don’t close the fi le, as you will need it 
in the next part of the lesson.
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Naming composition markers
Technically, composition markers don’t have names, but they do allow you to add 
comments that will display on the Timeline. You can often use this comment fi eld to stand 
in for a name, and it makes identifying individual markers much easier. In this section, you 
will name the 20 markers you created in the previous exercise.

1 With the Syncing Animation to Audio-working.aep fi le open, double-click on the 
fi rst composition marker to display the Composition Marker dialog box. Depending 
on your monitor resolution, you might want to zoom in on the Timeline to make 
each individual marker visible.

You can magnify the timeline display using the Zoom In and Zoom Out buttons at the bottom 
of the Timeline Panel. The keyboard command to zoom in on the Timeline display is = 
(Windows and Mac OS); the command to zoom out is - (Windows and Mac OS).

Pressing and holding the Tab key on your keyboard and pressing the Enter (Windows) or Return 
(Mac OS) key will also close the dialog box.

2 In the Comment fi eld, type Tiger 1st and click OK to close the dialog box. A label 
with the comment is now displayed next to the marker.

Comments assigned to labels will display in the Timeline.

3 Double-click on the second marker and in the Comment fi eld in the dialog box, type 
Tiger 2nd.
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4 If necessary, press the plus (+) key on your keyboard to zoom in on the Timeline and 
make the markers larger. Use the horizontal scroll bar at the bottom of the Timeline 
to reveal more keyframes. Follow the table below to label the rest of the markers:

MARKER 
NUMBER COMMENT

MARKER 
NUMBER COMMENT

1 Tiger 1st 11 What

2 Tiger 2nd 12 Immortal

3 Burning 13 Hand

4 Bright 14 Or

5 In 15 Eye

6 The 16 Dare

7 Forests 17 Frame

8 Of 18 Thy

9 The 19 Fearful

10 Night 20 Symmetry

The marker labels have a tendency to overlap when the markers are close to one another, so zoom in on the Timeline to see 
them individually.

5 Choose File > Save to save these changes to your After Eff ects project. Do not close 
the fi le, as you will need it again in the next part of the lesson.
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Refining the position of composition markers
Once added to the Timeline, markers are relatively easy to work with, as you learned in 
the previous exercises. In this section, you will refi ne the position of the markers by using 
the layer’s waveform as a guide. A waveform is the graphical representation of an audio 
fi le’s volume over time. The areas of the waveform that are taller represent louder areas; 
areas that are fl at indicate areas of relative quiet or silence. 

1 With the Syncing Animation to Audio-working.aep fi le open, click on the playhead 
and move it to the 1 second (0;00;01;00) mark on the Timeline; this is where the fi rst 
major peaks in the waveform are located.

As previously noted, waveforms represent the volume of an audio fi le over time; since 
you are working with a voice-over, these waveforms represent when the speaker is 
talking. The relatively level areas represent periods when he is silent or pausing. 

The fi rst two sets of peaks are where the speaker says the word Tiger.

You can make the waveform clearer by zooming in on the Timeline.

You may have to zoom in on the Timeline to make the peaks visible.

2 Hold down the Ctrl (Windows) or Command (Mac OS) key on your keyboard and 
scrub the playhead over these fi rst few peaks in the waveform to confi rm that you are 
in the right place on the Timeline.

Normally when scrubbing the playhead, the audio portion of the composition does not preview, 
but by holding down the Command (Mac OS) or Ctrl (Windows) key, you can enable it.

Through a little trial and error, you will fi nd that the word Tiger begins at 
approximately 29 frames into the Timeline.

3 Move the playhead to the 29 frame (0;00;00;29) mark on the Timeline. 

Drag the fi rst marker, the one labeled Tiger 1st, toward the playhead until it snaps into 
position.
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4 The second time the speaker says the word Tiger is at the 1 second 7 frames 
(0;00;01;07) mark on the Timeline. 

Move the playhead to this position and drag the second marker to the playhead.

5 Continue to position the markers so that they correspond with the actual position of 
the words as they are spoken. You will fi nd that some markers are closer than others. 
Follow the matrix below to synchronize the markers with the words. In the next 
lesson, you will adjust the timing of the animation to match the markers positioned 
here. If you just want to get an idea of how this process works, you can position the 
fi rst couple of markers only, instead of adjusting them all.

MARKER 
NAME POSITION

MARKER 
NAME POSITION

Tiger 1st 0;00;00;29 What 0;00;04;26

Tiger 2nd 0;00;01;07 Immortal 0;00;04;29

Burning 0;00;01;25 Hand 0;00;05;15

Bright 0;00;02;04 Or 0;00;05;24

In 0;00;02;23 Eye 0;00;05;27

The 0;00;02;26 Dare 0;00;06;11

Forests 0;00;03;05 Frame 0;00;06;22

Of 0;00;03;20 Thy 0;00;06;27

The 0;00;03;24 Fearful 0;00;07;06

Night 0;00;03;26 Symmetry 0;00;07;21

6 Choose File > Save to save these changes to your After Eff ects project. Do not close 
the fi le, as you will need it again in the next part of the lesson.

Syncing animation to composition markers
Now that you have completed the most complex part of this process, actually syncing the 
animation keyframes to the markers will be much easier. In this section, you will sync 
the animation for the fi rst stanza with the composition markers you have just created and 
synced to the text.

The syncing process can be tedious, so you’ll want to start this lesson when you have some 
time to concentrate, and when your patience level is high. Syncing is an important skill for 
animating in After Eff ects, so keep going even when it gets to be a bit repetitious..

1 With the Syncing Animation to Audio-working.aep fi le open, click on the reveal 
triangle for the Tiger Tiger.wav fi le to hide its properties.

2 Click on the layer named TIGER (layer number 2), hold down the Shift key, and click 
on the layer named night (layer number 11) to select all these layers simultaneously. 
Press the U key on your keyboard to reveal only the properties that have animation 
enabled for each layer.
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Once the properties are revealed, click in any empty area of the Timeline to deselect 
all the layers. 

3 Move the playhead to the fi rst composition marker, the one named Tiger 1st. Click 
on the layer named TIGER to select it and press the left bracket ( [ ) key on your 
keyboard. This moves the In point of the layer to the current position of the playhead.

This causes the fi rst keyframe of the layer’s animation to also become aligned with the 
fi rst marker.

The left bracket ( [ ) key aligns the In point of a layer with the current position of the playhead and the right bracket ( ] ) 
aligns the Out Point of a layer with the playhead. Neither command trims or shortens the layer. 

4 Click on the second keyframe of the animation, hold down the Shift key on your 
keyboard, and drag it to the left until it snaps to the position of the second marker, the 
one named Tiger 2nd.

You can tell a keyframe is selected because it changes color from gray to bright yellow.

Holding down the Shift key on your keyboard forces the keyframes to snap to the composition 
markers when you move them.

5 Move the playhead to the second composition marker, the one named Tiger 2nd. Hold 
down the Shift key on the keyboard and drag the fi rst keyframe for the layer named 
TIGER Reversal to the current position of the playhead.
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Hold down the Alt key on your keyboard and press the left bracket key. This trims the 
In point of the TIGER Reversal layer to the position of the playhead.

Remember that layers are only visible in the composition for the duration specifi ed by their In and Out points.

Trimming a layer actually shortens the layer’s duration. Holding down the Alt (Windows) or 
Option (Mac OS) key on your keyboard and pressing the left bracket ([) key trims the In point 
of the layer, while pressing the right bracket (]) key trims the layer’s Out point.

6 Click on the second keyframe of the TIGER Reversal layer, hold down the Shift key, 
and drag it to the marker named Burning.

7 Move the playhead to the marker named Burning, click on the layer named burning to 
select it, and press the left bracket key on your keyboard to move the In point of the 
layer to the playhead.

Click on the second keyframe of this layer, hold down the Shift key, and move it to 
the marker named Bright. Be sure the layer is selected before holding down Shift and 
moving it.

The Shift key is used to ensure that the playhead snaps to markers on the timeline. It also forces it to snap to layer In and 
Out points and keyframes as well.
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8 Move the playhead to the marker named Bright, click on the layer named bright to 
select it, and press the left bracket key on your keyboard to move the In point of the 
layer to the playhead.

Click on the second keyframe of this layer, hold down the Shift key, and move it to 
the marker named In.

9 Move the playhead to the marker named In, click on the layer named in to select it, 
and press the left bracket key on your keyboard to move the In point of the layer to 
the playhead.

Click on the second keyframe of this layer, hold down the Shift key, and move it to 
the marker named The.

10 Move the playhead to the marker named The, click on the layer named the to select it, 
and press the left bracket key on your keyboard to move the In point of the layer to 
the playhead.

Click on the second keyframe of this layer, hold down the Shift key, and move it to 
the marker named Forests.

11 Move the playhead to the marker named Forests, click on the layer named forests to 
select it, and press the left bracket key on your keyboard to move the In point of the 
layer to the playhead.

Click on the second keyframe of this layer, hold down the Shift key, and move it to 
the marker named of.

12 Move the playhead to the marker named Of, click on the layer named of to select it, 
and press the left bracket key on your keyboard to move the In point of the layer to 
the playhead.

Click on the second keyframe of this layer, hold down the Shift key, and move it to 
the marker named The.

13 Move the playhead to the marker named The, click on the layer named the to select it, 
and press the left bracket key on your keyboard to move the In point of the layer to 
the playhead.

Click on the second keyframe of this layer, hold down the Shift key, and move it to 
the marker named Night.
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14 Move the playhead to the marker named Night, click on the layer named night to select 
it, and press the left bracket key on your keyboard to move the In point of the layer to 
the playhead.

Move the playhead to the 4 second 5 frame (0;00;04;05) mark on the Timeline, hold 
down the Shift key, and drag the second keyframe to the playhead. Remember to click 
before pressing Shift as you discovered in step 7 of this exercise.

Keyframes can be moved on the timeline similar to the way layers can be dragged in the composition.

15 The last thing to do is to trim the Out points of all the layers so that you will have 
room for the second stanza to display. 

Move the playhead to the marker named What. Click on the layer named TIGER 
(layer number 2), hold down the Shift key, and click on the layer named night (layer 
number 11) to again select all these layers simultaneously.

Hold down the Alt (Windows) or Option (Mac OS) key on the keyboard and press 
the right bracket key to trim all the Out points of the selected layers to the playhead’s 
current position.

Remember that when multiple layers are selected almost any action that is applied to one of them is applied to all.

AECS6_06Pass.indb   233AECS6_06Pass.indb   233 5/18/12   1:06 PM5/18/12   1:06 PM



7 Creating keyframes from audio fi les

Adobe After Eff ects CS6 Digital Classroom234

16 Disable the shy switch at the top of the Composition panel to reveal the hidden layers. 
RAM Preview the animation to see what you have accomplished. The second half 
of the poem is still visible when you preview the animation. This is because the shy 
command only hides layers in the Timeline panel but leaves these same layers visible 
in the Composition. While you will not work with them as part of this lesson, these 
layers are available to you should you wish to continue to practice this technique of 
syncing audio with animation.

Choose File > Save to save these changes to your After Eff ects project. You may now 
close the fi le, as you are fi nished with it.

Creating keyframes from audio files
Audio isn’t always used on its own or to support animation; sometimes it’s actually used 
to run or trigger the animation of other layers. The audio information in a fi le can be 
converted into keyframes and then linked to properties on another layer using expressions, 
the scripting language built into After Eff ects. While you will learn more about 
expressions in Lesson 9, “Advanced Animation,” you are going to use a very simple feature 
of expressions here.

In this exercise, you will add an audio fi le to a prebuilt project and then use it to control 
the scaling of a series of objects in a composition.

1 Choose File > Open Project and navigate to the ae07lessons folder. Locate the 
Creating keyframes from audio fi les.aep fi le and double-click on it to open this 
project. The Main Composition consists of a background layer and a series of semi-
transparent circles above it. The circles are themselves each individual comps, 
duplicates of the Scaling Circle composition.

2 At the top of the Composition panel, click on the arrow in the fl owchart selector to 
the right of the main composition to open the Mini-Flowchart view.

When working with nested comps the mini-fl owchart allows you to navigate from one comp to another.
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3 As you can see in the Mini-Flowchart view, this composition is made up of the 
background comp and fi ve iterations of the Scaling Circle comp.

Click on the Scaling Circle (5) label in the Mini-Flowchart view to open this 
composition.

The mini-fl owchart view makes it easy 
to navigate between your compositions 
without leaving the Timeline or 
Composition panels.

4 Once the Scaling Circle comp opens, you can see that it is composed of one layer, a 
shape layer named circle.

In the Project panel, click on the audio folder to highlight it and choose 
File > Import > File.

In the Import File dialog box, navigate to the ae07lessons folder, locate the fi le named 
Captain Zero 16seconds.wav, and double-click to import it. It is automatically placed 
inside the audio folder.

5 Drag the Captain Zero 16 seconds.wav fi le to the Timeline and place it below the 
circle layer.

The audio fi le is a bit low, so you will adjust its audio levels to make it louder and 
produce a better eff ect. Since the intention here is to use the volume data from this audio 
fi le to power an animation, the louder the audio is, the stronger the fi nal eff ect will be.

6 Click on the reveal triangle for the audio layer to show the Audio property group. 
Then click on the reveal triangle for the property group to show the Audio Levels 
property. Change the value of the Audio Levels property to +12.00 dB.

7 With the Captain Zero 16seconds.wav layer selected, choose Animation > Keyframe 
Assistant > Convert Audio to Keyframes. This creates a new layer named Audio 
Amplitude.

The Convert Audio to Keyframes command converts the volume information in the 
audio fi le into keyframes and stores that information in this new layer.

8 With the Audio Amplitude layer selected, press the Return (Mac OS) or Enter 
(Windows) key on your keyboard to make the layer name editable, and change it to 
audio-volume keyframes. Then click on the reveal triangle to show the Eff ects and 
Transform property groups.

Click on the reveal triangle for the Eff ects group to reveal the Left, Right, and Both 
Channels properties.
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Finally, click the reveal triangle for the Both Channels property to reveal the slider 
control of this property. You will use expressions to attach the Scale property of the 
circle to this slider.

The keyframes for the layer are deeply nested inside the property group.

9 Click on the circle layer to select it and press the S key on the keyboard to reveal its 
Scale property. Click on the Scale property and choose Animation > Add Expression.

Adding an expression to a layer adds a series of controls and a text fi eld to the layer 
where you can input the expression code. You can learn more about expressions 
in Lesson 9, “Advanced Animation.” For now, you are simply going to use the 
Expression Pick whip ( ) to connect the Scale property to the Both Channels slider.

10 Click on the Expression Pick whip and drag it to the Both Channels slider above. 
When the slider property becomes highlighted, this is your cue that the Pick whip has 
found its target. 

The Expression pick whip can be used to connect any layer property to any other layer property.

When you release the Pick whip, it automatically adds the code that links the two 
properties to the text fi les in the Timeline.

11 Click on the Main Composition tab in the Timeline panel to return to that comp. 

RAM Preview the animation to see the eff ect of your work. Notice that the circles 
now oscillate in time to the music’s beat. Be sure to adjust your computer’s volume to 
suit your needs so that the playback is neither too loud nor too soft.

Choose File > Save As. In the dialog box that appears, navigate to the ae07lessons folder 
and change the fi le name to Creating keyframes from audio fi les-working.aep. 

Click Save to close the dialog box. You can now close the project, as you are done 
with it. Congratulations! You have completed the lesson.
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Review

Self study
1 Complete the animation for the Syncing Animation to Audio-working.aep project; 

there is still an entire stanza left to animate. 

2 Create a new Composition and import your own audio fi les, convert them into 
keyframes, and use the Expressions Pick whip to experiment with linking them to 
diff erent transform properties of visual layers such as Opacity and Position. You can 
also link them to the properties of eff ects.

Review
Questions
1 What is the advantage of using uncompressed audio fi les in After Eff ects?

2 What are the three ways to preview audio on the Timeline?

3 Why is it helpful to name composition markers?

Answers
1 Uncompressed audio fi les tend to preview better in After Eff ects. Also, because they are 

uncompressed, they usually produce a higher-quality sound when exported than fi les 
that have already been compressed and are again re-compressed when you output them.

2 You can preview audio on the Timeline using a RAM Preview, or by scrubbing the 
playhead while holding the Ctrl (Windows) or Command (Mac OS) key. You can also 
preview it separately by choosing Composition > Preview > Audio Preview (Here 
Forward) or choosing Composition > Preview > Audio Preview (Work Area).

3 Naming composition markers is helpful because it makes identifying and locating 
them more convenient.
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What you’ll learn in 
this lesson:
• Creating and Animating 

3D Layers

• Understanding 3D 
Transformations

• Using Lights and Cameras

• Working with Native After 
Eff ects 3D Objects

• Working with Photoshop 
3D Objects

Lesson 8

The real world has more than two dimensions, and so do your 
After Eff ects projects. Even experienced After Eff ects users can 
fi nd working in three dimensions a little daunting, but after an 
initial learning curve, you will come to see how much more visually 
compelling your work can be when using all three dimensions. 

Starting up
You will work with several fi les from the ae08lessons folder in this lesson. Make sure that 
you have loaded the aelessons folder onto your hard drive from the supplied DVD. See 
“Loading lesson fi les” in the Starting up section of the book.

See Lesson 8 in action!

Use the accompanying video to gain a better understanding of how to use some of the features 
shown in this lesson. The video tutorial for this lesson can be found on the included DVD.

8

Working with 3D 
in After Effects
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Setting up
As you work in After Eff ects, you will inevitably open and close many panels, depending 
on the type of project you are creating. However, when working through the projects in 
this book, it is important to have an interface that matches the lessons. To this end, you 
should always reset your workspace to the preset Standard confi guration.

1 Choose Window > Workspace > Standard to set your current workspace confi guration.

2 Choose Window > Workspace > Reset “Standard” to reset the standard workspace in 
case you have modifi ed it at some point. 

Previewing animation with RAM preview
Animations that you preview by pressing the spacebar or just scrubbing the playhead are 
not in real time; additionally, this method doesn’t preview audio fi les in your composition. 
Instead, you can have After Eff ects render a video preview by using your system’s RAM. 
The length of the preview depends on both the amount of RAM allocated to the program 
and the current settings of the Preview panel. There are two sets of RAM preview options 
available: RAM preview (the standard) and Shift-RAM preview. These options are simply 
a way of saving two diff erent render settings. For example, you may set the RAM preview 
options to render at full frame rate and resolution and set the Shift-RAM options for lower 
resolution and to mute audio. Lower-quality settings require less RAM, and therefore you 
can render longer previews more quickly.

A B C D E F G H

A. Go To First Frame. B. Go To Previous Frame. C. Play/Pause Timeline. D. Go To Next Frame. 
E. Go To Last Frame. F. Mute Audio. G. Loop Options. H. RAM Preview.

The options available when setting up a RAM preview are:

Mute Audio: By default, RAM preview, unlike the spacebar preview, includes audio on 
the Timeline. The Mute button allows you to exclude it to create a quicker preview.

Frame Rate: This option specifi es the frame rate for the rendered preview. If you choose 
the Auto setting, it uses the previewed composition’s frame rate.

Skip: This option specifi es the number of frames to skip between a rendered frame and 
the next rendered frame. Choose zero to render all frames. This setting is helpful for 
building previews more quickly.

Resolution: This option specifi es the resolution of the rendered preview. For example, 
setting this option to half renders every other pixel in the composition, resulting in a 
lower quality but faster preview. You should choose Auto to use the composition’s current 
resolution setting as specifi ed in the Resolution/Down Sample Factor pop-up menu.
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From Current Time: By default, a RAM preview plays from the beginning of the work 
area bar to the end. Select From Current Time to play from the current position of the 
playhead instead.

Full Screen: Normally the RAM preview plays in the workspace. Choose this option to 
isolate the preview on-screen against a fl at background.

The RAM Preview command will build a preview of the entire work area of your 
composition. Normally, this work area extends from the beginning of your comp to the 
end. However, you can change the preview area by adjusting the beginning and end of the 
work area bar manually in the following way: 

1 Click and drag to position the work area bar’s start and end points over the area you 
want to preview. 

You can press the B key on the keyboard to move the beginning of the work area bar to the 
playhead and the N key to move the end of the bar to the current position of the playhead.

2 Click the RAM Preview button ( ) in the Preview panel to begin rendering the Timeline. 

Working with After Effects 3D
When you create a new Composition, you have the option of choosing the type of 3D 
renderer to use. Located in the Advanced tab of the New Composition dialog box, your 
choices are to use either Classic 3D (the default) or the newer Ray-traced 3D. Introduced 
in After Eff ects CS6, the Ray-traced renderer allows for a more realistic 3D eff ect by 
providing a superior representation of how light interacts with objects in the 3D space. 
Setting a 3D renderer is a Composition level eff ect and will control the options available 
to every layer inside a specifi c composition. Even though the Ray-traced rendered seems 
to be the better choice of the two renderers, it has some drawbacks: it doesn’t render some 
eff ects that you can apply to footage layers, and it requires more system resources than the 
Classic 3D. In this lesson, you will use both renderers. 

You can set any layer in a composition to 3D by enabling the 3D switch from the Switches 
pane on the Timeline. The eff ects of enabling a layer’s 3D properties vary depending on 
the type of layer it is and on the active Composition renderer. For Classic 3D rendering, 
three things happen when you turn this switch on: the layer can now be aff ected by 
lights and camera movement, a new properties group called Material Options is added 
to the layer, and the existing Transform properties (with the exception of Opacity) are 
appended to include a z-axis value. In the case of Rotation, a new property is added called 
Orientation and the Rotation property is split into three diff erent properties: X Rotation, 
Y Rotation, and Z Rotation. For Ray-traced rendering, in addition to the features of the 
Classic renderer, you gain options such as extruded and beveled shapes, refl ections, and 
refractions. However, you also lose certain features: the Ray-traced renderer does not 
render eff ects such as Blend Modes, track mattes, or layer styles.
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Creating 3D layers
Unlike other motion graphics programs, After Eff ects allows you to combine both 2D and 
3D layers together in the same composition. By default, all layers, including layers made 
from nested compositions, start off  as 2D and can be easily converted to 3D by turning on 
a switch. In this set of exercises you will work with a pre-built composition to animate 
layers so that they appear to rotate toward the viewer in 3D space. But fi rst you must 
convert them to 3D layers. In this section of the lesson, you will work with a Composition 
that uses the Classic 3D renderer. 

1 Open the SecretOfSuccess.aep fi le found in your ae08lessons folder. This After Eff ects 
project is composed of a single composition with seven layers, one layer for each of the 
words in the phrase, “THE SECRET OF SUCCESS IS SINCERITY” and one for 
the background. Move the playhead to any time after the 3-second and 15-frame mark 
(00;00;03;15) on the timeline. 

The layers in this composition already have an opacity animation on them, so you 
won’t be able to see anything except the background plate while the playhead is at the 
beginning (00;00;00;00) of the Timeline.

2 Choose File > Save As and navigate to the ae08lessons folder. Rename the fi le 
SecretOfSuccess_Working.aep and click Save.

3 With the Composition panel highlighted, choose View > Clear Guides to remove the 
onscreen guidelines. 

The onscreen guides were used when this fi le was being created to help arrange the diff erent layers.

4 Lock the Background layer to avoid accidentally editing it, by clicking the Lock 
button ( ) to the left of the layer. If it is not already open, expand the Layer Switches 
pane in the After Eff ects Timeline panel by pressing the Expand/Collapse button ( ) 
in the lower-left corner of the panel.
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5 Click on the fi rst layer to highlight it and press Ctrl+A (Windows) or Command+A 
(Mac OS) to select all the layers in the composition, then click the 3D Layer switch ( ) 
to enable each layer’s 3D properties.

You can use layer switches to enable eff ects such as 3D and Motion Blur.

6 Whenever you have multiple layers selected, almost any change to one layer is applied 
to all of them. Press Ctrl+Shift+A (Windows) or Command+Shift+A (Mac OS) to 
deselect all the layers in your composition. 

7 Save your fi le by choosing File > Save.

Using multiple viewports
When working with layers in 3D space, it is very helpful to be able to change the native 
composition window from the standard single-view layout to a multiple-view layout. The 
multiple-view layout can split the composition area into either two or four viewports, 
each of which has several confi gurations. In preparation for working in 3D space, you will 
confi gure the Composition window with a two-view layout. 

1 Click the Select View Layout drop-down menu located at the bottom of the 
Composition window.

As you work with 3D elements in 
After Eff ects, you will often change 
the viewport layout.
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2 Choose the multiple-view layout named 2 Views-Horizontal from the drop-down 
menu. Keep in mind when working on your own that you may need to change the 
view confi guration quite often; in these situations you will want to choose the specifi c 
multiple-view layout that fi ts your needs.

The default display of 2Views-Horizontal is a Top and Active Camera view.
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Understanding the different views

Located next to the Select View Layout drop-down menu is the 3D View pop-up menu. 
You use it to change the view of the active viewport. While it is available at any time in the 
program, it is only useful when working with 3D layers. You have a choice between the 
Active Camera view; Orthographic views such as Front, Top, and Left; and using camera 
layers that you have created as viewports.

The default view in After Effects is called Active Camera. This is a perspective view that 
allows you to interact with your content along all three axes (X, Y, and Z), and it shows 
the effects of perspective as well. Initially you can think of it as a virtual default camera. 
Once you add additional cameras, however, the effect of choosing Active Camera changes a 
bit. When working with camera layers, you have the choice of viewing through either the 
cameras lens or Active Camera. In this situation, the active camera view refers to the camera 
that is currently underneath the playhead. 

In the figure above, as the playhead moves, the Active Camera view changes. At the 
beginning of the Timeline, Camera 1 is the Active Camera, but at 2 seconds (0;00;02;00) 
Camera 2 becomes the Active Camera view. As the playhead progresses and reaches the 4 
second (0;00;04;00) mark, the third camera, named Camera 3, becomes active. What this 
means is that the viewports shift what they are viewing. This is important to be aware of 
because only the Active Camera view can be rendered, so controlling the start and end points 
of camera layers is a way of creating cuts to different cameras in After Effects. 

In addition to camera layers and the Active Camera views, you can use a series of 
Orthographic views as well. These views — Front, Left, Top, Back, Right, and Bottom — 
provide an isolation of one specific angle. Each view is 90 degrees from the previous view, 
creating a virtual box that surrounds the composition. These views are very helpful when 
you must lay out content in three-dimensional space or if you simply need to isolate and 
move a single layer along a specified axis. 
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3 Select the left viewport and confi rm that the 3D view pop-up menu is set to Top. 
When you click on a view, small triangular markers appear at its corners, indicating 
that it is the active viewport. Choose Fit Up To 100% from the Magnifi cation drop-
down menu.

4 Select the right viewport and confi rm that the 3D view pop-up menu is set to Active 
Camera, and again choose Fit Up To 100% from the Magnifi cation drop-down menu. 
This ensures that you have enough room to actually see the composition as you animate 
the text. If you are working on a smaller display, the magnifi cation may not increase.

Understanding 3D Transform properties
Once you have enabled the 3D properties for any layer, you can immediately see a change 
in that layer’s Transform properties. With the exception of Opacity, every property that 
formerly had two values (for X and Y) now has an additional Z property. In addition to 
these modifi cations, the rotation value has been completely altered. When converted to a 
3D layer, the single Rotation property is split into X Rotation, Y Rotation, Z Rotation, 
and a fourth property that combines them all as a single keyframe-value Orientation.

Position, Anchor Point, and Scale

When a layer’s 3D property is disabled, Position, Anchor Point, and Scale each have two 
numerical values, one for X and one for Y. As part of a 3D layer, each of these properties 
gains another value for the Z property. For example, Position is now seen in the property 
list as Position 00.0, 00.0, 00.0 where the fi rst value represents the position of the layer 
along the X-axis, the second value represents its position along the Y-axis, and the third 
value its position along the Z-axis.

X Rotation, Y Rotation, Z Rotation and Orientation

Once you enable a layer’s 3D property, the single rotation value (which is actually 
Z Rotation) is split into three properties (X Rotation, Y Rotation, Z Rotation) and the 
Orientation property is added. The individual rotation properties allow you to create 
individual keyframes for each axis of rotation. This is helpful when you want to create 
rotational animations where the properties change by diff erent values or have diff erent 
timing, as you can create separate keyframes for each property. However, animation of 
the Orientation property creates a single keyframe that contains the values of all three 
rotation values.

Understanding Material Options
Once you have enabled the 3D switch for a layer, an additional property group named 
Material Options becomes available. A 3D layer’s Material Options specify how that 
layer reacts when it receives light and casts shadows. A Composition using the Classic 3D 
renderer has the following material options:
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Cast Shadows: This option specifi es whether a layer can cast shadows onto other layers. 
The position and angle of the cast shadows is determined by the relationship of the light 
that is creating the shadows to the layers that are casting and receiving the shadows. The 
density and diff usion of the shadows is determined by the light’s options. The Cast Shadows 
option is turned off  by default, but it actually has three settings: off , on, and only. The only 
setting removes the layer’s content and just projects a shadow onto the receiving layers.

Light Transmission: This option specifi es the translucency of a layer as a percentage. 
When you set the value to zero percent, the layer acts like an opaque wall casting a black 
shadow. A value of 100 percent allows the colors of a shadow-producing layer to be 
projected onto a receiving layer.

Accepts Shadows: This option specifi es whether or not a layer can receive shadows that 
are cast by other layers. In order to see the eff ects of the Cast Shadows option in a scene, 
there has to be at least one 3D layer in that scene with the Accepts Shadows option enabled.

Accepts Lights: This option specifi es whether or not the content of a 3D layer is aff ected 
by light layers in a composition.

Ambient: This option specifi es the ambient refl ectivity of a layer. The ambient refl ectivity 
of a layer is non-directional, meaning it doesn’t actually project light back toward the viewer. 
This setting is the most refl ective at 100 percent, and the least refl ective at zero percent.

Diff use: This option specifi es the diff use refl ectivity of a layer. The diff use refl ectivity 
is omnidirectional, meaning that light that falls on this layer is refl ected in all directions. 
You can think of the diff use refl ectivity as the base or overall refl ectivity of the layer. This 
setting is the most refl ective at 100 percent, and the least refl ective at zero percent.

Specular Intensity: This option specifi es the specular refl ectivity of a layer. The specular 
refl ectivity is directional, refl ecting back toward the source of light, the way a mirror 
would. Specular refl ectivity is what causes the intense highlights that give shiny metals, 
such as gold and silver, their distinctive appearances. This setting is the most refl ective at 
100 percent, and the least refl ective at zero percent.

Specular Shininess: This option specifi es the size of the highlight created (called the 
specular highlight) when you set the specular refl ectivity to a value higher than zero percent. 
Smaller values produce a larger specular highlight, while higher values produce a smaller 
one. Materials, such as shiny metals and plastics, tend to have very small specular highlights.

Metal: This option specifi es whether or not the layer’s content aff ects the color of the 
specular highlight. The default value of 100 percent sets the color of the highlight to that of 
the layer’s content, while a value of zero percent sets the highlight color to the light’s color.

Animating 3D layers
A Three-dimensional layer’s properties are animated in exactly the same fashion as a two-
dimensional layer’s properties. Once you have enabled animation for a specifi c property 
(by clicking on the Time-Vary Stopwatch ( ) to the left of the property), any change to 
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that property—either by changing the numerical values for the property in the Timeline, 
or by directly editing it in the Composition window—creates a new animation keyframe. 
Most of the properties for 2D and 3D layers are the same (Anchor Point, Position, and 
Scale) except they have an additional value for the Z-axis. However, the Rotation 
property is signifi cantly diff erent between these two types of layers. 

When working with two-dimensional layers, there is a single rotation value; it doesn’t say so, 
but this is a rotation along the Z-axis. Remember, once you enable the 3D switch for a layer, 
it gains three isolated rotation values: X Rotation, Y Rotation, and Z Rotation. It also gains 
the Orientation property, which combines all three rotations into a single keyframe value. 

In this exercise, you will animate the layers along their respective X and Y axes to give the 
impression that they are fl ipping toward the viewer, like a swinging door. In this exercise, 
the Anchor Point properties of the layers have been repositioned so that each layer will 
rotate properly.

The Opacity property is unchanged when dealing with 3D layers.

1 Select the fi rst layer named “THE” and press U on your keyboard; this shows the 
Opacity property. You press the U key to reveal all layer properties that already have 
the Time-Vary Stopwatch icon ( ) enabled. 

2 Hold down the Shift key on your keyboard and press R to reveal its Rotation 
properties (Orientation, X Rotation, Y Rotation, Z Rotation) as well. This ability 
to show multiple properties at once is helpful, especially when you want to create 
animation where diff erent properties animate concurrently.

Learning the various keyboard commands in After Eff ects improves your speed and effi  ciency 
when using the program.

Use the Shift key to add properties to the display without replacing the ones that are currently 
displayed. You can also use the Shift key to hide individual properties if you press Shift+R; in 
this example, the Rotation properties would be hidden, but the Opacity property would remain.
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3 If it is not already there, move your playhead to the beginning of the Timeline, where 
the fi rst Opacity keyframe is located. Click the Auto-Keyframe button ( ) at the 
top of the Timeline panel. Auto-Keyframe is a timesaving feature that allows you to 
enable animation for any property by simply changing its value.

4 Change this layer’s Y Rotation to 0x -90 degrees; a keyframe is created. Because the 
Auto-Keyframe switch was enabled, you don’t have to click on the property’s Time-
Vary Stopwatch icon fi rst. 

5 Press the K key on your keyboard to jump to the second opacity keyframe at 
0;00;01;00. Change the Y Rotation value to 0x 00 degrees. This returns the layer to 
its forward-facing position. Scrub the playhead back and forth to test your animation. 
The text now appears to swing forward and fade in to view. If you look in the Top 
viewport on the left, you will notice a wireframe animation that shows the position of 
the layer in that view.

The orthographic views are helpful for determining the positional relationship of layers in 3D space.

6 With the fi rst layer still selected, press Ctrl+ ~ on your keyboard to close all its visible 
properties. Then select layer 2, named “SECRET,” and again press U on your 
keyboard to reveal all properties with animation enabled. Then hold down the Shift 
key and press R to reveal this layer’s Rotation properties as well. The “SECRET” 
layer needs an X Rotation animation so that it can look like it swings down from the 
previous layer.
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7 Click in any area of the viewport on the left side of the Composition panel to make it 
active and change the 3D View Pop-up menu to Left. Now move the playhead to the 
fi rst opacity keyframe for this layer by pressing J (to move the playhead back) or K (to 
move the playhead forward) on your keyboard. Change the X Rotation to 90 degrees.

The 3D View Pop-up menu is used to change each view port independently.

8 Press K on your keyboard to jump to the last Opacity keyframe for this layer and 
change the X Rotation to 0 (zero) degrees. Scrub the playhead, and you can see that 
the animations all run simultaneously. 

With the layer selected, press Ctrl+ ~ to close all its visible properties.

Select the fi rst and second layers in the timeline and press the U key on your keyboard 
to reveal all the animated properties of both layers. Notice that the animations of the 
two layers overlap slightly. In other words, the second layer’s animation begins before 
the fi rst layer’s animation has fi nished, thus creating simultaneous animation.

Simultaneous animation is usually more visually appealing than simple sequential animation.
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9 With the fi rst and second layers still selected, press Ctrl+~ on your keyboard to hide 
all visible properties of the two layers. 

Select layer 3 and press T on your keyboard to reveal its Opacity property. Then 
hold down the Shift key and press R to reveal this layer’s Rotation properties as well. 
Hold down the Shift key and drag the playhead to the fi rst keyframe in the Opacity 
property. Pressing and holding the Shift key forces the playhead to snap to keyframes 
on the Timeline, and to the In and Out points of layers.

10 Set the Y Rotation for layer 3 to -90 degrees, move the playhead to the second opacity 
keyframe, and set the rotation value to 0 (zero) degrees. 

Now that you are familiar with this process, you can complete the other three layers 
yourself. The properties to animate and their values are listed in the following table. 
All the values below are for the fi rst keyframe of the animation. The second keyframe 
is always 0 (zero) degrees.

LAYER NUMBER LAYER NAME PROPERTY VALUE

4 SUCCESS X Rotation 90 degrees

5 IS X Rotation 90 degrees

6 Sincerity X Rotation 90 degrees

Remember to place each pair of rotation keyframes so that they correspond with the 
position of each layer’s opacity keyframes. The fi nal Timeline should look like this 
when complete.

Making the rotation animation simultaneous with the opacity animation creates a more visually appealing design.

11 Save your fi le by choosing File > Save.
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Creating and using lights
Lights in After Eff ects aff ect only three-dimensional layers, and you can use them to 
illuminate these layers and cast shadows. You can use lights to create appealing visual 
eff ects and enhance the sense of depth and volume in a scene. There are four types of 
lights that you can create in After Eff ects: Parallel, Spot, Point, and Ambient. Each light 
has specifi c editable properties and is intended to be used in a specifi c way. In this exercise, 
you will be creating a spotlight. The appearance of the shadows and highlights created by 
a spotlight are based on the position of the light and the layer it is shining on, as well their 
properties for Light and Material options. 

Lights do not have an Anchor Point property like other layers do; instead, they have a 
point of interest. This Point of Interest property sets the point in the composition that the 
light looks at. When it is moved around the composition, the light always rotates to look at 
this point. This feature is called Auto-Orient Towards Point of Interest, and you can edit it 
from the Auto-Orientation dialog box by choosing Layer > Transform > Auto-Orient. 

Unlike in the real world, lights in After Eff ects only cast shadows if you want them to. If you 
have ever tried to light a scene, you will be amazed at how diff erent everything looks when you 
can actually turn off  a light’s ability to cast shadows, or for that matter a layer’s ability to receive 
them, or even turn off  a layer’s ability to be aff ected by lights. In this exercise, you will set up the 
background layer so that it can receive shadows from the text layers above it.

1 Open the SecretOfSuccess_Working.aep fi le that you created earlier in this lesson. If 
you skipped that section, you can use the fi le named SecretOfSuccess-complete.aep 
that has been provided. Move the playhead to the 4 second (0;00;04;00) mark so that 
you can see the fi nal position of the animation. 

2 Choose File > Save As. If necessary, navigate to the ae08lessons folder. Rename the 
fi le SecretOfSuccess-lighting.aep and click Save.

3 Choose Layer > New > Light to open the Light Options dialog box. In the dialog 
box, set the light’s properties as follows:

• Name: Spot Light 1

• Light Type: Spot

• Intensity: 100%

• Cone Angle: 90º

• Cone Feather: 50%

• Color: White (R:255, G:255, B:255)

• Cast Shadows: On

• Shadow Darkness: 100%

• Shadow Diff usion: 0%

AECS6_06Pass.indb   252AECS6_06Pass.indb   252 5/18/12   1:06 PM5/18/12   1:06 PM



8

253Lesson 8, Working with 3D in After Eff ects 

Creating and using lights

Once you have set its properties, click OK to create the new light.

Spotlights are directional lights that project a cone of light 
at the subject.

The keyboard command for creating a new light layer is Ctrl+Alt+Shift+L (Windows) or 
Command+Option+Shift+L (Mac OS).
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The new spotlight has been created but you can see that it only aff ects the text layers. 
The middle of the layers where the light is actually hitting them is brightest, while 
the edges are much darker; this is caused by the light’s Cone Angle and Cone Feather 
settings. Even though Cast Shadows has been enabled for the light, the layers need 
to have the Cast Shadows option enabled individually, and even then the shadows 
need to have a surface to be cast on. To receive shadows, you have to convert the 
background layer to 3D and enable it to receive shadows.

The eff ect of lights is only visible on the opaque parts of 3D layers.

4 In the Composition panel’s Select View Layout drop-down menu, select 1 View. 

In the Timeline panel, lock the Spot Light 1 layer; the background layer was 
locked prior to this in an earlier exercise of the lesson. Press Ctrl+A (Windows) or 
Command+A (Mac OS) to select the remaining text layers. Now that they are all 
highlighted, any change you make to the properties of one layer will aff ect them all. 
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On the layer named THE, click the reveal triangle to the left of the layer name to 
show its properties. Then click the reveal triangle next to Material Options to show 
them as well.

Remember that Material options are only available for 3D layers.

5 Click the Cast Shadows property to turn it on. This enables Cast Shadows for all 
selected layers, but you still see no eff ect because shadows have to be cast onto a three-
dimensional background layer. Additionally, the layer that receives the shadows cannot 
be at the same Z position as the layers that are casting the shadows.

A B C D E

A. Layer to receive the shadows. B. The shadow. 
C. Layer that casts the shadow. D. Point of Interest. 
E. Light source.

With all the text layers still selected, press Ctrl+ ~ (Windows/Mac OS) to hide all the 
currently visible properties.

Sometimes it is necessary to use the Ctrl+ ~ (Windows/Mac OS) multiple times to close all the 
visible properties. 
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6 Unlock the bottom layer named background. Click the layer’s 3D switch; this 
immediately allows it to be aff ected by the spotlight. While the Accept Shadows 
property is enabled for this layer, the text layers can’t cast shadows on it because they all 
occupy the exact same Z position. To correct this, you will adjust the depth of this layer.

Confi rm that the playhead is still at the 4 second (0;00;04;00) mark n the timeline, and 
with the background layer still selected, press the P key on your keyboard to reveal its 
Position property and change the Z position to 150. This makes the layer’s position 
values 360.0, 240.0, and 150.0. You can now see the shadows being cast by the letters.

The shadows are dark and heavy due to the initial light settings, 
but they will be adjusted later.

7 Disable the visibility of the Spot Light 1 layer by clicking on the Visibility icon ( ) to 
the left of the layer name. This disables the lighting eff ect and returns the scene to the 
default lighting conditions where all layers receive a default ambient light. Now that 
you can see it, you will notice that the background layer appears much smaller than 
it did before. Due to the eff ect of perspective, objects that are farther away from the 
viewer appear smaller than objects that are closer. 

Whenever you are working with 3D layers, you must take into 
account the eff ect of size distortion caused by perspective.
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8 With the background layer still selected, hold down the Shift key on your keyboard 
and press S to reveal the Scale property. 

Make sure the Constrain Proportions switch is enabled and change the layer’s scale to 
120.0. This allows it to fi ll the entire composition background.

9 Re-enable the visibility of the Spot Light 1 layer and click the Lock icon ( ) to unlock 
it. Click the reveal triangle to the left of the layer name to show its properties, and 
then click the reveal triangle next to Light Options. Change the Shadow Darkness to 
40 percent and the Shadow Diff usion to 20 pixels. Change the light’s Cone Feather to 
100 percent. This produces a softer, more subdued eff ect.

The Position property stores the X, Y, and Z positions as a single keyframe value.

10 Press the P key on your keyboard to reveal the light’s Position property and change its 
position values to 455.0, 70.0, -375.0. With the light layer still selected, hold down the 
Ctrl key on your keyboard and press the tilde (~) key on your keyboard to hide this 
layer’s properties.

11 Save your fi le by choosing File > Save or by pressing Ctrl+S (Windows) or 
Command+S (Mac OS) on the keyboard.
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Understanding light options
When you create a new light, you always have access to the exact same properties but, 
depending on the light type you choose, some options will be disabled. In addition to 
being accessible in the Light Settings dialog box when you create a new light layer, these 
attributes are editable under the Light Options property group in the Timeline panel or 
when you double-click a light layer. 

Light Type: Located in the Light Settings dialog box, this setting lets you specify the type 
of light you want to create. Point lights create directional unrestricted light, similar to that 
cast by the sun. The Spot light is a directional light that is restricted to a conical shape and 
increases in diameter the farther the source of light is from the layers that are receiving it. 
A Point light emits unrestricted omnidirectional light, similar to the way a household light 
bulb does. An Ambient light lacks a source and doesn’t cast shadows, but instead adds to 
the overall brightness of a 3D scene.

Intensity: This setting specifi es the strength of the light as a percentage. Values above 
100 percent produce a burned-out eff ect on layers the light falls on, while negative values 
subtract from the colors of a layer.

Color: This setting specifi es the color of the light source.

Cone Angle: For a spotlight, this setting specifi es the angle of the cone that constrains the 
source of light. This aff ects the diameter of the light as it falls onto layers in your scene.

Cone Feather: For a spotlight, this setting specifi es the softness of the cone’s edge. 

Falloff : Sets the type of falloff  for the specifi ed light. None indicates that the light 
intensity will not diminish in strength the further it is from the layers it is illuminating. 
Smooth sets a gradual, linear falloff  that begins at the distance specifi ed by the light’s 
radius value, and extends based on the Falloff  Distance. Inverse Square Clamped creates an 
approximation of light falloff  that is the most physically accurate. 

Radius: Inside the distance specifi ed by the radius value, the light intensity is constant; 
outside of this distance, the light begins to fall off .

Falloff  Distance: Sets the distance that the light’s illumination falls off  once outside the 
range set by the Radius value.

Cast Shadows: This setting specifi es whether or not the light causes layers in a 3D scene 
to cast shadows onto other layers.

Shadow Darkness: If you enable the Cast Shadows option, this setting specifi es the 
darkness of the shadow.

Shadow Diff usion: If you enable the Cast Shadows option, this setting specifi es the 
shadow’s softness. The amount of softness is based on the value you set and the shadow’s 
distance from the layer casting it.
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Animating light properties 
Like nearly every other attribute in After Eff ects, the light options can be fully edited 
and animated in the Timeline. With the exceptions of the light type and whether or not 
it can cast shadows, you can animate every other property of a light to produce visually 
appealing graphics. In this exercise, you will use the SecretOfSuccess-lighting.aep fi le that 
you created previously and animate the light’s Point of Interest and Intensity properties to 
create a more visually compelling design.

1 Open the SecretOfSuccess-lighting.aep fi le that you created earlier in this lesson. 
If you skipped that section, you can use the fi le named SecretOfSuccess-lighting-
complete.aep that has been provided for you. Move the playhead to the 4 second 
(0;00;04;00) mark so that you can see the fi nal position of the animation. 

2 Choose File > Save As. If necessary, navigate to the ae08lessons folder. Rename the 
fi le SecretOfSuccess-lighting-working.aep and click Save.

3 Move the playhead to the 1 second (0;00;01;00) mark on the Timeline and click on the 
Spot Light 1 layer to highlight it. Press the Ctrl+~ keys (Windows/Mac OS) on your 
keyboard to reveal all the layer’s properties.

Once a light is created it overrides the default light in a composition so that only what the lights in your scene illuminate is visible.

4 Click the Time-Vary Stopwatch icon ( ) for the Point of Interest property in the 
Transform group to create a keyframe for the fi nal position of the animation. Move 
the playhead to the beginning (0;00;00;00) of the Timeline and change the Point of 
Interest property to 760.0, 510.0, 0.0. This moves it just outside of the lower-right 
corner, plunging the rest of the composition into darkness.
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5 Preview the animation. It works, but it would benefi t if the point of interest didn’t 
move in a straight line. You can easily do this, as you can adjust its Motion Path just 
like any other. Move the playhead to the beginning of the timeline (0;00;00;00) and 
then click on the Point of Interest property to highlight it so that you can view its 
Motion Path. Position your Selection tool ( ) over the direction handle at the end 
of the Motion Path and drag it down and to the left to the position shown in the 
following fi gure. Preview the animation to see the changes you made.

Motion Paths are visible for any positional animation such as Anchor Point, Point of Interest, and Position.

6 Move the playhead to the 4 second (0;00;04;00) mark, where the text animation ends. 
Click on the Time-Vary Stopwatch icons for Intensity and Cone Angle to create two 
keyframes. Because they are the fi rst keyframes on the Timeline for this property, they 
will act as placeholders, locking their values in place until this time.
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7 Move the playhead to the end of the Timeline. Change the Intensity to 700% and the 
Cone Angle to 180º.

While the Intensity value defaults to 100 percent, you can change it for visual eff ect.

This eff ectively whites-out the majority of the composition. You can combine this 
eff ect with a Dip to White (Fade to White) transition in an editing application such as 
Adobe Premiere Pro or Final Cut Pro to segue into another clip.

8 Save your fi le by choosing File > Save or by pressing Ctrl+S (Windows) or 
Command+S (Mac OS) on the keyboard.
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Creating and using cameras 
In After Eff ects, camera layers are designed to simulate the performance and behavior of 
fi lm cameras in real life. As three-dimensional objects, cameras can be panned, tilted, and 
moved to create more engaging compositions. In addition to the ability to animate the 
transform (Position, Rotation, Point of Interest, and so on) properties of camera layers, you 
can also animate a set of additional properties called Camera Options that are unique to 
camera layers. You can use these properties, such as Zoom, Focus Distance, and Blur Level, 
to simulate eff ects found in real-world cameras such as Depth of Field and Rack Focus.

Like lights, cameras do not have an Anchor Point property like other layers; instead, they 
have a point of interest. This Point of Interest property sets the point in the composition 
that the camera looks at. If you move a camera, it always rotates to look at this point. This 
feature is called Auto-Orient Towards Point of Interest and you can edit it from the Auto-
Orientation dialog box by choosing Layer > Transform > Auto-Orient. 

1 As in the previous exercise, open the SecretOfSuccess-lighting.aep fi le that you 
created earlier in this lesson. If you skipped that section, you can use the fi le named 
SecretOfSuccess-lighting-complete.aep that has been provided for you. Move the playhead 
to the 4 second (0;00;04;00) mark so that you can see the fi nal position of the animation. 

2 Choose File > Save As. If necessary, navigate to the ae08lessons folder. Rename the 
fi le SecretOfSuccess-camera-working.aep and click Save.

3 Click on the Timeline panel to highlight it and choose Layer > New > Camera to 
open the Camera Options dialog box. 

From the Type drop-down menu, select Two-Node Camera, and from the Preset 
menu, choose 50mm.

If it is enabled, uncheck the switch for Enable Depth of Field. Leave all other values 
unchanged and click OK to create the new camera layer.
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4 Click on the new camera layer to highlight it and press Ctrl+ ~ on the keyboard to 
show its properties. Click on the Select View Layout drop-down menu and choose 2 
views-Horizontal from the list.

Click on the left viewport and choose Top from the 3D View Pop-up menu.

Click on the Hand Tool ( ) in the Tools panel to activate it. Click and drag in the 
Top view until you can see the Rectangular Camera icon. Depending on your screen 
size and monitor resolution, you may need to change the lower the magnifi cation 
amount for this view as well.

The Hand icon is used to pan around a viewport.

5 Click on the Selection tool ( ) in the Tools panel to make it active and then click 
in the viewport on the right (the one labeled Active Camera) to make it active and 
change its Magnifi cation to Fit up to 100%. 
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6 With the camera layer selected in the timeline place your Selection tool on top of the 
rectangular camera body symbol in the top view. Click and drag the camera to the left 
side of the viewport and notice how the Active Camera view changes as well. 

The Camera, like all 3D layers has a red, green and blue gizmo when selected. If you position 
the Selection tool over one of these arrows it allows you to constrain the movement of the layer 
to a specifi c axis. If you place the Selection tool over the Actual Camera icon, as you do here, it 
allows you to move the layer along any axis.

Any Active Camera view will update in real time as you move the camera in another viewport.

When working on your own, you will usually position layers by dragging them 
around the viewport. However, for the purposes of this exercise, change the camera’s 
position value to 19.0, 240.0, -910.0. 

7 Moving the camera has changed the relationship of the layers on your screen. The 
background no longer covers the entire composition space when viewed from the 
camera’s new position.

Unlock the background layer and then with the layer selected, if necessary, press the S 
key on your keyboard to reveal its Scale property. Hold down the Shift key and press 
the P key to reveal the Position property as well.

8 Make sure the Constrain Proportions switch is enabled and change the background 
layer’s Scale property to 145. Then change the layer’s X position to 490.0.

9 Press the spacebar to begin building a preview to review the animation.

10 Save your fi le by choosing File > Save or by pressing Ctrl+S (Windows) or 
Command+S (Mac OS) on the keyboard.
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Understanding basic camera options
Cameras in After Eff ects are designed to mimic real-world video cameras. Like real 
cameras, they have properties such as position and rotation that can be animated to 
duplicate camera movements like panning and dollying. In addition to these physical 
properties like all layers possess there are specialized Camera options that can be 
manipulated to produce eff ects like zooms and focus changes.

Zoom: This specifi es the distance from the camera lens to the subjects in the 3D scene. 
This setting aff ects the relative size distortion of objects caused by perspective. A layer that 
is at the zoom distance appears at its normal size, while one that is double that distance 
from the camera appears to be half its actual size. 

Depth of Field: Toggle this setting to enable or disable depth of fi eld. When enabled, 
layers that are outside of the focus distance of the camera can appear blurry. 

Focus Distance: This specifi es the distance from the camera lens at which a layer is 
perfectly in focus. You can manipulate the Focus Distance value to produce depth-of-fi eld 
eff ects like those seen in standard photography and fi lms.

Aperture: This specifi es the size of the opening in a camera lens, and aff ects the camera’s 
depth of fi eld. Smaller Aperture settings decrease the blur produced by depth of fi eld, 
while larger settings increase it. 

Blur Level: This specifi es the amount of blur produced by a camera’s Depth of Field eff ect.

Animating camera properties
Like all layers, cameras possess a variety of properties that you can animate. In addition 
to the familiar Position, Orientation, and X, Y, and Z Rotation properties, camera layers 
have a Point of Interest property. The point of interest is a target on-screen that the camera 
always looks at. By default, all camera layers are set to automatically orient to their point 
of interest, but you can override this setting to allow them to move and rotate freely or to 
turn and bank following their motion paths during animation. In this exercise, you will 
work with the project you opened previously to create a camera fl y-through animation. 
You will add a camera to the project and animate its position over time.
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1 Choose File > Open Project. In the Open Project dialog box, navigate to the 
ae08lessons folder, click on Camera FlyIn.aep to highlight it, and click Open. This 
fi le is composed of a total of ten layers. Seven of the layers (Strip01 to Strip06 and 
Textured Background) contain images, the Background Text layer is a composition, 
and there are two light layers as well.

The starting project has light and image layers already set up for you to animate.

The keyboard command to open an existing project is Ctrl+O (Windows) or Command+O 
(Mac OS). 

2 Choose File > Save As. If necessary, navigate to the ae08lessons folder. Rename the 
fi le Camera FlyIn-working.aep and click Save.

3 Click on the Select View Layout drop-down menu at the bottom of the Composition 
panel and choose Two views-Horizontal from the list.

The viewport on the right should be the Active Camera view; change its 
Magnifi cation to Fit Up To 100%.
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The viewport on the left should be a Top view; if not, you can use the 3D View 
 pop-up menu to change it. Change this view’s magnifi cation until you can see 
the entire composition on-screen. In the following example, the window is set to 
12.5 percent, but yours may be diff erent.

The magnifi cation needed to view the entire composition will vary from computer to computer, based on 
monitor size and resolution.

4 With the Composition panel highlighted, create a new camera by choosing Layer > 
New > Camera to open the Camera Settings dialog box. 

Leave the default name, Camera 1, unchanged. From the Type drop-down menu, 
select Two-Node Camera. Then from the Preset drop-down menu, choose 50mm, 
disable the Depth of Field switch, and click OK.

When working with cameras, it is usually easiest to start with an existing preset 
and modify it.
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5 With the new camera layer highlighted, press P on your keyboard to reveal its 
Position property and change its Z position to -2550. Its Position values should now 
be 720.0, 480.0, -2550.

When working with Z position values, zero represents the origin point in the middle of the 
composition. Negative numbers are closer to the viewer than this point and positive numbers are 
farther away.

6 Move the playhead to the beginning of the Timeline (0;00;00;00) and click the Time-
Vary Stopwatch icon ( ) for the camera’s Position property to enable animation and 
create a keyframe.

7 Move the playhead to the 8 second (0;00;08;00) mark on the Timeline and change the 
camera’s Z position to -750.0.

Scrub the playhead to preview the animation. 

Animating the position of the camera creates a change in the positional 
relationship of the layers in the composition and can create an interesting 
visual eff ect.

This animation might benefi t from some rotational animation in addition to what you 
have just done.
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8 Press and hold the Shift key and then press the R key to display the rotation properties 
on the Timeline display; then click on the viewport on the left and change it from the 
Top view to the Front view.

Change the Front view’s Magnifi cation to Fit Up To 100%.

9 Again move the playhead to the beginning of the Timeline and click the Time-Vary 
Stopwatch icon next to the Orientation property to enable its animation and create the 
fi rst keyframe. This creates a keyframe for Orientation with a value of 0.0º, 0.0º, 0.0º.

10 In the Timeline panel, click on the Lock icon ( ) of all the layers in the composition 
except the camera layer. Then click on the Camera layer to select it and make it active.

Locking layers is very helpful to avoid accidentally transforming the wrong layer when working in the 
Composition panel.

Move the playhead to the 3 second (0;00;03;00) mark and click the Rotation tool ( ) 
in the Tools panel to make it active. 
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11 In the Front view, position the Rotation tool in the exact middle of the Camera icon 
right on top of the blue circle so that the tool becomes a capital Z. This indicates that 
your rotation will be constrained to the Z-axis. 

All 3D layers have a red, green, and blue arrow gizmo that allows you to constrain their 
transformations to a single axis.

If you were to position the Rotation tool over the red or green arrows on the camera, this would 
constrain its movement to the X and Y axes, respectively.

Click and drag toward the bottom of the screen until the Z value of the Orientation 
property in the Timeline reads 50 degrees. When you fi rst begin to click and drag on 
the camera a warning dialog box will appear. This dialog warns you that the camera is 
auto-orientated toward its point of interest and changing the rotation value may cause 
it to point away from it. 

The dialog box warns you that the layer is auto-oriented toward its point 
of interest.
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Click OK to close the dialog and continue to change the Camera’s orientation value. 
If you cannot stop exactly at 50 degrees, you can just type the value in the Timeline. 
The completed Orientation property should read 0.0º, 0.0º, 50.0º. 

When viewing the Orientation property the fi rst value represents the X Rotation, the second 
value represents the Y Rotation and the third value represents the Z Rotation.

It’s helpful as you transform a layer in the Composition panel to look at that layer’s properties in the Timeline panel.

By default both camera and light layers are auto-orientated toward their own point of interest. 
This is very useful in many situations such as when a light or camera must follow an object 
around the screen, but can be detrimental when you require a completely free range of movement. 

There are three choice for Auto Orient: Off , Orient Along Path, and Orient Towards Point 
of Interest. The can be adjusted from the Auto-Orientation dialog box by choosing Layer > 
Transform > Auto-Orient.
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12 Move the playhead to the 6 second (00;00;06;00) mark on the Timeline and rotate the 
camera until the Orientation’s Z value is 300.0º. 

Often transformations made in the Composition panel need to be adjusted numerically in the Timeline to be precise.

13 Press the K key on the keyboard to move the playhead to the next visible keyframe; 
this is the last position keyframe that you created in the beginning of this exercise. 

Click on the fi rst Orientation keyframe to highlight it (it becomes yellow) and choose 
Edit > Copy. This copies the keyframe’s values so you can apply them later.

14 Choose Edit > Paste to add the copied keyframe to the Timeline. The keyframe is 
placed at the current position of the playhead. The ability to copy and paste keyframes 
is very helpful when you want to have the exact same property values at diff erent 
points along the Timeline.

Instead of using the menu commands, you can use the standard copy-and-paste keyboard 
shortcuts: Ctrl+C and Ctrl+V (Windows) or Command+C and Command+V (Mac OS) .
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15 Scrub the playhead to preview the animation, and then save your fi le by choosing File > 
Save or by pressing Ctrl+S (Windows) or Command+S (Mac OS) on the keyboard.

Animating multiple properties simultaneously usually creates a more 
interesting eff ect.
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Creating the depth-of-field effect
Depth-of-fi eld is a classic eff ect used in both still photography and fi lmmaking. The eff ect 
involves setting up a specifi c focal distance for the camera, the distance from the camera 
at which objects are in focus, and then moving the camera along the Z-axis. This eff ect is 
extremely appealing when animating the position of the camera; as it moves closer to or 
farther away from the layers in the composition, they appear to be more or less in focus, 
thus creating a more believable sense of movement and depth. 

In addition to the basic camera properties mentioned earlier in this lesson, you have control 
over a variety of other properties that allow you to control the look of the depth-of-fi eld 
eff ect. Properties such as Iris Shape, Iris Rotation, and Iris Roundness allow you to control 
the shape of the depth-of-fi eld blurriness; other properties, such as Highlight Gain and 
Highlight Threshold allow you to control the blurriness of the lighter areas of a layer. This 
gives you the ability to create a depth-of-fi eld aff ect that can better simulate traditional 
camera eff ects.

1 With Camera Flyin-working.aep still open, move the playhead to the beginning of the 
Timeline (0;00;00;00). 

You can create the Depth-of-Field property of a camera when you create the camera, 
or at any time after.

2 Highlight the camera layer in the Timeline, click the reveal triangle to the left to show 
the Camera Options, and click the Camera Options reveal triangle to show its properties.

3 The camera’s Depth of Field property is currently disabled; click the Off  switch to On 
to enable it.

4 Even though it has been enabled, the eff ect is usually too subtle to be useful at its default 
settings. There are three basic properties that aff ect depth-of-fi eld: Focus Distance, 
Aperture, and Blur Level. 

Set the Focus Distance to 2250.0

Set the Aperture to 300

Set the Blur Level to 100
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The settings above work for this particular animation only. They are intended to show the eff ect 
of depth-of-fi eld while the camera is moving, but to keep the fi nal image of the text clear. Notice 
that all three properties above could be animated if you wanted to achieve an eff ect with varying 
depth-of-fi eld blurring. Feel free to experiment with diff erent settings to achieve an eff ect that you 
are happy with.

5 Move the playhead to the beginning of the Timeline and choose Composition > Preview 
> RAM Preview to build a RAM Preview of the animation. The rendering of this 
preview may take some time as the Depth-of-Field eff ect can be quite memory-intensive.

Adding depth-of-fi eld to an animation can enhance its sense of 
depth and space.
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6 The Depth-of-Field eff ect’s default settings can be adjusted to fi t your needs. From 
the Iris shape drop-down menu, choose Hexagon. This changes the shape of the blur, 
giving a more natural visual eff ect.

7 You can adjust the way the Depth-of-Field blur aff ects the brighter areas of your 
layers by adjusting the Highlight Gain and Highlight Threshold properties. Change 
the Highlight Gain property value to 25, and then change the Highlight Threshold 
property value to 150. 

Notice that the brightest areas of each layer are now a bit clearer and distinct. 

8 Save your fi le by choosing File > Save or by pressing Ctrl+S (Windows) or Command+S 
(Mac OS) on the keyboard. You can now close this fi le; you are done with it.

Creating a Rack Focus shot
Rack Focus is an eff ect used in television and video production. This technique is used 
to shift the attention of the viewer by changing the focus of the camera from a subject in 
the foreground to a subject in the background, or vice versa. In After Eff ects, you can do 
this by animating the focal distance of the camera. In this exercise, you will work with a 
project that has three layers, each at diff erent positions along the Z-axis. You will create a 
camera and animate its focus distance to create the eff ect.

1 Choose File > Open Project. Navigate to the ae08lessons folder and open 
Understanding Rack Focus.aep. The fi le has three layers: This is, Rack, and Focus. 

Each of the three layers in this composition is given a diff erent Z position. The layer 
with the This is text is positioned at 0.0 on the Z axis, while the Rack text layer is 
further away from the viewer at 233.0 and the Focus layer is closer to the viewer at 
-240.0. These diff erences in depth are what allow you to create the Rack Focus eff ect.

Choose File > Save As. Navigate to the ae08lessons folder and save the fi le as 
Understanding Rack Focus_Working.aep. 

2 With the Composition panel highlighted, create a new camera by choosing Layer > 
New > Camera to open the Camera Settings dialog box.
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3 From the Preset drop-down menu, choose 50mm. Click the switch to Enable Depth 
of Field and then disable the Lock to Zoom option. Click OK.

You can use the camera presets to quickly create new cameras.

4 When a camera layer is fi rst created, it is often diffi  cult to see its position in relation to 
the other layers in your composition. This can be fi xed by zooming and panning the 
views in the Composition panel. Click in the left viewport, the one labeled Top, and 
change the Magnifi cation to 50 percent. Press and hold the spacebar to activate the 
Hand tool ( ). Use it to pan the viewport until you can see the camera body as well as 
its cone. You may need to use a diff erent magnifi cation value depending upon the size 
and resolution of your monitor.

An Orthographic view such as Top 
is very helpful when trying to animate 
objects moving along the Z-axis.
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5 In the Timeline panel, select the new camera layer and press Ctrl+ ~ (Windows/
Mac OS) to reveal its properties. The Focus Distance property should already be set to 
909.1, which places it in the middle of the composition, exactly at the 0 Z position. 

If it is enabled, click the Auto-Keyframe Timeline switch to turn it off . Then change 
the Aperture property to 150 and the Blur Level to 200. The text This is remains 
clear, but the rest becomes blurry. 

At this point, your settings should match those shown here.

6 Move the playhead to the 1 second (0;00;01;00) mark. Click the Time-Vary Stopwatch 
icon ( ) next to the Focus Distance property to enable its animation.
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7 Move the playhead to the 2 second (0;00;02;00) mark. Change the Focus Distance 
property to 1144. The word Rack is now in focus. 

As the Focus Distance changes, diff erent layers move in and out of focus.

8 To hold the word Rack in focus for a time, you will create a second keyframe as a 
placeholder. Move the playhead to the 3 second (0;00;03;00) mark. Click on the Add 
or Remove Keyframe icon ( ) to the left of the Focus Distance property to create a 
new keyframe to act as a placeholder. 

9 Move the playhead to the 4 second (0;00;04;00) mark. Change the Focus Distance 
property to 670. This completes the animation. 

To enhance the blur eff ect, try raising the Aperture and/or Blur Level values.

10 Save your fi le by choosing File > Save or by clicking Ctrl+S (Windows) or 
Command+S (Mac OS) on the keyboard.
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Working with After Effects 3D Layers
The Ray-traced renderer available in After Eff ects CS6 allows for a variety of enhanced 
3D functions, including the ability to create beveled and extruded text and shape layers, 
as well as enhanced material options such as refl ections. This functionality allows you 
to completely create three-dimensional objects that react to lights and cameras in After 
Eff ects without the need for third-party plug-ins. 

Creating a Ray-traced composition
The type of renderer you choose is a composition level setting that will aff ect every 3D 
layer inside that composition. Ray-tracing creates a more accurate interpretation of how 
light aff ects three-dimensional objects and allows for superior rendering over the default 
Classic 3D renderer. Even though Ray-tracing is superior, it has drawbacks that prevent 
you from using it all the time. For example, Ray-tracing tends to use more memory than 
Classic 3D; also, certain eff ects, such as masks, track mattes, and eff ects are disabled.

In this part of the lesson, you will convert a Classic 3D composition into a Ray-traced 
composition. 

1 Choose File > Open Project. Navigate to the ae08lessons folder and open Working 
with After Eff ects 3D.aep. This project contains a single composition called Comic 
Book Novice. Inside this comp are four text layers, a solid layer to form the fl oor or 
ground plane, and a light and camera layer. 

Scrub the playhead; the camera is animated to move across the scene. 

Classic 3D Compositions can be easily converted into Ray-traced Compositions
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2 Choose File > Save As; in the Save As dialog box that appears, navigate to the 
ae08lessons folder. Rename the fi le Working with After Eff ects 3D-working.aep, and 
then click the button labeled Save.

3 With the Timeline panel highlighted, choose Composition > Composition Settings to 
open the Composition Settings dialog box.

4 In the dialog box, click the Advanced Tab; from the Renderer drop-down menu, 
choose Ray-traced 3D. 

Click OK to close the dialog box.

An alert box appears informing you of the features that the Ray-traced 3D render 
enables along with the features that are disabled as a result of using it. Click OK to 
close the Alert box.

Depending on your system confi guration settings, a Composition to the Ray-traced 3D renderer 
might signifi cantly increase the time it takes to preview the Composition panel.

5 Click the Fast Previews button ( ) located at the bottom of the Composition panel 
and choose Draft from the menu that appears. The Draft setting is only available when 
working with Ray-traced 3D Composition. It is a good way to speed up previews, as 
it lowers the visual quality of the preview, but still retains features such as bevels and 
extrusions.

6 Disable the visibility of the layers numbered 3-5, the ones called THE, COMIC, 
and BOOK, leaving only the layer called NOVICE visible. Disabling the visibility of 
layers that you are not currently working on can speed up Composition previews.

7 Save your fi le by choosing File > Save or by pressing Ctrl+S (Windows) or 
Command+S (Mac OS) on the keyboard. Do not close this fi le; you will need it in the 
next part of the lesson.

In the next part of this lesson, you will change the appearance of the text layer to 
convert it into a 3D object.

Extruding and Beveling Text
If you have used graphics applications such as Adobe Photoshop or Illustrator, you might 
be familiar with the idea of extruding and beveling text. When you extrude a text layer, 
you give it form and depth, turning a fl at piece of text into a fully three-dimensional 
object. Text layers in Ray-traced 3D Compositions can also have beveled edges applied to 
them to give a more decorative, appealing eff ect.

1 With Working with After Eff ects 3D-working.aep still open, move the playhead to 
the beginning of the Timeline (0;00;00;00), if necessary.
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2 Click layer number 6, the one called NOVICE, to highlight it, and then press the A 
key on your keyboard twice in quick succession. This reveals the Material Options for 
this layer.

3D layers in Ray-traced Compositions have additional material options.

You can also reveal a layer’s Material Options by clicking the reveal triangle to the left of the 
Layer Name.

3 In the Geometry Options property group, change the Bevel Style to Concave and the 
Extrusion Depth to 25.

3D layers in Ray-traced Compositions have additional material options.
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4 In the Material Options property group, change the Cast Shadows property to On, 
change the Specular Intensity property to 100%, and the Refl ection Intensity to 10%. 

The Specular Intensity controls the brightness of the layer’s highlights and the 
Refl ection Intensity controls the strength of the refl ections that appear on this layer. 
The results of enabling the layer to cast shadows will not be visible until you enable 
the light to cast shadows, which you will do now.

5 With the NOVICE layer still selected, press Ctrl+~ (Windows & MacOS) on your 
keyboard to collapse all the selected layer’s visible properties.

6 Click the Light 1 layer to highlight it, and then press the A key on your keyboard 
twice in quick succession to reveal the layer’s Light Options.

Set the Light’s Cast Shadows property to On, and then change the Shadow Darkness 
property to 60%.

At this point, the preview will re-render; you should be able to see the NOVICE cast 
a shadow onto the Floor layer.

The display of shadows must be set to On for the light and all the layers that will cast shadows.

7 With the Light 1 layer still selected, press Ctrl+~ (Windows & MacOS) on your 
keyboard to collapse all the selected layer’s visible properties.

8 Save your fi le by choosing File > Save or by pressing Ctrl+S (Windows) or 
Command+S (Mac OS) on the keyboard.

Do not close this fi le; you will need it in the next part of the lesson.

AECS6_06Pass.indb   283AECS6_06Pass.indb   283 5/18/12   1:07 PM5/18/12   1:07 PM



8 Working with After Eff ects 3D Layers

Adobe After Eff ects CS6 Digital Classroom284

Creating Reflections
A very powerful and visually appealing feature made possible by the Ray-traced 3D 
renderer is the ability to make 3D layers refl ective, thus allowing light from these layers 
to interact with other elements in your 3D scene. By default, all 3D layers in a Ray-
traced Composition have their “Appear in Refl ections” property enabled, but you must 
individually set the intensity with which each layer receives refl ections.

1 With Working with After Eff ects 3D-working.aep still open, move the playhead to 
the beginning of the Timeline (0;00;00;00) if necessary.

2 In the Timeline panel, click layer number 7, the one called FLOOR, to highlight 
it, and then press A on your keyboard twice in quick succession to reveal this layer’s 
Material Options. 

3 Change the fl oor layer’s Refl ection Intensity property to 40%. You will now be able 
to see the word NOVICE refl ected on the fl oor.

Adding Refl ections to objects in a 3D scene can enhance the sense of realism.

4 With the fl oor layer still selected, press Ctrl+~ (Windows & MacOS) on your 
keyboard to collapse all the selected layer’s visible properties.
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5 Turn the visibility for layers 3, 4, and 5 back on; for each layer, set the following 
Material Options:

BEVEL STYLE CONCAVE

Extrusion Depth 25

Cast Shadows On

Specular Intensity 100% 

Reflection Intensity 10% 

6 Click the Fast Previews button ( ) located at the bottom of the Composition panel 
and choose Adaptive Resolution.

RAM Preview the animation to see the fi nal result of your changes. Because Ray-
tracing is an intensive process, this preview might take some time to build.

7 Save your fi le by choosing File > Save or by pressing Ctrl+S (Windows) or 
Command+S (Mac OS) on the keyboard.

You may now close this fi le; you have completed the lesson.
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Self study
Create your own 3D scene in After Eff ects and animate the camera’s position to make it 
move through and around the layers in your composition. 

Enable a camera’s Depth of Field property and animate its properties to create a scene that 
has a varying depth-of-fi eld eff ect.

Review
Questions
1 Once a layer’s 3D switch is enabled, what are the four properties it gains for rotation?

2 Which three properties aff ect the strength of a camera’s depth of fi eld?

3 When working in a Ray-traced 3D Composition, all 3D layers are set to appear 
in Refl ections automatically. What property must you set on a layer to control the 
strength with which refl ections appear on it?

Answers
1 X Rotation, Y Rotation, Z Rotation, and Orientation. Each of the rotation properties 

allows you to isolate the property along a single axis, while the Orientation property 
creates a single keyframe for all three rotational axes.

2 Focus Distance, Aperture, and Blur Level are the three properties that aff ect depth 
of fi eld. 

Focus Distance specifi es the distance from the camera lens at which a layer would be 
perfectly in focus. You can manipulate the Focus Distance value to produce depth-of-
fi eld eff ects like those seen in standard photography and fi lms.

Aperture specifi es the size of the opening in a camera lens, and aff ects the camera’s 
depth of fi eld. Smaller Aperture settings decrease the blur produced by depth of fi eld, 
while larger settings increase it. 

Blur Level specifi es the amount of blur produced by a camera’s depth-of-fi eld eff ect.

3 To control the strength of refl ections on a 3D layer in a Ray-traced 3D Composition, 
you must adjust the layer’s Refl ection Intensity property.
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What you’ll learn in 
this lesson:
• Animating with Eff ects

• Applying and Modifying 
Eff ects Presets

• Saving your own Presets

Lesson 9

The animation you have created so far is just the tip of the 
proverbial iceberg. In addition to animating the native properties 
of layers, you can add additional properties and complexity to any 
animation by adding and animating eff ects, and when you want 
even more control of your animation, you can use tools such as 
Smoother, Wiggler, and the Graph Editor to enhance your work. 

Starting up
You will work with several fi les from the ae09lessons folder in this lesson. Make sure that 
you have loaded the aelessons folder onto your hard drive from the supplied DVD. See 
“Loading lesson fi les” in the Starting up section of this book.

See Lesson 9 in action!

Use the accompanying video to gain a better understanding of how to use some of the features 
shown in this lesson. The video tutorial for this lesson can be found on the included DVD.

9

Advanced Animation
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Setting up
As you work in After Eff ects you will inevitably open and close many panels, depending 
on the type of project you are creating. However, when working through the projects in 
this book, it is important to have an interface that matches the lessons. To this end, you 
should always reset your workspace to the preset Standard confi guration.

1 Choose Window > Workspace > Standard to set your current workspace confi guration.

2 Choose Window > Workspace > Reset “Standard” to reset the standard workspace in 
case you have modifi ed it at some point. 

Animating with effects 
There is a reason this program is called After Eff ects. In fact, the number of built-in eff ects 
that can be animated is something that new users often fi nd surprising and perhaps a little 
intimidating. Unlike other programs you may be familiar with, this is not a heavily tool-
based application, but it is very reliant on manipulating the properties of these eff ects. In 
order to create compelling motion graphics, you need to become comfortable working 
with the wide range of built-in eff ects plug-ins that are available to you.

In this lesson, you will animate a layer so that it explodes and blows away like stardust. 
The project contains a text layer that has been converted to shapes using the Layer > 
Create Shapes from Text command. This converts a text layer into a vector shape layer; 
it isn’t necessary to do this for the eff ects to work but it is useful in a situation like this 
when you must give a fi le to someone who may not have the same fonts installed on their 
computer as you do.

Applying effects to layers
The Eff ects & Presets panel is a library of accessible eff ects in the application. Eff ects are 
similar to fi lters in Adobe Photoshop because they allow you to apply special eff ects such 
as glows and blurs or add noise or color-correct a layer. 

In this section of the lesson, you will apply an eff ect to an existing layer and edit some of 
the default properties of the eff ect. 

Depending on the speed of your computer, previews of the Shatter eff ect can take a considerable 
amount of time. If you experience a delay while waiting for individual frames to preview when 
moving the playhead around the Timeline, you may want to change the Resolution/Down 
Sample factor to Half or Quarter speed. This will accelerate the previewing process.
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1 Choose File > Open Project and navigate to the ae09lessons folder. Locate the project 
named Animating with Eff ects.aep and double-click it to open the fi le.

2 In the Eff ects & Presets panel, type shatter into the search fi eld. When the Shatter 
eff ect appears, drag it onto the layer named Up Next in the Timeline. The Shatter 
eff ect is a great one to use when you want to explode a layer. It can simulate a wide 
range of common shatter patterns such as glass or bricks, and with a few adjustments it 
can produce a variety of diff erent looks. 

As a result of applying the eff ect, the Eff ect Controls panel appears and the entire layer 
enters a wireframe display mode. The rendered Shatter eff ect requires a great deal 
of processing power to preview on the Timeline, and as a result, it is set to use the 
wireframe display mode as a default view setting.

In order to speed up the preview, the Shatter eff ect has a default display mode that only displays a wireframe view of the layer.

3 Move the playhead to the 5 frame (0;00;00;05) mark on the Timeline and in the Eff ect 
Controls panel, change the view property pull-down menu to Rendered; this returns 
the layer’s appearance to normal.
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4 The default settings of the Shatter eff ect resemble bricks that fall toward the bottom of 
the screen. The fi rst thing you must do is to modify the eff ect’s properties so that the 
layer will look more like particles of dust or sand and fl y off  the side of the screen.

In the Eff ect Controls panel, click on the reveal triangle to the left of the Shape 
property group and adjust the settings as follows:

PROPERTY VALUE

Pattern Eggs

Repetitions 200

Direction 0x+0.0°

Extrusion Depth 0.0

The Shatter eff ect will automatically animate, so positioning the playhead at frame 5 allows you to see 
the eff ect of your adjustments. 

These settings will produce particles that look more like sand.
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5 Click on the reveal triangle to the left of the Force 1 and Force 2 property groups and 
adjust their settings to match those below:

FORCE 1 FORCE 2

PROPERTY VALUE PROPERTY VALUE

Position 176, 234 Position 743, 247

Depth 0.0 Depth 0.0

Radius 0.0 Radius 0.0

Strength 3.75 Strength 0.0

When you select the shape layer, a blue outline appears around the text, but when you deselect the layer, the blue outline 
vanishes.

These settings, specifi cally the ones for Force 1, will return the layer to the appearance 
it had before the eff ect was applied. Later in the lesson you will animate this property 
group to blow the text away.
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6 Click on the reveal triangle to the left of the Physics property group and adjust its 
settings to match the ones below:

PROPERTY VALUE

Rotation Speed 0.20

Tumble Axis Free

Randomness 0.10

Viscosity 0.00

Mass Variance 30%

Gravity 0.00

Gravity Direction 0 x +90.0º

Gravity Inclination 0.00

The adjustments to the Physics property group do not produce a noticeable change 
at this time but they are used to control the force of gravity, which will control the 
direction of movement of the particles created by the eff ect, once you animate the 
Force 1 property group.

In the next part of the lesson you will animate the properties of the Eff ect you have 
just applied.

7 Choose File > Save As and navigate to the ae09lessons folder. Rename the project 
Animating with Eff ects-working.aep and click the Save button. Do not close this 
fi le; you will need it in the next part of this lesson.

Animating effect properties
Many novice After Eff ects users are surprised by the sheer number of animatable eff ects 
they have access to. Nearly every property of every eff ect can be keyframed, even switches 
and pull-down menus. In this section of the lesson, you will animate the properties of the 
Shatter eff ect to blow away the text.

Up until this point, your preview and the speed at which the composition panel refreshes when 
you move around the timeline have probably been pretty smooth. When animating properties, 
you may experience longer delays while the application builds a preview for you. This is due to 
both the speed of your computer and the power needed to build and preview some eff ects. 

1 With the Animating with Eff ects-working.aep fi le open, move the playhead to the 
beginning (0;00;00;00) of the Timeline. 
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2 In the Eff ect Controls panel, locate the Force 1 property group and click the time-
vary stopwatch for the Radius property. This enables animation for this property and 
sets the fi rst keyframe at the beginning of the Timeline for the current values.

If the Eff ect Controls panel is not open already, you can choose Window > Eff ect Controls to 
reveal it.

3 Move the playhead to the 3 second (0;00;03;00) mark of the Timeline. With the Up 
Next layer selected, press the U key on the keyboard to reveal all animated properties 
on this layer. In the Eff ect Controls panel, change the Radius property of Force 1 to 
5.00.

Because you have revealed the Radius property on the Timeline, you can also change the property 
value there if you prefer.

4 Move the playhead to the 4 second (0;00;04;00) mark on the Timeline and press the 
N key on your keyboard. This moves the end of the work area bar to the current 
position of the playhead. Depending upon the speed of your computer, this could take 
a moment.

RAM preview the animation. When the last keyframe of the animation is located at 4 
seconds (0;00;04;00) on the Timeline, this signals the end of the animation, the point 
at which the layer has been completely removed from the screen.

You can move the beginning and end of the work area bar either with the cursor by clicking and 
dragging the end markers or by using the keyboard. Pressing the B key on the keyboard moves 
the beginning of the work area bar to the current position of the playhead, while pressing the 
N key on the keyboard moves the end of the bar to the playhead’s current position. 
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5 The text blows away as the Radius of Force 1 increases, but you can enhance the eff ect 
and make it more dynamic by animating the Camera Position property group as well.

From the Resolution/Down Sample Factor Pop-up menu at the bottom of the 
Composition panel, choose Quarter. This reduces the quality of the panel’s preview by 
rendering only every fourth pixel, but it also produces faster previews. 

Press the J key on the keyboard until the playhead is at the position of the fi rst Radius 
keyframe.

If you experience a delay while the Composition panel preview renders, you may want to press 
the Caps Lock key on the keyboard. This disables the preview and prevents it from refreshing, 
allowing you to move around the Timeline and edit properties. You have to press the Caps Lock 
key again to turn it off  and re-enable screen refreshing.

6 In the Eff ect Controls panel, locate the Camera Position property group and confi rm 
that the Y Rotation property is set to 0 x 0.0º. Then click this property’s Time-Vary 
Stopwatch ( ) to create a keyframe and enable animation.

7 Press the K key on the keyboard to move the playhead to the position of the second 
Radius keyframe and change the Y Rotation property to 0 x 80.0º. 

Press the U key on the keyboard to hide the layer’s properties, and then press it again 
to reveal both Radius and Y Rotation. RAM preview the animation.

If properties are visible on the Timeline, pressing the U key on the keyboard hides them, and pressing 
it again reveals only the currently animated properties.

If you press the U key too quickly it will actually reveal the content of the shape layer rather than 
the layer’s animated properties.

8 If it is not already there, move the playhead to the beginning (0;00;00;00) of the Timeline 
and in the Composition panel, change the Resolution/Down Sample Factor Pop-up 
menu to Auto. In the Eff ect Controls panel, click the reveal triangle next to Shatter to 
hide its properties. In the Eff ects & Presets panel, type glow into the search fi eld. When 
it appears, drag the Glow eff ect onto the Up Next layer in the Timeline panel.
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9 You use the Glow eff ect to make layers appear as if they are illuminated by an internal 
light, and when you combine it with the Shatter eff ect used here, it is applied to each 
shattered piece separately. In the Eff ect Controls panel, set the Glow eff ects properties 
to the following values:

PROPERTY VALUE PROPERTY VALUE

Glow Based On Color Channels Glow Color A & B Colors

Glow Threshold 25.0% Color Looping Triangle A>B>A

Glow Radius 10.0 Color Loops 1.0

Glow Intensity 2.0 Color Phase 0 x 0.0º

Composite 
Original

Behind A & B Midpoint 50%

Glow Operation Add Glow Dimensions Horizontal and 
Vertical

Click on the color box for the Color A property and in the Color A dialog box that 
appears, change the hexadecimal value to FFA200 and then Click OK to close the 
dialog. This changes Color A to a light orange.

You can enter colors numerically in After Eff ects using 
HSB, RGB, or hexadecimal values.

Click on the color box for the Color B property and in the Color B dialog box, 
change the hexadecimal value to FFFF00 and then click OK to close the dialog. This 
changes Color B to a very bright yellow color.

RAM preview the animation. You may need to change the Resolution/Down Sample 
Factor Pop-up menu (located at the bottom of the Composition panel) to Half, Third, 
or Quarter to speed up your rendering time. 

AECS6_06Pass.indb   295AECS6_06Pass.indb   295 5/18/12   1:07 PM5/18/12   1:07 PM



9 Animating eff ect properties

Adobe After Eff ects CS6 Digital Classroom296

As you can see, the Glow eff ect adds a sparkle to the animation and really makes it 
appear more vibrant.

If you are not familiar with them, hexadecimal values are a way of describing any RGB color. 
While very popular for the Web and in programming environments, hex code (as it is often 
called) can actually be used in a variety of diff erent applications, such as Adobe Photoshop and 
Illustrator, to denote RGB colors.

10 One last eff ect to add a greater sense of movement and depth to the animation, and 
it will be complete. Move the playhead to the 15 frame (0;00;00;15) mark on the 
Timeline. In the Eff ect Controls panel, click the reveal triangle next to Glow eff ect 
to hide its properties. In the Eff ects & Presets panel, type the word fast into the 
search fi eld. When it appears, drag the Fast Blur eff ect onto the Up Next layer in the 
Timeline panel.

11 In the Eff ect Controls panel, click the Time-Vary Stopwatch ( ) next to the 
Blurriness property of the Fast Blur eff ect to create a keyframe for this property.

12 With the Up Next layer in the timeline highlighted, press the letter K on the 
keyboard to move the playhead to the next visible keyframe at 3 seconds (00;00;03;00) 
on the Timeline. Again in the Eff ects Controls panel, change the value of the 
Blurriness property to 10.0. RAM preview the animation. As you can see, the text 
now starts the animation completely sharp and becomes progressively more blurry 
over time.

13 Choose File > Save to save these changes to your After Eff ects project. Do not close 
the fi le, as you will need it again in the next part of the lesson.

Saving animation presets 
There are a wide variety of presets that are shipped with the application and are intended 
to make using and learning eff ects easier. Originally called favorite eff ects, presets are 
stored groupings of eff ects with their settings and keyframes intact. They are fully editable, 
and you can apply them to a layer and customize them to fi t the needs of your animation. 
You aren’t limited to just using the animation presets that ship with After Eff ects. You can, 
of course, also create your own. This makes it very easy to reuse favorite eff ects that you 
have taken the time and eff ort to develop. In addition to the eff ects and their properties, 
the preset also includes any keyframes and expressions that you may have created.

1 With the Animating with Eff ects-working.aep fi le open, move the playhead to the 
beginning (0;00;00;00) of the Timeline. 

2 In the Eff ect Controls panel, click on the Shatter eff ect to select it. Press and hold the 
Shift key on your keyboard and click on the Glow and Fast Blur eff ects to select them 
as well.

3 With all three eff ects selected, choose Animation > Save Animation Preset.
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4 In the Save Animation Preset As dialog box, change the default name to Exploding 
Stardust. Confi rm that the Save As location is set to the default User Presets folder 
and click the Save button. You can now access this new animation preset at anytime in 
the Eff ects & Presets panel. It will be located in the User Presets group, which can be 
found inside the Animation Presets group (Animation Presets > User Presets).

5 Choose File > Save to save these changes to your After Eff ects project. You may now 
close this project, as you are fi nished with it.

Applying and modifying effects presets 
Presets themselves are a great feature of the After Eff ects application,. They provide you 
with a place to start your animations, but the weakness of relying too much on presets is 
that everyone else who buys the program has access to the exact same ones that you do. In 
order to create greater variety in your animation, you will inevitably want to customize 
the existing presets by editing the Eff ects properties. This is where the true strength of the 
preset model lies. Since none of the eff ects used to create your presets are pre-rendered, 
they are completely editable and animatable. While you may start with a preset from 
the library or one you created, you can quickly change it by adding additional eff ects or 
modifying property values.

In this part of the lesson, you will apply the Exploding Stardust preset that you just created 
to a composition in another project and modify its settings. In this project you will work 
with an animated logo; the goal is to have the logo materialize from a hail of stardust.

Depending on the speed of your computer, rendering even single–frame previews of the Shatter 
eff ect can take considerable time. If you experience a delay while waiting for individual frames 
to preview when moving the playhead around the Timeline, you may want to change the 
Resolution/Down Sample factor to Half or Quarter to speed up the process.

1 Choose File > Open Project and navigate to the ae09lessons folder. Locate the project 
named Bad Robot Animated Logo.aep and double-click it to open the fi le. Scrub the 
playhead to preview the Animated Logo composition.

This project contains two compositions: Bad Robot and Animated Logo. The Bad 
Robot comp contains the animation of the two halves of the robot head separating 
and revealing the logo; it is nested inside the Animated Logo composition. 

In Animated Logo, there is a marker on the Bad Robot Comp layer at the 4 second 
(0;00;04;00) mark that reads “Animation Starts Here.” Markers that are placed inside 
compositions are visible when they are nested and are helpful tools for synchronizing animations. 
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2 Hold down the Shift key on your keyboard and drag the playhead to the marker 
on the Bad Robot Composition layer until it snaps into position at the 4 second 
(0;00;04;00) mark on the Timeline.

The easiest way to apply an eff ect or preset to only part of the duration of a layer is to 
split it to produce two separate layers and then apply diff erent eff ects to each layer.

3 With the Bad Robot composition layer selected, choose Edit > Split Layer. The top 
layer is still selected after you split the layer. Press the Return (Mac OS) or Enter 
(Windows) key on the keyboard to make the layer name editable and rename it Bad 
Robot-Animation.

Click on the lower layer, the one still named [Bad Robot], press the Return (Mac OS) 
or Enter (Windows) key on the keyboard to make the layer name editable, and rename 
it Bad Robot-Stardust Eff ect.

The Split Layer command actually creates two exact copies of the layer and trims the in and out points of each copy 
to adjust their lengths.

4 Move the playhead to the beginning (0;00;00;00) of the Timeline and in the Eff ects & 
Presets panel, type stardust into the search fi eld.

When it appears, drag the Exploding Stardust preset onto the Bad Robot-Stardust 
Eff ect layer in the Timeline panel.

It is very important that you know where the playhead is before you apply any saved animation 
presets. Any keyframes that are saved with the animation preset are added to the Timeline; the 
fi rst keyframe in the preset is placed at the current position of the playhead, and any others are 
placed relative to that keyframe to maintain the timing of the overall animation.

RAM preview the animation. Notice that the glow eff ect isn’t working; this is 
because the eff ect’s settings need to be adjusted for the fact that this layer’s artwork is 
black while the original one that it was created for was white.
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5 Make sure the Bad Robot-Stardust Eff ect layer is selected and in the Eff ect Controls 
panel, locate the Glow eff ect. Change the Glow Based On property to Alpha 
Channel. This will allow it to create a glow around the opaque areas of the layer. The 
problem now is that the eff ect is very overpowering; to correct this, change the Glow 
Operation property to Normal.

The fi rst image is from the beginning (0;00;00;00) of the Timeline; the second is from 1 second (0;00;01;00).

6 RAM preview the animation. 

Choose File > Save As and navigate to the ae09lessons folder. Rename the project 
Bad Robot Animated Logo-working.aep and click Save. 

Do not close this fi le. You will need it in the next part of this lesson where you will 
change the layer’s property so that it plays from the end to the beginning and gives the 
impression that the layer is being created from stardust.

Time-reversing a layer
In real life, time fl ows in a straight line from beginning to end, but with After Eff ects you 
are not constrained to this linear approach. Using the variety of advanced time remapping 
features built into the program, you can reverse, speed up, slow down, and pause video 
footage to fi t your project’s needs.

Depending on the speed of your computer rendering even single frames, previews of the Shatter 
eff ect can take considerable time. If you experience a delay while waiting for individual frames 
to preview when moving the playhead around the Timeline, you may want to change the 
Resolution/Down Sample factor to Half or Quarter to speed up the process.

1 With the Bad Robot Animated Logo-working.aep fi le still open, click on the Bad 
Robot-Stardust Eff ect layer to select it. 
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2 Choose Layer > Time > Time-Reverse Layer. This swaps the layer’s In and Out 
points and allows it to play from beginning to end. 

You can achieve the same eff ect from the In/Out/Duration/Stretch pane by setting the layer’s 
Stretch percentage to -100 percent.

3 You may not have noticed it before you time-reversed the layer, but the position of 
the robot graphic changes from one layer to the next. This distortion is caused by the 
application of the Shatter eff ect. You can easily compensate for this by changing the 
position of the Bad Robot-Stardust Eff ect layer.

With the Bad Robot-Stardust Eff ect layer selected, press the P key on the keyboard 
to reveal the Position property. Change the value for Position to 396.0, 240.0. This 
corrects the distortion.

4 Because the Bad Robot-Animation layer does not have a glow eff ect on it, there is a 
slight disorienting jump when the layers switch. Animating the Glow property will 
correct this and help to create a more seamless changeover. With the Bad Robot-
Stardust Eff ect selected, press the letter E on your keyboard. This reveals the layer’s 
eff ects in the Timeline panel.

5 Move the playhead to the 3 second (0;00;03;00) mark on the Timeline and click the 
reveal triangle for the Glow eff ect in the Timeline panel to show all its properties.

Click the time-vary stopwatch for the Glow Intensity property to enable animation 
and create a keyframe for the current value of 2.0.

6 Move the playhead to the 4 second (0;00;04;00) mark on the Timeline and change the 
value of the Glow Intensity property to 0.0.

7 RAM preview the animation; it should now appear to have a more seamless blend 
from one layer to the next.

Choose File > Save to save these changes to your After Eff ects project. You may now 
close this project, as you are fi nished with it.

Using the Motion Sketch panel to capture motion
Some artists fi nd working with positional keyframes in After Eff ects to be tedious and non-
intuitive. And truthfully, dragging objects around the screen or changing property values 
in the Timeline panel is a foreign concept to most people. To off er another and perhaps 
more intuitive solution to animation, After Eff ects has the Motion Sketch feature. Motion 
Sketch allows the animator to draw motion paths onscreen and apply them to objects in the 
Timeline. It can be a quick and easy way to create organic, free-fl owing movement.

In this part of the lesson, you will work with a pre-assembled project that contains footage 
created in Adobe Photoshop and Illustrator. You will use the Smoother and Wiggler 
panels to add animation to the layers and create both smooth and frenetic movements that 
complement one another.
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1 Choose File > Open Project and navigate to the ae09lessons folder. Locate the project 
named Empire of the Ants.aep and double-click it to open the fi le.

2 Move the playhead to the beginning (0;00;00;00) of the Timeline and click on the 
fi rst layer, the one named ant. This layer is a nested composition; the ant graphic was 
created in Illustrator and the legs have been animated here in After Eff ects.

Press the P key on the keyboard to reveal the Position property of the layer and 
change its values to -95.0, 530. This places the layer outside of the lower-left corner of 
the composition.

When you move a layer outside the composition’s border, it displays in wireframe mode and remains editable.

3 Choose Window > Motion Sketch to reveal the Motion Sketch panel. It opens in the 
lower-right corner of the Standard workspace. 

Motion Sketch: Allows you to draw motion onscreen; the panel contains options to 
make this easier as well as to begin the capture process. There are fi ve properties in the 
panel:

Capture Speed At: Sets the ratio of the speed that motion is recorded at (eff ectively 
the speed the cursor is moving on the screen) to the speed that it plays back at. A value 
of 100 percent means that the motion plays back at the same speed it was recorded at; a 
value lower than 100 percent plays back faster; and values above 100 percent play back 
more slowly.

Smoothing: Smoothes the path of motion by removing extraneous keyframes. 
Higher values produce a smoother motion path.
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Show: The Wireframe switch shows a wireframe view of the layer onscreen as you 
are capturing motion, while the Background switch shows a static image of the frame 
where you started capturing motion.

Start: Displays the timecode where the Motion Sketch operation will begin 
capturing. The Start value corresponds to the start marker of the work area bar.

Duration: Specifi es the overall duration of the capture operation. 

4 If necessary, adjust the settings of the Motion Sketch dialog box to match the 
properties below:

PROPERTY VALUE PROPERTY VALUE

Capture speed at 100.00% Show Background Checked

Smoothing 1 Start 0;00;00;00

Show Wireframe Unchecked Duration 0;00;10;00

Click the Start Capture button at the bottom of the panel.

5 Place your cursor, which now resembles a cross-hair, near the anchor point of the ant 
layer. Click and drag the cursor across the screen toward the upper-right corner, and 
then loop around as if making a large fi gure eight. When fi nished, you should have a 
path similar to the one in the fi gure below.

Motion Sketch is intended to create unique motion paths so there is no way to capture the exact same path twice.
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6 As you draw the layer’s motion path onscreen, Motion Sketch adds keyframes to the 
Position property. You may have a very diff erent total number of keyframes and diff erent 
animation duration than the fi gure below. The number of keyframes and duration of the 
animation are dependent on how long it took you to draw the motion path. 

Drawing motion paths with the Motion Sketch feature creates unique paths that are nearly impossible to replicate.

RAM preview the animation. The two factors that are taken into account when 
motion is captured are the position of the mouse and the speed at which it moves. 
You will notice that the ant moves more slowly in certain points than in others; this is 
due to how quickly you may have moved the mouse onscreen. The motion is a little 
jagged and rough, and the ant doesn’t actually look like it is following the motion 
path; you will correct this later in the lesson.

7 Choose File > Save As and navigate to the ae09lessons folder. Rename the project 
Empire of the Ants-working.aep and click the Save button. Do not close this fi le, 
as you will need it in the next part of this lesson.

Controlling layer orientation
As you preview the animation created in the previous exercise, you will notice that while 
the ant layer moves across the screen, it continues to face toward the top of the screen. 
This makes the movement seem unnatural. In reality, an ant, or an airplane, or any 
moving object must face the direction it is traveling.

All layers have a property named Auto-Orient but by default, footage layers are set to auto-
orient toward nothing. This is usually a benefi t as it allows the animator to freely rotate the 
layer as needed, but here this same setting makes the animation seem strange. To correct 
this, you will change the layer’s Auto-Orient setting so that it follows its motion path.

1 With the Empire of the Ants-working project still open, move the playhead until you 
can see the ant graphic appear on your screen. Notice that the ant layer is pointing 
straight up toward the top of the composition. You must adjust this to add a sense of 
realistic movement to the animation.

2 With the ant layer highlighted, hold down the Shift key and press the R key on your 
keyboard so that the Rotation property displays along with the Position property. 
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Place your cursor over the property value and use the text slider to change the layer’s 
rotation until the ant faces toward the motion path. In the image below, the value used 
is 0x +96.0 but your specifi c value will diff er, as your direction path may vary. 

Positive values produce clockwise rotation, while negative 
values produce counter-clockwise rotation.

3 With the ant layer still selected, choose Layer > Transform > Auto-Orient to open the 
Auto Orient dialog box. Click the radio button next to Orient Along Path to enable 
this option, and click the OK button.

4 RAM preview the animation. Notice that the ant now seems to be following the 
motion path. Choose File > Save to save these changes to your After Eff ects project. 
Do not close this fi le, as you will need it in the next part of this lesson.

Using the Smoother panel to soften movement
The Smoother panel is used to modify the keyframes in an animation to make it appear 
smoother and more fl owing. It does this by removing extraneous keyframes based on 
values that you set. When combined with the Motion Sketch feature, it can help produce 
a less jagged motion path. In this part of the lesson, you will use the Smoother panel to 
soften the ant’s motion path.

1 With the Empire of the Ants-working project still open, scrub the playhead back and 
forth. Pay attention to the movement of the ant; notice that the movement seems 
jagged and perhaps a little wobbly. You can correct the motion path by using the 
Smoother panel to reduce the number of keyframes.

2 Choose Window > Workspace > Animation to switch to a workspace designed to aid in 
animation tasks. If you have amended the default animation workspace, choose Window 
> Workspace > Reset “Animation” to return it to its default appearance. Notice that in 
this workspace the Smoother panel is to the right of the Composition panel.

When resetting a workspace to its default confi guration, a dialog box appears, asking if you are 
sure that you want to reset. You have to confi rm that you are by clicking the Yes button to proceed.
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The Smoother panel only has two options: Apply To and Tolerance. The Apply To 
pull-down menu allows you to choose between applying the smoothing result to 
either a spatial or temporal path. Because you are dealing with the Position property in 
this lesson, you can only aff ect the spatial path.

You can use the Tolerance property to control the strength of the eff ect. Higher values 
produce a more noticeable smoothing result but may remove more detail than you want.

3 In the Timeline panel, click on the ant layer’s Position property. If this property is not 
visible, you can press the P key on your keyboard while the layer is highlighted to reveal 
it. Clicking any property name selects all the keyframes belonging to that property. In 
order to use the Smoother panel, you must select a minimum of three keyframes.

Clicking any property name selects all its keyframes simultaneously.

4 In the Smoother panel, set the Tolerance property to 8 and click the Apply button to 
produce a smoother path. 

The specifi c path that you create will vary, depending on your smooth settings and the initial path you start with.
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5 RAM preview the animation. Choose File > Save to save these changes to your After 
Eff ects project. Do not close this fi le, as you will need it in the next part of this lesson.

Using the Wiggler panel to add frantic motion
The Wiggler panel is the mirror opposite of Smoother. They both operate on the 
keyframes of an animation but instead of reducing keyframes, the Wiggler eff ect adds 
them. Wiggler is a great tool when you want to add random, frenetic movement to an 
animation without having to manually add extra keyframes. 

In this exercise, you will use the Wiggler panel to add randomness to the Position property 
and apply a more frenetic sense of movement to the logo animation of Empire of the 
Ants. The logo animation that you have seen while previewing this project is inside of 
the Empire of the Ants comp. It is caused by keyframes and an expression on the layers 
named EMPIRE and ANTS. The up-and-down movement is caused by a series of three 
keyframes each: one at the beginning of the Timeline (0;00;00;00), another at 15 frames 
(0;00;00;15), and the fi nal one at 1 second (0;00;01;00). 

1 With the Empire of the Ants-working project still open and the Empire Promo 
composition active, double-click on the Empire of the Ants composition in the Project 
panel to open it. 

2 Now in the Empire of the Ants comp, scrub the playhead to preview the animation. Notice 
that the words Empire and Ants repeat an animation where they move up and down. 

Press and hold the Control (Windows) or Cmd (Mac OS) key on your keyboard and 
then click on layer 1 (EMPIRE) and layer 4 (ANTS) to select them both. Once both 
layers are selected, you can release the Control (Windows) or Cmd (Mac OS) key and 
then press the U key to reveal the keyframes and expressions on them. The animation on 
these layers is regular and even, but you can create a greater sense of frantic movement by 
adding randomness to the position keyframes with the Wiggler panel.

3 Move the playhead to the beginning (0;00;00;00) of the Timeline and if you are not 
currently in the Animation workspace, choose Window > Workspace > Animation 
to switch. If you have amended the default animation workspace, choose Window 
> Workspace > Reset “Animation” to return it to its default appearance. In this 
workspace, the Wiggler panel is located right below the Smoother panel on the right. 
The Wiggler panel contains the following options:

Apply To: Specifi es whether the Wiggler will change the spatial graph to add 
randomness to the motion of a layer, or the temporal graph to Add deviations to the 
velocity of a layer.

Noise Type: Smooth Noise produces a gradual change that is free from sudden 
variations in the property, while Jagged Noise produces sudden, quick variations.

Dimensions: Specifi es whether to add deviations to a single dimension (x,y,z) or 
all dimensions simultaneously. If you use one of the all dimensions settings, you can 
specify whether to apply the same deviations to all the dimensions or to calculate 
individual values for each one.
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Frequency: Sets the number of deviations per second.

Magnitude: Sets the maximum size of the deviation using the unit of measure of the 
selected property.

4 Click on the Position property of the EMPIRE layer to highlight all its keyframes; 
this also activates the Wiggler panel. Set the Wiggler as follows:

PROPERTY VALUE

Apply To Spatial Path

Noise Type Jagged

Dimensions Y

Frequency 10

Magnitude 10

Click the Apply button. The Wiggler adds a series of keyframes to the property. Preview 
the animation; notice that the word EMPIRE seems to jump up-and-down randomly.

The Wiggler can randomize values between existing keyframes. 

5 Click on the Position property of the ANTS layer to highlight all its keyframes. The 
Wiggler panel maintains the previously used settings. Click Apply.

6 Double-click on the Empire Promo composition in the Project panel to make it active 
in the Timeline and Composition panels. RAM preview the composition. 

7 Choose File > Save to commit these changes to your After Eff ects project. You may 
now close this project, as you are fi nished with it.
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Understanding Keyframe Interpolation

You may ask yourself, what is interpolation? It is actually a very integral part of all keyframe-
based computer animation, but many novice After Effects users don’t completely understand 
how it works. When you create keyframes on the Timeline, you are setting the values of a 
specific property at a specific time. When you have two keyframes with different values, After 
Effects fills in the intermediate values between them (a process sometimes called tweening), thus 
creating animation. The technical term for this fill-in process where the program figures out the 
change in the keyframes and sets the intermediate values between them is called interpolation. 

There are two types of keyframe interpolation in After Effects: spatial and temporal. Spatial 
involves the interpolation of values in space such as position, while temporal involves the 
interpolation of values in time to control velocity. Some properties such as Opacity only have 
temporal interpolation—that is, After Effects only has to interpret changes in the property over 
time—while other properties such as Position have both a temporal and spatial component. 

Linear interpolation
The diamond-shaped keyframe icons that you have created in your animations throughout 
the projects in this book actually represent a very specific type of keyframe interpolation 
called linear interpolation. This type of interpolation creates a uniform rate of change 
between the keyframes. For example, if you have a layer moving 100 pixels across the screen 
over a duration of 10 seconds using linear interpolation, then the layer will move 10 pixels 
per second. Linear interpolation can lead to animation that seems stiff or mechanical. When 
dealing with spatial interpolation, a keyframe using linear interpolation creates a motion path 
in which the layer moves in a straight line.

Bézier interpolation
Bézier interpolation provides the most precise control of the value graph or motion path 
segments on either side of the keyframe. Bézier keyframes have two direction handles 
that operate independently on both the value graph and motion paths. If you apply Bézier 
interpolation to all the keyframes of a layer property, After Effects creates a smooth transition 
between these keyframes. Bézier interpolation allows you to create any combination of 
curves and straight lines along the motion path. Because each of the Bézier handles operates 
independently, a curving motion path can suddenly turn into a sharp corner.

Auto Bézier and Continuous Bézier interpolation
Auto Bézier interpolation creates a smooth rate of change, and is the default setting for 
spatial interpolation. As you change the values of keyframes using Auto Bézier interpolation, 
the positions of Auto Bézier direction handles change automatically to maintain a smooth 
transition between them. 

Similar to Auto Bézier, Continuous Bézier interpolation also creates a smooth rate of change 
throughout a keyframe. However, the positions of direction handles in a Continuous Bézier 
keyframe are adjusted manually. When you manually adjust the direction handles of a keyframe 
using Auto Bézier interpolation, After Effects converts it into Continuous Bézier interpolation.

Hold interpolation
Hold interpolation is available only as a temporal interpolation method. You can use it to 
change the value of a layer property over time without a gradual transition. If you apply Hold 
interpolation to a property’s keyframe, the value of the first keyframe holds steady until the 
next keyframe, at which point the values change immediately. This interpolation is very 
useful when you want to create strobe effects or have layers appear or vanish suddenly. 
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Create acceleration and deceleration using Easy Easing
The diff erent types of keyframe interpolation are important because they give you a 
choice of how your animations look. Linear is the default interpolation type for temporal 
keyframes; this is what gives your animation a consistent change in the value of a property 
over time. Spatial keyframes, on the other hand, default to the Auto Bézier interpolation. 
This interpolation is what produces the curved or Bézier motion paths, what you have 
become used to seeing when animating the Position properties of objects. These diff erent 
interpolation methods create diff erent types of motion, both when animating onscreen 
movement such as that created by a motion path and when controlling the timing of 
animation to simulate acceleration or deceleration. 

You are not limited to using the default interpolation method; you can change both spatial 
and temporal interpolation at any time to fi t the specifi c needs of any project. In this part 
of the lesson, you will be working with an existing project that contains an animation of a 
bouncing ball. While the animation has already been built, it requires some modifi cation 
to both the spatial and temporal keyframe interpolation to look more realistic. 

Changing spatial interpolation
Spatial interpolation is the easiest one to adjust for most users because it is very similar to 
the way that you work in programs such as Photoshop and Illustrator. You can directly 
manipulate vertices and direction handles in the Composition panel in much the same 
fashion that you change mask shapes. 

1 Choose File > Open Project and navigate to the ae09lessons folder. Locate the project 
named Using Easy Easing.aep and double-click it to open this fi le. If necessary, choose 
Window > Workspace > Standard to return to the default After Eff ects workspace and 
then again, if necessary, choose Window > Workspace > Reset “Standard.” 

RAM preview the fi le to view the animation. As you can see, the project consists of a 
graphic of a ball bouncing up and down and there is also a shadow that follows the ball 
as it connects with the fl oor. 

2 Move the playhead to the 2 second 15 frame (0;00;02;15) mark on the Timeline (this 
places you in the middle of the animation) and click on the Ball layer to highlight it. 
Then press the U key on your keyboard to reveal the layer’s animated keyframes.
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When you previewed the animation you may have noticed that the ball seems to 
fl oat or slide as it makes contact with the table. This is due to the fact that the second 
keyframe is set to use Continuous Bézier for its spatial interpolation; however you can 
easily correct this by changing it so that is uses Linear interpolation.

Changing spatial interpolation in After Eff ects is much like editing anchor points in graphics 
programs such as Adobe Illustrator and Photoshop.

3 In the Composition panel, right-click on the second keyframe; this is the one at which 
the ball connects with the fl oor graphic. In the menu that appears, choose Keyframe 
Interpolation to open a dialog box that allows you to control both temporal and spatial 
interpolation. 

You can use the Keyframe Interpolation dialog box to set 
temporal and spatial interpolation simultaneously.

If you want to change the shape of the motion path now, you can do so by editing the handles of 
the fi rst or last keyframes.
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4 In the Keyframe Interpolation dialog box, change the Spatial Interpolation pull-down 
menu to Linear and click OK. The shape of the motion path changes to resemble two 
upward-facing curves.

Motion paths in After Eff ects are similar to Bézier paths in other graphics programs.

5 Choose File > Save As and navigate to the ae09lessons folder. Rename the project 
Using Easy Easing-working.aep and click the Save button. Do not close this fi le, as 
you will need it in the next part of this lesson, where you will change the easing to the 
keyframes to simulate acceleration and deceleration.

Adding easing to keyframes
Easing is a technique that changes the rate of change or speed of an animated property to 
create the impression of acceleration or deceleration. If you are familiar with the principles 
of traditional cell animation, you may know this concept as slow-in and slow-out. After 
Eff ects makes it very simple to create this eff ect using Easy Ease In, Easy Ease Out, and 
Easy Ease, which you can use to quickly add easing with a simple right-click.

In this animation, the ball should gradually accelerate as it falls, attain its greatest speed just 
before it makes contact with the fl oor, and then decelerate as it approaches the top of its 
movement arc as it bounces away from the fl oor. 

1 With the Using Easy Easing-working project still open, move the playhead to the 
beginning (0;00;00;00) of the Timeline. If the Position property of the ball layer is not 
visible, select the layer and press the P key on your keyboard to reveal it.
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2 To create the sense that the ball is accelerating as it approaches contact with the fl oor, 
you will add Easy Ease Out to the fi rst keyframe. In the Timeline panel, right-click 
on the fi rst keyframe of the Position property and choose Keyframe Assistant > Easy 
Ease Out from the menu that appears.

Adding easing to any keyframe means that it is no longer a simple linear keyframe.

You can also access the Easy Easing functions from the Animation menu by choosing Animation 
> Keyframe Assistant.

3 Right-click on the last keyframe and choose Keyframe Assistant > Easy Ease In from 
the menu. This creates the deceleration eff ect as the ball bounces away from the point 
of contact with the fl oor.

You can use Easy Easing to create quick acceleration and deceleration eff ects.

4 RAM preview the animation and you see that the speed at which the ball moves from 
keyframe to keyframe is no longer constant. Choose File > Save to save these changes 
to your After Eff ects project. Do not close this fi le, as you will need it in the next part 
of this lesson where you will add a few fi nishing touches to the animation to make it 
seem more realistic and engaging.
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Using squash and stretch to enhance the animation
The Easy Easing you applied in the previous section of this lesson can enhance the sense 
of realistic movement in animations by creating acceleration or deceleration where you 
need it. Another principle of animation that you can also use to improve the visual appeal 
and sense of realism in an animated work is squash and stretch. Many animators consider 
it to be the most important element of an animation project and also one that is often 
overlooked in computer-based animation. You can use squash and stretch to convey a 
sense of weight and fl exibility to objects by showing how they react to making contact 
with other objects.

In this animation, the ball should react to hitting the fl oor object. At its point of contact, 
the ball will squash vertically as it reacts to the force with which it hits the ground and also 
stretch horizontally to maintain its overall volume. Adding a motion blur to the animation 
should also help to establish the impression of a realistic movement through space.

1 With the Using Easy Easing-working project still open, move the playhead to the 
2 second 15 frame (0;00;02;15) mark on the Timeline. Notice that the ball is still a 
perfect sphere at the point where it makes contact with the fl oor. This is actually the 
point at which it should squash and stretch.

2 With the ball layer selected, hold down the Shift key on your keyboard and press 
the letter S on the keyboard to add Scale to the currently displayed properties in the 
Timeline panel. 

Then press the Page Up key on your keyboard (this moves the playhead back one frame 
to 0;00;02;14) and click the Time-Vary Stopwatch ( ) for the Scale property. After 
Eff ects creates a keyframe at this point to preserve the ball’s current scale value.

The Page Up and Page Down keys are very helpful when you must navigate the Timeline frame by frame.

3 Press the Page Down key on your keyboard to return to 0;00;02;15 or just press the 
letter K on the keyboard to move the playhead to the next visible keyframe, which is 
the one for the contact position of the ball.
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4 Disable the Constrain Proportions switch ( ) to the left of the Scale property’s values. 
Change the property values to 120.0%, 90.0%. This gives the spherical ball a more 
elliptical appearance.

When adding squash and stretch, it is important to maintain the overall volume of the object.

5 Press the Page Down key on your keyboard fi ve times to move to the 2 second 
20 frame (0;00;02;20) mark on the Timeline. Change the Scale property values to 
100.0%, 100.0% to restore the original appearance of the ball.

6 Enable the ball layer’s Motion Blur switch and then click the Enable Motion Blur 
switch at the top of the Timeline panel to preview the motion blur eff ect in the 
composition. 

7 Choose Edit > Deselect All and then RAM preview the animation. The overall eff ect 
is much more realistic than when you started.

Choose File > Save to commit these changes to your After Eff ects project. You may 
now close this project, as you are fi nished with it.
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Animating with the Graph Editor
Throughout this book you have created your animations either by manipulating property 
values in what is called the layer bar mode of the Timeline panel, or by directly moving 
your layers around in the Composition panel. While both of these methods can be very 
successful, there is another tool available to you called the Graph Editor that is intended to 
give you additional control over your animations. The Graph Editor represents property 
values along a two-dimensional graph, where composition time is represented horizontally 
while speed or value is represented vertically. 

While you can use the Graph Editor to adjust the values of animated properties or to 
add additional keyframes, its primary function for most users is to control the speed of 
animations to create acceleration and deceleration. Like the Easy Easing you applied 
previously, you can use the Graph Editor to control the rate of change or speed of an 
animated property to create the impression of acceleration or deceleration. The diff erence 
is that the Graph Editor allows for much greater control and fi ne-tuning of the eff ect.

In this exercise, you will work with a pre-built After Eff ects project and use the Graph 
Editor to create a more realistic motion by adding acceleration to an animation.

1 Choose File > Open Project and navigate to the ae09lessons folder. Locate the project 
named Creating Acceleration with the Graph Editor.aep and double-click it to open 
this fi le.

RAM preview the Rocket composition. As you can see, it contains an animation of 
a rocket ship blasting off  into space. The rocket moves up at a constant rate but this is 
unrealistic; it should start off  slower and then accelerate upward.

2 Click on layer 2, the one named Rocket, to select it and press the U key on your 
keyboard to reveal its animated properties.

Pressing the U key with any number of layers selected reveals only the properties that have animation enabled on those layers.

As you can see, this animation consists of two keyframes for the position of the rocket. 
The fi rst keyframe at the 1 second (0;00;01;00) mark establishes the resting position 
and corresponds with the In points of the four layers that give you the rocket exhaust 
and fl ame trail. The second keyframe at the 5 second (0;00;05;00) mark places the 
rocket beyond the top border of the composition.
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3 Click the switch ( ) that looks like a little graph to the right of the Position property’s 
Time-Vary stopwatch ( ) to include the Position property in the Graph Editor 
display. 

Properties can be added or removed from the Graph Editor display by enabling or disabling this switch.

You must fi rst add properties to the Graph Editor display before you can work with them. You 
can add and manipulate them individually, or in groups, depending on your needs. 

4 Click the Graph Editor switch at the top of the Timeline panel to change the panel’s 
default layer bar mode to the Graph Editor view. 

The Graph Editor displays composition time horizontally along the top of the Timeline and property values vertically along 
the right.
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Understanding the Graph Editor

A B

C D E F G H I J K L M N O P Q

A. Composition time ruler. B. Property values. C. Choose which properties are shown in the Graph Editor. 
D. Choose graph type and options. E. Show transform box. F. Snap. G. Auto-zoom graph height. H. Fit selection to view. 
I. Fit all graphs to view. J. Separate dimensions. K. Edit selected keyframe. L. Convert selected keyframe to hold. 
M. Convert selected keyframe to linear. N. Convert selected keyframe to Auto Bézier. O. Easy Ease. P. Easy Ease In. 
Q. Easy Ease Out.

The Graph Editor displays composition time horizontally along the top of the Timeline and 
property values vertically along the right. When working with the Graph Editor, there are 
two different types of graphs available to you: value graphs and speed graphs. Value graphs 
show the actual value of the animated properties that you have added to the editor, while 
speed graphs show rates of change of the property values. For spatial properties such as 
Position, the Graph Editor defaults to the speed graph, while for temporal properties such as 
Opacity, the Graph Editor defaults to the value graph.
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5 The white graph line represents the speed at which the property values change. It 
is currently a straight line, meaning that the property’s change in value is constant. 
Notice that the keyframes on this speed graph correspond with the Position property’s 
value keyframes in the layer bar display. 

The keyframes (represented by the white anchor points on the graph line) in this 
graph use linear interpolation, and each possesses one direction handle (to control the 
curvature of the graph line) each. 

Linear keyframes produce a constant change in speed and may appear to create stiff  animation.

Click on the fi rst keyframe, hold the Shift key on your keyboard, and drag the 
keyframe to the zero px/sec position on the value graph. 

As you move keyframes vertically in the Graph Editor, the Timeline display automatically adjusts to make them all visible.
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6 RAM preview the animation. The rocket now seems to accelerate suddenly and then 
the speed tapers off  and remains relatively constant; this is due to the shape of the 
graph. The fi rst keyframe on the speed graph has a value of zero px/sec. The graph 
rapidly increases in value toward the beginning of the animation and then levels off  
approximately halfway through. You can adjust this by moving the second keyframe 
up. Click on the second keyframe, hold the Shift key on your keyboard, and drag the 
keyframe to the 600 px/sec position on the value graph. 

The Graph Editor automatically scrolls as you move a keyframe vertically and then adjusts to keep all your keyframes in view 
after you complete the movement because the Auto-zoom graph height button is enabled.

7 The keyframes are now in the proper position for the type of acceleration that you 
want, but you need to adjust the curvature of the graph line so that the rocket is 
picking up speed as it rises into the air. Click on the direction handle of the second 
keyframe and drag it to the left until the graph line resembles the one below.

The direction handles adjust a property of the speed graph’s keyframes called Infl uence.
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8 RAM preview the animation. The rocket should now pick up speed as it rises. If you 
want a greater acceleration, you can always adjust the vertical position of the second 
keyframe so that the rocket is traveling at a speed greater than 600 px/sec when the 
animation completes.

Choose File > Save As and navigate to the ae09lessons folder. Rename the project 
Creating Acceleration with the Graph Editor-complete.aep and click the Save 
button. You may now close this project, as you are fi nished with it.

If you prefer, you can set the speed and infl uence values for a keyframe numerically in a dialog 
box by double-clicking on that keyframe.

Create a strobing effect using hold interpolation
Whether using the linear method to create uniform changes or the Bézier method to 
vary the speed and create the impression of acceleration, the animation must still progress 
through every single value between the two keyframes. But what if an animation calls 
for a property to immediately change from one value to another? This is a time to use the 
hold interpolation method. 

In this section of the lesson, you will change keyframe interpolation to produce an eff ect 
in which a light bulb blinks on and off .

1 Choose File > Open Project and navigate to the ae09lessons folder. Locate the project 
named Using Hold Interpolation.aep and double-click it to open this fi le.

RAM preview the lightBulb composition. As you can see, the light bulb fades up and 
then fades down again, but in this case a better animation would have the light simply 
blink on and off .

2 The animation in this project is due to the opacity keyframes on the Filament-Dark, 
Bulb Color-White, and Flare Eff ect layers. Converting them all to hold keyframes will 
produce the desired eff ect. In the Timeline panel, click on the layer named Filament-
Dark to highlight it. Press and hold the Ctrl (Windows) or Command (MacOS) key 
on your keyboard and click the Bulb Color-White and Flare Eff ects layers to highlight 
them as well. With the three layers still selected, press the T key on your keyboard to 
reveal the Opacity property of all three layers. 
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3 Deselect all the layers by choosing Edit > Deselect All and then click the Opacity 
property for the Filament-Dark layer to select all this property’s keyframes.

Clicking on any property selects all keyframes for that property; you can then move or edit them simultaneously.

4 Hold the Shift key on your keyboard and click on the Opacity property for the Bulb 
Color-White and Flare Eff ect layers to select these keyframes as well.

5 Right-click on any one of the selected keyframes and choose Keyframe Interpolation 
from the menu that appears. 

6 In the Keyframe Interpolation dialog box, change the Temporal Interpolation to 
Hold. This converts all the linear keyframes that you selected to hold keyframes. Click 
OK to close the dialog box.

The Opacity property only has temporal keyframes.

7 RAM preview the animation. The light bulb now blinks on and off .

Choose File > Save As and navigate to the ae09lessons folder. Rename the project 
Using Hold Interpolation-complete.aep and click the Save button. You may now 
close this project, as you are fi nished with it.

Congratulations! You have fi nished this lesson.
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Self study
Now that you have learned some of the more advanced concepts and tools for creating 
animation in After Eff ects, you can try them out on your own. You should experiment 
with adding some of the expressions you have learned here to enhance the animations you 
have created in earlier lessons in this book.

Review
Questions
1 What is the advantage of creating your own animation presets?

2 Why would you want to use Motion Sketch?

3 What can you use the Wiggler panel for?

Answers
1 Animation presets allow you to quickly reuse animations you have created, and 

because their properties are editable once you apply them, you can adjust settings to 
match the specifi c needs of each project.

2 Motion Sketch off ers a more intuitive solution to animating positional changes in 
After Eff ects. It allows an artist to draw motion paths onscreen and apply them to 
objects in the Timeline.

3 The Wiggler panel allows you to apply frantic, frenetic motion to keyframes on your 
timeline.
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What you’ll learn in 
this lesson:
• Understanding how video 

stabilization and camera 
tracking work

• Stabilizing video footage

• Tracking a camera in 
3D space 

• Applying tracked camera 
data to composite graphics 
into a video frame.

Lesson 10

Animating graphic elements created in applications such as Adobe 
Photoshop and Illustrator, is relatively simple, as is working with 
straight video footage. However, when you need to combine these two 
diff erent types of media, motion and camera tracking are tools you 
can use. 

Starting up
You will work with several fi les from the ae10lessons folder in this lesson. Make sure that 
you have loaded the aelessons folder onto your hard drive from the supplied DVD. See 
“Loading lesson fi les” in the Starting up section of this book.

See Lesson 10 in action!

Use the accompanying video to gain a better understanding of how to use some of the features 
shown in this lesson. The video tutorial for this lesson can be found on the included DVD.

10

Tracking and 
Stabilizing Footage
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Setting up
As you work in After Eff ects, you will inevitably open and close many panels, depending 
on the type of project you are creating. However, when working through the projects in 
this book, it is important to have an interface that matches the lessons. To this end, you 
should always reset your workspace to the preset Standard confi guration.

1 Choose Window > Workspace > Standard to set your current workspace confi guration.

2 Choose Window > Workspace > Reset “Standard” to reset the standard workspace in 
case you have modifi ed it at some point. 

Understanding Video Stabilization and Tracking
Video stabilization and tracking are terms for several separate, but very similar, processes 
found in Adobe After Eff ects. In some cases, such as working with the point-based Motion 
Stabilizer and Motion tracker, they are actually the exact same command, but with 
diff erent targets and end results. Initially, all stabilization and tracking eff ects attempt to 
analyze a video sequence and extract useful data from it. Upon closer inspection, both 
have several distinct divisions that you should be aware of:

Warp Stabilizer: The Warp Stabilizer is used to remove jittery motion that is most often 
caused by camera movement. This eff ect makes it possible to correct handheld and shaky 
footage, turning it into a series of steady, smooth shots that appear as though they had been 
captured using a tripod or dolly. 

3D Camera Tracking: The 3D Camera Tracker is an eff ect that analyzes a video 
sequence and attempts to extract data about the position and motion of the camera that 
shot the footage. You can then use this data to create a Camera in After Eff ects that should 
correctly mimic the movement of the camera in the video sequence. This allows you to 
correctly composite 3D layers on top of your 2D video footage.

Using the Warp Stabilizer
The Warp Stabilizer was fi rst introduced in After Eff ects CS 5.5. This eff ects runs as a 
background process and begins immediately upon being applied to a layer. There are 
several options that you should be familiar with when using the Warp Stabilizer. 

Result: This property controls the intended results of the Warp Stabilizer. The only two 
options are Smooth Motion and No Motion. Smooth Motion retains the original camera 
movement of the footage, but attempts to make it appear smoother and less jerky. The No 
Motion setting attempts to remove all camera movement from the video sequence. 

Smoothness: Controls how much of the original footage’s camera motion is stabilized. 
Lower values preserve more of the camera’s original motion, while higher values produce a 
smoother result. Note that this property is only available when the Result is set to Smooth 
Motion.
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Using the Warp Stabilizer

Method: Specifi es the type of operation the Warp Stabilizer attempts to perform on the 
footage. 

Position: Tracking is based only the X and Y position of the content of your footage and 
is the simplest type of stabilization that can be performed. 

Position, Scale, and Rotation: Stabilization is based on all three of these properties and 
can provide a better result when the camera is moving through the scene. 

Perspective: Tracking can better stabilize footage that might have perspective shifts.

Subspace Warp: Attempts to warp diff erent areas of the video frame individually to 
stabilize the entire frame. If the Stabilizer cannot locate enough points to perform the 
selected stabilization, it will fall back to the preceding stabilization type.

Framing: The Framing property specifi es how the borders, the moving outside edges of 
the video frame that result from the stabilization eff ect, appear when the stabilizing result 
is viewed.

Stabilize Only: Displays the entire frame including the moving edges. This is good when 
you want to see how much work is being done by the Warp Stabilizer.

Stabilize, Crop: Crops the moving Edges without scaling them. This results in a 
stabilized video frame that is smaller in size than the original video frame.

Stabilize, Crop, Auto-scale: The default result of the Warp Stabilizer; crops the moving 
edges and then scales the resulting stabilized image to fi ll the entire size of the original 
video frame.

Stabilize, Synthesize Edges: Fills the space created by the moving edges with content 
extrapolated from adjacent frames. Users of Adobe Photoshop might fi nd it similar to an 
unrelated eff ect called Content Aware Fill.

In this section of the lesson, you will apply the Warp Stabilizer eff ect to a video clip. After 
Eff ects is often used to quickly correct shaky or otherwise unusable footage so it can then 
be integrated into a video editing project.

1 Choose File > Open Project and navigate to the ae10lessons folder. Locate the project 
called Using the Warp Stabilizer.aep and double-click it to open the fi le. This project 
contains a single video fi le called Park Scene-Shaky.mpeg. It is a ten-second, 1080P 
high-defi nition video fi le. 

2 In the Project panel, locate the Park Scene-Shaky fi le and then drag it to the Create 
a new Composition button located at the bottom of the panel. This creates a new 
composition based on the properties of the video fi le. It will exactly match the fi le’s 
dimensions, frame rate, and duration. This is a good technique to use in a situation 
where the goal is to apply an eff ect to a video clip, and then render it immediately so it 
can be used in a video editing application such as Adobe Premiere Pro or Apple Final 
Cut Pro.
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3 Choose File > Save As and navigate to the ae10lessons folder. Rename the project 
Using the Warp Stabilizer-working.aep, and then click the Save button. 

4 In the Project panel, the new Composition called Park Scene-Shaky was created inside 
the video folder along with the video clip. Click the composition and drag it outside 
of the folder.

Folders are a great way to keep the Project panel organized.

5 When you created the new Composition in the preceding step, it automatically 
became active in the Timeline and Composition panels simultaneously. 

Choose Composition > Preview > RAM Preview so that you can take a look at the 
unstabilized video footage. Notice that the video sequence is very shaky; a situation 
that is very common when working without a tripod or dolly. In this case, the camera 
person was using a hand-held camera while walking along the roadway. 

Stop the preview by clicking in the Timeline panel and then click on the Park-Shaky.
mpeg layer in the Timeline to make it active.
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Using the Warp Stabilizer

6 With the video layer selected, choose Animation > Warp Stabilizer. This applies the 
Warp Stabilizer eff ect, which immediately begins analyzing the contents of the layer 
based on its default settings. If you know that the default settings are not a good choice 
for your particular footage, you can cancel the eff ect via the Eff ect Controls panel that 
automatically opens when you apply the Warp Stabilizer. Keep in mind the only way 
you could possibly know that the default settings will not work for your sequence is 
if you have performed stabilization on similar footage in the past. It is often a good 
practice to apply the Warp Stabilizer with the default settings and then adjust them as 
necessary.

The warp stabilizer runs as a background eff ect.

Since the Warp Stabilizer runs as a background eff ect, you can perform other actions in After 
Eff ects while waiting for it to complete. If you hide the Composition panel that is showing you 
the results of the eff ect, you will receive notifi cation via the Info panel when the Warp Stabilizer 
is done. Depending on your system confi guration, this background process can take quite some 
time to complete.
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7 Once the Warp Stabilizer eff ect has completed analyzing and adjusting the footage, 
Choose Composition > Preview > RAM Preview so that you can take a look at how 
the footage has been stabilized. You will see that even at the eff ect’s default settings, 
the footage looks much better than what was originally shot. While there is still 
movement in the video sequence, the frantic movement has been signifcantly softened. 

Press the spacebar on the keyboard to stop the preview.

8 Choose File > Save As, and if necessary navigate to the ae10lessons folder. Rename 
this fi le Using the Warp Stabilizer-complete.aep and click the Save button. 

You can now close this fi le by choosing File > Close Project.

Many users of After Eff ects fi nd that the default settings of the Warp Stabilizer are actually 
very good when applied. It is a phenomenal leap beyond the capabilities of the legacy Point 
Stabilization that the application used to favor. With this eff ect, many quick stabilization 
jobs have become one-click operations. These default settings always aim for the highest 
possible level of stabilization. It uses the sub space warp method to warp diff erent areas of 
the video frame individually in an attempt to stabilize the entire frame.

Using the 3D Camera Tracker
The 3D Camera Tracker eff ect analyzes video or image sequences to extract camera motion 
and three-dimensional scene data. This extracted data can then be used to create an After 
Eff ects camera layer, allowing you to properly composite three-dimensional layers on top of 
existing two-dimensional footage. The 3D Camera Tracker eff ect shares its tracking code 
with the Warp Stabilizer, and like that eff ect, performs its analysis as a background process. 

The eff ect automatically runs at its default settings. If you know these are not appropriate 
for your current footage, you can stop the eff ect using the Cancel button located in the Eff ects 
Controls panel.

The 3D Camera Tracker eff ect has several controls that you should become familiar with.

Shot Type: this property is used to specify the angle of view used in the source video 
footage. You can choose from a fi xed horizontal angle of view, variable zoom, or a specifi c 
horizontal angle of view. If you set the property to a specifi c horizontal angle of view, you 
can input the exact angle of view the solver should use in its calculations.

Show Track Points: toggles between showing the 3D solved, perspective-hinted track 
points, and the 2D source points, without hinting perspective.

Render Track Points: controls whether the solved track points are rendered during 
RAM Preview. The track points are always visible when the eff ect is selected in the Eff ects 
Controls panel or Timeline, even if this option is not selected. 

Create Camera: builds an After Eff ects Camera layer from the solved camera data.
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Using the 3D Camera Tracker

Integrating graphics with live-action footage can be quite diffi  cult. If your camera 
is locked so it doesn’t move, adding graphics created in After Eff ects, Photoshop, or 
Illustrator can be a straight-forward process. However, when you are dealing with video 
footage in which the camera is moving through the environment, you need an application 
that can perform 3D camera tracking, also called match moving. This technique analyzes 
the video sequence and attempts to extract data about the relationship between elements 
in the footage. Once this data has been processed, a virtual camera can be created that 
matches the movement and positioning of the real-world camera, allowing graphics to be 
accurately matched to the video footage.

Prior to the CS6 release, this technology wasn’t available to After Eff ects users natively, but 
was provided through third-party plug-ins or other applications. Now that this feature is 
available natively within After Eff ects, any user can easily composite graphics into video 
footage.

In this part of the lesson, you will run the 3D Camera Tracker eff ect on a video sequence 
of a camera dollying down a school hallway, and then use the extracted data to composite 
two Photoshop graphics into the scene.

1 Choose File > Open Project and navigate to the ae10lessons folder. Locate the project 
called Using the 3D Camera Tracker.aep and double-click it to open the fi le. The main 
composition in this project is called On Education. It contains a video sequence called 
Dolly Down Hallway, and two secondary Compositions called Quote 1 and Quote 2. 

2 Choose File > Save As and navigate to the ae10lessons folder. Rename the project 
Using the 3D Camera Tracker-working.aep, and then click the Save button.

3 If necessary, double-click the On Education composition in the Project panel to make 
it active in the Timeline and Composition panels. This Composition contains three 
layers: Quote 1 and Quote 2, which are hidden, and a video layer called Dolly Down 
Hallway.mpeg. 

Layers in After Eff ects can contain any type of media, including other Compositions.
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4 Turn on the visibility of the two hidden layers by clicking the visibility switch located 
to the left of each layer. Drag the playhead back and forth along the Timeline; notice 
that the two graphic layers remain stationary, making it impossible to believe that they 
are in the same scene as the video. This is what the 3D Camera Tracker can help you 
correct. Hide the two Composition layers (Quote 1 and Quote 2) before you continue.

5 In the Timeline panel, click the video layer to highlight it, and then choose 
Animation > Track Camera.

The 3D Camera Tracker eff ect runs as a background process just like the Warp Stabilizer.
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Using the 3D Camera Tracker

Analyzing a video fi le to extract camera data is a time-consuming, processor-intensive 
process that can take time to complete. The Camera Tracker runs as a background 
process, thus allowing you to continue with other tasks while it works on your footage.

The completed eff ects with Track Points visible on your footage.
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6 Once the eff ect has completed processing, a series of 3D track points will be visible on 
your video footage. These points represent diff erent tracked pixels in the video footage 
and their relative positions in three-dimensional space. Move the playhead back and 
forth over the Timeline; notice that the points change as the camera moves down the 
hallway. As you move your cursor around the Composition panel, you will notice 
a selection ring appear when you are between multiple track points. This indicator 
shows the perspective distortion that exists between multiple points.

Track points are only visible when the 3D Camera Tracker eff ect is highlighted in the Eff ect Controls panel. 

You can assign 3D layers to either a single track point or to multiple ones. If you select multiple 
points, the application will warp the layer to account for perspective distortion, allowing you to 
have After Eff ects layers automatically adjust to the perspective in your video footage.

7 Choose File > Save. Do not close this fi le; you will need it in the next part of 
this lesson, where you will create an After Eff ects Camera layer that mimics the 
movements of the real-life camera from the footage.
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Using the 3D Camera Tracker

Attaching 3D layers to Track Points
Now that you have tracked the movement of a camera in the video fi le, you will use the 
created track points to position 3D layers so they can appear to transform in the same way 
that the rest of the video sequence does. Once you have your 3D track points, the next 
step of the compositing process begins. After Eff ects allows you to create a camera layer 
that matches the movement of the camera in your video sequence. 

Additionally, you can create three types of 3D layers; null, solid and text. You can then 
position them to match the position of any visible track point. 

Each of these three layer types can be useful for a number of diff erent situations. A null 
layer for example, is a helper object; it can have all the transform properties of any visual 
layer (position, scale, etc.) but it does not render and is therefore a useful layer to use as the 
parent of a visual layer. Solid layers can be used as graphics (color fi elds or color boxes) or as 
surfaces to receive shadows from 3D objects. Text layers allow you to have text in 3D space 
that seems to move along with the movement of the camera through your video footage.

1 With the Using the 3D Camera Tracker-working.aep fi le still open, move the playhead 
to the beginning (0;00;00;00) of the Timeline, if necessary.

2 In the Composition panel, right-click on one of the left most track points and choose 
Create Null and Camera from the menu that appears.

You can create solid, null and text layers at the position of any track point.

When you right-click a track point, you can choose to create a null, solid, or text layer at the 
current position of that track point.
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This command does several things: it creates a Camera layer from the Camera data 
extracted from the scene, and it creates a 3D Null layer that is placed at the position of 
the selected track point.

The Camera layer is necessary so that your graphics will appear to move as the camera in the 
video scene moves.

3 In the Timeline panel, locate the layer called Quote 1 and unhide it. Then, click the 
layer’s 3D switch to convert it from a two-dimensional to a three-dimensional layer. 
3D layers are necessary for anything you want to composite into a video scene, since 
only they are aff ected by Camera layers.

Remember any layer you want to attach to a track point has to be 3D.
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Using the 3D Camera Tracker

4 Press and hold the Shift key on your keyboard, click the Quote 1 layers Parent drop-
down menu, and choose Track Null 1 to parent the layer to the Null you created in a 
preceding step.

Choose Track Null 1 from the Parent drop-down menu.

Pressing and holding the Shift key while setting a layer parent moves the child layer (Quote 1 
in this case) to the position of the parent. Pressing and holding the Alt (Windows) or Option 
(Mac OS) key allows the child layers to maintain their current Transformation values.

The Quote 1 layer’s Anchor Point moves to the exact position of the Null layer.
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5 Because of the eff ect of perspective, the Quote 1 layer is now much larger and extends 
outside the video frame. You will correct this by resizing it. If it is not already 
selected, click the Quote 1 layer to highlight it, and then press the S key on your 
keyboard to reveal the layer’s Scale property. Click any of the three property values 
and change it to 50. 

Since the Constrain Proportions switch is enabled, changing any scale property value changes them all.

6 In the Timeline panel, right-click the Track Null 1 layer and choose Rename from the 
menu that appears. Change the Null’s name to Quote 1 Tracker.

7 RAM Preview the Timeline by choosing Composition > Preview > RAM Preview. 
Notice that the graphic now seems to move along with the video footage until you 
can no longer see it as the dolly moves past it.

8 Choose File > Save. You can now close this fi le.

Congratulations! You have fi nished this lesson.
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Review

Self study
1 Import your own video footage that needs stabilization and run the Warp Stabilizer 

eff ect on it. Depending on the type of correction you need to create, you might want 
to use a stabilization method other than Subspace Warp. For example, if you are 
only trying to keep a single unmoving object centered in the video frame, a simpler 
method, such as Position, would be better for this task.

2 Continue to work on the Using the 3D Camera Tracker.aep project, or use your own 
footage. Try adding a 3D text layer to your scene by right-clicking a track point and 
choosing Create Text from the menu that appears. 

Review
Questions
1 In Adobe After Eff ects, what is the purpose of the Warp Stabilizer?

2 What is the purpose of the 3D Camera Tracker?

3 When you right-click a solved track point, what are the three types of layers you can 
create?

Answers
1 The Warp Stabilizer is used to remove jittery motion most often caused by camera 

movement.

2 The 3D Camera Tracker eff ect analyzes video or image sequences to extract camera 
motion and three-dimensional scene data. This data can then be used to create a 
Camera layer, allowing you to properly composite graphics into a video sequence.

3 When you right-click a track point, you can choose to create a null, solid, or text layer 
at the current position of that track point.
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What you’ll learn in 
this lesson:
• Simple Expressions to 

enhance animations

• Apply scripts to enhance 
your workfl ow

• How to locate additional 
expressions and scripts for 
your use

Lesson 11

The animation you have created up until this point have all made 
use exclusively of key framing techniques. While it is the most 
common, creating keyframes is not the only way that you can create 
your animation. Two additional features that you can use to create 
or enhance animations, in addition to the traditional techniques, are 
Expressions and Scripts. 

Starting up
You will work with several fi les from the ae11lessons folder in this lesson. Make sure that 
you have loaded the aelessons folder onto your hard drive from the supplied DVD. See 
“Loading lesson fi les” in the Starting up section of this book.

See Lesson 11 in action!

Use the accompanying video to gain a better understanding of how to use some of the features 
shown in this lesson. The video tutorial for this lesson can be found on the included DVD.

11

Working with 
Expressions and Scripts
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Setting up
As you work in After Eff ects, you will inevitably open and close many panels, depending 
on the type of project you are creating. However, when working through the projects in 
this book, it is important to have an interface that matches the lessons. To this end, you 
should always reset your workspace to the preset Standard confi guration.

1 Choose Window > Workspace > Standard to set your current workspace 
confi guration.

2 Choose Window > Workspace > Reset “Standard” to reset the standard workspace in 
case you have modifi ed it at some point. 

Automating animation with expressions
What are expressions, you may ask? They are the scripting language built into After 
Eff ects and you can use them to automate some animation tasks that are otherwise tedious 
or time-consuming to complete. Expressions are not the answer to every problem you 
will face in the program, but they can be the solution to some of them. You can add them 
to any layer or eff ect property and they will either complement or replace (depending on 
which expressions you are using) the keyframes you have already set.

Expressions can be helpful to you in many ways. There are some eff ects that are virtually 
impossible to achieve using keyframes alone, while in other situations, such as when you 
want to loop an animation, they can simply cut down on the number of keyframes that 
you have to create. You can use expressions to link diff erent properties on diff erent layers 
together or force one layer to move or change in relation to another. Expressions are 
not the solution to every problem; in fact, sometimes it is easier to keyframe a series of 
actions than to try and create a complex expression to achieve the same eff ect. However, 
understanding when and how to use them can speed up your workfl ow.

Expressions are based on the JavaScript language, which is a very common language used 
in website development, but you don’t have to learn much code to take advantage of their 
power. If you are already interested in scripting, then you may choose to explore the full 
range of features available by writing your own expressions; however, most users really 
only need a general understanding of a few scripts that they can use to optimize their 
animation workfl ows.
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Automating animation with expressions

Finding expressions
There are many sites on the Web where you can fi nd additional expressions for use in 
After Eff ects. A Google search for the terms “After Eff ects” and “Expressions” is often a 
great place to start. The following is a short, annotated list of a few of the resources you 
may want to check out:

SITE NAME SITE ADDRESS NOTE

MotionScript.com www.motionscript.com The site of Dan Ebberts. Many 
of the scripts listed in the After 
Effects help files come from 
him.

Adobe User to User Forums http://forums.adobe.com/
index.jspa

The forums have message 
boards that specialize in 
expressions and scripting.

AE Enhancers www.aenhancers.com The site includes libraries, 
tutorials, and discussion 
forums on scripts and 
expressions.

Adding expressions to properties
When you add expressions to individual layer or eff ects properties, they only aff ect those 
specifi c properties. In Lesson 7, “Working with Audio,” when you learned how to work 
with audio in After Eff ects, you created an expression to link two properties together 
using the pick whip. Now you will move beyond simply linking two properties to 
each other and add expressions that modify the value or behavior of keyframes in your 
composition.

When working with Expressions you must be very careful. The Expressions language, 
like all scripting languages, is very sensitive to both spelling and capitalization. You will 
want to make sure that you input the code exactly as it is seen here. Any error that is made 
when you are entering code will disable the code and open a warning dialog box to appear 
when you exit the Expressions window. Once the error is corrected, the Expressions will 
then be re-enabled.

In this section of the lesson, you will work with a pre-built After Eff ects project and add 
several common and simple scripts to enhance the overall design and avoid having to 
create extraneous keyframes.

1 Choose File > Open Project and navigate to the ae11lessons folder. Locate the project 
named Using Common Expressions.aep and double-click it to open this fi le.

RAM preview the Dark City composition. As you can see, this project is composed 
of several diff erent pieces, most of which are currently static. In the course of this 
exercise, you will:
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Add an expression to the yellow wedge swinging in the background to allow it to loop 
forward and backward continuously.

Add an expression to the three-pointed white stars in the background that allows them 
to blink on and off  randomly.

Add an expression to the cloudy background that adds a constantly increasing 
movement so it seems to oscillate continuously.

Add an expression to the color fi elds on the cloudy background that allows them to 
vary their position frantically.

Using the loopOut() expression
You use the loopOut() expression to allow a keyframed animation to continue to play, 
even after the playhead has reached the last keyframe on the timeline. In this case, you 
will set the type of loop to use a ping pong eff ect so that the animation will play forward 
and backward continuously. You will work with the fl ourishes-Spikes composition in this 
section of the lesson.

1 With the Using Common Expressions.aep project open, double-click on the 
fl ourishes-Spikes composition in the Project panel to reveal it and make it active.

2 RAM preview the fl ourishes-Spikes composition to see that it is a simple animation of 
a yellow wedge shape rotating from a vertical to a horizontal position. 

Click on the layer named Single Spike to highlight it and press the R key on your 
keyboard to reveal the Rotation property. Notice that there are two keyframes for the 
property: one at the beginning of the Timeline (0;00;00;00) and the other at 3 seconds 
(0;00;03;00).

3 Press and hold the Alt (Windows) or Option (Mac OS) key on your keyboard and 
then click on the Time-Vary Stopwatch ( ) for the Rotation property to add a 
Rotation expression to the Timeline. 

A B

A. Expression interface. B. Expression fi eld.
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Adding an expression displays the expression interface, a series of buttons and menus 
for working with expressions and the expression fi eld, which is a resizable text fi eld 
that displays in the Timeline.

While editing expressions, previews are disabled.

4 Replace the placeholder text in the expression fi eld with the following:

loopOut();

Click in any empty area of the Timeline to exit the expression fi eld and then scrub the 
playhead from the beginning of the timeline to the end to preview the animation. As 
you scrub the playhead past the second keyframe, notice that the wedge jumps back to 
the starting position and the animation repeats; this type of looping is called a cycle. It 
will continue to do this for the duration of the composition.

5 While the default behavior of a loop function is to cycle, you can change this by 
modifying the line of code you created in the previous step. Click in the expression 
fi eld to make it editable and change the code you previously added, to the following:

loopOut(type="pingpong");

Click in any empty area of the Timeline to exit the expression fi eld and again scrub 
the playhead from the beginning of the timeline to the end to preview the animation. 
Notice that the wedge now swings down and then back up: playing forward and 
backward much like a ping-pong ball being hit back and forth across a table.

6 Double-click on the Dark City composition in the Project panel to return to the main 
composition, and RAM preview it to see the eff ect.

Choose File > Save As and navigate to the ae11lessons folder. Rename the project 
Using Common Expressions-working.aep and click the Save button. Do not 
close this fi le; you will need it in the next part of this lesson.
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Using the random() expression
It can be diffi  cult to create the impression of randomness in animation using keyframes 
alone. In situations where you need to create a sense that something is occurring 
randomly, you can always turn to the random function. In this section of the lesson, you 
will add randomness to the white, three-pointed stars to make them blink on and off  
haphazardly. To accomplish this, you will apply the expression to a single layer fi rst and 
then copy that expression to other layers.

1 With the Using Common Expressions-working.aep project open, double-click on the 
Star Outlines composition in the Project panel to reveal it and make it active. This 
composition consists of a series of concentric three-pointed stars.

2 Click on the layer at the top of the layer stack (the one named Layer 4) to select it and 
press the T key on the keyboard to reveal the Opacity property.

The keyboard commands for selecting properties are as follows: 
P = Position, A = Anchor Point, R = Rotation, T = Opacity, S = Scale.

3 Click on the Opacity property to select it, choose Animation > Add Expression, and in 
the expression fi eld that appears, replace the placeholder text with the following code:

random(0,100);

This randomizes the Opacity property by choosing a random number using the fi rst 
property 0 (zero) as the minimum possible value and the second property 100 as the 
maximum.

4 Click on the Opacity property again to confi rm that it is selected, and choose Edit > 
Copy Expression Only. This doesn’t copy the actual layer—only expressions written 
onto it.
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5 Click on the second layer in the stacking order, press and hold the Shift key on your 
keyboard, click on the last layer to select all them, and then choose Edit > Paste. 
Before you paste the expression to the other layers make sure you have them all 
selected. Depending on your screen resolution you may have to scroll down in the 
Timeline panel.

It is important to remember to choose the Copy Expression Only command; otherwise, After Eff ects 
will copy and paste the actual layer.
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This eff ectively replicates the code onto each selected layer, giving each a random 
opacity animation. Tap the E key on your keyboard twice in rapid succession to see 
the expressions that have been added to all the layers.

Quickly press the letter E on your keyboard twice to view the expressions on your layers.

To hide all the properties on all selected layers, you can hold down the Ctrl key on your keyboard 
and press the tilde (~) key.

6 Double-click on the Dark City composition in the Project panel to return to the main 
composition, and RAM preview it to see the eff ect.

Choose File > Save to commit these changes to your After Eff ects project. Do not 
close the fi le, as you will need it again in the next part of the lesson.
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Using the Time property with expressions
The Time property is the value of the composition time at the playhead’s current position. 
So if the playhead is at the 3 second (0;00;03;00) mark on the Timeline, the Time 
property’s value is 3, and if it is at the 10 second (0;00;10;00) mark, the value is 10. Because 
the time property is constantly changing, this can be a great way of making the property 
value of an eff ect increase in value without have to add extraneous keyframes.

1 With the Using Common Expressions-working.aep project open, double-click on 
the Dark City composition in the Project panel to select it and make it active in the 
Timeline panel.

2 In the Timeline panel, click on the clouds layer to select it, and then click on the solo 
switch to the left of the layer name to hide every other layer. The clouds layer is a 
shape layer that has an eff ect named Fractal Noise applied to it. It is this eff ect that 
gives the layer the appearance of a cloudy texture.

Press the E key on your keyboard to reveal the eff ects on this layer.

Soloing a layer is very helpful when you want to hide every other layer. Only layers with their solo 
switch enabled will display.

3 If it is not already visible, double-click on the Fractal Noise eff ect beneath the layer 
name to reveal the Eff ect Controls panel. Then, in the panel, right-click on the 
Evolution property and choose Reveal in Timeline from the menu that appears. 

4 Now that the Evolution property has been revealed in the Timeline, you can add an 
expression to it. This property uses progressive revolutions that continue to change 
the image with each added revolution and you can use it to specify how much the 
noise evolves over a period of time. With a little imagination, you can use the Time 
property to create an ever-increasing Evolution eff ect. Hold down the Alt (Windows) 
or Option (MacOS) key on your keyboard and click on the time-vary stopwatch for 
the Evolution property. 
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5 Click on the Expression language menu button ( ) in the expression interface, and 
choose Global > time from the menu that appears. 

The Expression language menu provides a convenient way to add expressions to your property and can save you 
a great deal of typing time.

This replaces the placeholder text in the expression fi eld with the Time property.

6 Click in the expression fi eld after the Time property and add the following code:

*200;

The completed expression should look like this:

time*200;

7 Disable the cloud layer’s solo switch and then RAM preview the animation by 
choosing Composition > Preview > RAM Preview, to see the eff ect of the expression. 
The cloud layer is now in constant motion. Depending on your system confi guration 
the RAM Preview may take some time to complete.

8 With the cloud layer highlighted, press Ctrl+~ (Windows and Mac) on your keyboard 
to collapse all the layers visible properties.

9 Choose File > Save to commit these changes to your After Eff ects project. Do not 
close the fi le, as you will need it again in the next part of the lesson.

Using the wiggle() expression
Earlier in this book you used the Wiggler panel to add frantic movement to a layer; a 
side eff ect of using the Wiggler was the creation of a bunch of extra keyframes. The 
wiggle() function allows you to create the same eff ect but doesn’t add any keyframes to 
the Timeline; as a result, adjusting the eff ect is much easier once you have applied it. In 
this part of the lesson, you will apply a wiggle function to the gradient fi ll on the orange, 
green, and blue shape layers in the Dark City composition. It is the gradient on these layers 
that gives the black-and-white cloud layer its color tinting. 

1 With the Using Common Expressions-working.aep project open, enable the solo 
switches for the shape layers named orange, green, and red. 
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2 With the layer named orange selected press the U key on your keyboard twice in 
quick succession. This will reveal the contents of the layer allowing you to see all its 
properties including Gradient Fill 1.

The Start Point property controls where the gradient fi ll begins, while the End Point property 
controls where it stops.

3 Hold down the Alt (Windows) or Option (MacOS) key on your keyboard and click 
on the time-vary stopwatch to the left of Gradient Fill 1’s Start Point property to add 
an expression to it.

4 Replace the placeholder text with the following code:

wiggle(10,50);

The wiggle function above has two parameters: The fi rst parameter specifi es 
the frequency, the number of wiggles per second. The second parameter sets the 
amplitude, the maximum amount of variation applied to the property the wiggle 
function is aff ecting. The amplitude uses the unit of measure of the property that you 
apply it to.

5 With the layer named orange still selected, press Ctrl+~ (Windows and MacOS) on 
your keyboard to hide all its properties. Now with the layer named green selected, 
press the U key on your keyboard twice in quick succession. This will reveal the 
contents of the layer allowing you to see the properties of this layer’s Gradient Fill 1.

6 Hold down the Alt key on your keyboard and click on the time-vary stopwatch to the 
left of the Start Point property to add an expression to it. Replace the placeholder text 
in the expression fi eld with the following code:

wiggle(15,20);

With the layer still selected, press Ctrl+~ (Windows and MacOS) on your keyboard to 
hide all its properties.  
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7 With the layer named red selected, press the U key on your keyboard twice in quick 
succession. This will reveal the contents of the layer allowing you to see the properties 
of this layer’s Gradient Fill 1.

8 Hold down the Alt key on your keyboard and click on the time-vary stopwatch to the 
left of the Start Point property to add an expression to it. Replace the placeholder text 
in the expression fi eld with the following code:

wiggle(5,30);

With the layer still selected, press Ctrl+~ (Windows and MacOS) on your keyboard to 
hide all its properties.  

9 Disable the solo switches for all three layers and reveal the entire composition. RAM 
preview the animation to see the eff ect of your work with expressions.

10 Choose File > Save to commit these changes to your After Eff ects project. You may 
now close this project, as you are fi nished with it.

It is important to note that script is very sensitive to spelling and capitalization errors. Any 
deviation from the proper spelling and capitalization of the language will cause the code to fail. 
Please be very careful when typing code into the Expression fi eld.

Working with scripts
You may not be familiar with scripts yet, but in many cases you can use them to make 
your workfl ow less tedious and more effi  cient, and they can often enhance the animation 
features of After Eff ects. A script is a group of programmatic commands that tell a program 
to perform a series of actions. Most Adobe applications have built-in support for running 
scripts to automate repetitive tasks, and some even off er scripting support for functions that 
are not supported in the program’s interface. In After Eff ects, scripts are created using the 
Adobe ExtendScript language, a variation of the JavaScript language, which is often used 
in the development of web pages. 

Scripts should not be confused with expressions, which use the internal scripting language 
of After Eff ects. While expressions are intended to assist in repetitive or diffi  cult animation 
tasks, the scripts written in the ExtendScript language are intended to alter the actual 
application. They can be used to add functionality that is lacking, or may currently require 
multiple menus or commands to run, such as scaling an entire composition or fi nding and 
replacing text in a comp. 

Installing and running scripts
When After Eff ects starts up, it automatically loads scripts from the Scripts folder. Several 
scripts come pre-installed with After Eff ects and are automatically installed in the Scripts 
folder in the application folder on your hard drive. Loaded scripts are available from the 
File > Scripts menu. You can run scripts even if they have not already been loaded by 
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choosing File > Scripts > Run Script File. Some scripts are intended to add additional 
panels to the program interface. These are installed into the ScriptUI Panels folder and are 
available from the bottom of the Window menu.

Creating scripts
If you are familiar with other scripting languages such as JavaScript or ActionScript, 
then you may want to explore the options available to you in writing your own scripts. 
You can write your own After Eff ects scripts using the Script Editor, which is part of the 
ExtendScript Toolkit. To start the Script Editor, choose File > Scripts > Open Script Editor.

Finding additional scripts
There are many sites on the Web where you can fi nd additional scripts for After Eff ects or the 
other applications in the Adobe Creative Suite. Many scripts are given away for free, while 
others are provided for a fee similar to plugins, and still others are available with a voluntary 
donation. The following is an annotated list of some of the sources available to you:

SITE NAME SITE ADDRESS NOTE

Adobe 
Exchange

www.adobe.com/cfusion/
exchange

Includes a wide variety of content for a range of 
programs in the Creative Suite.

AE Scripts www.aescripts.com Includes both free and for-purchase scripts.

AE Enhancers www.aenhancers.com Includes libraries, tutorials, and discussion 
forums on scripts and expressions.

Adobe User 
to User 
Forums

http://forums.adobe.com/
index.jspa

The forums have message boards that specialize 
in expressions and scripting.

Additional resources for scripting in After Eff ects, including helpful sites for tutorials and script 
downloads on the Web, is available through the Adobe Help application by searching for the 
word “Scripts.”

Using and running scripts
Running scripts in After Eff ects is a very easy process. Depending on where you have 
saved the script fi le you want to use, you will have a couple of diff erent options on 
how to run it.  Please note that before running any script you will want to read the 
documentation that was included with it. Some scripts require that you have specifi c layers 
or compositions highlighted in order to work, while others may require you to copy them 
into a specifi c folder location or change an application preference to work properly.
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When you install After Eff ects on your computer a scripts folder is automatically created 
inside of the After Eff ects application folder on your hard-drive. Depending on your 
operating system you can fi le that folder here:

• On the Windows OS: Program Files/Adobe/Adobe After Eff ects CS6/Support Files

• On the Mac OS: Applications/Adobe After Eff ects CS6

• If you have copied the script fi le into the Scripts folder located inside of the After Eff ects 
application folder on your computer’s hard-drive:

• Choose File > Scripts > Then choose the script you want to run from the list.

• If you have saved the script fi e anyone else on your hard drive:

• Choose File > Scripts > Run Script File...

• In the dialog box that appears, navigate to where you have your script fi le saved and 
double-click on the fi le to run it.

Using the Ease and Wizz Script
This is an optional exercise. To complete this section of the lesson, you will need to 
download and install a script from a third-party developer. If you do not currently 
have access to the Internet, cannot add scripts to the After Eff ects folder, or don’t feel 
comfortable doing this at the current time, you should skip this section.

In this section of the lesson, you will use the Ease and Wizz script created by Ian Haigh. 
Ease and Wizz is a script-based panel that improves upon the functionality provided by 
using the built-in Easy Ease commands. The Ease and Wizz script is available and asks for 
a voluntary donation from the AE Scripts website listed above. Information on installing 
and using the script, along with a few sample animations, is available at Ian’s website, 
www.ianhaigh.com/easeandwizz/. Before you can use the Ease and Wizz script you will have 
to do a few things:

• To install the Ease and Wizz script, copy the Ease and wizz.jsx fi le and easingExpressions 
folder into the ScriptUI Panels folder inside the After Eff ects application folder on your 
hard drive. You can fi nd the scripts folder in the following locations:

• On the Windows OS: Program Files/Adobe/Adobe After Eff ects CS6/Support Files

• On the Mac OS: Applications/Adobe After Eff ects CS6

• Once you have copied the fi les to the appropriate folder you will have to change a 
preference in After Eff ects to allow the script to create a new panel.

• In After Eff ects choose Edit > Preferences > General (Windows) or After Eff ects > 
Preferences > General (Mac OS) and in the General category of the Preferences panel 
enable the switch that says: Allow Scripts to Write Files and Access Network.

• Once the script has been copied to the ScriptsUI folder and the preference changed, 
you must restart After Eff ects so that the Ease and Wizz panel is accessible through the 
Window menu just like any other panel.
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1 Choose File > Open Project and navigate to the ae11lessons folder. Locate the project 
named SecretOfSuccess-Animated.aep and double-click it to open this fi le.

RAM preview the SecretOfSuccess composition. As you can see, this is the same 
animation that you worked on in Lesson 8, “Working with 3D in After Eff ects,” 
where you worked with the 3D features of After Eff ects.

2 Choose Window > Ease and Wizz.jsx to open the Ease and Wizz panel. It opens as a 
very large panel with a great deal of empty space. Resize it by clicking and dragging 
on the lower-right corner of the panel to make it more manageable. 

Many scripts exist that simply add additional 
panels to the After Eff ects interface.

The Ease and Wizz panel has four parameters that you can adjust:

Easing: Selects the type of easing algorithm to use. Enabling the curvaceous option 
below will limit the available choices somewhat.

Type: Specifi es whether the easing algorithm is applied to the keyframe so that it sets 
easing in, out, or both.

Keys: Sets which keyframes for the selected property the Ease and Wizz eff ect is 
applied to. You can choose to aff ect all a layer’s keyframes, only the start and end 
keyframes, or only the starting keyframe.

Curvaceous: A switch that has several diff erent functions. When applied to keyframes 
of the Position property, it allows the animated object to follow a Bézier motion path. 
Additionally, this switch allows you to use the Ease and Wizz script on Mask Path 
keyframes.

3 Click on the Spot Light 1 layer to select it and press the U key on your keyboard to 
reveal its animated properties. 

Click on property name; Point of Interest, to select all the keyframes for that property.

4 Right-click on the fi rst highlighted keyframe and from the menu that appears choose 
Keyframe Assistant > Easy Ease.

This will add Easing to both highlighted keyframes so that the movement of the Spot 
Light 1’s Point of Interest is no longer constant.
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5 RAM preview the animation. The spotlight’s Point of Interest now seems to pick 
up speed as it moves to complete its motion. As you learned when you worked with 
it earlier, the built in Easy Easing functions can be very helpful for making quick 
animation where things accelerate and decelerate. But what if you would like to be 
more creative with your easing? This is where the Ease and Wizz panel comes in.

6 With the Spot Light 1 layer selected, hold down the Ctrl key on your keyboard and 
press the tilde (~) key to hide all the layer’s properties. Then lock the layer by clicking 
the lock switch to the left of the layer name.

Choose Edit > Select All to select the remaining seven layers and then press the R key 
on your keyboard to reveal their Rotation properties. These keyframes are what you 
will adjust to create a more visually engaging animation. 

7 Each text layer has either the Y Rotation or X Rotation property animated. Click on 
the animated Y Rotation property of the layer named THE,

Holding down the Shift key and clicking on a property name allows you to select multiple properties at the same time.

When using the Shift key to select multiple layer properties, it is necessary to click on each 
property that you wold like to select. This is completely diff erent from when you use the Shift 
key to select layers in sequence, where you only have to click on the fi rst and last layer to select all 
the layers in between them.
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In the Ease and Wizz dialog box, set the following parameters:

Easing: Expo

Type: In

Key: All

Curvaceous: Disabled (checked off )

Click the Apply button. 

If you select multiple keyframes for multiple properties, then you can apply the Ease and Wizz 
eff ect simultaneously to all them.

8 Apply the same Ease and Wizz settings to the animated rotation properties of the 
remaining fi ve text layers.

9 RAM preview the animation. The animation now seems more dynamic and 
engaging.

Choose File > Save As and navigate to the ae11lessons folder. Rename the project 
SecretOfSuccess-Animated-complete.aep and click Save. You may now close this 
project, as you are fi nished with it.

Congratulations! You have completed the lesson.
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Self study
Now that you have learned some of the more advanced concepts and tools for creating 
animation in After Eff ects, you can try them out on your own. You should experiment 
with adding some of the expressions you have learned here to enhance the animations you 
have created in earlier lessons in this book.

Review
Questions
1 What are expressions and why would you use them?

2 When using the Random() expression what do the two values inside of the 
parenthesis set?

3 What are Scripts and what can you use them for in After Eff ects?

Answers
1 Expressions are the scripting language built into After Eff ects, and you can use them 

to automate some animation tasks that are otherwise tedious or time-consuming to 
complete. There are some eff ects that are virtually impossible to achieve using keyframes 
alone, while in other situations, such as when you want to loop an animation, they can 
simply cut down on the number of keyframes that you have to create.

2 When using the Random() expression the two values that you can place inside of the 
parenthesis indicate the minimum and maximum values for the random number that 
is generated.

3 A script is a group of programmatic commands that tell a program to perform a series of 
actions. In many cases you can use scripts to make your workfl ow less tedious and more 
effi  cient, and they can often enhance the animation features of After Eff ects. A script is 
a group of programmatic commands that tell a program to perform a series of actions.
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What you’ll learn in 
this lesson:
• Adding Compositions to 

the Render Queue

• Adjusting Render and 
Output Module Settings

• Creating Render Templates 
to ease repetitive tasks

Lesson 12

Creating your animations in After Eff ects is only a part of producing 
a complete project. Once that task is complete, you must still output 
your composition to a usable format by rendering it. Rendering 
creates a video fi le from the content on the Timeline. 

Starting up
You will work with several fi les from the ae12lessons folder in this lesson. Make sure that 
you have loaded the aelessons folder onto your hard drive from the supplied DVD. See 
“Loading lesson fi les” in the Starting up section of this book.

See Lesson 12 in action!

Use the accompanying video to gain a better understanding of how to use some of the features 
shown in this lesson. The video tutorial for this lesson can be found on the included DVD.

12

Outputting 
After Effects Projects
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Setting up
As you work in After Eff ects, you will open and close many panels depending on the 
type of project you are creating. When working through the projects in this book, it is 
important to have an interface that matches the lessons. To this end, you should always 
reset your workspace to the preset Standard confi guration.

1 Choose Window > Workspace > Standard to set your current workspace 
confi guration.

2 Choose Window > Workspace > Reset “Standard” to reset the standard workspace in 
case you have modifi ed it at some point. 

Rendering files for output
Rendering is the process of creating the frames of a video fi le from an After Eff ects 
composition. Rendering an individual frame creates a single image by combining all 
the layers, channels, eff ects, and other elements together to form a composite image. 
When you render the entire composition, After Eff ects renders the individual frames 
and combines them into a single video fi le or image sequence. After Eff ects off ers a wide 
variety of format and compression choices when rendering your project. The settings you 
choose for your project depend on how you plan to use it.

After Eff ects supports output to the following video, audio, and still image formats:

SUPPORTED FORMATS

3GPP (3GP) FLV, F4V H.264 and H.264 Blu-ray*

MPEG-2, MPEG-2 DVD, MPEG-2 
Blu-ray**

MPEG-4 QuickTime

SWF Video for Windows (AVI)*** Windows Media****

Audio Interchange File Format MP3 WAV

* The H.264 Blu-ray format splits the audio and video portions of a composition into different files. 

**  The MPEG-2 DVD and MPEG-2 Blu-ray formats split the audio and video portions of a composition 
into different files.

*** Exporting video to the AVI format is a Windows-only feature. 

**** Exporting video to the Windows Media format is a Windows-only feature.

If you use Adobe Premiere Pro to edit video, there is no need to render your After Eff ects 
compositions. You can use Adobe Dynamic Link to import unrendered comps directly to the 
Premiere Pro Timeline.
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Understanding the Render Queue
The Render Queue panel is the main interface for rendering and exporting fi les in 
After Eff ects. Multiple render items, each with its own output settings, can be managed 
simultaneously. You can create and apply templates for rendering and output settings in the 
Render Queue to aid productivity. The Render Queue has two sets of options that you 
must confi gure:

Render Settings: These options set characteristics for the output fi le such as resolution, 
frame rate, and duration.

Output Module: These options specify such settings as output format and compression. 
The Output Module also includes a section called Output To, which allows you to select a 
folder location and name for the output fi le.

Together, you use Render Settings and Output Module to control every aspect of your 
fi nal rendered fi le.

Adding compositions to the Render Queue
Compositions that have been added to the Render Queue are known as render items. 
The queue can contain multiple render items at the same time, and once you initiate 
this process by clicking the Render button, After Eff ects renders them all sequentially, 
unsupervised. 

In this exercise, you will open an existing project that contains multiple compositions and 
add one of them to the Render Queue to output a fi le for integration into a video editing 
application such as Premiere Pro.

1 Choose File > Open Project, navigate to the ae12lessons folder, and double-click on 
Adding Comps to the Render Queue.aep to open it.

This composition contains two of the text animations that you completed in Lesson 6,  
“Working with Text,” with the curtain background that is taken from the Animation 
Presets > Backgrounds in the Eff ects & Presets panel. 

2 In the Project panel, double-click on the Jabberwocky composition to select that comp 
and make it active in the Composition panel.
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3 Choose Composition > Add to Render Queue to open the Render Queue panel and 
add the composition as a render item.

The Render Queue panel is the main interface for outputting the work you create in After Eff ects.

A composition needs to be active in either the Project or Composition panel for the Composition 
> Add to Render Queue command to work.

4 Click on the reveal triangles to the left of Render Settings and Output Module to 
show the current settings for each set of options. By default, the Render Queue assigns 
the highest-quality rendering templates to the render item based on the composition’s 
properties.

By default, the Render Queue is set to output the highest-quality fi le for use in a video editing application.

In this case, the Project settings will produce a fi le for progressive display. 

5 Click on the downward-facing triangle to the right of Render Settings to select a new 
template to use in rendering this item. From the list that appears, choose DV Settings. 
This will change how the item is rendered to produce an interlaced video fi le that 
matches the settings of a standard-defi nition NTSC video fi le.
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6 Click the downward-facing triangle to the right of Output Module to select a new 
output template. From the list that appears, choose QuickTime DV NTSC 48 kHz to 
create a fi le that is compatible with the NTSC standard for digital video.

The built-in output templates provide a starting point for producing a video fi le that matches the established 
broadcast video standards.

If you are working on a PC, the equivalent template to QuickTime DV NTSC 48 kHz is 
named AVI DV NTSC 48 kHz.

7 Click the downward-facing triangle to the right of Output To and select Comp Name 
from the menu that appears; this opens a dialog box named Open.

In the dialog box, navigate to the ae12lessons project folder and click the Choose button 
in the lower-right corner of the dialog box to choose a location to save the output fi le.

8 If you look in the Status column located just above the Render Items you will notice 
that this one is now set to Queued. This means that this fi le will be included when the 
next render operation occurs. Click the Render button in the upper-right corner of 
the panel to initiate a rendering. This renders every item in the queue with its status 
set to Queued. 

The time it takes to render will vary, sometimes signifi cantly, from fi le to fi le and computer to 
computer. Rendering is a very processor-intensive activity, and while After Eff ects is rendering, 
you cannot use it for any other purpose. You can use the status indicator at the top of the Render 
Queue panel to review the estimated time to completion. When the render is complete, a chime 
sounds.

9 Notice that once the rendering process is complete, the items remain in the queue but 
they now have a status of Done. This is to allow you to duplicate render jobs without 
having to send a composition to the queue again. Click the reveal triangles to the left 
of Project Settings and Output Module to collapse the property display.
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10 Choose File > Save As and navigate to the ae12lessons folder. Rename the fi le 
Adding Comps to the Render Queue-working.aep and click the Save button. 
Do not close the fi le, as you will need it for the next section.

Adjusting render settings
Although the built-in Project Setting and Output Module templates can be very helpful in 
many situations, for more specifi c rendering needs, you will have to make adjustments to 
the individual settings. In this section, you will add another composition from the Adding 
Comps to the Render Queue project. This time, you will output the fi le in a format 
compatible with mobile devices and the Internet.

1 With the Adding Comps to the Render Queue-working.aep fi le still open, double-click 
on the Seneca—on speed composition to make it active. Choose Composition > Add to 
Render Queue. This adds the composition as the second render item in the queue.

2 Click on the words Best Settings to the right of the Render Settings label; this opens 
the Render Settings dialog box. 

In the Render Queue panel the text labels function as buttons.

There are many settings in this dialog box that you will probably never want to 
change from their default values. However, in the Time Sampling section, there are 
two properties that you should become familiar with: Field Rendering and Time 
Span. You use the Field Rendering drop-down menu when you must switch between 
rendering progressive and interlaced video, and the Time Span drop-down menu 
to control what part of the Timeline is rendered. You can specify either the entire 
Timeline or an area defi ned by the work area bar, or set custom In and Out points for 
the composition.
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3 The animation in the composition ends at the 5 second (0;00;05;00) mark on the 
Timeline, so you will specify a custom duration for the output fi le to reduce both the 
fi le size and render time.

Click the button labeled Custom, located at the bottom-right corner of the dialog box, 
to open the Custom Time Span dialog box. You use this dialog box to override the 
default duration of the render item.

Setting custom in and out points for your render are also 
helpful if you need to preview part of an overall project.

4 Leave the value for the Start timecode set to 0;00;00;00 and change the End value to 
0;00;06;29. This changes the duration to 7 seconds (0;00;07;00). Click OK to close 
this dialog box and return to the Render Settings dialog box. Click OK in the Render 
Settings dialog box to return to the Render Queue panel.

When counting with timecode, you always begin at the number zero, so one second in duration 
on the Timeline would be at 0;00;00;29 and not 0;00;01;00. 
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5 Click on the word Lossless to the right of the Output Module label; this opens the 
Output Module Settings dialog box. 

The default Output Module setting Lossless is intended to produce a high quality video fi le.

The Output Module controls everything about the fi nal output fi le, from its format 
and compression to whether or not you include an alpha channel in the render. From 
this dialog box, you can also adjust the size of the output video by resizing or cropping 
it and also adjust the audio output settings. 

6 From the format drop-down menu, choose H.264. This creates an MP4 fi le that is 
compatible with most modern digital devices as well as many HTML5 compatible 
web browsers. Click OK to return to the Render Queue panel.

7 The status of this render item is now set to Queued, meaning that this fi le will 
be included when the next render operation occurs. Click the Render button in 
the upper-right corner of the panel to initiate a rendering. When the fi le fi nishes 
rendering, locate the fi le that you saved to your hard-drive and double-click to play it. 
The video will play in your default media player application. 

8 After returning to After Eff ects, choose File > Save. Do not close this fi le; you will 
need it in the next section where you will duplicate the render job and create multiple 
Output Modules for it.
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Duplicating jobs in the Render Queue
While it is possible to duplicate render items in the queue by choosing the Edit > 
Duplicate command, it isn’t necessarily the most effi  cient way to work. An advantage of 
having the After Eff ects Render Queue is the ability to output a single render item with 
diff erent Render Module settings. Instead of sending a composition to the Render Queue 
multiple times, you can simply assign multiple output modules to the item. 

In this section, you will duplicate a render item and add multiple Output Modules to 
it with the intention of creating a QuickTime fi le for digital distribution and a low-
resolution sample fi le for review purposes. 

There will be times when you need to render an item again or simply render the same item with 
diff erent Project Settings. In order to do either of these, you must fi rst duplicate the item and then 
you can re-render or make changes.

1 With the Adding Comps to the Render Queue-working.aep fi le still open, click on 
the Jabberwocky render item in the Render Queue panel to highlight it.

2 Choose Edit > Duplicate to make a copy of the item. This adds a third render item to 
the panel with the same Render Settings and Output Module settings as the original, 
but with a diff erent fi lename in the Output To fi eld. You can also use a keyboard, 
Ctrl+D (Windows) or Command+D (Mac OS), in place of the menu command.

Duplicate the render item.

If you intend to use the new render item to replace the original, it is better to choose Edit > 
Duplicate with File Name when creating the new item.

3 Click on the downward facing arrow to the right of the Render Settings label. The 
menu that is revealed holds a series of render setting templates. Choose Best Settings 
from the list.
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4 Open the Output Module Settings dialog box by clicking on QuickTime DV NTSC, 
and then click on the Format Options button on the right. In the QuickTime Options 
dialog box, the Video tab allows you to view and adjust the video settings of the fi le 
you will render. Click on the Video Codec drop-down list and choose MPEG-4 as 
the new codec for your QuickTime fi le. Click the OK button at the bottom of the 
panel to return to the previous dialog box.

If you are working in the Windows operating system, the equivalent setting to those used here is 
AVI DV NTSC.

QuickTime is a common interchange format for video in 
many professional production settings.
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5 Because this fi le lacks an audio component, uncheck the Audio Output switch located at 
the bottom of the Output Module Settings dialog box. Click OK to close the dialog box.

When render items are duplicated, all the settings of the original 
are transferred to the copy.

6 Click on the fi lename located to the right of Output To, and in the Output Movie To 
dialog box, change the fi lename to Jabberwocky-large mobile.mov. Click Save to 
commit the name change and close the dialog box. 

7 Click the plus sign located to the left of Output To in order to add another Render 
Module to this item.

Adding additional Render Modules is an alternative to duplicating an entire render item.
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8 In this new render module, open the Output Module Settings dialog box by clicking 
on “Lossless” and click on the Format Options button on the right. In the QuickTime 
Options dialog box, choose MPEG-4 Video from the Video Codec drop-down menu 
and in the Basic Video Settings area change the Quality slider to 80. Click the OK 
button at the bottom of the panel to return to the previous dialog box.

Click the Resize checkbox to allow you to change the output dimensions of the video 
fi le, and with the Lock Aspect Ratio checkbox enabled, change the Resize to width to 
360. Click OK to close the dialog box and return to the Render Queue panel.

When resizing video reducing the size is usually fi ne but increasing it will result 
in a loss of quality.

Because Lock Aspect Ratio is enabled, changing the width will also automatically change the height 
once you click outside of the numerical fi eld.

9 Click on the fi lename located to the right of Output To, and in the Output Movie To 
dialog box, change the fi lename to Jabberwocky-small mobile.mov. Click Save to 
commit the name change and close the dialog box.
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10 The status of this render item is now set to Queued, meaning that this fi le will be 
included when the next render operation occurs. Because the render queue is now 
going to eff ectively render two fi les sequentially, this may take some time to complete. 
You can skip the render phase of this exercise if you choose.

If you would like to render the two video fi les, click the Render button in the upper-
right corner of the panel to initiate a rendering.

11 Choose File > Save. You may now close the fi le.

Creating render templates
Render templates allow you to streamline the output process. They can be created for both 
Render Settings and Output Modules and then applied to the render items in the queue. 

Next, you will create a Render Settings template for low-resolution previews and an Output 
Module template for QuickTime fi les that would be suitable for outputting these previews. 

1 With After Eff ects open, choose Edit > Templates > Render Settings to open the 
Render Settings Templates dialog box.

2 Click the New button in the Settings section of the dialog box to open the Render 
Settings dialog box.

Set the Resolution drop-down menu to Half. This produces a fi le that is half the size 
of the initial composition because only every other pixel will be rendered.

When working with video the term resolution is often used when talking about the 
pixel dimensions of a fi le.

Click OK to return to the previous dialog box.
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3 Type Low resolution preview into the Settings Name fi eld and click the OK button 
at the bottom of the dialog box. 

This template is now accessible from the Render Settings Template menu in the 
render queue.

4 Choose Edit > Templates > Output Module to open the Output Module Templates 
dialog box. Notice that it is set up almost exactly like the Render Settings Templates 
dialog box was.

5 Click the New button in the Settings section of the dialog box to open the Output 
Module Settings dialog box. Click on the Format Options button on the right.

If you are working in Windows, you will have to choose QuickTime from the Format drop-down 
menu before preceding to the next step.

In the QuickTime Options dialog box, if necessary choose MPEG-4 Video from the 
Video Codec drop-down menu and change the Quality slider to 80. Click the OK 
button at the bottom of the dialog box to return to the previous dialog box. Again 
click the OK button to return to the Output Module Templates dialog box.

6 Type QuickTime-MPEG4 Medium Quality into the Settings Name fi eld and click 
the OK button at the bottom of the dialog box. This template is now accessible from 
the Output Module Template menu in the render queue. Templates are automatically 
saved with the application whenever they are made, and you can use them in any After 
Eff ects project you create on your computer.

If you need to share templates between users of diff erent computers, you can do so using the 
Save All command found in both the Project Settings and Output Module Templates dialog 
boxes. After Eff ects saves the fi les in the .ars and .aom formats respectively, and they can then be 
loaded by another user through the Load command found in each dialog box. 

Exporting a project file
While the render queue is indeed the main interface for outputting your After Eff ects 
work, it is not the only one. If you are developing content for deployment online or 
through digital devices, you may need to bring your work into Adobe Flash. A workfl ow 
that takes advantage of both programs allows you to build highly engaging visual content 
in After Eff ects and then add interactivity in Flash using the ActionScript language. If 
Flash is your intended destination, you will use the Export command found in the File 
menu to create an Adobe Flash Professional (XFL) project fi le. An XFL fi le is essentially 
an XML-based equivalent of the native Flash project fi le (.fl a). When you export a 
composition to XFL format, the program attempts to create as accurate a conversion 
as possible by preserving as much data as possible, thus maintaining the integrity of 
individual layers and keyframes.
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Now, you will export an After Eff ects project as a Flash XFL project.

In addition to the XFL format used in Flash, there is a second project fi le format that you can 
export. An alternative workfl ow for video may involve exporting an After Eff ects composition as 
an Adobe Premiere Pro project (PRPROJ). Though viable, this isn’t the most commonly used 
option, as users of Premiere Pro are more likely to opt for importing After Eff ects elements using 
the Adobe Dynamic Link feature, which allows unrendered After Eff ects Compositions to be 
used on the Premiere Pro Timeline.

1 Choose File > Open Project, navigate to the ae12lessons folder, and double-click on 
Exporting to Flash.aep to open this project. This is a scaled-down version of one of 
the fi les you worked with in Lesson 6, “Working with Text.”

2 Double-click on the From word to deed composition in the Project panel to make it active. 

3 Choose File > Export > Adobe Flash Professional (XFL) to open the Export Settings 
dialog box.

4 Not all layer types and eff ects are supported when the composition is converted to an 
XFL fi le. Unsupported features must be either rasterized (as a video or PNG sequence) 
or ignored. If it is not already enabled, click on the radio button for Rasterize To and 
make sure the Format drop-down menu is set to FLV. This converts all unsupported 
layers to Flash video fi les.

If you choose to rasterize unsupported content, you must 
choose to convert it to either an FLV(fl ash video)fi le or a 
PNG image sequence.

Click OK.
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5 In the Save dialog box, navigate to the ae12lessons folder. By default, the fi lename 
simply copies the composition name; leave it as is and click the Save button to 
complete the export operation.

The fi le is now ready to be taken into Flash. You can open it by simply using the File 
> Open command in Adobe Flash Professional. Flash Professional cannot save an XFL 
fi le, so you will have to create a Flash Document (.fl a) from this exported fi le. 

6 Because the export process does not aff ect the project fi le, there is no need to save it. 
Choose File > Close Project. If the Save Changes dialog box appears, simply choose 
Don’t Save to close it.

Trimming and cropping compositions
When you create new compositions, you must specify their dimensions and durations, and 
it often seems perfectly reasonable to do so by just copying the settings of your current 
comp. But what happens when your project settings change? You may now need to trim a 
composition down to fi t a new specifi cation from your client or because you changed the 
length of your animation. Perhaps you have scaled down the content of a comp and want 
to reduce the dimensions to match. The ability to crop and trim layers is especially helpful 
when using the Pre-compose command, as it simply copies the duration and dimensions of 
your current comp. In this section, you will work with a pre-built project fi le where you 
will trim a composition’s duration to eliminate excess time and you will crop it to fi t the 
physical space that the animation occupies. In order to trim and crop a composition, you 
will use other features of the program as intermediaries to accomplish your goal. To trim, 
you will use the work area bar to defi ne the area to trim to, and to crop you will use the 
Region of Interest.

1 Choose File > Open Project, navigate to the ae12lessons folder, and double-click on 
Trimming and Cropping Comps.aep to open this project.

2 In the Project panel, double-click on the Creativity composition to make it active in 
the Timeline panel.

3 Click on the layer numbered 1 (the text layer) to select it and press the U key on the 
keyboard. This reveals all the properties on this layer that have animation enabled.

As you can see, this composition has a duration of 10 seconds (0;00;10;00), though the 
animation only lasts for the fi rst 5 seconds. Additionally, its dimensions are the full 
DV NTSC size of 720 × 480, though it is intended for use inside of another comp and 
needs to be a fraction of that size.
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4 Move the playhead to the 6 second (0;00;06;00) mark of the Timeline. This is one 
second after the animation is complete; adding a little time at the end of the animation 
gives the viewer time to absorb what they are seeing on-screen. If you plan on 
importing your animation into a video editing application such as Adobe Premiere 
Pro, this extra space after the animation, which is sometimes called a handle, makes it 
easier for the editor to work with.

Adding handles to the beginning and/or end of your compositions make it easier for an editor to integrate your animation 
into a video project.

5 Press and hold the Shift key on your keyboard and in the time ruler at the top of the 
Timeline, click on the end marker of the work area bar and drag it toward the playhead. 
Because you are holding down the Shift key, the marker snaps to the playhead.

You can adjust the work area bar by clicking and dragging either its start or end marker.

There are keyboard commands for setting the position of both the start and end of the work area 
bar. Pressing the B key on your keyboard moves the start of the work area bar to the playhead, 
while pressing N moves the end of the work area to the current position of the playhead.

6 Right-click on the work area bar and choose Trim Comp to Work Area from the 
menu that appears. This command changes the duration of the composition to only 
include the area the work area bar currently spans.
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7 In the Composition panel, click on the Choose grid and guide options button and 
choose Proportional Grid. This grid is a great tool when you need to have a general 
sense of the positioning of content in your composition but don’t need to be as exact as 
the rulers and guides allow.

You can only show one set of grids at a time, so when you enable the proportional grid, the action- and 
title-safe margins are disabled.

8 Click on the Region of Interest button at the bottom of the Composition panel. This 
changes the cursor into a cross-hair icon and disables the layer display. 

Since the layer display is disabled when using the Region of Interest tool, it is important to set up either the 
grid or guides beforehand.
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9 With the Region of Interest tool active, click and drag over the middle two rows of 
the grid. This completely encompasses the text so that it is visible.

The Region of Interest tool is also helpful if you want to preview only a portion of the composition panel 
because only the area inside it will preview during rendering.

You can remove the Region of Interest by holding down the Alt (Windows) or Option (Mac OS) 
key on your keyboard and clicking on the Region of Interest button.

10 Choose Composition > Crop Comp to Region of Interest. This changes the 
composition’s dimensions to match the size of the Region of Interest. 

Technically, this command doesn’t delete the area outside the Region of Interest; it simply adjusts 
the comp size so that it isn’t displayed. For example, you can still move the background layer 
around if you want to show a diff erent portion of it.
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11 Click on the Grid and Guide Options button and choose Proportional Grid from the 
menu to disable it.

Choose File > Save As and navigate to the ae12lessons folder. Rename the fi le 
Trimming and Cropping Comps-small.aep and click the Save button. Do not 
close this fi le, as you will need it in the next section.

Rendering an individual frame 
Sometimes you do not want to render an entire composition. Perhaps you want to render a 
single frame in order to use it as a template or visual guide. This can be a very useful tool 
if you must create content in another application such as Photoshop or Illustrator and you 
need to set its position relative to content in your After Eff ects comp. It can also be helpful 
for creating freeze-frame eff ects to hold a single frame of video in place, or if you need to 
make a still image to use as a thumbnail or preview image.

After Eff ects can output the following still-image formats:

OUTPUTTING FORMATS

Photoshop (PSD) Bitmap (BMP, RLE)* Cineon (CIN, DPX)

Graphic Interchange Format 
(GIF)*

Maya IFF (IFF; 16 bpc) JPEG (JPG, JPE)

OpenEXR (EXR) PNG (PNG; 16 bpc) Radiance (HDR, RGBE, XYZE)

SGI (SGI, BW, RGB) Targa (TGA, VBA, ICB, VST) TIFF (TIF)

* These formats can only be exported from a Windows-based computer.

1 With the Trimming and Cropping Comps-small.aep fi le still open, move the playhead 
to the end of the Creativity composition. 

2 Choose Composition > Save Frame As > File. This opens the render queue and adds 
the current comp to it. In the render queue, the Render Settings fi eld is set to Current 
Settings. Because you used the Save Frame As command, the current settings are to 
output the fi le as a single frame. 

The Output Module defaults to a Photoshop fi le and you can adjust it by editing the 
module’s settings. In many cases, you will want to bring the image fi les that you output 
into Photoshop for additional processing, so it makes a good default format here.
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3 Click on the text to the right of the Output To fi eld, Creativity (0;00;06;00).psd, to 
open the Output Frame To dialog box. Navigate to the ae12lessons folder, change the 
fi lename to Creativity thumbnail, and click the Save button to commit your changes.

While the Photoshop format is the default for the Save Thumbnail As command, you can choose another 
format by editing the Output Module Settings.

4 Click the Render button at the top of the Render Queue panel to render the fi le. 

This may take a few minutes, but when the render is complete, the fi les will be ready 
for editing in Photoshop or another application that will open this image format.

5 Choose File > Save to commit your changes to the fi le. You may now close this project.
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Adobe After Eff ects CS6 Digital Classroom378

Self study
Experiment with rendering the sample project provided on the DVD as well as your own 
project in diff erent video formats and with diff erent codecs. You will fi nd that the fi nal 
output fi le’s size varies, depending on the codec and the actual content of the fi le you are 
attempting to compress. 

Review
Questions
1 How do the fi les produced with H.264 Blu-ray and MPEG-2 DVD output settings 

diff er from the standard H.264 and MPEG-2 output?

2 What are the two project fi le types that can be exported from After Eff ects using the 
File > Export command?

3 What is the default image format when rendering an individual frame from a 
composition?

Answers
1 The H.264 Blu-ray and MPEG-2 DVD output settings produce two separate fi les, one 

for the audio portion of the composition and another for the video. This is so that they 
can be used in a DVD or Blu-ray disk authoring application such as Adobe Encore, as 
components in a multilingual disk.

2 The two project fi le types that can be exported from After Eff ects using the File > 
Export command are XFL for use in Adobe Flash Professional and PRPROJ for use in 
Adobe Premiere Pro.

3 Photoshop is the default image format when rendering an individual frame.
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Adobe After Effects keyboard shortcuts

 General Keyboard Shortcuts

 COMMAND WINDOWS MAC OS

Select all Ctrl+A Command+A

Deselect all F2 or Ctrl+Shift+A F2 or Command+Shift+A

Rename selected layer, composition, 
folder, effect, group, or mask

Enter on main keyboard Return

Open selected layer, composition, or 
footage item

Enter on numeric keypad Enter on numeric keypad

Move selected layers, masks, effects, or 
render items down (back) or up (forward) 
in stacking order

Ctrl+Alt+Down Arrow or 
Ctrl+Alt+Up Arrow

Command+Option+
Down Arrow or

Command+Option+Up 
Arrow

Move selected layers, masks, effects, or 
render items to bottom (back) or top 
(front) of stacking order

Ctrl+Alt+Shift+
Down Arrow or

Ctrl+Alt+Shift+Up Arrow

Command+Option+
Shift+Down Arrow or

Command+Option+
Shift+Up Arrow

Extend selection to next item in Project 
panel, Render Queue panel, or Effect 
Controls panel

Shift+Down Arrow Shift+Down Arrow

Extend selection to previous item in 
Project panel, Render Queue panel, or 
Effect Controls panel

Shift+Up Arrow Shift+Up Arrow

Duplicate selected layers, masks, effects, 
text selectors, animators, puppet meshes, 
shapes, render items, output modules, or 
compositions

Ctrl+D Command+D

Quit Ctrl+Q Command+Q

Undo Ctrl+Z Command+Z

Redo Ctrl+Shift+Z Command+Shift+Z

Purge all Ctrl+Alt+/ 
(on numeric keypad)

Command+Option+/ 
(on numeric keypad)

Interrupt running a script Esc Esc
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Working with After Effects Projects

 COMMAND WINDOWS MAC OS

New project Ctrl+Alt+N Command+Option+N

Open project Ctrl+O Command+O

Open most recent project Ctrl+Alt+Shift+P Command+Option+
Shift+P

New folder in Project panel Ctrl+Alt+Shift+N Command+Option+
Shift+N

Open Project Settings dialog box Ctrl+Alt+Shift+K Command+Option+
Shift+K

Find in Project panel Ctrl+F Command+F

Cycle through color bit depths for project Alt-click bit-depth button 
at bottom of Project 
panel

Option-click bit-depth 
button at bottom of 
Project panel

Open Project Settings dialog box Click bit-depth button at 
bottom of Project panel

Click bit-depth button at 
bottom of Project panel

 Working with Preferences 

 COMMAND WINDOWS MAC OS

Open Preferences dialog box Ctrl+Alt+; (semicolon) Command+Option+; 
(semicolon)

Restore default preferences settings Hold down Ctrl+Alt+Shift 
while starting After 
Effects

Hold down Command+
Option+Shift while 
starting After Effects

 Panels, viewers, workspaces, and windows 

 COMMAND WINDOWS MAC OS

Open or close Project panel Ctrl+0 Command+0

Open or close Render Queue panel Ctrl+Alt+0 Command+Option+0

Open or close Tools panel Ctrl+1 Command+1

Open or close Info panel Ctrl+2 Command+2

Open or close Preview panel Ctrl+3 Command+3

Open or close Audio panel Ctrl+4 Command+4

Open or close Effects & Presets panel Ctrl+5 Command+5

Open or close Character panel Ctrl+6 Command+6
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 COMMAND WINDOWS MAC OS

Open or close Paragraph panel Ctrl+7 Command+7

Open or close Paint panel Ctrl+8 Command+8

Open or close Brushes panel Ctrl+9 Command+9

Open or close Effect Controls panel for 
selected layer

F3 or Ctrl+Shift+T F3 or Command+Shift+T

Open Flowchart panel for project flowchart Ctrl+F11 Command+F11

Switch to workspace Shift+F10, Shift+F11, or 
Shift+F12

Shift+F10, Shift+F11, or 
Shift+F12

Close active viewer or panel (closes 
content first)

Ctrl+W Command+W

Close active panel or all viewers of type 
of active viewer (closes content first). For 
example, if a Timeline panel is active, this 
command closes all Timeline panels.

Ctrl+Shift+W Command+Shift+W

Split the frame containing the active 
viewer and create a new viewer with 
opposite locked/unlocked state

Ctrl+Alt+Shift+N Command+Option+
Shift+N

Maximize or restore panel under pointer ` (accent grave) ` (accent grave)

Resize application window or floating 
window to fit screen. (Press again to resize 
window so that contents fill the screen.)

Ctrl+\ (backslash) Command+\ (backslash)

Move application window or floating 
window to main monitor; resize window 
to fit screen. (Press again to resize window 
so that contents fill the screen.)

Ctrl+Alt+\ (backslash) Command+Option+\ 
(backslash)

Toggle activation between Composition 
panel and Timeline panel for current 
composition

\ (backslash) \ (backslash)

Cycle to previous or next item in active 
viewer (for example, cycle through open 
compositions)

Shift+, (comma) or Shift+. 
(period)

Shift+, (comma) or Shift+. 
(period)

Cycle to previous or next panel in active 
frame (for example, cycle through open 
Timeline panels)

Alt+Shift+, (comma) or 
Alt+Shift+. (period)

Option+Shift+, (comma) 
or 

Option+Shift+. (period)

Activate a view in a multi-view layout in 
the Composition panel without affecting 
layer selection

click with middle mouse 
button

click with middle mouse 
button
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 Activating tools 

 COMMAND WINDOWS MAC OS

Cycle through tools Alt-click tool button in 
Tools panel

Option-click tool button 
in Tools panel

Activate Selection tool V V

Activate Hand tool H H

Temporarily activate Hand tool Hold down spacebar or 
the middle mouse button.

Hold down spacebar or 
the middle mouse button.

Activate Zoom-In tool Z Z

Activate Zoom-Out tool Alt (when Zoom-In tool 
is active) 

Option (when Zoom-In 
tool is active)

Activate Rotation tool W W

Activate Roto Brush tool Alt+W Option+W

Activate and cycle through Camera tools 
(Unified Camera, Orbit Camera, Track XY 
Camera, and Track Z Camera)

C C

Activate Pan Behind tool Y Y

Activate and cycle through mask and 
shape tools (Rectangle, Rounded 
Rectangle, Ellipse, Polygon, Star)

Q Q

Activate and cycle through type tools 
(Horizontal and Vertical)

Ctrl+T Command+T

Activate and cycle through pen tools (Pen, 
Add Vertex, Delete Vertex, and Convert 
Vertex)

G G

Temporarily activate Selection tool when 
a pen tool is selected

Ctrl Command

Temporarily activate Pen tool when the 
Selection tool is selected and pointer 
is over a path. (Add Vertex tool when 
pointer is over a segment; Convert Vertex 
tool when pointer is over a vertex.)

Ctrl+Alt Command+Option

Activate and cycle through Brush, Clone 
Stamp, and Eraser tools

Ctrl+B Command+B

Activate and cycle through Puppet tools Ctrl+P Command+P

Temporarily convert Selection tool to 
Shape Duplication tool

Alt (in shape layer) Option (in shape layer)

Temporarily convert Selection tool to 
Direct Selection tool

Ctrl (in shape layer) Command (in shape layer)

AECS6_06Pass.indb   382AECS6_06Pass.indb   382 5/18/12   1:07 PM5/18/12   1:07 PM



A

383Appendix A

Appendix A

 Compositions and the work area (keyboard shortcuts)

 COMMAND WINDOWS MAC OS 

New composition Ctrl+N Command+N

Open Composition Settings dialog box for 
selected composition

Ctrl+K Command+K

Set beginning or end of work area to 
current time

B or N B or N

Set work area to duration of selected layers 
or, if no layers are selected, set work area 
to composition duration

Ctrl+Alt+B Command+Option+B

Open Composition Mini-Flowchart for 
active composition
Note: If you tap Shift several times without 
any intervening keystrokes, you may 
invoke a feature of your operating system’s 
StickyKeys or Sticky Keys accessibility 
software. See your operating system’s 
documentation for disabling this feature.

Tap Shift Tap Shift

Activate the most recently active 
composition that is in the same 
composition hierarchy (network of nested 
compositions) as the currently active 
composition

Shift+Esc Shift+Esc

Navigating the Timeline

 COMMAND WINDOWS MAC OS 

Go to specific time Alt+Shift+J Option+Shift+J

Go to beginning or end of work area Shift+Home or Shift+End Shift+Home or Shift+End

Go to previous or next visible item in time 
ruler (keyframe, layer marker, work area 
beginning or end)

J or K J or K

Go to beginning of composition, layer, or 
footage item

Home or Ctrl+Alt+
Left Arrow

Home or Command+
Option+Left Arrow

Go to end of composition, layer, or 
footage item

End or Ctrl+Alt+Right 
Arrow

End or
Command+Option+

Right Arrow

Go forward 1 frame Page Down or Ctrl+
Right Arrow

Page Down or 
Command+Right Arrow

Go forward 10 frames Shift+Page Down or 
Ctrl+Shift+Right Arrow

Shift+Page Down or
Command+Shift+

Right Arrow
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 COMMAND WINDOWS MAC OS 

Go backward 1 frame Page Up or Ctrl+
Left Arrow

Page Up or 
Command+Left Arrow

Go backward 10 frames Shift+Page Up or 
Ctrl+Shift+Left Arrow

Shift+Page Up or 
Command+Shift+

Left Arrow

Go to layer In point I I

Go to layer Out point O O

Go to previous In point or Out point Ctrl+Alt+Shift+Left Arrow Command+Option+
Shift+Left Arrow

Go to next In point or Out point Ctrl+Alt+Shift+
Right Arrow

Command+Option+
Shift+Right Arrow

Scroll to current time in Timeline panel D D

 Previews

 COMMAND WINDOWS MAC OS 

Start or stop standard preview spacebar spacebar

RAM preview 0 on numeric keypad* 0 on numeric keypad* or 
Control+0 (zero) on main 
keyboard

RAM preview with alternate settings Shift+0 on numeric 
keypad*

Shift+0 on numeric 
keypad* or 
Shift+Control+0 (zero) on 
main keyboard

Save RAM preview Ctrl-click RAM Preview 
button or press Ctrl+0 on 
numeric keypad*

Command-click RAM 
Preview button or press 
Command+0 on numeric 
keypad*

Save RAM preview with alternate settings Ctrl+Shift-click RAM 
Preview button or press 
Ctrl+Shift+0 on numeric 
keypad*

Command+Shift-click 
RAM Preview button or 
press Command+Shift+0 
on numeric keypad*

Preview only audio, from current time . (decimal point) on 
numeric keypad*

. (decimal point) on 
numeric keypad* or 
Control+. (period) on 
main keyboard

Preview only audio, in work area Alt+. (decimal point) on 
numeric keypad*

Option+. (decimal point) 
on numeric keypad* or 
Control+Option+. (period) 
on main keyboard
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 COMMAND WINDOWS MAC OS 

Manually preview (scrub) video Drag or Alt-drag 
current-time indicator, 
depending on Live 
Update setting

Drag or Option-drag 
current-time indicator, 
depending on Live 
Update setting

Manually preview (scrub) audio Ctrl-drag current-time 
indicator

Command-drag current-
time indicator

RAM preview number of frames specified 
by Alternate RAM Preview preference 
(defaults to 5)

Alt+0 on numeric 
keypad*

Option+0 on 
numeric keypad* or 
Control+Option+0 (zero) 
on main keyboard

Show current frame on video preview 
device

/ (on numeric keypad) / (on numeric keypad)

Toggle Output Device preference 
between Desktop Only and video preview 
device

Ctrl+/ 
(on numeric keypad)

Command+/ 
(on numeric keypad)

Take snapshot Shift+F5, Shift+F6, 
Shift+F7, or Shift+F8

Shift+F5, Shift+F6, 
Shift+F7, or Shift+F8

Display snapshot in active viewer F5, F6, F7, or F8 F5, F6, F7, or F8

Purge snapshot Ctrl+Shift+F5, 
Ctrl+Shift+F6, 
Ctrl+Shift+F7, or 
Ctrl+Shift+F8

Command+Shift+F5, 
Command+Shift+F6, 
Command+Shift+F7, or 
Command+Shift+F8

 Views

 COMMAND WINDOWS MAC OS 

Turn display color management on or off 
for active view

Shift+/ 
(on numeric keypad)

Shift+/ 
(on numeric keypad)

Show red, green, blue, or alpha channel as 
grayscale

Alt+1, Alt+2, Alt+3, Alt+4 Option+1, Option+2, 
Option+3, Option+4

Show colorized red, green, or blue 
channel

Alt+Shift+1, Alt+Shift+2, 
Alt+Shift+3

Option+Shift+1, 
Option+Shift+2, 
Option+Shift+3

Toggle showing straight RGB color Alt+Shift+4 Option+Shift+4

Show alpha boundary (outline between 
transparent and opaque regions) in Layer 
panel

Alt+5 Option+5

Show alpha overlay (colored overlay on 
transparent regions) in Layer panel

Alt+6 Option+6
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 COMMAND WINDOWS MAC OS 

Reset view in the Composition panel 
to 100% and center composition in the 
panel

Double-click Hand tool Double-click Hand tool

Zoom in in Composition, Layer, or 
Footage panel

. (period) on main 
keyboard

. (period) on main 
keyboard

Zoom out in Composition, Layer, or 
Footage panel

, (comma) , (comma)

Zoom to 100% in Composition, Layer, or 
Footage panel

/ (on main keyboard) / (on main keyboard) 

Zoom to fit in Composition, Layer, or 
Footage panel

Shift+/ (on main 
keyboard) 

Shift+/ 
(on main keyboard) 

Zoom up to 100% to fit in Composition, 
Layer, or Footage panel

Alt+/ 
(on main keyboard) 

Option+/ 
(on main keyboard)

Set resolution to Full, Half, or Custom in 
Composition panel

Ctrl+J, Ctrl+Shift+J, 
Ctrl+Alt+J

Command+J, 
Command+Shift+J, 
Command+Option+J

Open View Options dialog box for active 
Composition panel

Ctrl+Alt+U Command+Option+U

Zoom in time = (equal sign) on main 
keyboard

= (equal sign) on main 
keyboard

Zoom out time - (hyphen) on main 
keyboard

- (hyphen) on main 
keyboard

Zoom in Timeline panel to single-frame 
units (Press again to zoom out to show 
entire composition duration.)

; (semicolon) ; (semicolon)

Zoom out in Timeline panel to show the 
entire composition duration (Press again 
to zoom back in to the duration specified 
by the Time Navigator.)

Shift+; (semicolon) Shift+; (semicolon)

Suspend image updates Caps Lock Caps Lock

Show or hide safe zones ‘ (apostrophe) ‘ (apostrophe)

Show or hide grid Ctrl+’ (apostrophe) Command+’ 
(apostrophe)

Show or hide proportional grid Alt+’ (apostrophe) Option+’ (apostrophe)

Show or hide rulers Ctrl+R Command+R

Show or hide guides Ctrl+; (semicolon) Command+; (semicolon)
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 COMMAND WINDOWS MAC OS 

Turn snapping to grid on or off Ctrl+Shift+’ (apostrophe) Command+Shift+’ 
(apostrophe)

Turn snapping to guides on or off Ctrl+Shift+; (semicolon) Command+Shift+; 
(semicolon)

Lock or unlock guides Ctrl+Alt+Shift+; 
(semicolon)

Command+Option+
Shift+; (semicolon)

Show or hide layer controls Ctrl+Shift+H Command+Shift+H

 Footage

 COMMAND WINDOWS MAC OS 

Import one file or image sequence Ctrl+I Command+I

Import multiple files or image sequences Ctrl+Alt+I Command+Option+I

Open movie in an After Effects Footage 
panel

Alt-double-click Option-double-click

Add selected items to most recently 
activated composition

Ctrl+/ (on main 
keyboard)

Command+/ (on main 
keyboard)

Replace selected source footage for 
selected layers with footage item selected 
in Project panel

Ctrl+Alt+/ (on main 
keyboard)

Command+Option+/ (on 
main keyboard)

Replace source for a selected layer Alt-drag footage item 
from Project panel onto 
selected layer

Option-drag footage 
item from Project panel 
onto selected layer

Delete a footage item without a warning Ctrl+Backspace Command+Delete

Open Interpret Footage dialog box for 
selected footage item

Ctrl+Alt+G Command+Option+G

Remember footage interpretation Ctrl+Alt+C Command+Option+C

Edit selected footage item in application 
with which it’s associated (Edit Original)

Ctrl+E Command+E

Replace selected footage item Ctrl+H Command+H

Reload selected footage items Ctrl+Alt+L Command+Option+L

Set proxy for selected footage item Ctrl+Alt+P Command+Option+P
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 Effects and animation presets

 COMMAND WINDOWS MAC OS 

Delete all effects from selected layers Ctrl+Shift+E Command+Shift+E

Apply most recently applied effect to 
selected layers

Ctrl+Alt+Shift+E Command+Option+
Shift+E

Apply most recently applied animation 
preset to selected layers

Ctrl+Alt+Shift+F Command+Option+
Shift+F

 Layers

 COMMAND WINDOWS MAC OS 

New solid layer Ctrl+Y Command+Y

New null layer Ctrl+Alt+Shift+Y Command+Option+
Shift+Y

New adjustment layer Ctrl+Alt+Y Command+Option+Y

Select layer (1-999) by its number (enter 
digits rapidly for two-digit and three-digit 
numbers)

0-9 on numeric keypad* 0-9 on numeric keypad*

Toggle selection of layer (1-999) by its 
number (enter digits rapidly for two-digit 
and three-digit numbers)

Shift+0-9 on numeric 
keypad*

Shift+0-9 on numeric 
keypad*

Select next layer in stacking order Ctrl+Down Arrow Command+Down Arrow

Select previous layer in stacking order Ctrl+Up Arrow Command+Up Arrow

Extend selection to next layer in stacking 
order

Ctrl+Shift+Down Arrow Command+Shift+
Down Arrow

Extend selection to previous layer in 
stacking order

Ctrl+Shift+Up Arrow Command+Shift+
Up Arrow

Deselect all layers Ctrl+Shift+A Command+Shift+A

Scroll topmost selected layer to top of 
Timeline panel

X X

Show or hide Parent column Shift+F4 Shift+F4

Show or hide Layer Switches and Modes 
columns

F4 F4

Turn off all other solo switches Alt-click solo switch Option-click solo switch

Turn Video (eyeball) switch on or off for 
selected layers

Ctrl+Alt+Shift+V Command+Option+
Shift+V

Turn off Video switch for all video layers 
other than selected layers

Ctrl+Shift+V Command+Shift+V
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 COMMAND WINDOWS MAC OS 

Open settings dialog box for selected solid, 
light, camera, null, or adjustment layer

Ctrl+Shift+Y Command+Shift+Y

Paste layers at current time Ctrl+Alt+V Command+Option+V

Split selected layers (If no layers are 
selected, split all layers.)

Ctrl+Shift+D Command+Shift+D

Precompose selected layers Ctrl+Shift+C Command+Shift+C

Open Effect Controls panel for selected 
layers 

Ctrl+Shift+T Command+Shift+T

Open layer in Layer panel (opens source 
composition for precomposition layer in 
Composition panel)

Double-click a layer Double-click a layer

Open source of a layer in Footage panel 
(opens precomposition layer in Layer panel)

Alt-double-click a layer Option-double-click a 
layer

Reverse selected layers in time Ctrl+Alt+R Command+Option+R

Enable time remapping for selected layers Ctrl+Alt+T Command+Option+T

Move In point or Out point of selected 
layers to current time

[ (left bracket) or ] 
(right bracket)

[ (left bracket) or ] 
(right bracket)

Trim In point or Out point of selected 
layers to current time

Alt+[ (left bracket) or 
Alt+] (right bracket)

Option+[ (left bracket) or 
Option+] (right bracket)

Add or remove expression for a property Alt-click stopwatch Option-click stopwatch

Add an effect (or multiple selected 
effects) to selected layers

Double-click effect 
selection in Effects & 
Presets panel

Double-click effect 
selection in Effects & 
Presets panel

Set In point or Out point by 
time-stretching

Ctrl+Shift+, (comma) or 
Ctrl+Alt+, (comma)

Command+Shift+, 
(comma) or

Command+Option+, 
(comma)

Move In point of selected layers to 
beginning of composition

Alt+Home Option+Home

Move Out point of selected layers to end 
of composition

Alt+End Option+End

Lock selected layers Ctrl+L Command+L

Unlock all layers Ctrl+Shift+L Command+Shift+L

Set Quality to Best, Draft, or Wireframe for 
selected layers

Ctrl+U, Ctrl+Shift+U, or 
Ctrl+Alt+Shift+U

Command+U, 
Command+Shift+U,
Command+Option+

Shift+U
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 COMMAND WINDOWS MAC OS 

Cycle forward or backward through 
blending modes for selected layers

Shift+ - (hyphen) or 
Shift+= (equal sign) on 
the main keyboard

Shift+ - (hyphen) or 
Shift+= (equal sign) on 
the main keyboard

Find in Timeline panel Ctrl+F Command+F

 Showing properties and groups in the Timeline panel

 COMMAND WINDOWS MAC OS 

Find in Timeline panel Ctrl+F Command+F

Toggle expansion of selected layers to 
show all properties

Ctrl+̀  (accent grave) Command+̀  (accent 
grave)

Toggle expansion of property group 
and all child property groups to show all 
properties

Ctrl-click triangle to 
the left of the property 
group name

Command-click triangle 
to the left of the 
property group name

Show only Anchor Point property (for 
lights and cameras, Point Of Interest)

A A

Show only Audio Levels property L L

Show only Mask Feather property F F

Show only Mask Path property M M

Show only Mask Opacity property TT TT

Show only Opacity property (for lights, 
Intensity)

T T

Show only Position property P P

Show only Rotation and Orientation 
properties

R R

Show only Scale property S S

Show only Time Remap property RR RR

Show only instances of missing effects FF FF

Show only Effects property group E E

Show only mask property groups MM MM

Show only Material Options property 
group

AA AA

Show only expressions EE EE

Show only modified properties UU UU
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 COMMAND WINDOWS MAC OS 

Show only paint strokes, Roto Brush 
strokes, and Puppet pins

PP PP

Show only audio waveform LL LL

Show only properties with keyframes or 
expressions

U U

Show only selected properties and 
groups

SS SS

Hide property or group Alt+Shift-click property 
or group name

Option+Shift-click 
property or group name

Add or remove property or group from 
set that is shown

Shift+property or group 
shortcut

Shift+property or group 
shortcut

Add or remove keyframe at current time Alt+property shortcut Option+property 
shortcut

 Showing properties in the Effect Controls panel

 COMMAND WINDOWS MAC OS 

Toggle expansion of selected effects to 
show all properties

Ctrl+̀  (accent grave) Command+̀  (accent 
grave)

Toggle expansion of property group 
and all child property groups to show all 
properties

Ctrl-click triangle to 
the left of the property 
group name

Command-click triangle 
to the left of the 
property group name

 Modifying layer properties 

 COMMAND WINDOWS MAC OS 

Modify property value by default 
increments

Drag property value Drag property value

Modify property value by 10x default 
increments

Shift-drag property value Shift-drag property value

Modify property value by 1/10 default 
increments

Ctrl-drag property value Command-drag property 
value

Open Auto-Orientation dialog box for 
selected layers

Ctrl+Alt+O Command+Alt+O

Open Opacity dialog box for selected 
layers

Ctrl+Shift+O Command+Shift+O

Open Rotation dialog box for selected 
layers

Ctrl+Shift+R Command+Shift+R
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 COMMAND WINDOWS MAC OS 

Open Position dialog box for selected 
layers

Ctrl+Shift+P Command+Shift+P

Center selected layers in view (modifies 
Position property to place anchor points of 
selected layers in center of current view)

Ctrl+Home Command+Home

Move selected layers 1 pixel at current 
magnification (Position)

arrow key arrow key

Move selected layers 10 pixels at current 
magnification (Position)

Shift+arrow key Shift+arrow key

Move selected layers 1 frame earlier or 
later

Alt+Page Up or Alt+
Page Down

Option+Page Up or 
Option+Page Down

Move selected layers 10 frames earlier or 
later

Alt+Shift+Page Up or 
Alt+Shift+Page Down

Option+Shift+Page Up 
or Option+Shift+Page 
Down

Increase or decrease Rotation (Z Rotation) 
of selected layers by 1°

+ (plus) or - (minus) on 
numeric keypad

+ (plus) or - (minus) on 
numeric keypad

Increase or decrease Rotation (Z Rotation) 
of selected layers by 10°

Shift++ (plus) or Shift+- 
(minus) on numeric 
keypad

Shift++ (plus) or Shift+- 
(minus) on numeric 
keypad

Increase or decrease Opacity (or Intensity 
for light layers) of selected layers by 1%

Ctrl+Alt++ (plus) or 
Ctrl+Alt+- (minus) on 
numeric keypad

Control+Option++ (plus) 
or Control+Option+ - 
(minus) on numeric 
keypad

Increase or decrease Opacity (or Intensity 
for light layers) of selected layers by 10%

Ctrl+Alt+Shift++ (plus) or 
Ctrl+Alt+Shift+- (minus) 
on numeric keypad

Control+Option+Shift++ 
(plus) or 
Control+Option+Shift+- 
(minus) on numeric 
keypad

Increase Scale of selected layers by 1% Ctrl++ (plus) or Alt++ 
(plus) on numeric keypad

Command++ (plus) 
or Option++ (plus) on 
numeric keypad

Decrease Scale of selected layers by 1% Ctrl+- (minus) or Alt+- 
(minus) on numeric 
keypad

Command+- (minus) 
or Option+- (minus) on 
numeric keypad

Increase Scale of selected layers by 10% Ctrl+Shift++ (plus) or 
Alt+Shift++ (plus) on 
numeric keypad

Command+Shift++ (plus) 
or Option+Shift++ (plus) 
on numeric keypad

Decrease Scale of selected layers by 10% Ctrl+Shift+- (minus) or 
Alt+Shift+- (minus) on 
numeric keypad

Command+Shift+- 
(minus) or 
Option+Shift+- (minus) 
on numeric keypad
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 COMMAND WINDOWS MAC OS 

Modify Rotation or Orientation in 45° 
increments

Shift-drag with Rotation 
tool

Shift-drag with Rotation 
tool

Modify Scale, constrained to footage 
frame aspect ratio

Shift-drag layer handle 
with Selection tool

Shift-drag layer handle 
with Selection tool

Reset Rotation to 0° Double-click Rotation 
tool

Double-click Rotation 
tool

Reset Scale to 100% Double-click Selection 
tool

Double-click Selection 
tool

Scale and reposition selected layers to fit 
composition

Ctrl+Alt+F Command+Option+F

Scale and reposition selected layers to 
fit composition width, preserving image 
aspect ratio for each layer

Ctrl+Alt+Shift+H Command+Option+
Shift+H

Scale and reposition selected layers to fit 
composition height, preserving image 
aspect ratio for each layer

Ctrl+Alt+Shift+G Command+Option+
Shift+G

 3D layers

 COMMAND WINDOWS MAC OS 

Switch to 3D view 1 (defaults to Front) F10 F10

Switch to 3D view 2 
(defaults to Custom View 2)

F11 F11

Switch to 3D view 3 
(defaults to Active Camera)

F12 F12

Return to previous view Esc Esc

New light Ctrl+Alt+Shift+L Command+Option+
Shift+L

New camera Ctrl+Alt+Shift+C Command+Option+
Shift+C

Move the camera and its point of interest 
to look at selected 3D layers

Ctrl+Alt+Shift+\ Command+Option+
Shift+\

With a camera tool selected, move the 
camera and its point of interest to look at 
selected 3D layers

F F

With a camera tool selected, move the 
camera and its point of interest to look at 
all 3D layers

Ctrl+Shift+F Command+Shift+F

Turn Casts Shadows property on or off for 
selected 3D layers

Alt+Shift+C Option+Shift+C
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 Keyframes and the Graph Editor

 COMMAND WINDOWS MAC OS 

Toggle between Graph Editor and layer 
bar modes

Shift+F3 Shift+F3

Select all keyframes for a property Click property name Click property name

Select all visible keyframes and properties Ctrl+Alt+A Command+Option+A

Deselect all keyframes, properties, and 
property groups

Shift+F2 or 
Ctrl+Alt+Shift+A

Shift+F2 or 
Command+Option+

Shift+A

Move keyframe 1 frame later or earlier Alt+Right Arrow or 
Alt+Left Arrow

Option+Right Arrow or 
Option+Left Arrow

Move keyframe 10 frames later or earlier Alt+Shift+Right Arrow or 
Alt+Shift+Left Arrow

Option+Shift+
Right Arrow or 

Option+Shift+Left Arrow

Set interpolation for selected keyframes 
(layer bar mode)

Ctrl+Alt+K Command+Option+K

Set keyframe interpolation method to 
hold or Auto Bézier

Ctrl+Alt+H Command+Option+H

Set keyframe interpolation method to 
linear or Auto Bézier

Ctrl-click in layer bar 
mode

Command-click in layer 
bar mode

Set keyframe interpolation method to 
linear or hold

Ctrl+Alt-click in layer bar 
mode

Command+Option-click 
in layer bar mode

Easy ease selected keyframes F9 F9

Easy ease selected keyframes in Shift+F9 Shift+F9

Easy ease selected keyframes out Ctrl+Shift+F9 Command+Shift+F9

Set velocity for selected keyframes Ctrl+Shift+K Command+Shift+K

Add or remove keyframe at current time Alt+property shortcut Option+property 
shortcut
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 Text 

 COMMAND WINDOWS MAC OS 

New text layer Ctrl+Alt+Shift+T Command+Option+
Shift+T

Align selected horizontal text left, center, 
or right

Ctrl+Shift+L, 
Ctrl+Shift+C, or 
Ctrl+Shift+R

Command+Shift+L, 
Command+Shift+C, or 
Command+Shift+R

Align selected vertical text top, center, or 
bottom

Ctrl+Shift+L, 
Ctrl+Shift+C, or 
Ctrl+Shift+R

Command+Shift+L, 
Command+Shift+C, or 
Command+Shift+R

Extend or reduce selection by one 
character to right or left in horizontal text

Shift+Right Arrow or 
Shift+Left Arrow

Shift+Right Arrow or 
Shift+Left Arrow

Extend or reduce selection by one word 
to right or left in horizontal text

Ctrl+Shift+Right Arrow or 
Ctrl+Shift+Left Arrow

Command+Shift+
Right Arrow or

Command+Shift+
Left Arrow

Extend or reduce selection by one line up 
or down in horizontal text

Shift+Up Arrow or 
Shift+Down Arrow

Shift+Up Arrow or 
Shift+Down Arrow

Extend or reduce selection by one line to 
right or left in vertical text

Shift+Right Arrow or 
Shift+Left Arrow

Shift+Right Arrow or 
Shift+Left Arrow

Extend or reduce selection one word up 
or down in vertical text

Ctrl+Shift+Up Arrow or 
Ctrl+Shift+Down Arrow

Command+Shift+
Up Arrow or 

Command+Shift+Down 
Arrow

Extend or reduce selection by one 
character up or down in vertical text

Shift+Up Arrow or 
Shift+Down Arrow

Shift+Up Arrow or 
Shift+Down Arrow

Select text from insertion point to 
beginning or end of line

Shift+Home or Shift+End Shift+Home or Shift+End

Move insertion point to beginning or end 
of line

Home or End Home or End

Select all text on a layer Double-click text layer Double-click text layer

Select text from insertion point to 
beginning or end of text frame

Ctrl+Shift+Home or 
Ctrl+Shift+End

Command+Shift+Home 
or Command+Shift+End

Select text from insertion point to mouse 
click point

Shift-click Shift-click
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 COMMAND WINDOWS MAC OS 

In horizontal text, move insertion point 
one character left or right; one line up 
or down; one word left or right; or one 
paragraph up or down

Left Arrow or Right 
Arrow; Up Arrow or 
Down Arrow; Ctrl+Left 
Arrow or Ctrl+Right 
Arrow; or Ctrl+Up Arrow 
or Ctrl+Down Arrow

Left Arrow or Right Arrow; 
Up Arrow or Down Arrow; 
Command+Left Arrow or 
Command+Right Arrow; 
or Command+Up Arrow 
or Command+Down 
Arrow

In vertical text, move insertion point 
one character up or down; one left or 
right; one word up or down; or one 
paragraph left or right

Up Arrow or Down 
Arrow; Left Arrow or 
Right Arrow; Ctrl+Up 
Arrow or Ctrl+Down 
Arrow; or Ctrl+Left Arrow 
or Ctrl+Right Arrow

Up Arrow or Down 
Arrow; Left Arrow or 
Right Arrow; Command+
Up Arrow or Command+
Down Arrow; or 
Command+Left Arrow or 
Command+Right Arrow

Select word, line, paragraph, or entire text 
frame

Double-click, triple-
click, quadruple-click, or 
quintuple-click with Type 
tool

Double-click, triple-
click, quadruple-click, or 
quintuple-click with Type 
tool

Turn All Caps on or off for selected text Ctrl+Shift+K Command+Shift+K

Turn Small Caps on or off for selected text Ctrl+Alt+Shift+K Command+Option+
Shift+K

Turn Superscript on or off for selected text Ctrl+Shift+= (equals) Command+Shift+= 
(equals)

Turn Subscript on or off for selected text Ctrl+Alt+Shift+= (equals) Command+Option+
Shift+= (equals)

Set horizontal scale to 100% for selected 
text

Ctrl+Shift+X Command+Shift+X

Set vertical scale to 100% for selected text Ctrl+Alt+Shift+X Command+Option+
Shift+X

Auto leading for selected text Ctrl+Alt+Shift+A Command+Option+
Shift+A

Reset tracking to 0 for selected text Ctrl+Shift+Q Command+Shift+
Control+Q

Justify paragraph; left align last line Ctrl+Shift+J Command+Shift+J

Justify paragraph; right align last line Ctrl+Alt+Shift+J Command+Option+
Shift+J

Justify paragraph; force last line Ctrl+Shift+F Command+Shift+F
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 COMMAND WINDOWS MAC OS 

Decrease or increase font size of selected 
text by 2 units

Ctrl+Shift+, (comma) or 
Ctrl+Shift+. (period)

Command+Shift+, 
(comma) or 

Command+Shift+. 
(period)

Decrease or increase font size of selected 
text by 10 units

Ctrl+Alt+Shift+, (comma) 
or Ctrl+Alt+Shift+. 
(period)

Command+Option+
Shift+, (comma) or

Command+Option+
Shift+. (period)

Increase or decrease leading by 2 units Alt+Down Arrow or 
Alt+Up Arrow

Option+Down Arrow or 
Option+Up Arrow

Increase or decrease leading by 10 units Ctrl+Alt+Down Arrow or 
Ctrl+Alt+Up Arrow

Command+Option+
Down Arrow or 

Command+Option+Up 
Arrow

Decrease or increase baseline shift by 
2 units

Alt+Shift+Down Arrow or 
Alt+Shift+Up Arrow

Option+Shift+
Down Arrow or

Option+Shift+Up Arrow

Decrease or increase baseline shift by 
10 units

Ctrl+Alt+Shift+
Down Arrow or 

Ctrl+Alt+Shift+Up Arrow

Command+Option+
Shift+Down Arrow or 

Command+Option+
Shift+Up Arrow

Decrease or increase kerning or tracking 
20 units (20/1000 ems)

Alt+Left Arrow or
Alt+Right Arrow

Option+Left Arrow or 
Option+Right Arrow

Decrease or increase kerning or tracking 
100 units (100/1000 ems)

Ctrl+Alt+Left Arrow or 
Ctrl+Alt+Right Arrow

Command+Option+Left 
Arrow or 
Command+Option+
Right Arrow

Toggle paragraph composer Ctrl+Alt+Shift+T Command+Option+
Shift+T
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Working with Masks

 COMMAND WINDOWS MAC OS 

New mask Ctrl+Shift+N Command+Shift+N

Select all points in a mask Alt-click mask Option-click mask

Select next or previous mask Alt+̀  (accent grave) or 
Alt+Shift+̀  (accent grave)

Option+̀  (accent grave) 
or Option+Shift+̀  (accent 
grave)

Enter free-transform mask editing mode Double-click mask with 
Selection tool or select 
mask in Timeline panel 
and press Ctrl+T

Double-click mask with 
Selection tool or select 
mask in Timeline panel 
and press Command+T

Exit free-transform mask editing mode Esc Esc

Scale around center point in Free 
Transform mode

Ctrl-drag Command-drag

Move selected path points 1 pixel at 
current magnification

arrow key arrow key

Move selected path points 10 pixels at 
current magnification

Shift+arrow key Shift+arrow key

Toggle between smooth and corner 
points

Ctrl+Alt-click vertex Command+Option-
click vertex 

Redraw Bézier handles Ctrl+Alt-drag vertex Command+Option-
drag vertex 

Invert selected mask Ctrl+Shift+I Command+Shift+I

Open Mask Feather dialog box for 
selected mask

Ctrl+Shift+F Command+Shift+F

Open Mask Shape dialog box for 
selected mask

Ctrl+Shift+M Command+Shift+M

 Paint tools

 COMMAND WINDOWS MAC OS 

Swap paint background color and 
foreground colors

X X

Set paint foreground color to black and 
background color to white

D D

Set foreground color to the color 
currently under any paint tool pointer

Alt-click Option-click
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 COMMAND WINDOWS MAC OS 

Set foreground color to the average color 
of a 4-pixel x 4-pixel area under any paint 
tool pointer

Ctrl+Alt-click Command+Option-click

Set brush size for a paint tool Ctrl-drag Command-drag

Set brush hardness for a paint tool Ctrl-drag, then release 
Ctrl while dragging

Command-drag, then 
release Command while 
dragging

Join current paint stroke to the previous 
stroke

Hold Shift while 
beginning stroke

Hold Shift while 
beginning stroke

Set starting sample point to point 
currently under Clone Stamp tool pointer

Alt-click Option-click

Momentarily activate Eraser tool with Last 
Stroke Only option

Ctrl+Shift Command+Shift

Show and move overlay. (Change 
Offset value of aligned Clone Stamp 
tool or change Source Position value of 
unaligned Clone Stamp tool.)

Alt+Shift-drag with 
Clone Stamp tool

Option+Shift-drag with 
Clone Stamp tool

Activate a specific Clone Stamp tool 
preset

3, 4, 5, 6, or 7 on the main 
keyboard

3, 4, 5, 6, or 7 on the main 
keyboard

Duplicate a Clone Stamp tool preset in 
Paint panel

Alt-click the button for 
the preset

Option-click the button 
for the preset

Set opacity for a paint tool Digit on numeric keypad 
(for example, 9=90%, 
1=10%)*

Digit on numeric keypad 
(for example, 9=90%, 
1=10%)*

Set opacity for a paint tool to 100% . (decimal) on numeric 
keypad*

. (decimal) on numeric 
keypad*

Set flow for a paint tool Shift+a digit on numeric 
keypad (for example, 
9=90%, 1=10%)*

Shift+a digit on numeric 
keypad (for example, 
9=90%, 1=10%)*

Set flow for a paint tool to 100% Shift+. (decimal) on 
numeric keypad*

Shift+. (decimal) on 
numeric keypad*

Move earlier or later by number of frames 
specified for stroke Duration

Ctrl+Page Up or 
Ctrl+Page Down (or 1 or 
2 on the main keyboard)

Command+Page Up or 
Command+Page Down 
(or 1 or 2 on the main 
keyboard
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 Shape layers

 COMMAND WINDOWS MAC OS 

Group selected shapes Ctrl+G Command+G

Ungroup selected shapes Ctrl+Shift+G Command+Shift+G

Enter free-transform path editing mode Select Path property in 
Timeline panel and press 
Ctrl+T

Select Path property in 
Timeline panel and press 
Command+T

Increase star inner roundness Page Up when dragging 
to create shape

Page Up when dragging 
to create shape

Decrease star inner roundness Page Down when 
dragging to create shape

Page Down when 
dragging to create shape

Increase number of points for star or 
polygon; increase roundness for rounded 
rectangle

Up Arrow when dragging 
to create shape

Up Arrow when dragging 
to create shape

Decrease number of points for star or 
polygon; decrease roundness for rounded 
rectangle

Down Arrow when 
dragging to create shape

Down Arrow when 
dragging to create shape

Reposition shape during creation Hold spacebar when 
dragging to create shape

Hold spacebar when 
dragging to create shape

Set rounded rectangle roundness to 0 
(sharp corners); decrease polygon and 
star outer roundness

Left Arrow when 
dragging to create shape

Left Arrow when 
dragging to create shape

Set rounded rectangle roundness to 
maximum; increase polygon and star 
outer roundness

Right Arrow when 
dragging to create shape

Right Arrow when 
dragging to create shape

Constrain rectangles to squares; constrain 
ellipses to circles; constrain polygons and 
stars to zero rotation

Shift when dragging to 
create shape

Shift when dragging to 
create shape

Change outer radius of star Ctrl when dragging to 
create shape

Command when 
dragging to create shape
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 Markers

 COMMAND WINDOWS MAC OS 

Set marker at current time (works during 
RAM preview and audio-only preview)

* (multiply) on numeric 
keypad

* (multiply) on numeric 
keypad or Control+8 on 
main keyboard

Set marker at current time and open 
marker dialog box

Alt+* (multiply) on 
numeric keypad

Option+* (multiply) 
on numeric keypad or 
Control+Option+8 on 
main keyboard

Set and number a composition marker 
(0–9) at the current time

Shift+0–9 on main 
keyboard

Shift+0–9 on main 
keyboard

Go to a composition marker (0–9) 0–9 on main keyboard 0–9 on main keyboard

Display the duration between two layer 
markers or keyframes in the Info panel

Alt-click the markers or 
keyframes

Option-click the markers 
or keyframes

Remove marker Ctrl-click marker Command-click marker

 Motion tracking 

 COMMAND WINDOWS MAC OS 

Move feature region, search region, 
and attach point 1 pixel at current 
magnification

arrow key arrow key

Move feature region, search region, 
and attach point 10 pixels at current 
magnification

Shift+arrow key Shift+arrow key

Move feature region and search region 
1 pixel at current magnification

Alt+arrow key Option+arrow key

Move feature region and search region 
10 pixels at current magnification

Alt+Shift+arrow key Option+Shift+arrow key
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 Saving, exporting, and rendering

 COMMAND WINDOWS MAC OS 

Save project Ctrl+S Command+S

Increment and save project Ctrl+Alt+Shift+S Command+Option+
Shift+S

Save As Ctrl+Shift+S Command+Shift+S

Add active composition or selected items 
to render queue

Ctrl+Shift+/ (on main 
keyboard)

Command+Shift+/ (on 
main keyboard)

Add current frame to render queue Ctrl+Alt+S Command+Option+S

Duplicate render item with same output 
filename as original

Ctrl+Shift+D Command+Shift+D
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After Eff ects secondary panels
In Lesson 2, “Understanding the After Eff ects Interface,” the primary panels of After 
Eff ects are introduced in detail. This appendix is presented to provide reference of the 
remaining panels with which you may need to work.

Align
You use the Align panel to quickly align and distribute selected layers in your composition. 
The align commands line up selected layers in your composition either horizontally or 
vertically, while you use the distribute commands to even out the spacing between the 
anchor points of your layers. In order to use the Align commands, two or more layers must 
be selected, while to use the Distribute commands three or more layers must be selected.

The Align panel.

Audio (Ctrl + 4)
You use the Audio panel to display and adjust the volume of audio in your composition. 
During previews, the panel’s VU (Volume Unit) meter dynamically displays the changing 
volume in your composition.

The Audio panel.
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Brushes (Ctrl + 9) 
When using a Paint tool (Brush, Clone Stamp, or Eraser), you can use the Brushes panel 
to set the brush tip shape, diameter, roundness, angle, hardness, and dynamic options. 
Brushes in After Eff ects are vector based and their shapes can be animated as an eff ect. 

The Brushes panel.

Character and Paragraph
When working with text, the Character panel sets the properties of individual characters 
such as font, style, size, and tracking. The Paragraph panel sets the properties such as 
text alignment, indentation, and the space before and after each paragraph. Text in After 
Eff ects is very similar to the way you work with text in Illustrator, Photoshop or InDesign. 

The Character and Paragraph panels.
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Eff ects & Presets
The Eff ects & Presets panel is a library for both the built-in and add-on eff ects that 
are currently installed on your system. This panel also displays both the pre-installed 
animation presets and any custom presets that you have created. You can apply both eff ects 
and presets to layers in your composition from this panel either by dragging and dropping 
the preset name onto a destination layer or by double-clicking on the preset with a target 
layer highlighted in the Timeline panel.

The Eff ects and Preset panel.

Info
Similar to the standard Info panel in other Adobe applications, (Illustrator, Photoshop, 
InDesign) this panel tells you the color value (RGBA) at the cursor’s current position, as 
well as the coordinates of its current position. If you have a footage item highlighted, the 
Info panel displays its name and other related information.

The Info panel.
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Mask Interpolation
The Mask Interpolation panel allows you to automatically create new mask keyframes and 
speed the animation of mask shapes. This interpolation provides a high level of control 
for creating animation of mask path keyframes that have smooth and realistic motion. 
After you have selected the mask path keyframes that you want to interpolate, the mask 
interpolation panel is used to create intermediate keyframes based on the settings you 
specify.

The Mask Interpolation panel.

Metadata
In addition to the normal, audio-visual information that a media fi le can contain, some fi le 
types can also have metadata attached to them. This metadata can hold information about 
the type of camera that took a photograph, or perhaps hold Timeline markers for video or 
audio. The Metadata panel allows you to view the metadata associated with imported fi les.

The Metadata panel.
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Motion Sketch
The Motion Sketch panel gives you a more intuitive way to create animation by using 
your mouse or graphic tablet to draw a path for motion. It allows you to quickly create 
very complex and detailed motion animations. Many After Eff ects artists fi nd it benefi cial 
to use this panel to create motion paths that are natural or fl uid. 

The Motion Sketch panel.

Paint
When working with the Paint tools (Brush, Clone Stamp, and Eraser), you can use the 
Paint panel to set the color of the brush, as well as its other properties, such as opacity, 
mode, and duration. The controls of the Paint panel are similar to those found in other 
painting programs such as Photoshop and can be used to vary the appearance of painted 
strokes.

The Paint panel.
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Tools
The Tools panel contains the various tools that you use in After Eff ects. Each tool 
performs a specifi c function, such as moving or rotating objects or creating shapes and 
masks.

The Tools panel.

Preview
You use the Preview panel to control the playback and options of both Timeline and 
RAM previews. You can use the transport controls to move the position playhead around 
the Timeline or to initiate previews, while the switches control playback options, such as 
frame rate and resolution.

The Preview panel.
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Smoother
You use the Smoother panel to adjust an animation by reducing the number of keyframes 
for a selected property. Removing extraneous keyframes based on the tolerance setting 
(use a higher value for greater smoothing) produces a softer animation. You can apply 
the eff ects to either a spatial property, such as position or a temporal one such as scale or 
opacity. 

The Smoother panel.

Tracker
The Tracker panel contains the tools for both tracking and stabilizing video footage. 
Both tracking and stabilization work by analyzing the position of pixels on the screen and 
repurposing that information to either determine how the camera that took the footage 
was moving, or follow the movement of a point in the footage.

The Tracker panel.
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Wiggler
The Wiggler panel performs the opposite function of Smoother. Instead of reducing 
the number of keyframes for a property, the Wiggler increases the number based on 
the frequency and magnitude settings that you input. You can use the Wiggler to add 
randomness and frenetic motion to animations.

The Wiggler panel.
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Importable media formats
Some After Eff ects artists only work with one type of media; for example, they may 
specialize in animating still images built in Photoshop or Illustrator. But most users will 
be called upon to handle a wide variety of diff erent media, and thanks to the integrated 
environment of the Adobe Creative Suite, this is easier than ever. Most standard and many 
esoteric media types can be imported into After Eff ects. 

Video and audio
Prerecorded video and audio media are often imported into After Eff ects for enhancement 
or to be used to accompany an animation. You can import video fi les, video fi les that 
contain audio, or audio fi les independently. 

After Eff ects CS6 supports importing the video formats in the following table.

FILE FORMATS FILE TYPE EXTENSION NOTES

Animated GIF GIF

DV MOV, AVI, DV DV footage can be in either an 
MOV or AVI container, or the 
DV stream format.

Electric Image IMG, EI EIZ files are also supported.

Material eXchange Format MXF After Effects can only import 
some kinds of data contained 
within MXF files.

MPEG-1, MPEG-2, and MPEG-4 MPEG, MPE, MPG, M2V, MPA, 
MP2, M2A, MPV, M2P, M2T, 
M2TS (AVCHD), AC3, MP4, M4V, 
M4A

Some MPEG formats are stored 
inside container formats with 
file extensions that After 
Effects cannot understand, 
such as VOB. In some cases, 
merely replacing these 
extensions with one of the 
recognized extensions can 
help.

Photoshop Document PSD Importing PSD video layers 
requires that the QuickTime 
Player be installed on your 
computer.
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FILE FORMATS FILE TYPE EXTENSION NOTES

QuickTime MOV The QuickTime Player is 
required.

RED R3D

Flash Movie SWF The SWF file’s alpha channel is 
retained, though its audio and 
interactive content are not.

Video for Windows AVI The QuickTime Player is 
required for Mac OS.

Windows Media File WMV, WMA, ASF This can only be imported into 
the Windows version of After 
Effects.

XDCAM HD and XDCAM EX Uses either MPEG-2 or MPEG-4 
file extensions.

After Eff ects CS6 supports importing the audio formats in the following table.

FILE FORMATS FILE TYPE EXTENSION NOTES

Adobe Sound Document ASND Multi-track files are imported 
as a single, merged track.

Advanced Audio Coding AAC, M4A

Audio Interchange File Format AIF, AIFF

MP3 MP3, MPEG, MPG, MPA, MPE

Windows Waveform WAV
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Still images and image sequences
You can import individual still images into Adobe After Eff ects or import a sequentially 
numbered group of images as a sequence. The After Eff ects environment uses only the RGB 
color space, though it will convert CMYK images to RGB on import. When working with 
programs such as Photoshop and Illustrator, it is always best to create images in the RGB 
color mode for use in video, fi lm, mobile devices, and other non-print based displays.

After Eff ects CS6 supports importing the image formats in the following table.

FILE FORMATS FILE TYPE EXTENSION NOTES

Adobe Illustrator AI, AI4, AI5, EPS

Adobe PDF PDF Only the first page of 
multipage PDF files is 
imported.

Adobe Photoshop PSD PSD Video and 3D layers are 
supported.

Bitmap BMP, RLE, DIB

Camera Raw TIF, CRW, NEF, RAF, ORF, MRW, 
DCR, MOS, RAW, PEF, SRF, DNG, 
X3F, CR2, ERF

Cineon/DPX CIN, DPX

Discreet RLA/RPF RLA, RPF Embedded camera data is 
imported.

Encapsulated PostScript EPS

Joint Photographic Experts 
Group

JPG, JPEG

Maya camera data and Maya 
IFF

MA and IFF, TDI

OpenEXR EXR, SXR, MXR

PICT PCT

Portable Network Graphics PNG

Silicon Graphics Image SGI, BW, RGB

Tagged Image File Format TIFF, TIF
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Project formats
In addition to still images, video, and audio fi les, you can import a select number of native 
project fi les into After Eff ects CS6 from applications such as older versions of After Eff ects, 
Premiere Pro, and Apple Motion.

PROJECT FORMATS FILE TYPE EXTENSION NOTES

Adobe Premiere Pro PRPROJ Versions supported: 1.0, 1.5, 
2.0, CS3, CS4, CS5. Versions 1.0, 
1.5, and 2.0, Windows only

Adobe After Effects 6.0 and 
later

AEP, AET

Adobe After Effects CS4 and 
later XML projects

AEPX

Photoshop Vanishing Point 
Data

VPE

Apple Motion Project MOTN Imports as a QuickTime 
file with an alpha channel 
premultiplied with black.
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Understanding formats and codecs
There is a great deal of confusion among novice video makers about the diff erences 
between codecs and video formats. Most computer users are probably familiar with the 
term format when used to describe fi les. If you come from a design background, you are 
probably used to dealing with fi les of diff erent formats such as JPEG or TIFF, and even 
casual computer users may be familiar with formats such as Word DOC or PowerPoint 
PPT fi les. However, when working with video, understanding the format isn’t enough. 
Video formats such as QuickTime, AVI, Windows Media Video, and Flash Video are 
containers, much like a briefcase or a backpack that is fi lled with content. This is the 
relationship between formats and codecs: formats are the containers but the codecs are the 
language in which the contents are written.

Codec is a combination of the words “compressor” and “decompressor.” Codecs are 
mathematical algorithms that are used to shrink audio and video fi les down to manageable 
sizes. It is important to understand that video fi les are very large; for example, 20 minutes 
of NTSC DV video (from a standard-defi nition MiniDV camcorder) are over 4GB in size. 
That is about the capacity of one single-layer DVD. Without codecs, not only would it be 
much harder to store and save video footage that you want to archive, but it would also 
never be small enough to watch online, send through e-mail, or view on a mobile device. 
In order to view an audio or video fi le, not only must you have a player that is compatible 
with the format, but you must also have the same codec that was used to compress it, 
available on your computer so that you can decompress it. 

Here is a quick scenario: your friend shoots a short video of his dog doing a back fl ip. He 
edits it a little, maybe adds some background music and sound eff ects, and then creates a 
QuickTime movie using the H.264 codec and e-mails it to you. In order to view your 
friend’s video of the wonder dog, you open the movie in the latest version of QuickTime 
Player or VLC Media Player or one of several other media players that support QuickTime 
fi les, and it plays. No fuss; it just works. Now most people never actually think about 
why it works, they’re just happy and sometimes surprised that it does. The reason it works 
is because not only do you have a player that is compatible with the QuickTime Movie 
format, but you also have the H.264 codec installed. 

When working with video editing and animation programs, there are times when a 
format incompatibility will cause a problem where you can’t import a specifi c fi le type, but 
very often problems are caused by a codec that is either missing or unsupported by your 
software. 
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Understanding bit rate
Storing video takes up a lot of space on your hard drive, considerably more than text, 
images, or even audio fi les. If you tried to take these massive fi les and display them on 
the Internet or e-mail them to someone, it would never work, and this is the reason that 
codecs are used to shrink fi les. In general, there are two types of codecs: those that are 
intended for editing purposes and those that are intended to be used as a fi nal delivery 
format.

When determining the quality of a digital video fi le, a major factor to consider is the 
fi le’s bit rate. Bit rate is the amount of data that is allocated to each second of video. 
Usually the bit rate value is displayed as kbps (kilobytes per second); for example, the 
average bit rate of DVD video is 25,000 kbps. In general, the higher the bit rate of a 
video fi le, the better its quality will be. To get an idea of comparative bit rates, standard-
defi nition DV 25 (MiniDV) footage is approximately 25,000 kbps, while DVD-quality 
video is approximately 5,000 kbps, and if you can recall videotapes, VHS has a bit rate of 
approximately 1,200 kbps. Understanding the relationship between a fi le’s bit rate and its 
quality is important when choosing the export settings for your video project.

Understanding spatial and temporal compression
There are two types of compression that video codecs can use to shrink the size of 
fi les: spatial and temporal. While some codec use only one or the other, most use both 
compression types to reduce audio and video fi les to manageable sizes, thus allowing them 
to be easily shared.

Spatial compression is the easiest to understand because it is very similar to the 
compression used in image formats such as JPEG and GIF. This image compression is 
usually lossy, works on each frame in a video fi le individually, and is sometimes called 
intraframe compression. Another very powerful method of compression is called temporal 
or interframe compression. This type of compression compares each video frame to the 
one previous to it and only saves the data describing what has changed between them. 
This type of compression can experience problems if the original frames are removed or 
damaged.

All codecs employ one type of compression or the other, and many employ both methods. 
Codecs that only use spatial compression, such as the DV codec, are usually preferable for 
editing as each frame can stand alone. Codecs that employ temporal compression such 
as MPEG-2 tend to off er better compression ratios, but because of the interrelationship 
between frames, they can be problematic for editing.
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Understanding video displays
When shooting and displaying your video or when preparing your graphics, there are a 
few very important concepts you need to keep in mind:

What is the aspect ratio of your video?

What is the pixel aspect ratio of your video?

Will the video be displayed on an interlaced device or a progressive one?

Asking these questions before you begin your production will save time and eff ort when 
you are in the post production stage of editing, compositing, and graphics creation. It will 
also avoid sometimes time-consuming errors that can occur when you output your fi nal 
projects.

Understanding aspect ratio and pixel aspect ratio

4:3 3:2 16:9 1.85:1 2.39:1

Diff erences in the aspect ratio of fi lm and television are what cause letterboxing when 
fi lms are shown on televisions.

Aspect ratio and pixel aspect ratio (called PAR) are two terms that can cause some 
confusion and frustration when working with video formats. The aspect ratio, also called 
image aspect ratio, is the proportion of the width of an image to its height. Usually 
this value is expressed as two numbers separated by a colon, as in 4:3 or 1.85:1, though 
sometimes it is referred to using more generic terms such as standard and widescreen 
mode. In videography, the two most common aspect ratios are 4:3 (sometimes denoted 
as 1.33:1) for standard-defi nition display and 16:9 (sometimes denoted as 1.78:1) for 
widescreen or high-defi nition formats. Film uses diff erent aspect ratios than video and 
broadcast television, two notable ones being 1.85:1 and 2.39:1, to accommodate a wider 
vista and to better mimic human vision.
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The diff erences in aspect ratio usually become apparent when video is displayed on 
a television screen with an aspect ratio diff erent from that of the actual video. When 
displayed on a 4:3 television or computer monitor, widescreen video (16:9, 1.85:1, 
2.39:1) such as that created when a fi lm is transferred to DVD, is usually displayed at 
the full width of the screen with two black boxes at the top and bottom in a technique 
called letterboxing. Footage that is created using a 4:3 aspect ratio and then displayed 
on a widescreen device can appear with black bars to each side in a technique called 
pillarboxing. It is possible for a video image to be displayed with simultaneous letter- and 
pillarboxing, in a situation called windowboxing.

PillarboxingLetterboxing

Pillarboxing is caused when 4:3 footage is shown on a widescreen device.

Often confused with aspect ratio, pixel aspect ratio is the proportion of the width of the 
pixels that make up a video or still image to their height. While many people know that 
a pixel is the smallest individual unit of a digital image, they sometimes don’t realize that 
pixels can be diff erent shapes and sizes. The pixels used by a computer monitor are square 
in shape and have a pixel aspect ratio (par) of 1:1 (1.0), while many of the standard video 
formats have rectangular pixels; for example, standard defi nition D1/DV NTSC footage 
has a par of 0.9:1 (.9), widescreen NTSC footage has a par of 1.21:1 (1.21), and high-
defi nition HDV 1080 and DVCPRO HD 720 have a par of 1.33:1 (1.33).

Square Pixel

1.0

D1/DV NTSC

0.91 2.0

Anamorphic
2.1

1.21

D1/DV NTSC 
Widescreen

1.33

HDV 1080/DVCPRO 
HD 720

1.5

DVCPRO HD 1080

1.0

Pixel Aspect ratio distortion can cause video or graphics to seem stretched.
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After Eff ects usually does a good job of mixing diff erent types of source footage, though 
distortion can occur if the wrong par interpretation is used. When footage is interpreted 
incorrectly, it can appear either squashed or stretched, causing circular objects on-screen to 
appear as ovals. Graphics programs such as Photoshop can only create content using square 
pixels but they have presets and previewing modes for video projects that provide a good 
representation of what your graphics will look like when displayed on a television monitor. 
When creating graphics in Photoshop and Illustrator, it is always best to use their provided 
video presets and choose the one that matches your After Eff ects project.

To change the pixel aspect ratio interpretation of a footage item, right-click on the item in the 
Project panel and choose File > Interpret Footage > Main. Choose the correct ratio from the 
Pixel Aspect Ratio menu and click OK.

Progressive display versus interlacing

1
2
3
4
5
6
7
8
9

10

1
2
3
4
5
6
7
8
9

10

Progressive Display Interlacing

All video signals, whether broadcast or not, are either sent as a progressive or an 
interlaced signal.

Progressive display and interlacing are the two methods of displaying images on a video 
screen. In the United States, prior to the changeover to a digital broadcasting system, all 
television was sent as an interlaced signal in which every frame of video was actually made 
by combining two half-images called fi elds. Prior to the days of high-defi nition LCD and 
plasma screens, all televisions were made by wrapping a plastic or wooden frame around 
a large glass device called a cathode ray tube (CRT). These CRT television screens were 
made up of a series of even- and odd-numbered lines called scan lines, and each frame of 
video was displayed by illuminating these lines starting at the top of the screen. Interlacing 
was created to display video signals on this type of TV set and worked by illuminating 
one set (either the even- or odd-numbered) of lines fi rst and then jumping back up to the 
top of the display to illuminate the other set. By the time the fi rst set of lines began to 
fade, the display was already showing the second set, and the result formed one complete 
picture for the viewer. With NTSC broadcast television, this process happened 60 times 
per second. An alternative to interlacing, progressive display illuminates these scan lines 
sequentially, one after the other, from top to bottom.
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Most modern televisions have the ability to display in both interlaced and progressive 
modes, and the ATSC includes broadcast standards for both, while all computer monitors 
use progressive display only. The diff erence between the two display methods carries 
over into video camera formats as well; while older NTSC or PAL cameras can only 
shoot interlaced video, many newer cameras off er a choice between both interlaced and 
progressive shooting modes such as 50i (25 fps), 60i (30 fps), 30p (30 fps), and 24p (24 fps). 
When working in After Eff ects, you will want to use project settings that match your 
intended output medium.
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A
Acceleration, 309–314
Accepts Lights option, 247
Accepts Shadows option, 247
Action-Safe margin, 177
Activating tools, keyboard shortcuts, 

382
Active Camera, 245, 263–264
Add or Remove Keyframe at Current 

Time button, 105, 199
Add property, of masks, 130
Add/Remove Keyframe switch, 140
Adjustment Layers, 89, 92
Adobe After Eff ects 10.0 MC Prefs, 3
Adobe After Eff ects CS4 project 

formats, 414
Adobe Bridge, 195–196
Adobe Creative Suite, 213
Adobe Dynamic Link, 371
Adobe Exchange, 351
Adobe ExtendScript, 350
Adobe Flash Movie, 412
Adobe Flash Player

Flash video, 14–15
Viewing video tutorials with, 7

Adobe Flash Professional, 370
Adobe Illustrator

Anchor point, 129
Compositions, importing of, 83–84
Description of, 15
File extensions, 413
Importing fi les, 62–65
Vector paths, 137

Adobe Marketplace & Exchange, 201
Adobe PDF, 413
Adobe Photoshop CS6

Anchor point, 129
Compositions, importing of, 83–84
Description of, 15
File extensions, 62, 411–412
Importing fi les, 62–65
Track mattes created from animated 

fi les, 159–162
Vanishing Point Data, 414

Adobe Premiere, 46
Adobe Premiere Pro, 325, 358, 371, 414
Adobe Soundbooth, 213
Adobe Sound Document, 412
Adobe User to User Forums, 341, 351
Advanced Audio Coding, 412
Advanced Television Systems 

Committee. see ATSC
AE Enhancers, 341, 351
AE Scripts, 351
.ai, 62
Align panel, 36–37, 403
All Transform Properties, 192
Alpha, 22–23, 29, 157. see also 

Transparency
Alpha channels

Changing the type of, 73
Defi nition of, 15
Revealing of, 21
Transparent areas created with, 146

Ambient light, 252, 258
Ambient option, 247
Amount (Range Selector), 193
Amplitude Modulation, 221
Anchor Point

Bounding box, 136
Defi nition of, 94, 192
Illustration, 129

Index
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Kinestasis creation by animating, 
95–97

Motion paths, 108
3D Transform, 246

Anchor setting, 82
Animate In, 188
Animate Intro, 188
Animating

Audio levels, 219–220
Camera properties, 265–273
Eff ects properties, 292–299
Graph Editor, 315–321
Light properties, 259–261
Masks, 137–142, 155–157
Position, 103–110
Rotation, 98–102
3D layers, 247–251

Animation
Compositions, 78–83
Expressions used to automate. 

See Expressions
Positional, 103–110
Presets, saving, 296–297
RAM preview for previewing, 

240–241
Simultaneous, 249
Squash and stretch, 313–314
Syncing, to composition markers, 

229–234
Text properties, 188–193
Workfl ow, 78

Animation menu, 19
Animation workspace, 36
Animator group, 188
Animators. see Text animators
Aperture, 265
Appearance, 41

Apple Final Cut Pro, 46, 325
Apple Motion Project, 414
Applications folder, 3
Apply Interpretation command, 73
Apply To option, Wiggler panel, 306
Apply To pull-down menu, 305
Aspect ratio, 417–420
ATSC, 12, 420
Audio

Composition markers added to
Creating, 222–225
Description of, 222
Naming, 226–227
Position, refi ning of, 228–229
Syncing animation to, 229–234

File formats, 210, 411–412
Previewing, 56, 211–214
Uncompressed formats, 210

Audio Amplitude layer, 235
Audio eff ects, 220–222
Audio fi les

Adding to Timeline, 211–214
Keyframes created from, 234–236
Looping, 71–72, 217–219
Metadata, 214–216

Audio Hardware, 41
Audio Interchange File Format, 412
Audio layers

Adding eff ects to, 220–222
Stacking order of, 218

Audio levels, animating, 219–220
Audio On/Off  switch, 90
Audio Output Mapping, 41
Audio panel, 403
Auto Bézier interpolation, 308
Auto-Orientation dialog box, 262
Auto-Orient property, 303–304
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Auto-Orient Towards Point of Interest, 
262

Auto-Save, 41, 43
Auto setting, 25
.avi, 412
AVI DV NTSC 48 kHz, 361

B
Background Color dialog box, 79–80
Background color setting, 82
Background color swatch, 79
Background switch, 302
Based On (Range Selector), 193, 198
Baseline, 184
Baseline shift, 180
Beveling text, 281–283
Bézier interpolation, 308, 320
Bézier vertices, 129, 145
Bitmap, 413
Bit rate, 416
Blending modes, 114–117
Blur

Motion. see Motion blur
Text properties, 192

Blur-in eff ect, 203–204
Blur Level, 265
Bounding box, 135–136
Bracket keys, 218
Bridge (Adobe), 195–196
Brushes panel, 404

C
Camera

Active, 245, 263–264
Animating properties of, 265–273
Creating, 262–279
Depth-of-fi eld eff ect, 274–276
Options, 265

Point of Interest property, 262, 265, 
271

Rack Focus, 276–279
Camera layers

Description of, 89
Point of Interest property, 262, 265

Camera Raw, 413
Camera Tracker, 3D, 324, 328–332
Caps Lock key, 294
Capture Speed At, 301
Capturing motion, Motion Sketch for, 

300–303
Cast Shadows option, 247, 252, 

254–255, 258, 283
Cathode ray tube television screens, 419
Character Off  set, 192
Character panel, 178–182, 404
Character Range, 192
Character Value, 192
Choke, 170
Chroma key

Creating, 163–173
Garbage matte, 165–167
Uses, 159

Cineon/DPX, 413
Classic 3D, 241
Codecs, 415–416
Collapse Transformations/Continuously 

Rasterize switch, 91
Collect Files command, 74
Collect Files dialog box, 74
Color label, 91
Color of light, 258
Color Range eff ect, 167–168
Color Range Keying eff ect, 173
Column

Contraction of, 92
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Expanding of, 92
Column displays, 50–51
Comp button, 31
Composition(s)

Creating, 46, 78–80
Cropping, 372–376
Defi nition of, 46
Double-clicking of, 86
Illustrator, importing of, 83–84
Importing, 68–70
Importing fi le as, 62
Layer sizes, 64
Nested, 34, 46, 119–122, 242
Photoshop, importing of, 83–84
Previewing, 86
Render Queue, 359–362
Settings, 81–83
Trimming, 372–376

Composition markers
Creating, 222–225
Description of, 222
Keyboard shortcuts, 401
Naming, 226–227
Position, refi ning of, 228–229
Syncing animation to, 229–234

Composition menu, 19
Composition panel, 21–25, 30, 35, 

38–39, 134, 139, 224, 327, 374
Composition - Retain Layer Sizes 

setting, 63–64
Composition setting, 64
Composition Settings dialog box, 

80–81, 103–104, 112, 164
Cone Angle, 258
Cone Feather, 258
Constrain Proportions option, 142

Continuous Bézier interpolation, 308, 
310

Convert Audio to Keyframes command, 
235

Convert vertex tool, 151–153
Copying lesson fi les to hard drive, 4–5
Copy & Paste keyboard shortcut, 272
Corner vertices, 129
Create a New Folder button, 51
Create Camera property, 3D Camera 

Tracker, 329
Create New Folder button, 64–65
Creating

Chroma key, 163–173
Compositions, 46, 78–80
Folders, 51–54
Garbage matte, 165–167
Lights, 252–261
Masks, 131–133, 145–154
Projects, 47
Scripts, 351
Subfolders, 51–54
Text, 176–179
Track mattes, 157–162

Creative Suite (Adobe), 213
Cropping compositions, 372–376
Current Time button, 59–60, 105
Current Time Indicator, 34
Curvaceous option, Ease and Wizz 

panel, 353
Custom text animators, 202–204
Custom Time Span dialog box, 363
Custom workspace, 39

D
Darken property, of masks, 130
Deceleration, 309–314
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Depth-of-fi eld eff ect, 274–276
Depth of Field option, 265
Deselecting

Folders, 51–52
Masks, 155

Desktop distribution graphics, 10
Dialog boxes

Auto-Orientation, 262
Background Color, 79–80
Collect Files, 74
Composition Settings, 80–81, 

103–104, 112, 164
Custom Time Span, 363
Fill Options, 115
Go to Time, 59
Import, 48–49, 64–65, 213
Import File, 65–66
Import Multiple Files, 83–84
Import Options, 83
Interpret Footage, 71–73, 217
Keyframe Interpolation, 310
Light Options, 252
Mask Color, 150
New Composition, 241
Open Project, 202–204, 266
Output Module Settings, 364, 

366–368, 370
Preferences, 41–42
QuickTime Options, 368
Replace Footage File, 70
Stroke Options, 115

Diff erence, 130
Diff use option, 247
Digital video

Basics of, 11–15
Dimensions, 11
Formats, 11–13

Frame rate, 11, 14–15
Pixel aspect ratio, 11, 81, 417–420

Dimensions option, Wiggler panel, 306
Directional handles, 109, 129, 151–153
Discreet RLA/RPF, 413
Display option, 41
Displays, video

Aspect ratio, 417–420
Interlacing, 419–420
Pixel aspect ratio, 11, 81, 417–420
Progressive display, 419–420

Docking panels, 36–37
Dragging

Layers, 117
Masks, 138

Drawing masks, 148–154
Drop shadow, 117–118
Drop zone, 37
Duration setting, 82
DV, 411
DV codec, 416
DV NTSC 48 kHz, 361
Dynamic Link (Adobe), 371

E
Ease and Wizz panel, 353
Ease and Wizz script, 352–355
Ease High (Range Selector), 193
Ease Low (Range Selector), 193
Easing option, Ease and Wizz panel, 353
Easy Easing

Acceleration created using, 309–314
Deceleration created using, 309–314
Keyframes, 311–312

Editing
Layer, 47
Text, 187
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Edit menu, 19
Edit Original command, 54
Eff ect Controls panel, 25–26, 167, 169, 

289–290, 293–296, 327–328, 391
Eff ect menu, 19
Eff ects

Animating properties of, 292–299
Applying to layers, 288–292
Glow, 294–295
Presets, applying and modifying, 

297–299
Shatter, 288–290, 297, 299
Strobing, 320–321

Eff ects & Presets panel, 36, 196, 
288–289, 296, 405

Eff ects switch, 92
Electric Image, 411
Encapsulated PostScript, 413
Evolution property, 347
Exchange (Adobe), 351
Expand/Collapse button, 242
Expand or Collapse Transfer Controls 

Pane, 159
Expand Transfer Controls Pane button, 

116, 121
Exporting a fi le, 370–372, 402
Expressions

Adding to properties, 341–343
Defi nition of, 340
Finding, 341
JavaScript language, 340
LoopOut(), 342–343
Random(), 344–346
Scripts versus, 350
Spelling errors in, 341
Time property with, 347–348
wiggle(), 348–350

ExtendScript (Adobe), 350
Extruding text, 281–283
Eyedropper tool, 168–169, 173

F
.f4v, 15
Fade-in, 124
Falloff , 258
Falloff  Distance, 258
Fast Previews button, 281, 285
Favorite eff ects, 201, 296. see also Presets
Feathering of masks, 142–145
Field Rendering, 362
File(s)

Collect Files command for 
consolidation of, 74

Exporting, 370–372
Illustrator, 62–65
Mac OS, 5
Missing, locating of, 70–71
Multiple, importing of, 60–62
Photoshop, 62–65
Renaming, 54

File formats
Audio, 210, 411–412
Description of, 15, 48, 415
Image sequences, 413
Still images, 413
Video, 11–13, 411–412

File menu, 19
File Path column, 50
Fill Options dialog box, 115
FireWire, 46
First line indent, 180
First Margin, 205
Flash Player (Adobe)

Flash video, 14–15
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Viewing video tutorials with, 7
Flash Professional (Adobe), 370
Flowchart panel, 26
.fl v, 15
Focus Distance, 265
Folders, creating, 51–54
Fonts, 3
Font size, 180
Font style, 180
Footage, video

Graphics integration into, 329
Keyboard shortcuts, 387
Previewing, 54–60

Footage panel, 27–29, 55–56
Force Alignment, 205
Formatting individual text characters, 

182–188
4:3 aspect ratio, 417–418
FPS, 58
Frame Blend switch, 92
Frame rate, 11, 14–15, 82
Frame Rate option, 240
Framing property, Warp Stabilizer, 325
Frantic motion, Wiggler panel for, 

306–307
Freeform masks, 145–154
Frequency option, Wiggler panel, 307
From Current Time, 241
Full-screen mode, 32
Full Screen option, 241

G
Garbage matte

Creating, 165–167
Refi ning, 170–173

General, 41
Geometric softness, 170

GIF, 411
Glow eff ect, 294–295
Glow Intensity property, 300
Go to Time dialog box, 59
Graph Editor, 34, 315–321, 394
Graphics

Television, 10
Video, 10

Gray Level Softness, 170
Greenscreen, 163–165
Grid and Guide Options button, 374
Grids & Guides, 41

H
H.264, 13–14
Handles

Adding, 373
Defi nition of, 57
Directional, 109, 129, 151–153

Hand tool, 148, 263
Hard drive

Copying lesson fi les to, 4–5
Copying video tutorials to, 6

Height, 81
Help menu, 19
Hexadecimal values, 296
Hex code, 296
Hide Shy Layers Composition switch, 

91, 223
Hiding panels, 35–36
High-defi nition television, 12, 417
Hold interpolation

Description of, 308
Strobing eff ect created using, 320–321

Horizontal scale, 180
Horizontal Type tool, 177
HTML5, 14
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I
Illustrator (Adobe)

Anchor point, 129
Compositions, importing of, 83–84
Description of, 15
File extensions, 413
Importing fi les, 62–65
Vector paths, 137

Image sequences
File formats, 413
Importing, 65–67

Import/importing
Compositions, 68–70
Description of, 41
Illustrator fi les, 62–65
Image sequences, 65–67
Keyboard shortcut for, 48, 60
Media fi les, 48–54
Photoshop fi les, 62–65

Import As drop-down menu, 63–64, 83
Import dialog box, 48–49, 64–65, 213
Import File command, 60
Import File dialog box, 65–66
Import Multiple Files, 60–62
Import Multiple Files dialog box, 83–84
Import Options dialog box, 83
Info panel, 327, 405
In Point, 147
Intensity, light, 258
Interlacing, 419–420
Internet devices, 10
Interpolation

Auto Bézier, 308
Bézier, 308, 320
Continuous Bézier, 308, 310
Hold

Description of, 308

Strobing eff ect created using, 
320–321

Keyframe, 308
Linear, 308–309
Spatial, 309–311

Interpret Footage dialog box, 71–73, 
217

Intersect property, of masks, 130
Intraframe compression, 416
Inverse Square Clamped, 258
iPod, 14

J
JavaScript language, 340, 350
Joint Photographic Experts Group, 413
Jumping between keyframes, 107

K
Karat symbol, 151
Ken Burns eff ect, 95
Kerning, 180, 183, 186
Keyboard shortcuts

Activating tools, 382
Animation presets, 388
Beginning of work area, 293, 373
Composition markers, 401
Compositions, 383
Composition Settings dialog box, 103
Copy & Paste, 272
Deselecting all layers, 114
Eff ects, 388
End of work area, 293, 373
Exporting, 402
Graph editor, 394
Import, 48, 60, 213
Interpret Footage dialog box, 72
Keyframes, 394
Layers, 99, 122–124, 388–393, 400
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Markers, 401
Masks, 398
Motion tracking, 401
Moving playhead, 200
Navigating Timeline, 383–384
New composition, 79
New light layer, 253
Opening a project, 266
Out Point, 147
Paint tools, 398–399
Panels, 380–381
Preferences, 380
Previews, 384–385
Rendering, 402
Rotation properties, 248
Save, 25, 29, 53, 60, 402
Save As, 49
Shape layers, 400
Text, 395–397
3D layers, 393
Timeline panel, 390–391
Types of, 379–402
Viewers, 380–381
Views, 385–387
Visible properties, 120
Windows, 380–381
Workspaces, 380–381

Keyframe(s)
Audio fi les used to create, 234–236
Ease and Wizz eff ect added to, 355
Easing added to, 311–312
Jumping between, 107
Keyboard shortcuts, 394
Smoother panel for modifying, 

304–306
Keyframe interpolation

Spatial, 309–311

Types of, 308
Keyframe Interpolation dialog box, 310
Keys option, Ease and Wizz panel, 353
Kinestasis, 95–97

L
Labels, 41
Label switch, 91
Last Margin, 205
Layer(s)

Adjustment, 89
Audio

Adding eff ects to, 220–222
Stacking order of, 218

Blending modes, 114–117
Camera, 89
Defi nition of, 19, 47
Deselecting, 114
Dragging of, 117
Eff ects to, applying, 288–292
Keyboard shortcuts, 388–393, 400
Light, 89
Modifying properties, 391–393
Names, changing, 93–94
New light, 253
Null Object, 89
Orientation, controlling, 303–304
Precomposing, 122–124
Properties of, 47, 94, 99, 354
Shape, 89, 400
Solid, 89
Stacking order, 92–93
Styles, 117–119
Switches, 90–92
Text, 89, 181
Time-reversing, 299–300
Trimming, 231
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Working with, 85–94
Layer bar mode, 34
Layer menu, 19
Layer panel, 30–31
Layer solids, 89
Layer/Source Name switch, 91
Leading, 180
Left margin, 180
Lesson fi les, 4–5
Letterboxing, 418
Levels of Undo, 42
Lighten property, of masks, 130
Light layers, 89
Light Options dialog box, 252
Lights

Animating properties of, 259–261
Creating, 252–261
Options, 258
Point of Interest property, 271
Using, 252–261

Light Transmission option, 247
Light Type, 258
Line Anchor, 192
Linear interpolation, 308–309
Line Spacing, 192
Lock Aspect Ratio, 368
Lock button, 242
Lock switch, 90
Looping

Audio fi le, 71–72, 217–219
Video fi le, 71–72

LoopOut() expression, 342–343
Luminance, 157

M
Macintosh OS

Starting in, 3

Unlocking fi les, 5
Magnifi cation ratio drop-down menu, 

29
Magnifi cation ratio pop-up menu, 67
Magnitude option, Wiggler panel, 307
Marketplace & Exchange (Adobe), 201
Mask(s)

Animating, 137–142, 155–157
Color, 150–151
Composition of, 128
Creating, 131–133, 145–154
Defi nition of, 128
Deselecting, 155
Dragging, 138
Drawing, 148–154
Feathering of, 142–145
Freeform, 145–154
Keyboard shortcuts, 398
Manipulating, 134–137
Multiple, 136
Position, animating, 137–142
Properties, 130
Selecting, 134–137
Shape, animating, 155–157
Shape tools for creating, 131–133
Stacking order, 129
Vertices, 128–129, 138, 155–157
Working with, 128–133

Mask Color dialog box, 150
Mask Expansion property, 130
Mask Feather property, 130, 142–145, 

157
Mask Interpolation panel, 406
Mask Opacity property, 130
Mask Path property, 128, 130, 137, 140, 

155, 167
Material eXchange Format, 411
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Material Options properties group, 241, 
282–283

Matte(s)
Garbage, 165–167
Refi ning, 170–173
Traveling, 157–162

Matte Choker, 170–171
Maya camera data, 413
Maya IFF, 413
Media & Disk Cache, 41
Media fi les, importing, 48–54
Media management, 46
Memory and Multiprocessing, 41
Menu(s)

Animation, 19
Composition, 19
Edit, 19
Eff ect, 19
File, 19
Help, 19
Layer, 19
Presets, 81
View, 19
Window, 19
Working with, 18

Metadata
Audio fi le, 214–216
Defi nition of, 214–215

Metadata panel, 406
Metal option, 247
Method property, Warp Stabilizer, 325
Microsoft Zune, 14
Mini-Flowchart view, 235
Missing fi les, locating of, 70–71
Mobile devices, 10, 13–14
Mode (Range Selector), 193
Modulation Depth, 221

Modulation Rate, 221
Modulation Type, 221
Motion Blur

Adjusting settings, 112–113
Defi nition, 83, 110
Using of, 110–113

Motion Blur Comp button, 111
Motion Blur switch, 92, 111, 314
Motion graphics

Defi ning, 10
Types of, 10

Motion path
Auto-Orient setting changed to 

follow, 303
Changing the shape of, 310
Description of, 108–110

MotionScript.com, 341
Motion Sketch panel, 300–303, 407
Motion tracking, keyboard shortcuts, 

401
.mov, 15, 411–412
MP3, 412
MPEG-1, 411
MPEG-2, 411
MPEG-4, 14, 411
Mute Audio, 240

N
Names

Composition markers, 226–227
Layer, 93–94

National Television Systems 
Committee. see NTSC

Nested compositions, 34, 46, 119–122, 
242

New Composition button, 131, 146
New Composition dialog box, 241
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New light layer, 253
Noise Type option, Wiggler panel, 306
None property, of masks, 130
NTSC, 13, 47, 418–420
Null layers, 333
Null Object layers, 89
Number switch, 91

O
Off set (Range Selector), 193
OGG Theora, 14
1080i, 13
1080p, 13
Opacity, layer

Description of, 94, 344
Fade-in created by animating, 124
3D layers, 248

OpenEXR, 413
Opening a project, 18, 46, 266
Open Project dialog box, 202–204, 266
Orientation property, 246
Orthographic view, 245, 249, 277
Outer glow, 117
Out Point, 147, 155
Output, 41
Output Module Settings dialog box, 

364, 366–368, 370
Outputting

Exporting a project fi le, 370–372
Rendering, 358–359
Supported formats, 358, 376

P
Paint panel, 407
Paint tools, keyboard shortcuts, 398–399
PAL, 13
Pan and Zoom, 95
Panel(s)

Align, 36–37, 403
Audio, 403
Brushes, 404
Character, 178–182, 404
Composition, 21–25, 30, 34, 38–39, 

134, 139, 224, 327, 374
Description of, 20
Docking, 36–37
Drop zones, 37
Ease and Wizz, 353
Eff ect Controls, 26, 167, 169, 289–290, 

293–296, 327–328, 391
Eff ects & Presets, 36, 196, 288–289, 

296, 405
Flowchart, 26
Footage, 27–29, 55–56
Hiding, 35–36
Info, 327, 405
Keyboard shortcuts, 380–381
Layer, 30–31
Mask Interpolation, 406
Metadata, 406
Motion Sketch, 300–303, 407
Paint, 407
Paragraph, 178–182, 404
Preview, 408
Primary, 21–35
Project. see Project panel
Render Queue, 33, 360
Resizing, 38–39
Smoother, 304–306, 409
Timeline, 22, 26, 30, 34–35, 85–86, 

94, 195, 390–391
Tools, 408
Tracker, 409
Undocking, 36–37
Uses, 21

AECS6_06Pass.indb   432AECS6_06Pass.indb   432 5/18/12   1:07 PM5/18/12   1:07 PM



433Index

Viewing, 35–36
Wiggler, 306–307, 410

Paragraph alignment, 180
Paragraph panel, 178–182, 404
Paragraph text, 176, 179
Parallel light, 252
Parentheses, 25
Parenting

Applications of, 101–102
Defi nition of, 92

Path
Creating Text on, 205–206
Reverse, 205

Path Options property group, 205–206
Pen tool, 145, 148–154
Perpendicular to Path, 205
Perspective property, Warp Stabilizer, 

325
Per vertex mask feathering, 143–145
Phase alternating line, 13
Photoshop CS6 (Adobe)

Anchor point, 129
Compositions, importing of, 83–84
Description of, 15
File extensions, 62, 411, 413
Importing fi les, 62–65
Track mattes created from animated 

fi les, 159–162
Vanishing Point Data, 414

PICT, 413
Pillarboxing, 418
Pixel, 11
Pixel aspect ratio, 11, 81, 417–420
Playhead

Defi nition, 34
Moving, 105, 107, 138, 156–157, 200
Position, 298

Scrubbing the, 55, 158, 222, 228, 273
Point light, 252, 258
Point of Interest property, 262, 265, 271
Point text, 176
Portable Network Graphics, 413
Position

Animating of, 103–110
Text, 192
3D Transform, 246

Position, layer, 94
Position, Scale, and Rotation property, 

Warp Stabilizer, 325
Positional animation, 103–110
Position property, Warp Stabilizer, 325
Precomposing layers, 122–124
Preferences

Keyboard shortcuts, 380
Resetting of, 3
Setting, 41–43

Preferences dialog box, 41–42
Premiere (Adobe), 46
Premiere Pro (Adobe), 325, 358, 371, 

414
Premultiplied - Matted With Color 

option, 73
Prerequisites, 1–2
Presentation graphics, 10
Preserve frame rate when nested or in 

render queue setting, 83
Preserve resolution when nested setting, 

83
Presets

Animation, 296–297, 388
Defi nition, 296
Description, 79
Eff ects, applying and modifying, 

297–299
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Text animators
Applying, 195–197
Browsing, 195–197
Modifying, 198–201
Saving as, 194
Sharing of, 201
Working with, 195–201

Presets menu, 81
Preset workspaces, 35
Preview, 41

Duration of, 70
Footage panel, 27–29
Keyboard shortcuts, 384–385
Quarter resolution, 24
RAM, 56, 70, 211, 214, 240–241, 

285, 303, 312, 314–315, 
319–320, 326, 328, 336, 354

Timeline, 408
Previewing

Audio, 56, 211–214
Compositions, 86
Footage, 54–60
Spacebar for, 67
Stills, 55
Video, 55

Preview panel, 408
Progressive display, 419–420
Project(s)

Anatomy of, 47
Creating, 47
Formats, 414
New, 47
Older versions, 20
Opening, 18, 20, 46
Schematic diagram of, 47

Project fi le, 46
Project panel

Description of, 31–33, 49–50
Folders, 51–54
Renaming fi les, 54
Tilde key for changing size of, 33, 

49–50, 54
Proportional grid, 134, 148, 374
.psd, 62, 411
PSP, 14

Q
Quality switch, 91
Quarter resolution, 24
QuickTime, 13, 15, 361, 412, 415
QuickTime Options dialog box, 368

R
Rack Focus, 276–279
Radius, 258
RAM, 42
RAM preview, 56, 70, 211, 214, 

240–241, 285, 303, 312, 314–315, 
319–320, 326, 328, 336, 354

RAM Preview button, 56
Random() expression, 344–346
Randomize Order (Range Selector), 

193
Random Seed (Range Selector), 193
Range Selector properties, 193
Ray-traced 3D

Beveling text layers, 281–283
Creating composition, 280–281
Description of, 241
Extruding text layers, 281–283
Refl ections, creating, 284

Rectangle tool, 116, 136, 166
RED, 412
References, 31
Refi ning, matte, 170–173
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Refl ection Intensity option, 283
Refl ections, 284
Region of Interest button, 374–375
Remember Interpretation command, 73
Remove Marker option, 225
Renaming fi les, 54
Rendering

Classic 3D, 241
Defi nition, 70, 358
Individual frame, 376–377
Keyboard shortcuts, 402
Ray-traced 3D, 241
Time requirements, 361

Rendering plug-in setting, 82
Render items

Defi nition of, 359
Duplicating, 365–369

Render queue
Compositions added to, 359–362
Duplicating jobs in, 365–369
Options, 359
Settings, 362–364

Render Queue panel, 33, 359, 363
Render templates, 369–370
Render Track Points property, 3D 

Camera Tracker, 328
Repetition, parenting for, 101–102
Replace Footage File dialog box, 70
Re-rendering, 365
Resetting

Preferences, 3
Workspace, 40, 210, 304

Resizing
Columns, 50–51
Panels, 38–39

Resolution
Description of, 14–15

Quarter, 24
RAM preview, 240
Setting, 82

Resolution/Down Sample Factor Popup 
button, 24–25, 294

Resource Central, 216
Resources, 8
Result property, Warp Stabilizer, 324
Reveal

Alpha channels, 21
Columns, 50

Reverse Path, 205
RGBA mode, 15, 405
RGB mode, 15, 29
Right margin, 180
Rotation

Animating, 98–102
Keyboard shortcuts for, 248
Layer, 94, 354
Text, 192

Rotation tool, 269–270
Rulers composition, 21

S
Save All command, 370
Save As function, 49
Saving

Custom workspace, 39
Keyboard shortcuts, 25, 29, 53, 60, 

402
Scale, layer

Description of, 94
Fade-in created by animating, 124

Scale (3D Transform), 246
Scale (Text), 192
Script Editor, 351
Scripts
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Applying, 351–355
Capitalization errors, 350
Creating, 351
Defi nition of, 350
Expressions versus, 350
Finding, 351
Installing, 350–351
Running, 350–351
Spelling errors, 350
Using, 351–355

Scrubbing the playhead, 55, 158, 222, 
228, 273

Scrubbing through audio on Timeline, 
211

Selection tool, 135, 138–139, 141, 147, 
181–182, 260, 263

Select View Layout drop-down menu, 
245, 266

Setting preferences, 41–43
720p, 12
Shadow Darkness, 258
Shadow Diff usion, 258
Shape Layers, 89, 400
Shape (Range Selector), 193
Shape tools, 131–133
Shatter eff ect, 288–290, 297, 299
Shininess option, 247
Shot Type property, 3D Camera 

Tracker, 328
Show Channel and Color Management 

Settings button, 23, 29
Show Track Points property, 3D 

Camera Tracker, 328
Shutter Angle, 112
Shutter Phase, 112
Shy switch, 91, 224
Silicon Graphics Image, 413

Silverlight, 13
16:9 aspect ratio, 417
Skew (Text), 192
Skip, 240
Smoother panel, 304–306, 409
Smoothing, 301
Smoothness property, Warp Stabilizer, 

324
Smoothness (Range Selector), 193
Software versions, 20
Solid layers, 89, 333
Solo switch, 90
Soundbooth (Adobe), 213
Source text, 179
Space after paragraph, 180
Spacebar, 67
Space before paragraph, 180
Spatial compression, 416
Spatial interpolation, 309–311
Spectral Background composition, 

68–69
Specular Intensity option, 247, 283
Specular option, 247
Specular Shininess option, 247
Spelling, 341
Spill Suppressor eff ect, 173
Spot light, 252, 258
Squash and stretch, 313–314
Stabilization and tracking, video

Overview of, 324
3D Camera Tracker, 324, 328–332
Warp Stabilizer, 324–328

Stabilize, Crop, Auto-scale property, 
Warp Stabilizer, 325

Stabilize, Crop property, Warp 
Stabilizer, 325
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Stabilize, Synthesize Edges property, 
Warp Stabilizer, 325

Stabilize Only property, Warp 
Stabilizer, 325

Stacking order
Audio layers, 218
Layers, 92–93
Masks, 129

Standard-defi nition television, 13, 417
Start and End (Range Selector), 193
Starting, 3
Start Timecode setting, 82
Still images

File formats, 413
Previewing, 55

Strobing eff ect, 320–321
Stroke Options dialog box, 115
Stroke width, 180
Subfolders, 51–54
Subspace Warp property, Warp 

Stabilizer, 325
Subtract property, of masks, 130
Switches, layer, 90–92
Syncing animation to composition 

markers, 229–234
System requirements, 1–2

T
Tab key, 226
Tagged Image File Format, 15, 413
Television

High-defi nition, 12, 417
Standard-defi nition, 13, 417

Television graphics, 10
Templates

Render, 369–370
Sharing, 370

Temporal compression, 416
Text

Character panel, 178–182
Creating, 176–179
Editing, 187
Formatting individual characters, 

182–188
Keyboard shortcuts, 395–397
Margins, 177
Paragraph, 176, 179
Paragraph panel, 178–182
On a path, 205–206
Point, 176
Properties

Animating, 188–193
Global, setting, 179–188
List of, 192

Selecting, 182–183
Source, 179

Text animators
Blur-in eff ect, 203–204
Custom, 202–204
Description of, 89
Presets

Applying, 195–197
Browsing, 195–197
Modifying, 198–201
Saving as, 194
Sharing of, 201
Working with, 195–201

Types of, 188, 192
Typewriter eff ect, 202–203

Text layer
Animating properties of, 188
Beveling, 281–283
Description of, 89
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Double-clicking to select text, 
182–183

Extruding, 281–283
3D, 333

.tga, 15
3D Camera Tracker, 324, 328–332
3D layers

Animating, 247–251
Attaching to track points, 332–336
Creating, 242–243
Keyboard shortcuts, 393
Material Options, 246–247
Multiple viewports for, 243–246
Ray-traced composition, 280–285
Text layers, 333
Working with, 241

3D Layer switch, 92
3D renderer, 241
3D Transform, 246
.tiff , 15
Tilde key, 33, 49–50, 54, 217, 221, 346
Timecode, 58, 82, 363
Timeline

Audio fi les added to, 211–214
Composition markers added to, 224
Keyboard shortcuts for navigating, 

383–384
Magnifi cation of display, 226
Navigating, 383–384
Previews, 408
Scrubbing through audio on, 211

Timeline panel, 22, 26, 30, 34–35, 
85–86, 94, 195, 390–391

Time Marker, 28
Time property with expressions, 

347–348
Time-reversing, 299–300

Time Ruler, 28, 34
Time Span, 362
Time-Vary Stopwatch, 97, 99–100, 118, 

155, 190, 200, 202, 206, 247, 
259–260, 268–269, 296, 300, 313

Title-Safe margin, 177
Tolerance property, 305
Tools

Activating, 382
Convert vertex, 151–153
Eyedropper, 168–169, 173
Hand, 148, 263
Horizontal Type, 177
Pen, 145, 148–154
Rectangle, 116, 136, 166
Rotation, 269–270
Selection, 135, 138–139, 141, 147, 

181–182, 260, 263
Type, 182–184

Tools panel, 408
Tracker panel, 409
Tracking, 180, 183

Motion, keyboard shortcuts, 401
Overview of, 324
3D Camera Tracker, 324, 328–332
Warp Stabilizer, 324–328

Track mattes, 157–162
Track points, attaching 3D layers to, 

332–336
Transfer Controls pane, 158–159
Transformation point, 94
Transparency. see also Alpha

Description of, 15
Masks. see Masks
Opacity, 94

Trimming
Compositions, 372–376
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Layers, 231
Video clips, 57–60

Truevision Advanced Raster Graphics 
Adapter, 15

Tsume, 180
Typeface, 180, 185
Type option, Ease and Wizz panel, 353
Type tool, 182–184
Typewriter eff ect, 202–203

U
Uncompressed audio formats, 210
Undo, Levels of, 42
Undocked Panels workspace, 36
Undocking panels, 36–37
Units (Range Selector), 193
USB 2.0, 46

V
Vector paths (Adobe Illustrator), 137
Vertical scale, 180
Vertices, masks, 128–129
Video

Digital. see Digital video
Formats, 411, 413
Previewing, 55

Video clips
trimming, 57–60
Warp Stabilizer eff ect added to, 

325–328
Video displays

Aspect ratio, 417–420
Interlacing, 419–420
Pixel aspect ratio, 11, 81, 417–420
Progressive display, 419–420

Video fi les, looping of, 71–72
Video footage

Graphics integration into, 329

Keyboard shortcuts, 387
Previewing, 54–60

Video graphics, 10
Video On/Off  switch, 90
Video Preview, 41
Video stabilization and tracking

Overview of, 324
3D Camera Tracker, 324, 328–332
Warp Stabilizer, 324–328

Video tutorials, 6–7
Viewing Panel, 35–36
View menu, 19
Visibility switch, 330
Volume Unit meter, 403

W
Warp Stabilizer, 324–328
Web video, 13
Widescreen

NTSC, 13
PAL, 13

Width, 81
wiggle() expression, 348–350
Wiggler panel, 306–307, 410
Windowboxing, 418
Window menu, 19
Windows Media File, 412
Windows Media Video, 13–14
Windows operating system, 2–3
Windows Waveform, 213, 412
Wireframe switch, 302
Workspace

Animation, 36
Custom, saving of, 39
Defi nition of, 35
Illustration of, 20
Preset, 35
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Resetting, 40, 210, 304
Understanding of, 35
Undocked Panels, 36
Viewing and hiding panels on, 35–36

X
XDCAM EX, 412
XDCAM HD, 412
XFL fi le, 370
X Rotation, 192, 246, 271

Y
Y Rotation, 192, 246, 271

Z
Z-axis, 274
Zoom, 25, 265
Zoom In button, 226
Zoom Out button, 226
Z position, 268
Z Rotation, 192, 246, 271
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John Wiley & Sons, Inc. “WILEY”. By opening the accompanying software packet(s), you acknowledge 
that you have read and accept the following terms and conditions. If you do not agree and do not want to 
be bound by such terms and conditions, promptly return the Book and the unopened software packet(s) 
to the place you obtained them for a full refund.

 1. License Grant. WILEY grants to you (either an individual or entity) a nonexclusive license to 
use one copy of the enclosed software program(s) (collectively, the “Software”) solely for your own 
personal or business purposes on a single computer (whether a standard computer or a workstation 
component of a multi-user network). The Software is in use on a computer when it is loaded into 
temporary memory (RAM) or installed into permanent memory (hard disk, CD-ROM, or other 
storage device). WILEY reserves all rights not expressly granted herein.

 2. Ownership. WILEY is the owner of all right, title, and interest, including copyright, in and to 
the compilation of the Software recorded on the physical packet included with this Book “Software 
Media”. Copyright to the individual programs recorded on the Software Media is owned by the 
author or other authorized copyright owner of each program. Ownership of the Software and all 
proprietary rights relating thereto remain with WILEY and its licensers.

 3. Restrictions on Use and Transfer. 

 (a) You may only (i) make one copy of the Software for backup or archival purposes, or (ii) 
transfer the Software to a single hard disk, provided that you keep the original for backup 
or archival purposes. You may not (i) rent or lease the Software, (ii) copy or reproduce the 
Software through a LAN or other network system or through any computer subscriber 
system or bulletin-board system, or (iii) modify, adapt, or create derivative works based on 
the Software.

 (b) You may not reverse engineer, decompile, or disassemble the Software. You may transfer the 
Software and user documentation on a permanent basis, provided that the transferee agrees to 
accept the terms and conditions of this Agreement and you retain no copies. If the Software is 
an update or has been updated, any transfer must include the most recent update and all prior 
versions.

 4. Restrictions on Use of Individual Programs. You must follow the individual requirements 
and restrictions detailed for each individual program in the “About the CD” appendix of this Book 
or on the Software Media. These limitations are also contained in the individual license agreements 
recorded on the Software Media. These limitations may include a requirement that after using 
the program for a specifi ed period of time, the user must pay a registration fee or discontinue 
use. By opening the Software packet(s), you agree to abide by the licenses and restrictions for 
these individual programs that are detailed in the “About the CD” appendix and/or on the 
Software Media. None of the material on this Software Media or listed in this Book may ever be 
redistributed, in original or modifi ed form, for commercial purposes.
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 5. Limited Warranty.

 (a) WILEY warrants that the Software and Software Media are free from defects in materials and 
workmanship under normal use for a period of sixty (60) days from the date of purchase of 
this Book. If WILEY receives notifi cation within the warranty period of defects in materials 
or workmanship, WILEY will replace the defective Software Media. 

 (b) WILEY AND THE AUTHOR(S) OF THE BOOK DISCLAIM ALL OTHER 
WARRANTIES, EXPRESS OR IMPLIED, INCLUDING WITHOUT LIMITATION 
IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR 
A PARTICULAR PURPOSE, WITH RESPECT TO THE SOFTWARE, THE 
PROGRAMS, THE SOURCE CODE CONTAINED THEREIN, AND/OR THE 
TECHNIQUES DESCRIBED IN THIS BOOK. WILEY DOES NOT WARRANT 
THAT THE FUNCTIONS CONTAINED IN THE SOFTWARE WILL MEET YOUR 
REQUIREMENTS OR THAT THE OPERATION OF THE SOFTWARE WILL BE 
ERROR FREE. 

 (c) This limited warranty gives you specifi c legal rights, and you may have other rights that vary 
from jurisdiction to jurisdiction.

 6. Remedies. 

 (a) WILEY’s entire liability and your exclusive remedy for defects in materials and workmanship 
shall be limited to replacement of the Software Media, which may be returned to WILEY 
with a copy of your receipt at the following address: Software Media Fulfi llment Department, 
Attn.: Adobe After Eff ects CS6 Digital Classroom, John Wiley & Sons, Inc., 10475 Crosspoint 
Blvd., Indianapolis, IN 46256, or call 1-800-762-2974. Please allow four to six weeks for 
delivery. This Limited Warranty is void if failure of the Software Media has resulted from 
accident, abuse, or misapplication. Any replacement Software Media will be warranted for 
the remainder of the original warranty period or thirty (30) days, whichever is longer. 

 (b) In no event shall WILEY or the author be liable for any damages whatsoever (including 
without limitation damages for loss of business profi ts, business interruption, loss of business 
information, or any other pecuniary loss) arising from the use of or inability to use the Book 
or the Software, even if WILEY has been advised of the possibility of such damages. 

 (c) Because some jurisdictions do not allow the exclusion or limitation of liability for 
consequential or incidental damages, the above limitation or exclusion may not apply to you.

 7. U.S. Government Restricted Rights. Use, duplication, or disclosure of the Software for or on 
behalf of the United States of America, its agencies and/or instrumentalities “U.S. Government” is 
subject to restrictions as stated in paragraph (c)(1)(ii) of the Rights in Technical Data and Computer 
Software clause of DFARS 252.227-7013, or subparagraphs (c) (1) and (2) of the Commercial 
Computer Software - Restricted Rights clause at FAR 52.227-19, and in similar clauses in the 
NASA FAR supplement, as applicable.

 8. General. This Agreement constitutes the entire understanding of the parties and revokes and 
supersedes all prior agreements, oral or written, between them and may not be modifi ed or amended 
except in a writing signed by both parties hereto that specifi cally refers to this Agreement. This 
Agreement shall take precedence over any other documents that may be in confl ict herewith. If any 
one or more provisions contained in this Agreement are held by any court or tribunal to be invalid, 
illegal, or otherwise unenforceable, each and every other provision shall remain in full force and 
eff ect.
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